Ubuntu

GLIb-WARNING **: getpwid_r(): failed due to unknown user id

Reported by Sergio Zanchetta on 2010-09-28
168
This bug affects 35 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
plymouth (Ubuntu)
Undecided
Unassigned
Lucid
Medium
Unassigned
Maverick
Medium
Unassigned

Bug Description

Binary package hint: plymouth

Maverick pre-RC ISO testing.
I got this error message on screen just before Desktop appears on the screen (after selecting Try Ubuntu in Ubiquity)

I remember I see it very often in Lucid installed system too.

Annoying because boot is not so smooth with this.

SRU justification:
This message is consistently emitted by plymouth whenever plymouth is included in the initramfs (either because it's needed by some other initramfs script such as cryptsetup or casper, or because the user has themself configured it to be included to provide a prettier boot experience. While plymouth normally hides the message, it is sometimes exposed either because something has switched VT7 into text mode (e.g., during suspend/resume) or because of a bug in plymouth itself. The former is aesthetic, but the latter results in many bugs filed about the message which is *not* related to their problems, making it difficult to triage plymouth bug reports.

This can be addressed for the natty release by forward-copying the maverick-proposed SRU to natty.

TEST CASE:
1) run 'echo FRAMEBUFFER=y > /etc/initramfs-tools/conf.d/plymouth' as root
2) run 'update-initramfs -u' to regenerate the initramfs, with plymouth added
3) reboot with the splash screen enabled
4) press escape as soon as the splash screen appears; confirm that you see the GLib warning
5) install the plymouth package from -proposed
6) reboot repeatedly, and use the same technique as in step 4, to confirm that the warning message no longer appears

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: plymouth 0.8.2-2ubuntu5
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
Date: Tue Sep 28 15:25:59 2010
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
LiveMediaBuild: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate i386 (20100928)
MachineType: Acer Extensa 5220
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/casper/vmlinuz noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
ProcEnviron:
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
SourcePackage: plymouth
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
dmi.bios.date: 04/15/2008
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: V1.34
dmi.board.name: Columbia
dmi.board.vendor: Acer
dmi.board.version: Rev
dmi.chassis.asset.tag: None
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrV1.34:bd04/15/2008:svnAcer:pnExtensa5220:pvr0100:rvnAcer:rnColumbia:rvrRev:cvnAcer:ct10:cvrN/A:
dmi.product.name: Extensa 5220
dmi.product.version: 0100
dmi.sys.vendor: Acer

Sergio Zanchetta (primes2h) wrote :
tags: added: iso-testing
Sergio Zanchetta (primes2h) wrote :

Still present.
It appears even in Maverick Final.
Boot is not so smooth with this error.

Sergio Zanchetta (primes2h) wrote :

Confirmed with UNE on another laptop.

Scott Kitterman (kitterman) wrote :

Not something for release notes though. The warning is harmless and there's nothing the user needs to do.

Changed in ubuntu-release-notes:
status: New → Won't Fix
Steve Langasek (vorlon) on 2010-10-29
Changed in plymouth (Ubuntu):
assignee: nobody → Evan Broder (broder)
Changed in plymouth (Ubuntu Maverick):
assignee: nobody → Evan Broder (broder)
Evan Broder (broder) wrote :

This warning seems to be caused by the label control for plymouth, which uses pango to render text.

We should be able to suppress the warning simply by generating a bogus /etc/passwd file in the initrd with an entry for root, such that glib finds a valid user entry for uid 0.

Patch to do this attached; it's currently building in my PPA (https://launchpad.net/~broder/+archive/ubuntu-tests), and should be tested to confirm it eliminates the problem.

Evan Broder (broder) wrote :

Apparently an /etc/passwd file isn't sufficient - you actually need a nsswitch.conf file and libnss_files for getpwid_r to return something useful.

Updated patch attached. I've tested it locally and confirmed that it suppresses the GLib warning, and the new version has been pushed to my PPA (https://launchpad.net/~broder/+archive/ubuntu-tests) for test building

Changed in plymouth (Ubuntu):
status: New → Confirmed
assignee: Evan Broder (broder) → nobody
Evan Broder (broder) wrote :

The patch in comment #6 applies directly to Lucid and Maverick as well (the initramfs hook hasn't changed in a while); just the changelog needs to be updated with a correct version number.

Test builds are running in my PPA now.

Evan Broder (broder) wrote :

Here's the slightly modified patch for a Maverick SRU

Evan Broder (broder) wrote :

And for a Lucid SRU

Evan Broder (broder) on 2010-10-30
Changed in plymouth (Ubuntu Maverick):
assignee: Evan Broder (broder) → nobody
Steve Langasek (vorlon) on 2010-10-31
Changed in plymouth (Ubuntu Lucid):
status: New → In Progress
Changed in plymouth (Ubuntu Maverick):
status: New → In Progress
Changed in plymouth (Ubuntu Lucid):
importance: Undecided → Medium
Changed in plymouth (Ubuntu Maverick):
importance: Undecided → Medium
Steve Langasek (vorlon) on 2010-10-31
Changed in plymouth (Ubuntu):
status: Confirmed → In Progress
Steve Langasek (vorlon) on 2010-10-31
description: updated
Evan Broder (broder) on 2010-10-31
description: updated
Martin Pitt (pitti) wrote :

The updated lucid SRU doesn't match the debdiff here. It removes debian/patches/debian-changes without giving a rationale, and I think that's not intended?

On Fri, Nov 05, 2010 at 01:22:49PM -0000, Martin Pitt wrote:
> The updated lucid SRU doesn't match the debdiff here. It removes
> debian/patches/debian-changes without giving a rationale, and I think
> that's not intended?

debian/patches/debian-changes wasn't removed, it was just reordered.
Unfortunately 3.0 (quilt) packages aren't the easiest to compare with
debdiff; a diff of the unpacked sources will show that there are no changes
aside from the initramfs hook.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Accepted plymouth into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in plymouth (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed
Evan Broder (broder) wrote :

I've rebooted a number of times and can no longer reproduce the GLib warning with the plymouth in lucid-proposed.

tags: added: verification-done
removed: verification-needed
Martin Pitt (pitti) wrote :

Accepted plymouth into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in plymouth (Ubuntu Maverick):
status: In Progress → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Evan Broder (broder) wrote :

I can no longer reproduce the GLib warning with the package in maverick-proposed, either.

tags: added: verification-done
removed: verification-needed

I was experiencing this error message appearing after the plymouth boot screen and before the login screen. Using 10.10 (maverick).

I enabled maverick-proposed repository by System/Administration/Update Manager/Setting.../Updates/Proposed updates (maverick-proposed), then using Update Manager (had to select 6 updates and deselect all others). On reboot the error message has disappeared - success! Thanks.

Sergei Vorobyov (svorobyov) wrote :

I'd be damned, but this does not explain anything

> Many posters here IMO have a different booting problem. The error
> message however relates to a specific bug with plymouth which is fixed
> here: https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/649917.
> The fix code is now available in repository for maverick-proposed (and I
> guess lucid-proposed). However this only removes this error message,
> which is not itself important. If you are experiencing crashes it is
> almost certainly caused by something else.

I do not care about no error messages, I simply cannot bloody log in.

Yes but I'll be damned if your problem with log in has anything to do with this message: 'GLIb-WARNING **: getpwid_r(): failed due to unknown user id' - which is what this bug 649917 is about. This is a trivial error message which I have seen for months and it has never prevented me from logging in. It is now fixed (the error message, not your problem) in maverick-proposed.

Your problem is caused by something else, I think.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plymouth - 0.8.2-2ubuntu2.1

---------------
plymouth (0.8.2-2ubuntu2.1) lucid-proposed; urgency=low

  * Generate a dummy NSS stack in the initrd to suppress a glib warning
    generated by the label control (LP: #649917).
 -- Evan Broder <email address hidden> Thu, 28 Oct 2010 21:34:45 -0700

Changed in plymouth (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plymouth - 0.8.2-2ubuntu5.1

---------------
plymouth (0.8.2-2ubuntu5.1) maverick-proposed; urgency=low

  * Generate a dummy NSS stack in the initrd to suppress a glib warning
    generated by the label control (LP: #649917).
 -- Evan Broder <email address hidden> Fri, 29 Oct 2010 06:39:20 -0700

Changed in plymouth (Ubuntu Maverick):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to natty as well.

Changed in plymouth (Ubuntu):
status: In Progress → Fix Released
Linux Lover (obake) wrote :

Another bug solved. Hurray!

José Lou Chang wrote on 2010-11-20: #22

Another bug solved. Hurray!

I think not, the problem persisted because I download the ISO of Ubuntu 10.10 and gives me the error when wanting to install on a Toshiba NB200 netbook, intentanto install from a USB.

Evan Broder (broder) wrote :

Jorge: We don't re-build non-LTS CDs after they're released, so the 10.10 CD will always have this bug. However, if you upgrade the system after installing, the bug should no longer be there.

For 10.04, we do "point releases" every 6 months that incorporate updates into the CD, so the 10.04.2 CDs will incorporate this fix.

glkpspam (glkpspam) wrote :

Evan: How are we supposed to upgrade the system after installing when we can't install? I get the error when I try to load the CD on a Dell Latitude D810, and my system becomes nonresponsive (caps and scroll lock lights flash, but the keyboard is otherwise dead). This doesn't seem like a minor issue that should be ignored; the ISO is fatally flawed for many users.

glkpspam:
the fixed issue is *just* the warning message which did not cause any actual
problems to begin with. what you just described is a kernel panic, meaning
your hardware is either not compatible or just broken enough to make the
kernel very very unhappy

Martin Spacek (mspacek) wrote :

I had this problem on a seemingly standard setup, Asus P5K motherboard with quad core Core2 cpu and nvidia 7300. Here's my experience, in case it helps someone:

Booting from the maverick amd64 livecd off of a usb stick left me at the ubuntu logo with never-ending progress dots. Hitting escape revealed the "getpwid_r(): failed due to unknown user id" message, which was masking the real problem. Rebooting and choosing F6 during livecd bootup, and deleting the "quiet-splash" boot option revealed the true problem: "Buffer I/O Error on device, fd0 Logical Block 0". See http://ubuntuforums.org/showthread.php?t=1080102. My floppy controller was enabled in the BIOS, even though there's no floppy drive installed. This gave the kernel a fit. Disabling the controller in the BIOS allowed me to finally boot from the livecd. This has been reported in various places as a bug, but most of these are set as duplicates or fixed. Are any devs aware that it's still a problem?

https://bugzilla.kernel.org/show_bug.cgi?id=13486
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/236144
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/409094
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/384579

Note that the fix (at least on maverick) breaks dropbear's initramfs-hook, because it sets an invalid shell, namely /bin/bash (which isn't present in the initramfs). It should set /bin/sh instead. Also see https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/733268

Changed in plymouth (Ubuntu Lucid):
assignee: nobody → ironbutterfly (rainbownthedark)
Steve Langasek (vorlon) on 2011-03-21
Changed in plymouth (Ubuntu Lucid):
assignee: ironbutterfly (rainbownthedark) → nobody
Lorenzo Woodley (zath13) wrote :

hi I'im just an average pc user with little code knowledge im attempted to swap out Xp business professorial for ubuntu 10.10 and when i rebooted the computer the error code process 252)Glib WARNING XX: getpwuid_r()failed due to unknown user id(0) showed up can this fix be explained in a simpler way or can someone direct me to a downloadable fix please

if one an be found a.s.a.p email me at <email address hidden>

brabax (brabax2) wrote :

I have the fixed plymouth version installed, but it don't fixes the bug for me.

dpkg -s plymouth
> Version: 0.8.2-2ubuntu5.1

I have the same error message during boot-process (reported in duplicate of this bug - #620918). After the error message the system stops to work. The system comes up, if I boot without an external HDMI monitor connected. Besides this I'm able to boot with the external monitor if I do the following:

- Press "E" in GRUB startup page
- Delete "quiet splash" and add option "noplymouth" at the end of the line
- Boot with that option, pressing "Strg+X"

@Lorenzo: Please test the steps above. If you can boot into the system perform a complete software update. You should then have the fixed plymouth package 0.8.2-2ubuntu5.1. Are you able to boot without the steps above afterwards?

MillenniumBug (millenniumbug) wrote :

Does
sudo dpkg-reconfigure plymouth
solve the problem?

chenpoyang (young-cpy) wrote :

I want to install ubuntu 10.10 to my computer, while i boot my compuuter from CD-ROM, I encounter: process:285 Glib-warning **: getpwuid_r(): failed due to unknown user id(0), stdin:error 0.
what should i deal with it? contact me:<email address hidden>, thanks!

brabax (brabax2) wrote :

@Martin: after sudo dpkg-reconfigure plymouth I got:

update-initramfs: Generating /boot/initrd.img-2.6.35-28-generic

After new start of the system I did not get the error message any more, but the boot process stops. But there had been some other update meanwhile as well.

I see that the screen is triggered because it is not as dark as it is when switched off. If i remove the splash option in grub dialogue system starts as normal.

Changed in plymouth (Ubuntu):
assignee: nobody → Gaurav Juneja (thegauravjuneja)
Steve Langasek (vorlon) on 2011-05-07
Changed in plymouth (Ubuntu):
assignee: Gaurav Juneja (thegauravjuneja) → nobody
sacha@ubuntu (sacha-b77) wrote :

Hello!

This bug is absolutely not fixed! The message is hidden but the system could'nt launch xorg and gdm. Blank screen and only ctrl-alt-del can reboot the machine to try a next boot.

It seems to be linked with plymouth.

I've a debian testing on the same desktop and i've never seen this bug on debian. But, on debian, plymouth is not installed!

How can we unistall plymouth properly on lucid 10.04.2 LTS?

Mackenzie Morgan (maco.m) wrote :

This bug is about the message. For the hardware incompatibility that
plymouth is having, please file your own bug. Separate hardware needs
separate bugs.

Maco

tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.