Boot stalls on buffer I/O error for non-existant floppy device

Bug #236144 reported by Dominique Ramaekers on 2008-05-30
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

When starting the hardy live CD the bootup stalls on buffer I/O error for a non-existing floppy drive. After getting several error messages, de bootup just contiues.

This bug was allready reported and closed. Leann Ogasawara has asked me to report a new bug because it's likely I have different hardware and I need a other fix.

See attachements for

uname -a

cat /proc/version_signature

dmesg

sudo lspci -vvnn

cat /proc/interrupts

Nick Ellery (nick.ellery) wrote :

Please provide your .txt outputs as seperate attachments, not archived. Thanks.

jason (marshmel) wrote :

I had this problem. But I fixed it by making sure the floppy was fully disabled in the bios. Check all your bios settings

Ok but this shouldn't happen. BTW, if I wait a little longer, the bootup continues. That's a quicker solution ;-) and much easier.

Hi Dadio,

Thanks for opening this new report and sorry for the delayed response here. The Ubuntu kernel team is actively developing the upcoming Intrepid Ibex 8.10 release. Would you care to confirm this is still an issue with the latest Alpha for the upcoming Intrepid Ibex 8.10. You should be able to test via a LiveCD - http://www.ubuntu.com/testing. Please let us know your results. If the issue still exists, if you could attach and updated dmesg output that would be great. Thanks again and we appreciate your help and feedback.

Changed in linux:
status: New → Incomplete

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

The alpha5 doesn't report this error-message. So in my case the bug is fixed. Thanks a lot!

Go team, go!

Thanks for the note. Since Dadio is the original bug reporter I'm marking this "Fix Released" for Intrepid.

Changed in linux:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers