Ubuntu

fatal errors installing oss-compat, snd_pcm_oss module not found

Reported by Per Ångström on 2010-10-12
160
This bug affects 34 people
Affects Status Importance Assigned to Milestone
oss-compat (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: oss-compat

This is the output from installing oss-compat in Ubuntu 10.10:

Selecting previously deselected package oss-compat.
(Reading database ... 147977 files and directories currently installed.)
Unpacking oss-compat (from .../oss-compat_0.0.4+nmu3_all.deb) ...
Setting up oss-compat (0.0.4+nmu3) ...
FATAL: Module snd_seq_oss not found.
FATAL: Module snd_mixer_oss not found.
FATAL: Module snd_pcm_oss not found.

It happens on all my three Maverick installations, one upgraded from Lucid, the other two are fresh installs.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: oss-compat 0.0.4+nmu3
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
Architecture: amd64
Date: Tue Oct 12 10:12:31 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate amd64 (20100928.1)
PackageArchitecture: all
SourcePackage: oss-compat

Per Ångström (autark) wrote :
Per Ångström (autark) wrote :

This behavior seems to be a direct consequence of "fixing" bug #579300.

Daniel T Chen (crimsun) wrote :

Ugh, why was oss-compat even (un)blacklisted?

Daniel T Chen (crimsun) wrote :

Will be fixed in Natty, of course, by blacklisting

Changed in oss-compat (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Nikola Kotur (kotnik) wrote :

I must say that this decision is very wrong.

Disabling OSS (some very used legacy applications rely on it) without working OSSp (it can't be even compiled under 10.10) is not something to be proud of.

martinwguy (martinwguy) wrote :

Absolutely. please revert #579300. This was not a well-considered move.

Linuxexperte (andrea-koeth) wrote :

I got the same thing here after reinstalling LinuxMint 10 after a problem with ubuntu-tweak. Already after installation of the basic system, I started the Update in the Terminal and during installation of the necessary updates, I got the same message.
The next thing I found is, that the language used on the system is a mixture fo English and German, although I installed all necessary language-packages for German.
Then I have problems with missing utf8-support due to the above mentioned error-message.

Please fix this up. This is no go for the system and makes problems also in working with Gimp.

Greetings
Linuxexperte

@Linuxexperte:
It looks like you are having locale/language problems. This message you
saw is probably completely unrelated to that issue.

chanmix51 (hubert-greg) wrote :

This bug sill exists in Ubuntu 11.04:

FATAL: Module snd_seq_oss not found.
FATAL: Module snd_mixer_oss not found.
FATAL: Module snd_pcm_oss not found.

Are there any chances that the uptstream kernel comes with these modules ?

Regards,
greg

Rocko (rockorequin) wrote :

The upstream kernel sources (ie from kernel.org) does include the modules, although they are flagged as deprecated. The standard Ubuntu kernel sources probably also contain the modules.

But to enable them you need to build and install your own kernel, after changing the settings in the .config file as shown in bug #579300 (the CONFIG_SOUND_OSS* and CONFIG_SND_*OSS settings).

Would padsp help? (http://linux.die.net/man/1/padsp). It redirects calls to the OSS modules to pulseaudio so you don't need the OSS modules.

padsp sounds good.
However, I failed to make it work :-(

Here is what I tried:

% wajig start pulseaudio
 * PulseAudio configured for per-user sessions
% ps ax G pulse
 2043 ? S<sl 0:00 /usr/bin/pulseaudio --start --log-target=syslog
 2084 ? Sl 0:00 /usr/lib/pulseaudio/pulse/gconf-helper
24579 pts/1 S+ 0:00 grep pulse
% padsp aumix
aumix: error opening mixer: Input/output error

My goal is to have aumix available again...

Rocko (rockorequin) wrote :

Ah, it looks like they didn't remove OSS properly when they addressed bug #579300 - they only removed the OSS kernel modules. There are a handful of applications like aumix that depend on oss-compat (which doesn't run, as we know) and they should probably have also rebuilt oss-compat use alsa or pulseaudio libraries, or remove it and the dependent applications.

I thought there were some pulseaudio-alsa-oss links that might have got around this but I can't find them in Synaptic.

If you want to build your own kernel and enable the OSS modules (I think you'll need CONFIG_SND_MIXER_OSS as well), you could try these guides:

Build from Ubuntu sources: https://help.ubuntu.com/community/Kernel/Compile

Build from Linus' latest git sources: http://www.linux.com/learn/tutorials/39288-how-to-build-latest-linux-kernel-on-debian-from-linus-git-repo

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package oss-compat - 3

---------------
oss-compat (3) unstable; urgency=low

  * Use softdep directives in the modprobe configuration. (Closes:
    #660803.)
  * Switch to my Debian address.
  * Use canonical VCS URIs.
  * Drop obsolete Lintian override for module-init-tools dependency.
  * Recommend osspd, which provides OSS emulation using ALSA or PulseAudio
    (LP: #659024, #983707).
  * Standards-Version 3.9.4, no further change required.

 -- Stephen Kitt <email address hidden> Tue, 18 Jun 2013 15:05:31 +0200

Changed in oss-compat (Ubuntu):
status: Confirmed → Fix Released

This bug is not fixed. Now when installing oss-compat, it recommends osspd. However, installing osspd forces and uninstall of oss-compat. There is a warning given that oss-compat is a dependency of aumix. It is not until I tried to reinstall oss-compat and osspd was uninstalled that it said osspd provides oss-compat. This leads me to wonder why there was a dependency warning. The package aumix should be marked as depending on osspd or oss-compat if oss-compat is provided in both.

This still leaves aumix without the correct device. Neither of these packages provide an emulated or linked device for /dev/mixer which is required for aumix.

I suppose one simply should not install aumix in the first place, but I think things would just be simpler if Ubuntu put OSS modules back in the kernel so that `modprobe snd_mixer_oss` would work. It would also make many people frustrated with PulseAudio much happier.

Stephen Kitt (steve-sk2) wrote :

This bug is about errors preventing the installation of oss-compat, and is fixed. If you're unhappy about the audio functionality available in Ubuntu, please file bugs against the relevant packages (the kernel if you really want to be able to use aumix with /dev/mixer, osspd if you'd like it to support /dev/mixer). If you're using pulseaudio I'm not sure aumix is particularly useful anyway...

The whole point of osspd providing oss-compat is so that it can be used as an alternative; packages requiring the OSS devices are supposed to simply depend on oss-compat, not osspd.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers