Ubuntu

10de:01d7 Fonts corrupted on LibreOffice menus with nvidia, compiz, twinview and subpixel smoothing.

Reported by Sergio Fernández Marcos on 2010-04-22
136
This bug affects 26 people
Affects Status Importance Assigned to Milestone
NVIDIA Drivers Ubuntu
Undecided
Unassigned
libreoffice (Ubuntu)
Undecided
Unassigned
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg
If I configure twinview with my laptops monitor and an external LCD, I get font corruption. Sometimes, usually while LibreOffice is already opened, and i open firefox, LibreOffice menu fonts get corrupted. Choosing "Subpixel smoothing (LCD)" as font rendering option leads into the font corruption problem. Closing and opening LibreOffice doesn't solve the problem.

WORKAROUND: Disabling compiz restores font appearance.

WORKAROUND: Disabling twinview restores fonts and i don't get font corruption at all.

WORKAROUND: Changing font rendering option to "Best shapes" corrects the problem.

Lotus Notes 8.5 FP1 also suffers this problem.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xorg 1:7.5+5ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Thu Apr 22 16:58:52 2010
DkmsStatus: nvidia-current, 195.36.15, 2.6.32-21-generic, i686: installed
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Release Candidate i386 (20100419.1)
MachineType: Dell Inc. Latitude D620
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-21-generic root=UUID=f103da98-7d98-440e-9898-44f472e2f346 ro quiet splash
ProcEnviron:
 LANG=es_ES.utf8
 SHELL=/bin/bash
SourcePackage: xorg
Symptom: display
dmi.bios.date: 12/18/2006
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A07
dmi.board.name: 0KX350
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA07:bd12/18/2006:svnDellInc.:pnLatitudeD620:pvr:rvnDellInc.:rn0KX350:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude D620
dmi.sys.vendor: Dell Inc.
glxinfo: Error: [Errno 2] No existe el fichero ó directorio
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.32-21-generic

description: updated
Bryce Harrington (bryce) on 2010-04-23
affects: xorg (Ubuntu) → nvidia-graphics-drivers (Ubuntu)

It seems it's related to twinview. If I configure twinview with my laptops monitor and an external LCD, I get font corruption. Disabling twinview restores fonts and i don't get font corruption at all.

I've discarded an xorg.conf problem. I've copied my karmic's xorg.conf file to my lucid installation and I'm getting font corruption again.

Karmic is not suffering of this problem.

summary: - Fonts corrupted on Openoffice menus and Lotus Notes 8.5 with nvidia and
- compiz
+ Fonts corrupted on Openoffice menus and Lotus Notes 8.5 with nvidia,
+ compiz and twinview

Have tried the new version from xorg-edgers ppa (195.36.24) and I'm getting the same problem.

Reverting to 170.x version seems to solve the problem, but performance is horrible (compiz is almost unusable).

I've also tried installing NVIDIA official version through NVIDIA-Linux-x86-195.36.24-pkg1.run package and I'm getting the same results.

The problem is related to font rendering options. Choosing "Subpixel smoothing (LCD)" as font rendering option leads into the font corruption problem. Changing to "Best shapes" corrects the problem.

summary: Fonts corrupted on Openoffice menus and Lotus Notes 8.5 with nvidia,
- compiz and twinview
+ compiz, twinview and subpixel smoothing.
adiaz (andres-diaz-soto) wrote :

I'm having this problem too. I'm using NVIDIA restricted drivers and subpixel smooting, but no twinview.

I'm also having the same behaviour in GVIM. Maybe it's related with this bug: https://bugs.launchpad.net/ubuntu/+source/vim/+bug/572863

bedhead75 (bedhead999) wrote :

I can confirm the font corruption issue too, using Compiz, Nvidia 195.xx drivers, no twinview, and subpixel smoothing. The font corruption is serious enough to render OpenOffice almost unuseable. Changing to "Best Shapes" does correct the problem but it isn't an intuitive fix, and makes a very bad first impression to new users of Ubuntu.

The Bright Side (me-knowingme) wrote :

Nice to know about the fix! "Best shapes" changes the overall appearance of fonts in Ubuntu a little, too, and they look somewhat better in subpixel smoothing. Hope there'll be a fix soon for this bug!

The Bright Side (me-knowingme) wrote :

Just as an addition, when selecting "Best Shapes" and then setting the hinting to "Slight" in the Details options, fonts will look great and the OOO corruption is gone (can't say about Lotus Notes).

Another way to "fix" it is to disable font antialiasing in OOO's View options (you can find them in the first tree in Options).

little jo (littel-jo) wrote :

same bug in openoffice.org for one screen.

Without compiz : no bug

apt-cache policy compiz
compiz:
  Installed: 1:0.8.4-0ubuntu15

apt-cache policy nvidia-current
nvidia-current:
  Installed: 195.36.15-0ubuntu3

apt-cache policy openoffice.org
openoffice.org:
  Installed: 1:3.2.0-7ubuntu4

Queery1985 (djnoeth) wrote :

I get The same thing with OOO and Cream. Both changing to "best shape" and taking away the anti-aliasing in OOO works. But that is not a good fix. I have attached a screenshot showing how it tries to incorporate the top of my menu into the background of the menu. It is so weird!

pt123 (pt123) wrote :

nice to know I am not the only one affected, everything was fine in Karmic.

The upgrade to Lucid made, OOO terrible to use.

If I open OOO shortly after booting up the problem doesn't appear.
But if I open OOO few after boot this occurs. Sometimes screen would flash black
nvidia 195.36
compiz - 1.08.4
oo 3.2

Reset (r3s3t-osfight) wrote :

Confirm this bug using Nvidia + TwinView + Compiz. Turning off Compiz makes the fonts appear nicely.

Ubuntu Lucid 10.04.1
nvidia: 195.36.24
compiz: 0.8.4
oooffice: 3.2.1

Sorry for ranting, but Compiz sucks hell. This openoffice font bug is one of many (very annoying) due to Compiz.

Reset (r3s3t-osfight) wrote :

Just test Compiz 0.8.6 from the official ppa (ppa:compiz/ppa) and the bug still exists.

Andrei Badea (andrei-badea) wrote :

The bug also goes away for me (temporarily, I suppose) by restarting Compiz, e.g., by doing

$ compiz --replace &

from a terminal.

hostmaster (homyakov) wrote :

Сonfirm this bug using Nvidia + TwinView + Compiz

nvidia 260.19.12
compiz 0.8.6

Sven Bendel (ubuntudroid) wrote :

Can confirm TheBrightSide's fix regarding using "Best shape" with "slight" hinting works very well.

Sander Voerman (reg-savoerman) wrote :

I had the same bug without twinview. The following workaround solved this problem for me: edit /etc/X11/xorg.conf and add the line:

Option "RenderAccel" "0"

to the "device" section. I suppose this workaround is nonoptimal as it may reduce video acceleration, but it does allow using subpizel font rendering, compiz, and OpenOffice anti-aliasing at the same time.

Ningfei Li (ningfei) wrote :

Sander Voerman's fix by turning off the "RenderAccel" in xorg.conf works!
But what's the problem exactly? Any other perfect solution?

pt123 (pt123) wrote :

this happens on Libre Office 3.3

Smot (smot-msn) wrote :

This also happens in Gnome Commander.

Changing to "Best Shapes" as described by Sergio above fixes this too,

Guus (guus-verbeek) wrote :

i have this sometimes in wine as well

Deejay_TNT (idaho) wrote :

Also seeing this in wine applications sometimes.

Vasiliy (itess-home) wrote :

I thought that ubuntu is the most polished desktop for end user. But after this bug my wife (which laptop was bitten with this bug) is not agree with me anymore...

Alan Jackson (alan-ajackson) wrote :

I run Nvidia, ubuntu 10.04, and twinview. I originally saw this under kubuntu when I upgraded in Claws. I quickly switched to Gnome which fixed that problem, but then I saw it in gvim - not always, but most of the time. I haven't had any problem with OpenOffice. I fixed it by "set ttyscroll=0" in my .vimrc, which says "do a redraw when you scroll.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
affects: libreoffice → openoffice
Alan Jackson (alan-ajackson) wrote :

Spoke too soon, ttyscroll=0 only improved things, it stills fails with regularity.

sm8ps (sm8ps) wrote :

Hello all! Cannot say if my solution is in any ways the right one for anybody else. Yet it solved my problems on Ubuntu Lucid with OOo 3.2 and Compiz using NVidia 195.36.24 drivers. Although I could successfully work around the problem by disabling sub-pixel hinting in the 'appearance' menu. However, that made the desktop look rather ugly.
Acitivating the option "Force Full GPU Scaling" (and "Stretched" for 'GPU Scaling Method) under 'GPU 0 (GeForce Go 7300) > DFP 0' in the 'NVidia X Server Settings' tool (from the system menu) makes the OOo menus appear perfectly fine even with activated sup-pixel hinting.
HTH!
sm

Walter Ribeiro (wribeirojr) wrote :

For me this issue arose in Ubuntu 12.10 and still happening in version 13.04.
This is a terrible bug and makes Ubuntu and LibreOffice almost unusable for me!!

Fortunately, I found a work around:

1. Open NVIDIA X Server Settings, select Antialising Settings on left panel;
2. Turn ON "Antialising Settings->Override application settings" and move the slider to Off position.
3. Turn ON "Anisotropic Filtering->Override application settings" and move the slider to 1x position.
4. Close NVIDIA X Server Settings

I did some tests and, so far, the bug did not happen.

NVidia Driver Version: 304.64 (nvidia-304-updates)
Graphics Processor: GeForce 7150M / nForce 630M
HP Pavilion dv6000

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
affects: df-libreoffice → libreoffice (Ubuntu)
Changed in openoffice.org (Ubuntu):
status: New → Confirmed
affects: openoffice → openoffice.org (Ubuntu)
no longer affects: openoffice.org (Ubuntu)
Walter Ribeiro (wribeirojr) wrote :

Too early to celebrate. The bug keeps happening, with less frequency.

Walter Ribeiro (wribeirojr) wrote :

Someone tells me how to set the font rendering in Ubuntu 13?
Appearance Settings no longer has the options Subpixel smoothing (LCD)/Best shapes described in comment #6 above.
I would like to test this workarround, but do not know how.

Walter Ribeiro (wribeirojr) wrote :

I'm not sure about the relation. It would be better to have screenshots to compare.

Assuming that the bug could be related to language, I uninstalled Brazilian Portuguese, left everything in English and restarted Ubuntu.

The procedure for test is double click files DOC, DOCX and ODT in Nautilus. After 6 or 7 open files, the error still happens and the menus and tool bars are like that.

Corrupted display indicates a graphics driver problem. libreoffice (Ubuntu) -> Invalid

summary: - Fonts corrupted on Openoffice menus and Lotus Notes 8.5 with nvidia,
+ Fonts corrupted on LibreOffice menus and Lotus Notes 8.5 with nvidia,
compiz, twinview and subpixel smoothing.
summary: - Fonts corrupted on LibreOffice menus and Lotus Notes 8.5 with nvidia,
- compiz, twinview and subpixel smoothing.
+ Fonts corrupted on LibreOffice menus with nvidia, compiz, twinview and
+ subpixel smoothing.
Changed in libreoffice (Ubuntu):
status: New → Invalid

Sergio Fernández Marcos, thank you for reporting this and helping make Ubuntu better. As per https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers nvidia-graphics-drivers does not have a release for Raring yet. Hence, could you please test for this in Quantal via http://cdimage.ubuntu.com/releases/quantal/release/ ?

Changed in nvidia-graphics-drivers (Ubuntu):
status: Confirmed → Incomplete
Walter Ribeiro (wribeirojr) wrote :

Why bug 1082496 and bug 1078357 were unset duplicate of this bug?
They refer to the same issue.

Walter Ribeiro (wribeirojr) wrote :

Possible duplicates of this bug:
- bug 582030
- bug 590547
- bug 607509
- bug 1082496
- bug 1078357
- bug 1106090

Walter Ribeiro (wribeirojr) wrote :

Christopher M. Penalver, thank you for trying to solve this bug.
It seems that Sergio Fernández Marcos has not had much activity here lately, so I am afraid it may take a while waiting for an answer. However I can create a partition with Ubuntu 12.10 and test driver, but I need to be guided in more detail on how to proceed. Can you do it?

 I'm sorry but I do not own the computer where I found the bug anymore. Therefore I won't be able to perform tests around this issue anymore.

Walter Ribeiro (wribeirojr) wrote :

This bug has other consequences that go beyond the corrupted fonts on screen.
Often the screen flashes, the mouse pointer does not move and the whole system locks up, requiring the user to turn off the computer using the button, and lose the work being performed.
For this reason this error becomes very serious because it prevents the use of the office suite, which is the main working tool for many users, including me.

I'd like to collaborate with the solution of this bug testing patches, new drivers and sending back the log files. If I can be helpful in this task, I only ask to be guided on how to proceed.

Thank you!

Walter Ribeiro (wribeirojr) wrote :

Ubuntu 12.10 installed.
Waiting for instructions on how to test nvidia-graphics-drivers via http://cdimage.ubuntu.com/releases/quantal/release/

Changed in nvidia-graphics-drivers (Ubuntu):
status: Incomplete → Confirmed
Walter Ribeiro (wribeirojr) wrote :

After nVidia driver upgrade (nvidia-304-updates) to 304.84-0ubuntu1, the issue still exists in Ubuntu 13.04.
The problem is clearly related to the amount of resources available on the computer, because it only happens with multiple open documents, or when there are many programs running.

Walter Ribeiro (wribeirojr) wrote :

With a single monitor the bug occurs to me exactly as described above.
By connecting an external monitor and configuring TwinView, the issue gets much worse: after open or save a file, or other operation, the screen goes black, flashes, flickers. Sometimes User Interface closes and returns to the login screen. Sometimes the system apparently recovers and returns to work, for a while. Sometimes system hangs and must turn off computer.

Walter Ribeiro (wribeirojr) wrote :

Possible dupe: bug 1034110

Walter Ribeiro (wribeirojr) wrote :

Possible dupe: bug 1029901

Walter Ribeiro (wribeirojr) wrote :

Possible dupe: bug 1015216

Walter Ribeiro (wribeirojr) wrote :

I'm glad to say I found a workaround to this issue.
Not a fix, just a workaround, but after several tests, the corruption stopped happening.
The issue is clearly related to available resources, because it happens when there are many applications or documents open. So, I experimented change computer setup configuration, increasing video memory.
In my case, there is an option in Bios setup "Dedicated video memory up to", that was set to 64 Mb. The other options are 32 Mb and 128 Mb.
I just changed it to 128 Mb and saved.
Good luck!!

But, after all, I'm very very disappointed with NVidia. They don't support linux users and release drivers completely buggy and with poor performance.

Thanks Walter, your workaround did it for me. In my case the Bios setup option was "Framebuffer size". My configuration: Ubuntu 12.04 Precise, NVidia onboard graphics, Driver 304.88, Desktop is Gnome Shell and/or Cinnamon.
Have fun!

summary: - Fonts corrupted on LibreOffice menus with nvidia, compiz, twinview and
- subpixel smoothing.
+ 10de:01d7 Fonts corrupted on LibreOffice menus with nvidia, compiz,
+ twinview and subpixel smoothing.
tags: added: regression-release
description: updated
description: updated

Sergio Fernández Marcos, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/568492/comments/48 regarding you no longer having the hardware. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Confirmed → Invalid
Changed in nvidia-drivers-ubuntu:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers