Ubuntu

Context menu for a USB pendrive shows "Unmount", "Eject" and "Safely Remove Drive"

Reported by Alexander Gitter on 2009-10-16
332
This bug affects 62 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
One Hundred Papercuts
Low
Unassigned
nautilus (Ubuntu)
Medium
Martin Pitt
Lucid
Medium
Martin Pitt

Bug Description

Binary package hint: nautilus

I installed a daily Karmic build from my pendrive and just after rebooting I wanted to remove the drive.
As you can see in the attached image, nautilus offers three different options for what seems to be the same basic task for the average user.

ProblemType: Bug
Architecture: i386
Date: Fri Oct 16 14:43:59 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Alpha i386 (20091016)
Package: nautilus 1:2.28.0-0ubuntu7
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.47-generic
SourcePackage: nautilus
Uname: Linux 2.6.31-14-generic i686

Alexander Gitter (qwertz1230) wrote :
Alexander Gitter (qwertz1230) wrote :

The particular flash drive I'm using is a Sandisk Cruzer Micro with "U3 Smart Technology".
From what I've gathered these drives contain a small partition where the U3 installer is located. Now jaunty doesn't mount that partition, but Karmic does. It shows up as a mounted CD-Rom, seperate from the "actual USB drive" (that is, the data partition).
So the context menu entries are probably related to this, as the mounted CD shows three unmount/eject/remove entries as well.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

affects: nautilus (Ubuntu) → gvfs (Ubuntu)
Changed in gvfs (Ubuntu):
importance: Undecided → Low
Changed in gvfs (Ubuntu):
status: New → Triaged
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
Michał Gołębiowski (mgol) wrote :

I don't think it's about any hidden partition. My pendrive doesn't have any and I still see 3 options.

Let me write what I've written in my dup: I think only the "Safely remove..." option should be left. It's the way it's done in MS Windows XP (Vista/Seven behaves worse) and I think it's a proper way. If a user want to view their device again, they can disconnect and connect it again. If sb doesn't want to do that and they does want to unmount, not eject a device, then... then the user isn't a regular user and they know how to use a umount command - GUI option to do that is not needed, it only confuses others.

Michał Gołębiowski (mgol) wrote :

Any progress on that one?

Sebastien Bacher (seb128) wrote :

you can read comments on the upstream bug which explain why those 3 options are required

Vish (vish) wrote :

Adding papercut task from dup.

Changed in hundredpapercuts:
status: New → Triaged
importance: Undecided → Low
Changed in hundredpapercuts:
milestone: none → lucid-round-10
MillenniumBug (millenniumbug) wrote :

After reading in Gnome-bugs I understand that the three options makes sense, but nevertheless they confused me at first (and I take for granted that every beginner would feel the same).

Is it possible to add some explanation, for example a 'yellow label' showing up, when the mouse hovers over each option?

Although upstream offers use cases, no matter how esoteric, for each of these three apparently similar menu items, I guarantee that tooltips are not the solution here :)

Luke Symes (allsymes) wrote :

How about special casing the Desktop context menu:
"Eject" for Optical Drives and "Safely Remove" for anything else.
Advanced users can still "Unmount" in the Places sidebar context menu, while average users will (hopefully) see the eject button and not need to worry about what Unmount means.

Eduard Grebe (eduardgrebe) wrote :

Luke makes a good point. I would go even further and suggest that "unmount" should not be available anywhere in Nautilus, but that advanced users should go to Palimpsest or the terminal to unmount.

I don't think we should pursue a solution that has "normal users" doing one thing and "advanced users" stuck with a terminal. There must be a solution that "normal users" find easy to use and "advanced users" appreciate.

Michał Gołębiowski (mgol) wrote :

@David Siegel
I strongly disagree. First of all, advanced users appreciate terminal because it's for them (e.g. for me) faster and more convenient. On the other hand, non-technical users shouldn't touch the terminal. This itself contradicts Your claim. Besides, I find it the best solution to provide "default" users with as few options as possible which means they don't need an unmount option. If they really want to mount their pendrive again, they can just plug it out and in and it works. If You're an advanced user, You can also do that but You may consider it more convenient to just use the terminal.

That's not what I said. Users are of course free to use the terminal if they
wish, I don't mean to prevent them from doing that; and as far as options
are concerned, moderation is always better than starvation. I just think
that applying the pattern of designing one interface for "normal users" and
a different interface for "advanced users" is naive and will lead to a
disjointed feeling desktop for all.

I disagree with Michał Gołębiowski... i know the way around with the terminal, but to say that the terminal is more convenient "a priori" is simply wrong:

if we already have a place to manage the eject/umount of the devices, with the users (all users, even advanced ones) accustomated to reach there to perform the desired operation, it's unconvenient to force them to think:

"oh, right... i want to umount the device i'm seeing here in nautilus, but here i can only eject it... if i want to umount i have to open (if it's not already opened) a terminal and tab the way all to the mountpoint"

however i agree with the idea of presenting users with as few options as possibile, and if there isn't a better solution i guess that removing it altogether is better than what we have now...

maybe (since umount is typically used to repartition/format a volume) it would be good if palimpsest supported partitioning or if gparted made more visible their umount command (right now is in the context menu)

Kazade (kazade) wrote :

I wonder if "Unmount" could be shown only if you hold SHIFT when right clicking or can be enabled with a gconf key or something?

I've been using Ubuntu for some time (since 2005) and it's only while reading this bug report (and the one upstream) that I understand why there are 3 options there, I still don't fully understand why right-clicking my USB drive shows both "Eject" and "Safely Remove"

IMO by default, "Unmount" shouldn't be an option, CD/DVD drives should have "Eject", and anything else should have "Safely Remove", but like I said, it would be nice if it was easy to enable "Unmount" for those who require it.

I agree with those that think GUI should be minimal (so there are less technical variable to manage) and should only offer options for typical users. An advanced user can use the cli for certain operations. So, in the specific, I think that, as Kazade sayd, it should be only shown "eject" for cd/dvd drives and "safely remove" for other usb devices.

ethanay (ethan-y-us) wrote :

I understand the difference between all the options, and use all of them. I am still confused by the GUI. I think much of this is solvable with pop-up dialogs. See examples:

USB flash (thumb) drive:
1. Insert/connect drive.
2. [automount]
3. Press eject
4. Drive unmounts and dialog box appears: "No ejectable media found in drive. To disconnect, click 'safely remove drive.'"
5. ["safely remove" behaves as expected]

External USB CD/DVD Burner:
1. Connect external drive
2. [automount]
3. Press "safely remove"
4. Drive ejects and pop-up confirmation appears: "Are you sure you want to turn off power to the drive?"
5. YES: [Unmount and poweroff] NO: [Unmount only]
5. ["eject" behaves as expected]

The case of an external USB HDD is most concerning, because the hdd can be powered up and active when the user suddenly unplugs it and regularly forces an emergency powerdown while believing they properly prepared it for removal. We now have the GUI tools to avoid this (YAY!) -- but we must have clarity.

The only remaining question for the beginning user at this point is: "Ok, so what does 'UnMount' do then?"

Since "Unmount" is a more advanced option, it is normal and ok for this to be a question for new users of Unix-like systems. They can search online for the answer, and should be directed to resources like this:
https://help.ubuntu.com/community/Mount

It is fairly simple, and I think intuitive for the user to learn: When the drive is mounted, the files are accessible to read/write normally. Unmounting leaves the drive "visible" but does not allow normal read/write.

ethanay (ethan-y-us) wrote :

i cleaned up my comment a little here:
https://bugzilla.gnome.org/show_bug.cgi?id=598690#c18

kamereon (kamereon) wrote :

This isn't as off-topic as it sounds:
How do I delete files off an external drive?

Let's say the drive is full. So I delete some files to make room. these files disappear in Nautilus, but are not really gone, because I do not get any more free space on that drive. If I use 'safely remove' or 'eject', I cannot use the drive afterwards, because I have no free space on it. The files I deleted still use up the space. I cannot see them, but they are 'in the trash'.

The only way I know to really free this space on an external drive is to use 'unmount'. On 'unmount' Nautilus will ask me if i want to delete the trash. 'safely remove' and 'eject' will not do that.
So I think that even the most non-technical users will need 'unmount' if they ever want to free some space on their drive.
A better solution would of course be, if 'safely remove' and 'eject' would be merged to one command and that that command would also clear the trash.

Damian Yerrick (tepples) wrote :

> CD/DVD drives should have "Eject", and anything else should have "Safely Remove"

Then what should a CF/SD reader have? I'm guessing "eject" because the media can be removed from the drive.

Currently in 9.10, when I "unmount" a CF or SD card in my SanDisk multiformat reader, the LED next to the CF or SD slot remains on until I pull the card out; when I "eject", it turns off. When I "safely remove", both the SD and CF LEDs turn off and so does the "main power" LED until I disconnect the USB cable and reconnect it.

How easy is it for the underlying system to distinguish an SD reader with an SD card in it from a USB thumb drive? The former should get "eject", the latter "safely remove".

Martin Pitt (pitti) on 2010-03-24
Changed in gvfs (Ubuntu Lucid):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Martin Pitt (pitti)
importance: Low → Medium
status: Triaged → In Progress
phede92 (phede92) wrote :

In my opinion, must be removed in the case of CD / DVD and USB stick button "Unmount" because there is no need for external disks sorry but you do not install gparted from?

phede92 (phede92) wrote :

Sorry, but this bug is why background? While people are convolte forty-four Archive manager only four!

Martin Pitt (pitti) wrote :

Patch sent to upstream bug.

Changed in gvfs (Ubuntu Lucid):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

nautilus (1:2.30.0-0ubuntu3) lucid; urgency=low

  * Add 16_hide_unmount.patch: Do not show Unmount when showing Eject/Safe
    removal. Having three menu entries (unmount/eject/safe removal) in a
    volume/drive menu entry is too confusing. Unmount only really makes sense
    for internal drives, for external ones it is pretty much a "geek" option.
    Geeks can use palimpsest or "unmount /media/foo" from the CLI if they
    really want to, for everyone else it is just an unintuitive and hard to to
    explain menu entry. (LP: #453072)

 -- Martin Pitt <email address hidden> Tue, 30 Mar 2010 19:17:57 +0200

affects: gvfs (Ubuntu Lucid) → nautilus (Ubuntu Lucid)
Changed in nautilus (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2010-03-30
affects: gvfs → nautilus
Changed in hundredpapercuts:
status: Triaged → Fix Released

Why not add an "Advanced" menu that has sub-items to do the other two options? Some of us might want to unmount, but DON'T want to have to goto the command-line every time.

In the case of external media, can we just show Eject instead of Eject
and Safely Remove? I don't think users will be confused if they Eject
their USB key and the port doesn't spit the key out :)

David Siegel [2010-03-31 8:42 -0000]:
> In the case of external media, can we just show Eject instead of Eject
> and Safely Remove? I don't think users will be confused if they Eject
> their USB key and the port doesn't spit the key out :)

We should just show "Safely Remove", since technically you can't
"eject" an USB key. The problem is that almost all USB sticks out
there lie and claim that they have removable media (which is why
"eject" is shown in the first place). We do not currently know a way
to second-guess/work around that, I'm afraid.

I wouldn't worry that you can't technically "Eject" a USB stick. If the user
only sees "Eject", will the user think "technically I cannot eject a USB
device because the USB port lacks the mechanism to forcefully remove the
occupying plug, so I am not sure what to do at this point." Or, will the
user be more confused if they see both "Eject" and "Safely Remove?" I think
the latter case (both are shown) is more likely to confuse, therefore we
should only show "Eject".

For 10.10, we should find a better word than "Eject" -- something with good
semantics for CDs and other media.

For devices which actually have removable media, we still need both,
though. It's a difference whether you want to eject the media in a
drive, or disconnect the drive (for CD-ROMs, card readers, cameras,
etc.)

The upstream bug has some detailled information why we can't just use
"safe removal" by default.

@Martin Pitt
> It's a difference whether you want to eject the media in a
> drive, or disconnect the drive (for CD-ROMs, card readers,
> cameras, etc.)

Who in the world will want to actually "remove" the CD-ROM drive? AFAIK it would cause the drive to be unusable until a reboot so I cannot think who would really want anything like that...

@ Michal

I believe this relates specifically to removable, external USB devices
and drives...

Ethan

2010/3/31 Michał Gołębiowski <email address hidden>:
> @Martin Pitt
>> It's a difference whether you want to eject the media in a
>> drive, or disconnect the drive (for CD-ROMs, card readers,
>> cameras, etc.)
>
> Who in the world will want to actually "remove" the CD-ROM drive? AFAIK
> it would cause the drive to be unusable until a reboot so I cannot think
> who would really want anything like that...
>
> --
> Context menu for an USB pendrive shows "Unmount", "Eject" and "Safely Remove Drive"
> https://bugs.launchpad.net/bugs/453072
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in One Hundred Paper Cuts: Fix Released
> Status in Nautilus: Unknown
> Status in “nautilus” package in Ubuntu: Fix Released
> Status in “nautilus” source package in Lucid: Fix Released
>
> Bug description:
> Binary package hint: nautilus
>
> I installed a daily Karmic build from my pendrive and just after rebooting I wanted to remove the drive.
> As you can see in the attached image, nautilus offers three different options for what seems to be the same basic task for the average user.
>
> ProblemType: Bug
> Architecture: i386
> Date: Fri Oct 16 14:43:59 2009
> DistroRelease: Ubuntu 9.10
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Alpha i386 (20091016)
> Package: nautilus 1:2.28.0-0ubuntu7
> ProcEnviron:
>  LANG=en_US.UTF-8
>  SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-14.47-generic
> SourcePackage: nautilus
> Uname: Linux 2.6.31-14-generic i686
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/hundredpapercuts/+bug/453072/+subscribe
>

Michał Gołębiowski [2010-03-31 16:56 -0000]:
> Who in the world will want to actually "remove" the CD-ROM drive? AFAIK
> it would cause the drive to be unusable until a reboot so I cannot think
> who would really want anything like that...

Well, I do that, but indeed for CD-ROMs you can just yank the cable,
there's nothing to be written for them. It's a more interesting option
for iPods, card readers, etc. So for CD drives (which we can identify
reliably) we might remove the "Safe removal" option.

Martin
--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

Should this also be applied to "Volumes" section of the netbook edition? Currently a right click on a removable drive in this section on UNE only gives unmount as an option.

Changed in nautilus:
status: Unknown → In Progress
aloisam (a-musil) wrote :

Right now, i think "unmount" is the best option, Kamereon has true:

>The only way I know to really free this space on an external drive is to use 'unmount'. On 'unmount' Nautilus will ask me if i want to delete the trash. 'safely remove' and 'eject' will not do that.
So I think that even the most non-technical users will need 'unmount' if they ever want to free some space on their drive.
A better solution would of course be, if 'safely remove' and 'eject' would be merged to one command and that that command would also clear the trash.<

And there is bug related:
https://bugs.launchpad.net/ubuntu/+source/gnome-applets/+bug/569724

Michał Gołębiowski (mgol) wrote :

@aloisam
What one has to do with another? Trash icon doesn't get properly updated and that's why users need umount? That's just ridiculous. Users need Trash icon to properly reflect Trash contents and that's all. Not everyone wants to empty their Trash on disconnecting the drive so Ubuntu cannot force anyone to clear the Trash on such occasion.

summary: - Context menu for an USB pendrive shows "Unmount", "Eject" and "Safely
+ Context menu for a USB pendrive shows "Unmount", "Eject" and "Safely
Remove Drive"
Jon Loldrup (loldrup) wrote :

USB-drives shouldn't have their own trash-can. Users know of ONE trashcan, and thats the one they will go look in first.
To the user, the USB-drive is just a folder (that happens to be placed on an external device). Would one want every folder on the harddrive to have its own trash too?

Steven (stebalien) wrote :

@loldrup
USB drives have trash cans because moving a file within a drive is much faster than moving a file between drives. When moving a file within a drive, all that changes is the file name and the file is not touched. Deleting a file removes the reference to the file but again, the file itself is not touched.

Changed in nautilus:
importance: Unknown → Medium
Damian Yerrick (tepples) wrote :

@pitti
I know why one would want to unmount or safely remove a CD drive: Not all CD drives are CD-ROM drives; some are burners with a rewritable disc mounted in packet writing mode. But I'll admit that packet writing becomes less common as USB flash drives and SD card slots become more common.

turbolad (turbolad995) wrote :

The problem I have with a USB drive is the confusion between "Safely Remove Drive" and "Eject", with only the latter option working. The "Safely Remove Drive" just produces a weird error message.

Changed in nautilus:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.