Ubuntu

Wireless Mouse not registered on Startup or Reboot

Reported by Patrick Gillespie on 2012-03-17
454
This bug affects 90 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Unassigned

Bug Description

Since the last updates to Ubuntu 12.04 Beta 2 (as of March 12), Unity no longer recognizes the wireless mouse after a reboot or when the OS is initially started.

The workaround is to unplug the USB Mouse and plug it back in.

The Mouse: Logitech Anywhere MX

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.6.0-0ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic-pae 3.2.6
Uname: Linux 3.2.0-17-generic-pae i686
ApportVersion: 1.94.1-0ubuntu2
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,resize,mousepoll,move,obs,place,regex,imgpng,gnomecompat,grid,session,unitymtgrabhandles,vpswitch,animation,wall,workarounds,expo,ezoom,fade,scale,unityshell]
Date: Sat Mar 17 17:23:23 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120301)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Patrick Gillespie (vermontpoet) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Patrick Gillespie (vermontpoet) wrote :

This bug continues to worsen with the latest update. After Suspend, the mouse won't work in two out of the three USB ports. The workaround, unplugging and plugging back in, no longer works.

Omer Akram (om26er) wrote :

that's really not unity's fault I would say

affects: unity (Ubuntu) → ubuntu
Patrick Gillespie (vermontpoet) wrote :

OK, I think I'm narrowing this down:

Every time I use the Ubuntu-Tweak (Compiz) "Scale" feature (in my case by going down to the left corner), I lose wireless mouse functionality.

I'm still not sure where this bug should be filed? Unity? Ubuntu Tweak? Compiz?

Patrick Gillespie (vermontpoet) wrote :

The workaround (so far):

1.) Lock Screen.
2.) Unplug USB mouse.
3.) Plug back in.
4.) Unlock screen.

Also, I can use the compiz SCALE feature without losing my mouse if I use the middle mouse button (assigned in CCSM). So, I'm beginning to think this is an Ubuntu Tweak issue.

Patrick Gillespie (vermontpoet) wrote :

Scratch those last two comments. I can no longer reproduce the problem with Ubuntu Tweak. If there's a consistent reason why Unity/Ubuntu drops my mouse, I can't narrow it down. The only thing that remains consistent is that 12.04 drops my USB mouse at inconsistent times - when scaling, when using expo, after unlocking the screen and especially after suspend.

I can use the mouse in Xubuntu 11.10 without a hitch. I'm going to test it in the Gnome Session of 12.04.

Patrick Gillespie (vermontpoet) wrote :

The Mouse adventures continue.

The latest behavior is that the mouse will just stop. I can be in the middle of mousing and it will just stop - no mouse, no connection. I've been wondering whether it's my mouse, but I can restore the connection almost every time thusly:

1.) Click on Lock Screen using touchpad
2.) Mouse functionality magically returns
3.) Unlock Screen
4.) Use Mouse until it Just Stops - Wash, Rinse, Repeat

Is anyone listening, by the way? :-|

Patrick Gillespie (vermontpoet) wrote :

The mouse has begun exhibiting the same behavior on other OS's, including Windows.

I hereby call this an object lesson in user denial. My mouse is bad. I'm marking the bug invalid.

Changed in ubuntu:
status: Confirmed → Invalid
NoOp (glgxg) wrote :

Your mouse may be bad, but mine is not and I exerience the exact same symptoms on 12.04 (64bit fully updated as of 2012-03-28. Many times the mouse is not working at the lightdm login page. Mouse & Unifying receiver work just fine with 11.04 & Win7 on the same machine.

3.2.0-17-generic x86_64

046d:c52b Logitec, Inc. Unifying Receiver

Mouse is a Logitec M505.

Removing the USB Unifying Receiver & plugging in again sometimes works. Rebooting sometimes works. Again; only problems when booting/rebooting to 12.04 - mouse & receiver work fine when booted/rebooted to 11.04.

Lucazade (lucazade) wrote :

@NoOp
same here, mouse is not recognized at boot and I have to unplug and plug again to get it working.
It happens only with a Logitech Perfomance MX with DarkField tech whille other logitech mouse works properly.

Changed in ubuntu:
status: Invalid → Confirmed
Lucazade (lucazade) wrote :

lsusb when mouse is working and when is not recognized

I also has Logitech mouse and I should plug and unplug it to use. It happened only after I have updated to Ubuntu 12.04. I am waiting for solution.

Bipin Mathew (bipinmathew) wrote :

I can confirm this bug. Downloaded latest beta last night, and wireless mouse failed to be recognized on boot. Had to unplug and replug usb wireless adapter to work. Build:

ubuntu@ubuntu:~$ uname -a
Linux ubuntu 3.2.0-20-generic #33-Ubuntu SMP Tue Mar 27 16:42:26 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Here is the tail of the /var/log/syslog when reseating the wireless adapter for the mouse:

Apr 17 19:16:17 ubuntu kernel: [ 1875.776157] usb 6-2: USB disconnect, device number 3
Apr 17 19:16:20 ubuntu kernel: [ 1879.328216] usb 6-2: new full-speed USB device number 4 using uhci_hcd
Apr 17 19:16:20 ubuntu mtp-probe: checking bus 6, device 4: "/sys/devices/pci0000:00/0000:00:1d.1/usb6/6-2"
Apr 17 19:16:20 ubuntu kernel: [ 1879.519730] logitech-djreceiver 0003:046D:C52B.0012: hiddev0,hidraw3: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:1d.1-2/input2
Apr 17 19:16:20 ubuntu kernel: [ 1879.522902] input: Logitech Unifying Device. Wireless PID:101d as /devices/pci0000:00/0000:00:1d.1/usb6/6-2/6-2:1.2/0003:046D:C52B.0012/input/input18
Apr 17 19:16:20 ubuntu kernel: [ 1879.523138] logitech-djdevice 0003:046D:C52B.0013: input,hidraw4: USB HID v1.11 Mouse [Logitech Unifying Device. Wireless PID:101d] on usb-0000:00:1d.1-2:1
Apr 17 19:16:21 ubuntu mtp-probe: bus: 6, device: 4 was not an MTP device

Bungeur (sanfton-0801) wrote :

Affects me too. Logitech Peformance MX, Kubuntu 12.04 beta2. Old N42 mouse fine. Replugging clears fault, usually.
when I try the receiver in the USB of a Toshiba Port replicator (hub + LAN, serial, keyboard) it NEVER works - and dmesg reports "insufficient bandwidth". Yet this setup works faultlessly on 10.04 Lucid.

Uğur Çetin (ugur-jnmbk) wrote :

Hi, I'm not sure but this might be related to this debian bug:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=658029

Looking at the patch in this bug I edited my local /usr/share/initramfs-tools/hook-functions file and added hid-logitech-dj on line 416
then I did:
sudo update-initramfs -u

After a restart, my m505 mouse was correctly working without having to replug the receiver. Still this might be a one time luck. I'll comment again if this stops working later on.

Lucazade (lucazade) wrote :

@Uğur Çetin (ugur-jnmbk)
great! going to try it asap :)

Bungeur (sanfton-0801) wrote :

I tried it, too. Performance MX still not recognised at boot. :-(
 (I have no problems at RESUME)

Uğur Çetin (ugur-jnmbk) wrote :

It seems that was just my luck. Several hours later, mouse wasn't working after a start. Replugging the receiver is the only workaround.

Frans Bijma (fbijma) wrote :

I have the same kind of problem with my wireless Logitech mouse. Do'nt know the type. But very regularly the mouse just stucks and when I then move it arround a few times it just comes back. I used this same mouse on a windows machine yesterday ( another laptop) without any problem. lsusb allways shows the mouse in the list.

lsusb

Bus 001 Device 004: ID 0a5c:217f Broadcom Corp. Bluetooth Controller
Bus 001 Device 005: ID 17ef:480f Lenovo Integrated Webcam [R5U877]
Bus 002 Device 003: ID 05c6:9204 Qualcomm, Inc.
Bus 001 Device 006: ID 046d:c510 Logitech, Inc. Cordless Mouse

I experienced the same issue here with my wireless Logitech M325 using 12.04 LTS final amd64.

Swarnendu Biswas (swarna-cse) wrote :

Yes, thanks for the bug post. This is one feature which has been bothering me to no ends. I am facing this bug since maybe early Jan developer releases of Precise. I have a Dell XPS 15 laptop and a Logitech usb wireless mouse. However, interesting part is that I do not face this issue with Oneiric.

Logitech replaced my Anywhere MX mouse. Worryingly, the new mouse worked perfectly with Oneiric, just like my old mouse; but when I booted up the 12.04 partition (same computer) the brand new Anywhere Mouse failed (so far just once) to be recognized. Had to unplug the USB transmitter and plug it back in. Why this is worrisome is that this is precisely how the older mouse began to fail.

I'm concerned that something in 12.04 (the kernel?) is potentially damaging the hardware. I never had problems with my old mouse until I started testing 12.04. Is it sheer coincidence? Seems to me that the severity of the bug should be changed and the devs should start taking this problem seriously - either eliminating possibilities or confirming them.

JM (jose-mingorance) wrote :

Very same problem here....
Anywhere MX mouse not working at boot with 12.04.

Note that:
With any other previous version of ubuntu it works perfectly.
If I unplug the receiver and then plug it again, the mouse works perfectly. Therefore the problem is only at boot.

I'm also observing this problem with my logitech M325 mouse.
Instead of unplugging and re-plugging the USB receiver I'm running the following commands as discussed here: http://askubuntu.com/questions/128345/logitech-m515-does-not-work-after-upgrade-to-12-04

as super user:
modprobe -r hid_logitech_dj
modprobe hid_logitech_dj

Logitech Performance MX Mouse with same issue. Unplugging/re-plugging solves this issue, but obviously is a hassle. Seems to happen at restart only.

John Feole (jfeole) wrote :

I am also seeing this bug on a fresh install of 12.04. Mouse is fine, tested on 2 other machines with 12.04. The only way I can get it back is to remove/re-add the Logitech Unifying receiver into USB slot.

JFeole

I did a recent update through the update manager and this issue seems to have been resolved.

Negative, thought it was resolved, but it just happened again to me.

Yes, I too thought it was resolved. It just happened and I had to restart.

Similar story here...
Logitech M515 mouse. Triple boot machine, Windows7, Lucid 32bit, 12.04 64bit.
12.04 is clean install into empty partition.
Mouse operation may or may not work on boot into 12.04 (consistently fine in other OS's)
remove/reinsert USB dongle after boot restores normal operation
sudo modprobe -r hid_logitech_dj; sudo modprobe hid_logitech_dj; also restores normal operation

I'd guess at some sort of race condition. Is the new kernel faster than previous kernels? Is the M515 slower at poweron than other logitech mice?

Jeahavee (jamillskill) wrote :

When I first boot up and get to the log in screen my mouse doesn't respond. I'm using a fresh install of 12.04. I didn't have this problem when I upgrade from 11.10 to 12.04 (I had other problems which forced me to reinstall 12.04). [64bit only]

cki (charles-kirsch) wrote :

I have a M510 mouse and K800 wireless keyboard. If the problem appears, it affects both, the keyboard and the mouse. My impression is that if I switch on the devices only after I'm seeing the login screen, that the problem doesn't appear. I didn't have an issue that the mouse/keyboard stopped working after a couple of hours.

Same issue here .It happens randomly after reboot and i din't have this problem with previous ubuntu releases. Unplug/Plug mostly works .

Jeahavee (jamillskill) wrote :

Check this out. So yesterday I had to unplug replug, but when I did it I change the USB port to the one right behind it. What's special about that port is that's the original port I had first put the Unity dongle into when I first install this mouse on windows. SO today just now when I logged into 12.04 I turn my mouse on and it moved... I'm thinking maybe the labtop remembers where that port was from the beginning and somehow the OSs remembered the unity dongle was plugged in there from the beginning and so when I first boot up Windows notices the change, 11.10 noticed the change but some how 12.04 didn't notice the change. Maybe it's just my labtop might not be the same for others.

My 12.04 install still has occasional problems with my MX Mouse.

I just upgraded my wife's netbook from 11.10, which never once had a problem with her generic Logitech mouse M525, to 12.04. Now, she has to unplug and plug the mouse back in. Sometimes even that doesn't work.

So... is there any point to reporting this information? I have yet to see any effort made toward solving this bug.

I get the feeling everyone here is wasting their time.

Gunaddho Bhikkhu (taanpeter) wrote :

I have a logitech anywhere mx, as does my 83 year old mother. Both using ubuntu precise with unity. Both having the usb mouse not recognized at bootup and have to unplug and replug to get it working. Ubuntu devs should know that I also dual boot with Archlinux gnome-shell and there are no issues on that distro. This seems to be an Ubuntu exclusive. Any attention would be welcome.

Mustapha Mond (mustaphamond) wrote :

Same issue here. 12.04 (32bit) 3.2.0-24-generic-pae #39-Ubuntu SMP
Logitech Wireless Trackball M570

Jon Quiros (jquiros) wrote :

Same here- Release 12.04 (precise) 64-bit Linux tlaloc 3.2.0-24-generic #37-Ubuntu SMP x86_64 x86_64 x86_64 GNU/Linux
with Logitech MX310...
Regards,
Jon

Uğur Çetin (ugur-jnmbk) wrote :

Hi. I think I found something worth mentioning here.
It only works when mouse is moved before the module is loaded. Example:

sudo modprobe -r hid_logitech_dj
**move mouse**
sudo modprobe hid_logitech_dj

works 100% for me since I last commented here. It doesn't work when I don't move the mouse before loading module. So I think the problem should be related to detection part of this module (hid_logitech_dj).

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
tags: added: patch
47 comments hidden view all 127 comments
DR. VIMAL HURRY (vhurry200) wrote :

but to no avail!

Nick S (pinkcoons) wrote :

To make mine work, I have to repeatedly run

sudo modprobe -r hid_logitech_dj
sudo modprobe hid_logitech_dj

some number of times (anywhere between one and ten) at each boot. I wrote a script for it, but this is silly.

I have this same exact issue on 12.10 Beta 2 as of today on my Inspiron 15R Notebook (Inspiron 7520) using the Logitech Anywhere MX mouse. after spamming "sudo modprobe -r hid_logitech_dj && sudo modprobe hid_logitech_dj" a few times the mouse pointer comes to life until I reboot again.

same problem here on the ASUS zenbook

same problem with dell xps L521X / fedora 17 / kernel 3.6.3-1.fc17.x86_64 / M505 mouse

wilbur.harvey (wilbur-harvey) wrote :

I have several systems, all running 12.10 at this point.
Older Logitec mice without the Unifying dongle work always, on all machines.
Mice with the Unifying dongles have been working always on my machines with USB2 ports.
Mice with the Unifying dongles have never worked properly (12.10) on my Sony Z-Series with USB3.
Sometimes unplugging/plugging in the dongle will make it work, but it will randomly stop working.

Ian Brock (brock-physik) wrote :

I intermittently had the problem with slow and delayed mouse movement (Logitech M505) in Ubuntu 12.04. I upgraded to 12.10 last week and the problem appears much more often. My usual fix in the past of booting Windows 7 and then rebootting with Ubuntu did not fix the problem any more.
I tried fix #50, i.e. commenting out "blacklist usbmouse" and since then things are OK (several new starts and suspends), but only only one day of testing so far.

Luis Alvarado (luisalvarado) wrote :

The problem is back again in 12.10. Have not tried the #50 fix yet, but the common problems for me are:

1. Mouse moves correctly until I stop using it for a couple of seconds. After that it behaves good for 0.5 seconds, then bad for 0.5 seconds and this behavior continues until I remove the usb dongle plugged in.

2. The distance the mouse covers is smaller now on the same area I was doing the check. Nothing was added or removed from the room I was doing the check, somehow it works worse now at about 3 meters when it worked perfect in 5 and after 5 is when it started to loose effect (Tested batteries).

3. The "unifying effect" does not work between my Anywhere Mouse and my M600 Touch Mouse. I think they hate each other.

Ian Brock (brock-physik) wrote :

The "# blacklist usbmouse" solution I mentioned in #94 does not work every time. I therefore blacklisted usbmouse again.

The following combination of workarounds seems to work reliably (at least for the past 3-4 days):

http://askubuntu.com/questions/128345/logitech-m515-does-not-work-after-upgrade-to-12-04/202627#202627

i.e. I installed the logitech-unifying.sh script advertised there in /etc/init.d/. This script removes and reinstalls hid_logitech_dj

In addition, when I boot my laptop (Dell E6410 with (K)Ubuntu 12.10) I keep the mouse (Logitech M505) switched off and only switch it on 10 seconds or so after I have logged in.

Changed in linux:
status: Confirmed → Fix Released
Mercer Rivière (vincentuq) wrote :

Unfortunately the problem persist.
Sometimes after a boot the mouse is still not working, unplug and plug results with:

[10282.964070] hub 1-0:1.0: unable to enumerate USB device on port 3
[10434.128070] usb 2-4: new low-speed USB device number 2 using ohci_hcd
[10434.438116] input: HID 1241:1166 as /devices/pci0000:00/0000:00:02.0/usb2/2-4/2-4:1.0/input/input4
[10434.438985] generic-usb 0003:1241:1166.0001: input,hidraw0: USB HID v1.00 Mouse [HID 1241:1166] on usb-0000:00:02.0-4/input0
[10434.439047] usbcore: registered new interface driver usbhid
[10434.439052] usbhid: USB HID core driver
[10434.440748] usbcore: registered new interface driver usbmouse
[10434.440756] usbmouse: v1.6:USB HID Boot Protocol mouse driver

I agree, with my Logitec Anywhere MX mouse, it works a little better, but
still, most of the time I have to plug/unplug the dongle several times.
I am running the latest 12.10 updates.

On Fri, Dec 21, 2012 at 12:04 PM, Mercer Rivière
<email address hidden>wrote:

> Unfortunately the problem persist.
> Sometimes after a boot the mouse is still not working, unplug and plug
> results with:
>
> [10282.964070] hub 1-0:1.0: unable to enumerate USB device on port 3
> [10434.128070] usb 2-4: new low-speed USB device number 2 using ohci_hcd
> [10434.438116] input: HID 1241:1166 as
> /devices/pci0000:00/0000:00:02.0/usb2/2-4/2-4:1.0/input/input4
> [10434.438985] generic-usb 0003:1241:1166.0001: input,hidraw0: USB HID
> v1.00 Mouse [HID 1241:1166] on usb-0000:00:02.0-4/input0
> [10434.439047] usbcore: registered new interface driver usbhid
> [10434.439052] usbhid: USB HID core driver
> [10434.440748] usbcore: registered new interface driver usbmouse
> [10434.440756] usbmouse: v1.6:USB HID Boot Protocol mouse driver
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/958174
>
> Title:
> Wireless Mouse not registered on Startup or Reboot
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linux/+bug/958174/+subscriptions
>

Mercer Rivière (vincentuq) wrote :

Btw, as for the (WIRED!) mouse, the difference is with these modules in before/after plug/unplug:
+usbmouse 12666 0
+usbhid 41937 0
+hid 77428 1 usbhid

So I guess it's not hid_logitech_dj's cause...

Zoran Jeremic (zoran-jeremic) wrote :

Seems that solution suggested in #50 works for me too.

Mercer Rivière (vincentuq) wrote :

For me works an USB extension cable - the plug is close to the keyboard (which is on PS/2, great!) and makes plug/unpluging more easy.

Can we make that an official fix?

wilbur.harvey (wilbur-harvey) wrote :

The problem seems to be only with certain USB controllers.
Problems with two different new Sony Vaio with USB3 controllers.
Exact same configuration on my older Dell Studio 15 and there are no
problems.

On Mon, Jan 7, 2013 at 11:16 AM, Mercer Rivière
<email address hidden>wrote:

> For me works an USB extension cable - the plug is close to the keyboard
> (which is on PS/2, great!) and makes plug/unpluging more easy.
>
> Can we make that an official fix?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/958174
>
> Title:
> Wireless Mouse not registered on Startup or Reboot
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linux/+bug/958174/+subscriptions
>

Mercer Rivière (vincentuq) wrote :

I don't have a same configuration, but LTS on 5 machines (two DELL laptops, one very old DELL workstation, one recent HP Z820 and a desktop which is hard to describe), out of them, only on a single one (the last desktop) the problem manifests itself.

Mark Bokil (mark-bokil) wrote :

On a Lenovo GT780 with Ubuntu 12.10 I have mouse failure at startup. I have to do:
 sudo modprobe -r hid_logitech_dj && sudo modprobe hid_logitech_dj
about 2-5 times to get the logitech m325 to work.

Luis Alvarado (luisalvarado) wrote :

The problem for me is with 2 Logitech wireless mice:

- Anywhere mouse with it's Unified connector
- Touch Mouse m600 with it's Unified connector

I say "with it's Unified connector" because both do not work automatically when ing to use only one connector. There is actually no "unified" connection. But this is just another problem.

The problem with both is that if they stay a couple of seconds without use, they start a blinking game where they work for 0.5 seconds and then do not. It repeats forever. This affects 12.04 and 12.10. Have not yet tested 13.04

Same problem here on Ubuntu 12.10 and Ubuntu 13.04 (kernel 3.8.0-4-generic) with a Logitec Anywhere MX mouse. Worked fine on my old laptop with Ubuntu 12.10. This computer has USB 3 ports, my old one only had USB 2.

g3n1uss (g3n1uss-yandex) wrote :

The same problem. I think the reason is USB 3, cause it works fine on my old laptop with USB.

Jason Shultz (1-jason) wrote :

I can confirm that I'm having the same issue. I was able to restore mouse functionality by:

1.) Lock Screen.
2.) Unplug USB mouse.
3.) Plug back in.
4.) Unlock screen.

I have a Logitech Anywhere MX Notebook mouse.

Jason Shultz (1-jason) wrote :

I should add that I'm on Ubuntu 12.10 on a ASUS A55A-AH51. I have all the latest updates as well.

Kaiz Vohoumger (hx6030) wrote :

I confirm that this bug is fixed by the solution presented in comment 50.

I am using ubuntu 12.04 64bit with the latest updates and confirm this exact issue with a standard wired usb mouse. The keyboard is also affected but with a much lesser frequency than the mouse.

Since applying the fix in comment 50, I have had no problems whatsoever. I immediately noticed this problem when recently upgrading to 12.04 after years of trouble free operation on the previous ubuntu LTS release.

Based on my understanding of how the fix works by unblacklisting the usbmouse module and the intermittent nature of the problem (eg 50% failure rate on boot) - I would say that the hid handling subsystem of the 3.2.0-37-generic kernel has some kind of race condition which causes it to fail to identify the usb mouse.

In my 15 years of using linux this is the first time I've had a problem with a mouse being recognised!

Hardware AspireR3610, nvidia Ion, Logitech optical mouse M-bt96a

Ben Copeland (bcc) wrote :

I also have this problem on Ubuntu 13.04.

Have to unplug and plug the receiver back in to get the keyboard and mouse to work. Sometimes have to do it more than once.

mo cook (mo-cook) wrote :

I had this problem with 12.04 with the device plugged into a standard USB slot on the back of the machine itself.

But.... When I plugged it into an existing powered USB port instead of directly into the back of the machine it worked fine.... And still does after several reboots.

No idea why.... It's just a simple NEWLINK 4slot box which also has the Wireless adaptor and the printer plugged in.

This seems to have solved the problem for me!

Kent57 (kent5700) wrote :

Can confirm this problem still exists in Kubuntu 13-04 clean install with a Logitech Cordless Optical Trackman. Running "lsusb" shows the wireless device is there but it does not function.
Solutions offered in posts 40 & 50 do not work only unplugging and plugging it back in, resolves the issue till next time.

mabox (mabox) wrote :

I can confirm that this problem not longer exist for me in Ubuntu 13.04 with a Logitech Anywhere MX. For me this problem is fixed.

1 comments hidden view all 127 comments
Jeffrey Seria (kl7jef) wrote :

I am new to Linux and just loaded Ubuntu 12.04. Even during install I had to use the keyboard to complete it. I can move the cursor with the mouse without problem, it's just that I am unable to left click on anything all of a sudden. I have tried all the above suggestions to no avail. My mouse is a Logitech M510. Does anyone have suggestions on a mouse that isn't susceptible to this bug?

description: updated
MEB (mysticeyeblink) wrote :

Problem still exists in Ubuntu 12.04 with kernel 3.2.0-47-generic-pae #72. I've Logitech M505. Sometimes shutdown system and then start helps but rarely. My USB port hurts :(

tags: added: needs-kernel-logs needs-upstream-testing

Patrick Gillespie, could you please confirm this issue exists with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ . If the issue remains, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the mainline kernels archive directory daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.10-rc7

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: regression-potential
J.J. Valenzuela (computer-b) wrote :

Comment 50 worked for me. I have Logitech K800 keyboard and M510 mouse, both use the Unified Wireless Receiver (USB) and on boot (on Mint 15) they would never load, I had to unplug and plug the receiver in before they would work. commenting out usbmouse and usbkbd worked for me. They now load on boot.

J.J. Valenzuela (computer-b) wrote :

I spoke too soon. Comment 50 did not work for me after another reboot.

very frustrating

Changed in linux (Ubuntu):
importance: Undecided → Medium
J.J. Valenzuela (computer-b) wrote :

This is what I'm going to try tonight:
1. Use a USB 2.0 port instead of USB 3.0. This thread seems to have a pattern of people having it not work on boot with USB3 but it works fine on USB2.
2. If that doesn't work, try software from www.hidpoint.com
3. If that doesn't work, update to the very latest kernel, 3.10 i believe.

J.J. Valenzuela (computer-b) wrote :

Seems that

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1039143

Is all about this bug also and there was a fix in kernel but now it no longer works in the latest 3.10

The bug in NOT present in 3.9.8, but it's back in 3.10. I've tried all
ports (2.0 & 3.0)

almadana (almadana) wrote :

Same issue for me, mouse won't work in kernel 3.10 (3.10.3, 3.10.6...)

~$uname -a
Linux vaiaia 3.10.6-031006-generic #201308112316 SMP Mon Aug 12 03:17:33 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Works great with 3.8 kernel in Raring though.

almadana, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the official Ubuntu documentation:
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices
Ubuntu Community: https://wiki.ubuntu.com/ReportingBugs

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

Thank you for your understanding.

Felix Moreno (info-justdust) wrote :

same problem here, in ubuntu 13.10 is not working mouse at start a problem if u have encrypted partitions...
probably the solution is the same as this...
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1066376

Felix Moreno, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

No need exists to comment here at this time. After reading the above documentation in it's entirety, if you have further questions, you are welcome to redirect them to the appropriate mailing list or forum via http://www.ubuntu.com/support/community/mailinglists , or you may contact me directly.

Thank you for your understanding.

Displaying first 40 and last 40 comments. View all 127 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.