keyboard doesn't work to enter password with panda and encrypted partitions ubuntu

Bug #1066376 reported by Paul Larson on 2012-10-13
60
This bug affects 10 people
Affects Status Importance Assigned to Milestone
base-installer (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
initramfs-tools (Ubuntu)
Undecided
Adam Conrad
Precise
Undecided
Adam Conrad

Bug Description

This ended up being two bugs, one is for missing modules in the initramfs-tools static list (which is true for all arches), and one is that ARM specifically get a cut-down initrd due to the base-installer default of setting MODULES=dep only on ARM. The initramfs-tools SRU only addresses the former.

[IMPACT]
Users with certain USB keyboards and no USB->PS/2 BIOS emulation will no longer have keyboard control in their initrds after upgrading to an lts-quantal kernel.

[TEST CASE]
If you have the affected hardware, re-run update-initramfs -u both with and without the updated initramfs-tools (with a quantal kernel installed on precise), reboot with "break=bottom" on the command line, and see if you have a keyboard.

If you don't have the affected hardware, do the above initrd generation, and compare results, the new one should include hid-logitech-dj and hid-generic.

[Regression Potential]
Next to none. initrds may get a tiny bit larger, but not by any meaningful amount.

[Original description]
Installing quantal server on panda from the 20121013 image, a normal install with guided partitioning works fine, and keyboard works during and post-install.

However, if I select lvm+encrypted partitions from the partitioning screen, after rebooting the keyboard does not work for entering the password to unlock the disk, which prevents booting the system.

Paul Larson (pwlars) wrote :

Also tried this on x86, and disabled legacy support for usb in bios. When I did that, I could still enter the password to unlock the disk, but the grub menu would not respond to using the keyboard.

On ARM, the lack of ability to enter the password can be worked around by booting with serial console enabled.

Changed in initramfs-tools (Ubuntu):
assignee: nobody → Adam Conrad (adconrad)
Paul Larson (pwlars) wrote :

uInitrd from the panda after installation

Paul Larson (pwlars) wrote :

ubuntu@ubuntu:~$ lsusb
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 005: ID 125f:312b A-DATA Technology Co., Ltd. Superior S102 Pro
Bus 001 Device 006: ID 413c:2107 Dell Computer Corp.
ubuntu@ubuntu:~$ lsmod
Module Size Used by
hid_generic 1074 0
arc4 1417 2
wl12xx 12289 0
wlcore 157944 1 wl12xx
joydev 9528 0
mac80211 510720 1 wlcore
cfg80211 201355 2 wlcore,mac80211
hid_logitech_dj 11154 0
usbhid 38447 1 hid_logitech_dj
hid 77532 3 hid_generic,hid_logitech_dj,usbhid
wlcore_sdio 3721 0
gpio_keys 8751 0
ext2 63835 1
xts 3528 2
gf128mul 9238 1 xts
dm_crypt 17097 1
usb_storage 36630 2
uas 8598 0

Adam Conrad (adconrad) wrote :

20:21 < infinity> hggdh: If you still have a panda with crypted root that can only be unlocked via serial, can you jump on the #1066376 bandwagon and give me an lsmod of the booted system?
20:23 < infinity> hggdh: And if it happens that it also wants hid_logitech_dj, can you patch /usr/share/initramfs-tools/hook-functions by hand to add "hid-logitech-dj" in the same block as you find "hid-generic", run "sudo update-initramfs -u", and reboot and see if that's all you need to make it go?
20:23 < infinity> And this should all be in the bug.
20:23 * infinity copies and pastes.

Adam Conrad (adconrad) on 2012-10-16
Changed in initramfs-tools (Ubuntu Precise):
assignee: nobody → Adam Conrad (adconrad)
Adam Conrad (adconrad) on 2012-10-16
Changed in initramfs-tools (Ubuntu):
status: New → In Progress
Changed in initramfs-tools (Ubuntu Precise):
status: New → In Progress
Paul Larson (pwlars) wrote :

Here's some more data:
lsmod from the same system with a generic usbhid keyboard attached:
Module Size Used by
arc4 1417 2
wl12xx 12289 0
wlcore 157944 1 wl12xx
mac80211 510720 1 wlcore
cfg80211 201355 2 wlcore,mac80211
hid_generic 1074 0
usbhid 38447 0
hid 77532 2 hid_generic,usbhid
wlcore_sdio 3721 0
gpio_keys 8751 0
ext2 63835 1
xts 3528 2
gf128mul 9238 1 xts
dm_crypt 17097 1
usb_storage 36630 2
uas 8598 0

Output from serial session when I switch over to using serial, there's an error here about missing evms_activate which I don't remember seeing on x86:
Uncompressing Linux... done, booting the kernel.
error: unexpectedly disconnected from boot status daemon
  Reading all physical volumes. This may take a while...
  No volume groups found
  No volume groups found
cryptsetup: evms_activate is not available
Unlocking the disk /dev/disk/by-uuid/1e0f5901-b0b6-468c-a104-90f206bc0b3e (sda5_crypt)
Enter passphrase:
  Reading all physical volumes. This may take a while...
  Found volume group "ubuntu" using metadata type lvm2
  2 logical volume(s) in volume group "ubuntu" now active
/scripts/local-top/cryptroot: line 1: can't open /dev/mapper/ubuntu-root: no such file
cryptsetup: sda5_crypt set up successfully

Paul Larson (pwlars) wrote :

Also, adding hid_logitech_dj and rebuilding the initramfs appears to have no effect

Steve Langasek (vorlon) wrote :

<slangasek> infinity: hid from initramfs, only on ARM, hardware-specific> this seems to me like something we can take as a target of opportunity rather than something that warrants a respin on its own
<slangasek> infinity: so I'm going to leave it in the queue and mark it on the pad, for now

This can be accepted if another member of the release team thinks it should be, or if there are other packages accepted before release that require a global respin.

Paul Larson (pwlars) wrote :

Here's the uInitrd from the boot partition of my mmc after adding hid_logitech_dj and updating the initramfs. I'm not seeing hid_logitech_dj in it, nor am I seeing usbhid. Is it not getting updated in the boot partition properly?

Adam Conrad (adconrad) wrote :

I just tested with my new initramfs-tools, and got hid-logitech-dj in the initrd as expected. Not entirely sure what you did over there, but you could test by installing my test packages:

http://lucifer.0c3.net/~adconrad/logitech/initramfs-tools-bin_0.103ubuntu0.2_armhf.deb
http://lucifer.0c3.net/~adconrad/logitech/initramfs-tools_0.103ubuntu0.2_all.deb

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.103ubuntu0.2

---------------
initramfs-tools (0.103ubuntu0.2) quantal; urgency=low

  * Add hid-logitech-dj to the static module list to re-enable some
    keyboards that stopped working with recent kernels (LP: #1066376)
 -- Adam Conrad <email address hidden> Tue, 16 Oct 2012 03:39:23 +0100

Changed in initramfs-tools (Ubuntu):
status: In Progress → Fix Released
Paul Larson (pwlars) wrote :

This is still broken with 20121017.1

Changed in initramfs-tools (Ubuntu):
status: Fix Released → Confirmed
Paul Larson (pwlars) wrote :

Here's the initrd from /boot. I also stripped the uInitrd and the resulting initrd cmps the same.
With generic usbhid keyboard attached:
$ lsusb
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 005: ID 125f:312b A-DATA Technology Co., Ltd. Superior S102 Pro
Bus 001 Device 004: ID 413c:2107 Dell Computer Corp.

$ lsmod
Module Size Used by
arc4 1417 2
wl12xx 12289 0
wlcore 157944 1 wl12xx
mac80211 510720 1 wlcore
cfg80211 201355 2 wlcore,mac80211
hid_generic 1074 0
usbhid 38447 0
hid 77532 2 hid_generic,usbhid
wlcore_sdio 3721 0
gpio_keys 8751 0
ext2 63835 1
xts 3528 2
gf128mul 9238 1 xts
dm_crypt 17097 1
usb_storage 36630 2
uas 8598 0

Paul Larson (pwlars) wrote :

dmesg, some warnings with backtrace on boot that seem related to encrypted partition, but not likely to be related to this

Paul Larson (pwlars) wrote :

I retried running update-initramfs -u, and it ran successfully, but there was still no keyboard driver in the initrd.
Also, confirmed that initramfs-tools installed is 0.103ubuntu0.2

Adam Conrad (adconrad) on 2012-11-06
description: updated

Hello Paul, or anyone else affected,

Accepted initramfs-tools into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/initramfs-tools/0.99ubuntu13.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in initramfs-tools (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed

Since a few kernels, I lost the ability to use my USB keyboard in initramfs (crypt setup prompt) while it works in grub's menu. I'm running the amd64 version of the *standard* Precise kernel (not a Quantal backport). Testing the -proposed initramfs-tools version 0.99ubuntu13.1 didn't help but this bug set me on the right track for a workaround. All I needed to do is to add the following to usbhid, hid and mac_hid to /etc/initramfs-tools/modules and update my initrd.

Should I open a new bug since my problem does not involve a Quantal kernel?

Adam Conrad (adconrad) wrote :

Simon, would you be willing to work with me and test some things? I suspect, from the names of your modules, that you're running on a Mac, and we may just need to add that one module (mac_hid) to the list.

Simon Déziel (sdeziel) wrote :

Adam, I'm running a Lenovo T410. I already added the mac_hid module to my initramfs and that fixed the issue on the Precise 3.2.0 kernel.

$ grep -v ^# /etc/initramfs-tools/modules

usbhid
hid
mac_hid

Few days ago, I moved to linux-image-3.5.0-23-generic and now with this Quantal kernel, the workaround doesn't work anymore.

Simon Déziel (sdeziel) wrote :

Adam, thanks for suggesting to look at this. I removed "mac_hid" and added "hid_generic" to the initramfs and it works perfectly with 3.5.0-23.

Adam Conrad (adconrad) wrote :

Alright, curious. So, on your hardware, you needed mac_hid on 3.2.0 and hid_generic (which the initramfs-tools from -proposed should do for you) on 3.5.0? Fun.

Adam Conrad (adconrad) wrote :

Hrm. In looking at the driver, mac_hid does look very Macintosh-specific. Perhaps that was a red herring and you didn't actually need it? Do you use IRC, this might be easier real time. :P

Adam Conrad (adconrad) wrote :

After some tag-team with Simon, we discovered that he'd probably installed in expert mode from d-i and intentionally selected a MODULES=dep setup, which was why he wasn't getting hid modules in his initrd. After we backed that out, we tested the new initramfs-tools on both precise and quantal kernels and his cryptsetup password prompts were accessible and working for him.

description: updated
tags: added: verification-done
removed: verification-needed
Changed in initramfs-tools (Ubuntu):
status: Confirmed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

This bug was fixed in the package initramfs-tools - 0.99ubuntu13.1

---------------
initramfs-tools (0.99ubuntu13.1) precise; urgency=low

  * Add hid-generic and hid-logitech-dj modules to the static list
    to fix keyboards with newer kernels (LP: #1066376, #1017991)
 -- Adam Conrad <email address hidden> Tue, 16 Oct 2012 03:49:16 +0100

Changed in initramfs-tools (Ubuntu Precise):
status: Fix Committed → Fix Released
Nec (nicolas-ecarnot) wrote :

Hi,

Sorry, but : I still have the same problem.

My laptop is a Dell Latitude E5510 with a docking station, running Xubuntu Quantal 64 bits, and it has external USB mouse and keyboard.
I'm using this same harware for a long time, and I upgraded every release since say 10.04 or before.
I never had any problem, but I payed closed attention to the following fact :

- When using a 3.4.0-030400rc6-generic kernel, everything was fine.
- Since updating to 3.5.0-17-generic, problems began.

I don't have any encrypted partition, I'm using Xubuntu, but googling around for a while lead me to say this is the same issue. I'm not an expert but I read something has changed with hid-generic, some naming or some module inclusion (...?...).

At every new kernel release, I installed them and tried them, but the symptoms are still the same :
At boot time, my mouse and my keyboard are OK in the bios setup and in grub.
After that, the kernel is booting and the system loading, but then, my keyboard and my mouse become non responsive :
- the laser of my mouse is on, but no cursor move
- the leds of my keyboard are on, but even switching on/off of caps lock is non responsive
Unplugging/plugging does not help. Even on other usb ports.

I'm using initramfs-tools version 0.103ubuntu0.2.
I tried to add things in /etc/initramfs-tools/modules
 :
hid_generic
hid-generic #I wasn't sure of the typo, I tried both
usbhid
hid
mac_hid

I have MODULES=most in initramfs.conf

Every time, I updated the initramfs this way :
update-initramfs -u -k 3.7.0-030700rc2-generic
as this is the last kernel I have so far.

Every reboot on this update kernel lead to the same end : no keyboard not mouse response.

So, until a workaround comes to work, I'm still stuck with a 3.4.0-030400rc6-generic kernel. Not that bad, but I was wondering what non-geek users would have done in my case.

I'd be very very glad to help experts to test any solution they would propose.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in base-installer (Ubuntu Precise):
status: New → Confirmed
Changed in base-installer (Ubuntu):
status: New → Confirmed
Adam Conrad (adconrad) wrote :

Nec, regarding comment 25, if your input devices work in grub, and then fail to work in a fully booted system, this isn't your bug. Please file one against the kernel (the package "linux") and try to provide as much detail as you can.

Patrick T. (patrickt) wrote :

I'm also having this problem with Ubuntu 13.10 (saucy) beginning with kernels after 3.10.0-6-generic #17-Ubuntu SMP Fri Jul 26 18:29:23 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux.
I tried manually loading the modules hid, hid_generic,usb_hid by modifying the script /usr/share/initramfs-tools/scripts/local-top/cryptroot and regenerating the initial ramdisk, but this didn't help. How could i further debug this?

ibob63 (james-tuthill) wrote :

I confirm that I am also having this bug. I am stuck on 3.8 kernel. Can I provide anymore information to help?

Felix Moreno (felix-justdust) wrote :

same problem here with ubuntu 13.10 not with 13.04

summary: keyboard doesn't work to enter password with panda and encrypted
- partitions
+ partitions ubuntu 13.10 saucy
summary: keyboard doesn't work to enter password with panda and encrypted
- partitions ubuntu 13.10 saucy
+ partitions ubuntu
Felix Moreno (felix-justdust) wrote :

If you have the same problem in ubuntu 13.10 please say it here to be abel to fix it asap, as much people confirms it better..
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1238194

Mahiar Mody (mahiarmody) wrote :

I agree. I installed Ubuntu 13.10 (Saucy Salamander) today using the "64-bit PC (AMD64) desktop image". I opted to erase everything on disk and do a fresh install.

During installation, I opted to encrypt the hard disk and also my home folder. The installation succeeded and I was prompted as usual to reboot.

However, after the reboot, my wireless keyboard was not detected and so could not enter the pass-phrase to continue booting Ubuntu.

Finally I reverted back to Ubuntu 13.04, which does not have this issue.

Randy Scarberry (drrandys) wrote :

I too, have the same problem with Ubuntu 13.10, so I'm having to reinstall 13.04. Well, Microsoft will be glad to see that they're not the only ones with extremely embarrassing goof ups. This is BAD considering that it's happened before.

I won't be "upgrading" Ubuntu again any time soon.

Rui Simoes (rms1979) wrote :

I have the same problem... any news?

josh1986 (josh1986) wrote :

Cant solve this problem with ubuntu 14.04, 14.10 and 15.04. I have 2 different microsoft usb keyboards and OS wont work with both of them

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers