Ubuntu

synaptic touchpad not recognized on dell latitude e6510

Reported by Karol Szkudlarek on 2010-07-16
842
This bug affects 155 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Arch Linux)
Fix Released
Medium
linux (Ubuntu)
Low
Dave Turvene
Precise
Undecided
Dave Turvene
Quantal
Low
Dave Turvene
openSUSE
New
Undecided
Dave Turvene

Bug Description

It wrongly recognized as PS/2 Generic Mouse. And then scrolling does not work, but tapping does.

ProblemType: Bug
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: karol 2618 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xe9660000 irq 22'
   Mixer name : 'IDT 92HD81B1C5'
   Components : 'HDA:111d76d5,1028040b,00100104'
   Controls : 26
   Simple ctrls : 16
Date: Fri Jul 16 13:36:04 2010
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=cdf10c13-029f-401b-afed-f651ca0e2cbe
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.2)
MachineType: Dell Inc. Latitude E6510
NonfreeKernelModules: nvidia
Package: linux-image-2.6.31-22-generic-pae 2.6.31-22.60
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-22-generic-pae root=UUID=2f511d08-c4e9-44e6-a1d2-5be6172b18c6 ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-22.60-generic-pae
RelatedPackageVersions:
 linux-backports-modules-2.6.31-22-generic-pae 2.6.31-22.24
 linux-firmware 1.26
SourcePackage: linux
Uname: Linux 2.6.31-22-generic-pae i686
dmi.bios.date: 05/28/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A03
dmi.board.name: 0N5KHN
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA03:bd05/28/2010:svnDellInc.:pnLatitudeE6510:pvr0001:rvnDellInc.:rn0N5KHN:rvrA00:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E6510
dmi.product.version: 0001
dmi.sys.vendor: Dell Inc.

chazn85 (chaz-n) on 2010-07-17
tags: added: kernel-input
Jeremy Foshee (jeremyfoshee) wrote :

Hi Karol,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete

Hi Jeremy!

I've tried those packages:

http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/current/linux-image-2.6.35-999-generic_2.6.35-999.201007211008_i386.deb

http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/current/linux-headers-2.6.35-999_2.6.35-999.201007211008_all.deb
http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/current/linux-headers-2.6.35-999-generic_2.6.35-999.201007211008_i386.deb

and I've installed them succesfully through dpkg -i *.deb. Afrer installing nvidia drivers recompiled succesfully.

But after reboot kernel during booting in text mode several time screen blinks and after switching to graphics mode its probably set wrong graphics mode because all screen messed up and X session not apperared properly... :-( It's doesn't hang, I could switch to text mode and back (via Ctrl-Alt-F1 Ctrl-Alt-F7), but I can't login to the system.

So I couldn't check touchpad without X.

tags: removed: needs-upstream-testing
Øyvind Stegard (oyvinst) wrote :

This is probably dupe of bug #550625

The problem is still not fixed in latest 2.6.35-rc6 kernel.

Steven (svanpoeck) wrote :

Hi Øyvind,

Actually I don't think it is. The touchpad on the Dell Latitude 6510 is not recognized as such but as a PS/2 Generic Mouse and I do not have a TouchPad section at all (see screenshot attached)

BR,
Steven

Steven (svanpoeck) wrote :

I've attached as much information as I could think of. please tell me if you need more/other information and how to retrieve it.

Thanks,
Steven

Steven (svanpoeck) wrote :
Steven (svanpoeck) wrote :
Steven (svanpoeck) wrote :
Steven (svanpoeck) wrote :
Steven (svanpoeck) wrote :
Steven (svanpoeck) wrote :
Steven (svanpoeck) wrote :
dbuell (dbuell-poundsquared) wrote :

is i386 a relevant tag? I'm having the same issue on a 64-bit Ubuntu install.

Steven (svanpoeck) wrote :

Mine is 64bit too

I have the same problem on a Hercules EC-800 (very cheap 8" notebook). Kernel 2.6.32-24-generic #39-Ubuntu (installed from xubuntu "lucid" 10.04). Ressources on this "machine" are low (20 GB hard drive, etc.), so testing is hard.

Changed in linux (Ubuntu):
status: Incomplete → New
Doug (doug-m) wrote :

Same problem here, touchpad is detected as PS/2 Generic Mouse. Biggest symptom is that it moves the cursor all the time when typing, makes it almost unusable to type on. 10.04 64bit

uname -s -r -v -i -o
Linux 2.6.32-24-generic #39-Ubuntu SMP Wed Jul 28 05:14:15 UTC 2010 unknown GNU/Linux

cat /proc/bus/input/devices
[...]
I: Bus=0011 Vendor=0002 Product=0001 Version=0000
N: Name="PS/2 Generic Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input15
U: Uniq=
H: Handlers=mouse2 event15
B: EV=7
B: KEY=70000 0 0 0 0
B: REL=3

xinput --list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ PS/2 Generic Mouse id=13 [slave pointer (2)]
⎜ ↳ Macintosh mouse button emulation id=14 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ Sleep Button id=9 [slave keyboard (3)]
    ↳ Laptop_Integrated_Webcam_3M id=10 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=12 [slave keyboard (3)]
    ↳ Dell WMI hotkeys id=15 [slave keyboard (3)]

Doug, I noticed similar problems on my Latitude e6510 with irritated cursor moves during pressing keyboard..., ubuntu 9.10 32bit

Remco vd Zon (theunknowncylon) wrote :

For a fix one may be interested in:
https://confluence.nau.edu/display/~<email address hidden>/Recognize+ALPS+Touchpad+on+Dell+E6510+in+Ubuntu

Steven (svanpoeck) wrote :

Hi Remco,

The suggested fix did have the touchpad recognized as such in "System>Preferences>Pointing devices" but when I select "Touchpad Off" from the select list it is not deactivated and it still interferes with typing text...

~$ uname -s -r -v -i -o -m
Linux 2.6.32-24-generic #41-Ubuntu SMP Thu Aug 19 01:38:40 UTC 2010 x86_64 unknown GNU/Linux

~$ cat /proc/bus/input/devices
[...]
I: Bus=0011 Vendor=0002 Product=0008 Version=0000
N: Name="DualPoint Stick"
P: Phys=isa0060/serio1/input1
S: Sysfs=/devices/platform/i8042/serio1/input/input14
U: Uniq=
H: Handlers=mouse2 event14
B: EV=7
B: KEY=70000 0 0 0 0
B: REL=3

I: Bus=0011 Vendor=0002 Product=0008 Version=7326
N: Name="AlpsPS/2 ALPS DualPoint TouchPad"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input15
U: Uniq=
H: Handlers=mouse3 event15
B: EV=f
B: KEY=420 70000 0 0 0 0
B: REL=3
B: ABS=1000003

~$ xinput --list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ MLK Trust Mouse 16536 id=10 [slave pointer (2)]
⎜ ↳ DualPoint Stick id=12 [slave pointer (2)]
⎜ ↳ Macintosh mouse button emulation id=14 [slave pointer (2)]
⎜ ↳ AlpsPS/2 ALPS DualPoint TouchPad id=13 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ Sleep Button id=9 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=11 [slave keyboard (3)]
    ↳ Dell WMI hotkeys id=15 [slave keyboard (3)]

The same like Steven said... after the applied Remco psmouse patch touchpad is recognized:

cat /proc/bus/input/devices

I: Bus=0011 Vendor=0002 Product=0008 Version=0000
N: Name="DualPoint Stick"
P: Phys=isa0060/serio1/input1
S: Sysfs=/devices/platform/i8042/serio1/input/input14
U: Uniq=
H: Handlers=mouse1 event14
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3

I: Bus=0011 Vendor=0002 Product=0008 Version=7326
N: Name="AlpsPS/2 ALPS DualPoint TouchPad"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input15
U: Uniq=
H: Handlers=mouse2 event15
B: EV=f
B: KEY=420 0 70000 0 0 0 0 0 0 0 0
B: REL=3
B: ABS=1000003

and

$ uname -a
Linux karolszk-lap 2.6.31-22-generic-pae #63-Ubuntu SMP Wed Aug 18 23:57:18 UTC 2010 i686 GNU/Linux

Julien Cornuwel (cornuwel) wrote :

I've got the same problem with lucid amd64, on a Latitude E6510.
Both default kernel (2.6.32-24.41) and 2.6.36-999.201008301119 have the problem.

The link to the fix is currently down, I'll try again later.

Guru R (rguru76) wrote :

Same problem with me too.

I have Latitude E6510 & E6500 both have identical issues,

uname -a
Linux rgururaj 2.6.32-24-generic #42-Ubuntu SMP Fri Aug 20 14:24:04 UTC 2010 i686 GNU/Linux

cat /proc/bus/input/devices
I: Bus=0011 Vendor=0002 Product=0001 Version=0000
N: Name="PS/2 Generic Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input13
U: Uniq=
H: Handlers=mouse1 event13
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3

crazydave (crazy-dave) wrote :

Touchpad is working on my e6510 except for the scrolling fields.
The message "name of the touchpad device not..." shows up in the KDE System Settings.
Kubuntu 10.4.

2.6.32-24-generic #39-Ubuntu

hickwillie (hickwillie) wrote :

Same problem for me (E6510):

uname -a
Linux chrisj-laptop-linny 2.6.32-24-generic #42-Ubuntu SMP Fri Aug 20 14:21:58 UTC 2010 x86_64 GNU/Linux

cat /proc/bus/input/devices
I: Bus=0011 Vendor=0002 Product=0001 Version=0000
N: Name="PS/2 Generic Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input14
U: Uniq=
H: Handlers=mouse1 event14
B: EV=7
B: KEY=70000 0 0 0 0
B: REL=3

Steven (svanpoeck) wrote :

Hi,

I actually want to *deactivate* the touchpad. I prefer working with the pointer in the middle of the keyboard. But even though Remco's workaround gets the touchpad recognized I cannot deactivate it and it still interferes with typing.

Steven

uname -s -r -v -i -o -m
Linux 2.6.32-24-generic #42-Ubuntu SMP Fri Aug 20 14:21:58 UTC 2010 x86_64 unknown GNU/Linux

Jordi Adame (jordi-adame) wrote :

if you want to enable/disable the touchpad

Steven (svanpoeck) wrote :

Thanks Jordi.

But that also disables the pointer in the middle of the keyboard... Is there a way to identify the touchpad and the keyboard pointer as 2 different devices and then only disable the touchpad ?

Steven

uname -s -r -v -i -o -m
Linux 2.6.32-24-generic #43-Ubuntu SMP Thu Sep 16 14:58:24 UTC 2010 x86_64 unknown GNU/Linux

Jordi Adame (jordi-adame) wrote :

Steven, no, both are physically in the same cable

Steven (svanpoeck) wrote :

Well Jordi it actually helps me a lot already: when I have an external mouse plugged in, I simply run your script (using bash though ;) ) and voilà! no more typing freakness :D

It remains of course when I don't have an external mouse.

So: thanks :)
Steven

Jordi Adame (jordi-adame) wrote :

Steven, I have Win+F7 binded to that script, that way i can easily enable/disable the touchpad

Simon Dierl (simon.dierl) wrote :

#550625 addresses a slightly different type of hardware; the touchpad in question is identified as Product=0005 at /proc/bus/input/devices (ImPS/2 Generic Wheel Mouse). The touchpad in an E6510 reports Product=0001 (PS/2 Generic Mouse).
However, the root cause appears to be described at https://bugzilla.kernel.org/show_bug.cgi?id=14660 - apparently, newer ALPS touchpads use a new, undocumented and unsupported protocol. The touchpad falls back to a legacy emulation mode, resulting in faulty detections.
The kernel.org bug lists some efforts to reverse-engineer the protocol and has some patches based on DELL contributions that enable ImPS/2 emulation (scrolling works). This, however, still does not allow for synaptics support (turn off when typing, horizontal scroll, etc.). Additionally, some people report problems on suspend/resume.
The hardware detection used by the DELL patch in alps.c is:
{ { 0x73, 0x02, 0x64 }, 0x00, 0x00, ALPS_EC_PROTO }, /* Dell E2 series multitouch */
ALPS_EC_PROTO denotes a device memory access protocol used by the pads for initialization. It seems that this issue might affect all DELL E2 notebooks.

Guru R (rguru76) wrote :

Thanks Simon! at least we know someone's working on this bug. My primary issue is that the touchpad does not turn off during typing. Hope to see a solution/workaround soon.

Guru R (rguru76) wrote :

Thanks Jordi for the script. I will use your script as a workaround till a fix is found. Just tested it works great.

tags: removed: i386

Jordi, thanks for the script! After little modifications to xinput for 9.10 ubuntu the script works well. I don't know why xinput have such different syntax beetwen 9.10 and 10.04... I attached script for enable/disable touchpad for 9.10.

I can confirm that this problem also appear for the Dell E5510 laptops.

I agree with Simon Dierl that this is not the same issue as #550625 (I also get Product 0x1) even though some persons with this problem has posted at that thread.

aa-hcl (aa476) wrote :

Many thanks for the sh script!!! It is really useful!!!

I have Dell E5510 with ubuntu 10.04 and I can confirm that I have exactly the same issues with my touchpad.

Regarding the bug: It is interesting that touchpad is actually recognised by old kernel versions, see
http://ubuntuforums.org/showthread.php?p=9871231

It would be really lovely is this touchpad problem is solved in new kernel versions. Meanwhile, I am using external mouse and the toggleps2.sh with the shortcut (I also changed zsh to bash int eh script).

Another question - do you know actually how to make the SD card reader working on E5510?

Many thanks!

Brad Figg (brad-figg) on 2010-12-03
tags: added: acpi-bad-address
Grzegorz Ciołek (ciolekg) wrote :

Hi,

I have E6410 and Ubuntu 10.10 kernel 2.6.35-24-generic #42-Ubuntu SMP Thu Dec 2 02:41:37 UTC 2010 x86_64 GNU/Linux

So far I have found this:
https://patchwork.kernel.org/patch/350841/
I assume it is the best option so far. I am totally new with patching. Could anyone tell me if this patch will work in Ubuntu ?
If yes, how to apply this patch (step by step guide is preferred ;-) ?

Cheers
Grzesiek

gcla (grclark) wrote :

I've attached a sloppy python program inspired by Jordi's handy script. It disables the touchpad as soon as it detects keyboard activity, then a fraction of a second after the end of the keyboard activity, it re-enables the touchpad. I have an E6510 running Ubuntu 10.10 on x64, and I run the script like this:

$ sudo ./keyboarddetector.py /dev/input/event4

If you're running on x86, you might need to tweak the line containing "calcsize". It could be cleaned up to figure out automatically which of the event* entries to use.

Graham

Philip Aston (philipa) wrote :

Here's a refined version of the script.

    - Auto detect keyboard and trackpoint devices.
    - Auto detect 32-bit/64-bit processors.
    - Don't disable trackpoint for modifier keys.

The last one is important to allow modifier keys to be used in conjunction with the mouse, e.g. "control select".

Changed in linux (Ubuntu):
status: New → Confirmed
Ed S (ed-spittles) on 2011-10-22
summary: - synaptic touchpad not recognized on dell latitude e6510
+ synaptic touchpad not recognized on dell latitude e6510 and others
Changed in linux (Ubuntu):
milestone: none → ubuntu-12.04
status: Confirmed → Triaged
status: Triaged → In Progress
importance: Undecided → Low
tags: added: blocks-hwcert-enablement
Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in linux (Arch Linux):
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in linux:
status: Confirmed → Fix Released
Changed in linux (Arch Linux):
status: Confirmed → Fix Released
Changed in linux (Ubuntu Precise):
status: New → Confirmed
Florin9doi (florin9doi) on 2012-09-26
Changed in linux (Ubuntu Precise):
assignee: nobody → Florin9doi (florin9doi)
status: Confirmed → Fix Released
Florin9doi (florin9doi) on 2012-09-26
Changed in linux (Ubuntu Precise):
assignee: Florin9doi (florin9doi) → nobody
Dave Turvene (dturvene) on 2012-09-28
Changed in linux (Ubuntu Precise):
assignee: nobody → Dave Turvene (dturvene)
Dave Turvene (dturvene) on 2012-10-25
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
assignee: nobody → Dave Turvene (dturvene)
tags: added: patch
Dave Turvene (dturvene) on 2013-01-26
Changed in linux (Ubuntu):
status: Fix Committed → In Progress
Changed in linux (Ubuntu Quantal):
assignee: nobody → Dave Turvene (dturvene)
294 comments hidden view all 374 comments

Just to say: thank you!
The touchpad now works better on my dell latitude E6230.

I can scroll on the edge and the "circular scroll" also works. The two fingers scroll and right-click isn't easy, but the touchpad isn't so wide. I haven't get for now the three fingers middle click … but it doesn't matter for me.
The more important was the scroll gesture.

Thank you again :-)

Download full text (3.3 KiB)

Kevin -

Responses inline

On 02/18/2013 05:07 PM, Kevin Cernekee wrote:
> Just so we're on the same page - the "input-next" tree [1] (input.git,
> branch "next") is Dmitry's staging area for proposed input subsystem
> changes to send to Linus for the next merge window - currently targeting
> Linux 3.9. My patches 01-13 are in there now. This includes the code
> refactoring + Rushmore support, but no Dolphin support.
Good to know; I wondered how the roll-up works.
>
> This past weekend I submitted three more patches [2] to be applied on
> top of input-next:
>
> 1) Remove unused argument to alps_enter_command_mode() - trivial cleanup
>
> 2) Dolphin V1 support, credited to Dave/florin. This is believed to be
> in working order, and ready to merge.
>
> 3) Dolphin V2 support, consisting of my new init + detection sequence.
> This was marked as WIP because the pressure readings at the edge of the
> touchpad are still "off." I am hoping somebody with access to this
> hardware can help figure out why. Maybe switching to the V2-native
> report format (and writing a new decoder for it) would help, since that
> is what the ALPS drivers seem to prefer.
Great! I dump a lot of email lists, including linux-input, on my server
and only periodically check them. I just saw your three-part
submission. The code looks good. I'll post a new comment on the 606238
bug thread about my understanding of your progress - just to avoid
confusion.
>
>
> "It doesn't make sense to me for ALPS to create different touchpad layout using the same signature; more likely is the laptop exposes an area of the touchpad based on the available real estate."
>
> It appears that the driver can query the Dolphin V2 touchpads for their
> specs, and adjust the operating parameters accordingly.
>
> Unfortunately I don't know much about how this works, or what range of
> values we can expect to see in the wild.
>
> As for Rushmore, I can confirm that the touchpad dimensions and
> trackstick/buttons differ between Dell E6230/E6430, even though the IDs
> are the same. I haven't actually taken the laptops apart to see how
> they contrast physically. Doing so might shed light on how ALPS manages
> product variants.
Good to know but I'm unclear how to proceed. Back when, I put in a
sysfs debug interface that a user could run to capture the physical
coordinates of the edges in order to tune the X edge properties. I
could take your patches, add the debug and release a new dkms.
>
>
> "Update ./Documentation/input/alps.txt with details on the new variants."
>
> That's a great idea, and it's something I've been neglecting.
I'll update alps.txt tonight and submit to linux-input
>
> One other thing that might be worthwhile is to see how much (if any) of
> the refactored V3 code can be used for the V4 touchpads. There are many
> similarities between the two protocols.
I agree there are a lot of similarities but some differences as well.
For example, V3 uses byte 4 for x/y coordinates and byte 3 for buttons;
V4 uses byte 3 for x/y coordinates and byte 4 for buttons. This could
take a little bit of time to refactor. I'm backed up on several other
projects so I need to move on.
...

Read more...

Dave Turvene (dturvene) on 2013-02-27
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Quantal):
status: In Progress → Fix Committed
Changed in opensuse:
assignee: nobody → Dave Turvene (dturvene)

Just for the record, I'm on a Dell Latitude e6430u running Ubuntu 12.10 (Quantal) and this issue affects me.

Matt (f-launchpad-net) wrote :

Hi, what's the lead time from fixes getting committed until they arrive via the usual package updates?
I have an old Dell Inspiron 8200 that I'm trying to setup and the touchpad doesn't work at all, I think it's detected as PS2 Mouse.

I think this will probably fix it or should I submit a separate bug report with all the info?
Thanks for all the work on this.

Dave Turvene (dturvene) wrote :

@matt
I noticed that Kevin's patches were accepted for the next 3.7 kernel release.

I also noticed that a fedora maintainer backported Kevin's patches to the next Fedora release. See https://bugzilla.redhat.com/show_bug.cgi?id=812111

I have not seen any activity by Ubuntu maintainers to backport the patches, so I doubt they will be integrated into the Ubuntu train any time soon.

You can test it yourself by installing the psmouse-alps-1.3-alt.tbz attachment (see the "Bug Attachments" sidebar)

Miguel Ramiro (mike.longbow) wrote :

I can confirm that the patch contained in the psmouse-alps-1.3-alt.tbz attachment works on my Dell Vostro 3360. I get a behavior similar to what I got with the version I was using before (alps-dst-0.4, by Dave): still no edge-scrolling, and random choppyness, as if the touchpad skips some input frames (though that last one might only be my imagination, I must give it some time to confirm).

Also, I would like to note that the alps-1.3 version at http://www.dahetral.com/public-download/psmouse-alps-1.3.tbz/view does not work on my machine. Only the version in the attachment here does.

Regards.

Paul Swanson (paul-swanson) wrote :

Hi Dave, thanks also for all of your work.

How would, or is it ever likely, that this fix will make it into Quantal?

There's got to be a huge number of Ubuntu users out there with Dell laptops that could do with this functionality.

Is there anything we can do to petition the Ubuntu maintainers on this?

Thanks again.

I also confirmed that like Miguel, the patch psmouse-alps-1.3-alt.tbz partially works on my Dell Inspiron 13z. My touchpad that is previously recognized as PS/2 Generic Mouse is now recognized as AlpsPS/2 ALPS GlidePoint. I can finally disable mouse click by tapping while typing. However, like Miguel's case, there is no edge scrolling and random choppyness. It especially happens when I press the touchpad very lightly.

wgroiss (wolfgang-groiss-gmx) wrote :

I'm on a Dell Latitude E5530 running Ubuntu 13.04 (Raring Ringtail, Beta1) and this issue affects me on Kernel 3.8, too.

"Linux Dell-Latitude-E5530 3.8.0-13-generic #22-Ubuntu SMP Fri Mar 15 17:51:30 UTC 2013 i686 i686 i686 GNU/Linux."

I tried to fix it with #299:
I took ppa from quantal, made
apt-get update

and got this error:

Traceback (most recent call last):
  File "/usr/share/apport/package-hooks/dkms_packages.py", line 22, in <module>
    import apport
ImportError: No module named apport
Error! Bad return status for module build on kernel: 3.8.0-13-generic (i686)
Consult /var/lib/dkms/psmouse/3.5.0/build/make.log for more information.
....
root@Dell-Latitude-E5530:~#

Kevin Cernekee (cernekee) wrote :

"ImportError: No module named apport"

Try: sudo apt-get install python-apport

It is possible that some of the DKMS packages posted in this thread will need tweaking to build against Linux 3.8.

wgroiss (wolfgang-groiss-gmx) wrote :

Now the touchpad works!

I think, it was not the
******
sudo apt-get install python-apport
******
because i got an error.
But it i think, the fix was a newer kernel, which i got with ubuntu rairing update:
******
Linux Dell-Latitude-E5530 3.8.0-14-generic #24-Ubuntu SMP Fri Mar 22 19:21:28 UTC 2013 i686 i686 i686 GNU/Linux
******
Now I can see the Alps Touchpad and scrolling does work!

wolfgang@Dell-Latitude-E5530:~$ xinput
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ DualPoint Stick id=12 [slave pointer (2)]
⎜ ↳ AlpsPS/2 ALPS GlidePoint id=13 [slave pointer (2)]

lee bondam (libondam-0) wrote :

First of all: thanks for the work guys

I am on Dell Latitude XT
Alps hardware: touchpad, 4 buttons, 1 stick
Touchpad is detected as PS2 mouse, synapticts not loaded.
Touchpad works (tapping/moving), but not very sensitive cq. delays, buttons an stick work
The insensitivity / delays made me look for changing the setup.
And that made me aware of the synaptics issue.
(I never use scrolling so had not noticed anything missing ...).
Installed Os's:
wheezy 3.2.0-4-amd64 / xubuntu 3.2.0-40-generic / XP .
Downloaded psmouse-alps-1.3 from http://dahetral.com/public-download.
Unfortunately, there is no support for Dell Latitude XT.
Found an old mail exchange (2009) from Dmitry Torokhov.
This gave me a clue as what to try.

Added the following line to alps_model_data[]
       { { 0x73, 0x00, 0x14 }, 0x00, ALPS_PROTO_V2, 0xf8, 0xf8, ALPS_DUALPOINT | ALPS_FW_BK_2 }, /* Dell Latitude XT */

resulting dmesg:
psmouse serio1: alps: E6 report: 00 00 64
psmouse serio1: alps: E7 report: 73 00 14
psmouse serio1: alps: EC report: 10 00 64
psmouse serio1: alps: ALPS: E7=73 00 14, EC=10 00 64
psmouse serio1: alps: Model: proto=2 command_mode_byte3=00
psmouse serio1: alps: E6 report: 00 00 64
psmouse serio1: alps: E7 report: 73 00 14
psmouse serio1: alps: EC report: 10 00 64
psmouse serio1: alps: ALPS: E7=73 00 14, EC=10 00 64
psmouse serio1: alps: Model: proto=2 command_mode_byte3=00
psmouse serio1: alps: F5 report: 73 00 14
input: DualPoint Stick as /devices/platform/i8042/serio1/input/input10
input: AlpsPS/2 ALPS DualPoint TouchPad as /devices/platform/i8042/serio1/input/input11

Touchpad recognized, tapping works, scrolling works, buttons work.
The stick however goes haywire, sending random click events when touched.
This is in both xubuntu and wheezy
In wheezy I had to enable tapping, in xubuntu tapping worked 'out of the box'

My questions:
What is the status of Latitude XT support in alps.c ?
Can I help ?
Where to put these questions ?

I am pretty comfortable with linux and C
I also have win XP with latest Dell Alps driver on this laptop
(must say, I am not a happy windows hacker but can do ...)

Lee

Dave Turvene (dturvene) wrote :

@libondom-0

My guess is this is another mutation of the ALPS touchpad. It clearly is a new signature, which you added, which indicates new behavior: the trackstick. There have been several new significant behaviors added to the alps driver ("Rushmore" and "Dolphin").

The best I can recommend, not having this touchpad (and it's an n:m mapping between Dell system and Alps touchpad), is to add code to the driver to dump the trackstick changes and then try to reverse engineer what the movement codes actually mean. See the alps_process_packet_v1_v2 routine.

BTW, I experienced similar upheaval in the late 1980's as a customer to a company called Newbridge. Its staff was turning over so quickly that relative newbies were the sole support for some of their hardware and just hacked it up to get it to work regardless of documentation or compatibility. They released M$ drivers to support the new firmware but Unix boxes (we were a SUN shop) were left hanging. Newbridge and SUN no longer exist; I think this bodes poorly for ALPS.

Dave

lee bondam (libondam-0) wrote :

Hi Dave
Glad to see you are monitoring.
What/where is the best way to communicate about this?

The problem at hand:
It comes down to reverse engineering then.
The mail exchange from Dmitry Torokhov I mentioned was about Latitude XT
So some (reverse) engineering has been going on.
I have read some posts of people doing this with Virtualbox.
Must go backtrack a bit here.
Do you have any idea if there is anything of the sort going on upstream?
I do not want to invent the (mouse)wheel, but if nothing is happening,
I will have a go.
Looks a bit like a can of worms to me, but hey, I believe I like to make things work.
Would appreciate suggestions/tips as to how to go about.
Like using real or virtual XP
I use kvm/qemu here, and touchpad support would have to be added I think.
And then, how much do I have to know about win XP?

will keep posting here for now
Lee

lee bondam (libondam-0) wrote :

On second thought, do I need XP?
The touchpad is already recognized an handled by synaptics.
So all can be done in alps.c no?
Reverse engineer the event readings from 'cat /dev/input/mouseN'
On the right track here?

Lee

lee bondam (libondam-0) wrote :

on third thought
>>add code to the driver to dump trackstick changes'
i am there now
bit slow in pickin up ...
laters
lee

Dave Turvene (dturvene) wrote :

@libondam-0

Response to comments 348, 349, 350:

The easiest, and I mean *easiest*, way is to hack alps.c for the raw input from the touchpad and then "xinput setprop" to tune the X11 cooked input.

For brand-new alps touchpads that don't adhere to any of the known protocols, this is not sufficient and one needs to reverse engineer the Windows driver behavior. Seth Forshee showed us the way and then Ben Garami figured out the the new extensions. I seriously doubt this will be the case for you.

Use Virtualbox or Qemu to create a guest OS. I used Vista. Seth showed how to patch the I/O layer to dump the bytes going between the guest driver and the hardware. The catch is that the new alps drivers check the BIOS ACPI DSDT tables to make sure it's an ALPS hardware module; if not it drops into 3-byte PS2 mode. Therefore the virtual ACPI DSDT table must be updated to use the Hardware ID (HID) for the alps hardware model (taken from the real ACPI DSDT table.) If this sounds a little complicated, it is. Make sure you install the Alps driver into the guest OS!

In the alps.sh from the 1.3 DLKM, there are some helper routines to get the real DSDT and patch the qemu acpi-dsdt.dsl table for the correct HID.

There is another way to reverse engineer an ALPS touchpad, discovered by Kevin Cernekee but it's not totally reliable. It worked for him, and cleaned up the E6430 code a good deal. Email Kevin directly for how to do it.

Dave

When I upgraded my N5110 to the raring ringtail beta last week, the touchpad was no longer recognized. I believe I had the 0.4 version installed. I uninstalled and removed all of the existing DKMS entries and installed the 1.3 version downloaded from http://www.dahetral.com/public-download but the touchpad is still not recognized.

Has anyone been successful on an N5110 with this kernel? Any suggestions, or any tests I can perform to help resolve this?

Some potentially helpful info:

uname -a:
Linux rbmlaptop 3.8.0-17-generic #27-Ubuntu SMP Sun Apr 7 19:39:35 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Some lines from dmesg:
[ 8.279185] psmouse serio1: alps: E6 report: 00 00 64
[ 8.298297] psmouse serio1: alps: E7 report: 73 03 50
[ 8.316631] psmouse serio1: alps: EC report: 73 02 02
[ 8.319620] psmouse serio1: alps: ALPS: E7=73 03 50, EC=73 02 02
[ 8.319626] psmouse serio1: alps: Unknown ALPS touchpad: E7=73 03 50, EC=73 02 02

xinput:
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ PS/2 Generic Mouse id=12 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ Sleep Button id=9 [slave keyboard (3)]
    ↳ Laptop_Integrated_Webcam_HD id=10 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=11 [slave keyboard (3)]
    ↳ Dell WMI hotkeys id=13 [slave keyboard (3)]

dkms status:
psmouse, alps-1.3, 3.8.0-17-generic, x86_64: installed

Installing http://dahetral.com/public-download/psmouse-alps-dst-1.2.tbz/view worked for me.

Download into /usr/src, run
./alps.sh dkms_install_symlink
and then
 ./alps.sh dkms_build_alps

Dell latitude e5430, cat /proc/bus/input/devices says I: Bus=0011 Vendor=0002 Product=0008 Version=0000

This is 12.10

lee bondam (libondam-0) wrote :

@Dave

response to #351

Sorry, I missed your documentation in the alps-1.3 directory,
I had just compiled the psmouse module without any script.
After reading, I'll be a while I guess.
Complicated indeed.
Keep you posted.
Thanks.

Lee

Dave Turvene (dturvene) wrote :

Greetings -

I have received a number of emails about running the our dlkms on a 3.5+ kernel. Kevin Cernekee made the required API changes and added it as an attachment to this issue. I have copied his tarball to my public area at:

https://www.dahetral.com/public-download/psmouse-alps-1.3-alt.tbz/view

Dave

Sorry -

Kevin did a lot of work on the driver and then uploaded as an issue
attachment. I just uploaded his tarball to
http://www.dahetral.com/public-download.

No one has reported anything negative about the new driver and it has
been accepted to the linux kernel.

Dave

On 04/19/2013 11:26 AM, Richard Merren wrote:
> When I upgraded my N5110 to the raring ringtail beta last week, the
> touchpad was no longer recognized. I believe I had the 0.4 version
> installed. I uninstalled and removed all of the existing DKMS entries
> and installed the 1.3 version downloaded from http://www.dahetral.com
> /public-download but the touchpad is still not recognized.
>
> Has anyone been successful on an N5110 with this kernel? Any
> suggestions, or any tests I can perform to help resolve this?
>
> Some potentially helpful info:
>
> uname -a:
> Linux rbmlaptop 3.8.0-17-generic #27-Ubuntu SMP Sun Apr 7 19:39:35 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
>
> Some lines from dmesg:
> [ 8.279185] psmouse serio1: alps: E6 report: 00 00 64
> [ 8.298297] psmouse serio1: alps: E7 report: 73 03 50
> [ 8.316631] psmouse serio1: alps: EC report: 73 02 02
> [ 8.319620] psmouse serio1: alps: ALPS: E7=73 03 50, EC=73 02 02
> [ 8.319626] psmouse serio1: alps: Unknown ALPS touchpad: E7=73 03 50, EC=73 02 02
>
> xinput:
> ⎡ Virtual core pointer id=2 [master pointer (3)]
> ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
> ⎜ ↳ PS/2 Generic Mouse id=12 [slave pointer (2)]
> ⎣ Virtual core keyboard id=3 [master keyboard (2)]
> ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
> ↳ Power Button id=6 [slave keyboard (3)]
> ↳ Video Bus id=7 [slave keyboard (3)]
> ↳ Power Button id=8 [slave keyboard (3)]
> ↳ Sleep Button id=9 [slave keyboard (3)]
> ↳ Laptop_Integrated_Webcam_HD id=10 [slave keyboard (3)]
> ↳ AT Translated Set 2 keyboard id=11 [slave keyboard (3)]
> ↳ Dell WMI hotkeys id=13 [slave keyboard (3)]
>
> dkms status:
> psmouse, alps-1.3, 3.8.0-17-generic, x86_64: installed
>

The code version from comment #356 fixed my problems mentioned in comment #352. It works with Raring on the 3.8 kernel. I'm very happy because reverting to the supersensitive, nonscrolling touchpad I had before you wrote this driver was pretty unbearable. Thanks again for all of your work on this.

When you say it has been accepted to the linux kernel, do you mean to say that at some point this will work out-of-the-box without installing the driver with DKMS?

riu (stanray) wrote :

On Fujitsu LB AH532, after installing the driver I have both psmouse and ALPS touchpad active. I have only touchpad. Vertical scroll works in very narrow area on the right of the touchpad. Mouse and Touchpad have duplicate settings in the "Mouse and Touchpad" dialog: pointer acceleration and sensitivity. Is it intentional or anything wrong with my system?

xinput --list:

⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ PS/2 Mouse id=11 [slave pointer (2)]
⎜ ↳ AlpsPS/2 ALPS GlidePoint id=12 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ FJ Camera id=9 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=10 [slave keyboard (3)]

riu (stanray) wrote :

Hardware info on previos comment (comment #358) can be found in Bug #1041916 (“Touchpad of Fujitsu LifeBook AH532 not recognized” : Bugs : “xserver-xorg-input-synaptics” package : Ubuntu).

I have Ubuntu 12.04 with 3.5.0 kernel and xserver-xorg-input-synaptics-lts-quantal.

Masoud Pourmoosa (amirmasoud) wrote :

I am running Ubuntu 13.04 on a Dell Latitude E6430u, and my touchpad is recognized by default. Two-finger scrolling works. Pinch-to-zoom also works in e.g. Eye of GNOME (but not in Firefox/Chromium). It's great that the driver has been backported.

Kevin Cernekee (cernekee) wrote :

Now that Linux 3.9 is making its way into circulation, let's summarize the reported issues to date:

1) No Dolphin V2 support. Still need to borrow hardware to fully understand the report format and make edge scrolling work without excessive pressure. I believe we have a good init sequence.

2) Resync errors:

[1766509.702598] psmouse serio1: DualPoint TouchPad at isa0060/serio1/input0 lost sync at byte 6
[1766509.712794] psmouse serio1: DualPoint TouchPad at isa0060/serio1/input0 - driver resynced.
[1766509.722987] psmouse serio1: DualPoint TouchPad at isa0060/serio1/input0 lost sync at byte 6
[1766509.733151] psmouse serio1: DualPoint TouchPad at isa0060/serio1/input0 - driver resynced.
[1766509.743293] psmouse serio1: DualPoint TouchPad at isa0060/serio1/input0 lost sync at byte 6
[1766509.753533] psmouse serio1: DualPoint TouchPad at isa0060/serio1/input0 - driver resynced.

I see these pop up in dmesg every week or two; they run for maybe a minute or so and then vanish, with no obvious ill effects. Not sure how to reproduce them.

3) Click-and-drag (e.g. selecting text in an xterm) suddenly quits working. I've only seen this happen once. Unloading and reloading psmouse.ko fixed it. This problem mystifies me because when I ran xev, I still saw all of the proper events coming from the input device. So maybe it was caused by something higher in the stack.

4) Tap-to-click is broken on Rushmore[1]. Root cause: when transitioning from Linux 3.8 (touchpad detected as generic PS/2 mouse) to 3.9 (touchpad detected as an ALPS touchpad), tap-to-click in the pointer settings may need to be enabled by hand. If the touchpad is detected as a generic PS/2 mouse, tap-to-click will work regardless of this setting.

5) Pointer jumps all over the screen after suspend/resume on a Rushmore touchpad. Seen once, cannot reproduce.

6) "Noisy" X/Y values on Rushmore[2]. Reporter is investigating whether this shows up on other drivers. Three possibilities include: i) it's noisy everywhere, even in Windows; ii) the input data is noisy, and the driver needs to clean it up; or iii) the other drivers get "clean" report data but we're using a bad init sequence so our report data is sketchy.

Any hints on reproducing #2, #3, or #5 would be appreciated.

[1] http://www.spinics.net/lists/linux-input/msg25813.html
[2] http://www.spinics.net/lists/linux-input/msg25787.html

Chris Diamand (chuis) wrote :

Hi all,

I have a Dell Vostro 3360 with a 'Dolphin V2' touchpad, running linux 3.10-rc1 (latest from git).
I have been using the psmouse-alps-1.3-alt.tbz driver, works fine (touchpad detected, multitouch, not too jumpy) except for edge scrolling (but I don't care about that because two-finger scrolling works).

I had to make a few changes to build it against the latest kernel tree though, and instead of doing the DKMS thing I just copied alps.c into drivers/input/mouse/alps.c then rebuilt the kernel. Attached is a patch which applies the 1.3-alt code to linux 3.10.

Is it possible to get this V2 support mainlined? This patch works fine for me, but I'd be happy to provide any data/have a go at mild hacking required to fix other issues (edge scrolling) if that is needed to get the driver upstream.

The work so far is great, thanks to everyone involved.

Cheers!
Chris

Erno Kuusela (erno-iki) wrote :

On Dells this has been worked on and at bug 1089413, you can find fix status for different Ubuntu versions there.

Chris Diamand (chuis) wrote :

Hi,

It has been fixed for 'Dolphin V1' touchpads - the driver is upstream so they are fine.

The problem is that 'Doplhin V2' touchpads don't yet work - although a driver has been written (it's in the DKMS module and works great), it hasn't yet been pushed to the mainline kernel.

It would be great if 'V2' support was mainlined too.

Apologies, I didn't really say this very clearly in my first comment.

Cheers!

1 comments hidden view all 374 comments
Po-Hsu Lin (cypressyew) wrote :

Also affects:
201205-11042 Dell Precision M6700 (AlpsPS/2 ALPS DualPoint Touchpad)
And it could be solved by updating the system.

Bráulio (brauliobo) wrote :

affects me: dell vostro 3460. following http://askubuntu.com/questions/50491/detect-touchpad-as-touchpad/258513#258513 did made it work.

a package for this is being prepared?

PasKalou (pascal-padilla) wrote :

with Vostro 3360 a have the same pb.

http://askubuntu.com/questions/50491/detect-touchpad-as-touchpad/258513#258513 is good to me too

Anthony Wong (anthonywong) wrote :

Bráulio, which release are you using?

David Bailey (djb211) wrote :

I installed the package on my Fujitsu Lifebook and it is almost unusable - the touchpad fails to detect small touches (i.e. detects only a flat finger, not the fingertip); the x/y values are way off (y movement much faster than x, which is very sluggish). Multitouch features work though and ubuntu detects the touchpad as such.

Karol Szkudlarek, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

If reproducible, could you also please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc5

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
milestone: ubuntu-12.04 → ubuntu-14.04-feature-freeze
status: Fix Committed → Incomplete
summary: - synaptic touchpad not recognized on dell latitude e6510 and others
+ synaptic touchpad not recognized on dell latitude e6510
Changed in linux (Ubuntu Quantal):
milestone: ubuntu-12.04 → none
wgroiss (wolfgang-groiss-gmx) wrote :

Thank You, Christopher for reminding!
I had the same problem (see above): For me it's solved since Ubuntu 13.10.
I use now kernel 3.11.0-15.
Touchpad works fine. In settings i can choose between
- Scroll with 2 fingers and
- natural scroll
=> both works!
=> for me the bug is fixed!

Kalle Elmér (kalle-d) wrote :

I'm using the psmouse driver on a Dell Inspiron 17R SE and it makes the touchpad work as an actual touchpad and not just a mouse. However, I'm experiencing a significant amount of backlash. By this, I mean that when reversing the direction of movement the cursor will remain still for some time before it actually moves again. The behavior is very similar to the mechanical concept of backlash, which is nicely explained in this Wikipedia article:
http://en.wikipedia.org/wiki/Backlash_%28engineering%29

Could this be a flaw in the driver or in some other part of the software system? Is it just a property of my hardware? I have noticed the exact same behavior on a Fujitsu Lifebook with an ALPS touchpad that also works with this driver.

Kalle Elmér, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Displaying first 40 and last 40 comments. View all 374 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.