Comment 362 for bug 606238

Hi all,

I have a Dell Vostro 3360 with a 'Dolphin V2' touchpad, running linux 3.10-rc1 (latest from git).
I have been using the psmouse-alps-1.3-alt.tbz driver, works fine (touchpad detected, multitouch, not too jumpy) except for edge scrolling (but I don't care about that because two-finger scrolling works).

I had to make a few changes to build it against the latest kernel tree though, and instead of doing the DKMS thing I just copied alps.c into drivers/input/mouse/alps.c then rebuilt the kernel. Attached is a patch which applies the 1.3-alt code to linux 3.10.

Is it possible to get this V2 support mainlined? This patch works fine for me, but I'd be happy to provide any data/have a go at mild hacking required to fix other issues (edge scrolling) if that is needed to get the driver upstream.

The work so far is great, thanks to everyone involved.

Cheers!
Chris