live cd is unusable due to video degradation with the splash boot option enabled

Bug #1043518 reported by Doug McMahon on 2012-08-29
146
This bug affects 29 people
Affects Status Importance Assigned to Milestone
Linux
Unknown
Unknown
linux (Ubuntu)
High
Colin Ian King
Quantal
High
Colin Ian King
plymouth (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

All images after 08/15 have become unusable, either to install from or to use a live session.
Images from 08/15 & earlier work fine as does the install itself.

Attached are 2 possible screens which seem to vary depending on which partition grub is configured on in a multi-boot system (12.04 & 12.10

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 3.5.0-9.9-generic 3.5.0
Uname: Linux 3.5.0-9-generic x86_64
ApportVersion: 2.5.1-0ubuntu3
Architecture: amd64
Date: Wed Aug 29 16:21:08 2012
InstallCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash --
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120813.1)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)
---
ApportVersion: 2.5.1-0ubuntu7
Architecture: amd64
CasperVersion: 1.323
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
DistroRelease: Ubuntu 12.10
LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120912)
MachineType: Dell Inc. XPS M1330
Package: plymouth 0.8.4-0ubuntu3
PackageArchitecture: amd64
ProcCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/username.seed boot=casper initrd=/casper/initrd.lz --
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 nouveaufb
ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/username.seed boot=casper initrd=/casper/initrd.lz --
ProcVersionSignature: Ubuntu 3.5.0-14.16-generic 3.5.3
Tags: quantal running-unity
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
Uname: Linux 3.5.0-14-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 12/26/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A15
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA15:bd12/26/2008:svnDellInc.:pnXPSM1330:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: XPS M1330
dmi.sys.vendor: Dell Inc.

Doug McMahon (mc3man) wrote :
Doug McMahon (mc3man) wrote :
Doug McMahon (mc3man) on 2012-08-29
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Dimitri John Ledkov (xnox) wrote :

Have you tried the 20120828.2 or later images? Worked like a charm for me. If not please revert the status of this bug back to confirmed. Thanks.

Changed in ubiquity (Ubuntu):
status: Confirmed → Incomplete
Doug McMahon (mc3man) on 2012-08-29
Changed in ubiquity (Ubuntu):
status: Incomplete → Confirmed
Doug McMahon (mc3man) wrote :

Tried today's image, same deal
Can provide some of the logs though the syslog is quite large > 71MB,
(4 -500,000 lines similar to this
Aug 29 21:03:24 ubuntu kernel: [ 31.100123] [drm] nouveau 0000:01:00.0: PFIFO_CACHE_ERROR - Ch 2/0 Mthd 0x0204 Data 0x00000030

In some ways very similar to what happened in 12.04 dev except this is only on booting the live iso, installs are quite fine.
Bug 931967

Dale Beaudoin (twocamels) wrote :

I keep getting:

####:#### [drm} nouveau: idle channel #

Then it keeps looping back, trying different buggy screens. Not the first time this happened in this quantal series.

01:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce G210] (rev a2)
01:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)

Doug McMahon (mc3man) wrote :

I've gone ahead & tried the nomodeset option multiple times. (7)

Twice it worked fine to produce a workable live session/installer
Twice only got a black screen, once with splash screen, red lights, never proceeded
Once got usable live session though also removed splash quiet from boot option
Once got the live session but unity wasn't loaded
Once got live session with constant windows flashing

This machine has never before had issue like this - started after the removal of unity-2d & the inclusion of the ...904/5 xserver on live iso

Steve Langasek (vorlon) on 2012-09-04
Changed in ubiquity (Ubuntu):
importance: Undecided → High
Doug McMahon (mc3man) wrote :

I should note that as of recently using "nomodeset" will allow the installer window to show up & installs can be done. Occasionally with nomodeset nothing happens, either a plymouth splash appears & never ends or just a black screen.
Other users with various nvidia hardware report the same.

Also sometimes, (rare), just going to the options screen is enough & nomodeset doesn't have to used
The recently 'released' Ubuntu GNOME Remix 12.10 iso's show the same behaviors.
The current fedora 18 nightly is fine, no corruption.

Martin Spacek (mspacek) wrote :

I had the same problem (screen corruption, failure to get into desktop, Xorg crash, noveau idle channel messages), booting off the latest Xubuntu 12.10 amd64 liveusb on my ThinkPad W510 with NVidia GT216 (Quadro FX 880M) graphics. Once in a while I'd make it through bootup into xfce, but mostly not. Sometimes switching to a TTY and typing "startx" would work, but usually not. Booting with "nomodeset" seemed to fix the problem, but then once I got into the desktop, the resolution was too low (1024x768). Perhaps that's not surprising.

Next, I did an update from the repos. Updates included a bunch of Xorg and nouveau stuff, and at the same time I enabled the latest NVidia blob. Now I don't have this problem anymore. Not sure if it was the updates or the switch to the nvidia blob that fixed this liveusb.

Martin Spacek (mspacek) wrote :

I still have this problem with the latest live-usb, from 2012-09-09. This presumably incorporates any updates that I installed on the previous live-usb from a couple days ago, so what must've fixed it for me (i.e., not having to use "nomodeset" any more) was the installation of the nvidia blob.

I forgot to mention earlier, when booting normally (nomodeset left unset), the Xubuntu splash screen with the progress indicator comes up normally. Eventually it stops throbbing, and after a little while the screen switches to corruption.

avinas (avinas17) wrote :

2012.10.10 daily, baked to usb, useless- could not start. Crashes without ability to select "Try ubuntu" Option.
Got IVTV firmware failing message.

philinux (philcb) wrote :

Today with up to date ISO.

nVidia 8600GT

Booting starts. I get an error about video mode. Space to continue or scan produce same results. Plymouth looks great in correct resolution then garbage desktop. Multicoloured pixels. Launcher is there as it top panel but no mouse pointer but mouse is there.

Rebooting and using nomodeset works and desktop appears but is very sluggish and compiz crashes.

I would not install using this.

Albert J (amikot) wrote :

On my NVidia 8600GTS i have the same problem, but on alredy installed 12.10 binary Nvidia driver is unstable and crashes system when using 3D. Using nouveau - everything is stable.
Im not sure... is ubuntu liveCD booting with nVidia binary driver ?
LiveCD crash is so similar to nvidia driver crash (total freeze with trash on screen) and popped up in the same time (the same version of compilation).

Doug McMahon (mc3man) wrote :

The issue here seems to be the "splash" boot option
If I remove it then booting to the live session or installer works fine, no need for nomodeset, no video degradation at all.

Noticed this also recently when try to boot to an eariler kernel from grub. With the default boot options was more often than not getting a degraded unity-greeter that was unusable. Same thing - removing splash & all was fine

From a user perspective - I don't even see the complete boot line on the live cd. It ends with splash --
Fotunately splash was visible so it could be removed.. I wonder if some hardware may not even see splash ..??

summary: - live cd is unusable due to video degradation
+ live cd is unusable due to video degradation with the splash boot option
+ enabled
Albert J (amikot) wrote :

In Kernel or Video driver could be bug that pop ups in strange situations.
Maybe splash uses broken kernel or driver instruction ?

Martin Spacek (mspacek) wrote :

I can confirm that removing splash (or in my case, changing "splash" to "nosplash") works around the problem, as does using "nomodeset". This is on the latest Xubuntu daily live amd64 image, from USB, nvidia GT216. Don't think it's been mentioned before, nouveau throws a dmesg about GPU lockup when I switch to a TTY and try running "startx". Also, apport reports an Xorg crash once the desktop appears (at least when I boot using "nosplash"). Might be related.

Martin Spacek (mspacek) wrote :

Maybe plymouth and/or nouveau should be added to this bug report? I can't seem to figure out how to get launchpad to let me do it...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Doug McMahon (mc3man) on 2012-09-17
affects: plymouth → plymouth (Ubuntu)
Changed in plymouth (Ubuntu):
status: New → Confirmed
Doug McMahon (mc3man) wrote :

plymouth seems a bit suspect here for a couple of reason
Virtually all users reporting or confirming this, here or elsewhere, had this start occurring with live images shortly after 08/16
(I have a 08/15 image here that works fine, plymouth_0.8.4-0ubuntu1
Plymouth got a major upgrade on 08/16

Additionally there is a way on this hardware to now cause a corrupted unity greeter on an install, with the default plymouth packages downgraded to 0.8.4-0ubuntu1 it doesn't occur.
(a bit involved & requires 2 12.10 installs

Steve Langasek (vorlon) wrote :

Please run ' apport-collect -p plymouth 1043518' from the affected system after booting the live cd without splash (do *not* boot with nomodeset).
I would also like to see plymouth debug output from this machine, but I realize that may be difficult to capture if the video is corrupted after boot. By any chance, does switching to vt1 give you uncorrupted video after boot, allowing you to copy files off?

Fwiw, the display here looks like a framebuffer that plymouth (and X) is expecting to be set up as a linear framebuffer isn't. That's likely to be a kernel or bootloader bug rather than a plymouth bug. (bearing in mind that the live cd uses a different bootloader than the installed system) It may be helpful to test writing the image to a usb stick and check whether the behavior is the same.

Changed in plymouth (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Doug McMahon (mc3man) wrote :

"I would also like to see plymouth debug output from this machine, but I realize that may be difficult to capture if the video is corrupted after boot. By any chance, does switching to vt1 give you uncorrupted video after boot, allowing you to copy files off?"
Assuming that you want this from a normal (with splash) boot ? If so I believe we can do that (vt1), what exactly do you wish?
(a log or whatever

Martin Spacek (mspacek) on 2012-09-17
description: updated
Steve Langasek (vorlon) wrote :

> Assuming that you want this from a normal (with splash) boot ? If so I believe
> we can do that (vt1), what exactly do you wish?

Yes, looking for this when booting the liveCD with splash. Please append this boot option:

  plymouth.debug=file:/run/plymouth-debug.log

and attach the resulting file.

If vt1 works, this itself is interesting to know. I would have thought the same framebuffer was used for console as for plymouth+X.

Doug McMahon (mc3man) wrote :

Here you go, doesn't appear bad but i really wouldn't know..
Probably good to (re)note that when booting that way do get the splash, it's right after it disappears that instead of a live session get the unusable screens as orig. attached.

If not going to the options screen, just booting up, i'd have to d. check if it matters.
I think sometimes a splash, sometimes just black with cursor, & then in either case corrupted instead of the 'try me', install, ect. window

Doug McMahon (mc3man) wrote :

There appears to now be a similar issue with fedora 18 A1, though they are using ply. 0.8.7
Can be seen at https://bugzilla.redhat.com/show_bug.cgi?id=857300, & maybe
https://patchwork.kernel.org/patch/1455231/

Martin Spacek (mspacek) wrote :

@Doug McMahon, nice find! So it sounds like the real problem was a one line oops in nouveau, which is part of the kernel. I've tried to add the kernel to this bug report, but I may have picked the wrong project.

z3z (z3z) wrote :

I've got this problem too. I have an AMD processor and a GeForce GTX 460. I'd downloaded QQ beta last week but couldn't get it to boot. Tried again today with the latest daily build, but I have the same problem.

I get the initial purple screen with the accessibility options (at least, I think that's what the screen is!) Then it goes onto the screen with the Ubuntu name and the orange dots. The word Ubuntu is completely garbled and unreadable, so the graphics problem has already kicked in. Then it changes onto a mostly black screen with lots of little icons and random garbage spread all over the place. I can't move the mouse and it doesn't seem to respond to any keystrokes I tried. I can't get any kind of log reports because nothing works. I have to hit the reset button and restart my computer because it's completely frozen.

I haven't tried the Nomodeset option yet but I wanted to report this bug, because it's a pretty big deal breaker for the average person if they're faced with the same result I got.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1043518

tags: added: iso-testing
Greg Faith (gregfaith) wrote :

Testing Beta 2 Lubuntu Desktop amd64 20120925 I can confirm the issue still exists
and the best work around is removal of splash from the kernel mode line..

Nomodeset generally works but leaves the live session in low graphics. Removal of "splash"
maintains proper grahics in the live session. Thanks mc4man.

Doug McMahon (mc3man) wrote :

Seems to not be a plymouth issue per se, making invalid

Changed in plymouth (Ubuntu):
status: Incomplete → Invalid
Steve Langasek (vorlon) wrote :

Per comment #36, this looks to be a kernel bug instead. Kernel team, can we please get the patch from https://patchwork.kernel.org/patch/1455231/ pulled into the Ubuntu kernel? If we can't (or if it's already there but this is still broken), please kick this back to plymouth.

affects: ubiquity (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Confirmed → Triaged
tags: added: rls-q-incoming
Steve Langasek (vorlon) wrote :

have confirmed that the patch in question is not present in the quantal kernel.

Doug McMahon (mc3man) wrote :

It's in the mainline 3.6rc6, (not expecting 12.10 to use), thought I'd try re-mastering the current image to use that kernel as a test of the patch on a live session/install.
  For whatever reason cannot get UCK to do that properly. (seems ok but no matter what get booted back to a busybox.
So if someone does produce a patched kernel on a image will gladly test that iso.

Tim Gardner (timg-tpi) on 2012-09-27
Changed in linux (Ubuntu Quantal):
status: Triaged → Fix Committed
assignee: nobody → Colin King (colin-king)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.5.0-16.24

---------------
linux (3.5.0-16.24) quantal-proposed; urgency=low

  [ Andy Whitcroft ]

  * SAUCE: ata_piix: add a disable_driver option
    - LP: #994870

  [ Christian König ]

  * (pre-stable) drm/radeon: make 64bit fences more robust v3 (3.5 stable)
    - LP: #1029582

  [ David Henningsson ]

  * SAUCE: ALSA: hda - use both input paths on Conexant auto parser
    - LP: #1037642
  * SAUCE: ALSA: hda - fix control names for multiple speaker out on
    IDT/STAC
    - LP: #1046734

  [ Herton Ronaldo Krzesinski ]

  * SAUCE: ALSA: hda/via - don't report presence on HPs with no presence
    support
    - LP: #1052499
  * SAUCE: ext4: fix crash when accessing /proc/mounts concurrently
    - LP: #1053019
  * SAUCE: ALSA: hda/realtek - Fix detection of ALC271X codec
    - LP: #1006690

  [ Kyle Fazzari ]

  * SAUCE: input: Cypress PS/2 Trackpad fix disabling tap-to-click
    - LP: #1048816

  [ Leann Ogasawara ]

  * [Config] Disable CONFIG_DRM_AST
    - LP: #1053290

  [ Stefan Bader ]

  * [Config] Disable the Cirrus QEMU drm driver
    - LP: #1038055

  [ Upstream Kernel Changes ]

  * Revert "KVM: VMX: Fix KVM_SET_SREGS with big real mode segments"
    - LP: #1045027
  * x86, efi: Handover Protocol
  * drm/i915: HDMI - Clear Audio Enable bit for Hot Plug
    - LP: #1056729
  * UBUNTU SAUCE: apparmor: fix IRQ stack overflow
    - LP: #1056078
  * drm/nouveau: fix booting with plymouth + dumb support
    - LP: #1043518
  * ALSA: hda - Add DeviceID for Haswell HDA
    - LP: #1057698
  * ALSA: hda - add Haswell HDMI codec id
    - LP: #1057698
  * ALSA: hda - Fix driver type of Haswell controller to AZX_DRIVER_SCH
    - LP: #1057698
  * ALSA: hda_intel: Add Device IDs for Intel Lynx Point-LP PCH
    - LP: #1011438, #1057698

  [ Wang Xingchao ]

  * SAUCE: ALSA: hda - Add another pci id for Haswell board
    - LP: #1057698

  [ Wen-chien Jesse Sung ]

  * SAUCE: drm/i915: Explicitly disable RC6 for certain models
    - LP: #1002170, #1008867
 -- Leann Ogasawara <email address hidden> Thu, 27 Sep 2012 13:55:52 -0700

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released
Doug McMahon (mc3man) wrote :

resolved my issue with uck & kernel replacement, so tried this proposed on todays image.
No more corruption, booted to live session just fine.

Greg Faith (gregfaith) wrote :

Confirmed on Lubuntu quantal amd64 20120928 resolves my issues as well. The persistent USB I am using boots to a clean Live session with no kernel mode changes required.

Carla Sella (carla-sella) wrote :

I also solved my problems with today's ISO (http://cdimage.ubuntu.com/daily-live/20120929/quantal-desktop-amd64.iso), I can boot correctly with a live USB key on my PC with an Nvidia graphic card.

Cavsfan (cavsfan) wrote :

I downloaded the beta 2 today twice from 2 sources and md5sum checked OK.
But, I could not install or do anything with it. The video was just garbage with no options displayed.
Had to press reset on PC.
This is the ubuntu-12.10-beta2-desktop-amd64.iso version,

I have an nvidia geforce 9800 GT.

Walter Lapchynski (wxl) wrote :

Using 20120929 on a GeForce FX Go5200, no luck.

For grins, I tried various boot parameters and got nouveau's output to dmesg and the Xorg log for each of them.

Of these, the following failed to produce a visible X:
live http://paste.ubuntu.com/1254953/
live video=ofonly http://paste.ubuntu.com/1254998/
live video=offb:off http://paste.ubuntu.com/1255057/
live video=LVDS-1:1024x768-32@60 http://paste.ubuntu.com/1255066/
live video=VGA-1:d video=TV-1:d video:DVI-D-1:d http://paste.ubuntu.com/1255076/

These gave me "8 bit graphics" and blank dialogs (see http://imgur.com/ArhrV - scrot doesn't show it being so bad), i.e. an unusable install:
live nomodeset http://paste.ubuntu.com/1255047/
live nouveau.modeset=0 http://paste.ubuntu.com/1255013/

I'm wondering if the issue isn't the SMP kernel. I didn't set that up, it just ran that way. Thoughts?

Walter Lapchynski (wxl) wrote :

I'm sorry to say that the issue is not just with the live CD. I installed with the alternate of Lubuntu (20121001) on the aforementioned GeForce FX Go5200 and no luck still: http://paste.ubuntu.com/1256127/

In fact, the screen is far worse and even more unusable if you use the nomodeset parameter than in the desktop.

I'd love to change this from Fix Committed for as far as I can see on this hardware, the fix doesn't work.

philinux (philcb) wrote :

I just zsynced the daily live 64 bit iso and burnt to usb.

nVidia 8600GT booted fine. No graphics corruption at all.

Greg Faith (gregfaith) wrote :

Walter (wxl23) I think your issue is powerpc specific. If you look back on the reporters on this particular bug we were doing desktop amd64 installs on either Ubuntu or Lubuntu. Like philinux, I also ran the 20121001 amd64 Desktop Lubuntu and Ubuntu last night and both the live sessions were fine as reported on the qa-tracker.

it may be pppc specific, but i also note that cavsfan is using amd64 and failing. i'm guessing that ultimately the problem is only a portion of nvidia cards are affected. perhaps it would be useful for all of us to do a uname -a and post the results (i have in all of those ubuntu pastes above)

ojordan (ojordan12345) wrote :

@wxl you've provided a lot of logs there, but have you actually looked at them youself? I haven't read all the posts here, but it is fairly clear to me that you have a different problem to the original poster. But, just to be sure, have you tried turning off the splash screen? On a PowerPC live/desktop ISO you do this by selecting the nosplash option at yaboot.

Your problem is the nouveau xorg driver doesn't detect your device. Setting up an xorg.conf may solve this. Otherwise you will have to load a legacy framebuffer and use the fbdev xorg driver. The openfirmware framebuffer is limited to 16 colours (a lot less than 8 bit), and there is no getting around that.

Walter Lapchynski (wxl) wrote :

@ojordan I haven't read through the logs extensively. I see the "no devices detected" and I see when turning the OpenFirmware framebuffer off, there's a conflict that goes away (still no devices detected). I also see that fbdev seems to be used on the ones that do work.

Other than that, I'm not really skilled enough to know what to look for. I'm simply trying to provide information and experiences. If you can tell me what else to try, I'll keep trying, but I'm no expert on these matters.

I didn't gather from the PowerPCFAQ that there was much value in trying to do nosplash, but I can give it a shot. I'll let you know.

When it succeeds, it seems to use fbdev and the desktop is pretty much unusable. So unless you can provide some advice (or point me in the direction of where I might find info) on how to tweak it to work, that's kind of out.

I'll give a shot at an xorg.conf but I'm no expert in these matters. I see the section in PowerPCFAQ and will give it a read, but none of those examples relate to my machine. Seems most are for Radeon anywho.

Greg Faith (gregfaith) wrote :

Thanks for making me think here wxl. The Beta2 came out on 20120926 and the fix here arrived 20120928. By the way i did send cavsfan a notification to try the current live daily build and post back if it works.

ojordan (ojordan12345) wrote :

Just to correct my post #55, since on the logs nouveaufb looks like it is loading fine for you then you can use the fbdev driver with that. All you need to do is create an xorg.conf that specifies fbdev (don't use the nomodeset parameter). If you still get 8 bit graphics then you need to increase the colour depth at the yaboot prompt. It is very easy, but I would try setting up an xorg.conf with nouveau first.

Doug McMahon (mc3man) wrote :

Walter -
I think you may be better served with a new bug, this was quite specific to nvidia hardware that couldn't boot to a live session or installer normally but could if removing splash or using nomodeset.
It all instances of users affected once installed there was no issue at all, only occurred on the live session, & again in most instances the nvidia adapter supported 3d thru nouveau or nvidia drivers

(possibly some hardware that benefited from this did not support 3d thru nouveau though I'm not aware of any reports of such

There is a fair amount of reports that GeForce FX Go5200 does Not have 3d or proper 3d support for unity. How it would fair in lubuntu I've no clue but again not related to this bug. One such report on Debian, specific also to powerpc64, there are many more ...
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=668828

What cavsfan posted indicated he used the beta2 image which did not include this fix.

Walter Lapchynski (wxl) wrote :

thanks for the help, all. i agree, my issue may be somewhat different. symptoms, on the surface, are the same, but the root cause is probably different.

an auto-configured xorg.conf with 3d acceleration off fixes the problem for me. that seems like a pretty easy-to-implement fix. i'll make a new bug and post my findings there.

JOna (jblistat) wrote :

I tried to be systematic and did over 100 boots with different nouveau-settings both with and without xorg.conf, in varying configurations. Nothing works. At best I got unusable 4-color(?) screen that was mentioned in the first post of this thread. Text terminal in single-mode works.

The chip I have is GeForce4 440 MX in Powerbook G4 17 inch (M8793LL/A - PowerBook5,1 - A1013). I did the testing with kernels from ubuntu/lubuntu 12.04 and 12.10.

My conclusion at this point is that with recent kernels it is not possible to configure X in Powerbook G4 with Nvidia GeForce4 440 MX.

Maybe if I compile my own kernel I could get X back? What parts of the kernel should be dropped and what parts should be included?

FYI: I did also try every possible framebuffer with and without xorg.conf editing modprobe-blacklisting of framebuffers and yaboot bootline parameters accordingly. None of those work either. Some have dependancies with packages available only for i386, and the others were just broken.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.