Ubuntu

failed to set xfer mode error.

Reported by Serious Sven on 2007-05-03
24
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Medium
Unassigned

Bug Description

When trying to install Ubuntu Feisty Fawn it gives me a couple of errors, after installation Ubuntu hangs at first boot and when starting up the recovery mode it reports it cannot set udma mode and is trying to set udma/33 PIO, after that fsck crashes and Ubuntu reboots.

I also tried installing Edgy Eft first with updates and then upgrade to Feisty Fawn, but it results with thesame problem.

The errors:

[2.302217] usb 1-1: Device not accepting address 2 error -71
[33.23433] ata2.01: failed to set xfermode (err-mask= 0x4)
[69.030658] ata 2.01: failed to set xfermode (err-mask= 0x4)
[104.826988] ata 2.01: failed to set xfermode (err-mask= 0x4)
109.827119] ata 2.02: failed to set xfermode (err-mask = 0x40)

System specs:

Intel 875p chipset
Intel Pentium IV 3.2GHz (Northwood)
2Gb Corsair
nVidia Geforce 7800GS (Gainward Bliss 512+)
Promise Sata150 TX4 (SATA II)
2x Maxtor Maxline III 300GB Sata II
Soundblaster Audigy II Platinum Ex

Edgy Eft works fine.

Kind regards,

Sven Gertsen

Oleksij Rempel (olerem) wrote :

please can you post the kernel version of feisty-installcd you used. You need to start the desktop with this cd, runt terminal and type "uname -a".

If you say your feisty livecd working, it can be new ubuntu-kernel problem.
you can try to fix your system using livecd.
start cd
open xterm
mkdir /mnt/my_sys
mount /dev/sda_your_root_partition /mnt/my_sys
chroot /mnt/my_sys /bin/bash
mount -a
apt-get update
apt-get install linux-image-2.6.20-11 -generic
exit
reboot

after this try to boot ubuntu with older kernel.

Oleksij Rempel (olerem) wrote :

this is not solution. this workaround may help you to start the system.

Hi Fishor,

The livecd doesn't work, it gives thesame errors, it does install after the
errors (only tried the text mode installation of the alternate installation
cd) but after the installation it cannot set DMA mode so it tries to set it
to DMA/33 PIO, but then fschk crashes and the system reboots.

The kernel I use is the default kernel that's on the installation cd.

After I installed Edgy Eft and upgraded to Feisty Faugn I tried to boot to
the older kernel of Edgy Eft but it still hung while booting.

Let me know if I can do some more troubleshooting because I'm more than
willing to get Feisty Faugn working, I have a spare partition I can use for
testing.

Kind regards,

Sven Gertsen

please can you post the kernel version of feisty-installcd you used. You
need to start the desktop with this cd, runt terminal and type "uname
-a".

If you say your feisty livecd working, it can be new ubuntu-kernel problem.
you can try to fix your system using livecd.
start cd
open xterm
mkdir /mnt/my_sys
mount /dev/sda_your_root_partition /mnt/my_sys
chroot /mnt/my_sys /bin/bash
mount -a
apt-get update
apt-get install linux-image-2.6.20-11 -generic
exit
reboot

after this try to boot ubuntu with older kernel.

--
failed to set xfer mode error.
https://bugs.launchpad.net/bugs/112132
You received this bug notification because you are a direct subscriber
of the bug.

_________________________________________________________________
Get a FREE Web site, company branded e-mail and more from Microsoft Office
Live! http://clk.atdmt.com/MRT/go/mcrssaub0050001411mrt/direct/01/

Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description doesn't yet have enough information.
Please include the following additional information as attachments, if you have not already done so (please pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:
1. Please include the output of the command 'uname -a' in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command 'dmesg > dmesg.log' and attach the resulting file 'dmesg.log' to this bug report.
3. Please run the command 'sudo lspci -vvnn > lspci-vvnn.log' and attach the resulting file 'lspci-vvnn.log' to this bug report.
For your reference, the full description of procedures for kernel-related bug reports is available at https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks in advance!

scottwilkins (scottwilkins) wrote :

I'm getting the same error on attempts to install on an Intel Motherboard (true Intel made and sold)

Brian Murray (brian-murray) wrote :

scottwilkins - Could you add the information I asked for earlier then?

outlaw686 (crackers122) wrote :

Hi,

Glad to see this is a suspected bug and not my computer. Here's the information you requested.

dave@Warhorse:~$ uname -a
Linux Warhorse 2.6.20-16-generic #2 SMP Wed May 23 01:46:23 UTC 2007 i686 GNU/Linux

The requested logs are attached.

imperius1 (imperius1) wrote :

You could try adding "irqpoll" to the /boot/grub/menu.lst file, like : "kernel /boot/vmlinuz-2.6.20-15-generic root=UUID=48c5a348-eb39-4171-8531-671a49fdb75b ro quiet splash irqpoll". This is better described here : http://ubuntuforums.org/showthread.php?t=414002&page=2.

Serious Sven (s-gertsen) wrote :

I'm going to check this option in the next few days.

Thanks.

From: imperius <email address hidden>
Reply-To: Bug 112132 <email address hidden>
To: <email address hidden>
Subject: [Bug 112132] Re: failed to set xfer mode error.
Date: Mon, 11 Jun 2007 05:24:43 -0000

You could try adding "irqpoll" to the /boot/grub/menu.lst file, like :
"kernel /boot/vmlinuz-2.6.20-15-generic
root=UUID=48c5a348-eb39-4171-8531-671a49fdb75b ro quiet splash irqpoll".
This is better described here :
http://ubuntuforums.org/showthread.php?t=414002&page=2.

--
failed to set xfer mode error.
https://bugs.launchpad.net/bugs/112132
You received this bug notification because you are a direct subscriber
of the bug.

_________________________________________________________________
Like puzzles? Play free games & earn great prizes. Play Clink now.
http://club.live.com/clink.aspx?icid=clink_hotmailtextlink2

mfleming (mikef-warble) wrote :

Just FYI-- I have this same problem on my box when running 2.6.21. I added "irqpoll" and was indeed able to run with it, but made i/o performance crawl: I was seeking a couple hundred kilobits/sec on my GigE link. "irqpoll" is good for getting the machine booted, but isn't a permanent solution.

Changed in linux-source-2.6.20:
assignee: brian-murray → ubuntu-kernel-team
importance: Undecided → Medium
status: Needs Info → Confirmed
Yves (yves-gwerder) wrote :

I have this problem too.
If you still need information to fix it, please tell me.

imperius1 (imperius1) wrote :

So... Did anyone else come up with a better option than "irqpoll"? I haven't noticed any "performance crawl" on my system but I'd be happy to pick up some speed wherever I can find it. Please let us know if anyone has found any luck with another option.

Yves (yves-gwerder) wrote :

I have to add that it starts the normal way too, it just takes very very long (Progressbar isn't moving for about 2 minutes)

Serious Sven (s-gertsen) wrote :

If more trouble shooting needs to be done, please let me know because I'm
still running Edgy with success.

I have one partition free for Feisty if more testing is requested.

Kind regards,

Sven

From: Yves <email address hidden>
Reply-To: Bug 112132 <email address hidden>
To: <email address hidden>
Subject: [Bug 112132] Re: failed to set xfer mode error.
Date: Sat, 07 Jul 2007 11:09:56 -0000

I have to add that it starts the normal way too, it just takes very very
long (Progressbar isn't moving for about 2 minutes)

--
failed to set xfer mode error.
https://bugs.launchpad.net/bugs/112132
You received this bug notification because you are a direct subscriber
of the bug.

_________________________________________________________________
Local listings, incredible imagery, and driving directions - all in one
place! http://maps.live.com/?wip=69&FORM=MGAC01

erojijii (dab) wrote :

I have almost exactly the same problem. Or maybe not.

It's an HP PCm7170n with an Asus P5LP-LE (Lakeport) motherboard with a Pentium D 3.00Ghz (Smithfield)
Specs are here:
http://h10025.www1.hp.com/ewfrf/wc/document?docname=c00379616&lc=en&cc=ca&dlc=en&product=483897

I did an install from ubuntu-7.04-alternate-i386.iso. No problem on the install. The initial reboot after install was no problem (likely dumb luck). The reboot after the first update, including an update from 2.6.20-15-gereric to 2.6.20-16-generic, it failed to load. Going into grub and selecting any kernel option from the menu got the same result.

The main difference in what I get is that I am able to get it to boot once in a while. If I see the status bar does not move in 3 seconds I do Ctrl-Alt-Del. I have to do that between 2 and 7 times before it comes up. Once up, I have no trouble from that point on. If I reboot (with/without a power off), I have to do Ctrl-Alt-Del many times and it's up again.

When it fails, this is part of what I see in the recovery boot screen:

[ 41.032130] ata3.00: qc timeout (cmd 0x27)
[ 41.032179] ata3.00: ata_hpa_resize 1: sectors = 398297088, hpa_sectors = 0
[ 41.032231] ata3.00: ATA-7: Maxtor 6V200E0, VA111630, max UDMA/133
[ 41.032274] ata3.00: 398297088 sectors, multi 16: LBA48 NCQ (depth 0/32)
[ 41.032321] ata3.00: failed to set xfermode (err_mask=0x40)
[ 41.032363] ata3: failed to recoversome devices, retrying in 5 secs
[ 76.176415] ata3.00: qc timeout (cmd 0x27)
[ 76.176464] ata3.00: ata_hpa_resize 1: sectors = 398297088, hpa_sectors = 0
[ 76.176522] ata3.00: failed to set xfermode (err_mask=0x40)
[ 76.176564] ata3.00: limiting speed to UDMA/133:PIO3
[ 76.176605] ata3.00: failed to recoversome devices, retrying in 5 secs
[ 111.324358] ata3.00: qc timeout (cmd 0x27)
[ 111.324407] ata3.00: ata_hpa_resize 1: sectors = 398297088, hpa_sectors = 0
[ 111.324465] ata3.00: failed to set xfermode (err_mask=0x40)
[ 111.324507] disabled

Done.
     Check root = bootarg cat /proc/cmdline
     or missing modules, devices: cat /proc/modules ls /dev
ALERT!
     /dev/disk/by-uuid/f3892a94-011d-4c74-a6ee-94d35d1d210d does not exist
     Dropping to a shell!

The directory /dev/disk/by-uuid does not exist when it fails to boot, but does exist when it does boot.

I have not tried any of the workarounds mentioned above as I have been able to get it running with Ctrl-Alt-Del.

Happy to send any other info requested.

Michael Marley (mamarley) wrote :

I have exactly the same problem. I just installed Kubuntu on my PC using Wubi, and when I tell it to boot stalls and then displays the following error:

[33.23433] ata2.01: failed to set xfermode (err-mask= 0x4)
[69.030658] ata 2.01: failed to set xfermode (err-mask= 0x4)
[104.826988] ata 2.01: failed to set xfermode (err-mask= 0x4)
[109.827119] ata 2.02: failed to set xfermode (err-mask = 0x40)

Then it says something like:

[ACPI] invalid pblck length (5)

and then it continues the normal booting process. After it boots up, the system is perfectly normal. Also, I have previously tried running normal installations from the LiveCD. These attempts have produced the same results. I have also tried adding "irqpoll" to the GRUB configuration file to no avail.

Here are my system specs:

Asus CUSL2-C Motherboard (i815ep northbridge) (ICH2 southbridge)
Pentium III 1gHz Coppermine (not overclocked) and 512 MB SDR SDRAM.
Radeon 9200 (RV280) 128MB DDR AGP Video Card
Western Digital 80gb HDD
LG 16x DVD-ROM Drive (which works)
Lite-On 40x CD Burner (which works)
Several other PCI cards:
Intel PRO/100 LAN card
Sound Blaster Audigy (EMU10k1) Sound Card
USB 2.0 card (with NEC chipset (no VIA crap here!))
D-Link DWL-G510 Wireless LAN card (Atheros AR5005 chipset)

I am running kernel version 2.6.20-16, and all other applicable software updates have been applied. I am really glad to know that this is a widespread problem and not a problem with my box! Thanks in advance for any help.

Michael Marley (mamarley) wrote :

An update: I just checked, and my lite-on CDRW is NOT working. hmm.

Michael Marley (mamarley) wrote :

I just tried updating the firmware on my Lite-On drive. It did not help.

Ned (alabatros) wrote :

On my system I have a couple of hard drives attached to IDE to SATA adapters (specifically, SYBA ADSAIDE-3811 adapters). IDE Hard drive -> sata adapter -> sata port on motherboard. With Ubuntu 7.10 and 7.04 the drives with the adapters don't work and I get this output from dmesg that is attached with this post, which has those same "failed to set xfermode (err_mask=0x40)" errors. irqpoll does not work. I tried booting the system with an old version of Knoppix (Linux Knoppix 2.6.17 #4 SMP PREEMPT Wed May 10 2006 i686 GNU/Linux) and the drives work fine with no errors.

Michael Marley (mamarley) wrote :

The new release, 7.10 (Gutsy) fixes this problem completely for me. All drives now work without anything special, and it does not take forever to boot up. I have tried the Tribe 5, Beta, RC, and Final versions, and all work fine.

The error still exists for me. Although now it does not fail to boot, it just takes a considerably longer time. It takes 3 to 4 minutes to boot, as opposed to 1 to 1.5 minutes to boot. The error has changed now. While for me it used to be

ata2.01: failed to set xfermode (err-mask= 0x4)

the error has now become

[51.399855] ata2.01: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
[51.399923] ata2.01: cmd a0/01:00:00:00:00/00:00:00:00:00/b0 tag 0cdb 0x5a data 128 in

then about every 40 seconds the error shows up exactly the same again, until after 4 or 5 times, the system boots up, and the CD Drive does not respond to anything.

nemox (erabbit) wrote :

I receive the same problem with a Dell Poweredge 500SC, IBM HDD IDE UMDA/33, Seagate Mini Tape (STT20000), 1.13 PIII, 1024MB ECC RAM, additional PCI 10/100 Dell ethernet. I receive the aforementioned errors (depending on which boot options i put in, if any) in both Ubuntu Server 7.04 and 7.10.

komarov (bartnovsky) wrote :

That's really strange, but i got into the same error, namely:

ata2.01: failed to set xfermode (err-mask= 0x4)
ata2.01: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata2.01: cmd a0/01:00:00:00:00/00:00:00:00:00/b0 tag 0cdb 0x5a data 128 in

...

But i have also achieved to perceive the experimental conditions under which this takes place, my confiruration is:Pentium Core2 Duo,1Gb Kingstone, GeForce7600GT and two SATA disks. Both disks are Western Digital and have capacity 200Gb. Some days before (mamoy klyanus'![rus]) i tried to install kubuntu on one of these disks and everything was fine. Yesterday during startup i started to receive these mes.(look above). EVENTUALLY THIS BUG DOESN'T APPEAR IF JUST 1 DISK IS CONNECTED! I've inferred it from the following: i triedboth sata disks for installations of kubuntu - and as soon as i connect both - bang! I even tried to connect WD_200Gb + Seagate 80Gb(USB) - and amazingly same error comes up! And also -under Windows all disks work without a problem! HELP!

acacha (sergi-tur) wrote :

I confirm that bug.

I follow the workaround from this page: http://fak3r.com/2007/06/22/failed-to-set-xfermode-solved/

I take some notes in catalan at my wiki: http://acacha.dyndns.org/mediawiki/index.php/Ubuntu_TroubleShooting#Failed_to_set_xfermode

Rob Miracle (rob-robmiracle) wrote :

I have the same computer that erojijii above has, an HP m7170n and I'm experiencing the same error messages. In my case though, I had originally installed Dapper and did a dist upgrade to Edgy. I went recently to do a dist upgrade to Feisty and afterwards, it fails to reboot. I can however, boot from 2.6.15-27 (rwm@falcon:~$ uname -a
Linux falcon 2.6.15-27-386 #1 PREEMPT Sat Sep 16 01:51:59 UTC 2006 i686 GNU/Linux)

Any kernel I have installed after that (2.6.17-10 or later) generates the ata errors listed in erojijii's post. I can get you a dmesg from a successful boot into the older kernel, but since I can't boot either from the hard drive or a live CD with the later kernels, no dmesg is produced to provide. The same for the lspci run, this is from the 2.6.15 kernel, not the later one.

I really would like to get this computer up and going. The system is in a state of flux right now. Its got most of Feisty's binaries a vmware that won't run because my gcc doesn't match the kernel, etc. I'm not sure whats safe and whats not.

Rob Miracle (rob-robmiracle) wrote :

Here is the dmesg run for the previous entry since you can only attach one thing at a time apparently. Remember this is from the running older kernel, not the problem.

Changed in linux:
status: Unknown → In Progress
Changed in linux:
status: In Progress → Fix Released
Rob Miracle (rob-robmiracle) wrote :

2.6.20 with the irqpoll option now works fine on my computer. I upgraded to Gutsy and 2.6.22-14 has the same problem. irqpoll doesn't help it.

Rob

Oleksij Rempel (olerem) wrote :

if you have this issue with new 2.6.24 kernel please attach your
complete dmesg. I need to know which hardware affected.

Rob Miracle (rob-robmiracle) wrote :

fishor wrote:
> if you have this issue with new 2.6.24 kernel please attach your
> complete dmesg. I need to know which hardware affected.
>
>
Considering that I can't boot the 2.6.24 kernel, I can't get a dmsg for
it. I doubt the 2.6.22 kernel is going to report any different
hardware than the the dmesg I posted from the 2.6.15 kernel in the
thread already.

But to comply, I'll generate a dmesg when I get home tonight from the
2.6.20-16 kernel.

Rob

--
--
Rob Miracle
<email address hidden>
http://www.robmiracle.com

Oleksij Rempel (olerem) wrote :

Rob Miracle schrieb:
 I doubt the 2.6.22 kernel is going to report any different
> hardware than the the dmesg I posted from the 2.6.15 kernel in the
> thread already.

I don't have time to care about fixed hardware, it was made a lot of
work in 2.6.24.
So i need to know only hardware, not working with new kernel.

Rob Miracle (rob-robmiracle) wrote :
Download full text (31.5 KiB)

fishor wrote:
> if you have this issue with new 2.6.24 kernel please attach your
> complete dmesg. I need to know which hardware affected.
>
>
I installed the 2.6.24-1 386 kernel and when it tries to boot, it
generates the following messages:

ata3.00 qc timeout (cmd 0x27)
ata3.00 failed to read native max address (err_mask 0x4)

that repeated a couple of times. Then I got

ata3.00 revaluation failed (errno=-5)

and the whole sequence repeated if I remember.

I tried adding irqpoll to the boot sequence and it didn't help any.

I'm attaching a dmesg dump from booting Gutsy with the 2.26.20-16 kernel
which is latest kernel.

Thanks
Rob

[ 0.000000] Linux version 2.6.20-16-generic (root@terranova) (gcc version 4.1.2 (Ubuntu 4.1.2-0ubuntu4)) #2 SMP Sun Sep 23 19:50:39 UTC 2007 (Ubuntu 2.6.20-16.32-generic)
[ 0.000000] BIOS-provided physical RAM map:
[ 0.000000] sanitize start
[ 0.000000] sanitize end
[ 0.000000] copy_e820_map() start: 0000000000000000 size: 000000000009f800 end: 000000000009f800 type: 1
[ 0.000000] copy_e820_map() type is E820_RAM
[ 0.000000] copy_e820_map() start: 000000000009f800 size: 0000000000000800 end: 00000000000a0000 type: 2
[ 0.000000] copy_e820_map() start: 00000000000f0000 size: 0000000000010000 end: 0000000000100000 type: 2
[ 0.000000] copy_e820_map() start: 0000000000100000 size: 000000003fddf800 end: 000000003fedf800 type: 1
[ 0.000000] copy_e820_map() type is E820_RAM
[ 0.000000] copy_e820_map() start: 000000003fedf800 size: 0000000000000800 end: 000000003fee0000 type: 2
[ 0.000000] copy_e820_map() start: 000000003fee0000 size: 0000000000003000 end: 000000003fee3000 type: 4
[ 0.000000] copy_e820_map() start: 000000003fee3000 size: 000000000000d000 end: 000000003fef0000 type: 3
[ 0.000000] copy_e820_map() start: 000000003fef0000 size: 0000000000010000 end: 000000003ff00000 type: 2
[ 0.000000] copy_e820_map() start: 00000000f0000000 size: 0000000004000000 end: 00000000f4000000 type: 2
[ 0.000000] copy_e820_map() start: 00000000fec00000 size: 0000000001400000 end: 0000000100000000 type: 2
[ 0.000000] BIOS-e820: 0000000000000000 - 000000000009f800 (usable)
[ 0.000000] BIOS-e820: 000000000009f800 - 00000000000a0000 (reserved)
[ 0.000000] BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
[ 0.000000] BIOS-e820: 0000000000100000 - 000000003fedf800 (usable)
[ 0.000000] BIOS-e820: 000000003fedf800 - 000000003fee0000 (reserved)
[ 0.000000] BIOS-e820: 000000003fee0000 - 000000003fee3000 (ACPI NVS)
[ 0.000000] BIOS-e820: 000000003fee3000 - 000000003fef0000 (ACPI data)
[ 0.000000] BIOS-e820: 000000003fef0000 - 000000003ff00000 (reserved)
[ 0.000000] BIOS-e820: 00000000f0000000 - 00000000f4000000 (reserved)
[ 0.000000] BIOS-e820: 00000000fec00000 - 0000000100000000 (reserved)
[ 0.000000] 126MB HIGHMEM available.
[ 0.000000] 896MB LOWMEM available.
[ 0.000000] found SMP MP-table at 000f5eb0
[ 0.000000] Entering add_active_range(0, 0, 261855) 0 entries of 256 used
[ 0.000000] Zone PFN ranges:
[ 0.000000] DMA 0 -> 4096
[ 0.000000] Normal 4096 -> 229376
[ 0.000000] HighMem 2...

Oleksij Rempel (olerem) wrote :

Ok Rob, you have WDC WD2500JD-22HBC0 attached to ICH7, this is issue for
 ata_piix module.

Forwarding this to bugzilla upstream:
http://bugzilla.kernel.org/show_bug.cgi?id=9540

Regards
Alex

Ned (alabatros) wrote :

Does anyone know if there's a way to integrate the .deb patch onto a CD? The bug prevents me from using the hard drives on the affected system, so installation of the OS, and therefore the patch, is not possible.

Oleksij Rempel (olerem) wrote :

Rob, please subscribe yourself to the upstream bug. Fallow the link in my previous post.

Rob Miracle (rob-robmiracle) wrote :

fishor wrote:
> Rob, please subscribe yourself to the upstream bug. Fallow the link in
> my previous post.
>
>
Done!

--
--
Rob Miracle
<email address hidden>
http://www.robmiracle.com

Oleksij Rempel (olerem) wrote :

Ned, you do not need to make livecd to test kernel.
we can try do it with build in initramfs, bat you need some storage to save dmesg in, for example usb-stick.

1. plug the usb-stick in.
2. boot with kernel option break=mount
3. mkdir mnt
4. mount -t vfat /dev/sdb1 /mnt ( edit it to your need, change file system type and device location )
5, dd if=/proc/kmsg of=/mnt/dmesg
6. wait 5 seconds and reboot with ctrl+alt+del

if you have some correction, please lat me know ;)

Ned (alabatros) wrote :

I managed to get the patch installed to test it. The patch fixes the problem. Many thanks to fishor and Tejun.

gebi (gebi) wrote :

same on hardy beta:
maybe a duplicate of bug Bug #107982
https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/107982

where my cdrom was not anymore recognized, but the irqpoll kernel option fixed the problem

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Download full text (3.7 KiB)

I'll try and test it this weekend. I'm on Gutsy at the moment, so do I
need to put anything in my source list to find the package?

Let me ask you a question. But a bit of history first. This machine
used to run WinXP but one day it just froze hard. When it rebooted it
got to the end of the white progress bar and froze. Wouldn't boot in
safemode. Couldn't come up in repair mode. Figuring the drive was
being a problem, I booted a Ubuntu live CD mounted the drive and it was
fine and I managed to get a good backup. So I decided to reload
Windows. Would not install. I even tried Win2K, no luck. Once I
installed Ubuntu Edgy, it ran like a charm until I went to the 686
kernel and the keyboard didn't work.

I falsely assumed that hinted that the 2nd processor was dead and that
Windows was trying to enable it at boot time since the 386 kernel ran fine.

After a patch release to Edgy the 686 Kernel started working, so at that
point I knew something was amis elsewhere. 2.6.16 was the last kernel
to work as packaged on this machine.

I think it was the upgrade to Feisty that caused my system to no longer
boot with this set xfer mode error. However, I found that I could set
irqpoll parameter in the list file with all the kernels and it would
boot fine. This worked up until 2.6.20. Sometime after 2.6.20,
turning off irqpoll no longer fixed anything.

So it seems that its a physical problem with the SATA controller and I
suspect that some feature got turned on post 2.6.16 that no irqpoll
turned back off and that feature was turned on permanently in kernels
greater than 2.6.20. If I had a way to make the newer kernels behave
like 2.6.16 or 2.6.20 with irqpoll turned off, I could continue to move
forward with OS releases.

As it is with the kernel problems showing up during an upgrade, my
system is a mess right now (USB devices don't work, Samba won't talk the
rest of the network, etc.) and I want to throw a brand new install on
there, but I can't because of this controller issue.

Do you have any idea what new SATA feature got added between 2.6.16 and
now that could be triggering this? If I knew, I'd grab the source, and
build a custom kernel, throw 8.04LTS on and be done with it.

Even if I test this and it still fails, I say move on because there was
a definite break point in my hardware and without knowing what you guys
shouldn't be building a feature just for me. However the ability to
turn off the feature would be nice.

Thanks,
Rob

Leann Ogasawara wrote:
> The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the
> upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would
> appreciate it if you could please test this newer 2.6.27 Ubuntu kernel.
> There are one of two ways you should be able to test:
>
> 1) If you are comfortable installing packages on your own, the linux-
> image-2.6.27-* package is currently available for you to install and
> test.
>
> --or--
>
> 2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer
> 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4.
> Please watch http://www.ubuntu.com/testing for Alpha5 to be an...

Read more...

Rob Miracle (rob-robmiracle) wrote :

I've installed 2.6.27-2-generic and rebooted and it successfully booted. I'm doing a full upgrade to Intrepid at the moment, hopefully that will fix all of the oddities going on with my system, but at least I know I can take the LiveCD and reload the computer from scratch.

yea team!

Thanks
Rob

Setting this to "Fix Released" based on the decision to stick with the 2.6.27 kernel for Intrepid - https://lists.ubuntu.com/archives/kernel-team/2008-September/003107.html

Changed in linux:
status: Incomplete → Fix Released

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Changed in linux:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.