Comment 16 for bug 112132

Michael Marley (mamarley) wrote :

I have exactly the same problem. I just installed Kubuntu on my PC using Wubi, and when I tell it to boot stalls and then displays the following error:

[33.23433] ata2.01: failed to set xfermode (err-mask= 0x4)
[69.030658] ata 2.01: failed to set xfermode (err-mask= 0x4)
[104.826988] ata 2.01: failed to set xfermode (err-mask= 0x4)
[109.827119] ata 2.02: failed to set xfermode (err-mask = 0x40)

Then it says something like:

[ACPI] invalid pblck length (5)

and then it continues the normal booting process. After it boots up, the system is perfectly normal. Also, I have previously tried running normal installations from the LiveCD. These attempts have produced the same results. I have also tried adding "irqpoll" to the GRUB configuration file to no avail.

Here are my system specs:

Asus CUSL2-C Motherboard (i815ep northbridge) (ICH2 southbridge)
Pentium III 1gHz Coppermine (not overclocked) and 512 MB SDR SDRAM.
Radeon 9200 (RV280) 128MB DDR AGP Video Card
Western Digital 80gb HDD
LG 16x DVD-ROM Drive (which works)
Lite-On 40x CD Burner (which works)
Several other PCI cards:
Intel PRO/100 LAN card
Sound Blaster Audigy (EMU10k1) Sound Card
USB 2.0 card (with NEC chipset (no VIA crap here!))
D-Link DWL-G510 Wireless LAN card (Atheros AR5005 chipset)

I am running kernel version 2.6.20-16, and all other applicable software updates have been applied. I am really glad to know that this is a widespread problem and not a problem with my box! Thanks in advance for any help.