Comment 42 for bug 112132

I'll try and test it this weekend. I'm on Gutsy at the moment, so do I
need to put anything in my source list to find the package?

Let me ask you a question. But a bit of history first. This machine
used to run WinXP but one day it just froze hard. When it rebooted it
got to the end of the white progress bar and froze. Wouldn't boot in
safemode. Couldn't come up in repair mode. Figuring the drive was
being a problem, I booted a Ubuntu live CD mounted the drive and it was
fine and I managed to get a good backup. So I decided to reload
Windows. Would not install. I even tried Win2K, no luck. Once I
installed Ubuntu Edgy, it ran like a charm until I went to the 686
kernel and the keyboard didn't work.

I falsely assumed that hinted that the 2nd processor was dead and that
Windows was trying to enable it at boot time since the 386 kernel ran fine.

After a patch release to Edgy the 686 Kernel started working, so at that
point I knew something was amis elsewhere. 2.6.16 was the last kernel
to work as packaged on this machine.

I think it was the upgrade to Feisty that caused my system to no longer
boot with this set xfer mode error. However, I found that I could set
irqpoll parameter in the list file with all the kernels and it would
boot fine. This worked up until 2.6.20. Sometime after 2.6.20,
turning off irqpoll no longer fixed anything.

So it seems that its a physical problem with the SATA controller and I
suspect that some feature got turned on post 2.6.16 that no irqpoll
turned back off and that feature was turned on permanently in kernels
greater than 2.6.20. If I had a way to make the newer kernels behave
like 2.6.16 or 2.6.20 with irqpoll turned off, I could continue to move
forward with OS releases.

As it is with the kernel problems showing up during an upgrade, my
system is a mess right now (USB devices don't work, Samba won't talk the
rest of the network, etc.) and I want to throw a brand new install on
there, but I can't because of this controller issue.

Do you have any idea what new SATA feature got added between 2.6.16 and
now that could be triggering this? If I knew, I'd grab the source, and
build a custom kernel, throw 8.04LTS on and be done with it.

Even if I test this and it still fails, I say move on because there was
a definite break point in my hardware and without knowing what you guys
shouldn't be building a feature just for me. However the ability to
turn off the feature would be nice.

Thanks,
Rob

Leann Ogasawara wrote:
> The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the
> upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would
> appreciate it if you could please test this newer 2.6.27 Ubuntu kernel.
> There are one of two ways you should be able to test:
>
> 1) If you are comfortable installing packages on your own, the linux-
> image-2.6.27-* package is currently available for you to install and
> test.
>
> --or--
>
> 2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer
> 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4.
> Please watch http://www.ubuntu.com/testing for Alpha5 to be announced.
> You should then be able to test via a LiveCD.
>
> Please let us know immediately if this newer 2.6.27 kernel resolves the
> bug reported here or if the issue remains. More importantly, please
> open a new bug report for each new bug/regression introduced by the
> 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please
> specifically note if the issue does or does not appear in the 2.6.26
> kernel. Thanks again, we really appreicate your help and feedback.
>
> ** Tags added: cft-2.6.27
>

--
--
Rob Miracle
<email address hidden>
http://www.robmiracle.com