[ata_piix][NONCQ] failed to set xfermode

Bug #107982 reported by Matti Laakso on 2007-04-20
12
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-source-2.6.20

After upgrading from 6.10 to 7.04 final my computer no longer boots without irqpoll -option. Without irqpoll I get two times (about one minute in between) the message:

ata3.00: failed to set xfermode (err_mask=0x4)

After about a minute from this I get dropped to a BusyBox shell. With irqpoll I am able to boot.

I have an Abit AB9 motherboard (Intel 965 chipset) with my SATA hard disk connected to ICH8 and PATA CD/DVD connected to onboard JMicron-controller. Processor is Intel Core 2 Duo E6600.

Matti Laakso (matti-laakso) wrote :
Matti Laakso (matti-laakso) wrote :
Oleksij Rempel (olerem) wrote :

Please can you test Ubuntu Gutsy.

Oleksij Rempel (olerem) wrote :

I guess we need change
libata-core.c
 - { "HDT722516DLA380", "V43OA96A", ATA_HORKAGE_NONCQ, },
+ { "HDT722516DLA380", NULL, ATA_HORKAGE_NONCQ, },

Changed in linux-source-2.6.20:
status: New → Incomplete
Matti Laakso (matti-laakso) wrote :

Issue still exists in Gutsy.

Oleksij Rempel (olerem) on 2007-11-26
Changed in linux-source-2.6.20:
status: Incomplete → Confirmed
Brian Murray (brian-murray) wrote :

I am assigning this bug to the 'ubuntu-kernel-team' per their bug policy. For future reference you can learn more about their bug policy at https://wiki.ubuntu.com/KernelTeamBugPolicies .

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
gebi (gebi) wrote :

similar problem on hardy beta

my cdrom is not anymore recognized.
from dmesg:

[ 28.641504] ata2.00: failed to set xfermode (err_mask=0x1)
[ 28.641562] ata2.00: limiting speed to UDMA/33:PIO3
[ 28.641564] ata2: failed to recover some devices, retrying in 5 secs
[ 34.431373] ata2.00: failed to set xfermode (err_mask=0x1)
[ 34.431427] ata2.00: disabled

adding the irqpoll option as kernel-parameter fixed the problem:

title Ubuntu hardy (development branch), kernel 2.6.24-15-rt
root (hd0,0)
kernel /boot/vmlinuz-2.6.24-15-rt root=UUID=45b06837-70c1-4bb8-9543-fbbd04a75532 ro quiet splash irqpoll
initrd /boot/initrd.img-2.6.24-15-rt

Matti Laakso (matti-laakso) wrote :

Still the same with Hardy RC.

Nora Kischer-Browne (azetidine) wrote :

I got the same error trying to boot 2.6.24. here's approximately what happened (I wrote it down by hand at the time).

 [system clock time] ata1.00: qc timeout (cmd 0x27) failed to read native max address (err_mask = 0x4)
 failed to recover some devices, retrying in 5 secs
 [system clock time] ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
 [system clock time] ata2.00: cmd a0/00:00:00:24:00/00:00:00:00:00/a0 tag 0 pio0 36in
 [system clock time] ata2.00: status: {DRDY}

 and then it would loop the last three messages for longer than 10 minutes before going to a BusyBox shell. using the irqpoll option worked to get it functional.

Liz Fong-Jones (lizthegrey) wrote :

multiple people have reported this in Hardy, which uses 2.6.24

Changed in linux-source-2.6.24:
status: New → Confirmed

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Matti Laakso (matti-laakso) wrote :

My issue has been resolved in 8.10 Alpha5 live CD.

Thanks for the note. Marking this "Fix Released" for Intrepid. Against 2.6.22 this will be closed.

Changed in linux:
status: Confirmed → Fix Released
Changed in linux-source-2.6.22:
status: Confirmed → Won't Fix

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers