Ubuntu

package libreoffice-core 1:3.4.4-0ubuntu2 failed to install/upgrade: rmdir: failed to remove `usr/lib/libreoffice/basis3.4/program/': Directory not empty

Reported by Laura Czajkowski on 2012-01-12
This bug affects 250 people
Affects Status Importance Assigned to Milestone
LibreOffice Productivity Suite
Invalid
Undecided
Unassigned
libreoffice (Ubuntu)
Critical
Unassigned
Precise
Critical
Lazar Stojkovic

Bug Description

running updates/upgrades on Precise machine and message popped up saying it needed to report this bug.

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: libreoffice-core 1:3.4.4-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-7.13-generic 3.2.0-rc7
Uname: Linux 3.2.0-7-generic x86_64
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
Date: Thu Jan 12 11:44:43 2012
DuplicateSignature:
 Unpacking replacement libreoffice-math ...
 Preparing to replace libreoffice-core 1:3.4.4-0ubuntu2 (using .../libreoffice-core_1%3a3.5.0~beta2-2ubuntu2_amd64.deb) ...
 rmdir: failed to remove `usr/lib/libreoffice/basis3.4/program/': Directory not empty
 dpkg: error processing /var/cache/apt/archives/libreoffice-core_1%3a3.5.0~beta2-2ubuntu2_amd64.deb (--unpack):
  subprocess new pre-installation script returned error exit status 1
ErrorMessage: subprocess new pre-installation script returned error exit status 1
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
SourcePackage: libreoffice
Title: package libreoffice-core 1:3.4.4-0ubuntu2 failed to install/upgrade: subprocess new pre-installation script returned error exit status 1
UpgradeStatus: Upgraded to precise on 2012-01-05 (6 days ago)

Laura Czajkowski (czajkowski) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Nest (nestor15) wrote :

This crash has bad consequences:

It messed up with the package catalog / depencies. The software-center is unable to repair the damage and can no longer do anything. :/

Nest (nestor15) wrote :

apt-get can't fix the depencies. I can't uinstall libreoffice and apt-get upgrade no longer works.

Please email me if you have an idea how I can get my system working again.

dino99 (9d9) wrote :

@Nest : see #915332

Nest (nestor15) wrote :

@dino: Thanks for your help, but unfortunately it doesn't work.

mkdir: cannot create directory `/usr/lib/libreoffice/basis3.4/program/': File exists

Žilvinas Valinskas (zval) wrote :

This worked for me well:

$ sudo mv /usr/lib/libreoffice/basis3.4/program/ /usr/lib/libreoffice/basis3.4/program.old
$ sudo mkdir /usr/lib/libreoffice/basis3.4/program/
$ sudo apt-get install -f
$ sudo mv /usr/lib/libreoffice/basis3.4/program.old /usr/lib/libreoffice/basis3.4/program

Nest (nestor15) wrote :

@Žilvinas Valinskas: Worked fine, thanks! :)

fejes (anthony-fejes) wrote :

workaround worked for me. Thanks.

Xavier Bassery (xaba) on 2012-01-12
summary: package libreoffice-core 1:3.4.4-0ubuntu2 failed to install/upgrade:
- subprocess new pre-installation script returned error exit status 1
+ rmdir: failed to remove `usr/lib/libreoffice/basis3.4/program/':
+ Directory not empty
Emanuele Sottocorno (sotema) wrote :

@zval: worked for me too. Thanks

Andreas Moog (amoog) on 2012-01-12
Changed in libreoffice (Ubuntu):
importance: Undecided → Critical
carlos palma (carlos-palma) wrote :

Also for me. Thanks.

DaleEMoore (daleemoore) wrote :

https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/915271/comments/7 worked for me.

$ sudo -s
mv /usr/lib/libreoffice/basis3.4/program/ /usr/lib/libreoffice/basis3.4/program.old
mkdir /usr/lib/libreoffice/basis3.4/program/
apt-get install -f
mv /usr/lib/libreoffice/basis3.4/program.old /usr/lib/libreoffice/basis3.4/program

Barry Drake (b-drake) wrote :

Worked for me too. Thanks.

Eddie Kane (eddiekane150) wrote :

@DaleEMoore

worked for me as well as root:

sudo -s

$ sudo -s
mv /usr/lib/libreoffice/basis3.4/program/ /usr/lib/libreoffice/basis3.4/program.old
mkdir /usr/lib/libreoffice/basis3.4/program/
apt-get install -f
mv /usr/lib/libreoffice/basis3.4/program.old /usr/lib/libreoffice/basis3.4/program

M@ts (mats-900) wrote :

Thanks ........ Worked for me too.

// M@ts

There’s a similar problem when uninstalling and reinstalling all the libreoffice packages:

Unpacking libreoffice-core (from .../libreoffice-core_1%3a3.5.0~beta2-2ubuntu2_amd64.deb) ...
rmdir: failed to remove `usr/lib/libreoffice/basis3.4/program/': No such file or directory
dpkg: error processing /var/cache/apt/archives/libreoffice-core_1%3a3.5.0~beta2-2ubuntu2_amd64.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1

The paths in libreoffice-core.preinst are missing a leading /, and the script should be written so it doesn’t fail when the directory isn’t there.

Bart Willemsen (b-willemsen8) wrote :

Don't have access to my 12.04 testmachine right now but will try that fix as soon as I can.

The move to old directory, apt-install -f workaround worked for me. I initially did a purge and apt-get update/upgrade to deal with the lack of libreoffice directory. Then, once there was directory present in /usr the workaround was successful. I myself do not know the root of the issue. Workaround was posted by another user in launchpad. I can't get to my dev box right now either.

Sent from Eddie's iPhone
odosielané z iPhone Eddieho

On Jan 12, 2012, at 4:57 PM, Bart Willemsen <email address hidden> wrote:

> Don't have access to my 12.04 testmachine right now but will try that
> fix as soon as I can.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/915271
>
> Title:
> package libreoffice-core 1:3.4.4-0ubuntu2 failed to install/upgrade:
> rmdir: failed to remove `usr/lib/libreoffice/basis3.4/program/':
> Directory not empty
>
> Status in LibreOffice Productivity Suite:
> New
> Status in “libreoffice” package in Ubuntu:
> Confirmed
>
> Bug description:
> running updates/upgrades on Precise machine and message popped up
> saying it needed to report this bug.
>
> ProblemType: Package
> DistroRelease: Ubuntu 12.04
> Package: libreoffice-core 1:3.4.4-0ubuntu2
> ProcVersionSignature: Ubuntu 3.2.0-7.13-generic 3.2.0-rc7
> Uname: Linux 3.2.0-7-generic x86_64
> ApportVersion: 1.90-0ubuntu1
> Architecture: amd64
> Date: Thu Jan 12 11:44:43 2012
> DuplicateSignature:
> Unpacking replacement libreoffice-math ...
> Preparing to replace libreoffice-core 1:3.4.4-0ubuntu2 (using .../libreoffice-core_1%3a3.5.0~beta2-2ubuntu2_amd64.deb) ...
> rmdir: failed to remove `usr/lib/libreoffice/basis3.4/program/': Directory not empty
> dpkg: error processing /var/cache/apt/archives/libreoffice-core_1%3a3.5.0~beta2-2ubuntu2_amd64.deb (--unpack):
> subprocess new pre-installation script returned error exit status 1
> ErrorMessage: subprocess new pre-installation script returned error exit status 1
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
> SourcePackage: libreoffice
> Title: package libreoffice-core 1:3.4.4-0ubuntu2 failed to install/upgrade: subprocess new pre-installation script returned error exit status 1
> UpgradeStatus: Upgraded to precise on 2012-01-05 (6 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/df-libreoffice/+bug/915271/+subscriptions

@Žilvinas Valinskas: Thanks, this workaround works for me too.

Charles Durant (chrlsdrnt) wrote :

Works for me as well. 64 bit.

$ sudo mv /usr/lib/libreoffice/basis3.4/program/ /usr/lib/libreoffice/basis3.4/program.old
$ sudo mkdir /usr/lib/libreoffice/basis3.4/program/
$ sudo apt-get install -f

Worked great - thanks ! !

On Thu, Jan 12, 2012 at 7:49 PM, Charles Durant
<email address hidden> wrote:
> Works for me as well. 64 bit.
>
> $ sudo mv /usr/lib/libreoffice/basis3.4/program/ /usr/lib/libreoffice/basis3.4/program.old
> $ sudo mkdir /usr/lib/libreoffice/basis3.4/program/
> $ sudo apt-get install -f
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (915633).
> https://bugs.launchpad.net/bugs/915271
>
> Title:
>  package libreoffice-core 1:3.4.4-0ubuntu2 failed to install/upgrade:
>  rmdir: failed to remove `usr/lib/libreoffice/basis3.4/program/':
>  Directory not empty
>
> Status in LibreOffice Productivity Suite:
>  New
> Status in “libreoffice” package in Ubuntu:
>  Confirmed
>
> Bug description:
>  running updates/upgrades on Precise machine and message popped up
>  saying it needed to report this bug.
>
>  ProblemType: Package
>  DistroRelease: Ubuntu 12.04
>  Package: libreoffice-core 1:3.4.4-0ubuntu2
>  ProcVersionSignature: Ubuntu 3.2.0-7.13-generic 3.2.0-rc7
>  Uname: Linux 3.2.0-7-generic x86_64
>  ApportVersion: 1.90-0ubuntu1
>  Architecture: amd64
>  Date: Thu Jan 12 11:44:43 2012
>  DuplicateSignature:
>   Unpacking replacement libreoffice-math ...
>   Preparing to replace libreoffice-core 1:3.4.4-0ubuntu2 (using .../libreoffice-core_1%3a3.5.0~beta2-2ubuntu2_amd64.deb) ...
>   rmdir: failed to remove `usr/lib/libreoffice/basis3.4/program/': Directory not empty
>   dpkg: error processing /var/cache/apt/archives/libreoffice-core_1%3a3.5.0~beta2-2ubuntu2_amd64.deb (--unpack):
>    subprocess new pre-installation script returned error exit status 1
>  ErrorMessage: subprocess new pre-installation script returned error exit status 1
>  InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
>  SourcePackage: libreoffice
>  Title: package libreoffice-core 1:3.4.4-0ubuntu2 failed to install/upgrade: subprocess new pre-installation script returned error exit status 1
>  UpgradeStatus: Upgraded to precise on 2012-01-05 (6 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/df-libreoffice/+bug/915271/+subscriptions

worked for me, 64 bit - Thanks...

$ sudo mv /usr/lib/libreoffice/basis3.4/program/ /usr/lib/libreoffice/basis3.4/program.old
$ sudo mkdir /usr/lib/libreoffice/basis3.4/program/
$ sudo apt-get install -f

I take it back... Don't work!

Eddie Kane (eddiekane150) wrote :

You can also sudo -s ,switch to root, save you a little typing.

Sent from Eddie's iPhone
odosielané z iPhone Eddieho

On Jan 12, 2012, at 9:12 PM, phantomcharlie309 <email address hidden> wrote:

> worked for me, 64 bit - Thanks...
>
> $ sudo mv /usr/lib/libreoffice/basis3.4/program/ /usr/lib/libreoffice/basis3.4/program.old
> $ sudo mkdir /usr/lib/libreoffice/basis3.4/program/
> $ sudo apt-get install -f
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/915271
>
> Title:
> package libreoffice-core 1:3.4.4-0ubuntu2 failed to install/upgrade:
> rmdir: failed to remove `usr/lib/libreoffice/basis3.4/program/':
> Directory not empty
>
> Status in LibreOffice Productivity Suite:
> New
> Status in “libreoffice” package in Ubuntu:
> Confirmed
>
> Bug description:
> running updates/upgrades on Precise machine and message popped up
> saying it needed to report this bug.
>
> ProblemType: Package
> DistroRelease: Ubuntu 12.04
> Package: libreoffice-core 1:3.4.4-0ubuntu2
> ProcVersionSignature: Ubuntu 3.2.0-7.13-generic 3.2.0-rc7
> Uname: Linux 3.2.0-7-generic x86_64
> ApportVersion: 1.90-0ubuntu1
> Architecture: amd64
> Date: Thu Jan 12 11:44:43 2012
> DuplicateSignature:
> Unpacking replacement libreoffice-math ...
> Preparing to replace libreoffice-core 1:3.4.4-0ubuntu2 (using .../libreoffice-core_1%3a3.5.0~beta2-2ubuntu2_amd64.deb) ...
> rmdir: failed to remove `usr/lib/libreoffice/basis3.4/program/': Directory not empty
> dpkg: error processing /var/cache/apt/archives/libreoffice-core_1%3a3.5.0~beta2-2ubuntu2_amd64.deb (--unpack):
> subprocess new pre-installation script returned error exit status 1
> ErrorMessage: subprocess new pre-installation script returned error exit status 1
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
> SourcePackage: libreoffice
> Title: package libreoffice-core 1:3.4.4-0ubuntu2 failed to install/upgrade: subprocess new pre-installation script returned error exit status 1
> UpgradeStatus: Upgraded to precise on 2012-01-05 (6 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/df-libreoffice/+bug/915271/+subscriptions

Eddie Kane (eddiekane150) wrote :

Did you move current to old the install -f then move back. Sorry I don't have my dev box at hand.

Sent from Eddie's iPhone
odosielané z iPhone Eddieho

On Jan 12, 2012, at 9:24 PM, phantomcharlie309 <email address hidden> wrote:

> I take it back... Don't work!
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/915271
>
> Title:
> package libreoffice-core 1:3.4.4-0ubuntu2 failed to install/upgrade:
> rmdir: failed to remove `usr/lib/libreoffice/basis3.4/program/':
> Directory not empty
>
> Status in LibreOffice Productivity Suite:
> New
> Status in “libreoffice” package in Ubuntu:
> Confirmed
>
> Bug description:
> running updates/upgrades on Precise machine and message popped up
> saying it needed to report this bug.
>
> ProblemType: Package
> DistroRelease: Ubuntu 12.04
> Package: libreoffice-core 1:3.4.4-0ubuntu2
> ProcVersionSignature: Ubuntu 3.2.0-7.13-generic 3.2.0-rc7
> Uname: Linux 3.2.0-7-generic x86_64
> ApportVersion: 1.90-0ubuntu1
> Architecture: amd64
> Date: Thu Jan 12 11:44:43 2012
> DuplicateSignature:
> Unpacking replacement libreoffice-math ...
> Preparing to replace libreoffice-core 1:3.4.4-0ubuntu2 (using .../libreoffice-core_1%3a3.5.0~beta2-2ubuntu2_amd64.deb) ...
> rmdir: failed to remove `usr/lib/libreoffice/basis3.4/program/': Directory not empty
> dpkg: error processing /var/cache/apt/archives/libreoffice-core_1%3a3.5.0~beta2-2ubuntu2_amd64.deb (--unpack):
> subprocess new pre-installation script returned error exit status 1
> ErrorMessage: subprocess new pre-installation script returned error exit status 1
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
> SourcePackage: libreoffice
> Title: package libreoffice-core 1:3.4.4-0ubuntu2 failed to install/upgrade: subprocess new pre-installation script returned error exit status 1
> UpgradeStatus: Upgraded to precise on 2012-01-05 (6 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/df-libreoffice/+bug/915271/+subscriptions

Eddie Kane (eddiekane150) wrote :

Dir not empty? Did you move base32 (I think doing this from memory) to base32.old , mkdir base32 , apt-install -f then move .old back?

Sent from Eddie's iPhone
odosielané z iPhone Eddieho

On Jan 12, 2012, at 9:24 PM, phantomcharlie309 <email address hidden> wrote:

> I take it back... Don't work!
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/915271
>
> Title:
> package libreoffice-core 1:3.4.4-0ubuntu2 failed to install/upgrade:
> rmdir: failed to remove `usr/lib/libreoffice/basis3.4/program/':
> Directory not empty
>
> Status in LibreOffice Productivity Suite:
> New
> Status in “libreoffice” package in Ubuntu:
> Confirmed
>
> Bug description:
> running updates/upgrades on Precise machine and message popped up
> saying it needed to report this bug.
>
> ProblemType: Package
> DistroRelease: Ubuntu 12.04
> Package: libreoffice-core 1:3.4.4-0ubuntu2
> ProcVersionSignature: Ubuntu 3.2.0-7.13-generic 3.2.0-rc7
> Uname: Linux 3.2.0-7-generic x86_64
> ApportVersion: 1.90-0ubuntu1
> Architecture: amd64
> Date: Thu Jan 12 11:44:43 2012
> DuplicateSignature:
> Unpacking replacement libreoffice-math ...
> Preparing to replace libreoffice-core 1:3.4.4-0ubuntu2 (using .../libreoffice-core_1%3a3.5.0~beta2-2ubuntu2_amd64.deb) ...
> rmdir: failed to remove `usr/lib/libreoffice/basis3.4/program/': Directory not empty
> dpkg: error processing /var/cache/apt/archives/libreoffice-core_1%3a3.5.0~beta2-2ubuntu2_amd64.deb (--unpack):
> subprocess new pre-installation script returned error exit status 1
> ErrorMessage: subprocess new pre-installation script returned error exit status 1
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
> SourcePackage: libreoffice
> Title: package libreoffice-core 1:3.4.4-0ubuntu2 failed to install/upgrade: subprocess new pre-installation script returned error exit status 1
> UpgradeStatus: Upgraded to precise on 2012-01-05 (6 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/df-libreoffice/+bug/915271/+subscriptions

Eddie Kane (eddiekane150) wrote :

1. check to make sure that basis3.4 is there and has contents....broken
packages and whatnot.

Did you do this first creating empty directory? ---> sudo mv
/usr/lib/libreoffice/basis3.4/program/
/usr/lib/libreoffice/basis3.4/program.old

sudo mkdir /usr/lib/libreoffice/basis3.4/program/
sudo apt-get install -f
sudo mv /usr/lib/libreoffice/basis3.4/program.old
/usr/lib/libreoffice/basis3.4/program

On 01/12/2012 09:24 PM, phantomcharlie309 wrote:
> I take it back... Don't work!
>

Giovanni Mellini (merlos) wrote :

the fix on comment #7 worked for me too. tks

Jacob Mayle (jacobvengeance) wrote :

I am glad that fix worked, the smallest things seem to annoy me. It does however give me the error sometimes on synaptics package manager, but never stays around.

Brian Smith (brian-smith-i) wrote :

worked for me thanks

Changed in libreoffice (Ubuntu):
status: Confirmed → Triaged
Franco Bombi (franco.bombi) wrote :

works for me on a VirtualBox test
--fb

Il 13/01/2012 01:49, Charles Durant ha scritto:
> Works for me as well. 64 bit.
>
> $ sudo mv /usr/lib/libreoffice/basis3.4/program/ /usr/lib/libreoffice/basis3.4/program.old
> $ sudo mkdir /usr/lib/libreoffice/basis3.4/program/
> $ sudo apt-get install -f
>

--
Franco Bombi
<email address hidden>
+39 3472240520 - +39 049654025
skype franco.bombi

Bart Willemsen (b-willemsen8) wrote :

I can confirm that the fix mentioned above (moving program to program.old, fix dependencies than revert program.old back) does fix LibreOffice.

So now we got a workaround, is there a way to fix this so this won't happen with a future update?

Colin Watson (cjwatson) on 2012-01-13
Changed in libreoffice (Ubuntu Precise):
milestone: none → precise-alpha-2
tags: added: rls-mgr-p-tracking
tags: added: bugpattern-written

This worked for me

sudo mkdir-p / usr/lib/libreoffice/basis3.4/program & & sudo touch / usr/lib/libreoffice/basis3.4/program/services.rdb

cat / var / lib / dpkg / info / LibreOffice-core.preinst
# / bin / sh

set-e

PlatformId = linux_x86_64

if ["$ 1" = "upgrade"-o "$ 1" = "install"]; then
rm-f `echo usr / lib / LibreOffice | sed-es, / usr /, / var, g` / basis3.4/program/services.rdb
`echo rmdir usr / lib / LibreOffice | sed-es, / usr /, / var, g` / basis3.4/program /
fi

exit 0

Ian Booth (wallyworld) wrote :

Thank you. All good now :-)

On 13/01/12 22:58, hellojoker wrote:
> This worked for me
>
>
> sudo mkdir-p / usr/lib/libreoffice/basis3.4/program & & sudo touch / usr/lib/libreoffice/basis3.4/program/services.rdb
>
>
> cat / var / lib / dpkg / info / LibreOffice-core.preinst
> # / bin / sh
>
> set-e
>
> PlatformId = linux_x86_64
>
>
> if ["$ 1" = "upgrade"-o "$ 1" = "install"]; then
> rm-f `echo usr / lib / LibreOffice | sed-es, / usr /, / var, g` / basis3.4/program/services.rdb
> `echo rmdir usr / lib / LibreOffice | sed-es, / usr /, / var, g` / basis3.4/program /
> fi
>
>
> exit 0
>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:3.5.0~beta2-2ubuntu3

---------------
libreoffice (1:3.5.0~beta2-2ubuntu3) precise; urgency=low

  * enable l10n
  * get rid of obsolete BrOffice specialcasing (LP: #884786)
  * add control tags as per 'firefox distro add-on support'-spec (picked
    from oneiric-3.4)
  * enable human theme and make it the default for gtk desktops
  * cherry-pick Replaces commit from 3.4 (LP: #705343)
  * cherry-pick demotion of java-Recommends for -writer to Suggests
  * make preinst cleanup a bit more robust (LP: #915271)
 -- Bjoern Michaelsen <email address hidden> Fri, 13 Jan 2012 11:09:32 +0100

Changed in libreoffice (Ubuntu Precise):
status: Triaged → Fix Released
Bart Willemsen (b-willemsen8) wrote :

Great, thanks for the patch! :D

joelito (joel-caez-gmail) wrote :

At the risk of sounding stupid but if the installer was trying to remove the directory altogether why do you want to recreate it.

Woud something like this work better
$sudo -s
# rm -r /usr/lib/libreoffice/basis3.4/program/
# mkdir /usr/lib/libreoffice/basis3.4/program/
# apt-get -f install

Piero (it9cvi) wrote :

resolved, thank you.

Robert Collard (bobcollard) wrote :

This worked for me as well:

$ sudo mv /usr/lib/libreoffice/basis3.4/program/ /usr/lib/libreoffice/basis3.4/program.old
$ sudo mkdir /usr/lib/libreoffice/basis3.4/program/
$ sudo apt-get install -f
$ sudo mv /usr/lib/libreoffice/basis3.4/program.old /usr/lib/libreoffice/basis3.4/program

Thanks

Scott Lewin (sclewin) wrote :

Is the fix released yet? I ask because I am still getting the following error when trying to re-install libreoffice calc

 "libreoffice-calc:
 Depends: libreoffice-core but it is not going to be installed
 Depends: libreoffice-base-core but it is not going to be installed"

Key Schmidt (khbgschmidt) wrote :

Thanks you for the solution...

Key

Sam_ (and-sam) wrote :

apt-get -f install still says:
rmdir: failed to remove `usr/lib/libreoffice/basis3.4/program/': Directory not empty
dpkg: error processing /var/cache/apt/archives/libreoffice-core_1%3a3.5.0~beta2-2ubuntu2_amd64.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/libreoffice-core_1%3a3.5.0~beta2-2ubuntu2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Then use workaround from #7, terminal ouput says:
Preparing to replace libreoffice-core 1:3.4.4-0ubuntu2 (using .../libreoffice-core_1%3a3.5.0~beta2-2ubuntu2_amd64.deb) ...
Unpacking replacement libreoffice-core ...
dpkg: warning: unable to delete old directory '/var/lib/libreoffice/basis3.4/program': Directory not empty
dpkg: warning: unable to delete old directory '/var/lib/libreoffice/basis3.4': Directory not empty
dpkg: warning: unable to delete old directory '/usr/lib/libreoffice/basis3.4': Directory not empty

Eddie Kane (eddiekane150) wrote :

The bug was fixed in the package i belive, there was a post today about
five hours from this email. Did you remove all of the old packages?

https://bugs.launchpad.net/df-libreoffice/+bug/915271

'

Launchpad Janitor (janitor) <https://launchpad.net/%7Ejanitor> wrote 5
hours ago:

This bug was fixed in the package libreoffice - 1:3.5.0~beta2-2ubuntu3

---------------
libreoffice (1:3.5.0~beta2-2ubuntu3) precise; urgency=low

  * enable l10n
  * get rid of obsolete BrOffice specialcasing (LP: #884786
<https://bugs.launchpad.net/bugs/884786>)
  * add control tags as per 'firefox distro add-on support'-spec (picked
    from oneiric-3.4)
  * enable human theme and make it the default for gtk desktops
  * cherry-pick Replaces commit from 3.4 (LP: #705343
<https://bugs.launchpad.net/bugs/705343>)
  * cherry-pick demotion of java-Recommends for -writer to Suggests
  * make preinst cleanup a bit more robust (LP: #915271
<https://bugs.launchpad.net/bugs/915271>)
 -- Bjoern Michaelsen <email address hidden> Fri, 13 Jan 2012
11:09:32 +0100 '

/*Eddie

On 01/13/2012 02:42 PM, Scott Lewin wrote:
> Is the fix released yet? I ask because I am still getting the following
> error when trying to re-install libreoffice calc
>
> "libreoffice-calc:
> Depends: libreoffice-core but it is not going to be installed
> Depends: libreoffice-base-core but it is not going to be installed"
>

Eddie Kane (eddiekane150) wrote :

This might be of no help to you but I had to (try) install and remove
libre office about 3-4 times before /basis3.4 directory would show up
ald allow me to move it to .old and then make new directory? If you
haven't yet, i'd try removing all libre packages (or broken in
synaptic/bash) reinstalling libre and when it fails look for that dir to
move?

sudo -s (or just type sudo before every command)
mv /usr/lib/libreoffice/basis3.4/program/
/usr/lib/libreoffice/basis3.4/program.old <------ this directory must be
present for fix to work, was not case for me at first.
mkdir /usr/lib/libreoffice/basis3.4/program/
apt-get install -f
mv /usr/lib/libreoffice/basis3.4/program.old
/usr/lib/libreoffice/basis3.4/program

I hope this was of some help.

/*Eddie

On 01/13/2012 03:08 PM, Sam_ wrote:
> apt-get -f install still says:
> rmdir: failed to remove `usr/lib/libreoffice/basis3.4/program/': Directory not empty
> dpkg: error processing /var/cache/apt/archives/libreoffice-core_1%3a3.5.0~beta2-2ubuntu2_amd64.deb (--unpack):
> subprocess new pre-installation script returned error exit status 1
> Errors were encountered while processing:
> /var/cache/apt/archives/libreoffice-core_1%3a3.5.0~beta2-2ubuntu2_amd64.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
>
> Then use workaround from #7, terminal ouput says:
> Preparing to replace libreoffice-core 1:3.4.4-0ubuntu2 (using .../libreoffice-core_1%3a3.5.0~beta2-2ubuntu2_amd64.deb) ...
> Unpacking replacement libreoffice-core ...
> dpkg: warning: unable to delete old directory '/var/lib/libreoffice/basis3.4/program': Directory not empty
> dpkg: warning: unable to delete old directory '/var/lib/libreoffice/basis3.4': Directory not empty
> dpkg: warning: unable to delete old directory '/usr/lib/libreoffice/basis3.4': Directory not empty
>

Sam_ (and-sam) wrote :

No 1:3.5.0~beta2-2ubuntu3 available here.

apt-cache policy libreoffice-core
libreoffice-core:
  Installed: 1:3.5.0~beta2-2ubuntu2
  Candidate: 1:3.5.0~beta2-2ubuntu2
  Version table:
 *** 1:3.5.0~beta2-2ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

Joluca (luiz-joluca42) wrote :
Download full text (4.0 KiB)

I made this procedure:

$ sudo mv /usr/lib/libreoffice/basis3.4/program/
/usr/lib/libreoffice/basis3.4/program.old
$ sudo mkdir /usr/lib/libreoffice/basis3.4/program/
$ sudo apt-get install -f
$ sudo mv /usr/lib/libreoffice/basis3.4/program.old
/usr/lib/libreoffice/basis3.4/program

As, Robert Collard <email address hidden>

2012/1/13 eddie <email address hidden>

> The bug was fixed in the package i belive, there was a post today about
> five hours from this email. Did you remove all of the old packages?
>
> https://bugs.launchpad.net/df-libreoffice/+bug/915271
>
> '
>
> Launchpad Janitor (janitor) <https://launchpad.net/%7Ejanitor> wrote 5
> hours ago:
>
> This bug was fixed in the package libreoffice - 1:3.5.0~beta2-2ubuntu3
>
> ---------------
> libreoffice (1:3.5.0~beta2-2ubuntu3) precise; urgency=low
>
> * enable l10n
> * get rid of obsolete BrOffice specialcasing (LP: #884786
> <https://bugs.launchpad.net/bugs/884786>)
> * add control tags as per 'firefox distro add-on support'-spec (picked
> from oneiric-3.4)
> * enable human theme and make it the default for gtk desktops
> * cherry-pick Replaces commit from 3.4 (LP: #705343
> <https://bugs.launchpad.net/bugs/705343>)
> * cherry-pick demotion of java-Recommends for -writer to Suggests
> * make preinst cleanup a bit more robust (LP: #915271
> <https://bugs.launchpad.net/bugs/915271>)
> -- Bjoern Michaelsen <email address hidden> Fri, 13 Jan 2012
> 11:09:32 +0100 '
>
> /*Eddie
>
> On 01/13/2012 02:42 PM, Scott Lewin wrote:
> > Is the fix released yet? I ask because I am still getting the following
> > error when trying to re-install libreoffice calc
> >
> > "libreoffice-calc:
> > Depends: libreoffice-core but it is not going to be installed
> > Depends: libreoffice-base-core but it is not going to be installed"
> >
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (916001).
> https://bugs.launchpad.net/bugs/915271
>
> Title:
> package libreoffice-core 1:3.4.4-0ubuntu2 failed to install/upgrade:
> rmdir: failed to remove `usr/lib/libreoffice/basis3.4/program/':
> Directory not empty
>
> Status in LibreOffice Productivity Suite:
> New
> Status in “libreoffice” package in Ubuntu:
> Fix Released
> Status in “libreoffice” source package in Precise:
> Fix Released
>
> Bug description:
> running updates/upgrades on Precise machine and message popped up
> saying it needed to report this bug.
>
> ProblemType: Package
> DistroRelease: Ubuntu 12.04
> Package: libreoffice-core 1:3.4.4-0ubuntu2
> ProcVersionSignature: Ubuntu 3.2.0-7.13-generic 3.2.0-rc7
> Uname: Linux 3.2.0-7-generic x86_64
> ApportVersion: 1.90-0ubuntu1
> Architecture: amd64
> Date: Thu Jan 12 11:44:43 2012
> DuplicateSignature:
> Unpacking replacement libreoffice-math ...
> Preparing to replace libreoffice-core 1:3.4.4-0ubuntu2 (using
> .../libreoffice-core_1%3a3.5.0~beta2-2ubuntu2_amd64.deb) ...
> rmdir: failed to remove `usr/lib/libreoffice/basis3.4/program/':
> Directory not empty
> dpkg: error processing
> /var/cache/apt/archives/libreoffice-core_1%3a3.5.0~beta2-2ubuntu2_amd64.deb
> (--unpack):
> subprocess new p...

Read more...

Sam_ (and-sam) wrote :

1:3.5.0~beta2-2ubuntu3 might be somewhere but not yet in precise.
http://packages.ubuntu.com/precise/libreoffice-core

Kayash (kayash-khan) wrote :

even i had problems executing the lines mentioned above so i had to install libreoffice (i did by software centre) unsuccessfully just so that i can execute the following code as mentioed by Joluca. The problem has finally seem to be solved but opening any libreoffice application gives me a ms windows like feeling(which i dont like..) When clicked on Help->About... it displays the foll..
 Cannot find the git binary! Is git installed and is in PATH?
Anyways, it does work properly so Thanks a bunch for the fix!!! :D

The fix:
$ sudo mv /usr/lib/libreoffice/basis3.4/program/ /usr/lib/libreoffice/basis3.4/program.old
$ sudo mkdir /usr/lib/libreoffice/basis3.4/program/
$ sudo apt-get install -f
$ sudo mv /usr/lib/libreoffice/basis3.4/program.old /usr/lib/libreoffice/basis3.4/program

Sam_ (and-sam) wrote :

Update of 1:3.5.0~beta2-2ubuntu3 came in five minutes ago. Thanks for the fix.

leukes (allousse) wrote :

Thanks for a help

.....................
Leuke's

Scott Lewin (sclewin) wrote :

I just did a complete removal of all libre-office packages and a install of libreoffice-calc and it worked 100% perfect. Thanks, Great job! :)

Mark Murphy (mokmeister) wrote :

apt-get -f install and apt-get dist-upgrade worked perfectly this morning.

Jerry (jerrywone) wrote :

just upgraded, didn't get libreoffice-writer
and previously had problems with libreoffice-gcj
not being found,
but I'm running -calc now, and seems to be OK,
will let you know if there are more problems ;-/

On Fri, Jan 13, 2012 at 11:43 PM, Scott Lewin <email address hidden> wrote:
> I just did a complete removal of all libre-office packages and a install
> of libreoffice-calc and it worked 100% perfect.  Thanks, Great job! :)
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (915345).
> https://bugs.launchpad.net/bugs/915271
>
> Title:
>  package libreoffice-core 1:3.4.4-0ubuntu2 failed to install/upgrade:
>  rmdir: failed to remove `usr/lib/libreoffice/basis3.4/program/':
>  Directory not empty
>
> Status in LibreOffice Productivity Suite:
>  New
> Status in “libreoffice” package in Ubuntu:
>  Fix Released
> Status in “libreoffice” source package in Precise:
>  Fix Released
>
> Bug description:
>  running updates/upgrades on Precise machine and message popped up
>  saying it needed to report this bug.
>
>  ProblemType: Package
>  DistroRelease: Ubuntu 12.04
>  Package: libreoffice-core 1:3.4.4-0ubuntu2
>  ProcVersionSignature: Ubuntu 3.2.0-7.13-generic 3.2.0-rc7
>  Uname: Linux 3.2.0-7-generic x86_64
>  ApportVersion: 1.90-0ubuntu1
>  Architecture: amd64
>  Date: Thu Jan 12 11:44:43 2012
>  DuplicateSignature:
>   Unpacking replacement libreoffice-math ...
>   Preparing to replace libreoffice-core 1:3.4.4-0ubuntu2 (using .../libreoffice-core_1%3a3.5.0~beta2-2ubuntu2_amd64.deb) ...
>   rmdir: failed to remove `usr/lib/libreoffice/basis3.4/program/': Directory not empty
>   dpkg: error processing /var/cache/apt/archives/libreoffice-core_1%3a3.5.0~beta2-2ubuntu2_amd64.deb (--unpack):
>    subprocess new pre-installation script returned error exit status 1
>  ErrorMessage: subprocess new pre-installation script returned error exit status 1
>  InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
>  SourcePackage: libreoffice
>  Title: package libreoffice-core 1:3.4.4-0ubuntu2 failed to install/upgrade: subprocess new pre-installation script returned error exit status 1
>  UpgradeStatus: Upgraded to precise on 2012-01-05 (6 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/df-libreoffice/+bug/915271/+subscriptions

--
Jerry W

elhoir (jfarroyo82) wrote :

sudo apt-get update && sudo apt-get install -f worked perfecty for me now

thank you so much

Changed in libreoffice (Ubuntu Precise):
assignee: nobody → Lazar Stojkovic (anarox994)

@Kayash (kayash-khan): You need to reinstall libreoffice-gtk/libreoffice-gnome to make LibreOffice nonugly again.

Rigved Rakshit (rigved) wrote :

I get a green loading bar (instead of the Ubuntu orange) and the Libreoffice About window displays the message about the missing git binary (I know that git is not installed on my system). This does not feel integrated into the system. Unless the change from orange to green was intentional.

I tried re-installing libreoffice-gtk and libreoffice-gnome, but this did not solve the problem. I also tried installing libreoffice-gtk3, still did not work.

libreoffice-gnome:
  Installed: 1:3.5.0~beta2-2ubuntu3
  Candidate: 1:3.5.0~beta2-2ubuntu3
  Version table:
 *** 1:3.5.0~beta2-2ubuntu3 0
        500 http://in.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

Sam_ (and-sam) wrote :

There is bug 916411 about the missing git binary.
In case of the message that libroffice-core is alread installed and configured user will be directed to bug 541595

This was a packaging problem, not an upstream problem. Closing the upstream task.

Changed in df-libreoffice:
status: New → Invalid

LinkedIn
------------

Bug,

I'd like to add you to my professional network on LinkedIn.

- Leuke

Leuke Sen
technicien at SystechSN
Senegal

Confirm that you know Leuke Sen:
https://www.linkedin.com/e/ynq041-gy0bu3i0-41/isd/5703584985/AMtYPluE/?hs=false&tok=33pBW_mv47Il41

--
You are receiving Invitation to Connect emails. Click to unsubscribe:
http://www.linkedin.com/e/ynq041-gy0bu3i0-41/T5RsfQLTTIL4vMOXYUyf9vCTJdFQkCOwWVdu3wY/goo/915271%40bugs%2Elaunchpad%2Enet/20061/I1984551425_1/?hs=false&tok=1NIESkHZk7Il41

(c) 2012 LinkedIn Corporation. 2029 Stierlin Ct, Mountain View, CA 94043, USA.

Talchar (magnus-thulin) wrote :

Hi.. now this is a bit odd..
I was installing openoffice.. in the dependencies was nothing about libre office witch is a totally different program..
how come i end up here?

Lubuntu 12.04_32

good luck

Sorry but I have not mastered English well, but I decided, installing the
final release of Ubuntu 12.04.1 LTS,

Greetings,

2012/11/4 Talchar <email address hidden>

> Hi.. now this is a bit odd..
> I was installing openoffice.. in the dependencies was nothing about libre
> office witch is a totally different program..
> how come i end up here?
>
> Lubuntu 12.04_32
>
> good luck
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (916001).
> https://bugs.launchpad.net/bugs/915271
>
> Title:
> package libreoffice-core 1:3.4.4-0ubuntu2 failed to install/upgrade:
> rmdir: failed to remove `usr/lib/libreoffice/basis3.4/program/':
> Directory not empty
>
> Status in LibreOffice Productivity Suite:
> Invalid
> Status in “libreoffice” package in Ubuntu:
> Fix Released
> Status in “libreoffice” source package in Precise:
> Fix Released
>
> Bug description:
> running updates/upgrades on Precise machine and message popped up
> saying it needed to report this bug.
>
> ProblemType: Package
> DistroRelease: Ubuntu 12.04
> Package: libreoffice-core 1:3.4.4-0ubuntu2
> ProcVersionSignature: Ubuntu 3.2.0-7.13-generic 3.2.0-rc7
> Uname: Linux 3.2.0-7-generic x86_64
> ApportVersion: 1.90-0ubuntu1
> Architecture: amd64
> Date: Thu Jan 12 11:44:43 2012
> DuplicateSignature:
> Unpacking replacement libreoffice-math ...
> Preparing to replace libreoffice-core 1:3.4.4-0ubuntu2 (using
> .../libreoffice-core_1%3a3.5.0~beta2-2ubuntu2_amd64.deb) ...
> rmdir: failed to remove `usr/lib/libreoffice/basis3.4/program/':
> Directory not empty
> dpkg: error processing
> /var/cache/apt/archives/libreoffice-core_1%3a3.5.0~beta2-2ubuntu2_amd64.deb
> (--unpack):
> subprocess new pre-installation script returned error exit status 1
> ErrorMessage: subprocess new pre-installation script returned error exit
> status 1
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64
> (20111012)
> SourcePackage: libreoffice
> Title: package libreoffice-core 1:3.4.4-0ubuntu2 failed to
> install/upgrade: subprocess new pre-installation script returned error exit
> status 1
> UpgradeStatus: Upgraded to precise on 2012-01-05 (6 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/df-libreoffice/+bug/915271/+subscriptions
>

--

 Ao encaminhar esta mensagem, por favor:
--- apague meu endereço e os demais,
--- faça-o sempre com cópia oculta (CCO) ou (BCC).
Assim dificultarás a disseminação de Spam/Pishing.
A internet agradece.

Ubuntu/Linux 12.04.1 LTS
Precise Pangolin
"Humanidade com os outros."

Jacob Brasher (jakeeasdfghjkl) wrote :

When I had installed this in Ubuntu Software Center, the package had corrupted and it will keep trying to remove it. And in this is what I get, and whenever I try to remove anything it says it does not exist.
root@Jake:~# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libreoffice-common
Suggested packages:
  libreoffice-style-hicontrast libreoffice-style-crystal
  libreoffice-style-oxygen
The following NEW packages will be installed:
  libreoffice-common
0 upgraded, 1 newly installed, 0 to remove and 3 not upgraded.
20 not fully installed or removed.
Need to get 0 B/21.0 MB of archives.
After this operation, 52.7 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 131687 files and directories currently installed.)
Unpacking libreoffice-common (from .../libreoffice-common_1%3a3.5.7-0ubuntu5_all.deb) ...
dpkg: error processing /var/cache/apt/archives/libreoffice-common_1%3a3.5.7-0ubuntu5_all.deb (--unpack):
 trying to overwrite '/usr/bin/soffice', which is also in package openoffice-debian-menus 4.0-9714
rmdir: failed to remove `/var/lib/libreoffice/share/prereg/': No such file or directory
rmdir: failed to remove `/var/lib/libreoffice/share/': Directory not empty
rmdir: failed to remove `/var/lib/libreoffice/program/': No such file or directory
rmdir: failed to remove `/var/lib/libreoffice': Directory not empty
rmdir: failed to remove `/var/lib/libreoffice': Directory not empty
Processing triggers for shared-mime-info ...
Processing triggers for man-db ...
Processing triggers for desktop-file-utils ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for gnome-icon-theme ...
Errors were encountered while processing:
 /var/cache/apt/archives/libreoffice-common_1%3a3.5.7-0ubuntu5_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Changed in libreoffice (Ubuntu):
assignee: Lazar Stojkovic (anarox994) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers