Ubuntu

solid-bluetooth needs update for bluez 4.x

Reported by Scott Kitterman on 2008-10-09
422
This bug affects 42 people
Affects Status Importance Assigned to Milestone
KDE Base
Fix Released
High
Release Notes for Ubuntu
Undecided
Unassigned
kdebase-workspace (Ubuntu)
High
Unassigned
Intrepid
High
Scott Kitterman
Jaunty
High
Unassigned

Bug Description

Binary package hint: kdebase-workspace

Bluetooth still doesn't work after the kdebluetooth fixes.

:/usr/bin$ kbluetooth4-devicemanager
kbluetooth4-devicemanager(8525) Solid::Control::ManagerBasePrivate::loadBackend: Backend loaded: "BlueZ"
process 8525: arguments to dbus_message_new_method_call() were incorrect, assertion "path != NULL" failed in file dbus-message.c line 1070.
This is normally a bug in some application using the D-Bus library.
QDBusConnection: error: could not send message to service "org.bluez" path "" interface "org.freedesktop.DBus.Introspectable" member "Introspect"
kbluetooth4-devicemanager(8525) DeviceMan::DeviceMan: Device Manager - Welcome
kbluetooth4-devicemanager(8525) DeviceMan::getConfiguredDevices: Device List Size: 0
kbluetooth4-devicemanager(8525) DeviceMan::slotStartWizard: Starting Wizard
kbluetooth4-wizard(8542) Solid::Control::ManagerBasePrivate::loadBackend: Backend loaded: "BlueZ"
process 8542: arguments to dbus_message_new_method_call() were incorrect, assertion "path != NULL" failed in file dbus-message.c line 1070.
This is normally a bug in some application using the D-Bus library.
QDBusConnection: error: could not send message to service "org.bluez" path "" interface "org.freedesktop.DBus.Introspectable" member "Introspect"
Object::connect: No such slot BTWizard::slotValidatePage()
kbluetooth4-wizard(8542) BTWizard::slotNext: Page ID: 1
kbluetooth4-wizard(8542) BTWizard::slotNext: Page ID: 2
kbluetooth4-wizard(8542) BTWizard::slotNext: page 2 reached!
kbluetooth4-wizard(8542) BTWizard::slotSearch: searching...
process 8542: arguments to dbus_message_new_method_call() were incorrect, assertion "path != NULL" failed in file dbus-message.c line 1070.
This is normally a bug in some application using the D-Bus library.
QDBusConnection: error: could not send message to service "org.bluez" path "" interface "org.bluez.Adapter" member "DiscoverDevices"

TEST CASE: Install KDE 4.1.4 including kdebase-workspace-bin, -data, and -libs4+5 4.1.4-0ubuntu1~intrepid2 (after they are published and built) and the updated kdebluetooth 0.3 from intrepid-proposed.

Try bluetooth. If you have any, the test is successful (there is none in the released packages).

Please specify in your testing if you're using KDE 4.1 or 4.2 and if you're on Jaunty/Intrepid.

If you are using KDE 4.1.4, please comment on these other bugs so we can get 4.1.4 moved into intrepid-updates:

https://bugs.launchpad.net/ubuntu/+bugs?field.searchtext=&orderby=-importance&field.status%3Alist=NEW&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&field.status%3Alist=INVALID&field.status%3Alist=WONTFIX&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&field.status%3Alist=FIXCOMMITTED&field.status%3Alist=FIXRELEASED&assignee_option=any&field.assignee=&field.bug_reporter=&field.bug_supervisor=&field.bug_commenter=&field.subscriber=&field.component-empty-marker=1&field.status_upstream-empty-marker=1&field.omit_dupes.used=&field.omit_dupes=on&field.has_patch.used=&field.has_cve.used=&field.tag=kde4.1.4&field.tags_combinator=ANY&field.has_no_package.used=&search=Search

Changed in kdebase-workspace:
importance: Undecided → High
milestone: none → ubuntu-8.10
status: New → Confirmed
assignee: nobody → superm1
Niels Ganser (niels.io) wrote :

I don't mean to "litter" this bug report but isn't bluez 4.x completely unsupported by kdebase-workspace upstream? If so, is somebody working together with upstream developers on getting this done until Intrepid release? I don't think Kubuntu 8.10 should ship without apparent bluetooth support so a compromise might be to let Kubuntu install bluez-gnome until native support is there..

I spoke with the upstream developer, and at this point he does not have the
time to put towards porting to 4.x. I've started to do the port myself, but
the changes are quite large and i'm very familiar with the coding style.
You can see where they're at from revisions 10+ at this br branch:
https://code.edge.launchpad.net/~superm1/kdebase/bluez-4.x

In the event that I don't have the port ready in time, I think using
bluez-gnome w/ KDE is a fine solution.

On Mon, Oct 13, 2008 at 06:24, Niels Ganser <email address hidden> wrote:

> I don't mean to "litter" this bug report but isn't bluez 4.x completely
> unsupported by kdebase-workspace upstream? If so, is somebody working
> together with upstream developers on getting this done until Intrepid
> release? I don't think Kubuntu 8.10 should ship without apparent
> bluetooth support so a compromise might be to let Kubuntu install bluez-
> gnome until native support is there..
>
> --
> solid-bluetooth needs update for bluez 4.x
> https://bugs.launchpad.net/bugs/280997
> You received this bug notification because you are a bug assignee.
>

--
Mario Limonciello
<email address hidden>

Jonathan Riddell (jr) wrote :

bluez-gnome isn't acceptable. I'm pretty much resigned to not having bluetooth in kubuntu for intrepid. We can look at backporting solid-bluetooth when it gets ported to the new bluez for intrepid-updates. Thanks for trying Mario.

Kevin Christmas (kachristmas) wrote :

Is there anyway to have bluez 3.x co-exist with bluez 4.x?

I'm frustrated that my bluetooth mouse no longer works as of just a few days ago.

Scott Kitterman (kitterman) wrote :

Added release notes task because this certainly won't be entirely fixed at release.

Colin Watson (cjwatson) wrote :

If this isn't expected to be fixed by release (as both Jonathan and Scott have said), then it seems sensible to push the milestone back to intrepid-updates rather than have it continue to block 8.10.

Changed in kdebase-workspace:
milestone: ubuntu-8.10 → intrepid-updates

I think bluez-gnome is our best option right now.
Yes, it's a bit embarrasing that we will have to depend on the gnome interface in kde, but a lot of people depend on bluetooth and that's more important.
//Pascal

BryanLawrence (b-n-lawrence) wrote :

I agree with Pascal. A release without working bluetooth is a not really a release at all. I think bluez-gnome should be supported.

Jonathan: why isn't bluez-gnome acceptable?

Christian A. Reiter (droetker) wrote :

bluetooth-gnome is absolutely no option in my opinion.
Just learn for future releases. More polish in Base work, less polish in 3d effects and glitter.
Kubuntu MUST get more stable.

Niels Ganser (niels.io) wrote :

How on earth is bluez-gnome not an option? I can't fathom why something (a bluetooth GUI!) many people have used for all of the recent releases should be stripped out completely if there's a perfectly fine solution available. Now if there's a serious *functional* problem when using bluez-gnome, that's a different story!

But it appears to be just a "vanity" issue, does it not? In that case I would strongly suggest going with bluez-gnome until there's a working KDE counterpart available. It's not like this would be the first transitional package of all times..

Of course I completely agree with Christian's last 3 sentences. We should never have been in this situation in the first place. But we are now and simply looking the other way won't help.

Bottom line is this: not having a bluetooth GUI of some sort is a *defect* for many users. Using one of a different desktop environment most likely wouldn't even be noticed..

As a last thought: if the concern is that a gnome component would require too many libs that take away hard drive space, then how about popping up a window saying "hey, HAL has detected a bluetooth adapter. would you like to install bluez-gnome, requiring X mb on your hard drive?"

Scott Kitterman (kitterman) wrote :

1. The problem is not that Kubuntu devs were too busy making things shiny
they forgot to do core work. The problem is that bluez 3 was seriously
broken with our current kernel (input devices of any kind would not work)
and yet KDE upstream had not yet updated to work with bluez4. There really
wasn't a good choice and the decision was made to update. This is an
problem getting three upstreams synch'ed with our release schedule.

2. Does gnome-bluetooth work on Kubuntu? I gave it a short try yesterday
and couldn't get it working in the time I had available. Before we'd
consider switching, I think we should know it works.

I used the gnome bluetooth system in the last beta of kubuntu 8.10. And it worked fine. But I had to install nautilus which needed a lot of gnome packages :-( But then it did the way it should do: I could exchange files between my computer and my mobile phone unsing bluetooth.

Niels Ganser (niels.io) wrote :

Scott, I just aptitude installed bluez-gnome and ran bluetooth-applet. Worked out of the box for me.

Scott Kitterman (kitterman) wrote :

OK. That's good to know.

We really can't put the gnome stuff on the CD and automatically install it
because there would be no way to undo that once we have a working KDE
bluetooth for intrepid-updates. This does, however, seem worthy of a mention
in the release notes.

Would one of you who have done it please write up a draft for the release
notes on how to get a working bluetooth in Kubuntu. Ideally both the file
transfer and input device use cases would be addressed. That way we can tell
users what they need to do until we can get this fixed.

Kevin Christmas (kachristmas) wrote :

1. Scott, I don't think the comments under point number one are going to be useful to anyone other than making you feel better. When KDE 4.1 was released, bluetooth worked with the latest release of *buntu. It continued to work until just a few weeks ago in the development release. To get upset at them when they're between releases isn't fair, useful, or productive.

2. I don't know if there's more configuration settings somewhere else, but the gnome bluetooth-applet is painful. I have to constantly remove, search, and then re-add my mouse.

3. I was convinced to try Ubuntu because, "It just works."

Scott Kitterman (kitterman) wrote :

At this point there really isn't a great answer for bluetooth and Kubuntu.

Complaints that us developers aren't doing our 'job' - I'm a volunteer and so
are virtually all the developers working on Kubuntu just demotivate me, so no
apologies for the reaction.

For the release, the choices are no bluetooth or gnome-bluetooth. That's it.
We are working with upstream to get bluez 4 support ASAP into KDE (a large
fraction of the upstream commits toward this goal are from Ubuntu/Kubuntu
developers). Once that's done and tested there will be an update for
Intrepid.

Putting gnome-bluetooth in the default install would be extremely problematic,
because once we release it'll be on the Kubuntu Intrepid CD for the life of
the release (unlike Hardy, which was an LTS release for Ubuntu there are no
plans to redo the CD for Intrepid post-release).

There just aren't any other choices at this point.

Jonas Pedersen (jonasped) wrote :

Kevin Christmas wrote:
> 2. I don't know if there's more configuration settings somewhere else,
> but the gnome bluetooth-applet is painful. I have to constantly remove,
> search, and then re-add my mouse.

I don't think that is bluetooth-applet's fault. It is bug #249448 that
you hit.

Surely you can make a special package of bluez-gnome and once the kde-bluetooth is ready make the kde package depend on a package that uninstalls the special package.

Less than 10% reads the release notes is my guess.
Having blues-gnome on the cd wouldn't be bad. It's not that big! It's much better than loading the livecd and seeing that your mouse doesn't work. Bluetooth is an important factor.

Scott Kitterman (kitterman) wrote :

Perhaps, but not in the time we have until the archive closes. Release notes
is really all we can do.

Steve Langasek (vorlon) wrote :
Changed in ubuntu-release-notes:
status: New → Fix Released
Ryan Novosielski (novosirj) wrote :

I don't think this was a good choice. I read the release notes and therefore will not upgrade... I hope others are that lucky.

I'm pretty consistently disappointed by large broken things in Ubuntu. I realize that the Debian approach is also a problem, but I can't seem to find a good release that hasn't broken something new.

I appreciate all the work that is done, but if I can't upgrade to a new release because it doesn't work right, it wasn't really released as far as I'm concerned.

Gregor Rosenauer (grexe) wrote :

I was looking forward to Intrepid, but I guess I have to wait for the update, because of this bug - I only have a bluetooth keyboard (Logitech diNovo Edge) with a USB-dongle. However this may still work (will try the LiveCD), as it is normally seen as a normal keyboard+mouse by the OS - even works in BIOS.

Sebastian Sauer (mail-dipe) wrote :

> Niels Ganser wrote on 2008-10-13: (permalink)
> I don't mean to "litter" this bug report but isn't bluez 4.x completely unsupported
> by kdebase-workspace upstream? If so, is somebody working together with
> upstream developers on getting this done until Intrepid release?

No, noone did. In fact only suse is working on this and I am really frustrated that such a case doesn't went upstream to us :-(

So, I just confirmed https://bugs.kde.org/show_bug.cgi?id=172267 and did set the priority to high (less then 10 seconds of work btw), so we are at least aware of this.

Jonathan Thomas (echidnaman) wrote :

We were under the impression that Mario had talked with your guys and that you were aware, otherwise we definitely would have upstreamed this bug. Miscommunications happen I guess.

Mario Limonciello (superm1) wrote :

I've been working directly with Tom Patzig (although the two weeks or so
i've been ill and out of the loop)

On Tue, Nov 11, 2008 at 09:05, Harald Sitter <email address hidden>wrote:

> ** Also affects: kdebase via
> http://bugs.kde.org/show_bug.cgi?id=172267
> Importance: Unknown
> Status: Unknown
>
> --
> solid-bluetooth needs update for bluez 4.x
> https://bugs.launchpad.net/bugs/280997
> You received this bug notification because you are a bug assignee.
>

--
Mario Limonciello
<email address hidden>

Gletscher (gletscherspalte) wrote :

I also vouch for less glitter and a more stable release, intrepid kubuntu is in my opinion a plain broken release, to many things don't work. Thanks for the bluez-gnome hint, finally my mouse works again ...

Sebastian Sauer (mail-dipe) wrote :

> We were under the impression that Mario had talked with your guys and that
> you were aware, otherwise we definitely would have upstreamed this bug.

Well, specially for such imho high priority probs it would be rather useful to have them in the bug-db and to be aware of it. E.g. myself didn't worked before on kdebluetooth but switches his working-area depending on priorities.
Anyway; can we either move the work done in https://code.edge.launchpad.net/~superm1/kdebase/bluez-4.x to kde-svn or can I have write access to it to be able to help there? Thanks in advance :)

Scott Kitterman (kitterman) wrote :

Less glitter and more stable is available in Hardy if you want it. The
bluetooth issue isn't something any Kubuntu developer could control.

Changed in kdebase:
status: Unknown → Confirmed
Changed in kdebase-workspace:
status: Confirmed → Triaged
Gustav H Meyer (inetpro) wrote :

What I see nowhere is that if you install bluez-gnome that you also need nautilus installed. I figured this when looking into this issue again tonight. I realized that I needed nautilus when I executed bluetooth-browse from the commandline.

Now that I've installed nautilus I can happily use bluetooth to transfer photos from my mobile phone again.

meph (mike-meph) wrote :

Can anyone provide a status update or any idea when this might be fixed. - This thread seems to have dried up.

Gnome bluetooth hasn't worked for me after the first time I started it and even then it seemed to lack a lot of the functionality I use.

Should I hold out or go back to hardy?

Thanks
Mike

bakytn (bakytn) wrote :

Guys we believe in you, please fix it :(

See https://bugs.kde.org/show_bug.cgi?id=172267#c8 for a workaround and a description what needs to be done.

Thanks Scott, Mario and others for the effort!

I just tried the gnome bluetooth-applet in Kubuntu 8.10 and now I finally got dialup networking and stowaway keyboard working again.

In my opinion it would have been a much much better solution to temporarily use gnome bluetooth in KDE, which provides a mostly working solution, rather than leaving the whole bluetooth system broken. Some functionality is always better than no functionality, even if it's a cludge. And nobody really reads the release notes. I know I didn't.

I consider that the release notes are not prominent enough to be used for reporting such major issues. I think something as crucial as bluetooth being broken should be highlighted separately on the download page. The page shows a selection for choosing between 8.04 and 8.10, but doesn't really provide any assistance for selecting between the two. I think here it should be said clearly that 8.10 does not currently have bluetooth support without some hacking. At the very minimum the release notes should be linked there.

meph: I use Intrepid experimentally at home, but for daily use and work I use Hardy. I feel that Intrepid has too many problems, so I am waiting for fixes and/or Jaunty.

Felix (apoapo) wrote :

how long will it ~probably take to fix such a thing? 3 - 6- 12 months? this would be very nice to know. thanks

Sergio Callegari (callegar) wrote :

The kde bug reported in this thread indicates that downgrading to previous bluez is the sole workaround known not to depend on gnome tools, but it also indicates that the workaround will not work with the forthcoming kde 4.2.

Is there any chance that by the end of January kde 4.2 fixes this in the right way by adding updated bluez support to solid?
Otherwise may ubuntu developers kindly propose that kde 4.2 is delayed until this bluetooth issue is solved?

Please do not give the (wrong) feeling that new stuff and eyecandy is continuously being added without first solving pending regressions and known bugs.

SRElysian (srelysian) wrote :

The triage will be broken this month. So far as I've read, kbluetooth4 is the cuplrit, which is why the 3.x drivers work with it. It was only ported and not set up to function on the bluez4 system. Downgrading bluez puts it into a version series it can get along with, but so far as I have been told KDE 4.2 is going to completely break that. The fact that there has been no progress on this saddens me, it's not like they aren't aware of it. Has anyone tried it in Jaunty yet?

frapell (frapell) wrote :

I agree this is a very bad "publicity" for kde to just leave things broken.
I sent an email to Tom Patzig (he mentioned in one answer from 2008-12-19 that he welcome any help on fixing this) offering my help and didn't get any response at all, so dunno exactly wat's going on.

SRElysian (srelysian) wrote :
Download full text (3.8 KiB)

The more I think on this, the more it aggravates me. I was scrolling through
the posts earlier to see if any of the dev's have even spoken up about it,
and I came across something to the effect of "not having time to fix it".
This isn't some obscure mouse that for some reason doesn't work, it's an
entire system and along with it, an array of devices. Mice, Keyboards,
modems, wireless/wired cards, headsets, etc. It's not even a single brand of
blue-tooth, but all of them. So far as I have read, it's not working in
Jaunty either... which is due in 3 months. How many distro's are we going to
go through before Bluetooth becomes important. Alot of people rely on it, I
for one have an external logitech BT keyboard I've missed using. And despite
what other people think, I don't believe borrowing Gnome packages for a
purely KDE distro is a "fix". If I had a porche and the engine broke, I'd
fix it, I wouldn't replace it with one from a VW Beetle. Not trying to start
a "flame war" over gnome vs kde, but if I wanted to fill my hard-drive with
gnome packages, don't you think I would have installed ubuntu instead of
kubuntu?

On Fri, Jan 16, 2009 at 7:09 AM, frapell <email address hidden> wrote:

> I agree this is a very bad "publicity" for kde to just leave things broken.
> I sent an email to Tom Patzig (he mentioned in one answer from 2008-12-19
> that he welcome any help on fixing this) offering my help and didn't get any
> response at all, so dunno exactly wat's going on.
>
> --
> solid-bluetooth needs update for bluez 4.x
> https://bugs.launchpad.net/bugs/280997
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in KDE Base Components: Confirmed
> Status in Ubuntu Release Notes: Fix Released
> Status in "kdebase-workspace" source package in Ubuntu: Triaged
> Status in kdebase-workspace in Ubuntu Intrepid: Confirmed
>
> Bug description:
> Binary package hint: kdebase-workspace
>
> Bluetooth still doesn't work after the kdebluetooth fixes.
>
> :/usr/bin$ kbluetooth4-devicemanager
> kbluetooth4-devicemanager(8525)
> Solid::Control::ManagerBasePrivate::loadBackend: Backend loaded: "BlueZ"
> process 8525: arguments to dbus_message_new_method_call() were incorrect,
> assertion "path != NULL" failed in file dbus-message.c line 1070.
> This is normally a bug in some application using the D-Bus library.
> QDBusConnection: error: could not send message to service "org.bluez" path
> "" interface "org.freedesktop.DBus.Introspectable" member "Introspect"
> kbluetooth4-devicemanager(8525) DeviceMan::DeviceMan: Device Manager -
> Welcome
> kbluetooth4-devicemanager(8525) DeviceMan::getConfiguredDevices: Device
> List Size: 0
> kbluetooth4-devicemanager(8525) DeviceMan::slotStartWizard: Starting Wizard
> kbluetooth4-wizard(8542) Solid::Control::ManagerBasePrivate::loadBackend:
> Backend loaded: "BlueZ"
> process 8542: arguments to dbus_message_new_method_call() were incorrect,
> assertion "path != NULL" failed in file dbus-message.c line 1070.
> This is normally a bug in some application using the D-Bus library.
> QDBusConnection: error: could not send message to service "org.bluez" path
> "" interface "org.freedesktop....

Read more...

kamaxeon (israel) wrote :
Download full text (3.4 KiB)

Me too

SRElysian <email address hidden> ha escrito:

> You have my (20) vote(s). Hopefully this will change the priority a
> little.
>
> On Fri, Jan 16, 2009 at 8:40 AM, frapell <email address hidden> wrote:
>
>> @Niels Ganser:
>> Yes, that was the answer i was referring to... forgot to add a link there,
>> heh...
>> The mail i sent him was asking how to start, if i should read something
>> first, etc... but i will get the code and see if there's something i can
>> contribute...
>>
>> And yes, is a wonderful idea... everybody that want's this fixed NOW, go
>> to https://bugs.kde.org/show_bug.cgi?id=172267 create an account and
>> give that bug 20 votes :)
>>
>> --
>> solid-bluetooth needs update for bluez 4.x
>> https://bugs.launchpad.net/bugs/280997
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>> Status in KDE Base Components: Confirmed
>> Status in Ubuntu Release Notes: Fix Released
>> Status in "kdebase-workspace" source package in Ubuntu: Triaged
>> Status in kdebase-workspace in Ubuntu Intrepid: Confirmed
>>
>> Bug description:
>> Binary package hint: kdebase-workspace
>>
>> Bluetooth still doesn't work after the kdebluetooth fixes.
>>
>> :/usr/bin$ kbluetooth4-devicemanager
>> kbluetooth4-devicemanager(8525)
>> Solid::Control::ManagerBasePrivate::loadBackend: Backend loaded: "BlueZ"
>> process 8525: arguments to dbus_message_new_method_call() were incorrect,
>> assertion "path != NULL" failed in file dbus-message.c line 1070.
>> This is normally a bug in some application using the D-Bus library.
>> QDBusConnection: error: could not send message to service "org.bluez" path
>> "" interface "org.freedesktop.DBus.Introspectable" member "Introspect"
>> kbluetooth4-devicemanager(8525) DeviceMan::DeviceMan: Device Manager -
>> Welcome
>> kbluetooth4-devicemanager(8525) DeviceMan::getConfiguredDevices: Device
>> List Size: 0
>> kbluetooth4-devicemanager(8525) DeviceMan::slotStartWizard: Starting Wizard
>> kbluetooth4-wizard(8542) Solid::Control::ManagerBasePrivate::loadBackend:
>> Backend loaded: "BlueZ"
>> process 8542: arguments to dbus_message_new_method_call() were incorrect,
>> assertion "path != NULL" failed in file dbus-message.c line 1070.
>> This is normally a bug in some application using the D-Bus library.
>> QDBusConnection: error: could not send message to service "org.bluez" path
>> "" interface "org.freedesktop.DBus.Introspectable" member "Introspect"
>> Object::connect: No such slot BTWizard::slotValidatePage()
>> kbluetooth4-wizard(8542) BTWizard::slotNext: Page ID: 1
>> kbluetooth4-wizard(8542) BTWizard::slotNext: Page ID: 2
>> kbluetooth4-wizard(8542) BTWizard::slotNext: page 2 reached!
>> kbluetooth4-wizard(8542) BTWizard::slotSearch: searching...
>> process 8542: arguments to dbus_message_new_method_call() were incorrect,
>> assertion "path != NULL" failed in file dbus-message.c line 1070.
>> This is normally a bug in some application using the D-Bus library.
>> QDBusConnection: error: could not send message to service "org.bluez" path
>> "" interface "org.bluez.Adapter" member "DiscoverDevices"
>>
>
> --
> solid-bluetooth needs update for bluez 4.x
> https://bugs.launchpad.n...

Read more...

Niels Ganser (niels.io) wrote :

frapell: It's great that you want to assist in fixing this! You will probably have more success offering your help in https://bugs.kde.org/show_bug.cgi?id=172267 though, as this essentially is a KDE bug. In https://bugs.kde.org/show_bug.cgi?id=172267#c8 Tom references the repository experimental code can be found in that has already partially been ported.

It would also help if every one of us voted an the KDE bug so that it gets fixed in the 4.2 release.

SRELysian: I guess this bug doesn't really move forward simply because no (K)Ubuntu developer is personally affected. Don't get me wrong, I am as frustrated about this as you are but after all, all our days only have 24 hours so I'm not sure it makes sense to be angry at the developers (be it (K)Ubuntu or KDE).

Clearly, this issue sneaked in shortly before the final move to KDE 4 and once it came up, the transition was already too far progressed to stop it with the release coming too soon to fix it in time. So now we're just stuck with it. Hopefully only until KDE 4.2 though :)

Changed in kdebase-workspace:
status: Triaged → Fix Released
status: Confirmed → Triaged
Changed in kdebase-workspace:
status: Triaged → Fix Committed
assignee: superm1 → kitterman
description: updated
33 comments hidden view all 113 comments
mfabry (mfabry) wrote :

I've just installed latest Intrepid packages (KDE 4.1.4). I was able to pair devices (handheld and mobile) with my desktop. Unfortunately that's about it. File transfer doesn't work well and I don't get any (significant) error messages. I was trying to send files from my computer as well as receive them. During transfer from my handheld I get "unable to send" error and it looks like connection isn't even made. During transfer from my desktop to the handheld I briefly see connection info flashing (which disappears quickly). There is no progress bar and console shows only:
kbluetooth4(13215) BluezBluetoothInterface::slotDeviceFound: device found "00:70:E0:AD:04:31" QVariant(QString, "Magda")
Remote Device found "00:70:E0:AD:04:31" Name: QVariant(QString, "Magda")
Remote Device found "00:70:E0:AD:04:31" Name: QVariant(QString, "Magda")
kbluetooth4(13215) ObexSession::ObexSession: Konstruktor: "/org/openobex"
kbluetooth4(13215) ObexSession::sessionCreated: session interface created for: "/org/openobex/session3"
I was a bit more lucky with my phone - transfer was successful. Bluetooth Gnome works without a problem.

Scott Kitterman (kitterman) wrote :

On Thursday 22 January 2009 11:56, Michael Marley wrote:
> I just checked, and it is FTBFS for AMD64:

Due to build timing it built against the old version of kdebase-workspace.
I've just retried it.

Scott Kitterman (kitterman) wrote :

This is significantly better than before and IIRC about where we were
before the switch to bluez 4.

On Thu, 22 Jan 2009 18:01:42 -0000 mfabry <email address hidden> wrote:
>I've just installed latest Intrepid packages (KDE 4.1.4). I was able to
pair devices (handheld and mobile) with my desktop. Unfortunately that's
about it. File transfer doesn't work well and I don't get any (significant)
error messages. I was trying to send files from my computer as well as
receive them. During transfer from my handheld I get "unable to send"
error and it looks like connection isn't even made. During transfer from my
desktop to the handheld I briefly see connection info flashing (which
disappears quickly).

Javier Jardón (jjardon) wrote :

Kubuntu 8.10 with 4.1.96 (4.2rc)

Pairing and send files to my mobile phone works great here, thank you!

SRElysian (srelysian) wrote :
Download full text (4.9 KiB)

I've apparently managed to break it already. I was attempting to pair it
with my cellphone when the "kbluetooth4-devicemanager" crashed. It now
refuses to open with the following output:

kbluetooth4-devicemanager(8445)
Solid::Control::ManagerBasePrivate::loadBackend: Backend loaded: "BlueZ"
kbluetooth4-devicemanager(8445) DeviceMan::DeviceMan: Device Manager -
Welcome
QDBusObjectPath: invalid path ""
process 8445: arguments to dbus_message_new_method_call() were incorrect,
assertion "path != NULL" failed in file dbus-message.c line 1070.
This is normally a bug in some application using the D-Bus library.
QDBusConnection: error: could not send message to service "org.bluez" path
"" interface "org.freedesktop.DBus.Introspectable" member"Introspect"
Object::connect: No such signal
Solid::Control::BluetoothRemoteDevice::nodeCreated(QString)
Object::connect: No such signal
Solid::Control::BluetoothRemoteDevice::nodeRemoved(QString)
Object::connect: No such signal
Solid::Control::BluetoothRemoteDevice::nodeCreated(QString)
Object::connect: No such signal
Solid::Control::BluetoothRemoteDevice::nodeRemoved(QString)
Object::connect: No such signal
Solid::Control::BluetoothRemoteDevice::nodeCreated(QString)
Object::connect: No such signal
Solid::Control::BluetoothRemoteDevice::nodeRemoved(QString)
kbluetooth4-devicemanager(8445) DeviceMan::getConfiguredDevices: Device List
Size: 1
kbluetooth4-devicemanager: symbol lookup error: kbluetooth4-devicemanager:
undefined symbol: _ZN5Solid7Control21BluetoothRemoteDevice4nameEv

---

I believe it's refusing to open again because of a half-entry from the
original crash, If I could find the config file where it's stored and wipe
it I might have another shot. It may have crashed originally because no obex
server was installed yet it was enabled in the menu. Trying to disable the
obex without installing the server caused the entire app to crash. If anyone
knows where the cfg is stored would you mind letting me know? Thanks.

On Thu, Jan 22, 2009 at 5:23 PM, Javier Jardón <email address hidden>wrote:

> Kubuntu 8.10 with 4.1.96 (4.2rc)
>
> Pairing and send files to my mobile phone works great here, thank you!
>
> --
> solid-bluetooth needs update for bluez 4.x
> https://bugs.launchpad.net/bugs/280997
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in KDE Base Components: Confirmed
> Status in Ubuntu Release Notes: Fix Released
> Status in "kdebase-workspace" source package in Ubuntu: Fix Released
> Status in kdebase-workspace in Ubuntu Intrepid: Fix Committed
> Status in kdebase-workspace in Ubuntu Jaunty: Fix Released
>
> Bug description:
> Binary package hint: kdebase-workspace
>
> Bluetooth still doesn't work after the kdebluetooth fixes.
>
> :/usr/bin$ kbluetooth4-devicemanager
> kbluetooth4-devicemanager(8525)
> Solid::Control::ManagerBasePrivate::loadBackend: Backend loaded: "BlueZ"
> process 8525: arguments to dbus_message_new_method_call() were incorrect,
> assertion "path != NULL" failed in file dbus-message.c line 1070.
> This is normally a bug in some application using the D-Bus library.
> QDBusConnection: error: could not send message to service "or...

Read more...

Changed in kdebase-workspace:
assignee: superm1 → nobody
milestone: intrepid-updates → none

Working perfectly for me in Intrepid with my mouse. Only issue was that had I had to hit the search button before it really searched for the mouse. Bluetooth icon appeared for the first time on reboot after install.

Noticed that if I turn the mouse off, (after registering successfully and working fine), link is not re-established when the mouse is turned back on and I have to delete the device and re-register it in device manager. This is not a major problem but could be the same issue that others are reporting with data devices, if the link is lost during data transmission for example.

mfabry (mfabry) wrote :

I noticed one strange thing about data transfer to my phone. Usually I had to accept incoming connection first and then incoming transmission and received data. With new kdebluetooth I only have to accept incoming connection. Transfer itself is "silent" and data are automatically saved in default location. It might be a cause for problems I have with my Palm handheld (see my previous comment).

Download full text (3.6 KiB)

Upgraded to KDE 4.2 (Beta2) to try it out using adept.

 Everything looks ok in the KDE GUI (see a bluetooth icon etc) but am unable to run device manager and am getting a DBUS and further down a symbol lookup error when input wizard attempts to connect the device after finding it. This could easily be something I've done wrong of course or may be due to KDE 4.2 Beta, but thought I'd list it just in case it's important.

Log below:

/usr/bin$ kbluetooth4-inputwizard
kbluetooth4-wizard(7568) Solid::Control::ManagerBasePrivate::loadBackend: Backend loaded: "BlueZ"
pete@golum:/usr/bin$ kbluetooth4-wizard(7568) BTWizard::slotNext: Page ID: 1
kbluetooth4-wizard(7568) BTWizard::slotNext: Page ID: 2
kbluetooth4-wizard(7568) BTWizard::slotNext: page 2 reached!
kbluetooth4-wizard(7568) BTWizard::slotSearch: Text "&Search"
kbluetooth4-wizard(7568) BTWizard::slotSearch: searching...
QDBusObjectPath: invalid path ""
process 7568: arguments to dbus_message_new_method_call() were incorrect, assertion "path != NULL" failed in file dbus-message.c line 1070.
This is normally a bug in some application using the D-Bus library.
QDBusConnection: error: could not send message to service "org.bluez" path "" interface "org.freedesktop.DBus.Introspectable" member "Introspect"
Object::connect: No such signal Solid::Control::BluetoothRemoteDevice::nodeCreated(QString)
Object::connect: No such signal Solid::Control::BluetoothRemoteDevice::nodeRemoved(QString)
Object::connect: No such signal Solid::Control::BluetoothRemoteDevice::nodeCreated(QString)
Object::connect: No such signal Solid::Control::BluetoothRemoteDevice::nodeRemoved(QString)
Object::connect: No such signal Solid::Control::BluetoothRemoteDevice::nodeCreated(QString)
Object::connect: No such signal Solid::Control::BluetoothRemoteDevice::nodeRemoved(QString)
kbluetooth4-wizard(7568) BTWizard::slotSearch: Configured Devices: 1
kbluetooth4-wizard(7568) BTWizard::slotSearch: Text "&Stop Search"
kbluetooth4-wizard(7568) BTWizard::slotSearch: Stop searching
kbluetooth4-wizard(7568) BTWizard::slotSearch: Text "&Search"
kbluetooth4-wizard(7568) BTWizard::slotSearch: searching...
QDBusObjectPath: invalid path ""
Object::connect: No such signal Solid::Control::BluetoothRemoteDevice::nodeCreated(QString)
Object::connect: No such signal Solid::Control::BluetoothRemoteDevice::nodeRemoved(QString)
Object::connect: No such signal Solid::Control::BluetoothRemoteDevice::nodeCreated(QString)
Object::connect: No such signal Solid::Control::BluetoothRemoteDevice::nodeRemoved(QString)
kbluetooth4-wizard(7568) BTWizard::slotSearch: Configured Devices: 1
kbluetooth4(7462) BluezBluetoothInterface::slotDeviceFound: device found "00:0C:55:03:0D:DF" QVariant(QString, ...

Read more...

frapell (frapell) wrote :
Download full text (3.3 KiB)

Well, bt started working, i opened the device manager, scanned for my cell phone, tried to pair with it, but all the sudden it crashed, now every time i try to open the device manager i get that reported error, even after reboot, etc:

$ kbluetooth4
kbluetooth4(7429) Solid::Control::ManagerBasePrivate::loadBackend: Backend loaded: "BlueZ"
kbluetooth4(7429) KBlueTray::onlineMode: online Mode
kbluetooth4(7429) KBlueTray::onlineMode: adapter size 1
kbluetooth4(7429) KBlueTray::onlineMode: Adapter found "jenny"
AGENT registered !
kbluetooth4(7429) ObexServer::ObexServer: "00:00:00:00:00:00"
kbluetooth4(7429) ObexServer::serverCreated: obex server created
kbluetooth4(7429) ObexServer::serverCreated: session interface created for: "/org/openobex/server1"
kbluetooth4(7429) ObexServer::slotStarted: server started
kbluetooth4(7429) KBlueTray::slotServerStarted: obex server started
kbluetooth4(7429) KBlueTray::showManager: Starting Device Manager
kbluetooth4-devicemanager(7432) Solid::Control::ManagerBasePrivate::loadBackend: Backend loaded: "BlueZ"
kbluetooth4-devicemanager(7432) DeviceMan::DeviceMan: Device Manager - Welcome
QDBusObjectPath: invalid path ""
process 7432: arguments to dbus_message_new_method_call() were incorrect, assertion "path != NULL" failed in file dbus-message.c line 1070.
This is normally a bug in some application using the D-Bus library.
QDBusConnection: error: could not send message to service "org.bluez" path "" interface "org.freedesktop.DBus.Introspectable" member "Introspect"
Object::connect: No such signal Solid::Control::BluetoothRemoteDevice::nodeCreated(QString)
Object::connect: No such signal Solid::Control::BluetoothRemoteDevice::nodeRemoved(QString)
Object::connect: No such signal Solid::Control::BluetoothRemoteDevice::nodeCreated(QString)
Object::connect: No such signal Solid::Control::BluetoothRemoteDevice::nodeRemoved(QString)
Object::connect: No such signal Solid::Control::BluetoothRemoteDevice::nodeCreated(QString)
Object::connect: No such signal Solid::Control::BluetoothRemoteDevice::nodeRemoved(QString)
kbluetooth4-devicemanager(7432) DeviceMan::getConfiguredDevices: Device List Size: 1 ...

Read more...

frapell (frapell) wrote :
Download full text (3.8 KiB)

Update:

i used the gnome's bluetooth-applet to remove my cell, then opened kbluetooth4 and could open the device manager dialog, but again, after adding the cell, the whole thing crashed, and again the same problem as above. But here i have the trace from this crash:

$ kbluetooth4
kbluetooth4(7462) Solid::Control::ManagerBasePrivate::loadBackend: Backend loaded: "BlueZ"
kbluetooth4(7462) KBlueTray::onlineMode: online Mode
kbluetooth4(7462) KBlueTray::onlineMode: adapter size 1
kbluetooth4(7462) KBlueTray::onlineMode: Adapter found "jenny"
AGENT registered !
kbluetooth4(7462) ObexServer::ObexServer: "00:00:00:00:00:00"
kbluetooth4(7462) ObexServer::serverCreated: obex server created
kbluetooth4(7462) ObexServer::serverCreated: session interface created for: "/org/openobex/server2"
kbluetooth4(7462) ObexServer::slotStarted: server started
kbluetooth4(7462) KBlueTray::slotServerStarted: obex server started
kbluetooth4(7462) KBlueTray::showManager: Starting Device Manager
kbluetooth4-devicemanager(7465) Solid::Control::ManagerBasePrivate::loadBackend: Backend loaded: "BlueZ"
kbluetooth4-devicemanager(7465) DeviceMan::DeviceMan: Device Manager - Welcome
kbluetooth4-devicemanager(7465) DeviceMan::getConfiguredDevices: Device List Size: 0
kbluetooth4-devicemanager(7465) DeviceMan::slotStartWizard: Starting Wizard
kbluetooth4-wizard(7468) Solid::Control::ManagerBasePrivate::loadBackend: Backend loaded: "BlueZ"
kbluetooth4-wizard(7468) BTWizard::slotNext: Page ID: 1
kbluetooth4-wizard(7468) BTWizard::slotNext: Page ID: 2
kbluetooth4-wizard(7468) BTWizard::slotNext: page 2 reached!
kbluetooth4-wizard(7468) BTWizard::slotSearch: Text "&Search"
kbluetooth4-wizard(7468) BTWizard::slotSearch: searching...
kbluetooth4-wizard(7468) BTWizard::slotSearch: Configured Devices: 0
kbluetooth4(7462) BluezBluetoothInterface::slotDeviceFound: device found "00:19:2C:1F:68:74" QVariant(QString, "Amin")
kbluetooth4-devicemanager(7465) BluezBluetoothInterface::slotDeviceFound: device found "00:19:2C:1F:68:74" QVariant(QString, "Amin")
kbluetooth4-wizard(7468) BluezBluetoothInterface::slotDeviceFound: device found "00:19:2C:1F:68:74" QVariant(QString, "Amin")
kbluetooth4-wizard(7468) BTWizard::slotRemoteDeviceFound: Configured Devices from slotRemoteDeviceFound: 0
kbluetooth4-wizard(7468) BTWizard::filterList: Filter DeviceList "Amin" "phone"
kbluetooth4-wizard(7468) BTWizard::slotSearch: Text "&Stop Search"
kbluetooth4-wizard(7468) BTWizard::slotSearch: Stop searching
kbluetooth4-wizard(7468) BTWizard::slotDeviceSelectionChanged: 0x99cc6e8
kbluetooth4-wizard(7468) BTWizard::slotNext: Page ID: 3
kbluetooth4-devicemanager(7465) BluezBluetoothInterface::slotDeviceCreated: device created
kbluetooth4(7462) BluezBluetoothInterface::slotDeviceCreated: device created
kbluetooth4-devicemanager(7465) DeviceMan::slotDeviceAdded: Device Added
kbluetooth4-devicemanager: symbol lookup error: kbluetooth4-devicemanager: un...

Read more...

description: updated
paulo (paul-oakley) wrote :
Download full text (7.6 KiB)

KDE 4.1.96-0ubuntu1~intrepid1~ppa1
kdebluetooth 0.3-1ubuntu0.1
kdebase-workspace 4.1.96-0ubuntu4~intrepid1~ppa1
bluez 4.25-0ubuntu1~git20081226

I deleted all devices using gnomes "bluetooth-applet" in a terminal and then closed the terminal stopping the applet
Then I ran kbluetooth4-devicemanager in a terminal
in "select your device" I selected my BT mouse and clicked next, the device manager crashes with the following output

paulo@illustrious:~$ /usr/bin/kbluetooth4-devicemanager
kbluetooth4-devicemanager(14355) Solid::Control::ManagerBasePrivate::loadBackend: Backend loaded: "BlueZ"
kbluetooth4-devicemanager(14355) DeviceMan::DeviceMan: Device Manager - Welcome
kbluetooth4-devicemanager(14355) DeviceMan::getConfiguredDevices: Device List Size: 0
^[[B^[[B^[[Bkbluetooth4-devicemanager(14355) DeviceMan::slotStartWizard: Starting Wizard
kbluetooth4-wizard(14362) Solid::Control::ManagerBasePrivate::loadBackend: Backend loaded: "BlueZ"
kbluetooth4-wizard(14362) BTWizard::slotNext: Page ID: 1
kbluetooth4-wizard(14362) BTWizard::slotNext: Page ID: 2
kbluetooth4-wizard(14362) BTWizard::slotNext: page 2 reached!
kbluetooth4-wizard(14362) BTWizard::slotSearch: Text "&Search"
kbluetooth4-wizard(14362) BTWizard::slotSearch: searching...
kbluetooth4-wizard(14362) BTWizard::slotSearch: Configured Devices: 0
kbluetooth4-devicemanager(14355) BluezBluetoothInterface::slotDeviceFound: device found "B0:53:08:06:07:65" QVariant(QString, "Bluetooth Mouse")
kbluetooth4-wizard(14362) BluezBluetoothInterface::slotDeviceFound: device found "B0:53:08:06:07:65" QVariant(QString, "Bluetooth Mouse")
kbluetooth4-wizard(14362) BTWizard::slotRemoteDeviceFound: Configured Devices from slotRemoteDeviceFound: 0
kbluetooth4-wizard(14362) BTWizard::filterList: Filter DeviceList "Bluetooth Mouse" "input-mouse"
kbluetooth4-devicemanager(14355) BluezBluetoothInterface::slotDeviceFound: device found "00:1A:16:5A:3C:20" QVariant(QString, "Nokia 6021 km's")
kbluetooth4-wizard(14362) BluezBluetoothInterface::slotDeviceFound: device found "00:1A:16:5A:3C:20" QVariant(QString, "Nokia 6021 km's")
kbluetooth4-wizard(14362) BTWizard::slotRemoteDeviceFound: Configured Devices from slotRemoteDeviceFound: 0
kbluetooth4-wizard(14362) BTWizard::filterList: Filter DeviceList "Nokia 6021 km's" "phone"
kbluetooth4-devicemanager(14355) BluezBluetoothInterface::slotDeviceFound: device found "00:1F:CC:CF:75:52" QVariant(QString, "SGH-E250")
kbluetooth4-wizard(14362) BluezBluetoothInterface::slotDeviceFound: device found "00:1F:CC:CF:75:52" QVariant(QString, "SGH-E250")
kbluetooth4-wizard(14362) BTWizard::slotRemoteDeviceF...

Read more...

I can confirm the undefined symbol _ZNK5Solid7Control18BluetoothInterface28findBluetoothRemoteDeviceUBIERK7QString error from the comments above on Intrepid with KDE 4.2/i386 grabbed from kubuntu-experimental today.

There's a bug for this issue here: https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/318602/, flagged as duplicate of https://bugs.launchpad.net/ubuntu/+source/kdebluetooth/+bug/268821, although I'm not convinced about that.

The KDE Bug is here: http://bugs.kde.org/show_bug.cgi?id=179224
Anyhow, the bottom line is that it's not working in 4.2 :-(

Updated my Kubuntu Intrepid KDE installation today to 4.2 (final).

Last time I tried KDE 4.2RC2 with the fixes my BT device manager crashed when I tried to pair my Netbook using a BT dongle with my BT Stowaway keyboard. After that the device manager could not be restarted but immediately crashed as described in previous comments on this bug.

After upgrading to 4.2 final and not changing anything else KDE's BT device manager properly starts without crashing. Pairing works, albeit is a little bit tricky -- but this is more a Stowaway keyboard issue.

Pairing with a mobile phone Samsung E900 also worked. However, while I can send files to my mobile, the other way round does not work. Trying to send a file from the mobile to my Netbook results after a few seconds in a "service not supported" error message on my mobile.

Removing the USB BT dongle crashes the device manager.

ajit (ajit-odyssey) wrote :

I am not able to understand the above message even i am facing the same above problem kindly let me know the above steps in a simple and layman's terms

Those having the problem with the "undefined symbol", are you sure you have kdebluetooth installed from intrepid-proposed; you still need that if you are running the kubuntu-experimental packages.

Andreas you were right. I somehow was under the impression the fixes were included in the 4.2 release. I also tested kdebluetooth_0.3-0ubuntu1, which doesn't work either.

kdebluetooth_0.3-0ubuntu0.1 on the other hand works. kbluetooth4 immediately started up, lookup and pairing with my phone worked nicely.

OBEX however failed with a "The name org.openobex was not provided by any .service files" message, also kbluetooth4 crashed the first time I pulled the bluetooth dongle, but I could not reproduce this.

Scott Kitterman (kitterman) wrote :

The package in intrepid-proposed is missing a depends on
obex-data-server. Install that. A fix upload is pending.

lazslo (enochlnx) wrote :

I downloaded Kdebluetooth4_0.3-0ubuntu1 this morning. I tried to connect from my phone to the computer. I gave it the "0000" for the computer and then the computer wanted the pin for the phone. I don't remember this happening before.

mfabry (mfabry) wrote :

I downloaded the new kdebluetooth4. File transfer from desktop to my handheld still doesn't work (and there are no error messages either). I launched kbluetooth4 from console and attached output in text file.

frapell (frapell) wrote :
Download full text (3.5 KiB)

I have installed 1:0.3-0ubuntu2~intrepid1~ppa1 version of kdebluetooth this morning and here is my update:

The device manager no longer crashes, but is no working properly. When i search for my phone i see in the console:

kbluetooth4-wizard(8458) BTWizard::slotSearch: Text "&Search"
kbluetooth4-wizard(8458) BTWizard::slotSearch: searching...
kbluetooth4-wizard(8458) BTWizard::slotSearch: Configured Devices: 1
kbluetooth4-wizard(8458) BluezBluetoothInterface::slotDeviceFound: device found "00:19:2C:1F:68:74" QVariant(QString, "Amin")
kbluetooth4-devicemanager(8455) BluezBluetoothInterface::slotDeviceFound: device found "00:19:2C:1F:68:74" QVariant(QString, "Amin")
kbluetooth4(8452) BluezBluetoothInterface::slotDeviceFound: device found "00:19:2C:1F:68:74" QVariant(QString, "Amin")
kbluetooth4-wizard(8458) BTWizard::slotRemoteDeviceFound: Configured Devices from slotRemoteDeviceFound: 1
kbluetooth4(8452) BluezBluetoothInterface::slotDeviceFound: device found "00:19:2C:1F:68:74" QVariant(QString, "Amin")
kbluetooth4-devicemanager(8455) BluezBluetoothInterface::slotDeviceFound: device found "00:19:2C:1F:68:74" QVariant(QString, "Amin")
kbluetooth4-wizard(8458) BluezBluetoothInterface::slotDeviceFound: device found "00:19:2C:1F:68:74" QVariant(QString, "Amin")
kbluetooth4-wizard(8458) BTWizard::slotRemoteDeviceFound: Configured Devices from slotRemoteDeviceFound: 1
kbluetooth4(8452) BluezBluetoothInterface::slotDeviceFound: device found "00:19:2C:1F:68:74" QVariant(QString, "Amin")
kbluetooth4-devicemanager(8455) BluezBluetoothInterface::slotDeviceFound: device found "00:19:2C:1F:68:74" QVariant(QString, "Amin")
kbluetooth4-wizard(8458) BluezBluetoothInterface::slotDeviceFound: device found "00:19:2C:1F:68:74" QVariant(QString, "Amin")
kbluetooth4-wizard(8458) BTWizard::slotRemoteDeviceFound: Configured Devices from slotRemoteDeviceFound: 1

and the device is no appearing in the selection box, it just keeps searching and searching. After i cancel it and do the pairing the other way around (from the phone) i get the issue reported by lazlo. kbt asks for a password, i enter 1234, then the phone asks for it, i enter 1234, and then kbt asks it again and then things kind of worked.

I go to the send file option, select any file, and when i have to select the device, i get an empty box, but in the console i can see:

kbluetooth4(8452) BluezBluetoothInterface::slotDeviceFound: device found "00:19:2C:1F:68:74" QVariant(QString, "Amin")
Remote Device found "00:19:2C:1F:68:74" Name: QVaria...

Read more...

Egbert van der Wal (eggie) wrote :

I just added intrepid-proposed to my apt sources and updated kbluetooth4.

When I run kbluetooth4 I can send a file to my phone using bluetooth when I rightclick the bluetooth icon in the systray and select send file. But when I select Device Manager, click on 'New' and then 'Next', 'Next', my phone is not displayed although in the terminal I do see the bluetooth name of my phone coming by.

Attached is the logfile of a kbluetooth4 session in which I first try to find my phone ('Idioot de 2e') using the device manager and then send a file (info.txt) to my phone.

This all is on Intrepid with KDE 4.1.

Scott Kitterman (kitterman) wrote :

All of which confirms it works far better than it did before. I think
these new issues now that it works at all should be filed as new bugs.

I've lost track of everything I've tried, but now after just updating my Intrepid Kubuntu UMPC I did get the KDE Bluetooth icon after a reboot, and did manage to send a file to Nokia N95. This is on KDE 4.1.4.

So while issues with Bluetooth definitely remain, I think the issue in this bug has definitely progressed. The KBluetooth system crashed just after successfully sending though... separate bug report for that?

Scott Kitterman (kitterman) wrote :

Yes. Separate bug for the crash please.

Sorry guys, don't want to spoil the party but on my machine at least nothing works, maybe I'm missing something though and maybe it's the versions that are the problem.

Details:

Intrepid, KDE 4.2

Versions:

KDEBluetooth 1.03 intrepid1 ppa1
Bluez 4.28
Bluetooth 4.28
Obex-data-server 0.4.3
kdebase 4:4.2.0 intrepid1 ppa2
kdebase-workspace 4:4.2.0 intrepid1-ppa7

Error is still the same, no bluetooth icon on desktop and when running the device-manager command manually, I still get the following:

$ /usr/bin/kbluetooth4-devicemanager
kbluetooth4-devicemanager(7880) Solid::Control::ManagerBasePrivate::loadBackend: Backend loaded: "BlueZ"
kbluetooth4-devicemanager(7880) BluezBluetoothManager::defaultInterface: Calling Backend Default Interface
QDBusObjectPath: invalid path ""
kbluetooth4-devicemanager(7880) Solid::Control::BluetoothManagerPrivate::findRegisteredBluetoothInterface: findRegisteredBluetoothInterface ""
kbluetooth4-devicemanager(7880) Solid::Control::BluetoothManagerPrivate::findRegisteredBluetoothInterface: Creating New Interface ""
kbluetooth4-devicemanager(7880) Solid::Control::BluetoothManagerPrivate::findRegisteredBluetoothInterface: Calling Backend to Creating New Interface ""
process 7880: arguments to dbus_message_new_method_call() were incorrect, assertion "path != NULL" failed in file dbus-message.cline 1070.
This is normally a bug in some application using the D-Bus library.
QDBusConnection: error: could not send message to service "org.bluez" path "" interface "org.freedesktop.DBus.Introspectable" member "Introspect"
kbluetooth4-devicemanager(7880) Solid::Control::BluetoothManagerPrivate::findRegisteredBluetoothInterface: BackendIface created
kbluetooth4-devicemanager(7880) DeviceMan::DeviceMan: Device Manager - Welcome
process 7880: arguments to dbus_message_new_method_call() were incorrect, assertion "path != NULL" failed in file dbus-message.cline 1070.
This is normally a bug in some application using the D-Bus library.
QDBusConnection: error: could not send message to service "org.bluez" path "" interface "org.bluez.Adapter" member "ListDevices"
kbluetooth4-devicemanager(7880) DeviceMan::getConfiguredDevices: Device List Size: 0
kbluetooth4-devicemanager(7880) DeviceMan::~DeviceMan: inputDeviceMap deleted
kbluetooth4-devicemanager(7880) DeviceMan::~DeviceMan: remoteDeviceMap deleted
kbluetooth4-devicemanager(7880) DeviceMan::~DeviceMan: Device Manager closed
kbluetooth4-devicemanager(7880) Solid::Control::BluetoothManagerPrivate::_k_interfaceDestroyed: Interface detroyed

@Peter
You seem to have a strange mixture of intrepid/jaunty. Bluez looks to be from jaunty while kdebluetooth and kdebase-workspace is from the intrepid kubuntu-experimental PPA; I would recommend either upgrade entirely to jaunty or get rid of the jaunty packages you have installed, else the chances of it working is not big.

Hi Andreas I'll take any suggestions at the moment so I will try to find out if there is something odd installed, but I don't have any package repositories in adept sources list from Jaunty, so not sure if thats really possible.

@Peter
Please try to give the full version numbers instead, as reported by eg. apt-cache policy:
apt-cache policy bluez kdebluetooth obex-data-server kdebase-workspace-bin | grep Installed

Sure no problem, Here are the results - whats the 'git' package?

$ apt-cache policy bluez kdebluetooth obex-data-server kdebase-workspace-bin | grep Installed
  Installed: 4.28-0ubuntu1~git20090125
  Installed: 1:0.3-0ubuntu2~intrepid1~ppa1
  Installed: 0.4.3-1
  Installed: 4:4.2.0-0ubuntu1~intrepid1~ppa7

Cheers,

Pete.

@Peter
Neither bluez nor obex-data-server is from an official ubuntu repository, or from the kubuntu-experimental PPA as i can see. And that most likely explains why it doesn't work for you compared to others.

To see, where you've got them from, try to do a:
apt-cache policy bluez
apt-cache policy obex-data-server

Ok that probably explains it. I did add extra repositories for other things I needed so maybe these have been picked up from there without me realizing it.

ok now its just getting weird.

I booted up today without making any changes and the Bluetooth icon appeared in the system tray for the first time. I was even able to register my mouse and use it. However on shutdown I got a kdebluetooth4 crash window and since then after rebooting no icon and back to the dreaded dbus !=NULL message on manual starts again.

Time to give up on this one I think. Maybe I'll try Jaunty.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdebase-workspace - 4:4.1.4-0ubuntu1~intrepid3

---------------
kdebase-workspace (4:4.1.4-0ubuntu1~intrepid3) intrepid-proposed; urgency=low

  * Remove files no longer provided to fix FTBFS and update bluetooth solid for
    Bluez 4 (LP: #280997)
    - Drop usr/share/kde4/apps/solidfakebluetoothbackend and
      solidbackends/solid_fakebluetooth.desktop from
      kdebase-workspace-data.install and /usr/lib/kde4/solid_fakebluetooth.so
      from kdebase-workspace-bin.install since they are no longer provided

 -- Scott Kitterman <email address hidden> Thu, 22 Jan 2009 06:17:18 -0500

Changed in kdebase-workspace:
status: Fix Committed → Fix Released

Hi Janitor,

Are you saying we should downgrade the kdebase-workspace version to an older version for everything to wrk properly?

Currently I appear to have the following installed:

kdebase-workspace-bin: 4.2.0-0ubuntu1~intrepid 1-ppa7

@Peter
4.2.0-0ubuntu1~intrepid1-ppa7 contains the fix as well. And btw, Janitor is not a person but a script/bot, so he'll not be able to answer you.

Scott Kitterman (kitterman) wrote :

On Sun, 15 Feb 2009 15:46:45 -0000 Peter Pugh-Jones <email address hidden>
wrote:
>Hi Janitor,
>
>Are you saying we should downgrade the kdebase-workspace version to an
>older version for everything to wrk properly?
>
>Currently I appear to have the following installed:
>
>kdebase-workspace-bin: 4.2.0-0ubuntu1~intrepid 1-ppa7

Which is not an official Kubuntu package. I'm not personally sure if the
bluetooth patches are in the ppa build or not. I think they are, but you
might ask someone on #kubuntu-devel to check.

There are clearly still some bluetooth issues that need to be fixed. If
bluetooth works at all for you in KDE, then you have the fix in question.

LOL I am sad not knowing Janitor was a bot ! Anyway thanks loads Scott & Andreas.

Changed in kdebase:
status: Confirmed → Fix Released
Slightcrazed (randall-walls) wrote :

I'm on a stock Jaunty install with all updates applied and I'm seeing the EXACT same behaviour. kbluetooth4 starts in 'offline mode', and I get:

arguments to dbus_message_new_method_call() were incorrect, assertion "path != NULL" failed in file dbus-message.c line 1070

when running kbluetooth-devicemanager. Status updated to confirmed so that Jaunty can get some bluetooth love.

Changed in kdebase-workspace (Ubuntu Jaunty):
status: Fix Released → Confirmed
Jonathan Thomas (echidnaman) wrote :

Different bug, this one is fixed.

Changed in kdebase-workspace (Ubuntu Jaunty):
status: Confirmed → Fix Released
Changed in kdebase:
importance: Unknown → High
Displaying first 40 and last 40 comments. View all 113 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.