Unable to activate Broadcom b43 after STA driver

Bug #443185 reported by Jim Rorie on 2009-10-05
134
This bug affects 23 people
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
Low
Martin Pitt
Nominated for Maverick by Ben Isaacs
Karmic
Medium
Unassigned

Bug Description

This bug report became very noisy, the biggest part of it is already fixed, and loads of unrelated issues were reported. This bug report is about not showing the "b43" driver in Jockey any more once the STA driver has been enabled. This is due to the STA driver blacklisting 43, so that Jockey does not "see" it any more. If you have a different problem, please report a new bug!

WORKAROUND: Disable STA, reboot, run jockey again. This will show b43 again, which you can then activate. (Note that STA is highly recommended)

Original (obsolete) bug description:

Karmic Beta, Macbook Pro 5,1, Linux medusa 2.6.31-11-generic #38-Ubuntu SMP Fri Oct 2 11:06:40 UTC 2009 x86_64 GNU/Linux

When attempting to activate b43 driver, jockey disables input, acting as if it is busy. It never responds. When activating STA, jockey immediately returns, but the STA entry isn't marked as highlighted. lsmod shows b43 as loaded, but I have no wireless functions in net-man:

jfrorie@medusa:~$ lsmod | grep b43
b43 136552 0
ssb 40944 1 b43
mac80211 210104 1 b43
cfg80211 109144 2 b43,mac80211
led_class 5256 2 b43,applesmc

Attempting to load bcwml-kernel-source failed due the package not existing.

jfrorie@medusa:~$ sudo apt-get --reinstall install bcwml-kernel-source
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package bcwml-kernel-source

Possible duplicate of:
https://bugs.launchpad.net/ubuntu/+source/jockey/+bug/428428
https://bugs.launchpad.net/ubuntu/+source/jockey/+bug/440294
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/289360

ProblemType: Bug
Architecture: amd64
Date: Mon Oct 5 09:57:32 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/jockey-gtk
InterpreterPath: /usr/bin/python2.6
MachineType: Apple Inc. MacBookPro5,1
NonfreeKernelModules: nvidia
Package: jockey-gtk 0.5.5-0ubuntu1
PackageArchitecture: all
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-11-generic root=UUID=6a5f8c22-b773-4d05-b619-5b65bfa38369 ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
SourcePackage: jockey
Uname: Linux 2.6.31-11-generic x86_64
dmi.bios.date: 02/03/09
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBP51.88Z.007E.B00.0902031928
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-F42D86A9
dmi.board.vendor: Apple Inc.
dmi.board.version: Proto
dmi.chassis.asset.tag: Asset Tag#
dmi.chassis.type: 8
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F42D86A9
dmi.modalias: dmi:bvnAppleInc.:bvrMBP51.88Z.007E.B00.0902031928:bd02/03/09:svnAppleInc.:pnMacBookPro5,1:pvr1.0:rvnAppleInc.:rnMac-F42D86A9:rvrProto:cvnAppleInc.:ct8:cvrMac-F42D86A9:
dmi.product.name: MacBookPro5,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

Jim Rorie (jfrorie) wrote :
Tony (tonyr2k8) wrote :

This problem all so exists on the Macbook Pro 5,5

Dell Mini 9 - Developer's daily Desktop i386 (as of Sunday, October 4, 2009 at about 6:00PM MST (UTC-7). Install from USB key, manual partition (Installation complete, successfully). Boot and login successful. Wireless not active.

Hardware Drivers offered - Proprietary bc STA driver is the only one offered. When attempted to activate, it did not activate.

NOTE: This same driver activated and worked in Jaunty on the same machine under the same conditions of installation. If this can't be corrected, then it is a show stopper for my installing Ubuntu 9.10.

Rafael Bedendo (rafael-bedendo) wrote :

In my Notebook Inspiron 1525 was not automatically activated the network driver. You have to go to administration> hardware drivers and enable the Broadcom STA.

Jim Rorie (jfrorie) wrote :

Ok, I'm not crazy. Bumping this. It will cause havoc if it gets released this way.

Changed in jockey (Ubuntu):
status: New → Confirmed
Vince (v-brz) wrote :

I am experiencing the same issue on Karmic beta 64bit.

It did work with the liveCD though

Marcos Roriz (marcosrorizinf) wrote :

Im with this bug too :(

Marcos Roriz (marcosrorizinf) wrote :

on Dell Mini 1120BR

nwahmaet (nwahmaet) wrote :

Same experience as #3 above, on Dell Mini 9

Can Hantas (canhantas) wrote :

same problem here on Lenovo s10 Karmic 32bit (daily build 8. October)

It's bcmwl-kernel-source, not bcwml-kernel-source... I reinstalled this package and it is marked as activated in Hardware Drivers, but still doesn't work. ;/

Major Lockup (mlockup-rapture) wrote :

I used to have the exact same problem, on my dell mini 9 with BCM4312.
In despair I tried to find a way of making my wireless work, when after many failed attempts I noticed in jockey.log that the command "patch" was not there. I just did an apt-get install patch and it worked.

I hope this will help some of those who experience the same issue.

@Major Lockup
That's not it. I have a patch package installed, but my WiFi doesn't work.

Albert Cardona (cardona) wrote :

The reinstallation of the bcmwl-kernel-source package let me activate the STA driver, only after I have run again the activation via "Hardware drivers" manager GUI tool. The GUI still shows that the driver is not active (?), but it starts working.

What happens next is that the computer freezes after a few seconds of activating the STA driver.

This is a shiny new macbook pro with an nvidia card, running 9.10 installed from a beta 5 and dist-upgraded to today.

I checked on my old ASUS and WiFi doesn't work there, either. I think it's a *REALLY* serious bug; RC is on its way, I'd advise to bump the priority. I assume we'd all want to have working WiFi on a LiveCD, otherwise a lot of people won't be able to use Ubuntu at all (not everyone have ethernet network available).

Please, mark it Critical.

Brian Murray (brian-murray) wrote :

From CurrentDmesg.txt:

[37975.565677] b43-phy1: Broadcom 4322 WLAN found (core revision 16)
[37975.662805] b43-phy1 ERROR: FOUND UNSUPPORTED PHY (Analog 8, Type 4, Revision 4)
[37975.662851] b43: probe of ssb0:0 failed with error -95
[37975.662897] Broadcom 43xx driver loaded [ Features: PL, Firmware-ID: FW13 ]
[39570.221000] b43-phy2: Broadcom 4322 WLAN found (core revision 16)
[39570.320206] b43-phy2 ERROR: FOUND UNSUPPORTED PHY (Analog 8, Type 4, Revision 4)
[39570.320241] b43: probe of ssb0:0 failed with error -95
[39570.320281] Broadcom 43xx driver loaded [ Features: PL, Firmware-ID: FW13 ]

tags: added: regression-potential
Changed in jockey (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Changed in jockey (Ubuntu Karmic):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Martin Pitt (pitti) on 2009-10-20
Changed in jockey (Ubuntu Karmic):
assignee: Canonical Desktop Team (canonical-desktop-team) → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

I just tried that here, with faking jockey to think that my system has a broadcom wifi (I don't actually have one). I saw both the STA and the b43 drivers in Jockey. I enabled STA, it got installed (bcmwl-kernel-source), and jockey told me that the computer needs to be restarted (which is probably not true, it should work right away). the bcmwl-kernel-source package generated an appropriate /etc/modprobe.d/blacklist-bcm43.conf as well.

I then opened Jockey again and selected the b43 driver (I didn't reboot). Again it downloaded the driver, installed it, and said that you need to reboot (unavoidable, sorry). It correctly downloaded and extracted the firmware to /lib/firmware/b43, but failed to remove the blacklist file; that's because installing b43 did not uninstall bcmwl-kernel-source, which it should. (or at least remove the blacklist).

Jim, did you have a network connection when you tried this? It has to download stuff from the internet (for b43) and from the Ubuntu archive (for both drivers).

Jim Rorie (jfrorie) wrote :

I did have a wired network connection when I tried it.

One thing that noticed the other day when I tried it again. When I loaded the STA attempted to load, I noticed that the netman indicator activated and loaded the network. The jockey driver indicator was never changed. However, it didn't last beyond reboot. Wireless was not active.

Martin Pitt (pitti) wrote :

> STA ... and jockey told me that the computer needs to be restarted

Hm, I can't actually reproduce this again; I think I might have some module loaded before which I shouldn't have in my first run. Also, it's a fairly cosmetical bug, if it really happens for someone else, please file a separate bug.

Martin Pitt (pitti) wrote :

I fixed the b43 handler in http://bazaar.launchpad.net/~ubuntu-core-dev/jockey/ubuntu/revision/373 now. With that I can enable STA, switch to b43, and switch back to STA without ever havning to reboot, and it loads the correct modules and sets the correct blacklist.

summary: - Unable to activate Broadcom b43 and STA drivers
+ Unable to activate Broadcom b43 after STA driver
Changed in jockey (Ubuntu Karmic):
status: Triaged → Fix Committed
importance: High → Medium
milestone: none → ubuntu-9.10
Jim Rorie (jfrorie) wrote :

I've run this system since alpha 4. I'm wondering if part of it might be people that upgraded vs. fresh install? Otherwise, wouldn't we have more people complaining?

> Also, it's a fairly cosmetical bug, if it really happens for someone else, please file a separate bug.

What aspect is cosmetic? Although, the STA has a cosmetic portion, the load isn't surviving the reboot.

Jim Rorie [2009-10-22 17:34 -0000]:
> What aspect is cosmetic?

The bit that the STA driver says "needs reboot" when it's actually
already working. I just saw that once in my testing, though, and I
cannot say whether it was because I had the b43 module still loaded at
that time.

--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.5.5-0ubuntu2

---------------
jockey (0.5.5-0ubuntu2) karmic; urgency=low

  * data/handlers/b43.py: Remove bcmwl-kernel-source on installation, so that
    it actually has a chance to work when wl was active before. (LP: #443185)

 -- Martin Pitt <email address hidden> Thu, 22 Oct 2009 21:58:32 +0200

Changed in jockey (Ubuntu Karmic):
status: Fix Committed → Fix Released

@Martin Pitt
I'm not sure if reboot is not required. I activated the STA driver and I saw wifi networks but when I tried to connect to one of them, my system freezed. Only after a reboot everything works OK.

I also downloaded RC image, recorded it to USB by USB Disk Creator, booted, installed all updates, rebooted and activated the STA driver; my OS hanged even before I had a chance to connect to a wireless network. This time, though, after a reboot I see the STA driver activated, but wifi doesn't work at all (nm-applet doesn't see there is any wifi device at all).

Martin Pitt (pitti) wrote :

Michał Gołębiowski [2009-10-24 13:20 -0000]:
> booted, installed all updates, rebooted and activated the STA driver; my
> OS hanged even before I had a chance to connect to a wireless network.

This is a problem in the STA drive itself, though. Jockey just
installs it. Can you please report a bug against bcmwl?

laforey (laforey) wrote :

Dell Inspiron 1545. BCM4312. Karmic RC, managed to install and activate Wireless during Live CD session,with STA drivers from CD. But the Hardware Drivers app from the installed Karmic, can't activate the card. Go figure!!
Please fix this before final release.
thanks

@laforey
Did You do 'sudo apt-get update && sudo apt-get upgrade' first? I think this was fixed after RC release, so You have to upgrade first.

laforey (laforey) wrote :

sorry, but no results after "update & upgrade"
Still looking for a fix.
thanks

Alaric (jroose) wrote :

Run apt-cache show jockey-common and post the results here. The update just hit my repository. Ran the update process about 6 hours ago and there was nothing, then a minute ago it updated jockey to the version listed above. I've also got a Inspiron 1545 and I'm about to test whether this will fix the issue or not (I installed the jockey update under VirtualBox through XP, but I'm sure plugging into the network will work just as well as for me).

Alaric (jroose) wrote :

B43 disappears because it is uninstalled by Jockey when switching to STA. It can be reinstalled and loaded, but will not work with network manager, and is not a bug in Jockey. STA requires a restart to update network-manager. Inspiron 1545 users, use STA, although it does still have a few bugs of its own. The update to jockey-common and jockey-gtk (0.5.5-0ubuntu2) allows STA to be loaded. It may have just today propagated through the repositories.

Jim Rorie (jfrorie) wrote :

Still not working. Is there another step to resync or reset or something?

Installed-Size: 1472
Maintainer: Martin Pitt <email address hidden>
Architecture: all
Source: jockey
Version: 0.5.5-0ubuntu2
Depends: python (<< 2.7), python (>= 2.5), python-central (>= 0.6.11), python-xdg, python-xkit, python-dbus, python-apt, policykit-1

Johnny Proton (obijuan) wrote :

I am on a HP Mini 110 and this does not work in the Netbook Remix. Is this issue supposed to be resolved now? I had to manually install from the USB Key:

* dkms
* bcwml-kernel-source

And it still won't let me activate the driver. I've even made sure to do a clean restart while plugged into the ethernet and that didn't help.

Jim Rorie (jfrorie) wrote :

Ok, now it's working and I didn't do anything, The b43 option isn't in Jockey anymore. Wireless is active under STA, but I didn't activate it. It apparently finally remembered it from all the other attempts.

I see if I can load a clean image this weekend and test it.

I have a compaq mini 700 (the European hp mini version) just did a clean install of the unr and i can't activate the driver also. I can't use the wireless which makes it almost impossible to work. I did a update && upgrade but i still can't activate the driver.

Pham Thanh Nam (alophone2003) wrote :

Go to pool/restricted/b/bcmwl on Ubuntu CD or Ubuntu Live USB. Double click into the .deb file in there, and REINSTALL that package. Now you can activate Broadcom STA driver in Hardware Drivers.

Thank you! It works perfectly now.

Gonzalo Fernandez (gonz-it) wrote :

Thank you Pham Thanh your solution is the one

Paladyne (paladyne) wrote :

ty as well Pham Thanh, I had 4 comps offline because of this, something to add is off the cd for release you still need some kind of internet to dl the driver files, if you dont have a nic, it is always wise to keep a cheap usb wifi adapter nearby, this saved me here

AGreen BHM (agreenbhm) wrote :

Thanks a ton Pham! I tried to reinstall from Synaptic but that didn't seem to fix it. Your method, however, worked well.

jonLiechty (jonliechty) wrote :

I tried this last solution, but when I click activate on the Driver, it says Downloading and Installing Driver, doesn't do anything. It's still not activated. Thoughts?

TraceyC (grrlgeek) wrote :

I also had problems getting the wireless driver to load correctly on a fresh install of 9.10 on a Dell Latitude E6400. Previously, I had upgraded from 9.04 to 9.10 on this laptop and wireless was working fine. Pham's solution worked for me on the fresh install.

Nikolaus Rath (nikratio) wrote :

According to comment 40, this is still not fixed. I just reproduced it on a Dell Inspiron 1526. When running from the Karmic live CD, jockey correctly activates the driver. In the installed system, it doesn't do anything anymore. The "Downloading and Installing" dialog pops up briefly, but the driver stays disabled.

Changed in jockey (Ubuntu):
status: Fix Released → Confirmed
Changed in jockey (Ubuntu Karmic):
status: Fix Released → Confirmed
Nikolaus Rath (nikratio) wrote :

In my case, the problem can be fixed by purging and reinstalling bcwml-kernel-source, b43-fwcutter and bcwml-modaliases.

brennus (brennus) wrote :

I had this same thing happen to me. I've been using an upgraded 9.10 since release, but tonight I did a full re-install, and my wireless stopped working. b43 will activate, but doesn't work (wireless networks not shown in network manager applet). The first time I tried STA, it activated, disconnected my wired connection, and just as my wireless was starting to connect, my screen went black save for my pointer/mouse, and my system froze.

Looking for solutions.

Martin Pitt (pitti) wrote :

I cannot reproduce this. Please give detailled steps of how you installed, what you did, what you see (screenshots appreciated), and whether you have had a network connection during the time when you installed jockey. Please also attach /var/log/jockey.log after using jockey.

Changed in jockey (Ubuntu):
milestone: ubuntu-9.10 → none
Changed in jockey (Ubuntu Karmic):
milestone: ubuntu-9.10 → none
Changed in jockey (Ubuntu):
status: Confirmed → Incomplete
Martin Pitt (pitti) on 2009-11-08
Changed in jockey (Ubuntu Karmic):
status: Confirmed → Incomplete
Doug Whitfield (douglasawh) wrote :

Can someone post step-by-step instructions? I've gone through the entire thread and re-installed via the suggestion on #35 and it still doesn't work on Lenovo IdeaPad S10-2. I have jockey-common_0.5.5-0ubuntu2_all.deb

Doug Whitfield (douglasawh) wrote :

after some series of uninstalling and re-installing the driver and rebooting and incantations to the great lord of Ubuntu Satanic edition, it works...

brennus (brennus) wrote :

Douglas -- do you know what you did? I still can't figure it out on my dell e1405.

brennus (brennus) wrote :

Ok, another attempt at this. No screenshots, sorry about that.

Process starting from no wireless drivers installed (completely removed via synaptic). No wired connections working either.
Boot. Login. Insert Ubuntu Karmic x64 live cd.
Go to pool, reserved, install bcmwl.
Go to pool, main, install b43-cutter.
Reboot. Repeat several times, purging (complete removal via synaptic) each time.
Repeatedly, Hardware Drivers (jockey?) shows no available drivers to activate.
After several tries, I download and transfer from a different computer ndiswrapper common & utils and ndisgtk, thinking that maybe I need those for these drivers to work (although I do not believe that to be the case). I did not install any windows drivers, though.
On next try, wired connection finally worked, though no wireless drivers are installed. Call it a coincidence, I don't know.
Open Hardware Drivers (jockey?) and find b43 driver finally. Mark as active. It downloads and activates.
Install bcmwl (STA driver) from liveCD pool.
Upon reboot, b43 driver is now gone (from jockey), though STA driver appears (in jockey).
Click activate on STA driver, and jockey goes through the motions (password input, says it's downloading and installing, etc). It even disconnects my wired connection, as though it were activating it.
However, STA remains inactive, the little light isn't green, and it's as if I never told it to activate.

This is my current state, though it is unclear if this will still be clear tomorrow when I boot again. At this point I am utterly frustrated and out of ideas. There seems to be no rhyme nor reason to this process. An assistance is greatly appreciated.
Attached is my var/log/jockey.log

Risto H. Kurppa (risto.kurppa) wrote :

HP dv2140eu here with broadcom. Installed Karmic 64-bit Kubuntu there.

On live, I was able to install the drivers (b43, I think, I have no idea what's STA). I did it with no network connection, I think.

But now on installed system, with wired network I have the problems described above. I've upgraded the system to the latest packages but jockey usually disables the driver list wihtout actually installing anything.

-> this still seems to be an issue.

Risto H. Kurppa (risto.kurppa) wrote :

I finally decided to install the nvidia driver and restarted the computer - only to see that also the STA was installed and WLAN worked. -> looks like it may also have some problems showing if something's installed or not..

I installed 9.10 - My broadcom worked fine, but stopped working. This fix will work for most of you.
Go to System>Admin>Software Sources>OtherSoftware and add CD-rom with the install disk in the drive. Then open it up the cd and go to Pool>Restricted>b>bcmwl and install the deb file. Restart the computer and then go to System>Admin>Hardware Drivers and enable the driver. Restart. You should be good to go.

Unfortunately for me it worked perfect the first day. I installed all my updates and everything. shut down the computer and started it back up the next day and all i had was wired internet. I have repeated the process. installed ubuntu over and over again and nothing.

Synaptic shows the bcmwl-kernel-source is installed, but in Hardware Drivers nothing ever shows up.

Any ideas? Man, ubuntu needs this fixed BAD!

Loz (misterloz) wrote :

Any news on this fix?

This is fairly crippling to me, as one of the main reasons for having a netbook is its portability!

I have tried all the fixes listed above, but nothing has worked.

brennus (brennus) wrote :

Mine started working reliably after some unkown combination of uninstalling and reinstalling. It sucks, but that's the best anyone seems to be able to offer.

GWN (mike-nuala2) wrote :

DELL MINI 10v (9.10 UNR)

I too tried all the fixes listed above, but still couldn't activate the STA driver (even though it seemed installed).

Then I found a blog by Ridzwan that solved my problem (http://ridz1ba.blogspot.com/2009/11/unr-910-and-lenovo-s10-2-bad-karma_11.html).

To summarize, I had to re-install the STA driver, type the command as follows:

sudo dpkg --install /media/NAME/pool/restricted/b/bcmwl/bcmwl-kernel-source_5.10.91.9+bdcom-0ubuntu4_i386.deb

note1: NAME is the name of your USB stick (type "mount" at the terminal to find your usb stick's name). If you're using a liveCD, then your media path will be different.

note2: the name of my .deb file was different than Ridzwan's .deb file name and could be version related, find the actual name of your .deb file in the /pool/restricted/b/bcmwl/ folder.

Reboot your system and the network notification thingy (top right on UNR) should indicate both wired and wireless connections.

Hope this works for you.

Ketil Malde (ketil-ii) wrote :

Just another data point: I recently got an HP dm1 with a Broadcom 4312. After struggling with various options to get the wifi to work, I fired up jockey-gtk and activated first the b43 driver, which didn't work, and then the STA, which brought up a new interface (eth3). The computer froze when trying to configure it with wicd, but after a reboot, everything worked.

Steve Beattie (sbeattie) on 2009-12-02
tags: added: karmic regression-release
removed: regression-potential
Mihai Tambur (miskamt) wrote :

I didn't had any problems in Ubuntu 9.04 with the WI-FI it worked perfectly just activating the driver, but now ... it works only in live cd mode ... you went some steps back wit this release. I feel pityfull ...

Maelvon (maelvon-hawk) wrote :

On an Inspiron 1545, Karmic fresh install, the B43 is not working. Grrr !

But, it run after running thoses command in Terminal :

sudo apt-get install linux-backports-modules-karmic b43-fwcutter
sudo modprobe b43

Then go :

System->Administration->Hardware Drivers

Then activate the :

Broadcom B43 wireless driver

Hope this help!

markba (mark-baaijens) wrote :

Yes, that worked! Thanks all for the work.

Can anybody explain why the bugfix is in a backport-module? Normally backports are used for enhancements (like a new version of Firefox or OpenOffice), not for bugfixing.

SDC (sufyan-droubi) wrote :

Didn't work for me. Hardware Drives still not indicating the driver.

Martin Pitt (pitti) wrote :

I got a Dell Mini 10 now for testing, which has a Broadcom Wifi card, so I can test/fix this now.

Changed in jockey (Ubuntu):
status: Incomplete → In Progress
Changed in jockey (Ubuntu Karmic):
status: Incomplete → Triaged
assignee: Martin Pitt (pitti) → nobody
Richard.Downes (rdownes-uk) wrote :

Msi u130 netbook dual boot running Kubuntu 10.04. Wireless connectivity is broken. When I use the Create network connection tool I can input of settings but cannot connect. Ndiswrapper saves windows drivers but wireless remains unusable.

Richard.Downes (rdownes-uk) wrote :

https://answers.launchpad.net/ubuntu/%2Bquestion/95245?hl=en_GB

I did a little research and found the link above which was the solution:

UNCLAIMED Wireless Network controller [0280]: RaLink RT3090 Wireless 802.11n 1T/1R PCIe [1814:3090] - no drivers installed for wireless chipset on Compal KTV00 netbook in Ubuntu 9.10
Ubuntu Questions Question #95245

This solved my problem.

Msi u130, Intel Atom N450
2GB memory, WLAN 802.11b/g/n
Kubuntu 10.04 Beta 1

Martin Pitt (pitti) wrote :

This bug is not nearly important enough to be SRUed, it's a corner case.

description: updated
description: updated
Changed in jockey (Ubuntu Karmic):
status: Triaged → Won't Fix
Changed in jockey (Ubuntu):
importance: Medium → Low
Martin Pitt (pitti) wrote :

I investigated this more closely, and I'm afraid there is no easy way to have the b43 driver appear in jockey when STA is enabled.

Technical background: the STA driver blacklists tbe ssb module (it has to, in order to work at all), and the b43 module has modaliases in terms of "ssb:". Since there are no ssb: devices at all, the b43 module does not match on the current system. Even when loading ssb manually (or adding a manual modalias file for it) doesn't help, since wl blocks the detection of any ssb devices.

So the official answer for this is: Disable STA first, then enable b43. Sorry :-/

Changed in jockey (Ubuntu):
status: In Progress → Won't Fix
Marite (marite-sproge) wrote :

Guys - i did it!!
This crappy STA error was bugging me for 3 days.
As i am so green in this technical thing, first in my life i had to go through a million of treads regarding this missing wireless thing and i had no solution for my case.
1 - i did saw an inactive STA in System/Administration/Hardware drivers but i couldn't activate it
2- i checked Synaptic package manager and there wasn't this bcmwl-kernel-source, but there at least was bcmwl-modaliases
3 - i reinstalled the last one bcmwl-modaliases
4 - rebooted computer
5 - in Hardware drivers appeared B43 as already active, but wireless wasn't working anyways
6 - though i removed B43
7 - rebooted again
8 - tried to activate STA and got message "/var/log/jockey.log"
9 - tried again and got message "Sorry, the Jockey backend crashed"
how da heck could i know, that i have to go to Synaptic manager / Settings / Repositories / and mark a tickbox in Ubuntu softwear "Proprietary drivers for devices (restricted) !!!??? This small step solved all my problems
10 - bcmwl-kernel-source appeared in synaptic
11 - i acivated all of it, rebooted
12....and vuala!! Wireless was there!!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions