indicator-datetime or -session missing ~10% of the time

Bug #1239710 reported by Gema Gomez on 2013-10-14
532
This bug affects 134 people
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Fix Released
High
Lars Karlitski
Session Menu
Fix Released
High
Lars Karlitski
indicator-datetime (Ubuntu)
High
Prabhat Mishra
Saucy
High
Unassigned
indicator-session (Ubuntu)
High
Unassigned
Saucy
High
Unassigned

Bug Description

Impact: sometime indicator-session or datetime go missing in unity

Test Case: start sessions until that happens (or not)

Regression potential: the change is a one liner workaround for a glib lock, shouldn't create issue, just check that those indicators keep working as they should

-------------------

Indicator-datetime is not showing in the indicator bar today on image 96.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: indicator-datetime 13.10.0+13.10.20131011-0ubuntu1
Uname: Linux 3.4.0-3-mako armv7l
ApportVersion: 2.12.5-0ubuntu2
Architecture: armhf
Date: Mon Oct 14 16:00:26 2013
InstallationDate: Installed on 2013-10-14 (0 days ago)
InstallationMedia: Ubuntu 13.10 - armhf (20131014)
MarkForUpload: True
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
SourcePackage: indicator-datetime
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Gema Gomez (gema) wrote :
tags: added: avengers qa-touch
tags: added: rls-s-incoming
Jean-Baptiste Lallement (jibel) wrote :

confirmed on mako/build 96. But it doesn't happen on every boot.

Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
Charles Kerr (charlesk) wrote :

I'm having difficulty reproducing this issue.

When indicator-datetime fails to appear, is the indicator-datetime-process running on the system? Since there's no crash report, it seems likely that it's either hanging or is somehow failing to launch.

Gema Gomez (gema) wrote :

Will try to reproduce and find out today.

Gema Gomez (gema) wrote :

No, it is not present:
0 32011 2338 1927 20 0 40248 4160 poll_s Ssl ? 0:00 /usr/lib/arm-linux-gnueabihf/indicator-secret-agent
0 32011 2339 1927 20 0 39256 4808 poll_s Ssl ? 0:01 /usr/lib/arm-linux-gnueabihf/indicator-network/indicator-network-service
0 32011 2377 1927 20 0 35480 2840 poll_s Sl ? 0:00 /usr/lib/arm-linux-gnueabihf/indicator-bluetooth/indicator-bluetooth-service
0 32011 2383 1927 20 0 44452 2640 poll_s Sl ? 0:00 /usr/lib/arm-linux-gnueabihf/indicator-messages/indicator-messages-service
0 32011 2385 1927 20 0 27712 3248 poll_s Sl ? 0:00 /usr/lib/arm-linux-gnueabihf/indicator-location/indicator-location-service
0 32011 2386 1927 20 0 44984 3164 poll_s Sl ? 0:03 /usr/lib/arm-linux-gnueabihf/indicator-power/indicator-power-service
0 32011 2387 1927 20 0 104640 3440 poll_s Sl ? 0:00 /usr/lib/arm-linux-gnueabihf/indicator-sound/indicator-sound-service
0 0 4552 4537 20 0 1460 508 pipe_w S+ pts/16 0:00 grep --color=auto indicator

Matt Fischer (mfisch) wrote :

It's working for me in image 99.

Jean-Baptiste Lallement (jibel) wrote :

it's transient, sometimes indicator is present, sometimes not but I couldn't identify a pattern.

Changed in indicator-datetime (Ubuntu):
assignee: nobody → Charles Planincheck (charles)
importance: Undecided → High
assignee: Charles Planincheck (charles) → Charles Kerr (charlesk)
Changed in indicator-datetime:
importance: Undecided → High
status: New → Confirmed
Lars Karlitski (larsu) on 2013-10-17
Changed in indicator-session:
status: New → Confirmed
Changed in indicator-session (Ubuntu):
status: New → Confirmed
Changed in indicator-datetime:
assignee: nobody → Lars Uebernickel (larsu)
status: Confirmed → In Progress
Changed in indicator-session:
status: Confirmed → In Progress
assignee: nobody → Lars Uebernickel (larsu)
summary: - indicator-datetime missing
+ indicator-datetime and -session missing ~10% of the time

I have that problem but on desktop not Ubuntu Touch. I can't be sure if those indicators will start as they should.

Sometimes logout and login back makes them appear but for example today when I loged in there was no indicator-datetime so I logout and log back in and there is no indicator-session.

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:indicator-session/13.10 at revision None, scheduled for release in indicator-session, milestone Unknown

Changed in indicator-session:
status: In Progress → Fix Committed
Changed in indicator-datetime:
status: In Progress → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:indicator-datetime/13.10 at revision None, scheduled for release in indicator-datetime, milestone Unknown

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-datetime (Ubuntu Saucy):
status: New → Confirmed
Changed in indicator-session (Ubuntu Saucy):
status: New → Confirmed
Changed in indicator-datetime (Ubuntu):
status: Confirmed → Fix Committed
Changed in indicator-session (Ubuntu):
status: Confirmed → Fix Committed
Changed in indicator-datetime (Ubuntu):
assignee: Charles Kerr (charlesk) → nobody
Changed in indicator-datetime (Ubuntu Saucy):
status: Confirmed → Triaged
Changed in indicator-session (Ubuntu Saucy):
status: Confirmed → Triaged
Changed in indicator-session:
importance: Undecided → High
Changed in indicator-datetime (Ubuntu Saucy):
importance: Undecided → High
Changed in indicator-session (Ubuntu Saucy):
importance: Undecided → High
Changed in indicator-session (Ubuntu):
importance: Undecided → High
description: updated
Paweł Włosek (suore) wrote :

Repair this, please! irritates me it.

Ubuntu 13.10 64-bit.

M132 (m132) wrote :

For those who hate rebooting/relogging:
killall unity-panel-service

If doesn't work:

/usr/lib/x86_64-linux-gnu/indicator-datetime/indicator-datetime-service
killall unity-panel-service

or

/usr/lib/x86_64-linux-gnu/indicator-session/indicator-session-service
killall unity-panel-service

Hello Gema, or anyone else affected,

Accepted indicator-session into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/indicator-session/12.10.5+13.10.20131023.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in indicator-session (Ubuntu Saucy):
status: Triaged → Fix Committed
tags: added: verification-needed
tags: removed: rls-s-incoming
Changed in indicator-datetime (Ubuntu Saucy):
status: Triaged → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Gema, or anyone else affected,

Accepted indicator-datetime into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/indicator-datetime/13.10.0+13.10.20131023.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

I installed both indicator packages from proposed on two machines and restarted them about 20 times each, also logged out and back in about 20 times and both indicators always showed up. Occasionally they were missing before so the proposed packages seem to have fixed this bug for me.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 13.10.0+13.10.20131023.2-0ubuntu1

---------------
indicator-datetime (13.10.0+13.10.20131023.2-0ubuntu1) saucy-proposed; urgency=low

  [ Marcus Tomlinson ]
  * Fixed datetime title text to read "Date and Time" rather than the
    day of the week (as per spec). (LP: #1236400)

  [ Lars Uebernickel ]
  * Work around glib's type initialization deadlock.
    https://bugzilla.gnome.org/show_bug.cgi?id=674885. (LP: #1239710)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 279
 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 28 Oct 2013 14:59:27 -0400

Changed in indicator-datetime (Ubuntu):
status: Fix Committed → Fix Released
pdknsk (pdknsk) wrote :

I have installed indicator-datetime 13.10.0+13.10.20131023.2-0ubuntu1 and indicator session 12.10.5+13.10.20131023.1-0ubuntu1 from saucy-proposed, and this isn't fixed for me. I already updated some days ago, but only had it occur again today.

The service isn't running.

 1496 ? Sl 0:00 /usr/lib/i386-linux-gnu/indicator-application-service
 1499 ? Sl 0:00 /usr/lib/i386-linux-gnu/indicator-sound/indicator-sound-service
 1501 ? Sl 0:00 /usr/lib/i386-linux-gnu/indicator-power/indicator-power-service
 1512 ? Sl 0:00 /usr/lib/i386-linux-gnu/indicator-session/indicator-session-service

summary: - indicator-datetime and -session missing ~10% of the time
+ indicator-datetime or -session missing ~10% of the time
Michal Hruby (mhr3) on 2013-11-04
Changed in indicator-datetime (Ubuntu):
status: Fix Released → Confirmed
Michal Hruby (mhr3) on 2013-11-04
Changed in indicator-datetime (Ubuntu):
status: Confirmed → Fix Committed
pdknsk (pdknsk) wrote :

Well, it's not confirmed.

I installed those two packages long ago even before they landed in saucy-proposed. I simply downloaded them from SRU Staging PPA and so far everything worked.

Unfortunately today indicator-datetime didn't load. I think that there was about 30 successful boots (checking disks on Plymouth screen) since I installed the packages that supposedly fix the problem.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 12.10.5+13.10.20131023.1-0ubuntu1

---------------
indicator-session (12.10.5+13.10.20131023.1-0ubuntu1) saucy; urgency=low

  [ Lars Uebernickel ]
  * Work around glib's type initialization deadlock.
    https://bugzilla.gnome.org/show_bug.cgi?id=674885. (LP: #1239710)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 416
 -- Ubuntu daily release <email address hidden> Wed, 23 Oct 2013 05:57:52 +0000

Changed in indicator-session (Ubuntu Saucy):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 13.10.0+13.10.20131023.2-0ubuntu1

---------------
indicator-datetime (13.10.0+13.10.20131023.2-0ubuntu1) saucy-proposed; urgency=low

  [ Marcus Tomlinson ]
  * Fixed datetime title text to read "Date and Time" rather than the
    day of the week (as per spec). (LP: #1236400)

  [ Lars Uebernickel ]
  * Work around glib's type initialization deadlock.
    https://bugzilla.gnome.org/show_bug.cgi?id=674885. (LP: #1239710)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 279
 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 28 Oct 2013 14:59:27 -0400

Changed in indicator-datetime (Ubuntu Saucy):
status: Fix Committed → Fix Released
hufemj (hufemj-yahoo) wrote :

Upon upgrade to 13.10 from 13.04, all of the icons in the taskbar at the upper right disappeared after login. That is, when the login screen was present, the gear icon , time, etc. appeared. After login, the top status bar is completely blank. I have rebooted several times and the problem is very repeatable. I have a couple of sample users on this desktop and logging in as one of them has the same results. That is, no gear icon for logout/shutdown/reboot or clock or anything else.

I did an update around 8 PM Eastern time today, rebooted and the problem remains.

BeowulfOF (beowulfof) wrote :

Fix does work on my system. Thank you guys!

jerrylamos (jerrylamos) wrote :

time/date indicator now up after 3.12.0-2 update. Indicator not there this morning with3.12.0-1.

Gerhard Beck (gerhardbeck-de) wrote :

after updating yesterday indicator's not there right now...

Israel Dahl (israeldahl) wrote :

I don't have proposed enabled in 13.10, and I have the issue, but it looks as though the proposed "fix" doesn't always fix it from a few of the above comments.
I have variety (wallpaper changer) installed which shows the time on my wallpaper, but this is annoying to have to Ctrl Super D to see what time it is.

Gerhard Beck (gerhardbeck-de) wrote :

fix doesn't fix my problem. all software is actual

Those new packages resolved the problem in my case.

The new package for indicator-session is only available in saucy-updates (recommended actualisations) and the same goes for indicator-datetime. Check in software properties that you have this repository enabled and check the installed versions with this command:

apt-cache policy indicator-session indicator-datetime

hufemj (hufemj-yahoo) wrote :

The solution that worked for stachowski-mateusz did not work for my case:

mark@mark-desktop:~$ apt-cache policy indicator-session indicator-datetime
indicator-session:
  Installed: 12.10.5+13.10.20131023.1-0ubuntu1
  Candidate: 12.10.5+13.10.20131023.1-0ubuntu1
  Version table:
 *** 12.10.5+13.10.20131023.1-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ saucy-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     12.10.5+13.10.20131004-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ saucy/main amd64 Packages
indicator-datetime:
  Installed: 13.10.0+13.10.20131023.2-0ubuntu1
  Candidate: 13.10.0+13.10.20131023.2-0ubuntu1
  Version table:
 *** 13.10.0+13.10.20131023.2-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ saucy-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     13.10.0+13.10.20131016.2-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ saucy/main amd64 Packages
mark@mark-desktop:~$

Quinn Balazs (qbalazs) wrote :

Looks like this has come up in Trusty, every so often on login, the -session and -datetime indicators fail to appear. See bug #1251073 and bug #1250245. This happens with the current Trusty daily build.

Sebastien Bacher (seb128) wrote :

@Quinn: the fixes are in trusty, if you still have problems that's a different issue and you should open a new bug with a fresh description and the details you can provide, re-using an existing bug for similar but different problems makes it really difficult to follow up what is happening and tend to confuses everyone

Quinn Balazs (qbalazs) wrote :

Sorry about that, I mistakenly tested this out on a earlier build. This is indeed fixed in Trusty.

vanadium (ftack) wrote :

Like hufemj (hufemj-yahoo) (#32) I also still experience the issue occasionally on a fully updated Ubuntu 13.10 install.

~$ apt-cache policy indicator-session indicator-datetime
indicator-session:
  Installed: 12.10.5+13.10.20131023.1-0ubuntu1
  Candidate: 12.10.5+13.10.20131023.1-0ubuntu1
  Version table:
 *** 12.10.5+13.10.20131023.1-0ubuntu1 0
        500 http://be.archive.ubuntu.com/ubuntu/ saucy-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     12.10.5+13.10.20131004-0ubuntu1 0
        500 http://be.archive.ubuntu.com/ubuntu/ saucy/main amd64 Packages
indicator-datetime:
  Installed: 13.10.0+13.10.20131023.2-0ubuntu1
  Candidate: 13.10.0+13.10.20131023.2-0ubuntu1
  Version table:
 *** 13.10.0+13.10.20131023.2-0ubuntu1 0
        500 http://be.archive.ubuntu.com/ubuntu/ saucy-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     13.10.0+13.10.20131016.2-0ubuntu1 0
        500 http://be.archive.ubuntu.com/ubuntu/ saucy/main amd64 Packages

jerrylamos (jerrylamos) wrote :

Tahr is missing the "gear" on the Unity Panel top right now.

To shutdown I have to do a terminal sudo halt.

For Systems Settings I do a BFB systems settings.

I've been updating daily. Let me try again.

Picture attached.

Quinn Balazs (qbalazs) wrote :

Is this the AMD64 daily, or the i386? AMD64 from today has the gear in place (10 login cycles), I haven't checked i386 yet.

pdknsk (pdknsk) wrote :

I've had it occur numerous times since updating the packages. It's obvious this isn't really fixed.

Dac Chartrand (conner-bw) wrote :

All, this problem went away for me after I did, 1)

 dconf reset -f /org/compiz/
 setsid unity

And mostly 2)

I used to run a laptop and a monitor (dual monitor) with only 1 launcher, but since I reset Unity I have kept "Launcher placement" to "All displays" - Ie. I did not touch the defaults after reset.

I did this October 16th and haven't seen the problem since.

Hope this helps.

Tom Worley (tom-worley) wrote :

Dac,
You may be on to something.
I've been getting this problem and I too run dual monitors with only the launcher on the left hand display rather than the default on both screens.
Tom.

hufemj (hufemj-yahoo) wrote :

I tried Dac's suggestion, but it didn't work for me. I am using a dual monitor system on a desktop. When I did the setsid unity, my menu bar disappeared. I normally have it on the left side of my left monitor. After rebooting, I had the menu bar on the left of both displays, but no clock and no gear icon in the top status bar. I tried mirroring the displays, but still no top status bar (except for Dropbox and the Network Manager).

Mark

hufemj (hufemj-yahoo) wrote :

Quinn,

I am experiencing the problem 100% of the time on:

mark@mark-desktop:~$ uname -a
Linux mark-desktop 3.11.0-14-generic #21-Ubuntu SMP Tue Nov 12 17:04:55 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Mark

pdknsk (pdknsk) wrote :

Technically I also use a multi-monitor setup, laptop plus external screen, but the laptop screen is off.

Dac Chartrand (conner-bw) wrote :

Ouch, sorry to hear that Mark.

No idea why this problem stopped for me then.

Quinn Balazs (qbalazs) wrote :

Since the initial issue here has been addressed, and there seems to be two separate issues remaining, it would make this easier to deal with if we split this into two bugs. One for those who resolved the issue by changing launcher placement to "all displays", and one for those who that workaround does not work for.

After creating those, post the bug numbers back here, and we'll migrate from this issue over to those.

Thanks,
Quinn Balazs

hufemj (hufemj-yahoo) wrote :

I created a new bug, 1253693, for the unsolved branch and put a note in it referring back to this bug.

saikishor (saikishor-reddy) wrote :

Hi ,i upgraded to ubuntu 13.10 from 13.4...right side desktop icons are missing

hufemj (hufemj-yahoo) wrote :

If by "right side desktop icons" you mean the clock, shutdown gear icon, etc., in the top status bar, the workaround I use is gnome. On the login screen you can change your windows manager to gnome or gnome-flashback. It could be that when you first login you're still stuck with the ubuntu default. But if you reboot and login again, you should have gnome which will at least give you the shutdown button and the time.

It's not that gnome is great. But at least I get the clock display and I don't have to call up a terminal window to shutdown.

vanadium (ftack) wrote :

Today, I again have the issue. It occurs 1% or less of the time for me. I have launcher placement set to "all displays". However, I do not experience the bug to the extend described in the new bug, 1253693, where apparently no indicaters appear at all. It is just the date-time indicator that is missing, and it only happens very occasionally. My specs and the packages have not changed since I reported on 2013-11-20 (https://bugs.launchpad.net/ubuntu/+source/indicator-datetime/+bug/1239710/comments/36). I am not sure this bug should be considered completely "fixed".

hufemj (hufemj-yahoo) wrote :

In my situation, I do get some indicators. For example, Dropbox. But I don't get date/time, sound or the gear icon.

I discovered that unity-panel-service isn't running. If I start it from a terminal window, then I get all of the indicators in the top status bar.

I don't know why unity-panel-services fails to run when I log in.

wgroiss (wolfgang-groiss-gmx) wrote :

My situation is smiliar to hufemj:
I had almost all indicators, but missing date/time and chat-status (onlie/offline/busy/...).
Yesterday i changed settings of date/time via settings/time and date/watch (new: showing weekday + date and month + calender week in addition to time).
After the 1st restart date/time-icon is missing. After another logoff/logon tu unity => Icons are showed again.

But not a big problem for me. If i can provide some more information or testing, please let me know.

Lars Karlitski (larsu) wrote :

For anyone still experiencing this problem, let's the discussion to bug #1253693.

Changed in indicator-session (Ubuntu):
status: Fix Committed → Fix Released
Changed in indicator-datetime (Ubuntu):
status: Fix Committed → Fix Released
Changed in indicator-datetime:
status: Fix Committed → Fix Released
Changed in indicator-session:
status: Fix Committed → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1239710

tags: added: iso-testing
manny (estelar57) wrote :

well this is still happening, there's no fix yet.

https://bugs.launchpad.net/ubuntu/+source/indicator-datetime/+bug/1228360

i'm running ubuntu 13.10 since 2013 october, and its the first time it happens.
my software is up to date.
after an killall unity-panel-service it works again.

information type: Public → Public Security
information type: Public Security → Public
Prabhat Mishra (prabhat-viet) wrote :

setting button on top right corner is missing as well as hard disk partitions are not shown

Changed in indicator-datetime (Ubuntu):
assignee: nobody → Prabhat Mishra (prabhat-viet)
Edward (edwardjschmitt) wrote :

Can not find a means to logout of Ubuntu 13/10 Unity. Have attempted several time to reboot however no change

vanadium (ftack) wrote :

Today, the date time indicator does not appear. This is a fresh Ubuntu 14.04 installation. This has not been solved.

Matthew Paul Thomas (mpt) wrote :

vanadium, it's possible for more than one bug to cause the same symptom. And commenting in the report of a fixed bug generally isn't a good way to get other bugs fixed. Instead, at a terminal please enter "ubuntu-bug indicator-datetime" (without quotes) to report the bug you're seeing. Thanks.

vanadium (ftack) wrote :

Symptoms I have are those described here, which is of course why I reported here. Anyway, new report opened according to your indications (#1330678)

Tom Worley (tom-worley) wrote :

I can confirm that I've once again seen this bug with the clock missing (but other icons visible) but now in 14.04.

Quinn Balazs (qbalazs) wrote :

As has been said before, please open a new bug if you are still experiencing this problem. There are multiple issues that could potentially manifest these symptoms. Commenting on a bug that has already been marked as resolved isn't a good way to get assistance on resolving your particular problem. It just confuses matters.

This particular issue was resolved by a change to negotiate around a glib lock, any further problems likely have a different core cause.

Tom,

If you are experiencing the problem 100% of the time, then the bug you're seeing is likely 1253693. I opened that bug report several months ago. It's still unresolved. I just posted some work-arounds to that thread.

Mark

On Monday, June 23, 2014 4:35 AM, Tom Worley <email address hidden> wrote:

I can confirm that I've once again seen this bug with the clock missing
(but other icons visible) but now in 14.04.

--
You received this bug notification because you are subscribed to a
duplicate bug report (1250872).
https://bugs.launchpad.net/bugs/1239710

Title:
  indicator-datetime or -session missing ~10% of the time

Status in The Date and Time Indicator:
  Fix Released
Status in The Session Menu:
  Fix Released
Status in “indicator-datetime” package in Ubuntu:
  Fix Released
Status in “indicator-session” package in Ubuntu:
  Fix Released
Status in “indicator-datetime” source package in Saucy:
  Fix Released
Status in “indicator-session” source package in Saucy:
  Fix Released

Bug description:
  Impact: sometime indicator-session or datetime go missing in unity

  Test Case: start sessions until that happens (or not)

  Regression potential: the change is a one liner workaround for a glib
  lock, shouldn't create issue, just check that those indicators keep
  working as they should

  -------------------

  Indicator-datetime is not showing in the indicator bar today on image
  96.

  ProblemType: Bug
  DistroRelease: Ubuntu 13.10
  Package: indicator-datetime 13.10.0+13.10.20131011-0ubuntu1
  Uname: Linux 3.4.0-3-mako armv7l
  ApportVersion: 2.12.5-0ubuntu2
  Architecture: armhf
  Date: Mon Oct 14 16:00:26 2013
  InstallationDate: Installed on 2013-10-14 (0 days ago)
  InstallationMedia: Ubuntu 13.10 - armhf (20131014)
  MarkForUpload: True
  ProcEnviron:
   TERM=linux
   PATH=(custom, no user)
  SourcePackage: indicator-datetime
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/indicator-datetime/+bug/1239710/+subscriptions

Phil Buckler (buck2825) wrote :

I just had this happen on my Desktop running a nearly fresh (< 5 days) install of 14.10 64bit. It has been on for 1 day and 6 hours when this happened. Logged out, Logged in, time is back.

Sam Bull (dreamsorcerer) wrote :

This bug was on the phone and was fixed long ago. If you are experiencing similar issues, please report a new bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.