No clock in menu bar and can't edit Clock settings

Bug #1228360 reported by Barry Warsaw on 2013-09-20
722
This bug affects 164 people
Affects Status Importance Assigned to Milestone
indicator-datetime (Ubuntu)
High
Unassigned

Bug Description

The latest update broke the clock in several ways:

* No clock shows up in the menu bar.

* Open Time & Date settings. You cannot edit anything in the Clock tab.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: gnome-control-center 1:3.6.3-0ubuntu38
ProcVersionSignature: Ubuntu 3.11.0-7.14-generic 3.11.1
Uname: Linux 3.11.0-7-generic x86_64
ApportVersion: 2.12.4-0ubuntu1
Architecture: amd64
Date: Fri Sep 20 15:51:55 2013
EcryptfsInUse: Yes
InstallationDate: Installed on 2011-07-12 (800 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110705.1)
MarkForUpload: True
SourcePackage: gnome-control-center
SystemImageInfo: Error: [Errno 2] No such file or directory: 'system-image-cli'
UpgradeStatus: Upgraded to saucy on 2011-12-23 (637 days ago)
usr_lib_gnome-control-center:
 deja-dup 27.3.1-0ubuntu1
 gnome-control-center-datetime 13.10.0+13.10.20130913-0ubuntu1
 gnome-control-center-signon 0.1.7~+13.10.20130724.1-0ubuntu1
 gnome-control-center-unity 1.3daily13.06.14.1-0ubuntu1

Barry Warsaw (barry) wrote :
Jeremy Bicha (jbicha) wrote :

Not a gnome-control-center bug.

See also the Ubuntu Touch bug 1227519.

affects: gnome-control-center (Ubuntu) → indicator-datetime (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
Raphaël Badin (rvb) wrote :

I experienced the same thing. "killall unity-panel-service" fixed the problem.

Luis (luis+ph3l1v) wrote :

I have the same issue. In addition to the clock, the power icon and the main icon were missing as well. "killall unity-panel-service" fixed it.

Kervin (kervin-c) wrote :

Killall does not work for me. Multiple reboots and still no clock.

Joe Carey (joecarey) wrote :

Does killall temporarily or permanently fix the problem? My clock disappears but usually a reboot brings it back.

it is temporary u have to run the command again for enabling it

On Wed, Oct 30, 2013 at 5:02 PM, Joe Carey <email address hidden> wrote:
> Does killall temporarily or permanently fix the problem? My clock
> disappears but usually a reboot brings it back.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1228360
>
> Title:
> No clock in menu bar and can't edit Clock settings
>
> Status in “indicator-datetime” package in Ubuntu:
> Confirmed
>
> Bug description:
> The latest update broke the clock in several ways:
>
> * No clock shows up in the menu bar.
>
> * Open Time & Date settings. You cannot edit anything in the Clock
> tab.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 13.10
> Package: gnome-control-center 1:3.6.3-0ubuntu38
> ProcVersionSignature: Ubuntu 3.11.0-7.14-generic 3.11.1
> Uname: Linux 3.11.0-7-generic x86_64
> ApportVersion: 2.12.4-0ubuntu1
> Architecture: amd64
> Date: Fri Sep 20 15:51:55 2013
> EcryptfsInUse: Yes
> InstallationDate: Installed on 2011-07-12 (800 days ago)
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110705.1)
> MarkForUpload: True
> SourcePackage: gnome-control-center
> SystemImageInfo: Error: [Errno 2] No such file or directory: 'system-image-cli'
> UpgradeStatus: Upgraded to saucy on 2011-12-23 (637 days ago)
> usr_lib_gnome-control-center:
> deja-dup 27.3.1-0ubuntu1
> gnome-control-center-datetime 13.10.0+13.10.20130913-0ubuntu1
> gnome-control-center-signon 0.1.7~+13.10.20130724.1-0ubuntu1
> gnome-control-center-unity 1.3daily13.06.14.1-0ubuntu1
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/indicator-datetime/+bug/1228360/+subscriptions

Charles Kerr (charlesk) wrote :

This sounds like it's possibly a config error that happened during the upgrade, particularly the lack of configurable settings.

Could you try aptitude reinstall both indicator-datetime AND gnome-control-center-datetime and see if the problem persists?

Changed in indicator-datetime (Ubuntu):
status: Confirmed → Incomplete
Adam Niedling (krychek) wrote :

Charles: I'm having the same issue in a freshly installed 13.10. Currently the gearbox is missing, the clock is there.

Tyler Ball (tyleraball) wrote :

I updated from 13.04 to 13.10 and started experiencing this bug. I use apt-get with --reinstall on both indicator-datetime and gnome-control-center-datetime and my clock has returned.

Tyler Ball (tyleraball) wrote :

Just kidding! After a few restarts, my clock has once again disappeared even after I reinstalled indicator-datetime and gnome-control-center-datetime. Running "killall unity-panel-service" as sudo did restore it.

Adam Niedling (krychek) on 2013-11-01
Changed in indicator-datetime (Ubuntu):
status: Incomplete → Confirmed
Alistair Buxton (a-j-buxton) wrote :

We've seen similar things with the xfce4-panel gtk3 indicator support: at the first load up some indicators are missing, usually indicator-datetime. Restarting the panel makes them show up.

Doug McMahon (mc3man) wrote :

try the -proposed indicator-datetime package & see if issue goes away, if so then this bug is a dupe of
https://bugs.launchpad.net/ubuntu/+source/indicator-datetime/+bug/1239710

I'm not able to install the -proposed package, but the error may well be on my noobish end:

thomas@thomas-acer:~$ sudo apt-get install indicator-datetime/saucy-proposed
[sudo] password for thomas:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Release 'saucy-proposed' for 'indicator-datetime' was not found

Alistair Buxton (a-j-buxton) wrote :

The package in -proposed appears to fix this for me (using unreleased xfce/gtk3 development branches).

Kervin (kervin-c) wrote :

I think my indicator-datetime-service is linked against libical.so.0 but my system only has libical.so.1. Can someone help me find an updated indicator-datetime-service or the libical.so.0 deb?

ldd /usr/lib/x86_64-linux-gnu/indicator-datetime-service
libical.so.0 => not found

Kervin (kervin-c) wrote :

Found the issue. I built a few libraries from source earlier in /usr/local/lib . indicator-datetime-service found those libraries before the system libraries in /usr/lib for some reason. It shouldn't have done that.

One of those libraries pulled in the old libical.so.0 dependency which was no longer available. When I deleted all the GNOME/Evolution related libraries in /usr/local/lib I could start indicator-datetime-service again and my clock shown up.

Why would indicator-datetime-service load libraries from /usr/local/lib before /usr/local if they have the same library versions? Isn't that a bug?

Charles Kerr (charlesk) wrote :

This bug report is being closed due to your last comment regarding this being fixed after changing a configuration value back to its default. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in indicator-datetime (Ubuntu):
status: Confirmed → Invalid
Adam Niedling (krychek) wrote :

This is ridiculous. I have a brand new Saucy installation, I haven't been messing around with anything like Kervin (who's not even the original reporter) did and I don't have a clock right now! This issue affects way too many people to close it as "invalid" based on one single comment.

Changed in indicator-datetime (Ubuntu):
status: Invalid → Confirmed
Sebastien Bacher (seb128) wrote :

@Adam: is your issue that the indicators are sometime missing? That could be bug #1239710

Adam Niedling (krychek) wrote :

I'm attaching a screenshot to be clear about it. Which bug is this?

Freeman (brechtgijbels-gmail) wrote :

Same problem here, clean installation of Ubuntu 13.10 Saucy and after the upgrades the clock disappears but the rest of the icons are still there. As stated in a previous post, running 'killall unity-panel-service' will bring the time indication back to the panel. Let's hope it stays after reboot...

Jan Klesnil (klesnil) wrote :

Same problem after upgrade to 13.10. The 'killall unity-panel-service' helps.

Changed in indicator-datetime (Ubuntu):
status: Confirmed → Triaged
Changed in indicator-datetime:
status: New → Confirmed
Changed in indicator-datetime (Ubuntu):
importance: Undecided → High
Changed in hundredpapercuts:
importance: Undecided → High
status: New → Triaged

Affects me as well. Brand new 13.10 install on a new partition. Got all the other icons, no clock, can't edit clock settings. System has only been up about a week, have installed various things, not sure if I ever had a clock. Time keeps on slipping, slipping, slipping... into the future.

Upon shutdown and restart, I have the clock back. Tried running apps I had previously been using, to see if I could reproduce the problem. Those were: Firefox, a terminal, Phoronix opendwarfs benchmark, Synaptic Package Manager, and System Settings. So my problem is transitory. If it occurs again I'll report what I can about it.

Clock is gone again. Only app I've been using is Firefox.

I am experiencing this bug in a fully-updated Ubuntu 13.10. Here are some things I have noticed:

1) I have only noticed the clock/calendar missing on one user account (the account I use most on this laptop). As far as I have noticed it still appears on the login screen and in other accounts.

2) When the clock/calendar is missing, the controls for it are also greyed out in System Settings --> Time & Date --> Clock
I have the Unity Tweak Tool installed, and the clock controls are always visible in that tool, however they have no effect when the clock is missing. (In other words, changing the settings does not make it appear.)

3) killall unity-panel-service restores the clock/calendar for the account.

4) NOTE This laptop has been upgraded through four or more versions of Ubuntu by doing clean installs (while retaining the contents of the user home folders). SO is it possible this bug appears due to cruft in a settings file or database somewhere? This would explain my observation #1 -- the lesser-used accounts may not have so much cruft in the application settings.

$ apt-cache policy indicator-datetime
indicator-datetime:
  Installed: 13.10.0+13.10.20131023.2-0ubuntu1
  Candidate: 13.10.0+13.10.20131023.2-0ubuntu1
  Version table:
 *** 13.10.0+13.10.20131023.2-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ saucy-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     13.10.0+13.10.20131016.2-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ saucy/main amd64 Packages

BillIsaacs (billisaacs) wrote :

Don't know if this helps, but I made a small script I named 'fixtime' that restores the clock when it goes away:
=================
#!/bin/sh

apt-get install indicator-datetime
killall unity-panel-service
=================

Just running killall unity-panel-service does not bring back the clock. I have to first install the indicator-datetime (which comes back reporting that it is already the newest version, so nothing actually happens there):

root@IW-UB-01:/# fixtime
Reading package lists... Done
Building dependency tree
Reading state information... Done
indicator-datetime is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@IW-UB-01:/#

This brings back my clock. So something with touching the indicator-datetime installation file(s) seems to make a difference.

I hope this helps you guys track the bug down.

Ivan Jekic (the-edge) wrote :

This bug affects me too. I lose date/time from time to time. :P Using Lenovo g505, Ubuntu 13.10 out of the box. All fixes I tried were temporary.

quequotion (quequotion) wrote :

What happened to "/usr/lib/indicators3/7/libdatetime.so" et al?

These libraries are missing from several of saucy's indicator-* packages.

Take a look:
http://packages.ubuntu.com/raring/amd64/indicator-datetime/filelist
http://packages.ubuntu.com/saucy/amd64/indicator-datetime/filelist
http://packages.ubuntu.com/raring/amd64/indicator-sound/filelist
http://packages.ubuntu.com/saucy/amd64/indicator-sound/filelist

Perhaps they are not needed for unity, but these were used to load indicators for other panels.

Without these libraries the indicators can't be used outside of unity.

I hate unity, but I like indicators. Can I have them back please?

Changed in indicator-datetime:
status: Confirmed → Fix Released
Changed in hundredpapercuts:
status: Triaged → Fix Released
Changed in indicator-datetime (Ubuntu):
status: Triaged → Fix Released
papukaija (papukaija) wrote :

@George Vrinchev: Please do not change bugs' statuses without a comment. Please use "this bug affects me too" link above this bug's description. Thanks.

@moderators: Please set this bug back to confirmed/triaged, as this bug is not fixed. I can confirm it myself and George's karma of 0 suggests that he didn't mean that this bug is fixed but rather that this bug is affecting him. Thanks.

quequotion (quequotion) wrote :

>>Alberto Salvia Novella

Do not change bug status without verification.

This bug has not been fixed anywhere.

Changed in indicator-datetime:
status: Fix Released → Confirmed
Changed in hundredpapercuts:
status: Fix Released → Confirmed
Changed in indicator-datetime (Ubuntu):
status: Fix Released → Confirmed

Since the bug is not longer reproducible in Saucy (it was sometime ago), and this is the only affected release listed here, the bug has been fixed elsewhere.

Changed in indicator-datetime (Ubuntu):
status: Confirmed → Fix Released
Changed in hundredpapercuts:
status: Confirmed → Fix Released
Changed in indicator-datetime:
status: Confirmed → Fix Released
yellow (yellowshark) wrote :

killall unity-panel-service helped me

Seumas Mackinnon (seumas) wrote :

It's not fixed, I'm afraid. My up-to-date Saucy 64bit, running on an XPS 13, had exactly the same issue. killall worked for me too.

Maybe we should reopen thi bug, today I had this problem again, after a hard reboot (REISUB). Killing unity panel service worked fine to restore the clock.

using Ubuntu 13.10 with latest updates.

Adolfo Jayme (fitojb) wrote :

Unless we know with certainty what change in what component fixed a bug, we should not mark it "Fix Released" as this confuses everyone.

Changed in indicator-datetime (Ubuntu):
status: Fix Released → Triaged
no longer affects: hundredpapercuts
affects: indicator-datetime → hundredpapercuts
no longer affects: hundredpapercuts

Latest sighting yesterday on an up-to-date Saucy. The killall workaround helps.

nescient (nextbutone) wrote :

This bug is still affecting me - Ubuntu 13.10. Can anyone explain to me what is being done to correct the fault as reading this confusing bug report with all the status changes just makes my head want to explode. Thank you for reading this.

manny (estelar57) wrote :

supposedly there was a fix released some weeks ago, but that didn't help. same issue:

https://bugs.launchpad.net/ubuntu/+source/indicator-datetime/+bug/1239710

Eric Ongerth (ericongerth) wrote :

I had this bug back when Saucy was new, and the fix for it back then worked.

It returned today for the first time on Saucy (fully updated). "killall unity-panel-service" worked as an immediate fix, but I hope the bug does not return. This was on a fresh boot. Apparently something regressed?

WoodyEckelzone (bcr497) wrote :

FYI:
killall unity-panel-service did not bring the time back
I tried several times. I had a system-settings window open, time and date selected

After I closed the system-settings window ,
killall unity-panel-service
worked.

More than once, this issue has coincided with Dropbox (which has an icon in the panel) not autostarting properly. Has anyone else noticed the same?

Juan Simón (simonbcn) wrote :

Still it fails :(

Tyler Ball (tyleraball) wrote :

Yeah, I just saw the issue again for the first time in a few months. "killall unity-panel-service" restored the clock.

boon (boon-9ft1s) wrote :

Was working fine yesterday running Ubuntu 13.10. Then a bunch of updates came through, including a kernel update from 3.11.0-18 to 3.11.0-19 which resulted in a reboot. After the reboot the time had disappeared from the menu bar.

I hadn't realised how reliant I am on the time's being visible!

This should be a HIGH priority to fix.

If someone can tell me the necessary commands, I should be able to look up exactly what upgrades occurred yesterday and what other upgrades had been applied since the _previous_ reboot.

"killall unity-panel-service" restored the clock. However I am yet to see whether this is a permanent workaround or is only good for one login or is only good for one boot. I suspect that it is not a permanent workaround.

Jorge Q (jquiroga2005) wrote :

I'm also an affected user. Today after the first startup of the machine the indicator dissapear. I applied the solution of Billisaacs after just killing the the unity panel this appears in my terminal.

**@MyComputer:~$ apt-get install indicator-datetime
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
**@MyComputer:~$ killall unity-panel-service
**@MyComputer:~$

And after that, the datetime indicator appears. I have to note that I "killed" the unity panel service before, but the datetime indicator didn't appear, and my "Date time settings" continued grayed. After run the Billisaacs solution everything was fine. So, maybe for some reason, the lock file is not cleared properly after upgrade which (I think) explains why it affects only the user who uses more the machine, which usually is the same user who do the updates.

My two cents and sorry for my English. I'm not a native speaker.

TimoW (es-uomikim) wrote :

Same with me in 13.10, it happend two times in a row. After restarting it works again but it seems unstable. Clock disappears and time menu 'grays out'. It started with no apparent reason.

aprunai (aprunai) wrote :

The instructions found here solved the problem for me (Ubuntu 14.04 with latest updates):

http://www.dbdummy.com/322/how-to-fix-the-missing-datetime-in-menu-bar-after-upgrade-to-ubuntu-13-10-saucy.html

Alexander (aheihachi) wrote :

#50 fixed for me, thanks

#4 fixed for me, thanks!

"killall unity-panel-service" worked for me

brijesh (patelbrijesh333) wrote :

yes it can be fixed by installing gnome session
just go to terminal and type sudo apt-get install gnome-session-flashback

abdullah (abdullahcsjmi) wrote :

killall unity-panel-service worked for me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers