ia32-libs missing libQtDBus, others?

Bug #271550 reported by Nish Aravamudan on 2008-09-18
56
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ia32-libs (Debian)
Fix Released
Unknown
ia32-libs (Ubuntu)
Critical
Stephan Ruegamer
Nominated for Intrepid by Wouter Stomp

Bug Description

Binary package hint: ia32-libs

Release: Intrepid Ibex
Package Vesion: 2.2ubuntu12
Expected: According to packages.ubuntu.com (and apt-file), the ia32-libs package should be providing the following files/libraries:

/usr/lib32/libQtDBus.so.4 ia32-libs [not i386]
/usr/lib32/libQtDBus.so.4.3 ia32-libs [not i386]
/usr/lib32/libQtDBus.so.4.3.4 ia32-libs [not i386]

Occuring: However, dpkg indicates (as does examining /usr/lib32) that the files are not installed by ia32-libs:

root@arkanoid:/usr/lib32# dpkg -L ia32-libs | grep -i qt
root@arkanoid:/usr/lib32#

These libraries are needed to, among other things, allow the dynamically-linked Skype 2.0.0.72 to run. This worked fine in Hardy.

Related branches

Sounds very similar to this bug in debian:

libqt4-dbus: Skype cannot find libQtDBus.so.4 after upgrade
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=481224

I encounter the same problem.

I installed kubuntu intrepid ibex and then skype. When I start skype I get this error messag:

hyper@xubi:~$ skype
skype: error while loading shared libraries: libQtGui.so.4: cannot open shared object file: No such file or directory
hyper@xubi:~$

And here's the output when using ldd:

yper@xubi:~$ ldd /usr/bin/skype
        linux-gate.so.1 => (0xf7f56000)
        libasound.so.2 => /usr/lib32/libasound.so.2 (0xf7e75000)
        libXv.so.1 => /usr/lib32/libXv.so.1 (0xf7e6f000)
        libXss.so.1 => /usr/lib32/libXss.so.1 (0xf7e6a000)
        librt.so.1 => /lib32/librt.so.1 (0xf7e61000)
        libQtDBus.so.4 => /usr/lib32/libQtDBus.so.4 (0xf7df3000)
        libQtGui.so.4 => not found
        libQtNetwork.so.4 => not found
        libQtCore.so.4 => not found
        libpthread.so.0 => /lib32/libpthread.so.0 (0xf7dd9000)
        libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf7ceb000)
        libm.so.6 => /lib32/libm.so.6 (0xf7cc5000)
        libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf7cb7000)
        libc.so.6 => /lib32/libc.so.6 (0xf7b58000)
        libX11.so.6 => /usr/lib32/libX11.so.6 (0xf7a69000)
        libXext.so.6 => /usr/lib32/libXext.so.6 (0xf7a5a000)
        libdl.so.2 => /lib32/libdl.so.2 (0xf7a56000)
        /lib/ld-linux.so.2 (0xf7f57000)
        libQtXml.so.4 => not found
        libQtCore.so.4 => not found
        libxcb-xlib.so.0 => /usr/lib32/libxcb-xlib.so.0 (0xf7a52000)
        libxcb.so.1 => /usr/lib32/libxcb.so.1 (0xf7a39000)
        libXau.so.6 => /usr/lib32/libXau.so.6 (0xf7a36000)
        libXdmcp.so.6 => /usr/lib32/libXdmcp.so.6 (0xf7a31000)
hyper@xubi:~$

same problem here: (intrepid alpha-6)

my output:

$ skype
skype: error while loading shared libraries: libQtDBus.so.4: cannot open shared object file: No such file or directory

and:

$ ldd /usr/bin/skype
 linux-gate.so.1 => (0xf7f58000)
 libasound.so.2 => /usr/lib32/libasound.so.2 (0xf7e78000)
 libXv.so.1 => /usr/lib32/libXv.so.1 (0xf7e72000)
 libXss.so.1 => /usr/lib32/libXss.so.1 (0xf7e6d000)
 librt.so.1 => /lib32/librt.so.1 (0xf7e64000)
 libQtDBus.so.4 => not found
 libQtGui.so.4 => not found
 libQtNetwork.so.4 => not found
 libQtCore.so.4 => not found
 libpthread.so.0 => /lib32/libpthread.so.0 (0xf7e4a000)
 libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf7d5c000)
 libm.so.6 => /lib32/libm.so.6 (0xf7d36000)
 libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf7d28000)
 libc.so.6 => /lib32/libc.so.6 (0xf7bc9000)
 libX11.so.6 => /usr/lib32/libX11.so.6 (0xf7ada000)
 libXext.so.6 => /usr/lib32/libXext.so.6 (0xf7acb000)
 libdl.so.2 => /lib32/libdl.so.2 (0xf7ac7000)
 /lib/ld-linux.so.2 (0xf7f59000)
 libxcb-xlib.so.0 => /usr/lib32/libxcb-xlib.so.0 (0xf7ac4000)
 libxcb.so.1 => /usr/lib32/libxcb.so.1 (0xf7aaa000)
 libXau.so.6 => /usr/lib32/libXau.so.6 (0xf7aa7000)
 libXdmcp.so.6 => /usr/lib32/libXdmcp.so.6 (0xf7aa2000)

this one seems to be fixed in debian lenny... why is it not yet in ubuntu intrepid?

many people have this problem.

Changed in ia32-libs:
status: New → Confirmed

I wrote this little script below to fetch the missing 32-bit libs and unpack them to the right place (run it as sudo):

#!/bin/bash

mkdir /tmp/skype
mkdir /tmp/skype/tmp
cd /tmp/skype

wget http://mirror.switch.ch/ftp/mirror/ubuntu/pool/main/q/qt4-x11/libqtgui4_4.4.1-0ubuntu2_i386.deb
wget http://mirror.switch.ch/ftp/mirror/ubuntu/pool/main/q/qt4-x11/libqt4-network_4.4.1-0ubuntu2_i386.deb
wget http://mirror.switch.ch/ftp/mirror/ubuntu/pool/main/q/qt4-x11/libqtcore4_4.4.1-0ubuntu2_i386.deb
wget http://mirror.switch.ch/ftp/mirror/ubuntu/pool/main/q/qt4-x11/libqt4-xml_4.4.1-0ubuntu2_i386.deb

dpkg -x libqtgui4_4.4.1-0ubuntu2_i386.deb /tmp/skype/tmp
dpkg -x libqt4-network_4.4.1-0ubuntu2_i386.deb /tmp/skype/tmp
dpkg -x libqtcore4_4.4.1-0ubuntu2_i386.deb /tmp/skype/tmp
dpkg -x libqt4-xml_4.4.1-0ubuntu2_i386.deb /tmp/skype/tmp

cp -a /tmp/skype/tmp/usr/lib/* /usr/lib32/

*just subscription to this bug*

Changed in ia32-libs:
status: Unknown → Fix Released
Till Kamppeter (till-kamppeter) wrote :

I have the same problem and this is my vote to get it fixed in Intrepid. Skype relly should work on amd64.

Changed in ia32-libs:
importance: Undecided → Critical
milestone: none → ubuntu-8.10-beta
Till Kamppeter (till-kamppeter) wrote :

To make Skype working I had to add the following to the commands above:

cd /tmp/skype
wget http://mirror.switch.ch/ftp/mirror/ubuntu/pool/main/q/qt4-x11/libqt4-dbus_4.4.1-0ubuntu2_i386.deb
dpkg -x libqt4-dbus_4.4.1-0ubuntu2_i386.deb /tmp/skype/tmp
sudo cp -a /tmp/skype/tmp/usr/lib/* /usr/lib32/

Hmmm, libqt4-dbus was added for me... I guess some other package must have done it. Thx Till :)

For those that still have problems, run:

ldd /usr/bin/skype

And check out what files are missing.

Then use "apt-file" to find the according package:

sudo apt-get install apt-file
sudo apt-file update
apt-file search FILENAME

Then go to http://packages.ubuntu.com/
Set the searching for Ibex
Enter the package name
Download the i386 version and extract and copy the content to /usr/lib32/

Stephan Ruegamer (sadig) wrote :

well, libqt4-dbus and libqt4-network were never in hardy ia32-libs...
added them now...
and libqt4 in general is back

Changed in ia32-libs:
assignee: nobody → shermann
status: Confirmed → In Progress
Nish Aravamudan (nacc) wrote :

> well, libqt4-dbus and libqt4-network were never in hardy ia32-libs...
> added them now...
> and libqt4 in general is back

Huh? Are you referring to package names and libqt4 in the Hardy version also including the dbus libs? Even if that is the case, it should be quite clear that this is a regression from a working setup.

Skype (the binary with which I noticed this problem) worked just fine in Hardy and had the same dependency on a 32-bit libQtDBus. And according to: http://packages.ubuntu.com/search?searchon=contents&keywords=libQtDBus&mode=filename&suite=hardy&arch=any, libQtDBus was indeed provided by ia32-libs on Hardy AMD64.

Stephan Ruegamer (sadig) wrote :

@Nish:

Yes, the lib was there, but this changed totally in intrepid.
Intrepid now has several other libqt4-* packages, e.g. libqt4-dbus where the dbus interface to qt was laid off.
this was never in hardies version...
but now it's back in intrepid.
+ libqt4-network for working properly

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ia32-libs - 2.2ubuntu14

---------------
ia32-libs (2.2ubuntu14) intrepid; urgency=low

  * Re-bringing back libqt4
  * fetch-and-build:
    - added libqt4-dbus (LP: #271550)
    - added libqt4-network
    - added libqt4-qt3support (LP: #222934)

 -- Stephan Hermann <email address hidden> Fri, 26 Sep 2008 18:51:16 +0000

Changed in ia32-libs:
status: In Progress → Fix Released
David Vonka (vonkad) wrote :

This did not work out too good for me. the newly installed libqt-dbus and libqt-network are not compatible (4.4.2) with my hand installed liqt4-core (4.4.1) and libqt-gui (4.4.1). I had to reinstall them manually again (ie download from i386 repositories, extract and copy to /usr/lib32/) But as no-one seems to have a similar problem, I must be doing something wrong ...

Nish Aravamudan (nacc) wrote :

I am out of the country and won't be able to test the fix until October 10th or 11th. Will update the bug when I am able to do so.

Brian Murray (brian-murray) wrote :

After installing ia32-libs version 2.2ubuntu14, I still was not able to use skype which is what this bug is about. I believe that libqtgui4, libqtcore4 and libqt4-xml are still missing. Further information supporting this can be found in comments 2 and 3 - which contain ldd output for skype and additionally comment 6 where the person gets and extracts those packages.

Changed in ia32-libs:
status: Fix Released → Triaged
Pete Graner (pgraner) wrote :

I can also confirm that this is still broke after installing the new package per comment #14 above. Same errors.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ia32-libs - 2.2ubuntu15

---------------
ia32-libs (2.2ubuntu15) intrepid; urgency=low

  * fetch-and-build.sh: (LP: #271550)
    - replaced libqt4-gui with libqtgui4
    - replaced libqt4-core with libqtcore4

 -- Stephan Hermann <email address hidden> Wed, 01 Oct 2008 16:16:26 +0000

Changed in ia32-libs:
status: Triaged → Fix Released
Mingming Ren (portis25) wrote :

I upgraded to 2.2ubuntu15, but it seems that libQtXml.so.4 is still missing.

$skype
skype: error while loading shared libraries: libQtXml.so.4: cannot open shared object file: No such file or directory

$ldd /usr/bin/skype
libQtXml.so.4 => not found

Bremm (bremm) wrote :

Fixed with 2.2ubuntu16, thanks.

Dima Ilchenko (idtest) wrote :

Still doesn't work for me, skype allows to enter credentials but dies right at showing contact list with the error:
ALSA lib ../../src/conf.c:2700:(snd_config_hooks_call) Cannot open shared library /usr/lib/alsa-lib/libasound_module_conf_pulse.so
ALSA lib ../../../src/control/control.c:909:(snd_ctl_open_noupdate) Invalid CTL hw:0
Aborted (core dumped)

Dima: Also filed as bug 277180 but perhaps it has something todo with this.

Brian Murray (brian-murray) wrote :

Skype is failing for a different reason now (show in comment 22), however it is not related to this bug report as this is about skype even failing to launch due to missing libraries.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.