Ubuntu

[meta] cannot add facebook account, facebook does not update and more

Reported by Omer Akram on 2010-08-07
This bug affects 344 people
Affects Status Importance Assigned to Milestone
Gwibber
High
Unassigned
gwibber (Ubuntu)
High
Unassigned
Lucid
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Binary package hint: gwibber

This is a bug that covers many facebook related problems in gwibber. when a user add a facebook account after authorization gwibber dont show any add button so the account cannot be added. some people succeed in adding the account but then facebook does not update and gwibber-service logs show something like 'applicaton limit reached'. the logs seem to suggest that the problem is from the facebook side.. this bug is for tracking purpose so we have a single bug report as the root cause is the same.

I think bug #595265 covers some of these problems, but not all.

Omer Akram (om26er) on 2010-08-10
Changed in gwibber (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
James Walters (shinhadoken) wrote :

I am having this problem. I cannot connect to Facebook. This is a MASSIVE problem, since Gwibber is included by default in 10.04. Please, someone, get to work on this. I would myself but I don't possess the skills.

luca (l-savio) wrote :

Me too, same problem on 3 Pcs with fresh install Lucid, backports and proposed repositories added. note that twitter, identi.ca and status.net work fine.

Sergey (sergeyyy2004) wrote :

 While trying to authorize in Facebook Gwibber says that there's a mistake in Gwibber and connection fails.

momoxxen (aiman0906) wrote :

if it come as default apps...some1 really need to fix it fast.
go ubuntu!
(p/s: using my gwibber for twitter only, surf facebook like usual)

Debasish (ddas4) wrote :

I am having this same problem with a fresh Lucid install. However i had Karmic loaded on one installation which i upgraded to Lucid and i don't have problems with facebook there.

Somehow i think that the 'Importance' of the issue needs to be elevated.

Changed in gwibber (Ubuntu):
status: Triaged → Fix Released
Omer Akram (om26er) wrote :

setting back to triage. it seems it was mistakenly marked fixed.

Changed in gwibber (Ubuntu):
status: Fix Released → Triaged
Andrew Min (andrewmin) wrote :

I'm getting the "An error occurred with Gwibber. Please try again later" error.

Marcos Lans (markooss) wrote :

This run for me, try it.

'Not sure if I had the same problem, but try to open this page: http://www.facebook.com/username , go back to gwibber and use your username instead of your email when you login to your account. After that the Add button appeared for me.'

hamst3rl3 (peter-michelis) wrote :

I just tried this and it also worked for my facebook account. ... quite strange

Novid (novid) wrote :

with this tip, work for me too :)

Judy King (jk-crazybasenji) wrote :

I had the same issue with Gwibber not authorizing Facebook. I kept getting the FB sign in box, so quit trying to use it for a while. I tried again a few days ago and suddenly was able to log into FB. But after only one post and quitting Gwibber, I can't get it to open at all. I removed, reinstalled, re-started, got nothing.

Judy King (jk-crazybasenji) wrote :

Gwibber just made me a liar, and started like it had never been comatose. plplplplplthhhhhbt. False alarm. Sorry.

David Kaplan (dmkaplan) wrote :

I tried the proposed solution in comment #9 and it doesn't work for me. I get the same authentication failure error.

erny (erevilla) wrote :

I also tried #9, but no luck. The add button does not appear.

The same problem with Empathy 2.30.2. =/

DarkRedman (darkredman) wrote :

I've the same problem on Marverick Bêta Release

When trying to save the facebook account after a successful registration, the click on "Save" give this :
Saving...
Couldn't find field: username

And the facebook account is not added.
I use it on Mandriva Linux 2010.1.

Dr. Kenobi (drkenobi) wrote :

Guys, i'm having the same problem. But i Solved it. I deleted in Facebook the application 'Gwibber'. Then I tried to add my Facebook account to Gwibber and the 'Add' button appears! Cheers.

This was fixed for me in the latest update.
--
Greg Bair
<email address hidden>

Ilkka Laukkanen (ilkka) wrote :

Same here, or at least worked in a fresh & updated 10.04 netbook install.

DJ Dallas (djdallas) wrote :

Same problem here. Tried repeatedly to add Facebook account but failed because there was no "Add" button after completing authorisation. (Didn't realise there was supposed to be one until I read this!). Facebook accepted Gwibber as an authorised application, so no problem that side. Was finally successful after using Facebook username to authorise rather than my sign in email address. Thanks Marcos (post #9)

igi (igor-cali) wrote :

In Maverick beta none of proposed workarounds is working.

tags: added: maverick
PCHelper (adispivak) wrote :

gwibber-2.31.92 -

Saving...
Couldn't find field: username

only on facebook. none of the suggestions helped ( not deleting from facebook and not using the username).
twitter - buzz - flicker - all works.

PCHelper (adispivak) wrote :

correction - buzz and flicker added seccessfully, but showing empty.

PCHelper (adispivak) wrote :

log for buzz shows:
{"error":{"errors":[{"domain":"global","reason":"invalid","message":"User must have authorized this application to have the following scope in order to make this call: [https://www.googleapis.com/auth/buzz.readonly] Also , make sure your application is using the Buzz specific OAuth authorization URL.","locationType":"header","location":"Authorization"}],"code":401,"message":"User must have authorized this application to have the following scope in order to make this call: [https://www.googleapis.com/auth/buzz.readonly] Also , make sure your application is using the Buzz specific OAuth authorization URL."}}

checking buzz - deleted gwibber - and readded it and it appears in the allowed apps.

igi (igor-cali) wrote :

after latest maverick beta updates, I was finally able to add a facebook account. I propose to mark this as "fix released".

Maxim Doucet (maximdoucet) wrote :

I don't think the bug should be closed because it is still present in Lucid!

The solution for me on Lucid (Ubuntu 10.04.1) with Empathy 2.30.2 was to folow Dr. Kenobi's comment #19!

So:
 * go to facebook -> account -> privacy settings -> applications and websites settings -> "Remove unwanted or spammy applications" -> remove Gwibber
 * launch gwibber, manage accounts, add facebook, enter your login (email address works here)/password to authorize Gwibber as if it was the first time
 * the "Add" button does *not* appear yet
 * close the Gwibber's account window, open it again and redo the facebook connexion process
 * the "Add" button appears and it works finally well

Does anyone else have success with this?

0N3_xyz (tophitter225) wrote :

So:
 * go to facebook -> account -> privacy settings -> applications and websites settings -> "Remove unwanted or spammy applications" -> remove Gwibber
 * launch gwibber, manage accounts, add facebook, enter your login (email address works here)/password to authorize Gwibber as if it was the first time
 * the "Add" button does *not* appear yet
 * close the Gwibber's account window, open it again and redo the facebook connexion process
 * the "Add" button appears and it works finally well

Yes this finally worked for me in Ubuntu 10.10

Omer Akram (om26er) wrote :

yes worked for me too

On Fri, Sep 17, 2010 at 12:57 PM, 0N3_xyz <email address hidden> wrote:

> So:
> * go to facebook -> account -> privacy settings -> applications and
> websites settings -> "Remove unwanted or spammy applications" -> remove
> Gwibber
> * launch gwibber, manage accounts, add facebook, enter your login (email
> address works here)/password to authorize Gwibber as if it was the first
> time
> * the "Add" button does *not* appear yet
> * close the Gwibber's account window, open it again and redo the facebook
> connexion process
> * the "Add" button appears and it works finally well
>
> Yes this finally worked for me in Ubuntu 10.10
>
> --
> [meta] cannot add facebook account, facebook does not update and more
> https://bugs.launchpad.net/bugs/614742
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Gwibber: New
> Status in “gwibber” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: gwibber
>
> This is a bug that covers many facebook related problems in gwibber. when a
> user add a facebook account after authorization gwibber dont show any add
> button so the account cannot be added. some people succeed in adding the
> account but then facebook does not update and gwibber-service logs show
> something like 'applicaton limit reached'. the logs seem to suggest that the
> problem is from the facebook side.. this bug is for tracking purpose so we
> have a single bug report as the root cause is the same.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/gwibber/+bug/614742/+subscribe
>

asad (creative-asad) wrote :

Thank you so much. i appreciat your responce. i shall try this as soon as i
reach my home.

Regards
S. Asad Ali Zaidi

Electronics Engineer

.Net Specialist

MCSE

www.asadali.tk

www.freeonlinebooks.tk

+92-345-5164698

On 17/09/2010, Maxim Doucet <email address hidden> wrote:
>
> I don't think the bug should be closed because it is still present in
> Lucid!
>
> The solution for me on Lucid (Ubuntu 10.04.1) with Empathy 2.30.2 was to
> folow Dr. Kenobi's comment #19!
>
> So:
> * go to facebook -> account -> privacy settings -> applications and
> websites settings -> "Remove unwanted or spammy applications" -> remove
> Gwibber
> * launch gwibber, manage accounts, add facebook, enter your login (email
> address works here)/password to authorize Gwibber as if it was the first
> time
> * the "Add" button does *not* appear yet
> * close the Gwibber's account window, open it again and redo the facebook
> connexion process
> * the "Add" button appears and it works finally well
>
> Does anyone else have success with this?
>
> --
> [meta] cannot add facebook account, facebook does not update and more
> https://bugs.launchpad.net/bugs/614742
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (638794).
>

--

No such luck for me using that process. I'll try a few other things, but there is some server problems here. If you hit authorize twice (when the add button /should/ appear, but doesn't) it pops up with a new frame with "Success" printed in it.

Ben (klinerdraken) wrote :

jkltechinc, Try uninstalling - reinstalling gwibber then do that process. Thats what i had to do and it is now working correctly for me.

Th3Pr0ph3t (th3pr0ph3t) wrote :

The bug is still there:

The Save account button is not there after authorizing with facebook.
But if I try to change the color of the messages the button suddenly appears along with a cancel button, then:

Saving...
Couldn't find field: username

I hope this gets fixed before the Official Release.

Changed in gwibber (Ubuntu):
status: Triaged → Confirmed
Omer Akram (om26er) on 2010-09-22
Changed in gwibber (Ubuntu):
status: Confirmed → Triaged
Changed in gwibber:
status: New → Confirmed
Dario Bertini (berdario) wrote :

I can confirm this too, however, for those who tried the comment #19 solution and it didn't worked (like me):
maybe i have a workaround...

close gwibber, delete the gwibber authorization from facebook, then, (if like me you have tried the previous steps before) you may have some gwibber-services still running: kill them (you can do this via system->administration->system monitor, processes tab, sort by name, and kill everything that starts with gwibber), open gwibber again, and now it MAY work

one last thing: i started to notice this problem, when i connected my facebook account with a gwibber on another ubuntu machine (lucid, while my main is a maverick)... can someone confirm that this may be (one of) the cause(s)?

unfortunately i'm unable to confirm my workaround on this second machine now, so i'm not certain that this always works

  On 09/24/2010 05:34 PM, Dario Bertini wrote:
> I can confirm this too, however, for those who tried the comment #19 solution and it didn't worked (like me):
> maybe i have a workaround...
>
> close gwibber, delete the gwibber authorization from facebook, then, (if
> like me you have tried the previous steps before) you may have some
> gwibber-services still running: kill them (you can do this via
> system->administration->system monitor, processes tab, sort by name, and
> kill everything that starts with gwibber), open gwibber again, and now
> it MAY work
>
>
> one last thing: i started to notice this problem, when i connected my facebook account with a gwibber on another ubuntu machine (lucid, while my main is a maverick)... can someone confirm that this may be (one of) the cause(s)?
>
> unfortunately i'm unable to confirm my workaround on this second machine
> now, so i'm not certain that this always works
>
after doing a system update this morning, Facebook now works on my
install of Gwibber for Ubuntu 10.10 Beta.....but it's slow on updating,
like hours slow.....

Ben Clapp (ibenrunnin) wrote :

Workaround for bug (worked for me at least):
Open Gwibber.
Open Accounts.
Add Facebook account in Gwibber and authorize. It will say 'authorized', but give no add button.
Go into application settings in Facebook (in web browser); Find Gwibber, and click 'Edit Settings'.
Uncheck all settings for gwibber.
Close Gwibber account window.
Open Gwibber account window.
Add/Authorize Facebook account again, and this time there should be an 'add' button.

Vadim Rutkovsky (roignac) wrote :

The related branch fixes the missing "Add" button - now the error message appears if login is unsuccessful.

I've prepared an experimental build at ppa:roignac/svn (https://launchpad.net/~roignac/+archive/svn) - please, test this and post here if this helps. Most likely, the error will be "Application request limit reached", so the only way to add Facebook account is just to wait and try again in several minutes.

Ken Pratt (kenpratt) wrote :

Bug is still there. On the add account page there are two Add buttons. The Add... seems not to do anything. The other Add, under the drop down, does start the Facebook login process. However, after getting back an Authorized message and closing the dialog, it appears it did not work. And, When I go back to add an account, Facebook is not listed.

I am using Meerkat 64 Desktop latest as of now (Sep 28, 4:00 PM EST)

CedricMC (cedricmc) wrote :

In response to coment #9 of Marcos Lans, using my username on the login dialog worked fine for me.

Kamus (kamus) on 2010-10-05
Changed in gwibber (Ubuntu):
importance: Medium → High
49 comments hidden view all 129 comments
Sam Brightman (sambrightman) wrote :

Regarding testing: is it not possible to send the version number as part of some kind of client ID so you can see from your Facebook API account which versions are being used? And maybe test changes probabilistically - i.e. decide at runtime whether to use the old or new method. This would temporarily complicate the code of course, but once it's all understood the complexity can be removed again.

Ken VanDine (ken-vandine) wrote :

Unfortunately no, Facebook doesn't provide any way for us to track that kind of data.

Thino (frozenthino) wrote :

#65 worked for me , thank you

papukaija (papukaija) wrote :

This bug is also reported to FB's bug tracker at http://bugs.developers.facebook.net/show_bug.cgi?id=13040

flux (luigimarco) wrote :

#37 works for me... thanks ;)

sergioroa (s-roa) wrote :

In Ubuntu 10.04, I installed the ppa version of gwibber. I can confirm that now it works by deleting the files as explained in #65 and #89, including .config/gwibber/* and .gconf/apps/gwibber/*

I also have all loopbacks to 127.0.0.1, not sure if this is really needed. The procedure of first non-authorizing gwibber in facebook, deleting the files and then reauthorize gwibber as explained in #28 was then succesful.

Facebook is updating now and I can also send messages.

sergioroa (s-roa) wrote :

A continuation of the previous post #95. I am also using a username instead of email for authorizing facebook. I am also not sure of this is a need.

I add Facebook account to gwibber, but can't send messages. When I send message to facebook - nothing happened - message not added to facebook (((

Bruno Areal (bruno-areal) wrote :

I just updated from 10.04 to 10.10, and tried to add my Facebook account, but the "add" button didn't appear.
I simply changed my default browser to Firefox (it was Chromium) and tried again, wich worked!

Nevertheless, i cant send messages to facebook yet... :\

Bruno Areal (bruno-areal) wrote :

I was wrong. I can send messages to facebook, but with some delay (wierd network problems?). So, after changing my default browser to Firefox, add the account and changing the default browser to Chromium again, everything appears to work...

papukaija (papukaija) wrote :

Bug 595265 seems to be a duplicate of this bug.

On Ubuntu 10.10, Gwibber 2.32.0.1, resolution in comment 36 did not work, but the resolution in #51 did. After the edit, Gwibber needs to be shut down and restarted.

For the benefit of the non-tech community who found this thread by searching and don't know how to edit the hosts file:

From the applications menu, choose the "Accessories" menu and then "terminal."
type:
     sudo gedit /etc/hosts
If prompted for your password, enter it
If you see:
    127.0.1.1 [Name of Your System]
Edit that number to read 127.0.0.1
Save and close the file
(Exit the terminal)
Shut down Gwibber and restart

yvan (yvan-strahm) wrote :

Make it work by deleting the
~/.cache/desktop-couch
~/.config/desktop-couch
~/.local/share/desktop-couch

Then change the /etc/hosts

and login with me username and NOT the email

Thanks for all the suggestions

papukaija (papukaija) on 2010-11-01
tags: added: metabug
elPraga (elpraga) wrote :

Posting to Facebook via MeMenu or Gwibber on Lucid solved!!! (via workaround)

Hello guys. I found a workaround for posting to Facebook via Gwibber in Lucid using a twitter account. I actually do not use twitter, so doing it like this does not bother me at all.

1. Create a twiiter account.

2. Add twitter account to Gwibber.

3. Go to: http://apps.facebook.com/twitter/ , link the two accounts and allow Twitter post to Facebook.

4. You are done! You can post using MeMenu to Facebook now.

Reading some of the posts here, I understood that it could be quite a long process to get Gwibber posting directly, so I thought a little bit, and came to my mind that surely Twitter itself has a way to post to Facebook. Google gave me the answer with its firt hit.

P.S.
Apparently there is an app that does not repost all the tweets. You will find it at: http://www.facebook.com/selectivetwitter
I have not tried this one, because for me it has not use. Does someone knows if it is working well or not??

I hope many people can enjoy this :-)

shnifti (b-rous) wrote :

Solution promoted in #95 / #96 seemed to have worked for me.

Ken VanDine (ken-vandine) wrote :

To test 2.30.3 in Lucid and 2.32.2 in Maverick, restart gwibber-service and gwibber. You should notice "Facebook" doesn't have a "Replies" stream anymore.

As mentioned before, this fix won't be something that will just work, fixing the facebook allocation problem right away. We won't see the benefit from this fix until the update makes it to quite a few users. Based on the information facebook has provided, the API request we removed in this update was making 266 million database queries per day, so this fix should make a significant improvement.

Accepted gwibber into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gwibber (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted gwibber into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gwibber (Ubuntu Maverick):
status: New → Fix Committed
Schmankerl (schmankerl) wrote :

I installed maverick-proposed version of gwibber and could add my facebook-account. Messages are shown and it seems to be working now.

Installed the update too. Does still not work. Deleted all config files before I tried the fix. I still cannot add my account. Is this really that hard?

Daniel Bugl (omnidan) on 2010-11-15
Changed in gwibber:
status: Confirmed → Fix Committed

Ok, works. I had to use the network-manager instead of indicator-network. With the last one, it doesn't run. Whatever...

Omer Akram (om26er) wrote :

for gwibber upstream its fix released since i have seen many people seeing positive results after the update. and as Ken said the problem will go away eventually.

Changed in gwibber:
importance: Undecided → High
status: Fix Committed → Fix Released
Omer Akram (om26er) wrote :

gwibber 2.91.1 is in natty which includes the changes.

Changed in gwibber (Ubuntu):
status: Triaged → Fix Released
Omer Akram (om26er) wrote :

i have been using gwibber 2.32.1 and then later 2.32.2 but have not found any regression neither received any regression bug reports. on the other side facebook situation have improved alot so i am marking this as verification done.

tags: added: verification-done
removed: verification-needed
Miguel Mendes Ruiz (migmruiz) wrote :

I installed maverick-proposed version of gwibber, but it didn't work at the first time.
After removing : ~/.gconf/apps/gwibber/preferences/%gconf.xml I was able to add my facebook-account.

It seems to be working now.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.30.3-0ubuntu1

---------------
gwibber (2.30.3-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release.
    - Drop the responses operation from facebook, it abuses the allocation
      facebook gives us based on the DB query count (LP: #614742)
    - Backport fix for getting facebook comments embedded in the message
      content, which makes the removed responses operation un-needed.
  * -debian/patches/lp_653225.patch upstreamed
  * -debian/patches/refresh_timer.patch upstreamed
 -- Ken VanDine <email address hidden> Wed, 10 Nov 2010 22:40:41 -0500

Changed in gwibber (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.32.2-0ubuntu1

---------------
gwibber (2.32.2-0ubuntu1) maverick-proposed; urgency=low

  * Drop the responses operation from facebook, it abuses the
    allocation facebook gives us based on the DB query count (LP: #614742)
  * Fixed notifications for private messages (LP: #663377)

gwibber (2.32.1-0ubuntu1) maverick-proposed; urgency=low

  * New upstream release (LP: #673161)
    - Backported fix for clearing multi-column streams when activated by
      the messaging indicator (LP: #643487)
    - Save window size/position when it changes, so it doesn't get moved
      unexpectedly when activated by the messaging indicator
    - Fixed dupe notifications as well as displaying dupes in the stream
    - Shouldn't display reply icon for messages from you (LP: #661330)
    - Private messages shouldn't allow public replies (LP: #661358)
    - Private messages shouldn't allow retweets (LP: #661359)
 -- Ken VanDine <email address hidden> Wed, 10 Nov 2010 23:14:44 -0500

Changed in gwibber (Ubuntu Maverick):
status: Fix Committed → Fix Released
Raoul Bhatia (raoul-bhatia) wrote :

unfortunately, i cannot confirm that this fix works.

gwibber 2.32.2-0ubuntu2 -> cannot add facebook.

launching gwibber from shell, i see:
> Saving...
> Couldn't find field: username

what do i neet to do to create a logfile?

Eric B (eric-broszeit) wrote :

This is not fixed.

Just installed Ubuntu 10.10 yesterday, and there was no add button after authorization.

Updated Gwibber to 2.32.2, and it still does not work.

Eric B (eric-broszeit) wrote :
Download full text (3.1 KiB)

gwibber-service -d -o
Gwibber Dispatcher: DEBUG Setting up monitors
Gwibber Dispatcher: DEBUG Refresh interval is set to 15
Gwibber Dispatcher: DEBUG ** Starting Refresh - 2010-12-21 11:15:21.17 **
Gwibber Dispatcher: DEBUG <twitter:receive> Performing operation
Gwibber Dispatcher: DEBUG libproxy: getting proxies
Gwibber Dispatcher: DEBUG <twitter:responses> Performing operation
Gwibber Dispatcher: DEBUG libproxy: getting proxies
Gwibber Dispatcher: DEBUG <twitter:responses> Finished operation
Gwibber Dispatcher: DEBUG <twitter:private> Performing operation
Gwibber Dispatcher: DEBUG libproxy: getting proxies
Gwibber Dispatcher: DEBUG <twitter:receive> Adding record
Gwibber Dispatcher: DEBUG <twitter:receive> Adding record
Gwibber Dispatcher: DEBUG <twitter:receive> Finished operation
Gwibber Dispatcher: DEBUG <twitter:lists> Performing operation
Gwibber Dispatcher: DEBUG libproxy: getting proxies
Gwibber Dispatcher: DEBUG libproxy: getting proxies
Gwibber Dispatcher: DEBUG libproxy: getting proxies
Gwibber Dispatcher: DEBUG <twitter:private> Finished operation
Gwibber Dispatcher: DEBUG <buzz:receive> Performing operation
Gwibber Dispatcher: DEBUG libproxy: getting proxies
Gwibber Dispatcher: DEBUG <twitter:lists> Adding record
Gwibber Dispatcher: DEBUG <twitter:lists> Adding record
Gwibber Dispatcher: DEBUG <twitter:lists> Adding record
Gwibber Dispatcher: DEBUG <twitter:lists> Adding record
Gwibber Dispatcher: DEBUG <twitter:lists> Adding record
Gwibber Dispatcher: DEBUG <twitter:lists> Adding record
Gwibber Dispatcher: DEBUG <twitter:lists> Finished operation
Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/gwibber/microblog/network.py", line 53, in __init__
    self.curl.perform()
error: (56, 'GnuTLS recv error (-9): A TLS packet with unexpected length was received.')
Gwibber Dispatcher: ERROR Failed to communicate with https://www.googleapis.com/buzz/v1/activities/@me/@consumption?oauth_nonce=22574045&oauth_timestamp=1292948170&oauth_consumer_key=anonymous&oauth_signature_method=HMAC-SHA1&oauth_version=1.0&oauth_token=1%2FSP8cnI_8TqFb_4G23yszErqH6AEOjx2uhLkTchxLEik&oauth_signature=AICMJ8A1oYuC0SwmTbfHOKGzmFw%3D&alt=json
Gwibber Dispatcher: ERROR <buzz:receive> Operation failed
Gwibber Dispatcher: DEBUG Traceback:
Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/gwibber/microblog/dispatcher.py", line 79, in perform_operation
    message_data = PROTOCOLS[account["service"]].Client(account)(opname, **args)
  File "/usr/lib/python2.6/dist-packages/gwibber/microblog/buzz.py", line 117, in __call__
    return getattr(self, opname)(**args)
  File "/usr/lib/python2.6/dist-packages/gwibber/microblog/buzz.py", line 120, in receive
    return self._get("activities/@me/@consumption")
  File "/usr/lib/python2.6/dist-packages/gwibber/microblog/buzz.py", line 113, in _get
    if parse: return [getattr(self, "_%s" % parse)(m) for m in data["data"][collection]]
KeyError: 'data'

Gwibber Dispatcher: INFO Loading complete: 1 - []

This clearly shows how Buzz doesn't work, but I see nothing about Facebook when I ...

Read more...

Omer Akram (om26er) wrote :

are you using gwibber 2.32.2?

Omer Akram (om26er) wrote :

... if not(since you just installed maverick) please update your gwibber first and then try to add the account.

Eric B (eric-broszeit) wrote :

Yes, I am running 2.32.2. I said so in post #118 after saying I just installed Maverick. Sorry about including my log in a septate post. I didn't find the debug switch until later.

The add button just never shows up.

Same here, Omer. Running Gwibber 2.32.2 and when I attempt to add a Facebook account, after authorizing, I still never get an "Add" button.

Josh (joshhansen) wrote :

For me the issue resolved only when I bypassed my proxy and connected to the Internet directly. When the proxy is enabled, the 'Add' button never appears. When it's disabled, the 'Add' button appears as expected. This is not an issue when adding a Twitter account, so apparently the Facebook account code doesn't traverse the proxy as gracefully as the Twitter code.

Eric B (eric-broszeit) wrote :

I went on our guest wireless system that does not require a proxy, went to system>preferences>network proxy and turned off all proxy settings. There was still no add button.

Its kind of frustrating that Ubuntu is packaged with apps that don't work properly through proxies if at all. Empathy has a lot of issues as well.

Eibriel (gabriel-inv) wrote :

I've successfully added a Facebook account, but, I've changed the Facebook password, then I've no received updates anymore.
I've deleted the Facebook account from Gwibber, and when I attempt to add it again, I can't see the Add button after Authorize it.

Plus:
If I don't delete Gwibber from my Facebook applications, I can't authorize it, and the Add button don't show.

Regards!

Eibriel (gabriel-inv) wrote :

Using Gwibber 2.32.2

Tom Wieczorek (twz123) wrote :

Using gwibber 3.0.0.1-0ubuntu3, I cannot add my Facebook account. After entering username and password, the embedded browser frame becomes white and the String "Success" appears, nothing else. No Add button, nothing.

I get the following output when launching gwibber via Terminal:
Loading plugin for twitter
Loading plugin for facebook
Loading plugin for identica
Traceback (most recent call last):
  File "/usr/share/gwibber/plugins/facebook/gtk/facebook/__init__.py", line 121, in on_facebook_auth_title_change
    data = json.loads(urllib.urlopen("https://graph.facebook.com/me?access_token=" + self.account["access_token"]).read())
  File "/usr/lib/python2.7/urllib.py", line 84, in urlopen
    return opener.open(url)
  File "/usr/lib/python2.7/urllib.py", line 205, in open
    return getattr(self, name)(url)
  File "/usr/lib/python2.7/urllib.py", line 435, in open_https
    h.endheaders(data)
  File "/usr/lib/python2.7/httplib.py", line 951, in endheaders
    self._send_output(message_body)
  File "/usr/lib/python2.7/httplib.py", line 811, in _send_output
    self.send(msg)
  File "/usr/lib/python2.7/httplib.py", line 773, in send
    self.connect()
  File "/usr/lib/python2.7/httplib.py", line 1158, in connect
    self.sock = ssl.wrap_socket(sock, self.key_file, self.cert_file)
  File "/usr/lib/python2.7/ssl.py", line 344, in wrap_socket
    ciphers=ciphers)
  File "/usr/lib/python2.7/ssl.py", line 121, in __init__
    self.do_handshake()
  File "/usr/lib/python2.7/ssl.py", line 283, in do_handshake
    self._sslobj.do_handshake()
IOError: [Errno socket error] [Errno 1] _ssl.c:499: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol

dpkg -s gwibber returns:
Package: gwibber
Status: install ok installed
Priority: optional
Section: misc
Installed-Size: 1392
Maintainer: Ubuntu Developers <email address hidden>
Architecture: all
Version: 3.0.0.1-0ubuntu3
Depends: python-dbus, python-gtk2, python-gconf, python-egenix-mxdatetime, python-simplejson, python-webkit, librsvg2-2, librsvg2-common, python-imaging, python-xdg, python-mako, python-gtkspell, python-wnck, python-oauth, gwibber-service (= 3.0.0.1-0ubuntu3), python (>= 2.6), python-central (>= 0.6.11)
Suggests: gwibber-themes, gwibber-service-flickr, gwibber-service-digg, gwibber-service-buzz, gwibber-service-statusnet, gwibber-service-foursquare, gwibber-service-friendfeed, gwibber-service-pingfm, gwibber-service-qaiku
Conffiles:
 /etc/xdg/autostart/gwibber.desktop 6375e4874fa720f900c9407348998716
Description: Open source social networking client for GNOME
 Gwibber is a social networking client for GNOME. It supports Facebook,
 Twitter, Identi.ca, StatusNet, FriendFeed, Qaiku, Flickr, and Digg.
 .
 This package includes the Gwibber desktop client
Homepage: https://launchpad.net/gwibber
Python-Version: >=2.6

el_gallo_azul (el-gallo-azul) wrote :

For me, it's happening on

Ubuntu 12.04
Gwibber 3.4.2

I have tried

Web browser --> Facebook --> Apps --> My Apps --> Remove Gwibber
Quit browser
Start Gwibber
Create Facebook account and authorise again, giving the same 'Success' message, but quitting Gwibber and restarting it shows only my (good) Twitter account.

Changed in gwibber:
assignee: nobody → tim pellerin (tim-pellerin)
assignee: tim pellerin (tim-pellerin) → nobody
Displaying first 40 and last 40 comments. View all 129 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.