gtk_file_chooser_get_current_folder() function is broken in 2.24.10 < GTK+ < 2.24.15

Bug #1125260 reported by Tehnick on 2013-02-14
158
This bug affects 35 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Critical
gtk+2.0 (Ubuntu)
Undecided
Unassigned
Nominated for Raring by Dmitry Shachnev

Bug Description

Ubuntu users of EiskaltDC++ reported us about problem with GTK+ dialog for choosing folders: it always returns path to home directory instead of chosen one.
https://code.google.com/p/eiskaltdc/issues/detail?id=1392#c8

After small investigation I found that problem affects only Ubuntu Quantal and Raring. Bug is reproducible only in GTK+ > 2.24.10, and it was fixed in GTK+ 2.24.15. Related link:
https://bugzilla.gnome.org/show_bug.cgi?id=691040

Unfortunately, GTK+ 2.24.15 is not available in Ubuntu Raring yet. But I think that packages will be updated soon, because Ubuntu is not in freeze yet. So the most important question is about Ubuntu Quantal. Please add necessary patch into the package:
http://git.gnome.org/browse/gtk+/commit/?id=81df0059

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk+2.0 (Ubuntu):
status: New → Confirmed
Changed in gtk:
importance: Unknown → Critical
status: Unknown → Fix Released
Changed in gtk:
status: Fix Released → Confirmed
Changed in gtk:
status: Confirmed → Fix Released

Affects a lot of applications ... still unassigned in ubuntu?

The patch that the description points to is not the fix, it's just adding a test to the test patterns of the library. The correct patch seems to be this one:

https://bug691040.bugzilla-attachments.gnome.org/attachment.cgi?id=238204

emptythevoid (emptythevoid) wrote :

Just updated to 13.04 and this bug was the first thing I tried to replicate. I attempted to produce the bug in OpenShot, since that's where I run into it the most, and everything has worked normally. Unable to reproduce the bug.

Tehnick (tehnick) wrote :

This because of version 2.24.17-0ubuntu2 is in Ubuntu Raring now. Bug still affects Ubuntu Quantal.

tags: removed: raring
Dmitry Shachnev (mitya57) wrote :

Saucy now has 2.24.18 where the linked upstream bug was fixed, we can upload it to Raring as allowed by GNOME MRE.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.