For applications using simplified save dialogues, selecting a destination through "Other..." saves to /HOME directory

Bug #1070004 reported by emptythevoid on 2012-10-22
70
This bug affects 13 people
Affects Status Importance Assigned to Milestone
gtk+2.0 (Ubuntu)
Undecided
Unassigned
gtk+3.0 (Ubuntu)
Undecided
Unassigned

Bug Description

Certain applications, like DeVeDe or Openshot, use a simplified save dialogue box. From these simplified lists, the user is presented with some default directories to save in (Video, Desktop, Home, etc). Selecting any of these destinations from this menu works as expected. However, if the user wishes to save to some other location besides the ones suggested, they must click on "Other..." which displays the full, normal save dialogue. When this is used, it does not matter which directory the user chooses - the application will save to the /HOME directory.

I have tested this using DeVeDe on Ubuntu 12.10 64-bit (fresh install) and 12.10 32-bit (upgrade install). This *is not* a bug with DeVeDe, but it was the first application I found that was using the simplified save dialogue (and I also was able to reproduce this using Openshot, which does the same thing). If the application uses the normal save dialogue box, everything works as expected.

Please help me provide the information needed for this bug report. I do not know what package to file this against, or what other information that needs to be attached. It would also be helpful if someone can reproduce this. I have not filed a bug report because I did not know what to attach or what package to file against. Any help would be greatly appreciated.

Here is a video demonstrating the problem using DeVeDe. I tell DeVeDe to export a video to my Desktop from the defaults menu, which works as expected. I then tell it to save it to my Desktop, but using the "Other..." menu. I would expect it to say that there's a file already there with the same name, and offer to overwrite it. Instead, it saves the file to my /Home directory.

http://www.youtube.com/watch?v=7O5O6XnRTis&feature=youtu.be

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1070004/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment

Still not sure on the exact package, but its probably something to either do with Nautilus or Gnome

affects: ubuntu → nautilus (Ubuntu)
Changed in nautilus (Ubuntu):
status: New → Confirmed
affects: nautilus (Ubuntu) → gtk+3.0 (Ubuntu)
emptythevoid (emptythevoid) wrote :

This bug may be affecting control GtkFileChooserButton

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk+2.0 (Ubuntu):
status: New → Confirmed
summary: - For applications using simplified save dialogues, selecting a
- destionation through "Other..." saves to /HOME directory
+ For applications using simplified save dialogues, selecting a
+ destination through "Other..." saves to /HOME directory
william fischer (maxxjvx) wrote :

I noticed this symptom when trying to save to a different folder by selecting "Other" only to find the item in /Home directory using OpenShot.

Linux COMPUTERNAME 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Jrop (jrapodaca) wrote :

As far as I can tell this bug still hasn't been fixed (at least, with all updates installed, I still can't save in another folder than the ones listed in the dropdown). Here's a workaround, hope it helps somebody else:

1) Using nautilus (haven't tried this with other file managers), navigate to the folder you would like to save to
2) Choose Bookmark -> Add Bookmark
3) The folder now shows up as one of the options in the drop down within openshot (you may have to restart openshot to get it to appear)

After the first save, you are clear to delete the bookmark (so things don't get cluttered/messy). Hope this helps!

Any word on when this will get sorted out/pushed to Ubuntu updates or however that works?

Pete Keating (ptk) wrote :

I too have this bug, manifested in OpenShot. I'm on Lubuntu 12.10, Linux 3.5.0-21-generic #32-Ubuntu SMP. I will try the workarount above on my next project.

emptythevoid (emptythevoid) wrote :

This bug is still present on today's daily build of Ubuntu 13.04. Tested with Openshot.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers