Update gnome-terminal to 3.26.1

Bug #1721412 reported by Jeremy Bicha on 2017-10-04
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-terminal (Ubuntu)
Wishlist
Unassigned
vte2.91 (Ubuntu)
Wishlist
Unassigned

Bug Description

We ended up not having time for this for Ubuntu 17.10.

The gnome-terminal developer released a 3.25.1 early and then didn't release another build until just before 3.26.0.

We'll need to do a bit of work to update vte with our pcre2 revert patches.

Jeremy Bicha (jbicha) on 2017-10-04
Changed in vte2.91 (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Egmont Koblinger (egmont-gmail) wrote :

Hi,

Is it too late for 17.10 even if let's say I ported the patch for you tonight? (I can't promise but I might take a look *if* you confirm upfront that it'll likely make it into 17.10.)

The big change (that requires to update the pcre2 patch) made it into 3.25.1 (vte 0.49.1) so strictly speaking you had plenty of time to update.

A few releases were skipped because there were hardly any changes. I guess it came across as if it was really broken/unstable/unusable?? Would you have upgraded in time if there were .2, .90, .91 releases almost identical to .1?

What can we do in the future to prevent this kind of misunderstanding / implicit miscommunication?

Egmont Koblinger (egmont-gmail) wrote :

Whenever you update to vte-0.50, please make sure to address lp:1718909 too! It's really not okay to accidentally remove a brand new feature from Tilix.

Jeremy Bicha (jbicha) wrote :

Egmont, thanks for your comments.

1. To get 3.26 into Ubuntu 17.10, you would need to convert this bug into a Feature Freeze exception and have that exception approved by the Ubuntu Release Team. I'm not on the Release Team so I don't know whether it will be approved.

2. Basically I ran out of time.

3. I am not going to upload a GNOME development .1 release from very early in the release cycle into Ubuntu. (For one thing, my experience is that GNOME developers feel free to change features well after the GNOME Freeze if they never released a .90 yet.) A suitable tarball was not released until September 8 which is over 2 weeks late for Ubuntu Feature Freeze. So yes, it would definitely have helped if vte had followed GNOME's release cycle.

4. More specifically, this cycle I used .5 releases to start working on packaging, but .90 releases are really important because of how GNOME and Ubuntu's release cycles fit together. So far, I haven't devoted the time to work on packaging earlier GNOME snapshots.

5. If you can fix 17718909, please submit a patch and subscribe ubuntu-sponsors. Thanks.

References
----------
https://wiki.ubuntu.com/ArtfulAardvark/ReleaseSchedule
https://wiki.ubuntu.com/FeatureFreeze

Egmont Koblinger (egmont-gmail) wrote :

1. I'll let this one go then, sorry.

2. No worries! I don't know what vte/gnome-terminal will add in this cycle, but especially for the forthcoming 18.04 LTS it would be great not to miss something new due to such a silly misunderstanding.

3-4. I'll forward the request to the main developer not to skip a release (or at least not to skip .90, or not to skip more in a row). On the other hand, GNOME's various freeze dates apply to us too even if we skip a certain release. So e.g. if – theoretically – we skip .2 thru .90 the next time, by the time .90 is due please consider .1 as .90 :-)

Feel free to reach out to me any time you have questions or need a bit of help with vte/gnome-terminal (including e.g. porting the pcre patch). Unlike its main developer I'm actually using Ubuntu, so I'm happy to give some more direct help to this distro.

Thanks!

Egmont Koblinger (egmont-gmail) wrote :

Only 2 hunks fail to apply, one of them is trivial to fix. There's 1 tough, about a 100 lines in vte.cc.rej.

What is the status of this being in artful or bionic?

Egmont Koblinger (egmont-gmail) wrote :

Here's the PCRE2 removal patch updated to 0.50.2 / current vte-0-52.

Please review, test if works correctly, and if does then please apply and upgrade to vte-0.50.x and gnome-terminal-3.26.x.

The only nontrivially conflicting upstream patch was https://git.gnome.org/browse/vte/commit/?id=91e9c838 "widget: Provide a way to copy the selection to clipboard as HTML". The easy way to do the merging was to first revert this on top of 0.50.2, then apply Ubuntu's "revert-pcre2" patch belonging to 0.48, and then re-apply HTML copy-paste, and finally do some one-off fixes (like the complete removal of the "word" variable which was accidentally still present in upstream 0.48 and removed in upstream 0.50, and converting "row_text" from gchar* to GString*).

I've tested compiling "normally" (it still links against pcre2 - you're probably not interested in it), as well as --without-pcre2 which compiles and works fine too, and I've verified with ldd that pcre2 is indeed not linked.

I've also verified that the package works together with Artful's gnome-terminal{,-data} 3.24.2 packages (and correctly underlines URLs on hover), plus gnome-terminal 3-26 compiles and runs fine against it, and its regex unittests also pass.

I've compiled everything manually though, not using Ubuntu's build system. This shouldn't make a difference.

Egmont Koblinger (egmont-gmail) wrote :

Sorry, typo:

Here's the PCRE2 removal patch updated to 0.50.2 / current vte-0-*50*.

I'm looking into 0.52.x now...

Egmont Koblinger (egmont-gmail) wrote :

This is an incremental patch, goes on top of "vte 0.50.2 revert pcre2"!

Forthcoming vte-0.52 / gnome-terminal-3.28 is a piece of cake compared to the pain of 0.50.

The patch for 0.50.2 applies cleanly to 0.51.3, except for the part that patches vteapp.cc which is gone. Instead there's a new test app which I've patched more or less to compile and run. It gives warnings about the multiline flag, I don't understand the story here, but it totally doesn't matter since Ubuntu doesn't ship this test app.

There are two failing hunks for gnome-terminal 3.27.4 but they're so trivial that I don't even post a patch (only one of them needs to be applied, the other one seems to be gone).

Here's a teaser with some of the new features that hopefully really make it worth upgrading (apart from the usual bunch of bugfixes):

0.50 / 3.26:
- explicit hyperlinks (e.g. "ls --hyperlinks" if coreutils upgrades to 8.28)
- copy to clipboard in HTML with attributes (or plain text, the user's choice)
- improved URL recognition

0.52 / 3.28:
- double underline, curly underline, and overline text decorations
- colored normal/double/curly underline (e.g. for spell checking)
- blinking text
- option to disable extra brightness of bold text, mostly for the Solarized theme
- optional extra line spacing and character spacing for accessibility
- improved handling of --tab command line option
- even further improved URL recognition

Jeremy Bicha (jbicha) wrote :

Egmont, thank you very much for the patch updates! I am uploading 3.26 shortly.

Could you please open a new bug for the gnome-terminal 3.28 / vte2.91 0.52 update?

Changed in vte2.91 (Ubuntu):
status: Triaged → Fix Committed
Changed in gnome-terminal (Ubuntu):
status: Triaged → Fix Committed

The attachment "vte 0.50.2 revert pcre2" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch

> Could you please open a new bug for the gnome-terminal 3.28

Yup, filed lp:1744711.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vte2.91 - 0.50.2-4ubuntu2

---------------
vte2.91 (0.50.2-4ubuntu2) bionic; urgency=medium

  * Don't have libvte-2.91-dev depend on libpcre2-dev

 -- Jeremy Bicha <email address hidden> Sat, 20 Jan 2018 20:59:24 -0500

Changed in vte2.91 (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.6 KiB)

This bug was fixed in the package gnome-terminal - 3.26.2-3ubuntu1

---------------
gnome-terminal (3.26.2-3ubuntu1) bionic; urgency=medium

  * Merge with Debian (LP: #1721412). Remaining changes:
    + debian/rules:
      - Install compatibility version of gnome-terminal.desktop
    + gnome-terminal.wrap, debian/rules:
      - Add a wrapper script to restore command line compatibility.
    + debian/control.in:
      - gnome-terminal depends on python3, python3-gi and gir1.2-glib-2.0 for
        the wrapper script.
      - Don't Build-Depend on PCRE2
    + Add 0001-Restore-transparency.patch:
      - Restore transparency support
    + Add 0001-Add-style-classes-and-CSS-names-to-some-of-our-widge.patch:
      - Add CSS names and style classes so we can theme things more easily.
    + Add 0001-screen-window-Extra-padding-around-transparent-termi.patch:
      - Fix transparency on Wayland. Patch by Owen Taylor, via Debarshi Ray @
        Fedora (LP: #1650395)
    + Add 50_add_unity_quicklist.patch:
      - Add Unity quicklist menu item.
    + Add 52_support_apturl.patch:
      - Support apt: urls.
    + Add 60_add_lp_handler.patch:
      - Add a handler for launchpad bug URLs.
    + Add scrollbar-background-theming.patch:
      - Draw background under the scrollbar that matches the actual terminal
        background color. This allows proper theming.
    + Add debian/patches/revert-pcre2.patch:
      - Revert changes that require PCRE2 since it's not in main
        (see MIR #163666)
  * Refresh patches

gnome-terminal (3.26.2-3) unstable; urgency=medium

  * Update Vcs fields for migration to https://salsa.debian.org/
  * Bump debhelper compat to 11

gnome-terminal (3.26.2-2) unstable; urgency=medium

  * Update Vcs fields for conversion to git
  * Add debian/gbp.conf
  * Bump Standards-Version to 4.1.2

gnome-terminal (3.26.2-1) unstable; urgency=medium

  * New upstream release
  * Bump Build-Depends on libvte-2.91-dev to (>= 0.50.2)
  * Refresh patches
  * Switch to dh_missing and abort on uninstalled files

gnome-terminal (3.26.1-2) unstable; urgency=medium

  * Team upload
  * debian/gnome-terminal.wrapper: Improve emulation of xterm -e.
    Run gnome-terminal -- EXECUTABLE [ARGS] instead of deprecated
    gnome-terminal -e QUOTED_STRING or gnome-terminal -x EXECUTABLE [ARGS],
    and emulate xterm's fallback-to-shell behaviour more precisely.
  * d/p/window-Fix-tiled-check.patch: Use non-character-cell-based
    sizing whenever at least one edge is tiled, partially addressing
    a regression with GTK+ >= 3.22.23 (partial fix for: #879566)

gnome-terminal (3.26.1-1) unstable; urgency=medium

  * New upstream translations release (Closes: #877293)
  * Bump Build-Depends on libvte-2.91-dev to (>= 0.50.1) as per configure.ac.
  * Bump Standards-Version to 4.1.1

gnome-terminal (3.26.0-1) unstable; urgency=medium

  * Team upload
  * New upstream stable release
  * debian/control.in:
    - Bump Build-Depends on libvte-2.91-dev to (>= 0.50.0)

gnome-terminal (3.25.92-1) unstable; urgency=medium

  * New upstream release
  * debian/control.in:
    - Bump Build-Depends on libvte-2.91-dev to (>= 0.49.92)

gnome-terminal (3.24.2-1) unstable; urge...

Read more...

Changed in gnome-terminal (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions