Keyboard layout indicator does not indicate current layout (18.04 Bionic beaver)

Bug #1812266 reported by PabloAB on 2019-01-17
254
This bug affects 52 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
High
Marco Trevisan (Treviño)
Bionic
Undecided
Marco Trevisan (Treviño)
Cosmic
Undecided
Marco Trevisan (Treviño)

Bug Description

Upstream issue: https://gitlab.gnome.org/GNOME/gnome-shell/issues/913

[ Impact ]

Keyboard Layout indicator don't display current layout (empty selected drop down box)

[ Test case ]

1. Boot
2. Suspend or lock the screen
3. Log again with your user
4. The keyboard indicator should display current layout

[ Regression Potential ]

Really low, we properly pass a null value instead of an undefined one, without breaking JS.

--

Steps to reproduce the bug:

1. After normal boot, suspend or lock.
2. Login again.

Result: Keyboard Layout indicator don't display current layout (empty selected drop down box)

[ Workarounds ]

- Switch with keyboard (Super+space) or mouse. BUT if you then logout on the login screen *when you press the first character* of the password the shown selected keyboard layout resets.

- Restart Gnome Shell (Alt+F2 r):
https://wiki.gnome.org/Projects/GnomeShell/CheatSheet#Developer_tools

- Also asked here https://askubuntu.com/q/1109555/349837
- Similar old bug https://bugs.launchpad.net/gnome-settings-daemon/+bug/531173

$ inxi -SG -! 31 -y80 && cat /etc/default/keyboard && localectl status
System: Kernel: 4.15.0-43-generic x86_64 bits: 64 Desktop: Gnome 3.28.3
           Distro: Ubuntu 18.04.1 LTS
Graphics: Card-1: Intel HD Graphics 520
           Card-2: NVIDIA GM108M [GeForce 940M]
           Display Server: x11 (X.Org 1.19.6 )
           drivers: fbdev (unloaded: modesetting,vesa)
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2)
           version: 4.5 Mesa 18.0.5
# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="es"
XKBVARIANT="en"
XKBOPTIONS="terminate:ctrl_alt_bksp"

BACKSPACE="guess"
   System Locale: LANG=en_US.UTF-8
                  LC_NUMERIC=es_AR.UTF-8
                  LC_MONETARY=es_AR.UTF-8
                  LC_PAPER=es_AR.UTF-8
                  LC_NAME=es_AR.UTF-8
                  LC_ADDRESS=es_AR.UTF-8
                  LC_TELEPHONE=es_AR.UTF-8
                  LC_MEASUREMENT=es_AR.UTF-8
                  LC_IDENTIFICATION=es_AR.UTF-8
       VC Keymap: n/a
      X11 Layout: es
       X11 Model: pc105
     X11 Variant: en
     X11 Options: terminate:ctrl_alt_bksp

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Prashant Gupta (prashu20) wrote :

I face the same problem
Keyboard indicator icon keeps disappearing Ubuntu 18.04.1

Gnome shell version 3.28.3 Ubuntu 18.04.1.
As soon as I do screen lock or open up a new application, the keyboard icon keeps disappearing. I have to press super +Tab see the current keyboard layout icon again. But why does it disappear in the first place? I think the problem arose after an update

Here is relevant information from logs:

JS ERROR: Exception in callback for signal: activate: Error: Error invoking IBus.set_global_engine_async: Expected function for callback argument callback, got undefined
setEngine@resource:///org/gnome/shell/misc/ibusManager.js:207:9
wrapper@resource:///org/gnome/gjs/modules/_legacy.js:82:22
activateInputSource@resource:///org/gnome/shell/ui/status/keyboard.js:490:13
JS WARNING: [resource:///org/gnome/shell/ui/keyboard.js 546]: reference to undefined property "_rect"

Prashant Gupta (prashu20) wrote :

Output of command inxi -SG -! 31

Petruhin Alexandr (razblade) wrote :

Moreover problem appear not only in 18.04 but also in 18.10 version.

Rolling back gnome-shell and gnome-shell-common packages fix this problem, so i added gnome-shell to affected packages.

according to this launchpad - https://launchpad.net/ubuntu/+source/gnome-shell
for Ubuntu 18.04:
- gnome-shell and gnome-shell-common version 3.28.3-0ubuntu0.18.04.4 is affected by this problem
- gnome-shell and gnome-shell-common version 3.28.1-0ubuntu2 is doesn't affected by this problem

for Ubunut 18.10
- gnome-shell and gnome-shell-common version 3.30.1-2ubuntu1.18.10.2 is affected by this problem
- gnome-shell and gnome-shell-common version 3.30.1-2ubuntu1 is doesn't affected by this problem

Sebastien Bacher (seb128) wrote :

Thank you for your bug report.
- What desktop session do you use?
- What keyboard layouts do you have configued in GNOME?
- Could you add your journalctl log after getting the issue?

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Sebastien Bacher (seb128) wrote :

The warning looks like https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/187 , we should probably include that fix in the incoming SRU

Changed in gnome-shell (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → High
PabloAB (pabloab777) wrote :
Prashant Gupta (prashu20) wrote :

@PabloAB or @Sebastian Becher could you please tell how long one has to wait before the new update to gnome-shell fixes the issue? I wanted to avoid the method from Petruhin Alexandr of rolling back to earlier version of gnome-shell. I can wait for the new update if it doesn't take much time as you have mentioned above in the link above somebody already fixed the issue.

Prashant Gupta (prashu20) wrote :

- What desktop session do you use - Gnome 3.28.3
- What keyboard layouts do you have configured in GNOME- De (German) and En (Us English)
- Could you add your journalctl log after getting the issue? I have attached file below

PabloAB,

I don't think that the fix mentioned in such issue is the fix for it though.

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
no longer affects: gnome-settings-daemon (Ubuntu)
Changed in gnome-shell (Ubuntu):
status: Confirmed → In Progress
description: updated
tags: added: bionic regression-update
Launchpad Janitor (janitor) wrote :
Download full text (4.2 KiB)

This bug was fixed in the package gnome-shell - 3.30.2-2ubuntu1

---------------
gnome-shell (3.30.2-2ubuntu1) disco; urgency=medium

  * Merge with debian, remaining changes:
    + Replace gnome-backgrounds dep with ubuntu-wallpapers and Suggests
      gnome-themes-standard-data, gnome-backgrounds
    + Add some Recommends:
      - ubuntu-session (| gnome-session) to have the ubuntu session available
      - xserver-xorg-legacy
      - yaru-theme-gnome-shell for the default ubuntu theming
    + Update debian/gbp.conf with Ubuntu settings
    + gnome-shell-common.install: Install Ubuntu mode
    + gnome-shell-common.prerm: Remove deprecated ubuntu theme alternative
    + ubuntu/desktop_detect.patch:
      - add caching for desktop detection to avoid querying the current
        desktop env variable as iterate through the list each time. For the
        time of the Shell process, we can expect this env variable to stay
        stable.
    + ubuntu/smarter_alt_tab.patch:
      - quick alt-tab (without showing up the switcher) switch only between
        the last window of the last 2 applications to be focused instead of
        raising all windows of those apps.
    + ubuntu/lightdm-user-switching.patch:
      - Allow user switching when using LightDM.
    + ubuntu/lock_on_suspend.patch
      - Respect Ubuntu's lock-on-suspend setting.
    + ubuntu/gdm.patch
      - as gdm is system-wide and not session-wide, ensure gdm has an ubuntu
        styling by default, not impacting the gnome user session though.
    + ubuntu/background_login.patch
      - Change default background color as we modified the default GDM color
        for our ubuntu session. Change it as well here, still applying the
        background noise loading.
    + ubuntu/gdm_alternatives.patch
      - Add support for GDM3 theme alternatives
    + ubuntu/block_mode_extension_update.patch
      - Don't allow ubuntu mode extension to update
    + optional-hot-corner.patch
      - enable patch proposed by upstream developer already in package (but
        not in series) to add a settings for optional hot corner activation.
    + volume-Add-back-sound-feedback-on-scroll.patch
      - Fix regression causing missing feedback on volume slider scroll
    + st-texture-cache-Cancel-sliced-image-loading-on-target-ac.patch
      - Fix possible crash on cache loading
    + main-show-an-error-message-on-gnome-shell-crash.patch,
      global-make-possible-to-set-debug-flags-dynamically.patch,
      main-increase-the-granularity-of-backtraces-in-SHELL_DEBU.patch,
      main-add-backtrace-crashes-all-and-backtrace-all.patch,
      sessionMode-add-support-for-debugFlags-parameter.patch:
      - Improve debug JS tracing for crash reports
    + st-scroll-view-Handle-the-case-where-scrollbars-are-NULL.patch,
      st-scroll-view-Remove-scrollbars-references-on-dispose.patch:
      - Fix crash on theme changes
    + ubuntu/search-call-XUbuntuCancel-method-on-providers-when-no-dat.patch:
      - stop searches when requested from UI
    + keyboard-Do-not-call-KeyboardManager.holdKeyboard-with-se.patch:
      - Cherry-pick upstream commit to prevent focus stealing on password fields
        in firefox whe...

Read more...

Changed in gnome-shell (Ubuntu):
status: In Progress → Fix Released
Iain Lane (laney) on 2019-01-25
Changed in gnome-shell (Ubuntu Bionic):
status: New → In Progress
Changed in gnome-shell (Ubuntu Cosmic):
status: New → In Progress
Changed in gnome-shell (Ubuntu Bionic):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in gnome-shell (Ubuntu Cosmic):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
PabloAB (pabloab777) on 2019-01-26
description: updated
Edvin Rab (blackwicked) wrote :

I can confirm the issue on Ubuntu 18.10 (Cosmic) as well. I experienced that beside locking the screen, seeing the elevated prompt dialog (when the screen is dimmed) also makes the keyboard layout indicator disappear. Will be gnome-shell - version 3.30.2-2ubuntu1 available for cosmic too?

PabloAB (pabloab777) wrote :

Not sure if related: Not only the current layout indicator change after a lock but the whole indicator area. Screenshots of before/after: https://i.imgur.com/OazRcHL.png

#workaround: Restart Gnome Shell: Alt+F2 r

COBA (andreycosmos) wrote :

dpkg -s gnome-shell
Package: gnome-shell
Status: install ok installed
Priority: optional
Section: gnome
Installed-Size: 7350
Maintainer: Ubuntu Developers <email address hidden>
Architecture: amd64
Version: 3.28.3-0ubuntu0.18.04.4
Provides: notification-daemon, polkit-1-auth-agent
Depends: libatk-bridge2.0-0 (>= 2.5.3), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.14), libcairo2 (>= 1.14.0), libcanberra-gtk3-0 (>= 0.25), libcanberra0 (>= 0.2), libcroco3 (>= 0.6.2), libecal-1.2-19 (>= 3.17), libedataserver-1.2-23 (>= 3.17.2), libgcr-base-3-1 (>= 3.8.0), libgdk-pixbuf2.0-0 (>= 2.22.0), libgirepository-1.0-1 (>= 1.35.9), libgjs0-libmozjs-52-0, libgjs0g (>= 1.52.1), libglib2.0-0 (>= 2.53.0), libgstreamer1.0-0 (>= 1.4.0), libgtk-3-0 (>= 3.21.6), libical3 (>= 3.0.0), libjson-glib-1.0-0 (>= 0.13.2), libmutter-2-0 (>= 3.28.3), libnm0 (>= 1.0.0), libpango-1.0-0 (>= 1.14.0), libpangocairo-1.0-0 (>= 1.14.0), libpolkit-agent-1-0 (>= 0.99), libpolkit-gobject-1-0 (>= 0.94), libpulse-mainloop-glib0 (>= 0.99.1), libpulse0 (>= 0.99.1), libsecret-1-0 (>= 0.7), libstartup-notification0 (>= 0.11), libsystemd0, libx11-6, libxfixes3, evolution-data-server (>= 3.17.2), gir1.2-accountsservice-1.0, gir1.2-atspi-2.0 (>= 2.9.91), gir1.2-freedesktop, gir1.2-gdesktopenums-3.0 (>= 3.12), gir1.2-geoclue-2.0, gir1.2-gcr-3 (>= 3.7.5), gir1.2-gdm-1.0 (>= 3.18.2), gir1.2-glib-2.0 (>= 1.45.3), gir1.2-gnomebluetooth-1.0 (>= 3.12.0), gir1.2-gnomedesktop-3.0 (>= 3.12.0), gir1.2-gtk-3.0 (>= 3.16), gir1.2-gweather-3.0, gir1.2-ibus-1.0 (>= 1.5.2), gir1.2-mutter-2 (>= 3.27.91), gir1.2-nm-1.0, gir1.2-nma-1.0, gir1.2-pango-1.0, gir1.2-polkit-1.0, gir1.2-rsvg-2.0, gir1.2-soup-2.4 (>= 2.40.1), gir1.2-upowerglib-1.0 (>= 0.99), gjs (>= 1.47.90), gnome-settings-daemon (>= 3.16.0), gnome-shell-common (= 3.28.3-0ubuntu0.18.04.4), ubuntu-wallpapers, gsettings-desktop-schemas (>= 3.21.3), mutter (>= 3.27.91), python3, libglib2.0-bin (>= 2.53.0)
Recommends: xserver-xorg-legacy, bolt (>= 0.2), gkbd-capplet, gnome-control-center, gnome-user-guide, iio-sensor-proxy, unzip, ubuntu-session | gnome-session
Suggests: gir1.2-telepathyglib-0.12, gir1.2-telepathylogger-0.2 (>= 0.8.0), chrome-gnome-shell, gdm3 (>= 3.10.0.1-3~), gnome-themes-standard-data, switcheroo-control
Breaks: gdm3 (<< 3.19.92), gnome-session (<< 3.19)
Conflicts: gnome-screensaver (<< 3.6)
Description: graphical shell for the GNOME desktop
 The GNOME Shell provides core interface functions like switching
 windows, launching applications or see your notifications. It takes
 advantage of the capabilities of modern graphics hardware and
 introduces innovative user interface concepts to provide a
 delightful and easy to use experience. GNOME Shell is the defining
 technology of the GNOME 3 user experience.
Homepage: https://wiki.gnome.org/Projects/GnomeShell
Original-Maintainer: Debian GNOME Maintainers <email address hidden>

Hello PabloAB, or anyone else affected,

Accepted gnome-shell into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell/3.30.2-0ubuntu1.18.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-shell (Ubuntu Cosmic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Prashant Gupta (prashu20) wrote :

Hi,

will this fix be backported to Ubuntu 18.04 bionic release gnome-shell package?

Edvin Rab (blackwicked) wrote :

On Cosmic, gnome-shell version 3.30.2-0ubuntu1.18.10.1 I can't reproduce the bug anymore. I tested two known scenarios that were able to make the language layout indicator disappear:

* Locking the screen and returning
* Opening the elevation prompt (asking for admin password)

None of them are causing the issue anymore.

tags: added: verification-done verification-done-cosmic
removed: verification-needed verification-needed-cosmic
賴家亨 (laichiaheng) wrote :

Bionic needs it!

vvg (vvgnovanet) on 2019-02-03
Changed in gnome-shell (Ubuntu Cosmic):
status: Fix Committed → Confirmed
status: Confirmed → Fix Released
Alexander Mashin (alex-mashin) wrote :

Yes, I think it should be backported.

I also noticed that keyboard layout indicator is cleared not only after suspension but more often.

PabloAB (pabloab777) wrote :

Answering @sil2100 / Łukasz Zemczak, comment #17:

- I can't verify Cosmic because (as said on Description and title) I'm using Bionic.
- About links (Testing/EnableProposed QATeam/PerformingSRUVerification): tl;dr, but either way, as said, I'm using bionic. Should be a *easy and safety way* to test a certain proposed package.

PS, taking advantage of the visibility of this bug: I hope some day this awful obsolete site uses something like Gitlab!

Kleenux (kleenux) wrote :

Hello, when can we expect to get an update on 18.04?

18.04 is LTS, and all our workstations are 18.04. Next update will be 20.04.

IMHO, 18.04 should be the reference... and bugs should be fixed there first, then adapted to 18.10.

Please!

Petruhin Alexandr (razblade) wrote :

i'm checked 3.30.2-0ubuntu1.18.10.1 gnome-shell and can confirm that problem is fixed.

Kleenux,

The bug is in queue for Bionic too [1], since being an LTS there are also more checks before releasing any change.

[1] https://launchpad.net/ubuntu/bionic/+queue?queue_state=1&queue_text=gnome-shell

COBA (andreycosmos) wrote :

Where will be fixed in Ubuntu 18.04 LTS?

賴家亨 (laichiaheng) wrote :

It has been a long long time for Bionic.

hpp23 (hpp23) wrote :

Ubuntu 18.04.2 LTS, more than five weeks are now gone with this very annoying bug (that resulted from "fixing" a different bug without rigorous testing). Status: in progress. Nobody seems to bother: either Canonical, or the maintainers. Unbelievable.

hpp23,

the fix is waiting for SRU review for some weeks now
https://launchpad.net/ubuntu/bionic/+queue?queue_state=1&queue_text=gnome-shell

So we actually care of fixes, like we care about no regress in other things and so being a little conservative before releasing a new version.

hpp23 (hpp23) wrote :

Marco, thanks for your hard work, and for taking care of this.

Saveriy (saveriy) wrote :

Marco, installed your ppa and found an error. For all the time of use, the layout did not disappear.

I'm sorry, what you mean by "layout"?

Saveriy (saveriy) wrote :

Marco, sorry for my bad english)

I installed packages from ppa:ci-train-ppa-service/3597, the problem disappeared, thanks.

There is a new problem, attached a screenshot, on the right side of the window.

Prashant Gupta (prashu20) wrote :

Hello Marco,

Can you please tell how long one has to wait for approval (in case of bionic)? (a certain deadline will help no matter how far it is). This bug is very irritating.

Daniel van Vugt (vanvugt) wrote :

It appears the screenshot in comment #31 does not contain this bug. So if there's a problem there then please log a new bug.

A screenshot showing what this bug is about is at:
https://gitlab.gnome.org/GNOME/gnome-shell/issues/913
and also comment #14.

Tsvetomir Dimitrov (tdimitrov) wrote :

A temporary solution is to rollback gnome-shell gnome-shell-common to the previous versions, as described here https://askubuntu.com/a/1110089/190625. I see no major issues with these versions.

I am also disappointed with the patch not being merged in bionic. It's definitely not the 'Ubuntu way' to tackle such issues in an LTS distribution.

Łukasz Zemczak (sil2100) wrote :

Hello PabloAB, or anyone else affected,

Accepted gnome-shell into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell/3.28.3+git20190124-0ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-shell (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
removed: verification-done
PabloAB (pabloab777) wrote :

Hi Lukasz! I tried followed EnableProposed instructions ans upgraded:
  gnome-shell-common 3.28.3+git20190124-0ubuntu18.04.1
  gnome-shell 3.28.3+git20190124-0ubuntu18.04.1
Now everything seems working as expected. Well done! :)

Please be tolerant with those with a rude attitude.

tags: added: verification-done-bionic
removed: verification-needed-bionic
Prashant Gupta (prashu20) wrote :

Hi,
Enabled proposed and updated my system and the bug is fixed for me as well.
Thanks a lot everyone!!

PabloAB (pabloab777) wrote :

I added an answer to the related AskUbuntu question with easier instructions
https://askubuntu.com/a/1121203/349837

Miroslav Zaťko (mirec-z) wrote :

Still there with Ubuntu 18.10 after first lock + unlock screen. Fresh update/upgrade and restart right now:

ii gnome-shell 3.30.1-2ubuntu1.18.10.2 amd64 graphical shell for the GNOME desktop
ii gnome-shell-common 3.30.1-2ubuntu1.18.10.2 all common files for the GNOME graphical shell

mirec You are not running the latest version of gnome-shell. The latest version is 3.30.2-0ubuntu1.18.10.1

Dimtiris Grigor (lside) on 2019-03-01
Changed in gnome-shell (Ubuntu Bionic):
status: Fix Committed → Confirmed
status: Confirmed → Fix Committed

The verification of the Stable Release Update for gnome-shell has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Egor Tensin (egor-tensin) wrote :

I don't really get it, when's the fix going to be available for Bionic? I have -updates enabled, but the bug is still present on my system.

fessmage (fessmage) wrote :

Same thing.

gnome-shell/bionic-updates,now 3.28.3-0ubuntu0.18.04.4 amd64 [installed]
gnome-shell-common/bionic-updates,bionic-updates,now 3.28.3-0ubuntu0.18.04.4 all [installed]

but the bug is still here. Reboot don't help.

Daniel van Vugt (vanvugt) wrote :

fessmage,

You don't have the fix installed. The fix is in version:

  3.28.3+git20190124-0ubuntu18.04.1

(per comment #37) but is not released yet.

You can download the .debs to try the fix from:

  https://launchpad.net/ubuntu/+source/gnome-shell/3.28.3+git20190124-0ubuntu18.04.1/+build/16422548

Egor Tensin (egor-tensin) wrote :

Any info on when's that going to be released? Can't find it.

fessmage (fessmage) wrote :

@vangugt - I installed gnome-shell and gnome-shell-common from bionic-proposed and now problem fixed:
gnome-shell/bionic-proposed,now 3.28.3+git20190124-0ubuntu18.04.1 amd64 [installed]
gnome-shell-common/bionic-proposed,bionic-proposed,now 3.28.3+git20190124-0ubuntu18.04.1 all [installed]

I was confused by message from sil2100 where he claims: "The verification of the Stable Release Update for gnome-shell has completed successfully and the package has now been released to -updates."
Obviously, right now - it is not in updates, still only in proposed.

Daniel van Vugt (vanvugt) wrote :

OK that message in comment #43 was bound to cause confusion. It was actually about the fix for 18.10 (cosmic).

Snaker (snaker.me) wrote :

I installed the fix on Bionic by enabling proposed updates in settings and running Software Updater then.
Everything looks fine and the problem is solved.

But before when I tried to install via terminal gnome-shell/bionic-proposed and gnome-shell-common/bionic-proposed, it broke Gnome.

Daniel van Vugt (vanvugt) wrote :

Yes, sorry it is easy to break your package configuration :(

Maybe some safer instructions would be something like (not tested):

1. Software & Updates > Developer Options > Pre-released updates = ON
2. sudo apt update
3. sudo apt install gnome-shell
4. Software & Updates > Developer Options > Pre-released updates = OFF

tags: added: verification-done
removed: verification-needed
vvg (vvgnovanet) wrote :

Надоело ждать релиза, сегодня накатил обнову по этой инструкции - https://askubuntu.com/a/1121203/349837

Полёт нормальный языковая панель не исчезает . СПАСИБО !!!!

Egor Tensin (egor-tensin) wrote :

I still don't get it. It's been unfixed in Bionic since forever. Do I need to enable -proposed do get the fix? I thought this was risky. It's really annoying.

oganer@gmail.com (oganer) wrote :

Also confirming that after setting up checkbox in Software Updates -> Developer Options -> Pre released updates (bionic-proposed) and upgrading packages, the problem fixed.

Thank you!

Yonatan Yehezkeally (yoniy0) wrote :

I can also confirm that after following the instructions from #51 on Bionic, this bug is fixed.

(I would however comment that it would have been easy to miss that safety measure and upgrade a whole bunch of proposed packages by mistake. I would caution everyone to be more careful when directing non-developers to alter developer configurations.)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.28.3+git20190124-0ubuntu18.04.1

---------------
gnome-shell (3.28.3+git20190124-0ubuntu18.04.1) bionic; urgency=medium

  * New git snapshot release up to commit 24cdcc56d (LP: #1811900)
    - Don't fill journal with osdWindow errors (LP: #1772677)
    - Fix missing icon in keyboard indicator (LP: #1812266)
  * d/p/authPrompt-Do-not-enable-sensitivity-if-retries-are-disal.patch,
    d/p/authPrompt-Unset-preemptiveAnswer-on-reset.patch,
    d/p/gdm-util-Always-allow-to-retry-login-in-unlock-mode.patch,
    d/p/ibus-set-content-type-no-holdKeyboard.patch,
    d/p/popupMenu-Don-t-handle-key-presses-directly-if-there-are-.patch,
    d/p/st-button-Ignore-pointer-emulated-touch-events.patch,
    d/p/shell-ignore-invalid-window-monitor-index.patch,
    d/p/workspace-fix-repositioned-windows-in-activities.patch:
    - Removed patches applied upstream
  * d/p/StIcon-only-compute-shadow-pipeline-when-the-texture-is-p.patch,
    d/p/js-fix-invalid-access-errors.patch,
    d/p/js-ui-Choose-some-actors-to-cache-on-the-GPU.patch,
    d/p/optional-hot-corner.patch,
    d/p/st-texture-cache-Cancel-sliced-image-loading-on-target-ac.patch,
    d/p/workaround_crasher_fractional_scaling.patch:
    - Refreshed as per upstream changes
  * d/p/keyboard-Filter-redundant-FocusTracker-position-changed-s.patch,
    d/p/keyboard-Listen-to-IbusPanelService-focus-in-out-to-track.patch:
    - Fix OSK activation on X11 (LP: #1760399)
  * d/p/power-Label-the-PENDING_CHARGE-state-as-Not-Charging.patch:
    - Label the PENDING_CHARGE state as "Not Charging" (LP: #1745032)
  * d/p/debian/patches/volume-Add-back-sound-feedback-on-scroll.patch:
    - Add missing include (LP: #1811908)

 -- Marco Trevisan (Treviño) <email address hidden> Fri, 25 Jan 2019 18:29:40 +0000

Changed in gnome-shell (Ubuntu Bionic):
status: Fix Committed → Fix Released
fessmage (fessmage) wrote :

No, fix is not released:

gnome-shell - 3.28.3+git20190124-0ubuntu18.04.1 - package from bionic-proposed.

We are still waiting for it in bionic-updates.

hpp23 (hpp23) wrote :

I have currently installed: gnome-shell 3.28.4-0ubuntu18.04.1.
After more than five months, this bug is still in my installation of Ubuntu 18.04.2 LTS and annoys me every single day.
I am really disappointed.
Can somebody explain to me in simple language why the bug fix is still not released?

Daniel van Vugt (vanvugt) wrote :

The bug is marked as "fix released" so as far as we know the issue is closed.

If you still experience problems then please open a new bug by running:

  ubuntu-bug gnome-shell

and mention that it seems to be related to bug 1812266.

Daniel van Vugt (vanvugt) wrote :

---> bug 1834058 now

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers