Ubuntu 18.04's ibus package breaks password fields in Firefox (by lowering & raising window whenever they're focused)

Bug #1765304 reported by Daniel Holbert on 2018-04-19
242
This bug affects 46 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
High
Olivier Tilloy
Bionic
High
Olivier Tilloy
Cosmic
Undecided
Olivier Tilloy
ibus (Ubuntu)
Undecided
Unassigned
Cosmic
Undecided
Unassigned

Bug Description

https://gitlab.gnome.org/GNOME/gnome-shell/issues/391

---

tl;dr: starting in Ubuntu 18.04, "ibus" seems to lower and raise Firefox, whenever the user tries to focus an <input type="password"> field on a web page. This is not a regression in Firefox, as the same Firefox version runs just fine in Ubuntu 17.10 -- it seems to be a bug in ibus, because it only happens (in 18.04) when the environmental variable GTK_IM_MODULE is at its default value (which is "ibus"). It had this same value in 17.10 but the bug didn't happen there; hence, I'm guessing there was a change in ibus (or a related package) that caused this breakage / lowering+raising.

This is pretty bad, because in some cases, the focus-loss can mean users are simply unable to fill in password fields that previously were working fine. (see "ACTUAL RESULTS" below)

STEPS TO REPRODUCE #1, via "BitWarden" Firefox extension:
=========================================================
 1. Start Firefox. (fresh profile if you like)
 2. Install BitWarden from https://addons.mozilla.org/en-US/firefox/addon/bitwarden-password-manager/
 3. Click the BitWarden toolbar icon to spawn a menu-pane.
 4. Click "Log in" at the bottom of that pane.
 5. Click the "Master Password" field.

ACTUAL RESULTS:
 The menu pane disappears as soon as the Master Password field receives focus.
EXPECTED RESULTS:
 I should be able to type in a password; pane shouldn't disappear.

STEPS TO REPRODUCE #2, via Reddit:
=================================
 1. Visit https://www.reddit.com/r/firefox/ (or any reddit page)
 2. Click "Log in or sign up in seconds" at the extreme upper right of the page.
      (click the "Log in" part of that sentence)
 3. Try to click the password field (or "tab" into it) and type in some text.

ACTUAL RESULTS:
 Try as you might, the password field never receives focus.
EXPECTED RESULTS:
 Password field should accept focus & let me type text into it.

If I run firefox from the command line with env var GTK_IM_MODULE="", then I get "expected results". But with the default value of that env var, I get "actual results" (broken behavior, unable to enter passwords).

I initially reported this in Firefox, here: https://bugzilla.mozilla.org/show_bug.cgi?id=1451466 (with a few dependent bugs for the usage-specific STR quoted above). But I think it's a bug in ibus, hence filing here now.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ibus 1.5.17-3ubuntu3
ProcVersionSignature: Ubuntu 4.15.0-15.16-generic 4.15.15
Uname: Linux 4.15.0-15-generic x86_64
ApportVersion: 2.20.9-0ubuntu5
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Wed Apr 18 23:22:05 2018
InstallationDate: Installed on 2018-04-17 (1 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180416)
SourcePackage: ibus
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Daniel Holbert (dholbert) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, Ubuntu is not upstream for ibus so the bug might be better placed on https://github.com/ibus/ibus/issues instead.

So you only get the issue if GTK_IM_MODULE=ibus? What happens if you "unset GTK_IM_MODULE" and start firefox?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ibus (Ubuntu):
status: New → Confirmed
Daniel Holbert (dholbert) wrote :

> the bug might be better placed on https://github.com/ibus/ibus/issues instead.

Thanks -- I'll file an issue there, too, later today. (I wish I knew how to test old ibus builds & bisect between them so that I could extra-confirm that it was an ibus change that broke this, and perhaps bisect to find out which change...)

> So you only get the issue if GTK_IM_MODULE=ibus?

Correct. (And unfortunately, that's the default value. So I "only" get it by default. :))

> What happens if you "unset GTK_IM_MODULE" and start firefox?

Then the issue does not happen.

Daniel Holbert (dholbert) wrote :

As noted on the github issue, Fedora doesn't seem to be affected at all (when testing the same ibus/mutter/Firefox versions as in Ubuntu). So this is seeming to be Ubuntu-specific, fortunately/unfortunately...

John Ingve Olsen (raytar) wrote :

I have tried building ibus 1.5.7 without the ubuntu patches, which did not solve the problem. I have also tried building ibus 1.5.8 from debian and that did not solve the problem either.

John Ingve Olsen (raytar) wrote :

1.5.17 and 1.5.18, sorry

John Ingve Olsen (raytar) wrote :

Adding "ibus-xx-f19-password.patch" (See attachments) fixes the problem.

Sebastien Bacher (seb128) wrote :

Thanks, where is that patch coming from? It doesn't make much sense since it's adding code for gtk 3.6 which is not the version we are using...

John Ingve Olsen (raytar) wrote :

It's from Fedora 19. It was also included in Ubuntu 17.10's ibus package. For some reason it was removed from debian in ibus 1.5.17-2: https://salsa.debian.org/debian/ibus/commit/097e35c350edf76015c637c26ef637d80191052d

The attachment "ibus-xx-f19-password.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Sebastien Bacher (seb128) wrote :

The patch was disabled 3 years ago
https://salsa.debian.org/debian/ibus/commit/64efddf9

it's a workaround for gtk 3.6 which is years old, it doesn't make any sense that this patch would be the solution to an issue on current ubuntu

John Ingve Olsen (raytar) wrote :

Well, enabling the patch on 18.04 fixed the issue for me. I also tried to disable the same patch on 17.10 and that introduced the issue there too.

In reply to comment 11:

> It doesn't make much sense since it's adding code for gtk 3.6 which is not the version we are using...

It's adding code for GTK versions 3.6 and newer.
https://developer.gnome.org/gtk3/stable/gtk3-Feature-Test-Macros.html#GTK-CHECK-VERSION:CAPS

I don't know why it is limited to newer GTK 3 versions because input-purpose is not documented as newer than GTK version 3.0
https://developer.gnome.org/gtk3/stable/GtkIMContext.html#GtkIMContext--input-purpose

If this file is compiled for GTK version 2, however, (as implied by the filename and other version checks) then some compile-time check will be required.

In reply to comment 13:

> it's a workaround for gtk 3.6 which is years old

I don't know of any reason to suspect this was intended for 3.6 only.

I don't know why passwords should be special, but it looks like a better (or at least more general) test than the IS_ENTRY heuristic below
https://github.com/ibus/ibus/blob/master/client/gtk2/ibusimcontext.c#L900

Sebastien Bacher (seb128) wrote :

You are right about the macro including new versions, that at least explains why it makes a difference.

Then that patch was dropped 3 years ago in Debian and in fedora:
https://src.fedoraproject.org/cgit/rpms/ibus.git/tree/ibus.spec#n715

It's unclear why it would need to be restored now. It looks like an upstream issue that needs proper debugging/resolving

Diep Pham (favadi) wrote :

Should we just ask author of https://salsa.debian.org/debian/ibus/commit/097e35c350edf76015c637c26ef637d80191052d commit to know the reason why the ibus-xx-f19-password.patch is removed? As I see from this comment in ibus' github page: https://github.com/ibus/ibus/issues/2002#issuecomment-386537208, @Raytar told that the problem will happen in Ubuntu 17.10 too with the patch removed. So, I think there is no harm apply the patch to mitigate the problem temporarily?

Diep Pham (favadi) wrote :

I rebuild the ibus-gtk3 package myself and it seems to work fine so far: https://bugzilla.mozilla.org/show_bug.cgi?id=1405634#c16.

Diep Pham (favadi) wrote :

Hello guys, is there any news on this problem? If no one has the time to

> It looks like an upstream issue that needs proper debugging/resolving

Should we just reapply the patch to make Firefox usable for now?

Andrew Beyer (beyera) wrote :

We have multiple [1Password X](https://support.1password.com/getting-started-1password-x/) users who are unable to unlock 1Password due to this issue on Ubuntu 18.04.

I have a [temporary post on our discussion form](https://discussions.agilebits.com/discussion/90011/p1) advising our users on this issue, but we hope for a timely fix. Thanks to everyone helping to get this resolved.

Diep Pham (favadi) wrote :

@seb128 could you advice on next step to resolve this bug?

Pedro Palhares (pdimh) wrote :

is there a problem if i run firefox with GTK_IM_MODULE unset? On one of my machines, firefox is unusable.

calvin (jcalvin) wrote :

On Ubuntu 18.04 the problem is solved if you installed the available package by clicking the link below
https://bugzilla.mozilla.org/attachment.cgi?id=8974077
Here is the origin of the .deb
https://bugzilla.mozilla.org/show_bug.cgi?id=1405634

Olivier Tilloy (osomon) wrote :

So it looks like debian/patches/ibus-xx-f19-password.patch was dropped in version 1.5.17-2 in debian (https://git.launchpad.net/ubuntu/+source/ibus/commit/?id=e5815f7d548f064d4a28044f0a5240723e280bf5), and restoring that patch fixes the issue.

Olivier Tilloy (osomon) wrote :

I should have read all the comments before posting, I didn't realize that this patch is supposedly not relevant any longer. Looks like this is a red herring, we need to get to the bottom of this.

Alex Murray (alexmurray) wrote :

Seems this is an issue with gnome-shell: https://gitlab.gnome.org/GNOME/gnome-shell/issues/391

I have rebuilt gnome-shell with the patch from that upstream issue and it resolves this for me - if anyone wants to test I've put it in the following PPA (I just uploaded it so it will take a while to build):

https://launchpad.net/~alexmurray/+archive/ubuntu/lp1765304

George (gapop) wrote :

Me too. Updating gnome-shell from your PPA solves the problem.

Thanks for the update!

George (gapop) wrote :

@alexmurray: I am not sure, but I think that using gnome-shell from your PPA introduced a bug with icons disappearing from the Gnome top panel right-side icon set, specifically, the keyboard layout indicator/switcher.

For now, I have removed the PPA, reverted the gnome-shell version, and I am using the XIM input method as a workaround for this bug. The disappearing icon issue seems to have been resolved.

Diep Pham (favadi) wrote :

@seb128 so we have 2 options:

- reapply the ibus-xx-f19-password.patch to ibus package
- backport the gnome-shell patch: https://gitlab.gnome.org/GNOME/gnome-shell/issues/391.

What do you think we should do?

Rolf Kutz (vzsze) wrote :

I'm affected by this bug. It breaks password changes in Nextcloud and other websites. Is there any resolution to this bug?

augusto_hp (augusto-hp) wrote :

> I'm affected by this bug. It breaks password changes in Nextcloud and other websites.
> Is there any resolution to this bug?

There is a fixed version of 'ibus-gtk3' packaged as a '.deb' (you can install) available on Firefox's bug page: https://bugzilla.mozilla.org/show_bug.cgi?id=1405634

Diep Pham (favadi) wrote :

I attach the debdiff output with the ibus-xx-f19-password.patch reapplied in case anyone wants to rebuild the package or the package maintainer wants to pick it up.

Jim Campbell (jwcampbell) wrote :

The patch to resolve this bug was just accepted to upstream gnome-shell master: see https - gitlab.gnome dot org/GNOME/gnome-shell/merge_requests/140 (For some reason launchpad is not letting me submit a comment with a URL).

Might it be possible to back-port this patch to GNOME Shell 3.28 for Bionic?

Jim Campbell (jwcampbell) wrote :

I've added a similar comment / request on this related launchpad bug: https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1794655

Olivier Tilloy (osomon) wrote :

Similar issue (itself with duplicate reports): bug #1803631.

Olivier Tilloy (osomon) wrote :

Another possibly related issue: bug #1762726 (Context menu does not show on passwords fields).

lsmith (smith-pooteeweet) wrote :

yes, please backport to bionic. thx

Behrang (behrangsa) wrote :
Adolfo Jayme (fitojb) on 2018-11-25
Changed in gnome-shell (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in ibus (Ubuntu):
status: Confirmed → Invalid
Daniel van Vugt (vanvugt) wrote :

For the record: The fix (https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/140) is committed to gnome-shell master, and is included in gnome-shell version 3.31.2 only, for now.

description: updated
Olivier Tilloy (osomon) on 2018-11-27
no longer affects: ibus (Ubuntu Bionic)
Olivier Tilloy (osomon) wrote :

I rebuilt gnome-shell for bionic with https://gitlab.gnome.org/GNOME/gnome-shell/commit/551e827841626cd8084daa2210b3bf60e5be96be.patch applied, and I confirm this fixes the password fields focus issues in firefox (tested several test cases from duplicate reports).

Changed in gnome-shell (Ubuntu Bionic):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu Bionic):
status: New → Confirmed

Ubuntu, please backport the fix from gnome-shell to Bionic, it will help many users.

Meanwhile, I switched to Wayland which doesn't show the issue and plugins in Firefox work without problems.

Daniel van Vugt (vanvugt) wrote :

The fix would have to be released into 19.04 first at least, and maybe 18.10 too, before backporting to 18.04.

Olivier Tilloy (osomon) wrote :

From duplicate bug #1795169, this issue appears to be affecting bionic only, not cosmic (and I assume not disco either, although I haven't tested there).

Iain Lane (laney) wrote :

I'm uploading to all supported releases, to be safe and to satisfy the SRU process (trying to minimise the possibility of regressing the bug).

For cosmic, suggest running through the testcase and making sure it still works.

At the time of writing, there's currently a gnome-shell verified for release in cosmic-proposed; please don't clobber that if it's still there when this upload is reviewed.

Changed in gnome-shell (Ubuntu Cosmic):
status: New → In Progress
Changed in gnome-shell (Ubuntu Bionic):
status: Confirmed → In Progress
Changed in gnome-shell (Ubuntu):
status: Triaged → Fix Committed
assignee: nobody → Olivier Tilloy (osomon)
Changed in gnome-shell (Ubuntu Bionic):
assignee: nobody → Olivier Tilloy (osomon)
Changed in gnome-shell (Ubuntu Cosmic):
assignee: nobody → Olivier Tilloy (osomon)
Changed in ibus (Ubuntu Cosmic):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.30.1-2ubuntu3

---------------
gnome-shell (3.30.1-2ubuntu3) disco; urgency=medium

  * Cherry-pick upstream commit to prevent focus stealing on password fields
    in firefox when ibus is used (LP: #1765304)

 -- Iain Lane <email address hidden> Wed, 05 Dec 2018 12:53:32 +0000

Changed in gnome-shell (Ubuntu):
status: Fix Committed → Fix Released

Hello Daniel, or anyone else affected,

Accepted gnome-shell into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell/3.28.3-0ubuntu0.18.04.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-shell (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Olivier Tilloy (osomon) wrote :

I installed gnome-shell 3.28.3-0ubuntu0.18.04.4 from bionic-proposed in a fully up-to-date bionic VM (amd64) and verified that after restarting the shell (Alt+F2, r), the problem with password fields in firefox is gone.

I used the instructions in duplicate bug #1795169 for testing, as they don't involve installing an extension, and test case #2 in this bug report (which involves reddit login page) doesn't exhibit the problem any longer.

tags: added: verification-done-bionic
removed: verification-needed-bionic
Daniel Holbert (dholbert) wrote :

The fix seems good to me!

My verification steps:

 - I verified that I could still reproduce the issues in the first post here, in a stock Ubuntu 18.04.1 installation in a VM (all package at their "freshly installed" version, including Firefox).
 - In doing this, I tested both scenarios from the original comment here -- (1) the BitWarden extension and (2) "old" reddit ( https://old.reddit.com/r/firefox/ -- note that a slightly different URL is now needed to get the page that I was referencing in the original report here.)
 - Then, I installed these 2 packages:
https://launchpad.net/ubuntu/+source/gnome-shell/3.28.3-0ubuntu0.18.04.4/+build/15764981/+files/gnome-shell-common_3.28.3-0ubuntu0.18.04.4_all.deb
https://launchpad.net/ubuntu/+source/gnome-shell/3.28.3-0ubuntu0.18.04.4/+build/15764981/+files/gnome-shell_3.28.3-0ubuntu0.18.04.4_amd64.deb
...and ran "sudo apt --fix-broken install" to get a mutter update that gnome-shell required, and I rebooted, and retested BitWarden and "old reddit", and they were fixed!

After read your mail, I installed gnome-shell from bionic-proposed and
also the problem is gone, after restarting.
Thankyou very much for your time

El 12/12/18 a las 15:54, Olivier Tilloy escribió:
> I installed gnome-shell 3.28.3-0ubuntu0.18.04.4 from bionic-proposed in
> a fully up-to-date bionic VM (amd64) and verified that after restarting
> the shell (Alt+F2, r), the problem with password fields in firefox is
> gone.
>
> I used the instructions in duplicate bug #1795169 for testing, as they
> don't involve installing an extension, and test case #2 in this bug
> report (which involves reddit login page) doesn't exhibit the problem
> any longer.
>
> ** Tags removed: verification-needed-bionic
> ** Tags added: verification-done-bionic
>
>

Tony Partridge (tlpartridge) wrote :

Confirmed fixed with live ubuntu, working with gnome-shell 3.28.3-0ubuntu0.18.04.4 from bionic-proposed. Thanks guys, was a pesky bug.

Hello Daniel, or anyone else affected,

Accepted gnome-shell into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell/3.30.1-2ubuntu1.18.10.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-shell (Ubuntu Cosmic):
status: In Progress → Fix Committed
tags: added: verification-needed-cosmic
Daniel Holbert (dholbert) wrote :

Hi Brian. I have been running Cosmic (Ubuntu 18.10) as my main OS since its release, and I don't think I've ever actually hit the bug on Cosmic.

(I just verified that I have the GTK_IM_MODULE=ibus variable set, too. So I think I would be hitting this bug, if Cosmic were affected.)

So, my assumption has been that Cosmic has a newer snapshot of gnome-shell or ibus or some other involved package which has changed in some way to avoid the bug.

All of which is to say: based on my experience at least, the update from comment #52 here isn't necessary to fix this bug in Cosmic (but perhaps it's still valuable to keep pace with upstream, or something like that).

Daniel Holbert (dholbert) wrote :

(My experience [of Cosmic being unaffected] seems to match what was reported in comment 44 ( https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/1765304/comments/44 ), too.)

Olivier Tilloy (osomon) wrote :

Thanks for testing and the feedback Daniel. You're right, cosmic is not visibly affected by the bug, nevertheless the fix was backported there too to satisfy the SRU process (see comment #45). So what should really be tested is that this doesn't introduce regressions.

Joe (jromma) wrote :

Install gnome-shell 3.28.3-0ubuntu0.18.04.4 from the -proposed repo fixed the problem for me! Running Ubuntu 18.04. Thanks for the fix!

$ apt list gnome-shell
Listing... Done
gnome-shell/now 3.28.3-0ubuntu0.18.04.4 amd64 [installed,local]

Felipe Castillo (fcastillo.ec) wrote :

Any news when this fix is going to reach bionic-updates? I don't want to deal with enabling -proposed even if I can install a single package from it.
This comment (https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/1765304/comments/52) said it'll take 7 days after being in -proposed before it can go into -updates, that was December 11.
I know it's close to holidays and that might be the reason why it's taking longer, otherwise, I just want to understand more how packages more from one repo to the other

Daniel Holbert (dholbert) wrote :

RE cosmic (replying to https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/1765304/comments/52 and https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/1765304/comments/55 ):

I've installed the proposed gnome-shell-common and gnome-shell package updates, and I don't see any issues so far (after a reboot and starting Firefox and interacting with Bitwarden).

So: cosmic still unaffected, and no regressions that I've seen yet, and I'll report back if I do notice anything odd.

Benjamin Ralston (lordrahl007) wrote :

Installed gnome-shell 3.28.3-0ubuntu0.18.04.4 from bionic-proposed.
Confirmed problem is fixed!

Joel DeTeves (joeldeteves) wrote :

+1 for gnome-shell 3.28.3-0ubuntu0.18.04.4 bionic-proposed - fixed for me

Łukasz Zemczak (sil2100) wrote :

Seeing that no reports have been sent so far, I consider Daniel's sanity-check in comment #58 as a sufficient verification for cosmic.

tags: added: verification-done verification-done-cosmic
removed: verification-needed verification-needed-cosmic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.30.1-2ubuntu1.18.10.2

---------------
gnome-shell (3.30.1-2ubuntu1.18.10.2) cosmic; urgency=medium

  * debian/gbp.conf: Specify the right packaging branch
  * Cherry-pick upstream commit to prevent focus stealing on password fields
    in firefox when ibus is used (cherry picked from commit
    0e23c400f52cfcfbfa23e8d0097b5835d688e1c0) (LP: #1765304)

 -- Iain Lane <email address hidden> Wed, 05 Dec 2018 13:06:37 +0000

Changed in gnome-shell (Ubuntu Cosmic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-shell has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.28.3-0ubuntu0.18.04.4

---------------
gnome-shell (3.28.3-0ubuntu0.18.04.4) bionic; urgency=medium

  * debian/patches/ibus-set-content-type-no-holdKeyboard.patch:
    - Cherry-pick upstream commit to prevent focus stealing on password fields
      in firefox when ibus is used (LP: #1765304)

 -- Olivier Tilloy <email address hidden> Wed, 05 Dec 2018 13:08:10 +0000

Changed in gnome-shell (Ubuntu Bionic):
status: Fix Committed → Fix Released
Eugene Romanenko (eros2) wrote :

With this update was landed in bionic, layout indicator issue arisen:

After screen unlock, layout indicator doesn't show layout letters (en, ru, etc).
See attached pic.
Also, when clicked to layout indicator, in drop down menu no layout selected with dot.
Layout letters appears after switching layout or switching windows.

Christopher Smith (r-chris-0) wrote :

Hmm, I did notice something looked a bit weird up there. But now that you mention it I do see the same issue on my thing too (see screenshot).

Daniel van Vugt (vanvugt) wrote :

This bug is now closed. Please report further issues as new bugs.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.