New Lucid keyboard layout indicator does not indicate current layout

Reported by Oded Arbel on 2010-03-03
144
This bug affects 29 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon
Unknown
Wishlist
gnome-settings-daemon (Ubuntu)
Medium
Unassigned
Lucid
Medium
Jan Arne Petersen

Bug Description

Binary package hint: gnome-settings-daemon

After the Lucid update today, the keyboard layout indicator has moved from the notification area (system tray) to the "indicator applet", and now no longer shows which layout is currently selected - it only shows an icon of a keyboard.

By clicking on the icon and selected "Groups" I can see (and change) the currently used layout, but its very not visible.

The new layout indicator also relates or obsoletes bug #513152 and bug #519372.

Oded Arbel (oded-geek) on 2010-03-03
description: updated
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, not sure if that's a bug or a design decision, is it useful to show the active layout it should be easy to notice what layout is being used while typing

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Wishlist
Nikola Yanev (gericom) wrote :

confirmed here too.

Affects me too - no current layout displayed.
...keyboard.indicator.showFlags do not work either.

Sebastien Bacher (seb128) wrote :

Jan could you have a look at this? Does the indicator-application api limit to icons use?

Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → Jan Arne Petersen (jpetersen)
Martin Pitt (pitti) wrote :

This is a regression, not a wishlist item. It makes the indicator pretty useless when using key combos to change the layout, or to merely see what the current layout _is_.

Changed in gnome-settings-daemon (Ubuntu):
importance: Wishlist → Medium
status: New → Triaged
Martin Pitt (pitti) on 2010-03-03
Changed in gnome-settings-daemon (Ubuntu):
milestone: none → ubuntu-10.04-beta-1
tags: added: indicator-application regression-potential
Jan Arne Petersen (jpetersen) wrote :

We need bug 522153 in indicator-application implemented for that.

Jorge O. Castro (jorge) wrote :

Jan,

As discussed in IRC let's just revert this portion of g-s-d back since it's a regression.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 2.29.91.1-0ubuntu4

---------------
gnome-settings-daemon (2.29.91.1-0ubuntu4) lucid; urgency=low

  * debian/patches/06_use_application_indicator.patch:
    - update by Jan Arne Petersen to undo the keyboard indicator change since
      the current indicator-application doesn't allow to use a label, which
      would be required to indicate the selected keyboard layout
      (lp: #531173, #531290, #531296)
  * debian/patches/90_autoreconf.patch:
    - refreshed for the previous change
 -- Sebastien Bacher <email address hidden> Wed, 03 Mar 2010 21:39:12 +0100

Changed in gnome-settings-daemon (Ubuntu Lucid):
status: Triaged → Fix Released
axx (axx) wrote :

On an up to date version of Lucid Lynx beta I still have this problem.
I have a text description of my layout in the notification area, but it stays on "Fra" when I switch between different versions of the French layout (in my case azerty and bépo dvorak), rendering it useless as looking at the indicator won't tell me layout the keyboard is in.

If I add another language layout (say USA) then the indicatior does switch between one language and the other, going from Fra to USA, but still fails to go from Fra to Fra2 to USA.

On a side note, on-hover bubble info shows the proper info about the layout.

Oded Arbel (oded-geek) wrote :

aax: I'd like to note that the keyboard indicator have never indicated the different between two different variants of the same layout.

Worse - the behavior you describe is an improvement over Karmic , as in Karmic if I set up my keyboard preferences to have both "Israeli Lyx" and "Israeli Phonetic" enabled then the keyboard indicator only allows me to switch between "USA" and "Isr" - there is no third option.

That being said, your above comment is very important as when the keyboard indicator would eventually migrate to the indicator applet (I assume that this is the general idea) then your point can be taken into account - not only should the keyboard indicator indicate the language of the layout, it should also indicate the variant.

axx (axx) wrote :

I'm sorry Oded but I disagree, I've been using the keyboard indicator applet for quite some time prior to moving to Lucid beta, and I had "Fra" when on my default French setting and "Fra²" when on my other French setting.
I agree the indicator didn't say "Fra (alternative)" and "Fra (bepo)", but it did give me an indication of the fact that separate variants of the French keyboard were in use.

In Karmic, and Jaunty etc. before that, clicking on the applet switched from Fra to Fra² and then to USA if I had a third layout installed.
I'm 99% sure about this.
I even had a bug every now and then back then where the switching pattern use to become Fra > Fra² > ?? > ??² > Fra > …
So it would circulate through all the available layouts regardless of language.

But anyway, I think we all agree that the indicator needs to tell us about what actual layout is in use, and not just what language the layout is designed for.

And if, from what I gather, the indication was supposed to be done graphically (via a country flag I suppose), there should be an option to have the basic Fra or USA letters, and not a flag. Not all of us want to see a brightly coloured item in our gnome panels. :)

Oded Arbel (oded-geek) wrote :

Axx: you are correct - I tried that again with another login and it worked as you said. There is apparently something wrong with my user account that won't let me change the layouts available in the keyboard indicator, but this is another bug (if its a but).

Changed in gnome-settings-daemon:
status: Unknown → New
Peter Belew (peterbe) wrote :

I just subscribed to this bug because I just noticed the behavior in the keyboard indicator - it no longer displays different icons for variants of the same country layout, as for USA, USA1, USA2. This change must have occurred in the past few weeks, as I have been using alternate US layouts for different languages for many years. Typically I have the basic USA layout and a couple of different alternate USA layouts, switching to the basic one when I'm typing in English.

On some systems, you can set up the scroll lock LED to show alternate layouts, but that's not of great use when there are 3 or more layouts set up. Also, on my Dell netbook there is no scroll lock flag in the hardware or software, so that doesn't work. And it has no LEDs, so I would have to set up the Lock Keys Applet, which in fact doesn't show the nonexistent scroll lock flag.

Peter Belew (peterbe) wrote :

Note that I just observed this today, in the released Lucid, updated up to today, both on systems which had been installed during the alpha and beta stages and on one which was installed afresh on 3 May 2010.

Peter Belew (peterbe) wrote :

Karmic, up through any current updates, uses icons with numeric subscripts indicating variants of the basic keyboards for a language. Eliminating that feature (actually in a redesigned program) is a definite regression.

By the way, I designed the original US-International layout for Windows 2.11 in 1987, for Olivetti and Microsoft. This was redesigned the next year for Windows 3.0, with the advice of a Nokia engineer, to provide Nordic language support. Visually indicating variant keyboard selections has been an issue ever since. Recent XP versions use one icon or other indicator to indicate the base language, and another to show variants, when more than one variant is enabled.

Also XP provides a keyboard switching option something like control-shift+number key to select various layouts, instead of toggling or cycling through the enabled combinations. It's too easy otherwise to enable the wrong keyboard, without the icon showing definitely which layout is being used - this leads to confusion and typos.

There is a KDE keyboard indicator program, which I haven't tried - it apparently has user-configurable icons. I don't know if that covers this situation.

Sebastien Bacher (seb128) wrote :

the new comment is bug #546240

Peter Belew (peterbe) wrote :

Thank you, Sebastien, I just subscribed to bug #546240

Oded Arbel (oded-geek) wrote :

This is happening again in Maverick.

After the update yesterday the keyboard indicator started behaving again like it was during Lucid beta. My system is setup with two keyboard layouts, en-US and il-lyx, but from looking at the attached screenshot you wouldn't know that.

Changed in gnome-settings-daemon:
status: New → In Progress
Changed in gnome-settings-daemon:
importance: Unknown → Wishlist

Wishlist? Are you stupid? This one is critical.

Oded Arbel (oded-geek) wrote :

The problem I have in comment #19 may not be the same problem as the bug that was reported: with the session indicator applet, the keyboard session indicator shows both the keyboard layout and the keyboard icon (also bad, if you ask me, as it means it takes even more space in the crowded panel).

The screenshot in comment #19 is the original standard keyboard indicator that you see from gnome-settings-daemon when there is no session indicator. That in Maverick shows only the keyboard icon.

The "wishlist" thing above is from the GNOME upstream bug that is about getting gnome-settings-daemon to support the session indicator. It is a wishlist, at least from GNOME's perspective (as no one other then Ubuntu ships the session indicator).

Rich Wales (richw) wrote :

I installed a set of flag icons (us.png, etc.) in ~/.icons/flags, and I enabled /desktop/gnome/peripherals/keyboard/indicator/showFlags in gconf-editor, but this did no good — in fact, it made the static "keyboard" icon go away entirely (replaced with a generic "I can't find any icon to display here" placeholder).

I'm seeing this error in Maverick beta. The layout indicator (including using flags as described above) works perfectly for me in Lucid. It's a regression, not a "wishlist" item, since the layout indicator feature worked previously but is now broken.

I don't know why the fix that was reportedly released didn't fix the problem on my Maverick beta system, but it didn't.

"aptitude show gnome-settings-daemon" on my Maverick beta system reports version 2.32.0-0ubuntu1.

Rich Wales (richw) wrote :

Just on a wild guess, I launched "Add to Panel" and added the "Indicator Applet" — and a US flag (corresponding to my currently active keyboard layout) showed up in the panel along the top of the screen.

Although (re-)adding the indicator applet seems to have fixed the problem, there is still the question of why the indicator applet became broken in the first place.

Oded Arbel (oded-geek) wrote :

Rich: the problem is that the gnome-settings-daemon shows a keyboard indicator applet on the panel when the Ubuntu-specific "indicator applet" isn't shown.

As I've noted in comment #21, The gnome-settings-daemon keyboard indicator does not indicate the layout - it just shows a keyboard icon and you actually have to open it to figure out what layout is being used. The Ubuntu specific indicator applet that uses a menu system to show icons for "activities" (*) works correctly, but this bug report is not about the "indicator applet", its about the gnome-settings-daemon keyboard applet.

(*) which is a weird distinction - I understand how copying files is an activity and possibly how being connected to the network in activity, but I don't see how having a volume control or a keyboard layout control is an activity.

Rich Wales (richw) wrote :

From the perspective of a naive (or not-so-naive) Ubuntu user who is probably not aware of exactly which software component is doing which keyboard layout-related task, all they will notice is that the indicator icon breaks when they "upgrade" to Maverick.

If there is some reason why the Lucid indicator applet can't be transparently upgraded and must instead be reinstalled in Maverick, this needs to be clearly documented (or, better, fixed).

Oded Arbel (oded-geek) wrote :

Rich: obviously you are correct. I was simply noting the exact technical nature of the issue so the developers will have a good understanding of how to fix this.

One more piece of technical information though: When using GNOME shell instead of metacity, the panel apparently uses the gnome-settings applet so under that the keyboard layout indicator always does not indicate layout, and there is no work around for that as the Ubuntu application indicator does not work under GNOME shell.

Oded Arbel (oded-geek) wrote :

I've opened GNOME bug https://bugzilla.gnome.org/show_bug.cgi?id=631694 which is just about the gnome-settings-daemon applet not working properly.

> which is just about the gnome-settings-daemon applet not working properly.
They say it's ubuntu problem

2010/10/9 Oded Arbel <email address hidden>

> I've opened GNOME bug https://bugzilla.gnome.org/show_bug.cgi?id=631694
> which is just about the gnome-settings-daemon applet not working
> properly.
>
> ** Bug watch added: GNOME Bug Tracker #631694
> https://bugzilla.gnome.org/show_bug.cgi?id=631694
>
> --
> New Lucid keyboard layout indicator does not indicate current layout
> https://bugs.launchpad.net/bugs/531173
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (531157).
>

Changed in gnome-settings-daemon (Ubuntu):
assignee: Jan Arne Petersen (jpetersen) → Swizzl (c-root-r-mail-ru)
assignee: Swizzl (c-root-r-mail-ru) → nobody
Zubrania (dzmitryj) wrote :

have the applet missing

Changed in gnome-settings-daemon:
status: In Progress → Unknown
Oded Arbel (oded-geek) wrote :

Ping for developers - this is still a problem in Natty.

I understand that Ubuntu may not be interested in supporting non-indicator behavior, but the problem is caused by the indicator support patch developed by Ubuntu developers and it seriously hurts multi-language Ubuntu users that choose to stop using the default indicator applet - so I think the people causing the problem have a moral obligation to make sure their changes do not cause regressions with existing uses.

As a further note - the GNOME decision not to include the indicator support patch in their upstream simply on the basis that GNOME does not ship the indicator applet is arrogant and annoying, but even otherwise they would have probably not accepted the patch anyway if it causes regressions. If Ubuntu developers have any hope of ever pushing the patch upstream they should fix this issue.

Peter Belew (peterbe) wrote :

This problem has popped up over and over again with almost every Ubuntu release. It largely affects people who deal with a number of languages using the Latin character set, but are used to the US keyboard. I think there may be other variant keyboards for which subscripts would be useful, but I'm not sure. This is a convention adopted in MS-Windows many years ago.

BTW I created the first US-International keyboard layout for MS-Windows in 1987, and it soon needed to be expanded. It's pretty hard to devise a layout of that sort to handle ALL the European languages without making its use very cumbersome - that's why there are 3 or 4 variants other than the standard US keyboard. It's necessary for the user to know which one has been selected. The trick of enabling a popup showing the layout by right-clicking on the icon works, but it takes up screen space, which for example is limited in the first place on a netbook.

Oded Arbel (oded-geek) wrote :

Showing the selected keyboard layout with a popup is a serious usability regression from the previous behavior - instead of simply looking up to verify that you switched to the correct layout, you'd have to move your mouse over to a small area (and not even in a corner so Fitt's law does not apply); and worse - you'd have to click the small target?

That basically means that the operation of "changing the layout and verifying that it is what you want" - that multi-lingual people do many times in the course of writing a single document - goes from about 0.5 a second to 15 or even 20 seconds!

Note: all this is fine, and you know what - its even fine for Ubuntu developers to ignore it (it is open source after all, I'm sure they'll apply a patch I send to fix this), but the thing is - as it is documented on several other gnome-settings-daemon bugs - the keyboard layout indicator support isn't working either!

I don't need all these indicator-applets icons like mail/empathy/gwibber, bluetooth, and volume stuff. (I don't used Evolution because it sucks, empathy has simple notification icon, I don't use social networks crap, I don't use bluetooth devices, and gnome-volume-applet 'just works'). If you don't want us to use standard well-known g-s-d keyboard applet, could you please provide us with a solution on how to remove all these unneeded icons from the panel?

Oded Arbel (oded-geek) wrote :

Booxter: this issue is not about the indicator applet, so I suggest you file a different bug on that (though I believe there already is one). That being said - simple tip: If you don't like the indicator applet, just remove it.

Peter Belew (peterbe) wrote :

I don't particularly like the concept of the indicator applet OR the "notification area" - similar concepts, lumping together several applets; I'd rather just add these things individually and arrange them individually.

BUT: this bug is about the keyboard indicator specifically, which has lost a capability which existed in previous versions and is useful and even essential to a number of people doing multilingual work. It works fine in Lucid and Maverick, and I make use of it frequently.

Peter Belew (peterbe) wrote :

At any rate, this appears to be fixed in Lucid, Karmic, and the current Natty alpha version. I can see the various USA keyboard versions indicated, like USA, USA1 USA2 etc.

Arie Skliarouk (skliarie) wrote :

Recently upgraded 11.04 to 10.04. The user prefers to stay with gnome-classic instead of Unity.
The keyboard applet in gnome-classic does not show the current layout, just as described in the bug's description.

Arie Skliarouk (skliarie) wrote :

Sorry, in my previous post I meant upgraded 11.04 to 11.10. Pity the comments can't be edited...

Bob Bib (bobbib) wrote :

skliarie, I've reported that issue with 11.10 as bug #883698.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.