Ubuntu

gnome-session storing broken since intrepid

Reported by Lukas Hejtmanek on 2008-07-17
360
This bug affects 35 people
Affects Status Importance Assigned to Milestone
gnome-session
Fix Released
Critical
gnome-session (Fedora)
Fix Released
Unknown
gnome-session (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-session

The latest gnome-session in Ubuntu/intrepid does not restore saved session at all. It does not start window manager (I'm not using craps like compiz or metacity, I'm using openbox, but /usr/bin/gnome-wm correctly starts the openbox).

I have gnome-session: 2.23.4.1-0ubuntu1

I did gnome-session-save before quiting the session but nothing is restored. Moreover, I use save session on exit option.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, those are known upstream issues

Changed in gnome-session:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Changed in gnome-session:
status: Unknown → New
pakraticus (pakraticus) wrote :

Sebatien,
Would you be kind enough to point us to the mailing list or WIKI that discusses these upstream issues?

Per the August 8th changelog entry within the gnome-session source indicates this was fixed.
Traffic on the desktop-devel-list is somewhat sparse after the initial proposal to revamp gnome-session to dbus instead of xsmp. Traffic to gnome-list concerning the problem seems to be 2.22 oriented.
Nothing is mentioned in the Gnome 2.24 showstopper review.

A quick review of the desktop files generated for gnome-terminal indicate that gnome-terminal does not currently have AutostartCondition nor X-GNOME-Autostart-*.

Reading through the proposal thread http://mail.gnome.org/archives/desktop-devel-list/2008-June/msg00210.html indicates that xsmp was completely dropped in favor of the new session protocol with no concern over legacy apps, including core gnome apps such as gnome-terminal
This is not "known upstream issues." This is "This will never work for legacy applications." A warning of some sort in /usr/share/doc/gnome-session directing annoyed users to the guilty parties would have been appreciated.

Sebastien Bacher (seb128) wrote :

the upstream bug reference is listed several times on the launchpad bug page, in the bugs table and in the sidebar

Dan Drake (ddrake) wrote :

Is this really "low" priority? I find it extremely irritating that none of my applications are restarted when I log back in. It's even more irritating that Gnome claims to be able to do this!

Also, is gnome-terminal really a "legacy" application?

For years, I've had applications automatically started upon login -- I would consider this bug a serious regression. (Imagine the press after Intrepid is released: "It's 2008 and Ubuntu can't ship a distro that remembers what applications to start when logging in!")

There seems to be no activity on the upstream bug; is there any work within the Ubuntu community to do something about this?

Johne (simsonloverforever) wrote :

This isn't something that Ubuntu can really fix anyhow. Only Gnome's developers should be willing to spend the time to fix, not Ubuntu's.

On Fri, Oct 03, 2008 at 04:06:03AM -0000, Johne wrote:
> This isn't something that Ubuntu can really fix anyhow. Only Gnome's
> developers should be willing to spend the time to fix, not Ubuntu's.

Well, there's a fix, but at this point it would be a mess.
Revert to 2.22.x GNOME. Upgrade to 2.24.x GNOME when either
1) gnome-session is able to properly handle the legacy session protocol.
(Preferable, breaks the fewest apps).
2) The new protocol is adopted by KDE as well and a significant number of
apps support the new protocol.
(Acceptable, but can lead to a few annoyances).
3) A significant portion of gnome-core 2.24.x supports the new protocol.

Then there is politeness. Include in /usr/share/doc/gnome-session
a file indicating that GNOME upstream broke backwards compatibility
with the old session management protocol and why it was considered a good
idea for ubuntu to upgrade anyways.

Being able to have applications automatically start up when I log in
where I want them has been a standard part of my computing experience
for 18 years now. Being able to do that without having to drag out
'vi' has been part of my experience for 7 or 8 years now.

--
Chris Dukes
"In cynicism she's about 35" -- Terry Pratchett's "Hog Father"

pakraticus: As far as I know, GNOME *didn't* switch to a new session protocol. There are plans to eventually do that, but, for the time being, the session protocol continues to be XSMP. You may be confused by the fact that the GNOME 2.24 release notes mention DBus for session management, but, as far as I understand it, this is just an interface to control the session manager itself (start the shutdown sequence, for example).

Martin Soto (soto255) wrote :

First, correction: GNOME is indeed switching to a new D-Bus-based protocol for session management, but the new session manager *should have legacy support for XSMP*. The latest documentation seem to be http://live.gnome.org/SessionManagement/GnomeSession and XSMP is mentioned there prominently. Also on my machine, the session manager is indeed creating the SESSION_MANAGER environment variable needed by XSMP clients, and the variable points to a UNIX domain socket as expected.

Some further observation gives me the impression that, in intrepid, the session is not being saved at all, and that applications aren't being shut down cleanly. Try, for example, starting firefox, loading a page, logging out from the GNOME session, logging in again, and starting firefox again (it won't be restarted automatically, anyway.) Firefox will then report that the previous session was ended forcefully, and ask if its state should be restored. I tried with other applications, such as OpenOffice and Lyx (just open a new document, put some text in it, and log out from GNOME) and this leads to data loss. So I don't think this problem should be considered low priority, it isn't just anoying, it is rather dangerous.

Also, Sebastien, the linked upstream bug doesn't really seem to be related to this problem. As far as I understand it, it has to do with the new session manager not being able to restore old session data, saved by the older session manager.

Can people please check if they can repeat my results with Firefox and OpenOffice?

Lukas Hejtmanek (xhejtman) wrote :

Yes, the firefox is just killed. Anyway, gnome-session-properties complains that saving session is not implemented yet :) And I don't see any session file under ~/.gnome2, ~/.gnome2_private, ~/.config

On Wed, Oct 08, 2008 at 06:02:10PM -0000, Lukas Hejtmanek wrote:
> Yes, the firefox is just killed. Anyway, gnome-session-properties
> complains that saving session is not implemented yet :) And I don't see
> any session file under ~/.gnome2, ~/.gnome2_private, ~/.config

the new session protocol has each app that supports it
(Which as far as I can tell are the apps in gnome-session and nothing else)
directs each application to store session information in gconf2.

Backwards compatibility still remains on the todo list.
>
> --
> gnome session does not start window manager nor restores the previous session
> https://bugs.launchpad.net/bugs/249373
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The GNOME 2 Session Manager: New
> Status in “gnome-session” source package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: gnome-session
>
> The latest gnome-session in Ubuntu/intrepid does not restore saved session at all. It does not start window manager (I'm not using craps like compiz or metacity, I'm using openbox, but /usr/bin/gnome-wm correctly starts the openbox).
>
> I have gnome-session: 2.23.4.1-0ubuntu1
>
> I did gnome-session-save before quiting the session but nothing is restored. Moreover, I use save session on exit option.

--
Chris Dukes
"In cynicism she's about 35" -- Terry Pratchett's "Hog Father"

> the new session protocol has each app that supports it
> (Which as far as I can tell are the apps in gnome-session and nothing else)
> directs each application to store session information in gconf2.

I wonder who starts all the applications that have their session saved in gconf2. I don't care whether application remembers its last state, but I care that applications do not start again as they were.

erlguta (gonzalomarcote) wrote :

>Is this really "low" priority? I find it extremely irritating that none of my applications are restarted when I log back >in.
>It's even more irritating that Gnome claims to be able to do this!

I think the same. Low priority?.
This makes my system almost unusable. With low characteristics of the 90 systems.
This should not happen even in a Beta.

ibotty (ibotty) wrote :

i have to second this opinion! this is a serious regression! 'low' is way to low ;).

erlguta (gonzalomarcote) wrote :

I can't believe that this so upset and seriously bug still hapens in a RC!.
Are we supposed to be that every time you turn on the PC into intrepid run all the applications?, skype, pidgim, evolution, terminal, etc.. every time.!?
This marked low and it would be one of the most annoying bugs so far.
Amazing and worrying.

Sebastien Bacher (seb128) wrote :

you should comment upstream the ubuntu desktop team doesn't have the ressources to work on such changes right now, you can add softwares to the session start though

Mozg (andrei-arhont) wrote :

I agree that this bug should be a high priority fix as many users of previous releases are used to this option and expect it to work in the next release. I have this problem and it is _very_ annoying!

On Tue, Oct 28, 2008 at 03:01:56PM -0000, Mozg wrote:
> I agree that this bug should be a high priority fix as many users of
> previous releases are used to this option and expect it to work in the
> next release. I have this problem and it is _very_ annoying!

Complaining to the ubuntu bug tracker about a serious defect in
upstream gnome won't get anything fixed.

However, you might want to complain that there is no mention of
the gnome 2.24.x design problem mentioned in
https://wiki.ubuntu.com/IntrepidReleaseNotes

As for the bug with upstream...
Start following
http://bugzilla.gnome.org/show_bug.cgi?id=552387

I strongly suspect that Sebastien is already tracking this upstream
bug and will apply the fixes from upstream as soon as they are available.

Hopefully Gnome upstream will have a fix shortly after the 30th.
Otherwise, hopefully Gnome upstream will fix it by April :-).

--
Chris Dukes
"In cynicism she's about 35" -- Terry Pratchett's "Hog Father"

I have this same issue after upgrading, session is not saved, I had removed ~/.gnome2/session for test and it is not created now.

Session Save is a very important feature, I agree that this bug should be a high priority fix.

erlguta (gonzalomarcote) wrote :

Please include this so important and annoying bug in:
https://wiki.ubuntu.com/IntrepidReleaseNotes

Becoming more and more people that are being upgraded is discovering it.
I think it is so important and annoying to be appointed.

Kees Kuip (keeskuip) wrote :

I just upgraded to Intrepid and have this bug.

It is very very annoying. Please mark this bug has high priority.

Is there a workaround? a quick-dirty fix?

RdeWit (rdewit) wrote :

Hi Kees,

Someone has a workaround, but it requires a bit of effort, so it seems: http://blogs.sun.com/mattman/entry/gnome_2_24_session_save1.

The easiest way is have Gnome start your apps by setting them in your gnome-session-properties (System - Preferences - Sessions), but it's not the same as saving your session.

Another workaround is hibernate your computer instead of shutting it down.

At work I depend heavily on saving sessions, so I'm a bit crippled too.

Cheers, R.

Dammit, I should have waited longer before updating. This is *NOT* a low priority bug. It's the first one (there are more) that a user encounters. How could this go unnoticed in the release candidate?

How about something like this in the release notes, under "Other Known
issues":

User sessions are not currently saved on logout. The simple workaround
is to add the programs you need to start to the auto-start menu. We are
awaiting a fix from upstream, and expect to fix it in a post-release
update. https://bugs.launchpad.net/bugs/249373 .

discussing the setting will not change the fact that the bug is an upstream one and will require upstream work too

Changed in gnome-session:
importance: Low → Medium
David Gibson (dwg) wrote :

Of course, the fact that it's an upstream bug doesn't alter the fact that Ubuntu has made a serious error in judgement to move to a version of Gnome with such a serious regression.

Kees Kuip (keeskuip) wrote :

At the top of the page I see a link to bugzilla of gnome:
http://bugzilla.gnome.org/show_bug.cgi?id=536685

Is this the description of the upstream bug?
If it is so then I think a wrong bug is reported!
Also I don't see any links back from that bug to this thread. So that upstream can see what the problems are.

Sebastien Bacher (seb128) wrote :

ubuntu ships the current GNOME version every cycle that's not an error if you don't want it you can still use the lts version

David Gibson (dwg) wrote :

Just because it's consistent with your policy doesn't mean the policy itself is not an error. I shouldn't have to stay with a previous version of the distro in order to avoid total and complete breakage of a useful feature (with no replacement in sight). Not to mention that downgrading to a previous version is vastly more work than the upgrade.

Ubuntu was an attractive distro precisely because it was slick, and had a high proportion of things Just Working out of the box. With several highly irritating regressions in each of the last few releases, I'm really beginning to think they've completely lost the plot on this front.

On Sat, Nov 01, 2008 at 12:33:56AM -0000, Kees Kuip wrote:
> At the top of the page I see a link to bugzilla of gnome:
> http://bugzilla.gnome.org/show_bug.cgi?id=536685

http://bugzilla.gnome.org/show_bug.cgi?id=552387
is probably the better bug to track.
536685 refers more to a bug in migrating to the new version.

>
> Is this the description of the upstream bug?
> If it is so then I think a wrong bug is reported!
> Also I don't see any links back from that bug to this thread. So that upstream can see what the problems are.

Upstream is well aware of it.
If you follow that bug you may even find some amusing bits.

--
Chris Dukes
"In cynicism she's about 35" -- Terry Pratchett's "Hog Father"

Nikola Kasabov (nikaas) wrote :

Very annoying bug for distro with such claim.

Changed in gnome-session:
status: New → Unknown

This is an extremely bad and annoying feature regression. It's a show blocker and should not have been released. It must have been known about before release. It's things like this that will drive users away from Ubuntu and Linux. Absolutely unacceptable!

Sebastien Bacher (seb128) wrote :

To maintain a respectful atmosphere, please follow the code of conduct - http://www.ubuntu.com/community/conduct/ . Bug reports are handled by humans, the majority of whom are volunteers, such comments are not appropriate there

florinn (florinnaidin) wrote :

I agree that this is a serious bug, I have it since I upgraded from Hardy to Intrepid and is really annoying.
It should be mentioned in the release notes. Maybe I should have delayed the upgrade process if I knew about it.

Nicholas Allen (nick-allen) wrote :

Sorry if you found my tone was inappropriate. I certainly didn't mean to offend any of the developers or volunteers who work to make Ubuntu such a great product. I am very grateful for all the hard work they are doing and Ubuntu is by far my favorite OS!

However, I do believe it is unacceptable from a user's point of view that a release of Ubuntu should be made with this known feature broken/unimplemented when it worked perfectly well in all previous releases. Canonical has paid employees and releases a product that users pay for support for so there should be a level of quality control that would catch major problems like this before a new release is made. Even the most basic testing would have uncovered this.

My frustration is not with the developers, or the people who take care of bug tracking, but with the lack of quality control at Canonical that allowed something like this to make it into a new release of Ubuntu. This is a serious regression and I really can't believe Canonical wasn't aware of it before release.

Sebastien Bacher (seb128) wrote :

Ubuntu is not writting GNOME but only contributing upstream and distributing it. The bug was known before intrepid but downgrading the version was not trivial, it was not clear that GNOME was not going to work on the issue before 2.24 and Ubuntu usually ships the current GNOME. If you are not happy about the choice you should rather complain directly to GNOME, if you want a stable Ubuntu version maybe you should consider staying on a lts version?

Sebastien Bacher (seb128) wrote :

You can also note that the low priority focus for this bug upstream is due to the fact that the feature has never been working really correctly on many software and they don't consider that something stable and used by the majority of users, that might be wrong but should be discussed on bugzilla.gnome.org rather than here, intrepid ships now the current version which works mostly correctly and the way to go is to get the bug fixed now in the intrepid updates or jaunty

Iuri Diniz (iuridiniz) wrote :

Is this regression already in: https://wiki.ubuntu.com/IntrepidReleaseNotes ? I think that People must be warned about this.

And I agree with ubuntu guys, If someone wants to complain, do not do it here, neither on gnome tracker, comments like 'me too' is completely useless, just put your name on CC and wait for someone to work on it or do it by yourself (use the force). I'm one of guys that used to use this feature, I don't have time to resolve it, so I will wait, but I agree that this issue must be warned, I was not warned about it.

cannam (cannam) wrote :

At the risk of asking a really stupid question, does anyone have an idea whether there's any likelihood of a workaround such as installing and using the Gnome 2.22 session manager with 2.24? Or using a different session manager entirely? I don't mind hacking my system to get this to work, but if anyone can warn me that I'd be wasting my time, I'd appreciate that.

(I ran straight into this on the first machine I upgraded, and I don't want to upgrade any others unless I can find a fix. This regression in something I thought was one of the main functions of the desktop makes me feel extremely gloomy, but I won't vent any further here.)

Chris

Download full text (3.4 KiB)

On Tue, 2008-11-04 at 08:54 +0000, Sebastien Bacher wrote:
> You can also note that the low priority focus for this bug upstream is
> due to the fact that the feature has never been working really correctly
> on many software and they don't consider that something stable and used
> by the majority of users,

Well, as the comments here show, some people were relying on this
feature. This should be out of discussion now.

> that might be wrong but should be discussed on
> bugzilla.gnome.org rather than here, intrepid ships now the current
> version which works mostly correctly and the way to go is to get the bug
> fixed now in the intrepid updates or jaunty

With all due respect, I'm really surprised with this answer. Does this
imply that every time an upstream project delivers a new version with
regressions, Ubuntu will ship it just because it is the new upstream
version, no matter what damage it may cause? Does it imply that if
Ubuntu, for whatever reason, ships upstream code with a regression,
Ubuntu users will be directed to complain upstream as their only
resource?

I don't think this reflects Ubuntu's objectives (but please correct me
if I'm wrong.) As far as I can tell, Ubuntu has generally done a very
good job of selecting appropriate versions of upstream software: stable
and functional enough for most people, yet current. And most users now
rely on upgrades not containing serious regressions. So it can be argued
that the Ubuntu Desktop Team made the wrong decision when they let this
software in, because in fact, the problem was very well known to them
(https://lists.ubuntu.com/archives/ubuntu-devel/2008-September/026588.html look under "Release Status").

Now, my intention here is not to point fingers, but to ask for
reasonable damage control. As a minimum, I would expect this problem to
be acknowledged by the desktop team, and clearly reported in the Release
Notes, so that users can decide if they want to update. Of course, it
would also be good to try to fix gnome-session at least to the point of
not putting user data under risk (see my comment above in this bug
report) but I don't know if anyone can commit any resources to that.

Finally, regarding us complaining upstream, I'm not sure a lot of
disgruntled users commenting in GNOME Bugzilla will be of help. As far
as I can tell, this is not just a bug. What's going on here is that the
desired functionality is simply not implemented, or very immature in the
new gnome-session. So, it cannot be said that it "works mostly
correctly", because, in reality, it is able to start a session properly,
but far from being able to stop or restart it properly, which means it
currently does 30 to 50% of the intended functionality. This being the
actual state of affairs, I think we'll be very lucky if this is ready
for Jaunty.

Of course, GNOME should have also reported this clearly in their release
notes. They should also tell us what their policy regarding regressions
is, because they seem to be very picky regarding obscure ABI
regressions, but don't seem to mind large, user-visible regressions that
potentially put user data under risk of destruction. But this is
something we should try to bring t...

Read more...

> With all due respect, I'm really surprised with this answer. Does this
> imply that every time an upstream project delivers a new version with
> regressions, Ubuntu will ship it just because it is the new upstream
> version, no matter what damage it may cause? Does it imply that if
> Ubuntu, for whatever reason, ships upstream code with a regression,
> Ubuntu users will be directed to complain upstream as their only
> resource?

The decision has been made to use the new upstream version during the cycle because other desktop component started using the new gnome-session dbus api and gnome-session needed to be upgrade to upgrade those. The issue have been discussion with people working on the upstream rewrite and were on the list of things to work on for GNOME 2.24. The changes have slowed down when one of the people working on the new code changed job and had been busy with other things. Now the ubuntu team doesn't have extra ressources to put on writting this upstream code and downgrading is not really an option so the bug is basically blocker on something to step up and do the work there or in the GNOME community

Sebastien Bacher (seb128) wrote :

The comments about the upgrade notes, those are on a wiki so anybody can do changes there or contact the people who have been working on those and who don't read this bug or suggest items to be added you can contribute to the notes rather than blocking on other busy people to write an item there

cannam (cannam) wrote :

I ended up downgrading gnome-session and gnome-panel to 2.22 as a workaround. It appears to be working OK so far.

(You can't just downgrade gnome-session, because gnome-panel depends on the newer version to support essentials such as "log out".)

This is what worked for me. Start by adding the Hardy main repository back to sources.list, then:

 $ sudo apt-get install gnome-session/hardy gnome-panel/hardy gnome-panel-data/hardy

 $ for x in session panel panel-data; do echo gnome-$x hold | sudo dpkg --set-selections; done

I'm sure this will cause all sorts of trouble down the line, but it makes me happy for now and turns Intrepid into a genuinely pleasing system. Of course I'm missing any improvements made to gnome-panel since 2.22, but I'd be very surprised if it has anything significant enough to be worth losing this feature for.

One problem is that the "quit" dialog now lacks the icons for some of its options -- I'm not sure how to restore those without losing any icons that are needed for newer Gnome features.

Chris

cannam (cannam) wrote :

Per Sebastien's comment, I have added a couple of sentences about this to the Intrepid release notes. I trust that's OK.

I think Martin Soto's assessment is spot on. It _is_ worrying that Ubuntu should (as a matter of policy) be so sanguine about this. It's also surprising that GNOME developers should have been happy to take a broadly working session manager, remove much of its session management support on the basis of some concerns about architecture and code quality, and push the result as if it were a stable point update.

Would it be so hard (this is just an aside about Gnome, not about Ubuntu) to temporarily revert any changes elsewhere in Gnome that depend on the new DBUS session API, pull the "new" gnome-session back out to a branch until it works properly, and revert to the 2.22 session manager? I suppose that would feel like a backward step and make few friends among developers.

Chris

erlguta (gonzalomarcote) wrote :

I know many people who don't want to upgrade to Intrepid until this very annoying bug is resolved. Is somebody working on it?, Why it still appears triage status?. We will have to wait until Jaunty (as ever)?.
Perhaps this is not the place to discuss the impotence of view this situation. If someone wants to discuss this, please comment on this post to try to find solutions:
http://ubuntuforums.org/showthread.php?t=964730

Sebastien Bacher (seb128) wrote :

the bug is set as triaged because it has the required informations to be worked, the ubuntu team doesn't really have the ressources to do the GNOME work there though so you should better comment on bugzilla.gnome.org

Changed in gnome-session:
status: Unknown → Invalid

For a slightly different perspective on this bug, see http://np237.livejournal.com/22014.html
However, it's true that the old behaviour was not great: openoffice didn't seem to react to session exits (logouts), for example.

Scott Minster (sminster) wrote :

Replacing XSMP for a better way is a noble goal. However, it is ridiculous that Gnome released 2.24 with a half done version of the new protocol and no trace of the XSMP support. That simply speaks to bad management at the Gnome project.

This bug is not something Ubuntu can fix at this point, but I hope that those in charge of Ubuntu learn from this problem. It appears that Gnome cannot be trusted to release a new version without major regressions, and Ubuntu needs to rigorously test new versions before committing to them. This regression was noticed in mid July, 3 months before 8.10 was released. If this had been evaluated then, Ubuntu could have avoided releasing a version with this problem (either fixed somehow, not releasing 2.24, or going the Gentoo route and holding the session manager at 2.22).

Endolith (endolith) wrote :

> It appears that Gnome cannot be trusted to release a new version without
> major regressions, and Ubuntu needs to rigorously test new versions before
> committing to them.

But they don't. Ubuntu is committed to releasing on a rigid schedule regardless of functionality or regressions, too.

Martin Soto (soto255) wrote :

> > It appears that Gnome cannot be trusted to release a new version without
> > major regressions, and Ubuntu needs to rigorously test new versions before
> > committing to them.
>
> But they don't. Ubuntu is committed to releasing on a rigid schedule regardless of functionality or regressions, too.

No need to put the blame on time-based releases. They are definitely preferable to Debian-style releases, which seem to never get ready. The problem is that, in the absence of guaranteed developer commitment (and you never have guaranteed developers in Open Source) and good project planning, it is impossible to make sure that the desired functionality will be ready for the next release deadline. This is an inherent risk of time-based releases: if you're unlucky, you may have very few new features for your next release.

This case was particularly difficult for Ubuntu, I guess, because of the complex dependencies inside of GNOME. Running 2.24 with the 2.22 session manager is no trivial matter (as Gentoo's and Debian's efforts show) so this wouldn't have been possible in the Intrepid time frame. Therefore, the decision was between including 2.24 with the regression, and staying with at least a large portion of 2.22. As we all know, 2.24 won.

As I already said elsewhere in this thread, I regret this decision. I think that, by doing this, Ubuntu sends to wrong message upstream. I'm really surprised that such a large regression was possible in GNOME without any discussion whatsoever. In GNOME, a developer needs approval from three release team members in order to change a single string after string freeze, but he can cut off half of the functionality of a core component and nobody says a word. Strange, to say the least.

But this is getting off-topic. This should be discussed in some higher Ubuntu forum, but I don't know which one is appropriate. If any of you guys have a better idea of how this can be brought to a higher instance in an appropriate way, I'll be glad to know.

Changed in gnome-session:
status: Unknown → Confirmed
Changed in gnome-session:
importance: Medium → High
Changed in gnome-session:
status: Invalid → In Progress

This bug was fixed in the package gnome-session - 2.25.92-0ubuntu1

---------------
gnome-session (2.25.92-0ubuntu1) jaunty; urgency=low

  * New upstream version (LP: #337386):
    - Re-introduce support for session saving (LP: #249373).
    - Ensure treeview is included in a scrolled window with a
      shadow in the inhibit dialog.
    - Use system-log-out icon instead of deprecated gnome-logout.
    - Fix logout dialogs not being themed (LP: #320921).
  * 80_new_upstream_session_dialog.patch:
    - Updated so that it applies again.
  * 98_autotools.patch:
    - Recreate for new upstream version.

 -- Chris Coulson <email address hidden> Tue, 03 Mar 2009 18:53:58 +0000

Changed in gnome-session:
status: Triaged → Fix Released
Changed in gnome-session:
status: In Progress → Fix Released

On Tue, Mar 03, 2009 at 08:50:06PM -0000, Launchpad Bug Tracker wrote:
> This bug was fixed in the package gnome-session - 2.25.92-0ubuntu1

And whoever claimed this didn't do squat for regression testing.

sequence
login.
system->preferences->startup programs->options->
 check automatically remember running applications when logging out
 click remember currently running application.
Start a gnome-terminal
logout
log in again.
gnome-terminal starts

Okay, good.

ctrl-shift-n within the new gnome-terminal to open a second one.
logout
log in again
only one gnome-terminal open.

For giggles,
places->desktop
logout
log in again
only one gnome-terminal open.

So, we're back to the other bug I just recently opened.
"The developers of gnome-terminal and nautilus can't be
arsed to eat the new gnome session management dogfood."
>
> ---------------
> gnome-session (2.25.92-0ubuntu1) jaunty; urgency=low
>
> * New upstream version (LP: #337386):
> - Re-introduce support for session saving (LP: #249373).
> - Ensure treeview is included in a scrolled window with a
> shadow in the inhibit dialog.
> - Use system-log-out icon instead of deprecated gnome-logout.
> - Fix logout dialogs not being themed (LP: #320921).
> * 80_new_upstream_session_dialog.patch:
> - Updated so that it applies again.
> * 98_autotools.patch:
> - Recreate for new upstream version.
>
> -- Chris Coulson <email address hidden> Tue, 03 Mar 2009
> 18:53:58 +0000
>
> ** Changed in: gnome-session (Ubuntu)
> Status: Triaged => Fix Released
>
> --
> gnome-session storing broken in intrepid
> https://bugs.launchpad.net/bugs/249373
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The GNOME 2 Session Manager: Confirmed
> Status in “gnome-session” source package in Ubuntu: Fix Released
> Status in “gnome-session” source package in Fedora: In Progress
>
> Bug description:
> Binary package hint: gnome-session
>
> The latest gnome-session in Ubuntu/intrepid does not restore saved session at all. It does not start window manager (I'm not using craps like compiz or metacity, I'm using openbox, but /usr/bin/gnome-wm correctly starts the openbox).
>
> I have gnome-session: 2.23.4.1-0ubuntu1
>
> I did gnome-session-save before quiting the session but nothing is restored. Moreover, I use save session on exit option.

--
Chris Dukes
"In cynicism she's about 35" -- Terry Pratchett's "Hog Father"

The upstream bug is still "confirmed" and reading it seems that there are still many unresolved problems. So the status of this bug is "In Progress" at most.

But as evidenced in gnome bug, some of the regressions are from the apps which have inadvertently removed XSMP support rather than the new gnome-session not working correctly.

Lorenzo Bettini (bettini) wrote :

this version hasn't been backported to intrepid, has it?

Sebastien Bacher (seb128) wrote :

> this version hasn't been backported to intrepid, has it?

the new version just landed to jaunty still need testing and debugging so no it has not been backport to anything yet

Bruce Cowan (bruce89) wrote :

Core things such as GNOME session won't and shouldn't ever be backported.

Jeremy Nickurak (nickurak) wrote :

Well, maybe not gnome-session in it's entirety. But given how big a regression this was for Gnome, I'd hope that the individual changes that correct this upstream can be pulled into intrepid.

Sebastien Bacher (seb128) wrote :

intrepid is not a lts version, jaunty is due next month and will be much better quality than intrepid, it would take weeks to stabilize, backport and valide those backport and will not realistically be a high priority for intrepid

Jonathan (birge) wrote :

This kind of utter bullshit is exactly why linux is a marginal player in the desktop, and becoming even moreso (according to browser market share, at least). If a major feature is broken in an upstream package, how about this for a suggestion: keep the last version that worked, or write a patch to remove the feature temporarily. Don't get so version happy that you're willing to package a broken GNOME that advertises a feature that doesn't work. It only backfires, because it alienates the living crap out of users, and gives Ubuntu the appearance of a bush league operating system. Just throwing your hands up and saying "this is an upstream problem endemic to open source" is chicken sh*t. If that's true, then you're basically saying open source is incapable of providing a quality operating system, because there is always going to be stuff breaking upstream in an actively developed project.

On the other hand, if the attitude is simply that it's ok for interim releases to suck, I'd strongly suggest Ubuntu "management" rethink that strategy. If somebody new to linux downloads "the latest" Ubuntu, they just get the one with the biggest version number. They don't know about LTS or what that really means. If that version is broken, they go back to Windows or the Mac, and it's another person who thinks Linux is a joke. This whole experiment in open source isn't going to work if users are treated with such contempt that it's considered acceptable to release an OS where a major feature is just plain broken.

Really, gentlemen, how hard would it have been to just patch GNOME to remove the "Options" tab in Sessions Preferences?

Endolith (endolith) wrote :

[Cue someone ranting about how bug report comments aren't the place for rants.]

But really, where do we complain about this? How do we get 'the people in charge' to actually listen and rethink their priorities for releases? It seems that each Ubuntu release is a downgrade from the last.

Nicholas Allen (nick-allen) wrote :

This bug is a serious regression and it's the reason I moved to KDE. KDE's not perfect but at least basic things like this work.

efa (efa) wrote :

this regression in the last non-LTS is a bit uncomfortable, expecially after years of Ubuntu and Gnome well working version, but Linux with this little bug is anyway far better than Windows (considering all other aspects).
KDE 4 has similar other little bugs respect to previous 3.5, so friends that use Kubuntu 8.10, are not so happy like us.
Use a LTS, or install a Debian, really similar to Ubuntu (that is Debian based), but there you got only ultra stable software, at a price of infrequent release.

Bruce Cowan (bruce89) wrote :

This is not the right place for a GNOME vs. KDE debate.

Sebastien Bacher (seb128) wrote :

Could preople stop this rant there, that's not constructive, the choice taken for intrepid was wrong but everybody does mistake and now is time to get things fixed rather than blaming the distro team or GNOME again and again for the error

I've just uploaded a patched version to jaunty which restore session storing, it's late in the cycle for GNOME (but should not be an easy for jaunty), some applications are know to be buggy but session storing should basically work and it should prompt again for not saved work in gedit for example and don't display a firefox incorrect closing prompt on next opening

comments on the new jaunty version are appreciated

On Sat, Mar 14, 2009 at 12:16:04PM -0000, Sebastien Bacher wrote:
> Could preople stop this rant there, that's not constructive, the choice
> taken for intrepid was wrong but everybody does mistake and now is time
> to get things fixed rather than blaming the distro team or GNOME again
> and again for the error
>
> I've just uploaded a patched version to jaunty which restore session
> storing, it's late in the cycle for GNOME (but should not be an easy for
> jaunty), some applications are know to be buggy but session storing
> should basically work and it should prompt again for not saved work in
> gedit for example and don't display a firefox incorrect closing prompt
> on next opening
>
> comments on the new jaunty version are appreciated

2.25.92-0ubuntu2 gnome-session
2.25.91-0ubuntu2 gnome-terminal

gnome-terminal still doesn't remember that I have multiple open when
I logout. Time to dust off the bug I put in that gnome-terminal
and nautilus still can't be arsed to speak the new protocol.

I'm not thrilled with the prompting on gedit, but my specific complaint
looks more like a gedit bug. But as long as gnome-terminal doesn't
start prompting or nvi doesn't start prompting, I don't care...

--
Chris Dukes
"In cynicism she's about 35" -- Terry Pratchett's "Hog Father"

those who provide only negative comments, please provide a better sense of community than this.

lets join together to provide solutions rather than rail against those who are working very hard to provide an environment which we love to use. gnome is a great desktop. ubuntu is a great distribution. i am very happy with both.

rather than saying those in the release process are wrong, provide data to allow this to be fixed. negativity and mud-slinging is not beneficial and only makes those who are working very hard providing software and solutions upset.

*all* software will have bugs and defects. lets work to remove them rather than being harsh against the development community.

Ian Ellis (ianmailstuff) wrote :

Well said, Qoquaq. A bug report isn't really the place for this, but I thought I'd add something to that comment. Criticism is fine, as long as it's constructive criticism. Most people are happy to receive constructive criticism. In fact, I believe that Ubuntu has a places for it. There's brainstorm.ubuntu.com and a qa.ubuntu.com. So, rather than re-iterating that this is a horrible bug and Ubuntu sucks because of it, go over there and offer ideas about how to stop stuff like this happening in the future.

Brandon Thomson (gravix) wrote :

I don't want to clog up everyone's mailbox further but before you comment saying people are incompetent or that it is so easy to add such and such a feature, please try to make those changes yourself. Not only would you be doing the community a great service if you are successful, but you will also learn that these things are not as easy as they look and take a great deal of time to implement and then test. We should all be thankful that folks are donating their valuable time to work on this bug.

Endolith (endolith) wrote :

It's not a matter of adding such and such a feature. It's a matter of breaking something that already worked fine.

They didn't need to include the latest broken version of Gnome in Ubuntu, and they didn't need to release Ubuntu on a specific date with known bugs and regressions, but they did anyway.

(We're all clogging inboxes while saying that we shouldn't. Where *specifically* should this discussion take place instead of here?)

Don Cristóbal (doncristobal) wrote :

Should this work in Jaunty Beta? I'm asking because it does not properly:
* There is NO prompt for saving open documents at restart/shutdown.
* On logout, it miraculously works, at least with Gedit and OpenOffice

- If someone here knows what the state /should/ be in Jaunty Beta, please post here, thanks!

Sebastien Bacher (seb128) wrote :

the current version only works for logout indeed

Changed in gnome-session (Ubuntu):
status: Fix Released → Triaged
Don Cristóbal (doncristobal) wrote :

So should someone post a new bug report for Jaunty? Or are the developers already aware?

summary: - gnome-session storing broken in intrepid
+ gnome-session storing broken since intrepid
cannam (cannam) wrote :

My understanding from the GNOME bugtracker is that a fix exists, but is not included in 2.26.0 (hopefully in 2.26.1).

This presumably means the fix will not be in 9.04, but is likely to appear in a subsequent update -- is that right?

I see no mention of it in the known issues section of the notes at http://www.ubuntu.com/testing/jaunty/beta (not sure whether I would expect to see issues reported there that are not regressions new to this particular release), but this seems consistent with Christoph's comment above and Sebastien's change to the summary.

In the mean time, has anyone had a go at using gnome-session 2.22 with the rest of gnome 2.26? I currently have gnome-session and gnome-panel 2.22 packages on "hold" while using 2.24 for everything else, and I'd like to get an idea of whether it will be possible to leave them held while upgrading the rest of the distro from 8.10 to 9.04.

Per Ångström (autark) wrote :

Session restore seems to be back with the latest updates for Jaunty.

Lorenzo Bettini (bettini) wrote :

but the position and the number of occurrences of an application are not restored correctly: e.g., if I had 3 terminals running, upon restoring only one terminal window is shown (and not in the right position: at the up left corner, with the window title under the panel so that it cannot be moved)

Martin Soto (soto255) wrote :

Just a short comment to confirm what user Christoph reported above: session shutdown and saving is sort of working when the "log out" option is chosen in the menu, but not when the "restart" or "shut down" options are selected.

Sebastien Bacher (seb128) wrote :

gnome-session (2.26.0svn20090408-0ubuntu1) jaunty; urgency=low

  * Updated to the current svn version (lp: #257067, #272854)
  * debian/patches/91_upstream_change_fix_session_saving.patch:
    - update by Vincent Untz which should make session storing work
      on all the actions now (lp: #552387)
  * debian/patches/98_autotools.patch:
    - new version update
  * debian/rules:
    - update for manpage changes in the new version

Changed in gnome-session (Ubuntu):
status: Triaged → Fix Released
Martin Soto (soto255) wrote :

This is still not working for me, unfortunately. I have the latest version of gnome-session available from Jaunty (2.26.0svn20090408-0ubuntu2) and the problem remains: "Log Out" from the FUSA applet works properly, whereas "Shut Down" and "Restart" don't. My test case is to leave Firefox running and terminate the session. After "Log Out", Firefox restarts automatically with the same tabs. When any one of the other two options is used, it complains later about having been terminated abnormally.

Sebastien Bacher (seb128) wrote :

gnome-session is fixed but fusa needs updating still

Changed in gnome-session:
status: Confirmed → Fix Released
cannam (cannam) wrote :

This works somewhat better, but not entirely, for me in 9.04 (upgraded from 8.10).

For example: start a new session, then run up Firefox, Emacs, Inkscape, Scribus and gnome-terminal, open documents in all of them (where applicable), replace metacity with my preferred window manager (which is not metacity or compiz).

Then select "Restart", reboot, and log in again.

The restarted session contains Firefox with all of the correct tabs open (though none of them load, as network-manager has not yet reestablished the network connection). It also has Emacs and gnome-terminal. So that's a definite improvement.

But it does not restart Scribus or Inkscape at all, and it has the wrong window manager. Reading .xsession-errors it looks like gnome-session tries to run my preferred window manager, but it has already started metacity before that, so the "right" window manager then fails to start.

There are also some weird random errors -- once it started Emacs with a window only a few pixels large, and it often seems to open an additional window from some program that I did not have open at all before (a Nautilus window on some arbitrary directory, or a Tomboy index window).

It doesn't seem to make any difference whether I "Restart" or "Log Out", both work equally (i.e. partially).

Altogether, better than 8.10 but still a regression from 8.04. I haven't established yet whether the programs that were not restarted had been given a chance to save their documents before exit or not -- that's quite important.

Chris

 This bug persists with me, too: I exited Pidgin, run gnome-session-save, logged out logged in and Pidgin reappeared automatically. (Pidgin is not an entry in System > Preferences > Startup Applications.)
The same result when I rebooted instead of logging out.
uname -a; Linux MD97600 2.6.28-14-generic #47-Ubuntu SMP Sat Jul 25 00:28:35 UTC 2009 i686 GNU/Linux
This Ubuntu version is a dist-upgrade from 8.04.2 > 8.10 > 9.04.
GNOME 2.26.1

Changed in gnome-session:
importance: Unknown → Critical
efa (efa) wrote :

with Ubuntu 10.04:
1) the gnome-terminal and nautilus windows are restored not iconized, if they were iconized at shutdown time.
2) the application position inside task bar are not restored in the correct order (are always swapped)
3) Mozilla windows are all restored on the first desktop, even if they are in other desktops at shut down time.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.