Screensaver doesn't start

Bug #278112 reported by Sebastian Breier on 2008-10-04
270
This bug affects 14 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Medium
Michael Vogt
Intrepid
Medium
Michael Vogt
gnome-screensaver (Ubuntu)
Undecided
Unassigned
Intrepid
Undecided
Unassigned
xorg-server (Ubuntu)
Medium
Michael Vogt
Intrepid
Medium
Michael Vogt

Bug Description

Binary package hint: gnome-screensaver

Version: intrepid ibex, 2.24.0-0ubuntu1

This is a continuation from Bug #274926.
When the session is idle (or when gnome-screensaver-command -a has been issued), the screen starts to fade, but then immediately returns to the desktop instead of starting the screensaver.

I'm attaching the output of gnome-screensaver (made by Khashayar Naderehvandi, not me).

Related branches

I'm a bit too busy right now to do anything useful, but I thought I'd just add this bit of information: It seems this problem occurs only when compiz is active. When metacity is managing windows, the screensaver activates just fine.

Sebastian Breier (tomcat42) wrote :

Thanks for that information. I have added compiz to the bug. :-)

Changed in gnome-screensaver:
status: New → Confirmed
Sebastian Breier (tomcat42) wrote :

And I can confirm it: Works with metacity, doesn't with compiz.

Changed in compiz:
status: New → Confirmed
Noel J. Bergman (noeljb) wrote :

See Bug 270129, now marked as a duplicate, which provides more detail on the problem.

Andrea P (pinnisi) wrote :

same here, ubuntu amd64 + nvidia + compiz

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Could you please try the compiz from:
deb http://ppa.launchpad.net/compiz/ubuntu intrepid main
?

That seems to have fixed the problem for me.

Changed in compiz:
assignee: nobody → mvo
importance: Undecided → Medium
milestone: none → ubuntu-8.10
status: Confirmed → Incomplete
Sebastian Breier (tomcat42) wrote :

Sorry, does not fix it for me.
I reset the gconf-keys of g-s and compiz.
I tried several settings, idling the session, g-s-c -a.
The same result, no screensaver.

Changed in compiz:
status: Incomplete → In Progress
Andrea P (pinnisi) wrote :

@Michael Vodgt
I tried that version of compiz, same problem.. no screensaver :-(

Andrea P (pinnisi) wrote :

I disabled the screen saver, and now my monitor can go to standby! (before it won't)

Florin Ivan (florica76) wrote :

I have the same problem.

I have this problem. Ubuntu amd64, Nvidia (9600GT) and compiz. Screensaver fails just after dim and a half second long play. Works fine in preview.

Noel J. Bergman (noeljb) wrote :

Again, as mentioned in Bug 270129, it appears that an event is being generated that cancels the screensaver, which is why the workaround of having the screen locked when running the screensaver works.

Michael, I'll try compiz from the PPA, but I doubt that I'll get to it before Thursday evening.

Sebastian Breier (tomcat42) wrote :

I tried debugging compiz, g-s & dbus, but it's really impossible without any knowledge of the structure of these programs (and for both, there doesn't seem to be any good debug output). dbus-monitor only confirmed that the screensaver is stopped.

Chris Coulson (chrisccoulson) wrote :

Sebastien - It still might be useful to attach the output of 'dbus-monitor --session' whilst the screensaver attempts to activate.

Dan Andreșan (danyer) wrote :

Are you sure this is not a duplicate of bug 159263 ?
That one has a simple workaround, which completely solved the problem for me.
Try it. If the problem is solved, then it's the same bug.

Thanks Dan,

That workaround definitely has something to do with this problem. It seems to have solved the problem here. "Seems" because, I'm only getting a dark screen, not the actual screensaver I've chosen, but that's probably a different problem.

Unredirecting full screen might not be the thing we want though, but I guess this takes us closer to the core of the problem.

Jan (jan23) wrote :

For me disabling compiz as proposed here https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/159263/comments/11 solves the bug. Maybe a duplicate of 159263?

Dan Andreșan (danyer) wrote :

Of course, JanJan, compiz configuration doesn't allow the screensaver to start. Disabling compiz will "solve" the bug. But this is not the idea. The idea is to have screensaver *and* compiz. So we need to disable only *part of* compiz. The info in bug 159263 does exactly that.

Sebastian Breier (tomcat42) wrote :

Here's the output of dbus-monitor --session type=signal when starting the screensaver with gnome-screensaver-command -a.

Sebastian Breier (tomcat42) wrote :

Indeed, the workaround proposed by Dan (General Options in ccsm: Disable "unredirect fullscreen windows") fixed it for me. Not sure if this is a duplicate... I have no idea what this option does. ;)

kylea (kylea) wrote :

Can confirm that locking the screen allows the screen saver to work, even with compiz active

In ccsm "undirect fullscreen windows" disabled, screen saver works.

Frank Prescott (73ckn797) wrote :

I have this problem. S
Biostar TF560 A2+, AMD Athlon 64 X2 Dual Core 4000+, 2gb DDR2 800 Ram. Nvidia 7600GS 256mb.

Screensaver fails just after dim and a half second long play. Works fine in preview.

Updated 10/10/2008.

Oliver Grawert (ogra) wrote :

removing gnome-screensaver doesnt change any of the behavior and since the fade process is handled by gnome-power-manager i started suspecting a clash between X dpms and g-p-m dpms functionallity ... either uninstalling g-p-m *or* setting xset -dpms in a terminal window fixes the issue here, the screen properly fades to black after a while ....
since someone above noted that unsetting "undirect fullscreen windows" fixes it too, i would assume that this plugin somewhat interferes with dpms settings.

oupablo (oupablo) wrote :

I can confirm that disabling "Unredirect Fullscreen Windows" on the General options tab in the CompizConfig Settings Manager lets the screensaver start.

Dan Andreșan (danyer) wrote :

Since it seems that bug 159263 and bug 278112 are the same, could anyone mark one of them as duplicate of the other? Or at least point to the difference between them if not considered overlapping, cause I don't find any.

Thierry Carrez (ttx) wrote :

xset -dpms doesn't fix it here.
unsetting "undirect fullscreen windows" fixes it.

Thierry Carrez (ttx) wrote :

This might be related or just another bug :
If I select the option "Lock screen while screensaver is on" in gnome-screensaver, then the screensaver starts up correctly. However when I hit some keys or move the mouse, the screensaver just restarts... I need to kill it from SSH to recover my keyboard and screen.

Thierry Carrez (ttx) wrote :

Proposed fix is to reenable an updated version of the 030_fix_screensaver patch that disables "Unredirect Fullscreen Windows" for gnome-screensaver only.

I will push this into my PPA so that you can all test this and report if it fixes it without any dirty side-effect :)

compiz (1:0.7.8-0ubuntu4) intrepid; urgency=low

  * Reenable an updated 030_fix_screensaver to prevent "unredirect fullscreen
    windows" option from waking up gnome-screensaver (fixes LP: #278112)

Note that this just fixes the screensaver not starting problem, it doesn't prevent the locking issue above when selecting "lock screen..." in gnome-screensaver...

Thierry Carrez (ttx) wrote :

Those who can, please test the compiz packages from:
https://launchpad.net/~tcarrez/+archive
and report success/failure. You no longer should have "Unredirect Fullscreen Windows" disabled since the purpose of this workaround is to disable it for gnome-screensaver only. Don't forget to log out/ log in after you upgraded the compiz packages.

If you don't fear, please also test "lock screen..." checkbox in gnome-screensaver : before applying the PPA version, and after. Warning ! you might lock you into the screensaver so ensure that you have a way to SSH in to kill gnome-screensaver properly.

t_e_r (ter-ihear) wrote :

Ditto to https://bugs.launchpad.net/~valto-wirkola workaround on an asus m70. Thx.

DJ Dallas (djdallas) wrote :

I may have found some problems with the proposed solution (i.e. unchecking "Undirect fullscreen windows") when you have multiple users. Could someone please try these steps and confirm?

Firstly, "uncheck" "Undirect fullscreen windows" in CCSM so that the screensaver works.
Also, make sure that the User Switcher applet preferences are on its default setting, with "Lock screen after switching users" "checked".
Set the screensaver preferences to its default setting with "Lock screen when screensaver is active" "unchecked". (I tried with it checked as well, and don't think that it makes a difference.)
Now create a new user if you don't already have another.
Without logging out of the first session, switch to another user.
In the new session, "uncheck" "Undirect fullscreen windows" in CCSM so that the screensaver works for the new user.
Switch between the two user sessions using the User Switcher applet on the panel.
(I get a white screen instead of the password prompt. If I blindly type the password it will switch sessions and restore the display to normal.)

Assuming you still have two user sessions logged in, "Suspend" the computer (standby) rather than shutting down normally.
Resume the computer from its standby state.
(I get a totally black screen except for the mouse cursor, but there is display corruption in a small square around the cursor. Again, blindly typing the password will usually restore the session.)

I've found 2 workarounds to the white-screen problem.
The first is to click on "System, Log out, Switch user" rather than using the fast user switcher. This seems to always take you to the GDM login screen, rather than the usual locked-screen window, and prevents the white screen.
The second is to "uncheck" the "Lock screen after switching users" in the fast user switcher preferences for both users. This again avoids the locked-screen password prompt, which seems to be causing the white screen problem when using the fast user switcher.

I have no idea how to fix the black-screen on resume issue, except by leaving "Undirect fullscreen windows" "checked". Once again, this may be an issue with the locked-screen password prompt itself, or how compiz uses it.

I've also believe that setting the screensaver preferences to "Lock screen when screensaver is active" is more of workaround than a real solution to the screensaver not starting. With this option checked the screensaver should start immediately after the pre-set time, and only show the password prompt when there"s activity again (move the mouse/keyboard/whatever). With compiz on, it shows the prompt, and after it times out (login period expires), only then does the screensaver start. Turn off compiz and you'll see what I mean. The screen-lock seems to prevent compiz from blocking the screensaver.

Disabling compiz for all users also fixes all these issues, and then everything works as advertised.

-Nvidia 8600GT with version 177 restricted drivers

I can confirm the DJ Dallas' white-screen problem. If you uncheck "Undirect fullscreen windows" for a user (say X), you get a white screen when you switch from one user to the X user.

I fear that we will have to find another fix/workaround for this bug... :(

DJ Dallas (djdallas) wrote :

I can confirm that the patch Thierry posted does allow the screensaver to start normally. The "lock screen..." checkbox in gnome-screensaver didn't cause any issues here.

However, it still introduces the white screen when switching users with the User Switcher on the panel. Black screen on resume is no longer an issue. Here is a possible solution; I just don't know how to implement it:

If a user wants to "lock screen after switching users" when using the User Switcher applet, why not return to the GDM login screen for the password? The click on "System, Log out, Switch user" approach to switching users seemed to work. So, that could be an easy workaround. If a user doesn't lock their session, then the white screen is not an issue when you return to that session.

Sorry about the repeated misspelling of "Unredirect Fullscreen Windows" in the previous post!

Thierry Carrez (ttx) wrote :

Forget my Lock screen issue (comment 29), it is unrelated (see bug 275957).

Andrea P (pinnisi) wrote :

everything fine here!

shouldn't have gss task, bug is a missed patch in compiz (see above)

Changed in gnome-screensaver:
status: Confirmed → Invalid
Christopher (soft-kristal) wrote :

I attached an external monitor and the screensaver began behaving normally. Very odd.

Martin Pitt (pitti) wrote :

I confirm that this patch fixes the screen saver for me, too. Thanks, Thierry! I'll talk to Michael again and sponsor this.

Michael Vogt (mvo) wrote :

I talked to upstream about this and I'm not sure if there is not a bug in gnome-screensaver here as well:

onestone: unredirect creates and unmap and a map notify for the screensaver. maybe gnome screen saver understands them wrong

Does the Thierry's patch have the white-screen side-effect? (see comments #33, #34, #35).

Michael Vogt (mvo) wrote :

The issue seems to be that the gnome-screensaver watches for "visibility_notify_event" in gs-window-x11.c

For unredirect fullscreenwindows it get:

[gs_window_real_visibility_notify_event] gs-window-x11.c:2059 (21:02:19): gs_window_real_visibility_notify_event(): 7bf080 unobscured
[gs_window_real_visibility_notify_event] gs-window-x11.c:2059 (21:02:19): gs_window_real_visibility_notify_event(): 7bf080 fully_obscured
[gs_window_real_visibility_notify_event] gs-window-x11.c:2059 (21:02:20): gs_window_real_visibility_notify_event(): 7bf080 unobscured

but without "unredirect fullscreen windows" its:
[gs_window_real_visibility_notify_event] gs-window-x11.c:2059 (21:07:02): gs_window_real_visibility_notify_event(): 7bf260 unobscured

Now in gs-manager.c window_obscured_cb () is run and it tests if the window is obscured. If that is the case, it requests a unlock.

Michael Vogt (mvo) wrote :

I debugged that a bit further and the current theory is that when XCompositeUnredirectWindow() on a redirected window is called (that happens with unredirect fullscreen windows) then the xserver will do a internal map/unmap cycle. No events are generated for this, its for internal resource (re)allocation. But it looks like it still has as the side-effect a user-visible "Unobscured", "FulylObscured", "Unobscured".

I see the following options:
a) fix it in the xserver (hard but the best way)
b) fix it in xscreensaver by adding detection if the window cycles between redirected and unredirected (medium hard)
c) re-add the hack in compiz that ignored gnome-screensaver for redirect fullscreen windows (easy, but we get the whie-screen bug back this way)

Michael Vogt (mvo) wrote :

I think the following patch fixes the problem in the xserver.

diff -u xorg-server-1.5.2/dix/window.c xorg-server-1.5.2/dix/window.c
--- xorg-server-1.5.2/dix/window.c
+++ xorg-server-1.5.2/dix/window.c
@@ -3259,6 +3258,8 @@
 SendVisibilityNotify(WindowPtr pWin)
 {
     xEvent event;
+ if (!MapUnmapEventsEnabled(pWin))
+ return;
 #ifndef NO_XINERAMA_PORT
     unsigned int visibility = pWin->visibility;
 #endif

Michael Vogt (mvo) wrote :

Normal obscured/unobscured events are still delivered AFAICS - but the screensaver issue is fixed for me with it.

Michael Vogt (mvo) wrote :

I put debs for xserver-xorg with the patch into my PPA:
https://launchpad.net/~mvo/+archive/+index?start=50&batch=50

Michael Vogt: Your PPA packages solved the bug on my system too. Thanks!

Thierry Carrez (ttx) wrote :

Michael:
Confirmed your PPA packages fix the issue for me too. Good job :)

Michael Vogt (mvo) on 2008-10-20
Changed in compiz:
status: In Progress → Invalid
Changed in xorg-server:
assignee: nobody → mvo
importance: Undecided → Medium
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.5.2-2ubuntu1

---------------
xorg-server (2:1.5.2-2ubuntu1) intrepid; urgency=low

  * debian/patches/150_no_visibility_notify_on_unredirect.patch
    - do not sent VisibilityNotify events when MapUnmapEvents
      are disabled (LP: #278112)

 -- Michael Vogt <email address hidden> Sat, 18 Oct 2008 00:05:30 +0200

Changed in xorg-server:
status: In Progress → Fix Released
Oliver Grawert (ogra) wrote :

not fixed on any of my devices, neither in the mobile image nor on ubuntu desktop on my laptop

John Dong (jdong) wrote :

Not on any of my devices either, updated this morning. Same symptoms as before.

Jan Mynarik (jan-mynarik) wrote :

It is fixed for me. Thanks!

Jan (jan23) wrote :

The fix works for me. Thanks!

Bernhard (b.a.koenig) wrote :

Not fixed for me either. I guess we have a split vote. :(

Fixed for me!

Bernhard (b.a.koenig) wrote :

OK, so I downloaded the new version and it works for me now, so I retract my earlier statement. Sorry for that and thanks for the fix!

Thierry Carrez (ttx) wrote :

For me it fixes the bug from the description : "the screen starts to fade, but then immediately returns to the desktop instead of starting the screensaver".

(Note that I still have just a blank screen rather than a specific screensaver if running on battery, but this is not what this bug is about, and I tend to consider this a feature rather than a bug).

For those who still report failure with xorg-server 2:1.5.2-2ubuntu1 installed, maybe you're experiencing a slightly different bug, that might warrant a separate bug report. In particular, I know Oliver could workaround the issue by setting xset -dpms in a terminal window, which I couldn't.

julien martigny (julienmn) wrote :

hello, i am having the exact same behaviour.
i.e. screen start to blank but than goes back to normal. if I disable screen-saver , the monitor powermanagement standby does not start either. i cant use the trick of unchecking the "unredirect fullscreen windows" because if I do so , the 3d application that I use in full screen is becoming super laggy. This is with the official release of intrepid ibex, just wanted to let you know guys. and is there a plan of that being fixed by some updates at some point.

this is with amd64 cpu using 32bit version of ubuntu, nvidia 8600gt, compiz and all updates done.

thank you

julien martigny (julienmn) wrote :

well i guess you can ignore my last post, it started to work normally 3 days after the install.
what is strange is that i did nothing that i can remember to fix it.

zorblek (zorblek) wrote :

I am experiencing this exact problem in Intrepid, with all updates installed. So far, it has not gone away on its own. :)

If there's any additional info I can provide, please let me know.

Bernhard (b.a.koenig) wrote :

Did you check the settings in "System" "Preferences" "Screensaver" to see if it's really activated?

Yes. It is definitely activated.

Michael B. Trausch (mtrausch) wrote :

Hrm. I have this problem on Jaunty, as well. My setup is a dual-head setup, though, so I don't know if that would have anything to do with it. That said, should this issue be re-opened (it looks closed to me, unless I am missing something) or should a new bug be filed?

Michael B. Trausch (mtrausch) wrote :

(Though, I can use the "gnome-screensaver-command -a" command to start the screensaver; it just doesn't properly start when the session is idle. It will fade, then come right back to the desktop... but manually starting it every time is a pain...)

Noel J. Bergman (noeljb) wrote :

> It will fade, then come right back to the desktop...

Exactly as I described in Bug 270129. But that's long been closed and working for me, although I don't recall if I have tried it on a dual-head scenario lately. Will try it this evening, and report if it fails.

zorblek (zorblek) wrote :

Mine is definitely not dual-headed, either.

On Thu, Apr 16, 2009 at 4:39 PM, Noel J. Bergman <email address hidden> wrote:

> > It will fade, then come right back to the desktop...
>
> Exactly as I described in Bug 270129. But that's long been closed and
> working for me, although I don't recall if I have tried it on a dual-
> head scenario lately. Will try it this evening, and report if it fails.
>
> --
> Screensaver doesn't start
> https://bugs.launchpad.net/bugs/278112
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “compiz” source package in Ubuntu: Invalid
> Status in “gnome-screensaver” source package in Ubuntu: Invalid
> Status in “xorg-server” source package in Ubuntu: Fix Released
> Status in compiz in Ubuntu Intrepid: Invalid
> Status in gnome-screensaver in Ubuntu Intrepid: Invalid
> Status in xorg-server in Ubuntu Intrepid: Fix Released
>
> Bug description:
> Binary package hint: gnome-screensaver
>
> Version: intrepid ibex, 2.24.0-0ubuntu1
>
> This is a continuation from Bug #274926.
> When the session is idle (or when gnome-screensaver-command -a has been
> issued), the screen starts to fade, but then immediately returns to the
> desktop instead of starting the screensaver.
>
> I'm attaching the output of gnome-screensaver (made by Khashayar
> Naderehvandi, not me).
>

This behavior has affected a Jaunty machine.

It has an ATI card with the Open-source drivers.
Compiz is activated, and "Unredirect Windows" is unticked.

The symptoms described in the bug report are exactly what happens.

I've attached a log.

BinaryFu (binaryfu) wrote :

Having no programming skills but a fair amount of Beta test work in many programs and a few operating systems, please take the following with a grain of noob salt...

It appears that the issue may be the fault of having APM and ACPI active at the same time.

I have had this issue in the past and when I do - I simply go in and turn off one of the two (APM for newer systems gets turned off or ACPI on older pre-2000 systems) and this resolves the issue instantly with a reboot.

I hope this helps.

Cheers,
BinaryFu

This bug still affects me. I'm using Karmic Koala.

I can solve the problem by a reboot or by clicking on the screensaver-preview. When I've done this, the screensaver works fine.

Changed in gnome-screensaver (Ubuntu Intrepid):
status: Invalid → Confirmed
Changed in gnome-screensaver (Ubuntu):
status: Invalid → Confirmed
Chris Coulson (chrisccoulson) wrote :

Please don't open previously fixed or invalidated tasks. Please report a new bug instead

Changed in gnome-screensaver (Ubuntu):
status: Confirmed → Invalid
Changed in gnome-screensaver (Ubuntu Intrepid):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers