gnome-panel will not autostart on lucid

Bug #542343 reported by Virgil Brummond
648
This bug affects 111 people
Affects Status Importance Assigned to Milestone
cdbs
Invalid
Undecided
Unassigned
cdbs (Ubuntu)
Fix Released
Critical
Unassigned
gnome-panel (Ubuntu)
Fix Released
High
Canonical Desktop Team

Bug Description

Binary package hint: gnome-panel

After the latest updates on Lucid, I rebooted. When logging in I found my gnome panel did not start, though Compiz and Nautilus did. Doing a dpkg-reconfigure or resetting preferences did not fix the issue. A workaround is to add a launcher for gnome-panel on the desktop, and clicking it at login. If you need any information please ask.

ProblemType: Bug
Architecture: amd64
Date: Fri Mar 19 21:02:11 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
Package: gnome-panel 1:2.29.92.1-0ubuntu1
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: gnome-panel
Uname: Linux 2.6.32-16-generic x86_64

Revision history for this message
Virgil Brummond (uraharakisuke153) wrote :
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

It seems that the latest langpack.mk is mangling all the desktop files, and putting X-Ubuntu-Gettext-Domain above the "[Desktop Entry] " header in all the new builds

Changed in cdbs (Ubuntu):
importance: Undecided → Critical
status: New → Triaged
Revision history for this message
Addamaccada (adematthews) wrote :

I`m getting similar errors after updating my machine, however there are slight differences on my machine compiz loads up but nautilus & gnome-panel do not.

When I run them from terminal I get

ade@laptop:~$ gnome-panel

(gnome-panel:2025): EggSMClient-WARNING **: Could not load desktop file '/usr/share/applications/gnome-panel.desktop': Key file does not start with a group

gnome-panel then loads correctly

ade@laptop:~$ nautilus

(nautilus:2008): EggSMClient-WARNING **: Could not load desktop file '/usr/share/applications/nautilus.desktop': Key file does not start with a group
Segmentation fault (core dumped)

Revision history for this message
Chris Coulson (chrisccoulson) wrote :
Download full text (3.1 KiB)

kenvandine just did an upgrade, and so far these desktop files are broken (so these packages will need a rebuild at some point):

Invalid desktop file /usr/share/applications/nautilus-autorun-software.desktop: ParsingError in file '/usr/share/applications/nautilus-autorun-software.desktop', [Desktop Entry]-Header missing
Invalid desktop file /usr/share/applications/evolution-2.2.desktop: ParsingError in file '/usr/share/applications/evolution-2.2.desktop', [Desktop Entry]-Header missing
Invalid desktop file /usr/share/applications/empathy.desktop: ParsingError in file '/usr/share/applications/empathy.desktop', [Desktop Entry]-Header missing
Invalid desktop file /usr/share/applications/palimpsest.desktop: ParsingError in file '/usr/share/applications/palimpsest.desktop', [Desktop Entry]-Header missing
Invalid desktop file /usr/share/applications/empathy-accounts.desktop: ParsingError in file '/usr/share/applications/empathy-accounts.desktop', [Desktop Entry]-Header missing
Invalid desktop file /usr/share/applications/gnome-panel.desktop: ParsingError in file '/usr/share/applications/gnome-panel.desktop', [Desktop Entry]-Header missing
Invalid desktop file /usr/share/applications/nautilus-computer.desktop: ParsingError in file '/usr/share/applications/nautilus-computer.desktop', [Desktop Entry]-Header missing
Invalid desktop file /usr/share/applications/rhythmbox.desktop: ParsingError in file '/usr/share/applications/rhythmbox.desktop', [Desktop Entry]-Header missing
Invalid desktop file /usr/share/applications/nautilus-file-management-properties.desktop: ParsingError in file '/usr/share/applications/nautilus-file-management-properties.desktop', [Desktop Entry]-Header missing
Invalid desktop file /usr/share/applications/ubuntu-about.desktop: ParsingError in file '/usr/share/applications/ubuntu-about.desktop', [Desktop Entry]-Header missing
Invalid desktop file /usr/share/applications/nautilus.desktop: ParsingError in file '/usr/share/applications/nautilus.desktop', [Desktop Entry]-Header missing
Invalid desktop file /usr/share/applications/gedit.desktop: ParsingError in file '/usr/share/applications/gedit.desktop', [Desktop Entry]-Header missing
Invalid desktop file /usr/share/applications/evolution.desktop: ParsingError in file '/usr/share/applications/evolution.desktop', [Desktop Entry]-Header missing
Invalid desktop file /usr/share/applications/network-scheme.desktop: ParsingError in file '/usr/share/applications/network-scheme.desktop', [Desktop Entry]-Header missing
Invalid desktop file /usr/share/applications/nautilus-home.desktop: ParsingError in file '/usr/share/applications/nautilus-home.desktop', [Desktop Entry]-Header missing
Invalid desktop file /usr/share/applications/mount-archive.desktop: ParsingError in file '/usr/share/applications/mount-archive.desktop', [Desktop Entry]-Header missing
Invalid desktop file /usr/share/applications/nautilus-folder-handler.desktop: ParsingError in file '/usr/share/applications/nautilus-folder-handler.desktop', [Desktop Entry]-Header missing
Invalid desktop file /usr/share/applications/nautilus-browser.desktop: ParsingError in file '/usr/share/applications/nautilus-browser.desktop', [Desktop Entry]...

Read more...

Revision history for this message
Nathan Rogers (nathaniel-r) wrote :

This can easily be fixed by editing the gnome-panel.desktop file

`sudo vim /usr/share/applications/gnome-panel.desktop`

Move the first line ("X-Ubuntu-Gettext-Domain=gnome-panel-2.0") that appears before the group name '[Desktop Entry]' to some point after, for example mine now looks something like this:

<code>
[Desktop Entry]
Type=Application
Name=Panel
Comment=Launch other applications and provide various utilities to manage windows, show the time, etc.
Icon=gnome-panel
Exec=gnome-panel
StartupNotify=true
Terminal=false
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=gnome-panel
X-GNOME-Bugzilla-Component=general
X-GNOME-Bugzilla-Version=2.29.92.1
Categories=GNOME;GTK;Utility;Core;
OnlyShowIn=GNOME;
NoDisplay=true
X-GNOME-AutoRestart=true
#X-GNOME-Autostart-Phase=Panel
X-GNOME-Provides=panel
X-GNOME-Autostart-Notify=true
X-Ubuntu-Gettext-Domain=gnome-panel-2.0
</code>

Revision history for this message
gokul (dotgokul) wrote :

I am affected too. Nothing in gnome starts, even in failsafe mode.
To get a working desktop, I have to start an xterm session, then start gnome-panel first and then start gnome-session. Starting a gnome-session first from xterm does not work.

I got similar errors as mentioned in comment #4.

Revision history for this message
holstein (mikeholstein) wrote : apport information

Architecture: i386
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100304)
Package: gnome-panel 1:2.29.92.1-0ubuntu2
PackageArchitecture: i386
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
Tags: lucid
Uname: Linux 2.6.32-16-generic i686
UserGroups: adm admin cdrom dialout lpadmin netdev plugdev sambashare

tags: added: apport-collected
Revision history for this message
holstein (mikeholstein) wrote : Dependencies.txt

apport information

Revision history for this message
holstein (mikeholstein) wrote : GConfNonDefault.txt

apport information

collinp (collinp)
Changed in gnome-panel (Ubuntu):
status: New → Confirmed
Revision history for this message
Delan Azabani (azabani) wrote :

gokul: You could use Nathan's workaround, or start the gnome-panel from tty1 as follows:

export DISPLAY=:0.0
gnome-panel&

logout

Revision history for this message
gokul (dotgokul) wrote :

Delan: Thanks. I don't get ttys -- a different bug, I think. I will try the other workaround.

Revision history for this message
collinp (collinp) wrote :

A patch that should work for standard installations of gnome-panel is included. To patch, download to your home directory (~/), and execute, in a terminal:
"sudo patch -i gnome-panel.desktop.patch /usr/share/applications/gnome-panel.desktop"
This should work for users that have the problem as described by Nathan Rogers in a previous comment.

Exact commands used to create and test the patch (with gnome-panel.desktop being the broken version and gnome-panel.desktop1 being the fixed version):
"diff -cr /usr/share/applications/gnome-panel.desktop /usr/share/applications/gnome-panel.desktop1 > gnome-panel.desktop.patch"
"sudo patch -i gnome-panel.desktop.patch /usr/share/applications/gnome-panel.desktop"

tags: added: patch
Changed in gnome-panel (Ubuntu):
importance: Undecided → High
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Revision history for this message
Virgil Brummond (uraharakisuke153) wrote :

After a reboot, nautilus will no longer run. I have to run both from a terminal emulator at login. I can get to a console by pressing ctrl+alt+t.

Revision history for this message
supermalloch (supermalloch) wrote :

I have the same error as #3 and have to clue as to how to get gnome started again ;-; , this is the 2nd time this has happened last time I just did a reinstall thinking that mmaybe it failed , but its happening once again. Thhe first login worked, then gnome became non responsive and upon reboot, no longer started when I log in. Help me plz x.x I also tried sudo vim ect..... and got a command not found error for vim .... :(

Revision history for this message
William Grant (wgrant) wrote :

The cdbs change has been reverted. Once it's published, the critical broken bits will be rebuilt.

Revision history for this message
supermalloch (supermalloch) wrote :

Sudo nano worked instead of vim if you had the same problem as me , thanks nathan :)

Emmet Hikory (persia)
Changed in cdbs:
status: New → Invalid
Changed in gnome-panel (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Confirmed
Revision history for this message
Emmet Hikory (persia) wrote :

CDBS Task now Fix Releasd in lucid, as 0.4.62+nmu1ubuntu7 has propagated to the buildd mirror. Just needs rebuilds of affected pacakges.

Changed in cdbs (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Krzysztof Kolasa (kkolasa) wrote :

After correction (transfer of the first line before Section [Desktop Entry] at the end of the file) files identified by Chris Coulson Gnome is working properly

Revision history for this message
Emmet Hikory (persia) wrote :

nautilus and gnome-panel have been rebuild against reverted CDBS and published for i386/amd64. Other architectures are pending build publication, and should be available in about an hour. Some users may continue to experience this bug depending on mirroring delays for several hours to come. Please take care when upgrading.

Changed in gnome-panel (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
William Grant (wgrant) wrote :

gnome-panel and nautilus 1:2.29.92.1-0ubuntu3 are fixed and on archive.ubuntu.com. Upgrading to those will restore desktop functionality.

To temporarily recover from a blank desktop so you can run the upgrade, press Ctrl+Alt+T to start a terminal, and run 'gnome-panel'.

[I'm currently grepping recent binaries to find anything else that needs to be rebuilt, so it may be a while before some other missing applications return.]

Revision history for this message
tgpraveen (tgpraveen89) wrote :

upgraded and most things back to normal.
totem still not working/available.

Revision history for this message
Bruno Adele (bruno-adele-launchpad) wrote :

After change from french repository(mirror) to master repository and apply upgrade, it's work now !

Thx

Revision history for this message
William Grant (wgrant) wrote :

I've completed a scan of all builds finished since the problematic cdbs upload, and we fixed all of them in the initial upload batch. All packages for all architectures except sparc and armel will be on archive.ubuntu.com within the hour.

Again, please be careful when upgrading that your mirror has the fixed versions of gnome-panel and nautilus -- look for -0ubuntu3 in the version, not -0ubuntu2.

Revision history for this message
Sebastien Bacher (seb128) wrote :

closing since that's fixed now in lucid

Changed in gnome-panel (Ubuntu):
status: Fix Committed → Fix Released
Naoki NAKAMURA (nnkmr)
Changed in gnome-panel (Ubuntu):
status: Fix Released → Fix Committed
Revision history for this message
jerrylamos (jerrylamos) wrote :

Hit this problem this morning on Beta 1.

Did a sudo aptitude -q update and a sudo aptitude -q safe-upgrade
now gnome panel is coming up (just wait til the next update!)

The "-q" is required for me to get around a "glibc" crash Bug #515525.

Jerry

Naoki NAKAMURA (nnkmr)
Changed in gnome-panel (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Uncle Spellbinder (spellbinder) wrote :

Since the "Missing Menu Entries - Lucid Beta 1" bug (#542300) has been marked a dupe of this bug, I thought I'd summarize:

Beta 1 (32-bit) - Menu > system tools is empty and system > preferences > main menu >system tools is empty. The other 2 issues of nVidia settings and Control Center not being present in the menus seems to have been corrected by a recent update.

tags: added: regression-potential
tags: removed: regression-potential
Revision history for this message
Madde (cev-madde) wrote :

I fail to see why this bug: https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/542507 is a duplicate of this one...

Revision history for this message
Chris Coulson (chrisccoulson) wrote : Re: [Bug 542343] Re: gnome-panel will not autostart on lucid

On Sat, 2010-03-20 at 18:25 +0000, Madde wrote:
> I fail to see why this bug:
> https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/542507 is a
> duplicate of this one...
>
Because it's the same problem. The malformed desktop file triggered the
symptoms in Nautilus too

Revision history for this message
Uncle Spellbinder (spellbinder) wrote :

So how, exactly, do .desktop entries effect missing menu entries?? In Karmic (and previous versions) as well as Lucid up through Alpha 3, System Tools included the entries "Configuration Editor", "File Browser", "GDebi", "Report A Problem" and "Root Terminal". All are now not present. This was viewable in system > preferences > main menu >system tools. The menu editor had these entries up until Beta 1. I fail to see how my original bug - https://bugs.launchpad.net/ubuntu/+bug/542300 - is a dupe of this bug.

Could someone please enlighten me?

Revision history for this message
Noel J. Bergman (noeljb) wrote :

I had checked the .desktop entries, and did not see the type of corruption present in this bug. In fact, some of them were dated to March 8, predating these problems.

Revision history for this message
K7AAY (john-bartley) wrote :

Unable to reach desktop. Instead, Lucid now launches into a plain purple background with Ubuntu 10.04 above four spaced dots, which switch from white to red in series and back to white again. Unable to execute gnome-panel.

Revision history for this message
William Grant (wgrant) wrote :

K7AAY, that is a separate issue. It sounds like X isn't starting at all in your case.

Revision history for this message
K7AAY (john-bartley) wrote :

Resolved with Nathan Rodgers fix after resolving separate filesystem corruption issue.

Revision history for this message
electhor (electhor) wrote :

I fail to see how this is a duplicate of this issue https://bugs.launchpad.net/bugs/534040 - however, being developers, I guess you are correct as you know much more than I do. Just thought I would add, despite being updated with the latest updates available, there has been no change in behaviour from the original bug, linked to above. Login to desktop is still taking 20+ seconds. I am happy to supply any logs or preform a test if necessary, if someone can send instructions.

Revision history for this message
William Grant (wgrant) wrote :

electhor, neither is marked as a duplicate of the other. The new symptom introduced in your comment #12 is this bug, but that is all.

Revision history for this message
KeithG (grider-4) wrote :

Well, this is affecting me as well on released code?!? I "killall gnome-panel" and it works fine, but from login I get no panels except for one login (mine). The 2 other 'users' get no panels at all. I have set them up with a launcher icon that kills the panels and resets teh panels and all is fine.

I updated Lucid last night and spent a lot of time trying to diagnose and got nowhere. Deleting the config files ~/.g*** and allowing them to be rebuilt does not work. I did try to install that mac like launcher which did not work so I uninstalled it. Also nanny would also not run so I uninstalled that as well (I get no configuration panel though it shows an icon in the panel when it launches). Something is amiss. Much rebooting and logging in and out and no joy. Any help appreciated.

Revision history for this message
Jose L. VG (josvaz) wrote :

Same for me on a supposed to be stable release of a LTS version.

Revision history for this message
J Slater (slater887) wrote :

I have a new install of 10.04 on a Intel board with 815E chipset and Celeron processor. The video is is the integrated version in the 815 chipset. On this machine, Lucid launches with no gnome-panel, but otherwise xwindows is working.

On first launch, before any updating, gnome-panel did appear. And now it re-appears very occasionally, maybe every 20th boot.

Any help would be appreciated. I am aware that gnome-panel can be launched by hand after the boot.

Revision history for this message
Erasmo Ruiz (erasmorg) wrote :

The status appears like fixed, but I upgraded to 10.04 today and gnome-panel does not work, in repositories is stiil the bug.
I returned to 9.10

Revision history for this message
Adam Guthrie (therigu) wrote :

Marking as patch-rejected since provided patch, though good, is only a workaround and the issue was fixed elsewhere.

tags: added: patch-rejected
Tom Lynch (tj-lynch)
Changed in gnome-panel (Ubuntu):
status: Fix Released → In Progress
William Grant (wgrant)
Changed in gnome-panel (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Alvils Berzins (alvils) wrote :
Download full text (3.3 KiB)

Hmm, I must admit this seems like some kind of a race condition to me. As Lucid in general starts up processes "in parallel", then in a case where the system performance is not adequate, things might go south.
To test this, I have assembled two machines of notably low performance.
The first one is running on a Celeron 667 (sic) MHz CPU. Initially I put 256 megs of RAM into it. It has a 20 GiB hard drive. Swapping as hell, it worked, apart from the fact that its i740 video card didn't support resolutions higher than 800x600 and so I was forced to generate an xorg.conf file and use the vesa driver. But that's another issue. Adding an additional 256 MiB helped to remedy the swapping issue, and, although pretty slow, it still worked.
The second one is the precise Intel Desktop Board with the i815 chipset mentioned in post #38. It has a Celeron 600 MHz CPU and 384 MiB of RAM installed. It uses the embedded video. Oh my - the first logon works as it should, as perhaps the configuration files are generated/cached, but the second one has no panel. Actually the panel launches, and pressing Ctrl+Alt+T to open the terminal and issuing `sudo killall gnome-panel` brings it back up. I tried to edit the /usr/share/applications/gnome-panel.desktop file and uncomment the X-gnome-autostart-phase=Panel line. After doing that, deleting ~/.g* directories and rebooting the panel came up again. And so after several restarts. But then I realized another issue - Nautilus does things the same way, so, although the panel is up, the desktop icons ain't. :(
Needless to say that after installing the updates the .desktop files were changed back to original, so just editing them is not enough, as any updates could put "things back to normal".
I suspect the problem is Celeron 600's performance. I have a Celeron 766 MHz somewhere at home, so if I find it, I'll try to install that CPU on the faulty PC and see whether startup works normally then. It could be that the critical line for using a Celeron CPU is somewhere between 600 and 667 MHz. At least in the configuration I used.
Anyway, regardless of whether my tests will be successful, the very main issue that creates such behaviour is the one Lucid developers are proud of - parallel starting of processes. While giving an advantage on modern multi-core CPUs, this may not work on slower machines. I would be very glad in this regard if there was an option available during the installation (and maybe also afterwards) that would allow me to choose whether I want to start processes in parallel or in a sequential manner, so owners of older and slower machines (anyway, Celeron 600 is still enough for my Grandma to read e-mails) could also run Lucid. At the very least, update manager should not try to be smarter than me and change the .desktop files back to "original". If I have edited them, I think I know what I'm doing and WHY I am doing that... :(

So, the bottom line of this is: I strongly suspect that this "bug" is created by the parallel starting of processes. If a machine, for whatever reason, does not have enough horsepower, a race condition could appear. The obvious solution would be to allow the user to choose a "compatibili...

Read more...

Revision history for this message
Virgil Brummond (uraharakisuke153) wrote :

Alvils Berzins, perhaps try setting the swappiness parameter to vm.swappiness=100 on machines with low ram. I find this makes things much smoother.

To do so:

1. Open this text file as root: /etc/sysctl.conf
2. Append this to the end: vm.swappiness=100
3. Reboot.

Revision history for this message
Alvils Berzins (alvils) wrote :

Hi Virgil,

Thanks for the tip. :) Actually, this is a good idea.
Yet, this is not the case. As I wrote, a Celeron 667 with 256 MiB of RAM swaps, but works. A Celeron 600 with 384 MiB does not.

Revision history for this message
William Grant (wgrant) wrote :

Virgil, Alvils: Whatever you are experiencing, it is not this bug. Please file another.

Changed in gnome-panel (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Revision history for this message
candtalan (aeclist) wrote :

I get loss of panels from a fully updated ubuntu 10.10 in an old machine with lots of RAM, also in fact in Ubuntu 10.04 also.
The comment above by Alvils Berzins is very interesting indeed because my problem machine is PIII 650MHz, right in his proposed trouble range.
The Ubuntuforums thread re ubuntu 10.10 which includes the post
http://ubuntuforums.org/showpost.php?p=10084974&postcount=13
starts with an apparent X crash but then also reveals the same 'missing panels' situation which was seen in the same machine in ubuntu 10.04.

It is beginning to look as if I just cannot make use of Ubuntu for these old machines...

Changed in gnome-panel (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Eugen Vlasov (eugensvlasov)
Revision history for this message
Greg Grossmeier (greg.grossmeier) wrote :

Eugen: Please do not reassign bugs, especially ones that are already marked as "Fix Released"

Changed in gnome-panel (Ubuntu):
assignee: Eugen Vlasov (eugensvlasov) → Canonical Desktop Team (canonical-desktop-team)
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related questions