Window list behaves bad when panel is vertical.

Bug #43066 reported by neutrico on 2006-05-05
358
This bug affects 54 people
Affects Status Importance Assigned to Milestone
GNOME Panel
Confirmed
High
gnome-panel (Ubuntu)
Medium
Ubuntu Desktop Bugs
Declined for Karmic by Dmitry Shachnev
libwnck (Ubuntu)
Medium
Ubuntu Desktop Bugs
Declined for Karmic by Dmitry Shachnev

Bug Description

Binary package hint: gnome-panel

Ubuntu dapper

Use default panel settings.

Put gnome-panel that contains window list on right or left edge of screen.
Also drag gnome-panel that is on top to some side of the screen.

You will see a lot of weird behaviour there.

Window list will be almost unusable when panel height is small - only icons are visible, and text with application names is invisible because these buttons are not rotated 90degrees.

While clock and main menu (applications/places/system) will be rotated and text will be visible.

Someone should provide some HIG standard to these panel elements while panel is vertical.

In fact I'm not sure which behaviour is better...

Window list is almost unusable, but also clock and main menu that is rotated is not comfortable at all :-)

Please provide some better ideas or just block an ability to put gnome-panel on right/left edge.

Sebastien Bacher (seb128) wrote :

Thanks for your bug. That's known upstream: http://bugzilla.gnome.org/show_bug.cgi?id=86382

Changed in gnome-panel:
assignee: nobody → desktop-bugs
status: Unconfirmed → Confirmed
Changed in gnome-panel:
status: Confirmed → Triaged
paskma (paskma) wrote :

I've recorded demonstration of this bug, it can be found here:

http://www.youtube.com/watch?v=dhCbnq08roA

It shows how the gnome panel completely freezes when more than 7 windows is opened. Demonstrated on Hardy Alpha4, GNOME 2.21. This bug makes vertical panel usage completely unusable.

This bug appeared in GNOME 2.20 (in 2.18 it was not perfect but it worked). There are patches available in GNOME bugzilla #86382 but they were not integrated.

Sebastien Bacher (seb128) wrote :

You comment on a bug which has been opened before GNOME 2.20 so your issue is a different one, it looks rather bug #187540

This problem still occurs in the current Hardy snapshot.

See:
http://www.ucc.asn.au/~mccabedj/ccache/Screenshot-Hardy-fdccache.png

Sebastien Bacher (seb128) wrote :

untagging from the hardy desktop list, that's not something we have ressources to change this cycle without upstream and not a high priority issue neither

Cay Horstmann (cay) wrote :

I understand it is not like solving world hunger, but it is a pain. You don't want the window list on top because that's where apps put their menus, and you want to mouse there quickly. You don't want it on the bottom if you use a laptop because you lose the bottom when you detach from a large screen monitor. The left is the rational choice, but this bug blocks it.

Carey Underwood (cwillu) wrote :

This is a duplicate of 152838.

The root cause is that libwnck (the window list) is providing a size hint based on the desired width of the buttons * the number of columns (based on 25 characters visible), and gnome-panel using that hint to determine the vertical size of the switcher.

Walter Huf (hufman) wrote :

Yay, this bug has finally been triaged!
That means we'll see a fix soon, right? Right? Especially since the upstream bug has an attached patch that fixes it? Right??

Tired of waiting, I have a hack job that beats libwnck22's tasklist.c
into submission. And the best part is, it can be cleaned up into an
actual _proper_ patch!

On Wed, May 27, 2009 at 8:39 AM, Walter Huf<email address hidden> wrote:
> Yay, this bug has finally been triaged!
> That means we'll see a fix soon, right? Right? Especially since the upstream bug has an attached patch that fixes it? Right??
>
> --
> Window list behaves bad when panel is vertical.
> https://bugs.launchpad.net/bugs/43066
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Carey Underwood (cwillu) wrote :

Horrible horrible patch that knowingly breaks grouping, and horizontal
panels. But not in a fundamentally "wrong" way, just in a "lets
comment out all this irrelevant code" way.

Expect a cleaner patch really soon.

Carey Underwood (cwillu) wrote :

Cleaned up the patch significantly, re-enabled the grouping and
horizontal panels, and as an added bonus added multiple column support
back into the vertical panels, but only when they're _really_ full.

This patch is more suitable for sane eyes.

On Sat, Aug 8, 2009 at 1:12 AM, cwillu<email address hidden> wrote:
> Horrible horrible patch that knowingly breaks grouping, and horizontal
> panels.  But not in a fundamentally "wrong" way, just in a "lets
> comment out all this irrelevant code" way.
>
> Expect a cleaner patch really soon.
>

Carey Underwood (cwillu) wrote :

A slightly cleaner patch again.

Changed in gnome-panel (Ubuntu):
status: Triaged → In Progress
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Carey Underwood (cwillu) wrote :

(oops)

Changed in gnome-panel (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
Saivann Carignan (oxmosys) wrote :

Carey Underwood : Why don't you attach your patch in the upstream bug report? http://bugzilla.gnome.org/show_bug.cgi?id=86382

It would be awesome if you can get this patch to be accepted upstream.

Carey Underwood (cwillu) wrote :

Removed a couple lingering bogus hardcoded values

Sebastien Bacher (seb128) wrote :

Could you add your change to the upstream bug?

Carey Underwood (cwillu) wrote :

I will as soon as I can. I'm giving it one more day of use at work
today, and then I'll send the patch upstream. I've been trying to
poke people in gimpnet's #gnome-hackers, but everyone scatters and
hides every time I bring up libwnck :p

Sebastien Bacher (seb128) wrote :

Upstream is doing patch review today for 2.27.90 tarballs due today would be nice to send the change now

Carey Underwood (cwillu) wrote :

In that case...

Last change to mostly fix an asymmetry in the "use all available
space" logic (doesn't handle right clicking in empty space properly in
vertical orientation, but this is still way better behaviour than
previously).

On Mon, Aug 10, 2009 at 8:39 AM, Sebastien Bacher<email address hidden> wrote:
> Upstream is doing patch review today for 2.27.90 tarballs due today
> would be nice to send the change now
>
> --
> Window list behaves bad when panel is vertical.
> https://bugs.launchpad.net/bugs/43066
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Carey Underwood (cwillu) wrote :

Sebastien Bacher:

What would it take for this to be included in directly in Ubuntu's package? There's been no activity upstream that I can see despite the patch getting positive reviews by users on the gnome bug, and I'm not in a position to spend much more time trying to push over a brick wall that hasn't given any sign of giving way.

Sebastien Bacher (seb128) wrote :

Upstream is doing patch review this week we will have a look before karmic beta if they don't comment before

Sebastien Bacher (seb128) wrote :

The bug should be reassigned to libwnck?

Carey Underwood (cwillu) wrote :

It should probably be against both. The panel doesn't provide enough information for the applet to do the right thing in both orientations, although the worst of the behaviour comes from libwnck's handling of the situation.

Changed in libwnck (Ubuntu):
status: New → In Progress
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
h1l4nd0r (chupan) wrote :

hi i hve similar situation

see my video : )

Changed in libwnck (Ubuntu):
importance: Undecided → Low
importance: Low → Medium
h1l4nd0r (chupan) wrote :

I would say the importnce should be High not Medium

because Ubuntu must be Ubuntu , for human beings, and so convinient for humans

Thane Gill (thaneg) wrote :

Definitely a bad bug for me, I would say high priority, it stops me from really using Ubuntu.

I put task bars / panels at the sides of my screens because docs, websites etc. are thinner than they are tall. I don't want to squash viewing area because the panel hasn't been well designed in a vertical orientation.

n3rd (n3rd) wrote :

It is unbelievable that this bug is still existing! That it what makes Linux so uncomfortable to use for most of the people, lots of cool and innovative features but it seems that most of them are poor implemented and buggy. Not only that, the bugs are not getting fixed were it appears to be easy.

I am using Linux now for a couple of years now and have a vertical panel in gnome for quite some, this bug is really annoying and should be addressed soon - priority high -, as it is a really fundamental problem. By the way, I am using the gnome-panel-fix script described here http://www.osfight.de/archives/92 (in german), which worked so far for me on 8.04 - 9.04.

riprop (riprop) wrote :

I've also weiting year and a half for solution for this bug. Please make importance high. Regards

Arno Mayrhofer (azrael3000) wrote :

I can confirm that the patch is working on Karmic to a certain extent.
However as mentioned in https://bugzilla.gnome.org/show_bug.cgi?id=86382 comments 140, 141 and 145 there are some final issues to be resolved.
Thanks Carey.

Arno

yvadim (yvadim) wrote :

Sorry for being expressive, but this bug is annoying as the hell together with notification area one in vertical orientation. I wonder if this defect gets fixed before I learn programming under gtk and fork crappy libwnck into something more usable, like separate panel and windows list applet packages for human beings.

Cheers.

Cay Horstmann (cay) wrote :

I actually did learn enough to do this--see my post https://bugzilla.gnome.org/show_bug.cgi?id=86382#c153. It worked like a charm, but it doesn't look as if anyone wanted to bite and roll that into a patch. Then I found out that AWN works just fine with a vertical panel, and that's what I use now. Check it out! http://wiki.awn-project.org/

Carey Underwood (cwillu) wrote :

An additional patch available at the gnome bug report overlays on mine to fix most of the remaining issues.

David Futcher (bobbo) on 2010-06-08
tags: added: patch-forwarded-upstream

In Lucid (GNOME Panel 2.30.0), I get weird behaviour (oscillation between 1 and 2 columns) when the number of windows in the list exceeds eight. This is about half the height available for the panel.

Since I did not see a step-by-step description here before, I'll add one.

To reproduce:

- Move the taskbar to the right edge of the screen
- Go to a desktop without any windows
- Make sure "Never group windows" and "Show windows from current workspace" is selected
- Open nine terminals
- Try to select one of them from the sidebar.

Result: Jumping back and forth between 1 and 2 columns.

cometdog (ericctharley) wrote :

@ Sebastien Bacher
Nearly 1 year ago you wrote:
>Upstream is doing patch review this week we will have a look before karmic beta if they don't comment before

Any more news on getting this included in upstream? Not everyone's going to be rushing to Gnome Shell, particularly since Ubuntu Lucid is LTS. Maybe this was included already and the current bad behavior in Lucid is something different? Is there anything that can be done to get a fix released for Lucid?

tealex (tealex) wrote :

my bug video
http://www.youtube.com/watch?v=TQFXWh6wxuE

1) vertical panel
2) size like ~20
3) open MANY window
4) you see how windows on panel oscillate

JAdshead (jads) wrote :

This is also presents a big Ubuntu usability issue for me too.. I have spent years placing the taskbar/window list on the left hand side in Windows, where it works sensibly and flawlessly (makes it much easier to work with a large number of open windows).. have never seen it work under Ubuntu. Hate to say it, but it's the same old story, bug reports for basic functionality issues that languish for years.. very off-putting for newcomers to Ubuntu.

Jason Kraftcheck (kraftche) wrote :

"... and one of the things I want to banish is wasted vertical space", Mark Shuttleworth (The 'Banish the Status Bar section of http://www.markshuttleworth.com/archives/333). Yet with each release of Ubuntu vertical gnome panels, the quickest and simplest way to get a little more vertical screen real estate, are more broken.

Changed in gnome-panel:
importance: Unknown → High
Craig Shelley (craigshelley) wrote :

This problem can be solved with by adding 1 line of code to window-list.c within the gnome-panel source.

First ensure you have the latest versions of gnome-panel and libwnck22.

dpkg -l gnome-panel libwnck22
ii gnome-panel 1:2.30.2-1ubuntu3 launcher and docking facility for GNOME
ii libwnck22 1:2.30.5-0ubuntu1 Window Navigator Construction Kit - runtime files

Then get the source and build dependencies

apt-get source gnome-panel
apt-get build-dep gnome-panel

Edit applets/wncklet/window-list.c in your favourite editor and add this line of code to the beginning of function tasklist_update, just before the if statement.

wnck_tasklist_set_orientation(tasklist->tasklist, tasklist->orientation);

Build the package with dpkg-buildpackage, and install the .deb file for gnome-panel.
Alternatively, use the attached patch file instead of manually editing the source code.
Restart the task list applet using;
killall wnck-applet

I hope this helps.
--
Craig Shelley

Sounds beautiful, and thanks for the explicit instructions. However, it does not compile under this version:

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu 10.04.1 LTS"

probably because libwnck22 is too old:

ii libwnck22 1:2.30.0-0ubuntu1

Result:

/home/hta/gnome/gnome-panel-2.30.2/applets/wncklet/window-list.c:76: undefined reference to `wnck_tasklist_set_orientation'

Being a novice in apt-get and debian: is there an easy cookboook to get the newer wncklet src and find the differences?
I would REALLY love to see this bug fixed on my (mainly-lucid) environment!

Moses Moore (moses-mozai) wrote :

Seeing it here in Ubuntu 11.04 'natty'.
One gnome-panel, vertical orientation (right side or left side), with applet 'Window List 2.32.1' in it.

gnome-panel - 1:2.32.1-0ubuntu6.1
libwnck-common - 1:2.30.6-0ubuntu3
libwnck22 - 1:2.30.6-0ubuntu3

Once an eighth icon is added to the Window List applet (by opening an eighth ungrouped window), it flickers like a strobe light between two different heights for the icons.

Corentin SCHREIBER (cschreib) wrote :

Craig's last path works very well for me.

For non programmers, you could add a few details :
1) after running :
apt-get source gnome-panel
apt-get build-dep gnome-panel
... you'll have a new folder named "gnome-panel-xxx" ("xxx" might change, for me it's "2.30.2").
The file that you need to modify is located in "gnome-panel-xxx/applets/wncklet/window-list.c".
2) once you're done, use your terminal to navigate to "gnome-panel-xxx" and type "dpkg-buildpackage". It might take some time to compile the whole thing.
3) when it's done, type "cd .." and "ls". You should see several ".deb" packages.
I only installed one : "gnome-panel_xxx-1ubuntu3_i386.deb" (is it necessary to re-install the others?). To install it, type : "sudo dpkg --install gnome-panel_xxx-1ubuntu3_i386.deb"
4) when it's done, type "killall wnck-applet" : a prompt (or several ones) will ask you if you want to restart the program, answer yes. The problem is now fixed !

Thank you Craig !

That said, it's sad to see that this bug is still present 4 years after its discovery.
The fix appears to be simple, and the problem is quite annoying.

Soo (soowjo) wrote :

Moose,

It is true that Craig's solution does not work with libwnck22 1:2.30.0-0ubuntu1. However, you can add Maverick repository and force libwnck version to 2.30.5. This may cause version consistency issue with some packages later, hence not recommended, however I was able to the get the vertical window list work properly in Lucid.

Like others said, this problem has been around for years, and still no fix.

Moses Moore (moses-mozai) wrote :

Natty 11.04 released -- gnome-panel 1:2.32.1-0ubuntu6.4 is in 'natty-proposed' and the problem is still present.

I followed Craig's instructions in https://bugs.launchpad.net/ubuntu/+source/gnome-panel/+bug/43066/comments/39 , replaced the gnome-panel package (and only the gnome-panel package), and the window-list applet doesn't have the strobing effect when oriented vertically anymore. No need to change the libwnck22 package, just 'gnome-panel'.

Craig Shelley (craigshelley) wrote :

Hello,

I'm just confirming that this bug still exists in the following gnome-panel version:

gnome-panel 1:2.32.1-0ubuntu6.5

The fix described in my original post https://bugs.launchpad.net/gnome-panel/+bug/43066/comments/39
still seems to be a valid fix for the problem.

What do we need to do next in order to get this patch incorporated into the ubuntu package?

Regards,
Craig

Andrzej (ndrwrdck) wrote :

For people who still want a Gnome2-like desktop with a vertical panel like the one described in this bug report:

We have recently extended the the Xfce (Xubuntu) panel to support a vertical panel/horizontal items layout. Changes go well beyond the tasklist. Starting from Xfce 4.10, vertical "deskbar" is one of three supported panel modes and all plugins are (expected to be) aware of it.

To see how it works, you need to change the panel "mode" and "number of rows" (a bit unfortunate name - in vertical panels "rows" are "columns").

Changed in gnome-panel (Ubuntu):
status: In Progress → Confirmed
Changed in libwnck (Ubuntu):
status: In Progress → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.