gnome-panel crashes when selecting location without coordinates

Bug #201102 reported by NickRickard on 2008-03-11
174
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME Panel
Fix Released
Critical
Ubuntu Studio
Undecided
Unassigned
gnome-panel (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Click on the date/time on the deskbar to show the calendar. Click on 'Locations', 'Add', 'Find' and choose Bristol (Europe > UK). Click 'OK' and the deskbar disappears. On Hardy up to about Alpha 3 the deskbar disappeared for good. More recently, the deskbar disappears then reappears after about five seconds but the location is not updated. This is repeatable. I can add London (UK) to the list with no problems.

Hardy Alpha up to date as of 11-Mar-2008.

Grateful for explicit directions if you want any system logs attached. Thanks.

Related branches

James Westby (james-w) wrote :

Hi,

I can confirm this. I do already have a Bristol
entry on my clock though, so it must have
worked at some point I guess.

Go Bristol :)

Thanks,

James

Changed in deskbar-applet:
status: New → Confirmed

Thanks for your bug report. There is some additional information that could help track this down. Could you please look to see if you have a .crash file for gnome-panel? Launch nautilus and navigate to the /var/crash directory and double click on the crash report you wish to submit.

If you have a report there, please close this bug as submitting the report will automatically open a new bug with the information attached. Thanks!

Changed in gnome-panel:
status: Confirmed → Incomplete
NickRickard (nickrickard) wrote :

There's no .crash file for gnome-panel (or similar, just an old one for nm-applet).

On Tue, 2008-03-11 at 19:20 +0000, Andrew Starr-Bochicchio wrote:
> Thanks for your bug report. There is some additional information that
> could help track this down. Could you please look to see if you have a
> .crash file for gnome-panel? Launch nautilus and navigate to the
> /var/crash directory and double click on the crash report you wish to
> submit.
>
> If you have a report there, please close this bug as submitting the
> report will automatically open a new bug with the information attached.
> Thanks!

Sorry, should have said that I am going to grab a backtrace with
gdb when I have a minute, as there is no crash file for the issue.

I'm leaving to bug report as Incomplete to remind me to do that.

Thanks,

James

Hi,

Here's the backtrace for the crash.

#0 0xb59439e9 in clock_zoneinfo_get_coords (this=0x0, lat=0xbf9d2804, lon=0xbf9d2800) at clock-zoneinfo.c:196
No locals.
#1 0xb5939a54 in run_find_location_save (button=0x8456ab8, cd=0x845ac68) at clock.c:3202
 selection = <value optimized out>
 model = (GtkTreeModel *) 0x8742358
 iter = {stamp = -1346971773, user_data = 0x8959c38, user_data2 = 0x0, user_data3 = 0x0}
 loc = (WeatherLocation *) 0x895aa60
 name_entry = <value optimized out>
 edit_window = (GtkWidget *) 0x8447b10
#2 0xb770c2bf in g_cclosure_marshal_VOID__VOID () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#3 0xb76fe789 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#4 0xb7714525 in ?? () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#5 0x083e1830 in ?? ()
No symbol table info available.
#6 0x00000000 in ?? ()
No symbol table info available.

Thanks,

James

Changed in gnome-panel:
status: Incomplete → New
James Westby (james-w) on 2008-03-12
Changed in gnome-panel:
status: New → Confirmed
Colin Watson (cjwatson) wrote :

Same crash when selecting North America -> United States -> Texas -> Houston -> Clover.

Colin Watson (cjwatson) wrote :

The common factor is that neither location entry in /usr/share/libgweather/Locations.xml has a <coordinates/> tag.

Pedro Villavicencio (pedro) wrote :

I was able to get a more complete stacktrace and I've sent this upstream at: http://bugzilla.gnome.org/show_bug.cgi?id=522438 ; thanks for reporting!.

Changed in gnome-panel:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in gnome-panel:
status: Unknown → New
David Orman (ormandj) wrote :

This also occurs for "San Antonio".

Ignacio Larrain (ilarrain) wrote :

Same problem when setting Central and South America > Chile > Santiago.

Changed in gnome-panel:
milestone: none → ubuntu-8.04
Daniel Davidson (trifleb) wrote :

Had same problem for Europe > UK > Midlands > Birmingham

Pedro Villavicencio (pedro) wrote :

fixed upstream, thanks for reporting!.

Changed in gnome-panel:
status: Triaged → Fix Committed
  • unnamed Edit (863 bytes, text/html; charset=ISO-8859-1)

Thanks a lot.

On 03/04/2008, Pedro Villavicencio <email address hidden> wrote:
>
> fixed upstream, thanks for reporting!.
>
>
> ** Changed in: gnome-panel (Ubuntu)
>
> Status: Triaged => Fix Committed
>
>
> --
> gnome-panel crashes when selecting location without coordinates
> https://bugs.launchpad.net/bugs/201102
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Best regards,
Nickolay Kutsyy.

Lafa (luis-alves) wrote :

I got same problem today selecting USA->CA-> lake tahoe

Katsuro (katsuro1989) wrote :

I have the same problems.
I Live in Spain, I add first my location (You can find it, it's Reus), and it adds correctly. Then I add other locations, and all of my desktop crashes, disappearing icons, taskbars,.... and passed about 5 seconds, it appears the icons and the taskbars.
My location, Reus, is saved in, but when I add more locations, crashes all.
I find the cities using the searcher, which obtains the coordinates, and all the data of the location that I want to put.

PD: I am from Spain, and I'm so young, sorry for my bad English.

Mikeisgood (mikeisgoodforyou) wrote :
  • unnamed Edit (2.4 KiB, text/html; charset=ISO-8859-1)

Hey Katsuro and thanks for writing (don't apologize I think you speak
English very well)!!! As you know I have the same problem with this BETA as
well, and I got a response from someone named Pedro about it. I copy and
pasted his response here:

Thanks for the bug report. This particular bug has already been reported
into our bug tracking system, but please feel free to report any further
bugs you find.

** Changed in: gnome-panel (Ubuntu)
      Status: New => Invalid

** Visibility changed to: Public

** Attachment removed: "CoreDump.gz"

  http://launchpadlibrarian.net/13114071/CoreDump.gz

** This bug has been marked a duplicate of bug 201102
  gnome-panel crashes when selecting location without coordinates

--
gnome-panel crashed with SIGSEGV in clock_zoneinfo_get_coords()
https://bugs.launchpad.net/bugs/211821
- Show quoted text -

I hope this helps!!!

On Mon, Apr 7, 2008 at 4:29 PM, Katsuro <email address hidden> wrote:

> I have the same problems.
> I Live in Spain, I add first my location (You can find it, it's Reus), and
> it adds correctly. Then I add other locations, and all of my desktop
> crashes, disappearing icons, taskbars,.... and passed about 5 seconds, it
> appears the icons and the taskbars.
> My location, Reus, is saved in, but when I add more locations, crashes
> all.
> I find the cities using the searcher, which obtains the coordinates, and
> all the data of the location that I want to put.
>
>
> PD: I am from Spain, and I'm so young, sorry for my bad English.
>
> --
> gnome-panel crashes when selecting location without coordinates
> https://bugs.launchpad.net/bugs/201102
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-panel - 1:2.22.1-0ubuntu1

---------------
gnome-panel (1:2.22.1-0ubuntu1) hardy; urgency=low

  * New upstream version:
    Panel
    - Convert username/login to UTF-8 in logout dialog
    - Fix applet processes not quitting when the applet is removed (lp: #195915)
    Misc
    - Remove old and useless files
    - Require gweather 2.22.1
    - Don't explicitly require libxml for the weather applet anymore
    Clock Applet
    - Fix crash when there are no locations available
    - Fix locations not appearing in the preferences dialog
    - Make find location window larger
    - Handle escape to close the dialog in the time/timezone dialogs
    - Fix various issues with adding/removing locations
    - Fix crash when PolicyKit helper can't be called (lp: #208791)
    - Fix crash when closing the calendar popup when a city is blinking
      on the map (lp: #200881, ##207954)
    - Improve the blinking on the map when clicking on various locations
    - Cleanups
    - Correctly redraw the map outline on expose events
    - Fix crash when the location doesn't have coordinates (lp: #201102)
    - Fix crash when updating locations while calendar popup is not shown
      (lp: #210470)
    - Fix initial visibility of the appointments to actually follow the
      state of the expander (lp: #206118)
    - Make sure we always use data from the right country (lp: #185190)
    - Show caldav appointments in the calendar
    - Ignore dbus errors when setting the time and there's no reply on the bus
      (lp: #207890)
    - Open evolution on the right day, in all timezones (lp: #66028)
    - Fix crash when an evolution-data-server dies (lp: #122590)
    - Correctly set time, even when DST is on (lp: #208598)
    - Handle multiple locations in the same timezone in a better way
    - Fix weather tooltip to show the real temperature and the apparent
      temperature, instead of only the apparent one (lp: #188183)
    - Do not lose the weather location information when changing the
      timezone of a location (lp: #200911)
    - Don't show weather information of the last location once it has been
      removed
    - Remove empty space on the left of the clock when there's no location
      (lp: #203691)
    - Potential fix for another crash in the calendar code
    - When adding a location, make it the current one if it makes sense
  * debian/control.in:
    - updated libgweather requirement
  * debian/patches/17_expose_wm_keybindings.patch:
    - dropped, the current version has some issues and need to be rework
      during next cycle (lp: #211112)
  * debian/patches/80_from_bugzilla_use_correct_current_timezone.patch:
    - dropped, fixed in the new version

 -- Sebastien Bacher <email address hidden> Tue, 08 Apr 2008 01:47:12 +0200

Changed in gnome-panel:
status: Fix Committed → Fix Released
Katsuro (katsuro1989) wrote :

Good morning.
I have saw more tan 30 updates this morning, and I found the update of gnome-panel. I updated it, I rebooted all the computer, and finally I began the tests.
Results:
I have my home (Reus) added. I add a new location, putting only the name and selecting a time zone. All perfect :)
But, when I add a location searching it, all crashes again :( Let me explain it detailed:
When I click to add more locations, appears a dialog (That you can write the location, put the time zone and the coordinates), I click on "Search". I search the city that I want, and when I click "OK" to add it, crashes the taskbars, the icons of my desktop, and a few seconds later appears the tasbars and the icons.

Thanks a lot to resolve the first part of this bug, now it's time to solve the second part :P

PD: Thanks Mikeisgood this have helped me ^_^

Sebastien Bacher (seb128) wrote :

the new gnome-panel didn't build yet because it's waiting on the new libgweather, how did you install this version?

Katsuro (katsuro1989) wrote :

Sebastien Bacher this version of "libgweather" is the version that comes in ubuntu 8.04 (Hardy Heron). I updated my Ubuntu 7.10 to 8.04 this Saturday to test it and find bugs.

Sebastien Bacher (seb128) wrote :

what I'm saying is that the fixed version is not available yet so how do you know that what you call the second part of the issue is not fixed in the new version?

Katsuro (katsuro1989) wrote :

pfff... I dont like that my English is very poor :( sorry.
Now I have dist-upgraded and rebooted the Ubuntu beta, and the problem is solved now, but almost all of locations have been dissapeared :S
Have a look in the attachment (a screenshot of the locations). My Ubuntu is in "Catalan" language.

Soory again for the problems that have caused my bad english :(

Sebastien Bacher (seb128) wrote :

what version of libgweather1 and gnome-panel are installed?

Katsuro (katsuro1989) wrote :

Using Synaptic:

gnome-panel: 1:2.22.0-0ubuntu3
libgweather1: is not installed. If I try to install it, it says that those packages will be removed:
-apturl
-evolution
-evolution-exchange
-evolution-plugins
-gnome-app-install
-liblpint-bonobo0
-python-launchpad-integration
-ubufox
-ubuntu-desktop

I think... that it will be a great idea to format this ubuntu and install a new one using the daily buildings... What do you think?

UKThom (ukthom) wrote :

Just updated my gnome-panel, and now it's not working/crashing every time I load up GNOME. I've managed to eek open a terminal (Alt-F2 wasn't working either), and am desperately seeking some guidance. I will try to remove and reinstall ubuntustudio-desktop and see what happens...Yikes :(

mykola.kutsyy (n-p-kutsyy) wrote :

I have last version of gnome-panel (1:2.22.1.2-0ubuntu3)

I can not add to locations anyone city of Ukraine.
Also you have to fix names of cities:
Kiev -> Kyiv
L'Viv -> L'viv

etc. You can check how to spell here http://www.ukrcensus.gov.ua/eng/regions/

Fill free to ask me about spell of Ukrainian words.

This bug has been resolved. If you are experiencing other bugs with Gnome Panel, please open a new bug. Thanks.

Changed in ubuntustudio:
status: New → Invalid

On Mon, Apr 14, 2008 at 08:25:20PM -0000, beginner wrote:
> I have last version of gnome-panel (1:2.22.1.2-0ubuntu3)

> I can not add to locations anyone city of Ukraine.
> Also you have to fix names of cities:
> Kiev -> Kyiv
> L'Viv -> L'viv

> etc. You can check how to spell here
> http://www.ukrcensus.gov.ua/eng/regions/

Kiev is a well-known city in English, and "Kiev" is the standard spelling in
English. It would be incorrect to normalize this to match Ukrainian
transliteration rules, just as it would be incorrect to label "Moscow" as
"Moskva" in the English locale.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

hackel (hackel) wrote :

I certainly disagree, politically. All the English brutalisations of names in other languages should be eliminated. But I suppose a movement like this can't be started by Ubuntu. I think we should follow Google Maps' lead. As you pan around the map of the world, the names of places appear in their native language. Certainly not a problem with Unicode...

Chris Coulson (chrisccoulson) wrote :

This isn't the place for this discussion, but the locations should be displayed in the localization defined in the current language set. So, if you have English selected, then the English localizations should be used.

Changed in gnome-panel:
status: New → Fix Released
Changed in gnome-panel:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.