Fontconfig warning: Having multiple values in <test> isn't supported and may not works as expected

Bug #1034928 reported by Steve Magoun on 2012-08-09
734
This bug affects 171 people
Affects Status Importance Assigned to Milestone
Fedora
Unknown
Unknown
culmus (Ubuntu)
Low
Benjamin Drung
Quantal
Undecided
Unassigned
fonts-arphic-ukai (Debian)
Fix Released
Unknown
fonts-arphic-ukai (Ubuntu)
Low
Unassigned
Quantal
Undecided
Unassigned
fonts-arphic-uming (Debian)
Fix Released
Unknown
fonts-arphic-uming (Ubuntu)
Undecided
RaduStoica
Quantal
Undecided
Unassigned
fonts-baekmuk (Debian)
Fix Released
Unknown
fonts-baekmuk (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned
fonts-droid (Debian)
Fix Released
Unknown
fonts-droid (Ubuntu)
Undecided
Andrew Starr-Bochicchio
Quantal
Undecided
Unassigned
fonts-nanum (Debian)
Fix Released
Unknown
fonts-nanum (Ubuntu)
Undecided
Andrew Starr-Bochicchio
Quantal
Undecided
Unassigned
fonts-nanum-coding (Ubuntu)
Undecided
Benjamin Drung
Quantal
Undecided
Unassigned
fonts-sil-andika (Debian)
Fix Released
Unknown
fonts-sil-andika (Ubuntu)
Undecided
Iain Lane
Quantal
Undecided
Unassigned
fonts-tlwg (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned
fonts-unfonts-core (Debian)
Fix Released
Unknown
fonts-unfonts-core (Ubuntu)
Undecided
Andrew Starr-Bochicchio
Quantal
Undecided
Unassigned
fonts-unfonts-extra (Debian)
Fix Released
Unknown
fonts-unfonts-extra (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned
language-selector (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned
libreoffice (Ubuntu)
Low
Unassigned
ttf-wqy-zenhei (Debian)
New
Unknown
ttf-wqy-zenhei (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

In 12.10, fontconfig prints warnings similar to the following whenever fontconfig is invoked:

Fontconfig warning: "/etc/fonts/conf.d/90-fonts-unfonts-core.conf", line 11: Having multiple values in <test> isn't supported and may not works as expected

This affects fonts from a number of packages:
fonts-arphic-ukai: /etc/fonts/conf.d/41-arphic-ukai.conf
fonts-arphic-uming: /etc/fonts/conf.d/41-arphic-uming.conf
fonts-droid: /etc/fonts/conf.d/65-droid-sans-fonts.conf
fonts-tlwg-garuda: /etc/fonts/conf.d/89-tlwg-garuda-synthetic.conf
fonts-tlwg-kinnari: /etc/fonts/conf.d/89-tlwg-kinnari-synthetic.conf
fonts-tlwg-loma: /etc/fonts/conf.d/89-tlwg-loma-synthetic.conf
fonts-tlwg-umpush: /etc/fonts/conf.d/89-tlwg-umpush-synthetic.conf
fonts-nanum: /etc/fonts/conf.d/90-fonts-nanum.conf
fonts-unfonts-core: /etc/fonts/conf.d/90-fonts-unfonts-core.conf

[Test Case]
1) Install the fonts in question
2) Open a terminal
3) Launch 'gedit' from the terminal

Expected results:
gedit launches, no fontconfig warnings in the terminal

Actual results:
gedit launches, fontconfig warnings are displayed in the terminal

[Regression Potential]
In case of a regression, the font in question can be affected.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: fonts-unfonts-core 1.0.3.is.1.0.2-080608-5ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-8.8-generic 3.5.0
Uname: Linux 3.5.0-8-generic x86_64
ApportVersion: 2.4-0ubuntu6
Architecture: amd64
Date: Thu Aug 9 10:02:59 2012
Dependencies:

InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta amd64 (20100901.1)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: fonts-unfonts-core
UpgradeStatus: Upgraded to quantal on 2012-08-07 (1 days ago)

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fonts-droid (Ubuntu):
status: New → Confirmed
Changed in fonts-nanum (Ubuntu):
status: New → Confirmed
Changed in fonts-tlwg (Ubuntu):
status: New → Confirmed
Changed in fonts-unfonts-core (Ubuntu):
status: New → Confirmed
Logan Rosen (logan) wrote :

Version 1:0.5.0-5 in Debian of fonts-tlwg claims to have fixed the fontconfig issue, so I submitted a sync request in Bug 1035704.

John Lenton (chipaca) wrote :

I just updated fonts-tlwg and now have 1:0.5.0-5 and am still getting the warnings. Notably, for fonts that are not part of fonts-tlwg:

$ gucharmap 2>&1 | cut -d\ -f3 /tmp/err | sort -u
"/etc/fonts/conf.d/41-arphic-uming.conf",
"/etc/fonts/conf.d/64-arphic-uming.conf",
"/etc/fonts/conf.d/65-droid-sans-fonts.conf",
"/etc/fonts/conf.d/90-fonts-nanum.conf",
"/etc/fonts/conf.d/90-fonts-unfonts-core.conf",

Logan Rosen (logan) wrote :

Well, that is to be expected. I should have clarified in my comment that it only fixes the fontconfig issue for the fonts-tlwg fonts.

description: updated
Changed in fonts-arphic-uming (Ubuntu):
status: New → Confirmed
Logan Rosen (logan) wrote :

John, I updated the description with the fonts-arphic-uming package, as you seem to be getting an error with it. Just to clarify, is it the "Having multiple values in <test> isn't supported and may not works as expected" that you're receiving for the first two fonts in your comment?

crf (chrisfahlman) wrote :

Fix the grammar mistake in the warning message too, please.

Logan Rosen (logan) wrote :

I have created Bug 1037509 for the grammar mistake and forwarded it upstream.

Fumihito YOSHIDA (hito) wrote :

Conclusion from Fedora bug, Akira TAGOH said(https://bugzilla.redhat.com/show_bug.cgi?id=837520#c0):

> Still no changes in the behavior in the latest version of fontconfig,
> but it now warns when <test> contains multiple values or <alias> contains
> multiple <family>s. this is because the behavior isn't intuitive and
> doesn't work as expected necessarily. So you better consider to fix it
> to make clearer what you want to do with it.
>
> For solution, if you are expecting OR operator with that rule, add more
> <match>s or <alias>es. if you are expecting AND operator with that rule,
> just add more <test>s in that <match>.

Fumihito YOSHIDA (hito) wrote :

I found this bug affects language-selector::{ja-jp,zh-tw}.

Fontconfig warning: "/etc/fonts/conf.d/69-language-selector-ja-jp.conf", line 126: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/69-language-selector-zh-tw.conf", line 70: Having multiple values in <test> isn't supported and may not works as expected

Dimitri John Ledkov (xnox) wrote :

So should we be fixing each individual font? How is the current syntax treated as "OR" or "AND"? And which one to pick for each font?

Changed in fonts-tlwg (Ubuntu):
status: Confirmed → Fix Released
Fumihito YOSHIDA (hito) wrote :

> So should we be fixing each individual font?

IMHO, our options are:

  a) fix each indicidual fonts.
  b) remove fontconfigs alert code by ubuntu patch, and write off this behavior.

In ways of "geeky" thinking, b) is reasonable... Because these "warned" conditional configs are defunct at all. These like cecum.

dino99 (9d9) wrote :

on Ubuntu, i does not get these fonts errors since i've renamed both: .fonts.conf file & fontconfig folder
(fontconfig 2.10.1)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in language-selector (Ubuntu):
status: New → Confirmed
diaber (program) wrote :

I have the same bug, occurs during system startup, the computer waits with the black screen showing the same errors:

Fontconfig warning: "/ etc/fonts/conf.d/65-andika.conf", line 16: Having multiple values ​​in <test> is not supported and may not works as expected
Fontconfig warning: "/ etc/fonts/conf.d/65-andika.conf", line 35: Having multiple <Family> in <alias> is not supported and may not works as expected
Fontconfig warning: "/ etc/fonts/conf.d/65-droid-sans-fonts.conf", line 103: Having multiple values ​​in <test> is not supported and may not works as expected
Fontconfig warning: "/ etc/fonts/conf.d/65-droid-sans-fonts.conf", line 138: Having multiple values ​​in <test> is not supported and may not works as expected
Fontconfig warning: "/ etc/fonts/conf.d/90-fonts-nanum.conf", line 9: Having multiple values ​​in <test> is not supported and may not works as expected
Fontconfig warning: "/ etc/fonts/conf.d/90-fonts-nanum.conf", line 22: Having multiple <Family> in <alias> is not supported and may not works as expected
Fontconfig warning: "/ etc/fonts/conf.d/90-fonts-nanum.conf", line 26: Having multiple <Family> in <alias> is not supported and may not works as expected
Fontconfig warning: "/ etc/fonts/conf.d/90-fonts-nanum.conf", line 31: Having multiple values ​​in <test> is not supported and may not works as expected
Fontconfig warning: "/ etc/fonts/conf.d/90-fonts-nanum.conf", line 40: Having multiple values ​​in <test> is not supported and may not works as expected
Fontconfig warning: "/ etc/fonts/conf.d/90-fonts-unfonts-core.conf", line 11: Having multiple values ​​in <test> is not supported and may not works as expected

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fonts-sil-andika (Ubuntu):
status: New → Confirmed
Fumihito YOSHIDA (hito) wrote :

I updated 69-language-selector-{ja-jp,zw-th}.conf files, that based language-selector 0.86.

Dear @japaneseteam and @ubuntu-tw members, could you test these files in your environments?
http://bazaar.launchpad.net/~hito/+junk/language-selector/revision/222

Johan (oortjies) wrote :

I am very new at this bug reporting story, so please bear with me.
It affects my software center itself, starting it with terminal, I get same report:- Fontconfig warning: "/etc/fonts/conf.d/65-andika.conf", line 16: Having multiple values in <test> isn't supported and may not works as expected plus more warnings.

gedit produce same output.
~$ gedit
Fontconfig warning: "/etc/fonts/conf.d/65-andika.conf", line 16: Having multiple values in <test> isn't supported and may not works as expected + more warnings.

I presume that it is the same bug that is causing my problems. If further detail is required to possibly assist to nail this one, please ask and I will oblige.

System:-
Release 12.10 (quantal) 64-bit
Kernel Linux 3.5.0-10-lowlatency
GNOME 3.5.5
AMD Athlon(tm) X4 620 Processor × 4

Sebastien Bacher (seb128) wrote :

corresponding upstream bug:

"just for references:

For the AND operator:

<match>
  <test name="object".../test>
  <test name="object".../test>
  <edit.../edit>
</match>

For the OR operator:
<match>
  <test name="object".../test>
  <edit.../edit>
</match>
<match>
  <test name="object".../test>
  <edit.../edit>
</match>

the above should works."

opensshd (opensshd) wrote :

======================
libparted : 2.3
======================
Fontconfig warning: "/etc/fonts/conf.d/65-droid-sans-fonts.conf", line 103: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/65-droid-sans-fonts.conf", line 138: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/69-language-selector-ja-jp.conf", line 141: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/69-language-selector-zh-tw.conf", line 79: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/90-fonts-nanum.conf", line 9: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/90-fonts-nanum.conf", line 22: Having multiple <family> in <alias> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/90-fonts-nanum.conf", line 22: Having multiple <family> in <alias> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/90-fonts-nanum.conf", line 22: Having multiple <family> in <alias> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/90-fonts-nanum.conf", line 26: Having multiple <family> in <alias> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/90-fonts-nanum.conf", line 31: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/90-fonts-nanum.conf", line 40: Having multiple values in <test> isn't supported and may not works as expected

Changed in fonts-droid (Ubuntu):
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
status: Confirmed → In Progress
Changed in fonts-nanum (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
Changed in fonts-droid (Debian):
status: Unknown → New
Changed in fonts-unfonts-core (Ubuntu):
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
status: Confirmed → In Progress
Changed in fonts-unfonts-core (Debian):
status: Unknown → New
Iain Lane (laney) wrote :

Uploaded language-selector to the queue. Thanks hito!

Changed in language-selector (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.87

---------------
language-selector (0.87) quantal; urgency=low

  * Fix bad testing sections. LP: #1034928
    - fontconfig/69-language-selector-ja-jp.conf: Separate matching
      patterns for non-bitmap/non-hinting sections. And remove legacy
      font lists.
    - fontconfig/69-language-selector-zh-tw.conf: Separate matching
      patterns at "Bind AR PL UMing with DejaVu Serif" section.
 -- Fumihito YOSHIDA <email address hidden> Wed, 22 Aug 2012 11:35:26 +0900

Changed in language-selector (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fonts-unfonts-core - 1.0.3.is.1.0.2-080608-5ubuntu2

---------------
fonts-unfonts-core (1.0.3.is.1.0.2-080608-5ubuntu2) quantal; urgency=low

  * debian/90-fonts-unfonts-core.conf: (LP: #1034928)
   - Update so that there are not multiple values within
     test tags as Fontconfig warns that this is not supported.
 -- Andrew Starr-Bochicchio <email address hidden> Tue, 04 Sep 2012 16:18:03 -0400

Changed in fonts-unfonts-core (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fonts-nanum - 3.020-1ubuntu1

---------------
fonts-nanum (3.020-1ubuntu1) quantal; urgency=low

  * debian/90-fonts-nanum{-extra}.conf: (LP: #1034928)
   - Update so that there are not multiple values within
     test tags as Fontconfig warns that this is not supported.
  * Add Pre-Depends: dpkg (>= 1.15.6~) for xz compression.
 -- Andrew Starr-Bochicchio <email address hidden> Tue, 04 Sep 2012 15:00:01 -0400

Changed in fonts-nanum (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fonts-droid - 20111207+git-1ubuntu1

---------------
fonts-droid (20111207+git-1ubuntu1) quantal; urgency=low

  * debian/local/65-droid-sans-fonts.conf: (LP: #1034928)
   - Update so that there are not multiple values within
     test tags as Fontconfig warns that this is not supported.
 -- Andrew Starr-Bochicchio <email address hidden> Tue, 04 Sep 2012 13:53:12 -0400

Changed in fonts-droid (Ubuntu):
status: In Progress → Fix Released
Changed in fonts-nanum (Debian):
status: Unknown → New
RaduStoica (radumstoica) on 2012-09-08
Changed in fonts-arphic-uming (Ubuntu):
assignee: nobody → RaduStoica (radumstoica)
status: Confirmed → Fix Released
Logan Rosen (logan) wrote :

RaduStoica, please don't mark the bug task as Fix Released if you have only created the merge request, and it hasn't been merged yet; I'll set it to In Progress.

Logan Rosen (logan) wrote :

Hmm, won't let me do that. Can you please change it to In Progress for fonts-arphic-uming? Thanks!

Changed in fonts-arphic-uming (Ubuntu):
status: Fix Released → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fonts-arphic-uming - 0.2.20080216.2-4ubuntu1

---------------
fonts-arphic-uming (0.2.20080216.2-4ubuntu1) quantal; urgency=low

  * Add single_alias_test_tags.patch: Avoid multiple values in an alias and
    test tags, as they are not supported by current fontconfig. (LP: #1034928)
 -- Radu Stoica <email address hidden> Mon, 10 Sep 2012 11:49:15 +0200

Changed in fonts-arphic-uming (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fonts-unfonts-extra - 1.0.3.is.1.0.2-080608-4ubuntu2

---------------
fonts-unfonts-extra (1.0.3.is.1.0.2-080608-4ubuntu2) quantal; urgency=low

  * Update fontconfig file to not contain multiple matches in a <test> block
    when we mean 'or'. (LP: #1034928)
 -- Iain Lane <email address hidden> Mon, 10 Sep 2012 12:07:13 +0100

Changed in fonts-unfonts-extra (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fonts-baekmuk - 2.2-7ubuntu2

---------------
fonts-baekmuk (2.2-7ubuntu2) quantal; urgency=low

  * Revert previous change now that we have a new enough dpkg in Quantal
  * Fix incorrect syntax for disjunction in fontconfig .conf file (LP:
    #1034928)
 -- Iain Lane <email address hidden> Mon, 10 Sep 2012 12:43:01 +0100

Changed in fonts-baekmuk (Ubuntu):
status: New → Fix Released
Changed in fonts-arphic-uming (Debian):
status: Unknown → Fix Committed
Iain Lane (laney) on 2012-09-10
Changed in fonts-sil-andika (Ubuntu):
assignee: nobody → Iain Lane (laney)
Iain Lane (laney) wrote :

I uploaded with the wrong bug ref in -andika; closing manually

Steve Magoun (smagoun) wrote :

A similar error also affects libreoffice. Launch libreoffice from a command line:

steve@steve-laptop:~$ libreoffice
Fontconfig warning: "/usr/lib/libreoffice/share/fonts/truetype/fc_local.conf", line 13: Having multiple <family> in <alias> isn't supported and may not works as expected

Iain Lane (laney) on 2012-09-10
Changed in fonts-sil-andika (Ubuntu):
status: Confirmed → Fix Released
Changed in fonts-droid (Debian):
status: New → Fix Committed
Changed in fonts-sil-andika (Debian):
status: Unknown → New
Changed in ttf-wqy-zenhei (Debian):
status: Unknown → New
Changed in fonts-baekmuk (Debian):
status: Unknown → New
Changed in fonts-unfonts-extra (Debian):
status: Unknown → New
Johan (oortjies) wrote :

I am having same problems with Libre Office, there could be more involved but part definitively same bug.
Here is my report when loaded with terminal.

~$ libreoffice
Fontconfig warning: "/usr/lib/libreoffice/share/fonts/truetype/fc_local.conf", line 13: Having multiple <family> in <alias> isn't supported and may not works as expected
p11-kit: duplicate configured module: gnome-keyring.module: /usr/lib/x86_64-linux-gnu/pkcs11/gnome-keyring-pkcs11.so
WARNING: gnome-keyring:: couldn't connect to: /home/johan/.cache/keyring-N7Zzor/pkcs11: No such file or directory
The andika warning is solved on my machine after update. I get a clean bill of health when starting "gedit" with terminal. thank you guys for your dedication.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ttf-wqy-zenhei (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ttf-wqy-zenhei - 0.9.45-4ubuntu1

---------------
ttf-wqy-zenhei (0.9.45-4ubuntu1) quantal; urgency=low

  * Update 25-wqy-zenhei.conf for correct 'or' syntax. (LP: #1034928)
 -- Iain Lane <email address hidden> Tue, 11 Sep 2012 13:38:30 +0100

Changed in ttf-wqy-zenhei (Ubuntu):
status: Confirmed → Fix Released
Changed in fonts-sil-andika (Debian):
status: New → Fix Committed
funicorn (funicorn) wrote :

still no. language-selector 0.87

$~leafpad

Fontconfig warning: "/etc/fonts/conf.d/41-arphic-ukai.conf", line 16: Having multiple <family> in <alias> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/41-arphic-ukai.conf", line 16: Having multiple <family> in <alias> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/41-arphic-ukai.conf", line 16: Having multiple <family> in <alias> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/41-arphic-ukai.conf", line 16: Having multiple <family> in <alias> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/41-arphic-ukai.conf", line 16: Having multiple <family> in <alias> isn't supported and may not works as expected

$~ cat /etc/fonts/conf.d/41-arphic-ukai.conf

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>

<!--
  Sans-serif faces
 -->
 <alias>
  <family>AR PL ZenKai Uni</family>
  <family>AR PL ZenKai Uni MBE</family>
  <family>AR PL UKai CN</family>
  <family>AR PL UKai HK</family>
  <family>AR PL UKai TW</family>
  <family>AR PL UKai TW MBE</family>
  <default><family>sans-serif</family></default>
 </alias>
</fontconfig>

so?

funicorn (funicorn) wrote :

I know what's going on here. It seems fontconfig requires now one rule applies to one pattern.

I rewritten the above codes in a 'separted' form, one pattern per font, everything goes fine.

Yeah, users should be OK with this, except that it makes linux people more and more stupid.

 <alias>
  <family>AR PL ZenKai Uni</family>
  <default><family>sans-serif</family></default>
 </alias>
 <alias>
  <family>AR PL ZenKai Uni MBE</family>
  <default><family>sans-serif</family></default>
 </alias>
 <alias>
  <family>AR PL UKai CN</family>
  <default><family>sans-serif</family></default>
 </alias>
 <alias>
  <family>AR PL UKai HK</family>
  <default><family>sans-serif</family></default>
 </alias>
 <alias>
  <family>AR PL UKai TW</family>
  <default><family>sans-serif</family></default>
 </alias>
 <alias>
  <family>AR PL UKai TW MBE</family>
  <default><family>sans-serif</family></default>
 </alias>

Hi,

On Mon, Sep 17, 2012 at 03:01:33PM -0000, funicorn wrote:
> still no. language-selector 0.87
>
> $~leafpad
>
> Fontconfig warning: "/etc/fonts/conf.d/41-arphic-ukai.conf", line 16: Having multiple <family> in <alias> isn't supported and may not works as expected
> […]

That's not language-selector. It's fonts-arphic-ukai.

 affects ubuntu/fonts-arphic-ukai
 status triaged
 severity low

Cheers,

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

Changed in fonts-arphic-ukai (Ubuntu):
importance: Undecided → Low
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fonts-arphic-ukai - 0.2.20080216.2-3ubuntu1

---------------
fonts-arphic-ukai (0.2.20080216.2-3ubuntu1) quantal; urgency=low

  * Fix <alias> syntax. fontconfig only allows one family to be aliased at a
    time, so duplicate the block for each family to be aliased. (LP: #1034928)
 -- Iain Lane <email address hidden> Tue, 18 Sep 2012 10:17:37 +0100

Changed in fonts-arphic-ukai (Ubuntu):
status: Triaged → Fix Released
Changed in fonts-arphic-ukai (Debian):
status: Unknown → New
Jack Leigh (leighman) wrote :

Still getting this with sil-andika even though it says fix released.

Iain Lane (laney) wrote :

On Fri, Sep 21, 2012 at 04:46:17PM -0000, Jack Leigh wrote:
> Still getting this with sil-andika even though it says fix released.

I'm not. Can you please paste the messages you see? What version of
fonts-sil-andika do you have? (paste the output of `apt-cache policy
fonts-sil-andika')

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

Jack Leigh (leighman) wrote :

fonts-sil-andika:
  Installed: 1.002-2ubuntu1
  Candidate: 1.002-2ubuntu1
  Version table:
 *** 1.002-2ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ quantal/universe i386 Packages
        100 /var/lib/dpkg/status

Opening evince:
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
Fontconfig warning: "/etc/fonts/conf.d/65-ttf-sil-andika.conf", line 14: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/65-ttf-sil-andika.conf", line 32: Having multiple <family> in <alias> isn't supported and may not works as expected

Iain Lane (laney) wrote :

On Fri, Sep 21, 2012 at 09:20:35PM -0000, Jack Leigh wrote:
> […]
> Fontconfig warning: "/etc/fonts/conf.d/65-ttf-sil-andika.conf", line 14: Having multiple values in <test> isn't supported and may not works as expected
> Fontconfig warning: "/etc/fonts/conf.d/65-ttf-sil-andika.conf", line 32: Having multiple <family> in <alias> isn't supported and may not works as expected

That file doesn't exist in the current package. It's probably cruft left
over on your system. You can probably just get rid of it, unless you
want to keep the customisations in which case you can fix it as we've
been fixing the others for this bug.

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

Jack Leigh (leighman) wrote :

Should it not have been deleted by the update then? I've never edited it.

Johan (oortjies) wrote :

All my other font warnings something of the past, only have the following one still appearing,

~$ libreoffice
Fontconfig warning: "/usr/lib/libreoffice/share/fonts/truetype/fc_local.conf", line 13: Having multiple <family> in <alias> isn't supported and may not works as expected
WARNING: gnome-keyring:: couldn't connect to: /home/johan/.cache/keyring-FRzd97/pkcs11: No such file or directory

All the latest updates installed.

Iain Lane (laney) wrote :

Here's the diff for that file in LO: http://paste.debian.net/193128/

I pinged the maintainer on IRC and asked if he could apply it.

Johan (oortjies) wrote :

Ok I applied diff... "http://paste.debian.net/193128/" ...this is what I get now:-

~$ libreoffice
Fontconfig error: "/usr/lib/libreoffice/share/fonts/truetype/fc_local.conf", line 1: syntax error
Fontconfig error: Cannot load config file "/usr/lib/libreoffice/share/fonts/truetype/fc_local.conf"
FcConfigParseAndLoad( "/usr/lib/libreoffice/share/fonts/truetype/fc_local.conf") => 0
WARNING: gnome-keyring:: couldn't connect to: /home/johan/.cache/keyring-FRzd97/pkcs11: No such file or directory

instead of this:- (after changing conf. file to above mentioned)
~$ libreoffice
Fontconfig warning: "/usr/lib/libreoffice/share/fonts/truetype/fc_local.conf", line 13: Having multiple <family> in <alias> isn't supported and may not works as expected
WARNING: gnome-keyring:: couldn't connect to: /home/johan/.cache/keyring-FRzd97/pkcs11: No such file or directory

I am truly new at this, so please bear with me if I have done something stupid.

@Johan: how exactly have you applied the patch?

Johan (oortjies) wrote :

On 09/26/2012 05:40 PM, Andrea Corbellini wrote:
> @Johan: how exactly have you applied the patch?
>
I replaced the config. file by the Diff file, Was that stupid of me or
am I on the right track?

mlentink (martin-athenenoctua) wrote :

Libreoffice just dies on me right after this message is displayed, can't use it, Have te use my 12.04 laptop for any work with lo

Fontconfig warning: "/usr/lib/libreoffice/share/fonts/truetype/fc_local.conf", line 13: Having multiple <family> in <alias> isn't supported and may not works as expected

@mlentink: the messages from fontconfig are just warnings, not errors. If Libreoffice fails to start, then you are experiencing a different issue. Please, file a bug about that using "ubuntu-bug libreoffice". For more information, see https://help.ubuntu.com/community/ReportingBugs

Changed in fonts-unfonts-core (Debian):
status: New → Fix Released
Changed in fonts-nanum (Debian):
status: New → Fix Released
Changed in fonts-unfonts-extra (Debian):
status: New → Fix Released
Changed in fonts-baekmuk (Debian):
status: New → Fix Released
Gunnar Hjalmarsson (gunnarhj) wrote :

Yet another package added: culmus

Changed in culmus (Ubuntu):
status: New → Confirmed

@Johan (sorry, I forgot to reply): unfortunately, that's not the right way to apply a patch. A patch contains just the differences between the old version of a file and the new version. To get the new version of the file, you need to "combine" the old version with the diff. Generally, to apply a patch you should use the following commands:

  cd /path/to/the/file
  patch -p0 < /path/to/the/patch

Though, this might not work in every case (see "man patch" for more information).

Changed in culmus (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
no longer affects: libreoffice (Ubuntu)
Changed in libreoffice (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Bzzz (da-bzzz) wrote :

Has appeared yesterday on my 12.04 system, after I did a lot of updates with tlmgr, the update tool of TeX Live. I have a separate installation of TeX, not that from the Ubuntu repositories.

James Maddison (jamesmadd) wrote :

Also affects the fonts-nanum-coding package

@James: Looking at 90-fonts-nanum-coding.conf 2.0-4 (from Quantal) I cannot see any problem with <test>. Please, could you paste the warning you get and also tell the version you are using?

Changed in fonts-nanum-coding (Ubuntu):
status: New → Incomplete
RaduStoica (radumstoica) on 2012-10-21
no longer affects: culmus
emptythevoid (emptythevoid) wrote :

I can confirm the fonts-nanum. Just did an upgrade to 12.10 from a 12.04 64-bit desktop system that was fully updated and throughout the update, the terminal window spit countless "Having multiple values in <test> isn't supported and may not works as expected" against fonts-nanum. but that was the *only* font I saw errors with.

Good news is I can run gedit from Terminal on this machine I get no font errors.

However my 32-bit netbook (referenced in my earlier post) is still spitting up errors for andika,conf

My 64-bit laptop that has a clean install of 12.10 is getting no font errors at all.

James Maddison (jamesmadd) wrote :

For example:

$ kate
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
Fontconfig warning: "/etc/fonts/conf.d/90-fonts-nanum-coding.conf", line 10: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/90-fonts-nanum-coding.conf", line 22: Having multiple values in <test> isn't supported and may not works as expected

James Maddison (jamesmadd) wrote :

This is an upgraded Kubuntu 12.10 64-bit with fonts-nanum-coding 2.0-4.

Benjamin Drung (bdrung) wrote :

Here's the uploaded fix for the culmus font package.

Benjamin Drung (bdrung) wrote :

Here's the uploaded fix for the fonts-nanum-coding font package.

Benjamin Drung (bdrung) wrote :

The fix for culmus is forwarded to the upstream author via mail. Debian fixed fonts-nanum-coding in version 2.0-5 in a different way.

Changed in fonts-nanum-coding (Ubuntu):
assignee: nobody → Benjamin Drung (bdrung)
status: Incomplete → In Progress
Changed in culmus (Ubuntu):
assignee: nobody → Benjamin Drung (bdrung)
status: Triaged → In Progress
Benjamin Drung (bdrung) on 2012-10-26
description: updated

Hello Steve, or anyone else affected,

Accepted culmus into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/culmus/0.121-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in culmus (Ubuntu Quantal):
status: New → Fix Committed
tags: added: verification-needed
Changed in fonts-nanum-coding (Ubuntu Quantal):
status: New → Fix Committed
Steve Langasek (vorlon) wrote :

Hello Steve, or anyone else affected,

Accepted fonts-nanum-coding into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/fonts-nanum-coding/2.0-4ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Steve Langasek (vorlon) wrote :

fixed for raring in fonts-nanum-coding 2.0-5.

Changed in fonts-nanum-coding (Ubuntu):
status: In Progress → Fix Released
Changed in fonts-arphic-ukai (Ubuntu Quantal):
status: New → Fix Released
Changed in fonts-arphic-uming (Ubuntu Quantal):
status: New → Fix Released
Steve Langasek (vorlon) on 2012-11-04
Changed in fonts-baekmuk (Ubuntu Quantal):
status: New → Fix Released
Steve Langasek (vorlon) on 2012-11-04
Changed in fonts-droid (Ubuntu Quantal):
status: New → Fix Released
Changed in fonts-nanum (Ubuntu Quantal):
status: New → Fix Released
Steve Langasek (vorlon) on 2012-11-04
Changed in fonts-sil-andika (Ubuntu Quantal):
status: New → Fix Released
Changed in fonts-tlwg (Ubuntu Quantal):
status: New → Fix Released
Changed in fonts-unfonts-core (Ubuntu Quantal):
status: New → Fix Released
Steve Langasek (vorlon) on 2012-11-04
Changed in fonts-unfonts-extra (Ubuntu Quantal):
status: New → Fix Released
Steve Langasek (vorlon) wrote :

confirmed this fix for both the culmus and the fonts-nanum-coding packages.

Changed in language-selector (Ubuntu Quantal):
status: New → Fix Released
Changed in ttf-wqy-zenhei (Ubuntu Quantal):
status: New → Fix Released
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu Quantal):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package culmus - 0.121-2

---------------
culmus (0.121-2) unstable; urgency=low

  * Split multiple test field values in culmus.conf (LP: #1034928)
    - Relevant for fontconfig >= 2.9.91 (see fdo#33644)

 -- Lior Kaplan <email address hidden> Sun, 04 Nov 2012 23:33:21 +0200

Changed in culmus (Ubuntu):
status: In Progress → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package culmus - 0.121-1ubuntu1

---------------
culmus (0.121-1ubuntu1) quantal-proposed; urgency=low

  * Fix incorrect syntax for disjunction in fontconfig .conf file (LP: #1034928)
 -- Benjamin Drung <email address hidden> Wed, 24 Oct 2012 15:20:46 +0200

Changed in culmus (Ubuntu Quantal):
status: Fix Committed → Fix Released
tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fonts-nanum-coding - 2.0-4ubuntu1

---------------
fonts-nanum-coding (2.0-4ubuntu1) quantal-proposed; urgency=low

  * Fix incorrect syntax for disjunction in fontconfig .conf file (LP: #1034928)
 -- Benjamin Drung <email address hidden> Wed, 24 Oct 2012 15:37:27 +0200

Changed in fonts-nanum-coding (Ubuntu Quantal):
status: Fix Committed → Fix Released
Hassan El Jacifi (waver) wrote :

This bug is still present if you run libroffice

Fontconfig warning: "/usr/lib/libreoffice/share/fonts/truetype/fc_local.conf", line 13: Having multiple <family> in <alias> isn't supported and may not works as expected

Changed in fonts-droid (Debian):
status: Fix Committed → Fix Released
Susan Cragin (susancragin) wrote :

This problem affects me only when I try to run a beta of libreoffice located at:

/opt/lodev4.1/programs/soffice (or swriter or scalc)

$ cd /opt/lodev4.1/program
$ ./scalc
Fontconfig error: Cannot load default config file
Fontconfig warning: "/opt/lodev4.1/share/fonts/truetype/fc_local.conf", line 13: Having multiple <family> in <alias> isn't supported and may not work as expected

@Susan Cragin: I'm sorry for your problem. Unfortunately, it can't be fixed in Ubuntu because, as you said, you are using the beta version of LibreOffice, which is not shipped by Ubuntu. There's nothing we can do about it. You should create an issue in the LibreOffice bug tracker.

Steve Magoun (smagoun) wrote :

@Andrea: The libreoffice bug is reproducible in 12.10 (LibreOffice version 1:3.6.2~rc2-0ubuntu4)

steve@steve-laptop:~$ libreoffice
Fontconfig warning: "/usr/lib/libreoffice/share/fonts/truetype/fc_local.conf", line 13: Having multiple <family> in <alias> isn't supported and may not works as expected

/usr/lib/libreoffice/share/fonts/truetype/fc_local.conf pretty clearly has multiple <family> elements nested inside <alias> elements:
        <alias binding="same">
          <family>Liberation Sans Narrow</family>
          <family>Arial Narrow</family>
          <default>
          <family>Arial Narrow</family>
          </default>
        </alias>

I can't load the patch from paste.debian.net from above, but this should be pretty straightforward to correct.

@Steve, Susan: I was sure that the libreoffice task was already fixed. My bad, sorry!

sabine (a4a43959) wrote :

Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
Fontconfig warning: "/usr/lib/libreoffice/share/fonts/truetype/fc_local.conf", line 13: Having multiple <family> in <alias> isn't supported and may not works as expected

This is all i could find in my logs to explain the desktop crashes caused by libreoffice (only libreoffice). I am not an expert, and I do not understand any of this, but need my computer to work.

Sworddragon (sworddragon) wrote :

Normally this problem should not cause your desktop to crash. But I have found an upstream report and attached a patch on it: https://bugs.freedesktop.org/show_bug.cgi?id=58164

Adolfo Jayme (fitojb) wrote :

A fontconfig warning is exactly that—a warning, not a crasher. By the way, a fix has been committed to libreoffice master http://cgit.freedesktop.org/libreoffice/core/commit/?id=c28c3c55c4bf672aa9f8028deb9891ae49b625e1

Changed in libreoffice (Ubuntu):
status: Triaged → Fix Committed
tags: added: target-4.0.1
Launchpad Janitor (janitor) wrote :
Download full text (5.8 KiB)

This bug was fixed in the package libreoffice - 1:4.0.1-0ubuntu1

---------------
libreoffice (1:4.0.1-0ubuntu1) raring; urgency=low

  [ Bjoern Michaelsen ]
  * new upstream release
    - fixes CRASH in action after Undo (LP: #785518)
    - fixes fontconfig warning (LP: #1034928)
    - fixes desktop file translations (LP: #1131470)
  * add transitionals for -presenter-console and -binfilter
  * add sessioninstaller for remaining wizards (LP: #780399)
  * merge from debian at 1:4.0.1~rc1-2
  * remaining delta on debian/control:
    - drop ${java-common-depends} from Recommends to Suggests on
      libreoffice-help-*
    - add libreoffice-gnome | libreoffice-kde Recommends on libreoffice
    - add libreoffice-style-human Suggests to libreoffice-common
    - add libreoffice-common self Conflicts with << 3.5.0
    - drop java-common-depends and java-runtime-depends from Recommends to
      Suggests on libreoffice-writer
    - add libreoffice-pdfimport Recommends on libreoffice-draw
    - drop libreoffice-core from Depends to Recommends on libreoffice-style-*
    - add libreoffice-style-human
    - add C/P/R against lo-menubar from libreoffice-gtk
    - alternatively Recommends libreoffice-style-human from libreoffice-gtk3
    - add C/R against libreoffice-core (<< 1:3.9999) from libreoffice-gnome
    - add Conflicts against libreoffice-common (<< 1:3.5.0) from python3-uno
    - add libreoffice-subsequentcheckbase
    - add libreoffice-presenter-console transitional
  * remaining delta on debian/patches:
    - add Ubuntu brand palette
    - add session-installer for Java Wizards
  * remaining delta on rules:
    - fix configure switch for human theme
    - use internal jfreereport because of huge component mismatch otherwise
    - white progressbar instead of Debian Purple (or Ubuntu orange)
    - adjust bug reporting destination for ppa builds
    - disable tests on armel, armhf, powerpc
    - enable parallel build and mergelibs
    - disable evolution
    - use internal liblangtag for now
    - disable help building on armel/armhf
    - Ubuntu backport fixes
    - reduced l10n for ppa builds
    - alternatively allow firefox-dev to xulrunner-dev as build-dep
    - warn early on GVFS and GIO in same build
    - generate transitionals
    - generate subsequentcheckbase
    - fix missing closing para wrt slide remote
    - move sessioninstaller from -gtk to -gnome for gio deps
    - move subsequentcheckbase jars to package
    - use --with-all-tarballs in addition to our flags for getting the source
      - this is so that ./configure doesnt stumble over other checks
        (e.g. still needing gnomevfs)
  * removed delta:
    - drop libreoffice-filter-mobiledev and ttf-sil-gentium-basic from Depends
      to Suggests on libreoffice
    - remove libreoffice-core postinst
    - fixed gnu make version
    - remove hotfixes get-orig-sources hack
    - some whitespace
  * silent some lintian noise for unversioned breaks:
    - promote Breaks to Conflicts against -binfilter as it will never return
    - promote Breaks to Conflicts from langpacks against en-US
    - remove Breaks against -style-industrial which is long gone
  * libreoffice-core already ...

Read more...

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
Adolfo Jayme (fitojb) on 2013-03-11
tags: added: metabug
HeinzBoettjer (heinz-boettjer) wrote :
Download full text (12.7 KiB)

I hope this is the right way to report, if not sorry.

$ uname -a
Linux LinuxMint14Desktop 3.5.0-27-generic #46-Ubuntu SMP Mon Mar 25 20:00:05 UTC 2013 i686 i686 i686 GNU/Linux

$ libreoffice --version
LibreOffice 3.6

Program: libroffice
Fontconfig warning: "/usr/lib/libreoffice/share/fonts/truetype/fc_local.conf", line 13: Having multiple <family> in <alias> isn't supported and may not works as expected

a new spreadsheet works
an old spreadshet effects a lot of message and no load possible:
administrator@LinuxMint14Desktop ~ $ libreoffice /media/Dropbox/Dropbox/Photos/LibreOffice/Tabellen/F_G/Fussball.ods
Fontconfig warning: "/usr/lib/libreoffice/share/fonts/truetype/fc_local.conf", line 13: Having multiple <family> in <alias> isn't supported and may not works as expected
*** glibc detected *** /usr/lib/libreoffice/program/soffice.bin: invalid fastbin entry (free): 0x095b0a30 ***
======= Backtrace: =========
/lib/i386-linux-gnu/libc.so.6(+0x75ee2)[0xb742eee2]
/usr/lib/i386-linux-gnu/libstdc++.so.6(_ZdlPv+0x1f)[0xb75f5adf]
/usr/lib/libreoffice/program/../program/libsclo.so(+0x2a8c40)[0xae261c40]
/usr/lib/libreoffice/program/../program/libsclo.so(+0x2aaa6a)[0xae263a6a]
/usr/lib/libreoffice/program/../program/libsclo.so(_ZN11ScRangeList6AppendERK7ScRange+0x3c)[0xae262ea2]
/usr/lib/libreoffice/program/../program/libsclo.so(_ZN11ScRangeList4JoinERK7ScRangeb+0x38)[0xae262ee4]
/usr/lib/libreoffice/program/../program/libsclo.so(+0x32b127)[0xae2e4127]
/usr/lib/libreoffice/program/../program/libsclo.so(+0x31e21b)[0xae2d721b]
/usr/lib/libreoffice/program/../program/libsclo.so(+0x31e6a2)[0xae2d76a2]
/usr/lib/libreoffice/program/../program/libsclo.so(+0x2e04dd)[0xae2994dd]
/usr/lib/libreoffice/program/../program/libsclo.so(+0x2e0a59)[0xae299a59]
/usr/lib/libreoffice/program/../program/libsclo.so(+0x2e0bb0)[0xae299bb0]
/usr/lib/libreoffice/program/../program/libsclo.so(+0x32d23b)[0xae2e623b]
/usr/lib/libreoffice/program/../program/libsclo.so(+0x32f29d)[0xae2e829d]
/usr/lib/libreoffice/program/../program/libxolo.so(_ZN11SvXMLImport10endElementERKN3rtl8OUStringE+0x41)[0xaf06ef13]
/usr/lib/libreoffice/program/../program/expwrap.uno.so(+0x5f41)[0xafe2cf41]
/lib/i386-linux-gnu/libexpat.so.1(+0x6806)[0xb4177806]
/lib/i386-linux-gnu/libexpat.so.1(+0x7632)[0xb4178632]
/lib/i386-linux-gnu/libexpat.so.1(XML_ParseBuffer+0x7e)[0xb417c96e]
/lib/i386-linux-gnu/libexpat.so.1(XML_Parse+0x106)[0xb417cd66]
/usr/lib/libreoffice/program/../program/expwrap.uno.so(+0x6880)[0xafe2d880]
/usr/lib/libreoffice/program/../program/expwrap.uno.so(+0x74c6)[0xafe2e4c6]
/usr/lib/libreoffice/program/../program/libsclo.so(+0x330364)[0xae2e9364]
/usr/lib/libreoffice/program/../program/libsclo.so(+0x3316c9)[0xae2ea6c9]
/usr/lib/libreoffice/program/../program/libsclo.so(+0x3caee0)[0xae383ee0]
/usr/lib/libreoffice/program/../program/libsclo.so(_ZN10ScDocShell4LoadER9SfxMedium+0xef)[0xae3841ab]
/usr/lib/libreoffice/program/libsfxlo.so(_ZN14SfxObjectShell13LoadOwnFormatER9SfxMedium+0x133)[0xb707e1c3]
/usr/lib/libreoffice/program/libsfxlo.so(_ZN14SfxObjectShell6DoLoadEP9SfxMedium+0x551)[0xb70880f9]
/usr/lib/libreoffice/program/libsfxlo.so(_ZN12SfxBaseModel4loadERKN3com3sun4star3uno8SequenceIN...

Sworddragon (sworddragon) wrote :

The crash has nothing to do with this ticket. You should maybe create a new one.

Dear Heinz Boettjer,

Please refer to https://help.ubuntu.com/community/ReportingBugs for instructions on how to open a new bug report.

Nick Payne (nick-payne) wrote :

On 13.04, after adding the SIL repository (http://packages.sil.org/ubuntu/) to my sources and installing the Andika font, I'm getting these warnings from fontconfig (version 2.10.2):

$ fc-cache
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
Fontconfig warning: "/etc/fonts/conf.d/65-fonts-sil-andika.conf", line 16: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/65-fonts-sil-andika.conf", line 35: Having multiple <family> in <alias> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/65-fonts-sil-andika.conf", line 35: Having multiple <family> in <alias> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/65-fonts-sil-andika.conf", line 35: Having multiple <family> in <alias> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/65-fonts-sil-andika.conf", line 35: Having multiple <family> in <alias> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/65-fonts-sil-andika.conf", line 35: Having multiple <family> in <alias> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/65-fonts-sil-andika.conf", line 35: Having multiple <family> in <alias> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/65-fonts-sil-andika.conf", line 35: Having multiple <family> in <alias> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/65-fonts-sil-andika.conf", line 35: Having multiple <family> in <alias> isn't supported and may not work as expected

Changed in fonts-arphic-ukai (Debian):
status: New → Fix Released
Changed in fonts-arphic-uming (Debian):
status: Fix Committed → Fix Released
Nicolae Paladi (n-paladi) wrote :

I am running a ubuntu with gnome 12.04 and got this bug after updating my machine today

Changed in fonts-arphic-uming (Debian):
status: Fix Released → New
Changed in fonts-arphic-uming (Debian):
status: New → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1034928

tags: added: iso-testing
Adolfo Jayme (fitojb) on 2014-05-04
no longer affects: libreoffice (Ubuntu Quantal)
Changed in fonts-sil-andika (Debian):
status: Fix Committed → New
Changed in fonts-sil-andika (Debian):
status: New → Fix Committed
Changed in fonts-sil-andika (Debian):
status: Fix Committed → Fix Released
Jim Cline (jcline-physics) wrote :

This bug is easy to fix. For example, it will be caused by a section like this:

    <test name="lang" compare="not_eq">
      <string>zh-cn</string>
      <string>zh-sg</string>
    </test>

The correct syntax would be

    <test name="lang" compare="not_eq">
      <string>zh-cn</string>
    </test>
    <test name="lang" compare="not_eq">
      <string>zh-sg</string>
    </test>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.