Comment 86 for bug 1034928

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:4.0.1-0ubuntu1

---------------
libreoffice (1:4.0.1-0ubuntu1) raring; urgency=low

  [ Bjoern Michaelsen ]
  * new upstream release
    - fixes CRASH in action after Undo (LP: #785518)
    - fixes fontconfig warning (LP: #1034928)
    - fixes desktop file translations (LP: #1131470)
  * add transitionals for -presenter-console and -binfilter
  * add sessioninstaller for remaining wizards (LP: #780399)
  * merge from debian at 1:4.0.1~rc1-2
  * remaining delta on debian/control:
    - drop ${java-common-depends} from Recommends to Suggests on
      libreoffice-help-*
    - add libreoffice-gnome | libreoffice-kde Recommends on libreoffice
    - add libreoffice-style-human Suggests to libreoffice-common
    - add libreoffice-common self Conflicts with << 3.5.0
    - drop java-common-depends and java-runtime-depends from Recommends to
      Suggests on libreoffice-writer
    - add libreoffice-pdfimport Recommends on libreoffice-draw
    - drop libreoffice-core from Depends to Recommends on libreoffice-style-*
    - add libreoffice-style-human
    - add C/P/R against lo-menubar from libreoffice-gtk
    - alternatively Recommends libreoffice-style-human from libreoffice-gtk3
    - add C/R against libreoffice-core (<< 1:3.9999) from libreoffice-gnome
    - add Conflicts against libreoffice-common (<< 1:3.5.0) from python3-uno
    - add libreoffice-subsequentcheckbase
    - add libreoffice-presenter-console transitional
  * remaining delta on debian/patches:
    - add Ubuntu brand palette
    - add session-installer for Java Wizards
  * remaining delta on rules:
    - fix configure switch for human theme
    - use internal jfreereport because of huge component mismatch otherwise
    - white progressbar instead of Debian Purple (or Ubuntu orange)
    - adjust bug reporting destination for ppa builds
    - disable tests on armel, armhf, powerpc
    - enable parallel build and mergelibs
    - disable evolution
    - use internal liblangtag for now
    - disable help building on armel/armhf
    - Ubuntu backport fixes
    - reduced l10n for ppa builds
    - alternatively allow firefox-dev to xulrunner-dev as build-dep
    - warn early on GVFS and GIO in same build
    - generate transitionals
    - generate subsequentcheckbase
    - fix missing closing para wrt slide remote
    - move sessioninstaller from -gtk to -gnome for gio deps
    - move subsequentcheckbase jars to package
    - use --with-all-tarballs in addition to our flags for getting the source
      - this is so that ./configure doesnt stumble over other checks
        (e.g. still needing gnomevfs)
  * removed delta:
    - drop libreoffice-filter-mobiledev and ttf-sil-gentium-basic from Depends
      to Suggests on libreoffice
    - remove libreoffice-core postinst
    - fixed gnu make version
    - remove hotfixes get-orig-sources hack
    - some whitespace
  * silent some lintian noise for unversioned breaks:
    - promote Breaks to Conflicts against -binfilter as it will never return
    - promote Breaks to Conflicts from langpacks against en-US
    - remove Breaks against -style-industrial which is long gone
  * libreoffice-core already conflicts with -evolution, so no need to break in
      addition
  * remove all traces of -so52
  * conflict help language packages in both ways

  [ Rico Tzschichholz ]
  * disable two more flaky tests for now:
    - fdo#35663
    - fdo#61896

libreoffice (1:4.0.1~rc1-2) experimental; urgency=low

  * debian/rules:
    - add correct build-dep on cpp-4.7...

libreoffice (1:4.0.1~rc1-1) experimental; urgency=low

  * new upstream release candidate
    - removes "Impress Remote" menu option unless in experimental mode.
      (closes: #700728)

  * debian/patches/debian-hardened-buildflags.diff: only set CPPFLAGS here now

  * debian/rules:
    - use /usr/share/dpkg/buildflags.mk for C(XX)FLAGS, LDFLAGS now that LO
      honours those from the env in configure. Remove manual passing to make.
    - conditionalize pyuno build/install more so that we can build only
      python-uno on wheezy-backports. Bit obscure, but...
    - explicitly use cpp-4.7 as cpp 4.8 would fail

libreoffice (1:4.0.0-1) experimental; urgency=low

  * new upstream release
    - contains new driver for mozab (mork). Automatically enabled thus
      this closes: #321099
    - now has a basic(!) gnumeric import in experimental mode
      (closes: #595708)
    - fixes LibreOffice Calc unshows comments importing MS Office xlsx (LP: #990868)
    - supports IFERROR (closes: #662798)

  * debian/control.in:
    - make -impress suggest bluez (for impress remote control)
    - make libreoffice depend on / -common recommend python(3)-uno for the
      new python-based wizards
  * debian/rules:
    - add new conditionals for new dependencies: liblangtag, liborcus,
      libmspub, (u)cpp; remove them for gone saxon, librsvg, db
    - enable sdrmeote on all archs; b-d on libbluetooth-dev on where we
      enable bluetooth (!kfreebsd-*)
    - use gstreamer1.0
    - use --disable-dependency-tracking instead of gb_FULLDEPS= and
      --enable-hardlink-deliver instead of gb_Deliver_HARDLINK=T
    - python3 is default now; reverse logic (use python3 per default and
      and build python2 in a extra step)
    - add option to build with --enable-mergelibs, not yet enabled.
    - remove stlport hacks for i386 - not used/needed anymore upstream
  * debian/uno-libs3.symbols: update
  * debian/control*.in, debian/rules, debian/scripts/gid2pkgdirs.sh: binfilter
    is gone. yay.
  * debian/*.mime:
    - don't use obsolete -no-oosplash anymore, thanks Matthijs Kooijman
      for the patch (closes: #698845)
  * debian/copyright: update
  * debian/control.mozilla.in: OOo -> "old OOo and OpenDocument"
    (closes: #699708)
 -- Bjoern Michaelsen <email address hidden> Thu, 07 Mar 2013 14:56:29 +0100