Docky freezes in zeitgeist-gio when launching application

Bug #628372 reported by Mathijs Henquet on 2010-09-01
102
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Docky
High
Rico Tzschichholz
Unity
Fix Released
Medium
Mikkel Kamstrup Erlandsen
libzeitgeist
High
Mikkel Kamstrup Erlandsen
docky (Ubuntu)
Undecided
Unassigned
libzeitgeist (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: docky

Since today's (kernel) updates Docky freezes when launching an -- previously not running -- application from the dock. The icon jump animation isn't shown, the mouseover stays on screen, and Docky becomes completely unresponsive.

Launching applications in other way or minimizing/maximizing windows doesn't freeze Docky.

I'm using
Ubuntu version: Maverick alpha
Docky version: 2.1.0 vzr docky r1620 ppa
Kernal version: 2.6.35.19
CLR version: 2.0.50727.1433

This bug is not just in the ppa, after downgrading to Maverick packages (Docky 2.0.5 releace) the bug is still present.

Same here, previoulsy installed with the PPA, but the bug still present after the downgrade.

Alberto Milone (albertomilone) wrote :

I managed to get the following thread dump.

summary: - Docky feezes when launching application
+ Docky freezes when launching application

I never had the PPA installed and I'm also getting this bug.

My thread dump is different from Alberto's one, so I thought I post it too.

Changed in docky (Ubuntu):
status: New → Confirmed
Robert Dyer (psybers) wrote :

This freeze seems to only affect Maverick.

Changed in docky:
assignee: nobody → Chris S. (cszikszoy)
importance: Undecided → High
Alberto Milone (albertomilone) wrote :

Yes, the problem affects Maverick and can be reproduced with 2.6.35.15 too (not only with 2.6.35.19).

Me too. Docky's strace stops on a futex system call. Some kind of deadlock then?

Changed in docky:
status: New → Confirmed
description: updated
TheNerdAL (thedezigncenter) wrote :

Happens to me too.

dart (dart-v85) wrote :

This affects me too and I had to switch to AWN...

Robert Dyer (psybers) wrote :

We dont need a bunch of 'me too' posts - there is something up top to indicate it affects you.

If you post a comment, please provide us with new information to help us resolve the issue.

Revision 1622 fixed it on kernel version 2.6.35.19. Thanks!

Robert Dyer (psybers) wrote :

Well then 1624 will break it again because I reverted 1622.

Alberto Milone (albertomilone) wrote :

I tried the packages in PPA but they didn't solve the problem, then I decided to go back to the package in Maverick by using the ppa-purge utility (from the xorg-edgers PPA):

sudo ppa-purge docky-core

Finally I ran docky with "docky --debug" for further debugging and the problem was gone (see the output in the attached file). I haven't been able to reproduce the problem since then (with or without "--debug").

My guess is that some file was removed from /etc when I purged the packages.

AkiraH (akirah) wrote :

I've tried it too with 2.0.6 and it freeze too

AkiraH (akirah) wrote :

Debug log with older version.

Doug McMahon (mc3man) wrote :

Happened to install Docky last night from the maverick repo to find some solutions to non functional audio-cd icon (no sound-juicer
(had never been previously installed
Ran fine on 2 different machines, both with current 10.10 installs.
After removing fully a built 2.0.6 also works fine, as does a build from the current source on the ppa - 2.1.0~bzr1628

Robert Dyer (psybers) wrote :

@AkiraH: unless the upload of your log failed to finish and/or is cut off, it appears your lockup was while Docky was loading and thus is not this bug.

@Doug: thanks for the input, it seems that simply being on Maverick is not enough to encounter this bug - there must be more factoring into it.

Doug McMahon (mc3man) wrote :

Just to complete - didn't get a chance to follow thru 100% before

removed completely built installs from the current ppa sources of docky and dockmanager

Added the ppa and installed docky and dockmanager - 1 package set was also upgraded
libndesk-dbus1.0-cil, libndesk-dbus1.0-cil-dev

All works fine - the debug is as expected
Then main difference from here and those affected seems to be a prior install, maybe someone try using ppa-purge and then re-installing from the ppa or the maverick version

Jack Deslippe (jdeslip) wrote :

I tried using ppa-purge and then installing from the maverick version and it is still broken (freezes when launch an application). I even removed the docky directories from .gconf and local...

The weird thing is that this just started happenning to me yesterday on Maverick. Not sure what changed...

Jack Deslippe (jdeslip) wrote :

I have figured out the origin of this bug (at least for me). The bug appeared for me yesterday because I had just installed unity (for fun) which brought in a bunch of zeitgeist packages. When I removed unity and all the zeitgeist packages, this bug goes away. In particular, libzeitgeist-gio libzeitgeist-1.0-0 seem to cause the trouble.

I can reproduce the bug 100% of the time and reproduce the fix every time by reinstalling unity and then removing it (and the zeitgeist packages).

AkiraH (akirah) wrote :

@Jack I can confirm that. That's what I've just noticed in strace, that it hangs on zeitgeist.

Robert Dyer (psybers) wrote :

@Jack: thanks for narrowing it down. Marking this bug as Invalid for Docky and adding libzg to the tracker.

Changed in docky (Ubuntu):
status: Confirmed → Invalid
Changed in docky:
status: Confirmed → Invalid
Seif Lotfy (seif) wrote :

Try installing the zeitgeist-engine and zeitgeist-datahub packages without
libzeitgeist-gio libzeitgeist-1.0-0
and tell me what happens please

Changed in libzeitgeist:
status: New → Confirmed

confirmed, i uninstalled libzeitgeist-gio libzeitgeist-1.0-0 and now all is OK. Thanks!

OK seems like its something from libzg indeed. I will contact the
responsible person. Thanks alot

On Fri, Sep 10, 2010 at 11:23 PM, Jérémi Couillard <<email address hidden>
> wrote:

> confirmed, i uninstalled libzeitgeist-gio libzeitgeist-1.0-0 and now all
> is OK. Thanks!
>
> --
> Docky freezes when launching application
> https://bugs.launchpad.net/bugs/628372
> You received this bug notification because you are subscribed to The
> Zeitgeist Project.
>
> Status in Docky: Invalid
> Status in Zeitgeist Client Library: Confirmed
> Status in “docky” package in Ubuntu: Invalid
>
> Bug description:
> Binary package hint: docky
>
> Since today's (kernel) updates Docky freezes when launching an --
> previously not running -- application from the dock. The icon jump animation
> isn't shown, the mouseover stays on screen, and Docky becomes completely
> unresponsive.
>
> Launching applications in other way or minimizing/maximizing windows
> doesn't freeze Docky.
>
> I'm using
> Ubuntu version: Maverick alpha
> Docky version: 2.1.0 vzr docky r1620 ppa
> Kernal version: 2.6.35.19
> CLR version: 2.0.50727.1433
>
>
>
>
>

--
This is me doing some advertisement for my blog http://seilo.geekyogre.com

@Seif - I wasn't able to find the zeitgeist-engine package, but install zeitgeist-datahub (which brings in zeitgeist-core) seems fine. It does not break docky like the libzeitgeist package does.

I don't really know if it is "working" per-se because I don't know what docky has to do with zeitgeist, but it doesn't break docky at least.

do you have the zeitgeist helper activated?

On Fri, Sep 10, 2010 at 11:37 PM, Jack Deslippe <email address hidden> wrote:

> @Seif - I wasn't able to find the zeitgeist-engine package, but install
> zeitgeist-datahub (which brings in zeitgeist-core) seems fine. It does
> not break docky like the libzeitgeist package does.
>
> I don't really know if it is "working" per-se because I don't know what
> docky has to do with zeitgeist, but it doesn't break docky at least.
>
> --
> Docky freezes when launching application
> https://bugs.launchpad.net/bugs/628372
> You received this bug notification because you are subscribed to The
> Zeitgeist Project.
>
> Status in Docky: Invalid
> Status in Zeitgeist Client Library: Confirmed
> Status in “docky” package in Ubuntu: Invalid
>
> Bug description:
> Binary package hint: docky
>
> Since today's (kernel) updates Docky freezes when launching an --
> previously not running -- application from the dock. The icon jump animation
> isn't shown, the mouseover stays on screen, and Docky becomes completely
> unresponsive.
>
> Launching applications in other way or minimizing/maximizing windows
> doesn't freeze Docky.
>
> I'm using
> Ubuntu version: Maverick alpha
> Docky version: 2.1.0 vzr docky r1620 ppa
> Kernal version: 2.6.35.19
> CLR version: 2.0.50727.1433
>
>
>
>
>

--
This is me doing some advertisement for my blog http://seilo.geekyogre.com

What happens if you install just libzeitgeist-1.0-0, but *not* libzeitgeist-gio?

I'd be surprised if libzeitgeist alone should cause this. libzeitgeist-gio installs a GIO module that logs in Zeitgeist every time a GDesktopAppInfo is launched. This way we can track "most popular apps" and other cool stats about your app usage patterns.

So the most likely cause of the problem is that this GIO module somehow messes stuff up with Docky... I can't see what this should be off the top of my head, but we'll get to the bottom of this :-)

Jack Deslippe (jdeslip) wrote :

@Mikkel - You are right. It is only libzeitgeist-gio that causes the bug. libzeitgeist-1.0.0 alone is ok. I thought for some reason that those two packages were inseparable earlier.

I bit of ping ponging with Michal Hruby has led me to believe that this is almost certainly some threading issue of some sort.

I change in the zeitgeist-gio code that is very likely to fix this would be to defer all the zg-gio logic into an idle handler - which is probably the right thing to do anyway...

I've milestoned it for this weeks Unity updates so I don't forget about this issue - let's cross fingers that it's the right fix :-)

summary: - Docky freezes when launching application
+ Docky freezes in zeitgeist-gio when launching application
Changed in libzeitgeist:
importance: Undecided → High
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
Changed in unity:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → Medium
milestone: none → 2010-09-16
status: New → Triaged

While digging into the libzeitgeist-gio code I suddenly recall that I added some lazy initialization of the crucial parts. This fixed some odd crashes and deadlocks I was seeing. Can any of you affected by this report which version of libzeitgeist-gio you have installed? The fix was available since 0.2.8.

libzeitgeist-gio:
  Installed: 0.2.8-0ubuntu1
  Candidate: 0.2.8-0ubuntu1
  Version table:
 *** 0.2.8-0ubuntu1 0
        500 http://ubuntu.media.mit.edu/ubuntu/ maverick/main amd64 Packages
        100 /var/lib/dpkg/status

I still have this bug in docky.

--
Cheers,
Leif

Changed in docky:
assignee: Chris S. (cszikszoy) → Rico Tzschichholz (ricotz)
status: Invalid → Fix Committed
milestone: none → 2.0.7
Changed in libzeitgeist:
status: Confirmed → Fix Committed
Changed in unity:
status: Triaged → Fix Committed
dart (dart-v85) wrote :

Thanks for the fix....Docky works fine now. **Relief**

On Thu, Sep 16, 2010 at 1:49 AM, Launchpad Bug Tracker <
<email address hidden>> wrote:

> ** Branch linked: lp:libzeitgeist
>
> --
> Docky freezes in zeitgeist-gio when launching application
> https://bugs.launchpad.net/bugs/628372
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Docky: Fix Committed
> Status in Zeitgeist Client Library: Fix Committed
> Status in Unity: Fix Committed
> Status in “docky” package in Ubuntu: Invalid
>
> Bug description:
> Binary package hint: docky
>
> Since today's (kernel) updates Docky freezes when launching an --
> previously not running -- application from the dock. The icon jump animation
> isn't shown, the mouseover stays on screen, and Docky becomes completely
> unresponsive.
>
> Launching applications in other way or minimizing/maximizing windows
> doesn't freeze Docky.
>
> I'm using
> Ubuntu version: Maverick alpha
> Docky version: 2.1.0 vzr docky r1620 ppa
> Kernal version: 2.6.35.19
> CLR version: 2.0.50727.1433
>
>
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/docky/+bug/628372/+subscribe
>

Robert Dyer (psybers) wrote :

*not* a Docky bug, rev 1638 in Docky will be reverted and a proper fix in libzg will fix this problem

Changed in docky:
status: Fix Committed → Invalid
milestone: 2.0.7 → none
Changed in unity:
status: Fix Committed → Fix Released
Changed in libzeitgeist:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2010-09-17
Changed in libzeitgeist (Ubuntu):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libzeitgeist - 0.2.10-0ubuntu1

---------------
libzeitgeist (0.2.10-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - Docky freezes in zeitgeist-gio when launching application (LP: #628372)
  * debian/rules:
    - remove DEB_DH_MAKESHLIBS_ARGS_libzeitgeist1.0-0: no more needed now that
      we have a symbol file
 -- Didier Roche <email address hidden> Fri, 17 Sep 2010 14:07:03 +0200

Changed in libzeitgeist (Ubuntu):
status: Triaged → Fix Released
rais (ramzi-rais) wrote :

thank you very much
docky started to work now!!!!

Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers