package cupsys 1.3.2-1ubuntu4 failed to install/upgrade: trying to overwrite `/usr/share/doc/libcupsys2/CREDITS.txt', which is also in package libcupsys2

Bug #149106 reported by Martin Thorsen Ranang on 2007-10-04
648
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cupsys (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: cupsys

The same bug as #149097, but for version 1.3.2-1ubuntu4.

ProblemType: Package
Architecture: i386
Date: Thu Oct 4 21:19:27 2007
DistroRelease: Ubuntu 7.10
ErrorMessage: trying to overwrite `/usr/share/doc/libcupsys2/CREDITS.txt', which is also in package libcupsys2
Package: cupsys 1.3.2-1ubuntu1
PackageArchitecture: i386
SourcePackage: cupsys
Title: package cupsys 1.3.2-1ubuntu1 failed to install/upgrade: trying to overwrite `/usr/share/doc/libcupsys2/CREDITS.txt', which is also in package libcupsys2
Uname: Linux mtr-laptop 2.6.22-12-generic #1 SMP Sun Sep 23 18:11:30 GMT 2007 i686 GNU/Linux

Martin Thorsen Ranang (mtr) wrote :
Amit Kumar Sharma (amit.9b) wrote :

-- Temporary Fix --

STEP 1: Run
 # dpkg -i --force-overwrite /var/cache/apt/archives/cupsys_1.3.2-1ubuntu4_i386.deb

STEP 2: Since conflict has already been resolved (forcefully), proceed with normal installation
Run :
  # apt-get -f install

Daniel Hahler (blueyed) on 2007-10-04
Changed in cupsys:
status: New → Confirmed
kenw (kenw) wrote :

Confirmed, both the bug and the Temporary Fix.

In my case I just went back to update-manager and clicked the install button again and all finished up just fine.

On tor, okt 04 2007, amit_9b wrote:

> -- Temporary Fix --
>
> STEP 1: Run
> # dpkg -i --force-overwrite /var/cache/apt/archives/cupsys_1.3.2-1ubuntu4_i386.deb
>
> STEP 2: Since conflict has already been resolved (forcefully), proceed with normal installation
> Run :
> # apt-get -f install

Thanks for the tip, although I had already done that. I only wanted
to report the bug so that the package could be fixed.

> ** Attachment added: "log of issuing the above commands"
> http://launchpadlibrarian.net/9737673/foo.log
>
> --
> package cupsys 1.3.2-1ubuntu4 failed to install/upgrade: trying to overwrite `/usr/share/doc/libcupsys2/CREDITS.txt', which is also in package libcupsys2
> https://bugs.launchpad.net/bugs/149106
> You received this bug notification because you are a direct subscriber
> of the bug.

--
Sincerely yours,

Martin Thorsen Ranang

dragon76 (tfishwall) wrote :

The above fix is for i386 installs only.
For amd64 installations the temporary fix dpkg command should be:

dpkg -i --force-overwrite /var/cache/apt/archives/cupsys_1.3.2-1ubuntu4_amd64.deb

Dragon

Steve Langasek (vorlon) on 2007-10-04
Changed in cupsys:
importance: Undecided → High
Vince McIntyre (vmcintyr) wrote :

I had the same error as the initial report.
However when trying to install the .deb by force, I get further errors, see below.
So that method won't work for all cases.

$ sudo dpkg -i --force-overwrite /var/cache/apt/archives/cupsys_1.3.2-1ubuntu4_i386.deb
(Reading database ... 162129 files and directories currently installed.)
Preparing to replace cupsys 1.3.2-1ubuntu1 (using .../cupsys_1.3.2-1ubuntu4_i386.deb) ...
Ignoring nonregistered document cupsys
 * Stopping Common Unix Printing System: cupsd [ OK ]
Unpacking replacement cupsys ...
dpkg - warning, overriding problem because --force enabled:
 trying to overwrite `/usr/share/doc/libcupsys2/CREDITS.txt', which is also in package libcupsys2
dpkg - warning, overriding problem because --force enabled:
 trying to overwrite `/usr/share/doc/libcupsys2/README.txt.gz', which is also in package libcupsys2
dpkg: dependency problems prevent configuration of cupsys:
 cupsys depends on libavahi-compat-libdnssd1 (>= 0.6.13); however:
  Package libavahi-compat-libdnssd1 is not configured yet.
 cupsys depends on libcupsimage2 (>= 1.3.0); however:
  Package libcupsimage2 is not configured yet.
 cupsys depends on libcupsys2 (>= 1.3.0); however:
  Package libcupsys2 is not configured yet.
 cupsys depends on cupsys-common; however:
  Package cupsys-common is not configured yet.
dpkg: error processing cupsys (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 cupsys

Kalrog (nathan-deckinga) wrote :

Same issue here - 64bit Kubuntu. The temporary fix did not work for me.

Johannes Möller (jojo-moeller) wrote :

Bug confirmed, temporary fix didn't work. Don't know, why, did it as explained above (the i386 one, naturally).

Peter Jönsson (peterj1978) wrote :

Ran into this problem also, temporary fix let me continue.

Daniel Hahler (blueyed) wrote :

If the temporary fix does not work for you, please try running "sudo apt-get install -f" before forcefully installing the .deb.
If you are not using i386, you need to "dpkg -i --force-overwrite /var/cache/apt/archives/cupsys_1.3.2-1ubuntu4_$ARCH.deb" - replacing "$ARCH" with e.g. "amd64". Tab-completion may help here.

Temporary workaround suggested above works for me. kubuntu 7.10 beta.

James Dunmore (james-dunmore) wrote :

"Temporary workaround suggested above works for me. kubuntu 7.10 beta."

Me too

Also works for me.

Nizar Kerkeni (nizarus) wrote :

Temporary workaround suggested above works for me with a "sudo" on gutsy amd64

works for me too

Adric Riedel (adric-riedel) wrote :

dAniel hAhler's workaround fixed the problem; Kubuntu 7.10 AMD64.

daws (dawsdesign) wrote :

Workaround worked for me

Chow Loong Jin (hyperair) wrote :

Workaround worked for me. I had that problem earlier with GIMP but it went off with this update.

hshan (hshan) wrote :

Ditto on the temp work around. Thanks.

Changed in cupsys:
status: Confirmed → Triaged
jmrichky (jmrichky) wrote :

temporary fixed worked for me on amd64

Roger Hart (rogerivanhart) wrote :

Temporary fix worked. Great, thanks.

Kyle Jones (mutiny32) wrote :

Temporary fix worked perfectly.

n3m3sis (nem2killu2) wrote :

Temporary fix worked for me also, however like kenw I just clicked the update manger again. It reported 110 updates available, not 111 but finished the install anyway.

Many thanks for the temporary fix, Long Live Ubuntu!!!

Temporary fix works for me too

Colin Watson (cjwatson) wrote :

For future reference, please don't use this kind of temporary fix - I'm having to put a rather more permanent workaround into the fixed packages to cope with the way everyone's using this temporary fix!

Samnsparky (samnsparky) wrote :

I confirm the problem and that the temporary fix was successful.

Joey Stanford (joey) wrote :

Worked for me on i386, thanks

Samnsparky (samnsparky) wrote :

However, after the temporary fix was applied various errors (that I can not reproduce) have come up and a strange message displayed in the terminal: If your squo ;ve been using windows. I can not reproduce the errors and I dont know how to get to them. I reported all of the errors however there must have been at least twenty.

Samnsparky (samnsparky) wrote :

Just as an update. Everything appears to be working normally.

Colin Watson (cjwatson) wrote :

cupsys (1.3.2-1ubuntu5) gutsy; urgency=low

  * Revert previous approach to symlinking of documentation directories, and
    do it in a way that's more in line with the existing code in
    debian/rules.
  * debian/cupsys.docs: Remove duplicate files (LP: #149106).
  * Make libcupsys2 replace the broken version of cupsys to help out people
    who used dpkg --force-overwrite wrongly.
  * Fix dh_compress arguments to cope with moved examples.
  * debian/cupsys.preinst, debian/cupsys-common.preinst: Remove old
    directories before unpack, since dpkg won't replace directories with
    symlinks.

 -- Colin Watson <email address hidden> Fri, 05 Oct 2007 02:46:34 +0100

Changed in cupsys:
status: Triaged → Fix Released
lert (lizheng02) wrote :

OK, my problem has been solved by the command: dpkg -i --force-write **.deb. Thanks.

Nikhil (gupta-nikhil83) wrote :

works for me.

Adric Riedel (adric-riedel) wrote :

Colin Watson, what would have been the preferred way to fix it?

Also, what exactly did we break by doing that? Package pinning?

KLA Khan (klakhan) wrote :

I can also confirm the bug and the temporary fix works for me.

bretticus (bretticus) wrote :

Work-around put me back in business...many thanks!

John (fezzik02) wrote :

Workaround good for me. Sorry about doing the force update, but it's not my fault it was broken in the first place. What would have been cool would be a way to tell it (apt-get/Synaptic) to ignore the update and not bother me again until there is an even newer update (that works, hopefully). It's implemented pretty slick in XP. If I had that, I would have skipped the force. I know I'm in beta, if the installer doesn't work, I just have to accept it and move on.

Workaround worked for me too.

jimw428 (jimw428) wrote :

Dragon 64-bit fix worked for me.

valentinos (valentinos) wrote :

The fix worked ok

Thank you

Nick Lally (nick-lally) wrote :

Fix worked for me.

Fix worked. Gutsy Beta.

snoopbear (leeley) wrote :

Fix worked for me

mitkonanov (mitko-n) wrote :

retrying to update from manager worked fine for me

Fix Released ?
the problem is still here ! (using german mirror)

Mircea Deaconu (mirceade) wrote :

Confirming problem (german mirrors).

Alec Wright (alecjw) wrote :

For all those who say they cant upgrade to the new version (eg dominik & Mircea), just be patient, It'll be uploaded to your mirror soon. Probably within a day at the max. If you're really desperate, I can confirm that the UK mirror (http://gb.archive.ubuntu.com/ubuntu) has the upgrade on it.
alec@Jupiter:~$ apt-cache policy libcupsys2
libcupsys2:
  Installed: 1.3.2-1ubuntu4
  Candidate: 1.3.2-1ubuntu5
  Version table:
     1.3.2-1ubuntu5 0
        500 http://gb.archive.ubuntu.com gutsy/main Packages
 *** 1.3.2-1ubuntu4 0
        100 /var/lib/dpkg/status
alec@Jupiter:~$

Wrwrwr (wrwrwr) wrote :

As a temporary fix, wouldn't just holding the package (force version) for a second be better? Unless you need the new version urgently of course. Worked for me ;)

zhang shixing (roterio) wrote :

    First I'd like to thank all of you for different suggestions.
 The various solutions really worked for me effectively .It's so great.Now
 the problem was solved successfully .Everything turns OK. I think
The new version will be getting more perfect and wonderful for everyone who
 is interested in and pay attention to Ubuntu . Thank for all people here.

Solved on german mirros, too.

starscalling (starscalling) wrote :

i just waited a day and then the packages from the repo seemed to have been fixed
thanx for the quick attention to the bug guys/galz!

ifbermeo (ifbermeo) wrote :

Does anyone know how I can stop getting emails about this bug?

On 10/8/07, starscalling <email address hidden> wrote:
>
> i just waited a day and then the packages from the repo seemed to have
> been fixed
> thanx for the quick attention to the bug guys/galz!
>
> --
> package cupsys 1.3.2-1ubuntu4 failed to install/upgrade: trying to
> overwrite `/usr/share/doc/libcupsys2/CREDITS.txt', which is also in package
> libcupsys2
> https://bugs.launchpad.net/bugs/149106
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Hi

There is a patch to download and it fixed it.

Better still install all the updates except that one and it gets sorted
out on the next batch of updates anyway, as I found out on my second pc.

FRANKOS

On Wed, 2007-10-10 at 01:22 +0000, ifbermeo wrote:
> Does anyone know how I can stop getting emails about this bug?
>
> On 10/8/07, starscalling <email address hidden> wrote:
> >
> > i just waited a day and then the packages from the repo seemed to have
> > been fixed
> > thanx for the quick attention to the bug guys/galz!
> >
> > --
> > package cupsys 1.3.2-1ubuntu4 failed to install/upgrade: trying to
> > overwrite `/usr/share/doc/libcupsys2/CREDITS.txt', which is also in package
> > libcupsys2
> > https://bugs.launchpad.net/bugs/149106
> > You received this bug notification because you are a direct subscriber
> > of a duplicate bug.
> >
>

This has long been fixed. In fact and as always since I installed Tribe 5,
switching from Adept to aptitude on the command line perfectly installs any
package that Adept failed to. So it has been fixed for me the first day it
appeared.

On 10/10/07, Frank Leigh <email address hidden> wrote:
>
> Hi
>
> There is a patch to download and it fixed it.
>
> Better still install all the updates except that one and it gets sorted
> out on the next batch of updates anyway, as I found out on my second pc.
>
> FRANKOS
>
>
> On Wed, 2007-10-10 at 01:22 +0000, ifbermeo wrote:
> > Does anyone know how I can stop getting emails about this bug?
> >
> > On 10/8/07, starscalling <email address hidden> wrote:
> > >
> > > i just waited a day and then the packages from the repo seemed to have
> > > been fixed
> > > thanx for the quick attention to the bug guys/galz!
> > >
> > > --
> > > package cupsys 1.3.2-1ubuntu4 failed to install/upgrade: trying to
> > > overwrite `/usr/share/doc/libcupsys2/CREDITS.txt', which is also in
> package
> > > libcupsys2
> > > https://bugs.launchpad.net/bugs/149106
> > > You received this bug notification because you are a direct subscriber
> > > of a duplicate bug.
> > >
> >
>
> --
> package cupsys 1.3.2-1ubuntu4 failed to install/upgrade: trying to
> overwrite `/usr/share/doc/libcupsys2/CREDITS.txt', which is also in package
> libcupsys2
> https://bugs.launchpad.net/bugs/149106
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
[Thorns]
Tessa IM at OL - http://obsidianlake.com/
My blog - http://obsidianlake.blogspot.com/
My host - http://www.aquawebsolutions.com/

DatsMzCC2U (cmimsbrad) on 2010-01-01
Changed in cupsys (Ubuntu):
status: Fix Released → Incomplete
status: Incomplete → Fix Committed
status: Fix Committed → Fix Released
DatsMzCC2U (cmimsbrad) on 2010-01-01
Changed in cupsys (Ubuntu):
status: Fix Released → Fix Committed
Daniel Hahler (blueyed) wrote :

This was fixed already. Comments above appear to be spam.
See Bug #45419 about a request to easily flag this - you might want to click "Affects me" there.

Changed in cupsys (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.