Ubuntu

Encountered a section with no Package: header

Reported by Nizar Kerkeni on 2008-02-22
152
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
High
Michael Vogt

Bug Description

Binary package hint: update-manager

on ubuntu hardy alpha 4 on amd64
package update-manager, synaptic, apt-get

After updating hardy alpha 4 in 02/21/08 today (02/22/08) i got this message after trying to update my system with synaptic and apt-get command line.

E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_hardy_universe_i18n_Translation-fr
E: Impossible d'ouvrir ou d'analyser le fichier contenant la liste des états ou celui des paquets disponibles.
E: _cache->open() failed, please report.

I update my ubuntu almost daily. This error was caused by the update of 23 february 2008.

jamdess (jamdess) wrote :

I've exactly the same problem

Lecture des listes de paquets... Erreur !
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_hardy_universe_i18n_Translation-fr
E: Les listes de paquets ou le fichier « status » ne peuvent être analysés ou lus.
E: Impossible de reconstruire le cache des paquets

how can we do an update to correct this problem, as our apt package manager seems to be crashed with the last update ?

hype (hypeuser-lp) wrote :

Confirmed

Olivier Blanc (olivier-blanc) wrote :

I have the same error:
Lecture des listes de paquets... Erreur !
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_hardy_universe_i18n_Translation-fr
E: Les listes de paquets ou le fichier « status » ne peuvent être analysés ou lus.

moa3333 (moa3333) wrote :

same here

Lecture des listes de paquets... Erreur !
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_hardy_universe_i18n_Translation-fr
E: Les listes de paquets ou le fichier « status » ne peuvent être analysés ou lus.
Lecture des listes de paquets... Erreur !
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_hardy_universe_i18n_Translation-fr
E: Les listes de paquets ou le fichier « status » ne peuvent être analysés ou lus.

moa3333 (moa3333) on 2008-02-22
Changed in update-manager:
status: New → Confirmed
moa3333 (moa3333) on 2008-02-22
description: updated
foox (fooxland) wrote :

same for me

Jim Braux-Zin (j-brauxzin) wrote :

Same problem here

Jean-Rémy Falleri (jrfaller) wrote :

I have also the same problem...

cestuila (cestuila) wrote :

same here on hardy 32bits

Atteint http://archive.ubuntu.com hardy-security/multiverse Packages
Lecture des listes de paquets... Erreur !
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_hardy_universe_i18n_Translation-fr
E: Les listes de paquets ou le fichier « status » ne peuvent être analysés ou lus.

Jim Braux-Zin (j-brauxzin) wrote :

A temporary workaround : disable the universe source. At least you would be able to use the package managers.

knoodrake (knoodrake) wrote :

Confirmed here.

Hoa (nicolas-boucly) wrote :

Same here

Changed in update-manager:
assignee: nobody → nicolas-boucly
assignee: nicolas-boucly → nobody
Jim Braux-Zin (j-brauxzin) wrote :

better workaround : delete the file /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_hardy_universe_i18n_Translation-fr each time you do an apt-get update

hype (hypeuser-lp) wrote :

Jim Braux-Zin , this file is recreated each time you update.
Doing what you said doesnt solve the issue here.

Jim Braux-Zin (j-brauxzin) wrote :

Of course no but it allows to use the package managers as usual instead of throwing an error.

nazeman (gnome-nazeman) wrote :

workaround : write in console
# LANG=C
# synaptic or apt-get update

work ;-)

Mathieu Gaspard (lukeg) wrote :

the workaround above works (as the language is changed from french to english)

Iulian Udrea (iulian) on 2008-02-23
Changed in update-manager:
importance: Undecided → Low
Nicolas DERIVE (kalon33) wrote :

Same problem in hardy i386...

atomic (julienmachon) wrote :

Thank you Nazeman. It works perfectly on my Alpha 5.

Yves Le Berre (yleberre) wrote :

The file '/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_hardy_universe_i18n_Translation-fr' contains
a package description (3dchess) which must be updated by removing ^M and adding '.' and spaces.

As this file is cleaned (default option --list-cleanup) and reloaded from universe repository when 'apt-get update' is spawned, you may update it and change rights 444 to verify there are no more errors (revert the file to original rights 644 or remove it after the verification)

Adrien Cunin (adri2000) wrote :

This is indeed a bug with the translation of packages descriptions.
As of now, http://archive.ubuntu.com/ubuntu/dists/hardy/universe/i18n/Translation-fr is still not fixed.
Subscribing French translation team.

Yves Le Berre (yleberre) wrote :

My previous post was incorrect :

The file is cleaned and reloaded from universe repository ONLY if it has been modified since the last apt-get update, so you do not have to change rights for testing.

The only thing I've noticed in those translations is two ’ (instead of ') in 3dchess description. I've changed this string yesterday in Launchpad. Anyway this was an old translation (2006), I don't think this could solve the problem.

Yves Le Berre (yleberre) wrote :

See the file loaded by apt-get update : Translation-fr in the attachment
Translation-fr.bz2 or Translation-fr.gz from repository give the same file after uncompress.

Thanks for your analysis Yves, but French Translators couldn't do anything for now. We can only modify translated strings via Launchpad. Obviously there's a problem with 3dchess description and, as I said previously, this has been fixed in Launchpad. We now have to wait a new sync of universe with Launchpad translations...

Michael Vogt (mvo) on 2008-02-25
Changed in update-manager:
assignee: nobody → mvo
importance: Low → High
status: Confirmed → In Progress

Thanks a lot Michael for your work on this bug. Hope this will be fixed soon ;-)
If this was due to an inconsistency (typo error or anything else) within French translation, maybe there's something to improve in Launchpad to avoid this kind of issue in the future.

Michael Vogt (mvo) wrote :

Thanks for your help with fixing the issue, I uploaded new translations into the archive now and I added some checks to my code that should prevent this from happening again in the future.

Cheers,
 Michael

Changed in apt:
status: In Progress → Fix Committed

I have a good correction, the correction is in file file.
The problem is the hazardous character and point to miss.
The correction is to link her : http://paste.ubuntu-nl.org/57333/ or file

sorry i'm bad to english

Je soumet une correction de bug.
Le problème était que dans l'ancien fichier il manquais un point, et deux caractères chapeau M était trop.
Je vous donne le lien du bon fichier : http://paste.ubuntu-nl.org/57333/ ainsi que le fichier dans l'attachement.

Ok, this bug is squashed ;-) Thanks again Michael for the quick fix.
Our apologies to French users on behalf of French Translators Team.

Michael Vogt (mvo) wrote :

Thanks for verifying the fix and sorry for the trouble. Setting to fix released now.

Changed in apt:
status: Fix Committed → Fix Released
A. Broustet (ubuntu-amael) wrote :

I still get the error when using synaptic with language set to french (the workaround lang=C works). How do I apply / get the fix ?
Thank you.
P.S : amazing how fast Michael has produced a fix. Thank you !

Nizar Kerkeni (nizarus) wrote :

You have to do an update on a terminal before using synaptic or any other package manager.
I just done it few minutes later and i have no error message

I think it depends on which mirror you are using...

You might have to wait a few hours for a sync.

Otherwise the fix is confirmed (by myself :))

Thanks mvo,

     chris

On Mon, Feb 25, 2008 at 5:54 PM, A. Broustet <email address hidden> wrote:
> I still get the error when using synaptic with language set to french (the workaround lang=C works). How do I apply / get the fix ?
> Thank you.
> P.S : amazing how fast Michael has produced a fix. Thank you !
>
> --
> Encountered a section with no Package: header
> https://bugs.launchpad.net/bugs/194436
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Ma vie |
Mes recettes | http://www.reponses.net
Mes images |

Try this: sudo aptitude update

Arend (de-bont-andreas) wrote :

I updated my Ubuntu from 08.10 upto 09.04 but while updating it went wrong; the update kept hanging a few times, now i can't run the package manager anymore and receive this message;

Could not initialize the package information

An unresolvable problem occurred while initializing the package information.

Please report this bug against the 'update-manager' package and include the following error message:

'E:Encountered a section with no Package: header, E:Problem with MergeList /var/lib/dpkg/status, E:De pakketlijsten of het statusbestand konden of niet ontleed, of niet geopend worden.'

When i start the package manager i receive;

E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/dpkg/status
E: The package lists or status file could not be parsed or opened.
E: _cache->open() failed, please report.

and i want to add/remove this happens;

Failed to check for installed and available applications

This is a major failure of your software management system. Please check for broken packages with synaptic, check the file permissions and correctness of the file '/etc/apt/sources.list' and reload the software information with: 'sudo apt-get update' and 'sudo apt-get install -f'.

help!

Rascal999 (smiles-999) wrote :

I believe this problem occurs when users gateway returns a html page instead of the respective package file. If a check on the file to make sure it's not a html page is done before attempting to use it, the problem could be avoided, or at least made known to the user.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers