No windows hiding with compiz

Bug #106583 reported by Alendit on 2007-04-14
106
This bug affects 1 person
Affects Status Importance Assigned to Milestone
AllTray
Medium
Unassigned
alltray (Ubuntu)
Medium
Unassigned
Nominated for Hardy by Michael B. Trausch
Intrepid
Medium
Unassigned

Bug Description

Rewriting the description per the requirements listed at https://wiki.ubuntu.com/StableReleaseUpdates

AllTray does not interact with windows in “click-mode” when Compiz is the active window manager for the system. In other words, when using Compiz as the window manager, one cannot dock already-running applications to the system tray/notification area by starting AllTray and then clicking on the application's window.

The cause of this issue was lack of special-case handling for Compiz within the AllTray code. Specifically, it would appear that AllTray must treat Compiz one way for one code path, and another way for the other one. The debdiff attached to this bug provides code that does this. There was another fix supplied for this bug previously, but given the fragility of the AllTray code base, it conflicted with another patch and the situation had to be resolved again---which is what this patch does.

TEST CASE:
  * Run Ubuntu Gutsy or Hardy using the available version of AllTray.
  * Install AllTray.
  * Activate Desktop Effects.
  * Start a program (I use gcalctool as my “test” program)
  * Start AllTray with no command line parameters. It will prompt you to click on a window that you want to dock.
  * Click on your test program and find that the thing doesn’t work.

Given the (relative) triviality surrounding the patch, I believe that there is little to no chance of regression potential. This patch has been tested and I have been actively using it in Hardy for some time now, without any functionality removed from the AllTray package or the introduction of any new bugs within it.

A note: This is not a security patch. It is only a bug-fix.

The debdiff attached to this bug is against the currently released version in Hardy (0.69-1ubuntu1). It will result in 0.69-1ubuntu2, which should be uploaded to hardy-proposed as per the https://wiki.ubuntu.com/StableReleaseUpdates page. I will be watching for the upload in -proposed, and monitoring the bugs for AllTray for a minimum period of one week as per the SRU procedures.

I can confirm this bug. I just can click "Cancel". Deactivating "Desktop Effects" all works again.

I can not yet reproduce this bug. Calling e.g. "alltray --show --no-alltray --icon /usr/share/icons/crystalsvg/32x32/apps/evolution.png evolution" gives me a working evolution with all normal clicking options working.

Can you please give more details about which (and how) application you run and maybe if you have tuned something in your xorg.conf. Also running alltray from a command line without forking it to background could be helpfull so you maybe can see error messages.

Thanks in advance.

Changed in alltray:
status: Unconfirmed → Needs Info

There is no problem running Alltray from the command line. The bug happens when using Alltray "visually", when it offers the option of clicking the window you want to tray. When the Desktop Effects are activated, Alltray can not find any window to tray. Running Alltray in debug mode gives no useful info.

Thanks for your comment. I can now confirm this bug. Assigning to ubuntu desktops effects as this seems to be related to it.

Changed in alltray:
assignee: nobody → ubuntu-desktop-effects
status: Needs Info → Confirmed
Dougle (daniel-craig) wrote :

As a short term fix turn off beryl or compiz then setup alltray, then turn it back on, have got "alltray 'evolution' -s" working this way

AZ (m-dev) wrote :

looks like there are two problems hidden as one:
 a) alltray does not detect compiz being similar to metacity
 b) alltray cannot find a sub window and therefore rejects minimizing.

This fixs adds explicitly the compiz manager as a special case of the gnome window manager.
Additionally, it skips the window_id != window_id_xmu check in src/clickmode.c if compiz is used.
This works fine for me.

Please find a unified diff attached.

Travis Watkins (amaranth) wrote :

To get your fix included in Ubuntu, it would help if you tried transforming it into a debdiff (http://wiki.ubuntu.com/PackagingGuide/Recipes/Debdiff) and submit it for review (http://wiki.ubuntu.com/SponsorshipProcess). If you prefer somebody else to do that, that's fine - please just indicate if you're available to do that.

Changed in alltray:
assignee: ubuntu-desktop-effects → nobody
AZ (m-dev) wrote :

Here comes my debdiff.
I'm not sure what to do to make it get reviewed.

crjackson (crjackson) wrote :

Okay, what am I missing here. I've downloaded the debdiff package, not how do I use this to patch my existing install?

David Rahrer (david-rahrer) wrote :

FWIW, I applied the diffdeb patch to the stock Gutsy 32 version of Alltray and installed. It has been working perfectly in the same environment that the other did not, i.e. compiz. Thank you so much AZ, I'm glad to see this might get into the repository for the next release. For those interested, the copy I made is attached to my post in the Ubuntu Forum thread about this issue:

http://ubuntuforums.org/showthread.php?p=4442489#post4442489

I've also attached it to this comment (Gutsy 32 only)

I'll report if I find any problems.

David Rahrer (david-rahrer) wrote :

Drat, my bad. Somehow compiz got disabled while I was working with this and that's why it appeared to be working correctly. Please disregard my post and attachment above, it doesn't work either. I don't know if I applied the debdiff incorrectly, or if it just doesn't work. I will try the diff against the source and see. Sorry...

AZ (m-dev) wrote :

Maybe you want to test this precompiled package if you don't consider this being to dangerous for your system?

It works perfectly (tested with firefox and thunderbird) on my system (Gutsy32) and I verified that compiz is running. It just does not maximize the window on resuming but leaves it in the panel, though this has already be reported as Bug #128683 .

Subscribed Ubuntu Sponsors for Universe for review.

David Rahrer (david-rahrer) wrote :

AZ, I installed it but I'm afraid it did the same thing as the old version. When I target the window boarder, the app (Evolution in this case but I also tried just a Nautilus file window) goes away and a weird icon shows up in the menu bar (never seen it before, looks like a generic app window). When I left click on the icon nothing happens, and when I right click and select close it goes away, shutting down the app and disabling compiz (something I noticed before). I have to go back to the Appearance applet to turn effects back on. If I try to boot up with the startup script as suggested on the older version of Alltray, the app never starts - you can't tell it is even set to start.

For now I've reinstalled the stock Gutsy version and disabled effects. Having Evolution in the tray all the time is more important to me than the effects, though I would like to have a choice. Alltray is one of those apps that is not big and bold, but you really get used to having it around ;) I'll be happy to try another version, or try to debug if you tell me what you need.

Thanks for the effort.

AZ (m-dev) wrote :

Hi David, thanks a lot for your quick testing. I've started evolution here and got the following results: as long as I click into the evolution window, it works as expected. But if I click at the window title, it does not work. Can you confirm this?

I tried to examine the situation with xwininfo -all, which recursivly prints all child windows and gives a hint about the parent window starting at the window clicked at. But xwininfo could not find a named window (=a window that reported a title) below if i clicked on the window title, while the parent window has been reported as the root window.
I'm starting to consider that this might be a bug in compiz.

AZ (m-dev) wrote :

(or has something to do with wrapping windows for desktop effects.)

Travis Watkins (amaranth) wrote :

Compiz does not reparent windows to add the window borders, they are completely separate windows. I believe compiz is the only WM that works like this although it is completely valid to do.

Siegfried Gevatter (rainct) wrote :

I'm unsubscribing ubuntu-universe-sponsors as I can't find anything to review... The author of the last (and only) attached debdiff indicated that it doesn't work.

David Rahrer (david-rahrer) wrote :

Sorry for the delay. Using AZ's deb, I tried selecting a section of the Evolution window and not the border, and indeed it seemed to work. However, there are some problems. First, and minor, when clicking on the close button on Evolution after using Alltray with it, it closes. Normally, it would just minimize to the tray. Second, and more troublesome, after a couple of times accessing Evolution, it no longer leaves the bottom bar when minimized to the tray. To reproduce, click on the Evolution icon in the tray (ala Alltray), then minimize back to the tray. Do this a few times and you should see Evolution now shows up in the task bar as any other program would. At first it is not there, as it should not be.

Perhaps the most sever issue was starting it from a script at boot. Using the same basic script suggested by the Alltray author, I set it to start up with the session through the sessions feature in preferences. When I reboot, the system would not boot. I can't remember exactly where it stopped, but I'm sure it was when the script was called. IT just stayed blank and I had to boot into the repair mode to rename the script so it would not load in order to use the system again.

So, I would say there are definitely still issues. The original author told me he thought he knew what the problem was when I contacted him, but he was clear about not having time to deal with it. You might email him and see if he can point you to something you didn't think of? Just a thought, thanks for the work on this. I'll monitor this thread for any more developments. Until then, I've turned off compiz just to get the Alltray functionality back. I really like having Evolution running that way, seems a feature missing from it actually.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alltray - 0.69-1ubuntu1

---------------
alltray (0.69-1ubuntu1) hardy; urgency=low

  [ Michael B. Trausch ]
  * Work around issues with Compiz window manager and display of
    window titles (LP: #178541)
  * Modify Maintainer value to match the DebianMaintainerField
    specification.
  * Add dpatch to build-depends in debian/control.
  * Modify debian/rules to use dpatch.
  * Modify alltray.desktop comment to be more descriptive and thus useful.

  [ Daniel Hahler ]
  * Fix "No windows hiding with compiz" (LP: #106583)
    - 02-fix-compiz-windows-select.dpatch, provided by "AZ"
    - There are still issues with compiz and alltray, but this patch makes it
      better
  * debian/control:
    - Standards-Version 3.7.3
    - Moved Homepage from desc to field
  * debian/rules:
    - Fix debian-rules-ignores-make-clean-error (lintian)

 -- Daniel Hahler <email address hidden> Sat, 22 Mar 2008 00:26:48 +0100

Changed in alltray:
status: Confirmed → Fix Released
Mackenzie Morgan (maco.m) wrote :

It's broken worse now. Apps that are started using Alltray from the command line will not show/hide (it can't be toggled) with Compiz. After switching from Compiz to Metacity and back it works.

Bernhard Gehl (bernhard-gehl) wrote :

Sadly I can confirm Mackenzie Morgan's findings. With version 0.69-1ubuntu1, alltray has become fairly unusable with compiz:

- clicking the "minimize" button of the gtk-window decorator results in no reaction (not even a debug message)
- clicking the "close" button of the gtk-window decorator closes the application instead of minimizing it to dock (debug: "gnome unmap notify", "gnome destroy notify", "destroy_al_and_exit", "child already dead")
- manually selecting "hide" from the context menu of the tray icon gives no reaction (comparable to the result when clicking the "minimize" button.

Michael B. Trausch (mtrausch) wrote :

Assigning to me, as I have discovered the root cause, and will be submitting a diff shortly.

Changed in alltray:
assignee: nobody → mtrausch
status: Fix Released → Confirmed
Michael B. Trausch (mtrausch) wrote :

Please test the version I have in my PPA.

You can add the PPA and apt-get upgrade to the version by adding the following lines to a new file, /etc/apt/mbt-ppa.sources.list:

deb http://ppa.launchpad.net/mtrausch/ubuntu hardy main
deb-src http://ppa.launchpad.net/mtrausch/ubuntu hardy main

If you do not want to do that, you can install it directly by running the following:

For i386:
$ wget http://ppa.launchpad.net/mtrausch/ubuntu/pool/main/a/alltray/alltray_0.69-1ubuntu2~ppa0_i386.deb
$ gdebi alltray_0.69-1ubuntu2~ppa0_i386.deb

For amd64:
$ wget http://ppa.launchpad.net/mtrausch/ubuntu/pool/main/a/alltray/alltray_0.69-1ubuntu2~ppa0_amd64.deb
$ gdebi alltray_0.69-1ubuntu2~ppa0_amd64.deb

Once I get two positive reviews of this package, I will upload a debdiff and request that this be included in Hardy.

Michael B. Trausch (mtrausch) wrote :

It would appear that there is another issue... Am pulling the builds from the PPA, and will have another build coming (hopefully soon).

Michael B. Trausch (mtrausch) wrote :

A new build has just been kicked off in my PPA; testing of that (when it's finished and uploaded, ETA about 30 minutes) would be appreciated.

David Rahrer (david-rahrer) wrote :

I'm not ignoring you, I just don't have Hardy installed on anything but a vbox image and that (at least on mine) doesn't support compiz so I can't really test this yet :(

I'm very glad to hear you found the root of the issue, hope it works. This is a very handy tool.

  • unnamed Edit (189 bytes, application/pgp-signature; name=signature.asc)

On Wed, 2008-04-09 at 03:56 +0000, Michael B. Trausch wrote:
> A new build has just been kicked off in my PPA; testing of that (when
> it's finished and uploaded, ETA about 30 minutes) would be appreciated.

It seems to be working fairly well. The first thing I tried it on was
Cycle, though, and that's a program that first starts as a login window
and when you login, that window closes and a new one is spawned. The
child window is not captured by Alltray. As far as this bug is
concerned though, your PPA version seems to fix it.

--
Mackenzie Morgan
http://ubuntulinuxtipstricks.blogspot.com
apt-get moo

AZ (m-dev) wrote :

Sry, I'd like to test it but http://ppa.launchpad.net/mtrausch/ubuntu/pool/main/a/alltray/alltray_0.69-1ubuntu2~ppa0_i386.deb does not exists (HTTP 404 Not Found).

Michael B. Trausch (mtrausch) wrote :

There was a problem with the ppa0 build... I have released a ppa1 build to replace it. Just change ppa0 to ppa1 if you want to download the package directly, or you can go to the PPA page at https://edge.launchpad.net/~mtrausch/+archive and download a binary .deb from the alltray section near the bottom.

Michael B. Trausch (mtrausch) wrote :
  • unnamed Edit (189 bytes, application/pgp-signature; name=signature.asc)

On Wed, 2008-04-09 at 05:17 +0000, Mackenzie Morgan wrote:
> It seems to be working fairly well. The first thing I tried it on was
> Cycle, though, and that's a program that first starts as a login
> window and when you login, that window closes and a new one is
> spawned. The child window is not captured by Alltray. As far as this
> bug is concerned though, your PPA version seems to fix it.

Yeah, that's probably one case where Alltray could use some improvement.
There's actually a lot of room for improvement in Alltray (particularly
with things like command line option parsing), I have noticed in working
with it on this and one other bug. I might wind up doing that, assuming
that I have the time to do so. I've started a bzr repo locally to work
on it, though I've not done much in the way of substance with it yet.

 --- Mike

--
Michael B. Trausch <email address hidden>
home: 404-592-5746, 1 www.trausch.us
cell: 678-522-7934 im: <email address hidden>, jabber
Ubuntu Unofficial Backports Project: http://backports.trausch.us/

Michael B. Trausch (mtrausch) wrote :

Attaching the debdiff for the fix. The debdiff stats are:

 changelog | 11 +++++
 patches/02-fix-compiz-windows-select.dpatch | 57 ++++++++++++++++++++++------
 rules | 10 ----
 3 files changed, 58 insertions(+), 20 deletions(-)

Will be following up (as soon as I know what procedures to follow) to get these changes moved to Debian, as well.

Michael B. Trausch (mtrausch) wrote :

Any chance this patch can be reviewed for inclusion into Hardy? The problem that it fixes is somewhat extreme, and (to be completely honest) I'd like to maintain as few fixes for Hardy unofficially as possible. :-)

AZ (m-dev) wrote :

I'm proposing to change the dpatch >= 2.0.28 build dependency into dpatch >= 2.0.25 in order to enable compilation for gutsy. It works for me.

AZ (m-dev) wrote :

I've just compiled and installed alltray ppa1 for gutsy and it does not work for me if i click on the window title. There is still this weird icon in the systray which does not interact with the acutal window. I tried using thunderbird and firefox.

Michael B. Trausch (mtrausch) wrote :
  • unnamed Edit (2.0 KiB, text/html; charset=utf-8)
  • unnamed Edit (189 bytes, application/pgp-signature; name=signature.asc)

On Sat, 2008-04-19 at 12:09 +0000, AZ wrote:

> I've just compiled and installed alltray ppa1 for gutsy and it does
> not
> work for me if i click on the window title. There is still this weird
> icon in the systray which does not interact with the acutal window. I
> tried using thunderbird and firefox.

Alright... There have been been a number of changes to compiz between
Gutsy and Hardy. I am not sure if it's going to be possible to make it
work under both distributions without more truly ugly hacking. The code
base for AllTray really needs a lot of re-working so that the handling
of different window managers can be done modularly, to be honest.

    — Mike

--
Michael B. Trausch <email address hidden>
home: 404-592-5746, 1 www.trausch.us
cell: 678-522-7934 im: <email address hidden>, jabber
Ubuntu Unofficial Backports Project: http://backports.trausch.us/

Michael B. Trausch (mtrausch) wrote :

Unassigning because there is a fix available in my PPA, which needs reviewed. Debdiff is also available.

Changed in alltray:
assignee: mtrausch → nobody
Kjell Braden (afflux) on 2008-04-28
Changed in alltray:
importance: Undecided → Medium
description: updated
midnightflash (midnightflash) wrote :

Your version is working fine for me.

Michael B. Trausch (mtrausch) wrote :

The Intrepid Ibex is open now, so can the sponsors upload this to Intrepid so as to facilitate getting it into Ubuntu 8.04.1, as well? The patch on comment 32 should be used against the AllTray version currently published in Hardy, to create the new version for Hardy 8.04.1 and Intrepid.

Michael B. Trausch (mtrausch) wrote :

Comment 32 did not autolink like I thought it would—https://bugs.edge.launchpad.net/ubuntu/+source/alltray/+bug/106583/comments/32 (to make it more convenient)

AZ (m-dev) wrote :

I installed hardy but regarding comments 35 / 36 it still does not work if i click on the window title.
If I attach an app to alltray while it is already running - in contrast to starting alltray with the app as a parameter - clicking on the minimize/close button in the window title bar results in minimizing/closing the window instead of hiding the window.

Michael B. Trausch (mtrausch) wrote :

On Wed, 2008-05-07 at 17:17 +0000, AZ wrote:
> I installed hardy but regarding comments 35 / 36 it still does not
> work if i click on the window title.
> If I attach an app to alltray while it is already running - in
> contrast to starting alltray with the app as a parameter - clicking on
> the minimize/close button in the window title bar results in
> minimizing/closing the window instead of hiding the window.

The window title part is known, and I haven't found the source of that
issue yet.

The not catching the minimize/close button, though, that's kind of an
issue. :) This is under compiz in Hardy? Are you using emerald or
gtk-window-decorator?

 --- Mike

--
Michael B. Trausch <email address hidden>
home: 404-592-5746, 1 www.trausch.us
cell: 678-522-7934 im: <email address hidden>, jabber
Ubuntu Unofficial Backports Project: http://backports.trausch.us/

Joel Oliver (joelol75) wrote :

I just wanted to thank you for fixing this porgram. My upgrade to Hardy broke this and it is really a needed app! My results ranged from the app just opening once and disappearing after that to working only if the avant dock was not. Compiz was used in both cases and your update fixed all my problems. Thanks again!

Andrea Colangelo (warp10) wrote :

Unsubscribing u-u-s, since no debdiff for Intrepid is attached here.

Michael B. Trausch (mtrausch) wrote :

@Andrea: Do you require one to be? The fix is the same, and there would be no need to update it other than to change the changelog to say intrepid. Sorry for the lag on the response for this one, I am out of town at the moment and have not had occasion to get with my mail until now.

AZ (m-dev) wrote :

> The not catching the minimize/close button, though, that's kind of an
> issue. :) This is under compiz in Hardy? Are you using emerald or
> gtk-window-decorator?
I'm using gtk-window-decorator.

FYI, your private .deb fixed bug 234666 for me. However, I can also confirm AZ's findings regarding the title bar bug and the lack of minimize/close catching. I am running compiz with gtk-window-decorator in pure up-to-date Hardy.

Note that the minimize/close thing is not a regression. It was the same for me in 0.69-1ubuntu1.

Kjell Braden (afflux) wrote :

resubscribing ubuntu-universe-sponsors as the debdiff in [1] still applies for intrepid.

[1] https://bugs.edge.launchpad.net/ubuntu/+source/alltray/+bug/106583/comments/32

Hi ! I have installed http://ppa.launchpad.net/mtrausch/ubuntu/pool/main/a/alltray/alltray_0.69-1ubuntu2~ppa1_i386.deb and it seems to work perfectly for me (Hardy without Compiz).

Thank you very very much.

Michael B. Trausch (mtrausch) wrote :

Sorry about not having been keeping a very close eye on this; I had to travel out of town for a week, and my Internet access was somewhat sporadic at best.

It seems that the PPA build and the debdiff associated with it (which were originally submitted to LP before Hardy was released) are working well for everyone. I am still trying to figure out some of the other issues, which really probably need their own bugs if they do not already have them. Tomorrow (that is, June 3), I am going to go through LP and try to get all of the Alltray bugs (assuming there are more than a few) sorted and try to figure out if the other issues (such as the misc. title bar/close button grabbing issue) are reported elsewhere.

Upstream has abandoned the package, unfortunately. I am of the opinion that it probably needs to be massively refactored (e.g., rewritten) such that it can be better behaved and less sensitive to code changes. Nothing I haven't said before. Anyway, I am very happy that the PPA build is working well.

@Kjell, thanks for re-subscribing UUS; I did not want to do that again myself without some sort of additional feedback.

Luca Falavigna (dktrkranz) wrote :

Travis, Daniel: could you please have a look?

Travis Watkins (amaranth) wrote :

It would be more appropriate to get this fix into intrepid (you have to do that first anyway) and just do a backport.

jan_k (wobble-gmx) wrote :

I'd like to confirm that alltray_0.69-1ubuntu2~ppa1_i386.deb fixed the problems for the most part.

However, on hardy, trying to place streamtuner into the tray-bar by pin-pointing the window, places some icon (not the streamtuner one) into the traybar. Attempting to close the window through this icon crashes compiz and the desktop falls-back to the 'non-compiz mode'.

James Westby (james-w) wrote :

Hi,

I just uploaded the patch to Intrepid. Please test if you are
running Intrepid.

The package seems quite buggy to me, but this change at least
fixes one bug.

The program is not maintained upstream anymore, I would encourage
anyone that uses this program and has the requisite skills to take
over maintainence, otherwise the program will be less and less usable
over time.

Also, the bug tracker is closed upstream, so I was unable to forward
the patch.

Please work with motu-sru to get this fixed for hardy if you wish to have
the fix there.

Thanks,

James

Changed in alltray:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alltray - 0.69-1ubuntu2

---------------
alltray (0.69-1ubuntu2) intrepid; urgency=low

  * Only reparent with Compiz running when not in click_mode, so as to
    enable running alltray to dock an already-running application on
    the system. (LP: #106583)
  * debian/rules: Remove optimization from the compiled binary entirely,
    which appears to create side effects in the code, including an
    infinite loop condition that does not occur without optimization.

 -- <email address hidden> (Michael B. Trausch) Wed, 09 Apr 2008 21:06:56 -0400

Changed in alltray:
status: Fix Committed → Fix Released
vlc (vlc) wrote :

The deb package seems to have disappeared. I neither can download it using "wget http://ppa.launchpad.net/mtrausch/ubuntu/pool/main/a/alltray/alltray_0.69-1ubuntu2~ppa1_i386.deb" (returns "ERROR 404: Not Found") nor find it in https://edge.launchpad.net/~mtrausch/+archive.

Is there still a way to download this package?

Michael B. Trausch (mtrausch) wrote :

On Thu, 16 Oct 2008 14:27:40 -0000
vlc <email address hidden> wrote:

> The deb package seems to have disappeared. I neither can download it
> using "wget
> http://ppa.launchpad.net/mtrausch/ubuntu/pool/main/a/alltray/alltray_0.69-1ubuntu2~ppa1_i386.deb"
> (returns "ERROR 404: Not Found") nor find it in
> https://edge.launchpad.net/~mtrausch/+archive.
>
> Is there still a way to download this package?

Ack!

Somehow I managed to accidently delete it when I was removing some
other things that I put in there for testing.

The package will be back there within the next 24 hours.

 --- Mike

--
My sigfile ran away and is on hiatus.

Hicham HAOUARI (funnylife-ma) wrote :

I confirm that this bug is still existing on Intrepid.

Mackenzie Morgan (maco.m) wrote :

How about Intrepid, since that's the development version?

Michael B. Trausch (mtrausch) wrote :

On Wed, 18 Feb 2009 20:57:14 -0000
Mackenzie Morgan <email address hidden> wrote:

> How about Intrepid, since that's the development version?

It'll still be in Jaunty, though I may be able to have a new release
available before Jaunty+1. I am currently doing a lot of work to
AllTray in order to make it easier to work with and hopefully less
sensitive to code changes in the future.

 --- Mike

--
My sigfile ran away and is on hiatus.
http://www.trausch.us/

Mackenzie Morgan (maco.m) wrote :

Thank you for understanding my question, since I fail at remembering what I'm
typing halfway through my sentences.

Michael B. Trausch (mtrausch) wrote :

For whatever reason, this was never re-opened. Essentially, one case was fixed, and others apparently were/are still lingering on this issue. Am opening this bug against AllTray itself, since its bugs are now being tracked here at LP.

Changed in alltray:
importance: Undecided → Medium
milestone: none → alltray-0.8.0
status: New → Confirmed

The bug still alive for me on amd64 version of intrepid ibex.
Someone knows how fix this "with our own hands" ?
thanks

Michael B. Trausch (mtrausch) wrote :

If someone is able and willing to test 0.7.2dev to see if this new line of development for AllTray addresses this bug, I'd greatly appreciate some feedback. This new version is *not* suitable for most people to use on an every-day basis, so I don't recommend fully installing it on your system yet. However, it would be helpful to know if anyone else considers this bug addressed in this new development series.

Download information: https://edge.launchpad.net/alltray/trunk/0.7.1dev

Michael B. Trausch (mtrausch) wrote :

A fix for this is in the development tree which will become 0.8.0 later this year.

Changed in alltray:
status: Confirmed → Fix Committed
Juan Simón (simonbcn) wrote :

"Fix Committed", and when it will release?

mtf (mtf022004) wrote :

The deb package for Hardy seems to be still missing.
I neither can download it using "wget http://ppa.launchpad.net/mtrausch/ubuntu/pool/main/a/alltray/alltray_0.69-1ubuntu2~ppa1_i386.deb" (returns "ERROR 404: Not Found") nor find it in https://edge.launchpad.net/~mtrausch/+archive.

Is there still a way to download this very useful package?

Michael B. Trausch (mtrausch) wrote :

I will have a package up for Hardy users in the AllTray PPA...

Just as soon as the servers become responsive again. Happy Jaunty Release Day!

mtf (mtf022004) wrote :

Is there a way to download the deb package for Hardy (very useful package)?
Thanks.

mtf (mtf022004) wrote :

Is there a way to download the deb package for Hardy (very useful package)?
Thanks.

Changed in alltray:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers