seahorse-agent assert failure: ERROR:iop-profiles.c:606:IOP_generate_profiles: assertion failed: (obj && (obj->profile_list == NULL) && obj->orb)

Bug #429322 reported by Juan Sebastián Marulanda on 2009-09-14
This bug affects 1569 people
Affects Status Importance Assigned to Milestone
seahorse-plugins
Confirmed
Medium
seahorse-plugins (Fedora)
Fix Released
Medium
seahorse-plugins (Ubuntu)
High
Unassigned
Karmic
High
darko

Bug Description

Binary package hint: seahorse-plugins

Got this error after starting session.

ProblemType: Crash
Architecture: i386
AssertionMessage: ERROR:iop-profiles.c:606:IOP_generate_profiles: assertion failed: (obj && (obj->profile_list == NULL) && obj->orb)
CheckboxSubmission: b921af5b1a4fc862d51d74bcbde28d88
CheckboxSystem: daed2f3d6643b4a84b4520a2427f8c2b
CrashCounter: 1
Date: Mon Sep 14 06:36:28 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/seahorse-agent
Package: seahorse-plugins 2.27.1-0ubuntu1 [modified: usr/share/applications/seahorse-pgp-encrypted.desktop]
ProcCmdline: /usr/bin/seahorse-agent --execute gnome-session
ProcEnviron:
 LANG=es_CO.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.32-generic-pae
Signal: 6
SourcePackage: seahorse-plugins
StacktraceTop:
 raise () from /lib/libc.so.6
 abort () from /lib/libc.so.6
 g_assertion_message () from /usr/lib/libglib-2.0.so.0
 g_assertion_message_expr () from /usr/lib/libglib-2.0.so.0
 IOP_generate_profiles () from /usr/lib/libORBit-2.so.0
Title: seahorse-agent assert failure: ERROR:iop-profiles.c:606:IOP_generate_profiles: assertion failed: (obj && (obj->profile_list == NULL) && obj->orb)
Uname: Linux 2.6.31-10-generic-pae i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare vboxusers

StacktraceTop:*__GI_raise (sig=6)
*__GI_abort () at abort.c:92
IA__g_assertion_message (domain=0x0,
IA__g_assertion_message_expr (domain=0x0,
IOP_generate_profiles (obj=0x9d22468) at iop-profiles.c:606

Changed in seahorse-plugins (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace

abrt detected a crash.

How to reproduce
-----
1.
2.
3.

Additional information
======

Attached files
----
backtrace

cmdline
-----
/usr/bin/seahorse-agent --variables

component
-----
seahorse-plugins

executable
-----
/usr/bin/seahorse-agent

kernel
-----
2.6.31-23.fc12.x86_64

package
-----
seahorse-plugins-2.27.1-4.fc12

reason
-----
Process was terminated by signal 6

Created attachment 361792
File: backtrace

Brian Curtis (bcurtiswx) on 2009-09-27
visibility: private → public
Changed in seahorse-plugins (Ubuntu):
status: New → Confirmed

*** Bug 525454 has been marked as a duplicate of this bug. ***

Rolando Garza (rolandog) wrote :

Happened to me as well, though I'm using amd64.

Same problem here, using i386

Changed in seahorse-plugins (Fedora):
status: Unknown → Confirmed
Eduard Grebe (eduardgrebe) wrote :

I experience this on karmic beta amd64.

I was using karmic alpha 64bits. I am using the beta version now and its
better, but unstable.

On Thu, Oct 8, 2009 at 3:26 PM, Eduard Grebe <email address hidden> wrote:

> I experience this on karmic beta amd64.
>
> --
> seahorse-agent assert failure:
> ERROR:iop-profiles.c:606:IOP_generate_profiles: assertion failed: (obj &&
> (obj->profile_list == NULL) && obj->orb)
> https://bugs.launchpad.net/bugs/429322
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

sid (siddharthakattoju) on 2009-10-08
Changed in seahorse-plugins (Ubuntu):
assignee: nobody → Seahorse (ceesvanderzee)
Graham F (gandalfmeister) wrote :

karmic beta i386. I had 2 failures - evince failed to open PDF - and then this immediately after starting the bug report for evince. No problems with seahorse prior to todays upgrade (kernal 31.13)

Changed in seahorse-plugins (Ubuntu):
status: Confirmed → Fix Released
digc16 (tribletsurvivor) wrote :

I typed seahors start in terminal is this message normal.

** Message: init gpgme version 1.1.8
WARNING: Unhandled message: interface=org.freedesktop.DBus.Introspectable, path=/, member=Introspect

Tom Pino (metalsmith-rangeweb) wrote :

As far as I know, I was doing nothing that needed seahorse at all.

Beats me.

devinep (devinep2k7) on 2009-10-18
Changed in seahorse-plugins (Ubuntu):
status: Fix Released → Fix Committed
Tormod Volden (tormodvolden) wrote :

Please do not change bug status and other properties if you have no idea how they work.

Changed in seahorse-plugins (Ubuntu):
assignee: Seahorse (ceesvanderzee) → nobody
status: Fix Committed → Confirmed

after watching Hulu desktop?

Jeroen Hoek (mail-jeroenhoek) wrote :

Crash popped up a couple of times fairly directly after logging in. It doesn't seem to be caused by anything I did.

Karmic beta 64-bit, running Firefox.

*** Bug 530356 has been marked as a duplicate of this bug. ***

*** Bug 529773 has been marked as a duplicate of this bug. ***

bodam (londo) wrote :

To echo Jeroen Hoek and others:

Crash popped up a couple of times fairly directly after logging in. It doesn't seem to be caused by anything I did.

Karmic beta 64-bit, running Firefox.

keloha (johan-keloha) wrote :

Karmic beta 64-bit, running firefox.

All though this is the main thread for this bug, I subsequently submit this duplicate that may contain attachments or information that could be helpful:
https://bugs.launchpad.net/ubuntu/+source/seahorse-plugins/+bug/461703

Unfortunately, launch pad won't allow you to submit these types of automated attachments unless you report something as a new bug; if you indicate that you have the same bug as someone else, it doesn't automatically attached the auto-collected (potentially pertinent) info to someone else's (already reported) bug.

Martin Pitt (pitti) on 2009-10-28
Changed in seahorse-plugins (Ubuntu):
importance: Medium → High
Martin Pitt (pitti) wrote :

Robert, this seems to be a very popular crash. Do you happen to see where the problem could be, based on the stack trace? It seems to be related to icon handling?

Changed in seahorse-plugins (Ubuntu Karmic):
assignee: nobody → Robert Ancell (robert-ancell)
Robert Ancell (robert-ancell) wrote :

It appears that the agent is getting an X error during initialisation.

My best guess is the steps are:
1. An X error is received while calling seahorse_gtkstock_init()
2. This triggers seahorse_agent_uninit() to be called as the application exits
3. Somewhere in the uninit (the trace doesn't seem to have worked for this part of the stack) a gconf key is set
4. Which hits an assertion in the orbit layer below gconf, perhaps due to being unable to contact X

If you are getting this problem please look in /var/log/Xorg.0.log for any error messages at the bottom and attach them if you do have this problem. Also please note if the problem always occurs or only on some logins.

I've tried reproducing this on my login and a guest login and I am not getting the problem.

Bryce Harrington (bryce) wrote :

The Xorg.0.log would be interesting to see, however I suspect chances are small that a relevant error message will appear there.

Another debugging technique which might be more fruitful is to use xtrace. Xtrace sits in between the client and X server, and gives you a stream of all the commands going back and forth, so you can see where the communication is failing.

Robert Ancell (robert-ancell) wrote :

Also if you are getting this problem please try the following from a terminal:
$ ps ux|grep seahorse-agent
to confirm if the agent is running after login

  • Xorg.0.log Edit (62.7 KiB, text/x-log; name="Xorg.0.log"; charset="UTF-8")

Hey thanks for the info and suggestions. This is an upgraded system and
not a fresh install if that makes any difference; I'm not sure if that
was mentioned in my bug report. I have run the command listed below and
can confirm that seahorse-agent is not running after login. I have also
attached my Xorg.0.log file.

Zach

On Thu, 2009-10-29 at 00:35 +0000, Robert Ancell wrote:

> Also if you are getting this problem please try the following from a terminal:
> $ ps ux|grep seahorse-agent
> to confirm if the agent is running after login
>

Daniel Holbach (dholbach) wrote :

Could this assert failure also happen on shutdown? I always had the agent running fine, but apport popped up anyway after login.

Anita (a-lewis) wrote :

I got the problem yesterday and submitted a duplicate from apport. On fresh boot and login this morning I get this check on seahorse-agent:

ajlewis2@hopalong:~$ ps ux|grep seahorse-agent
ajlewis2 2189 0.0 0.0 5808 612 ? Ss 06:16 0:00 /usr/bin/ssh-agent /usr/bin/dbus-launch --exit-with-session /usr/bin/pulse-session /usr/bin/seahorse-agent --execute gnome-session
ajlewis2 2192 0.0 0.0 3380 708 ? S 06:16 0:00 /usr/bin/dbus-launch --exit-with-session /usr/bin/pulse-session /usr/bin/seahorse-agent --execute gnome-session
ajlewis2 2212 0.0 0.6 19812 6196 ? Ss 06:16 0:00 /usr/bin/seahorse-agent --execute gnome-session

*** Bug 530616 has been marked as a duplicate of this bug. ***

*** Bug 531038 has been marked as a duplicate of this bug. ***

Damian Yerrick (tepples) wrote :

Karmic, upgraded from Jaunty on an Eee PC 900 (with 32 GB SSD), and I got the crash report this morning on a fresh boot. The system is set to skip the password screen, if it matters.

In answer to your question....

see attachment

Op donderdag 29-10-2009 om 00:35 uur [tijdzone +0000], schreef Robert
Ancell:
> Also if you are getting this problem please try the following from a terminal:
> $ ps ux|grep seahorse-agent
> to confirm if the agent is running after login
>

Roc.am (roc-am) wrote :

Forget my previousmail, did something wrong.

See attachment

Op donderdag 29-10-2009 om 00:35 uur [tijdzone +0000], schreef Robert
Ancell:
> Also if you are getting this problem please try the following from a terminal:
> $ ps ux|grep seahorse-agent
> to confirm if the agent is running after login
>

Danvil (davidw) wrote :

I have update 9.04 -> 9.10.
On ervery login there appeares this little crash icon in the panel, saying that seahorse-agent has a problem.

ps ux|grep seahorse-agent:
david 1923 0.0 0.0 4916 608 ? Ss 10:33 0:00 /usr/bin/ssh-agent /usr/bin/dbus-launch --exit-with-session /usr/bin/pulse-session /usr/bin/seahorse-agent --execute gnome-session
david 1926 0.0 0.0 3380 704 ? S 10:33 0:00 /usr/bin/dbus-launch --exit-with-session /usr/bin/pulse-session /usr/bin/seahorse-agent --execute gnome-session
david 1947 0.0 0.1 19912 6072 ? Ss 10:33 0:00 /usr/bin/seahorse-agent --execute gnome-session
david 2424 0.0 0.0 3048 796 pts/0 S+ 10:52 0:00 grep seahorse-agent

/var/log/Xorg.0.log in attatchment (but I don't see any errors there)

Chris Coulson (chrisccoulson) wrote :

Daniel is right - this crash is happening on shutdown, and it happens when the X connection dies. This is easily reproducible by running "xtrace -k -d:0 -D:9" in one terminal, and then running "DISPLAY=:9.0 seahorse-agent" in another. If you kill xtrace, then seahorse-agent crashes every time.

The new version crashes because seahorse-agent calls "atexit (seahorse_agent_exit);" when it initializes, which registers a handler to run when exit() is called (such as, when Xorg dies!). The handler is obviously doing something which it shouldn't be doing when there is no X connection anymore.

That's the next step for debugging...

Chris Coulson (chrisccoulson) wrote :

Incidentally, I have a more complete backtrace

Danvil (davidw) wrote :

I had this bug a few times. Now it happens no more without changing anything special.

Chris Coulson (chrisccoulson) wrote :

It probably happens no more because Apport is disabled in the stable release, so you won't see any crash reports

Thank you so much "Danvil"!
Even I didn't get that error again as you mentioned! Thank you very much for
your kind attention! I really appreciate that!

Thanks!!!!

On Wed, Nov 4, 2009 at 4:05 PM, Danvil <email address hidden> wrote:

> I had this bug a few times. Now it happens no more without changing
> anything special.
>
> --
> seahorse-agent assert failure:
> ERROR:iop-profiles.c:606:IOP_generate_profiles: assertion failed: (obj &&
> (obj->profile_list == NULL) && obj->orb)
> https://bugs.launchpad.net/bugs/429322
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Renato Golin (rengolin) wrote :

Fixed here too, thanks! My new upgrades were not affected too. All fine.

Chris Coulson (chrisccoulson) wrote :

This bug is still present and nobody has fixed it. Your comments are misleading. Like I said, users aren't seeing crash reports any more because Apport is disabled, but the bug is still there.

Renato Golin (rengolin) wrote :

2009/11/4 Chris Coulson <email address hidden>:
> This bug is still present and nobody has fixed it. Your comments are
> misleading. Like I said, users aren't seeing crash reports any more
> because Apport is disabled, but the bug is still there.

You have hundreds of similar reports and the "problem" users were
seeing IS fixed. The underlying problem, though, is NOT fixed, but
that's a different matter entirely.

How you deal with the bug system is up to you, but as soon as you
start asking users NOT to reply you get them not to report problems
again, which is not what you intend, I believe.

I'd suggest you close this defect and open another one, with this as
x-ref and describe better what the underlying problem is and how to
reproduce it. Will make your life much easier and not scare users
away.

My 2 cents.

cheers,
--renato

Chris Coulson (chrisccoulson) wrote :

I've done some investigating of this, and this is what I think is happening:

- When seahorse-agent starts, various exit handlers are registered with atexit(). These handlers are registered in the following order: seahorse_agent_exit() [seahorse-plugins/agent/seahorse-agent.c], shutdown_orb() [orbit2/src/orb/orb-core/corba-orb.c], global_client_free() [seahorse-plugins/libseahorse/seahorse-gconf.c]

- When the X connection dies, exit() is called, which causes the exit handlers to be called in reverse order.

- global_client_free() free's the global GConfClient in seahorse-plugins/libseahorse/seahorse-gconf.c
- shutdown_orb() closes the socket
- seahorse_agent_exit() removes some gconf notifies. However, because the global GConfClient was free'd earlier, a new one is created in get_global_client(). In addition to this, gconf_client_add_dir() is invoked again (which happened already when seahorse-agent originally started). Normally, this would trigger a call to CORBA_ORB_init(), which would undo what happened in shutdown_orb(). However, because gconf thinks it is already initialized (check out gconf_get_config_listener in gconf.c - the ConfigListener "listener" already exists), this doesn't get called again, leading to the assertion later on

Robert Ancell (robert-ancell) wrote :

Pushed a patch to lp:~robert-ancell/seahorse-plugins/bug-429322 with a candidate patch as a SRU proposal.

However, I'm not sure if this patch is useful because:
- None of the bug reports seem to be indicating this crash is causing any problems. The diagnosis and reproduction by Chris only shows it occurring at shutdown (presumably after any useful shutdown actions have occurred).
- Users of Karmic final will not have apport enabled and therefore not see this report

The biggest problem seems to be Launchpad and Apport spamming everyone when a duplicate is detected.

Subscribed main sponsors to see what they think.

Changed in seahorse-plugins (Ubuntu):
assignee: Robert Ancell (robert-ancell) → nobody
Changed in seahorse-plugins (Ubuntu Karmic):
assignee: Robert Ancell (robert-ancell) → nobody

*** Bug 531713 has been marked as a duplicate of this bug. ***

seahorse-plugins-2.28.1-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/seahorse-plugins-2.28.1-2.fc12

seahorse-plugins-2.28.1-2.fc12 has been pushed to the Fedora 12 testing repository. If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with
 su -c 'yum --enablerepo=updates-testing update seahorse-plugins'. You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-11348

Changed in seahorse-plugins (Fedora):
status: Confirmed → Fix Committed

Direct link to unsubscribe. Page itself timeouts, and it's impossible
to click the button.

https://bugs.launchpad.net/ubuntu/+source/seahorse-plugins/+bug/429322/+subscribe

--
anatoly t.

On Sun, Nov 15, 2009 at 5:53 AM, Apport retracing service
<email address hidden> wrote:
> *** This bug is a duplicate of bug 429322 ***
>    https://bugs.launchpad.net/bugs/429322
>
> Thank you for taking the time to report this crash and helping to make
> Ubuntu better.  This particular crash has already been reported and is a
> duplicate of bug #429322, so is being marked as such.  Please look at
> the other bug report to see if there is any missing information that you
> can provide, or to see if there is a workaround for the bug.
> Additionally, any further discussion regarding the bug should occur in
> the other report.  Please continue to report any other bugs you may
> find.
>
> ** Attachment removed: "CoreDump.gz"
>   http://launchpadlibrarian.net/34781740/CoreDump.gz
>
> ** Attachment removed: "Dependencies.txt"
>   http://launchpadlibrarian.net/34781744/Dependencies.txt
>
> ** Attachment removed: "Disassembly.txt"
>   http://launchpadlibrarian.net/34781745/Disassembly.txt
>
> ** Attachment removed: "ProcMaps.txt"
>   http://launchpadlibrarian.net/34781746/ProcMaps.txt
>
> ** Attachment removed: "ProcStatus.txt"
>   http://launchpadlibrarian.net/34781747/ProcStatus.txt
>
> ** Attachment removed: "Registers.txt"
>   http://launchpadlibrarian.net/34781748/Registers.txt
>
> ** Attachment removed: "Stacktrace.txt"
>   http://launchpadlibrarian.net/34781750/Stacktrace.txt
>
> ** Attachment removed: "ThreadStacktrace.txt"
>   http://launchpadlibrarian.net/34781751/ThreadStacktrace.txt
>
> ** This bug has been marked a duplicate of bug 429322
>   seahorse-agent assert failure: ERROR:iop-profiles.c:606:IOP_generate_profiles: assertion failed: (obj && (obj->profile_list == NULL) && obj->orb)
>
> ** Visibility changed to: Public
>
> ** Tags removed: need-i386-retrace
>
> --
> LMMS .4.5
> https://bugs.launchpad.net/bugs/466773
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (via bug 429322).
>

No, the solution is not to unsubscribe from Bug #429322. Probably, you
are not even subscribed to that bug. If you are receiving all these
e-mail notifications, it's because you are subscribed to *another* bug.
To one that is a duplicate of Bug #429322.

Which bug is that? Well, the one (or ones) that you reported yourself.
How to unsubscribe, then?

1.- Go to the web:
https://launchpad.net/

2.- If you're not logged in, use the link on the upper right corner to
log in.

3.- Click your own user name in the upper right corner to go your
personal Launchpad page.

4.- In the column titled "Participation" (on the right) click on "Bugs".

5.- Click on "Advanced Search" under the search textbox. Scroll down and
unmark the option "Hide duplicate bugs". Then click "Search".

6.- Look for the bug(s) you reported yourself. If you didn't change the
summary while reporting, it should say "seahorse-agent...". But it may
be different. In any case, it shouldn't be very difficult to find.
(Hint: look for the bugs with the greater bug number.)

7.- Click on the bug to open it, then click "Unsubscribe" on the right
column.

Regards.

anatoly techtonik escribió:
> Direct link to unsubscribe. Page itself timeouts, and it's impossible
> to click the button.
>
> https://bugs.launchpad.net/ubuntu/+source/seahorse-
> plugins/+bug/429322/+subscribe
>
>

herb (schmid-herbert) wrote :

Thank you! I think I did stop this spam now!!!

Am Sonntag, den 15.11.2009, 09:33 +0000 schrieb Paco Soberón:
> No, the solution is not to unsubscribe from Bug #429322. Probably, you
> are not even subscribed to that bug. If you are receiving all these
> e-mail notifications, it's because you are subscribed to *another* bug.
> To one that is a duplicate of Bug #429322.
>
> Which bug is that? Well, the one (or ones) that you reported yourself.
> How to unsubscribe, then?
>
> 1.- Go to the web:
> https://launchpad.net/
>
> 2.- If you're not logged in, use the link on the upper right corner to
> log in.
>
> 3.- Click your own user name in the upper right corner to go your
> personal Launchpad page.
>
> 4.- In the column titled "Participation" (on the right) click on "Bugs".
>
> 5.- Click on "Advanced Search" under the search textbox. Scroll down and
> unmark the option "Hide duplicate bugs". Then click "Search".
>
> 6.- Look for the bug(s) you reported yourself. If you didn't change the
> summary while reporting, it should say "seahorse-agent...". But it may
> be different. In any case, it shouldn't be very difficult to find.
> (Hint: look for the bugs with the greater bug number.)
>
> 7.- Click on the bug to open it, then click "Unsubscribe" on the right
> column.
>
> Regards.
>
>
> anatoly techtonik escribió:
> > Direct link to unsubscribe. Page itself timeouts, and it's impossible
> > to click the button.
> >
> > https://bugs.launchpad.net/ubuntu/+source/seahorse-
> > plugins/+bug/429322/+subscribe
> >
> >
>

Paul Sladen (sladen) wrote :

An update; for those wondering:

02:26 < intellectronica> sladen: subscriptions to duplicates nuked. this will continue to be a problem as new dupes and subscriptions are created all the time, but i hope it will make things manageable until we come up with a longer-term solution tomorrow

which has the handy side-effect of allowing this bug report to load again!

seahorse-plugins-2.28.1-2.fc12 has been pushed to the Fedora 12 stable repository. If problems still persist, please make note of it in this bug report.

Changed in seahorse-plugins (Fedora):
status: Fix Committed → Fix Released
darko (darko) on 2009-11-16
Changed in seahorse-plugins (Ubuntu):
assignee: nobody → darko (darko)
Changed in seahorse-plugins (Ubuntu Karmic):
assignee: nobody → darko (darko)
darko (darko) on 2009-11-19
Changed in seahorse-plugins (Ubuntu):
assignee: darko (darko) → nobody
status: Confirmed → Invalid
darko (darko) on 2009-11-19
Changed in seahorse-plugins (Ubuntu):
assignee: nobody → darko (darko)
status: Invalid → Confirmed
darko (darko) on 2009-11-20
Changed in seahorse-plugins (Ubuntu):
status: Confirmed → Fix Committed
status: Fix Committed → In Progress
darko (darko) on 2009-11-21
description: updated
Changed in seahorse-plugins (Ubuntu):
status: In Progress → Fix Committed
darko (darko) on 2009-11-24
Changed in seahorse-plugins (Ubuntu):
status: Fix Committed → Fix Released
digc16 (tribletsurvivor) on 2009-12-02
affects: seahorse-plugins (Ubuntu) → grub (Ubuntu)
Steve Langasek (vorlon) wrote :

Please stop messing with the state of this bug.

affects: grub (Ubuntu) → seahorse-plugins (Ubuntu)
Changed in seahorse-plugins (Ubuntu):
assignee: darko (darko) → nobody
status: Fix Released → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package seahorse-plugins - 2.28.1-0ubuntu4

---------------
seahorse-plugins (2.28.1-0ubuntu4) karmic-proposed; urgency=low

  * debian/patches/03_dont_crash_on_exit.patch:
    - Only clean up the socket dir on exit. Calling GConf functions
      in the atexit handler is bad, as it conflicts with a handler
      registered inside liborbit, leading to a crash (LP: #429322)
 -- Chris Coulson <email address hidden> Mon, 09 Nov 2009 22:34:57 +0000

Changed in seahorse-plugins (Ubuntu Karmic):
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

the change is in lucid too now

Changed in seahorse-plugins (Ubuntu):
status: Confirmed → Fix Released

       *You have 6 minutes* ?

[image: cid:001101c90ce3$f968e340$0444fe7c@myc393e36b9796]*

This is without a doubt one of the nicest good luck forwards I have received
Hope it works for you -- and me!
You have 6 minutes

There's some mighty fine advice in these words, even if you're not
superstitious. This has been sent To you for good luck from the Anthony
Robbins organization.. It has been sent around the world ten times so Far.

Do not keep this message.

This must leave your hands in 6 MINUTES. Otherwise you will get a very
unpleasant surprise. This is true, even if you are not superstitious,
agnostic, or otherwise faith impaired. **

ONE.** **Give people more than they expect and do it cheerfully.

TWO.** **Marry a man/woman you love to talk to. As you get older, their
conversational skills will be as important as any other.

THREE. Don't believe all you hear, spend all you have or sleep all you want

FOUR.** **When you say, 'I love you,' mean it.

FIVE.** **When you say, 'I'm sorry,' look the person in the eye.

SIX.** **Be engaged at least six months before you get ma rried.

SEVEN. Believe in love at first sight.** **

EIGHT.* *Never laugh at anyone's dream. People who don't have dreams don't
have much.

NINE. Love deeply and passionately. Y ou might get hurt but it's the only
way to live life completely.

TEN. In disagreements, fight fairly. No name calling.

ELEVEN. Don't judge people by their relatives.

T WELVE . Talk slowly but think quickly.

THIRTEEN. When someone asks you a question you don't want to answer, smile
and ask, 'Why do you want to know?'

FOURTEEN. Remember that great love and great achievements involve great
risk. **

FIFTEEN. **Say 'God bless you' when y ou hear someone sneeze.

SIXTEEN. When you lose, don't lose the lesson .

SEVENTEEN. Remember the three R's: Respect for self; Respect for others; and
Responsibility for all your actions.

EIGHTEEN. Don't let a little dispute injure a great friendship.

NINETEEN. When you realize you've made a mistake, take immediate steps to
correct it. **
?** **
TWENTY.* *Smile when picking up the phone. The caller will hear it in your
voice.

TWENTY-ONE. Spend some time alone.** **

Now, here's the FUN part!
Send this to at least 5 people and your life will improve. 1-4 people: Your
life will improve slightly.
5-9 people: Your life will improve to your liking.
9-14 people: You will have at least 5 surprises in the next 3 weeks
15 and above: Your life will improve drastically and everything you ever
dreamed of wil l begi n to take shape.

A true friend is someone who reaches for your hand and touches your heart.

Do not keep this message*

--
-Chathura Asanga-

Changed in seahorse-plugins:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in seahorse-plugins (Fedora):
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.