crash when node-editing pattern-filled object

Bug #463602 reported by emmanuel on 2009-10-29
174
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Krzysztof Kosinski
inkscape (Debian)
Fix Released
Unknown
inkscape (Ubuntu)
Medium
Unassigned

Bug Description

I'm on ubuntu 9.10 with inkscape 0.47pre4 r22446 and I also figure this bug with inkscape0.47pre4 with mac osx leopard.

Each time I assign a pattern to a figure, and I try to move the figure with the nodes editor by selecting all his nodes, and move it, inkscape crash.

this the backtrace

emmanuel (le-unamme) wrote :
jazzynico (jazzynico) wrote :

Not reproduced on Vista, Inkscape revision 22536.
I've tried with a rectangle, converted to path, and filled with stripes. Selected all the node and moved it. No crash.
Could you please tell us exactly how you reproduced it, or provide a SVG with the crashing shape.
Thanks!

Changed in inkscape:
importance: Undecided → High
tags: added: crash node-editing
emmanuel (le-unamme) wrote :

I reproduce it by :
1 draw something, anything.
2 Make your drawing a pattern
3 Draw a closed shape with ink
4 select all the nodes with node editor
5 move the shape by taking one the selected nodes.
6 crash occur.

I join the terminal ouput from ubuntu :

[manu@manu-desktop ~]$ inkscape

** (inkscape:4142): CRITICAL **: virtual const gchar* Inkscape::XML::SimpleNode::attribute(const gchar*) const: assertion `name != NULL' failed

** (inkscape:4142): CRITICAL **: virtual void Inkscape::XML::SimpleNode::setAttribute(const gchar*, const gchar*, bool): assertion `name && *name' failed

** (inkscape:4142): CRITICAL **: void sp_canvas_end_forced_full_redraws(SPCanvas*): assertion `canvas != NULL' failed

Emergency save activated!

Emergency save document locations:
  /home/manu/Nouveau document 1.2009_10_29_22_27_18.0.svg
Emergency save completed. Inkscape will close now.
If you can reproduce this crash, please file a bug at www.inkscape.org
with a detailed description of the steps leading to the crash, so we can fix it.
Erreur de segmentation

emmanuel (le-unamme) wrote :

Oups forget
3,5 fill your shape with pattern.

su_v (suv-lp) wrote :

Reproduced with Inkscape 0.46+devel r22544 on OS X 10.5.8

1) create shape (star, rectangle) and convert it to path, or draw a closed path with the bézier tool
2) set pattern fill (take the first, stripes, though I doubt it matters)
3) switch to node editor <F2>
4a) use 'Ctrl+A' to select all nodes or:
4b) drag a selection window big enough to include the pattern handles
5) move the path by dragging a node

results (most of the times) in a crash or freeze. I suspect that the pattern handles are relevant for this crash.

Changed in inkscape:
status: New → Confirmed
emmanuel (le-unamme) wrote :

This is a crashing document, try to edit the nodes othe shape, or moving it with node editor.

Alvin Penner (apenner) wrote :

running Windows XP and Inkscape 0.47pre4. It took me a few tries before I got a crash, but when it crashed I got the messages:

** (inkscape.exe:892): CRITICAL **: virtual const gchar* Inkscape::XML::SimpleNode::attribute(const gchar*) const: assertion `name != NULL' failed

** (inkscape.exe:892): CRITICAL **: virtual void Inkscape::XML::SimpleNode::setAttribute(const gchar*, const gchar*, bool): assertion `name && *name' failed

** (inkscape.exe:892): CRITICAL **: void sp_canvas_end_forced_full_redraws(SPCanvas*): assertion `canvas != NULL' failed

Emergency save activated!

jazzynico (jazzynico) wrote :

Ok, I can reproduce it with the pattern handles selected.
Here's the Windows XP gdb backtrace:

-----
(gdb) bt
#0 0x68605637 in g_str_hash () from C:\Devel\SVN\inkscape\libglib-2.0-0.dll
#1 0x685db0fd in g_hash_table_lookup () from C:\Devel\SVN\inkscape\libglib-2.0-0.dll
#2 0x685d4873 in g_quark_from_string () from C:\Devel\SVN\inkscape\libglib-2.0-0.dll
#3 0x00537e85 in ?? ()
-----

jazzynico (jazzynico) wrote :

Also reproduced on Ubuntu 9.04, Inkscape revision 22548.
Backtrace attached.

Sasa (sasarakezic) wrote :

I have same problem on 0.47pre4 on Kubuntu Karmic Koala 9.10.

I was doing like this:

- Import image
- Make it pattern (object to pattern)
- draw rectangle
- in fill and stroke i picked pattern
- select node editor
- when i touch any node Inkscape crashes

Cheers,

su_v (suv-lp) on 2009-11-06
tags: added: pattern
su_v (suv-lp) on 2009-11-21
summary: - crash by moving drawing by grouping his nodes
+ crash when node-editing pattern-filled object

same here, here is what I get:

** (inkscape:13473): CRITICAL **: virtual const gchar* Inkscape::XML::SimpleNode::attribute(const gchar*) const: assertion `name != NULL' failed

** (inkscape:13473): CRITICAL **: virtual void Inkscape::XML::SimpleNode::setAttribute(const gchar*, const gchar*, bool): assertion `name && *name' failed

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7f5eaa8137c0 (LWP 13473)]
0x00000000008072ab in SPCurve::SPCurve ()

CarloBertini (waydotnet) wrote :

Linux mylaptop 2.6.31-15-generic #50-Ubuntu SMP Tue Nov 10 14:53:52 UTC 2009 x86_64 GNU/Linux

1) File --> Import --> image.jpg
2) with image selected, object => pattern => Object to Pattern (ALt+I)
3) Path => Object to path
4) double click into image
5) move top left angle, crash!

** (inkscape:15240): CRITICAL **: virtual void Inkscape::XML::SimpleNode::setAttribute(const gchar*, const gchar*, bool): assertion `name && *name' failed

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff40db234 in g_type_check_instance_cast () from /usr/lib/libgobject-2.0.so.0

Krzysztof Kosinski (tweenk) wrote :

No longer crashes in the new node tool.

Changed in inkscape:
assignee: nobody → Krzysztof Kosinski (tweenk)
status: Confirmed → Fix Committed
jazzynico (jazzynico) on 2010-02-15
Changed in inkscape:
milestone: none → 0.48
Merrattic (merrattic) wrote :

So is this fixed? I get this problem in 0.47. Do I have to compile from SVN to fix it?

Krzysztof Kosinski (tweenk) wrote :

Yes. "Fix Committed" means the fix is available in the development version (it's in Bazaar, not in SVN, by the way). "Fix Released" means the fix is in a stable release.

Merrattic (merrattic) wrote :

OK thanks. Found by myself out it wasn't in the SVN release having spent the night getting dependencies and compiling 0.47 :D. Will have a look at Bazaar next.

BobSongs (bobspcrepair) wrote :

System: Ubuntu 9.10
Inkscape version: 0.47, compiled from source (same happened with pre)

Happens every time:

1. Command Prompt
2. type "Inkscape", hit Enter
3. Drag image from desktop (small JPG, 3.9 Kb) to New document 1
4. From the menus: Object > Pattern > Objects to Pattern (Alt+I)
5. Delete image from New document 1 (crash occurs whether image remains on desktop or not)
6. Create random rectangle
7. Fill and Stroke (Shift+Ctrl+F)
8. Under "Fill" tab, click chequered "Pattern", left of [?] icon
9. Fill and Stroke says: "Pattern2830" (Use the Node tool to adjust postion, scale, etc...)
10.Close Fill and Stroke dialogue
11.From the menus: Path > Object to path (Shift+Ctrl+C)
12.Click Node Tool (F2)
13.Click object to make nodes appear
14.Take a node and move it.
15.Dialogue box appears: "Inkscape encountered an internal error and will close now. Automatic backups of unsaved documents were done to the following locations:"
16.Command Prompt message: "Emergency save completed. Inkscape will close now.
"If you can reproduce this crash, please file a bug at www.inkscape.org with a detailed description of the steps leading to the crash, so we can fix it.
"Segmentation fault"

Krzysztof Kosinski (tweenk) wrote :

I followed the steps above but can't reproduce the bug in the development version - I think it really is fixed.

BobSongs (bobspcrepair) wrote :

Krzysztof Kosinski : I just tried this in Windows XP Home, SP3, Inkscape 0.47 r22583, built Nov 21 2009 (standard current setup). And you're right: the problem cannot be reproduced. I can't tell you what happens on my Mac because the betas only go so far for Tiger, and I do not believe there's a .dmg file for the completed 0.47 for that O/S.

When compiling Inkscape in Ubuntu, I ensured that all the dependencies were supplied. After running ./configure, I reviewed the output and installed items that configure didn't seem to mind not having. I wanted as many libraries available to Inkscape as humanly possible. If you want me to post the results of 'configure', I'll do that. After installing Inkscape 0.47 I tested that one element. It caused Inkscape to collapse. Perhaps I missed something essential. However, it is odd that this particular feature does fail in a fresh compile.

: /

su_v (suv-lp) wrote :

tested again (following the steps described in comment #17):
-> crash reproduced with Inkscape 0.47 r22583 on OS X 10.5.8
-> crash _not_ reproduced with Inkscape 0.47+devel r9186 on OS X 10.5.8

@BobSongs - the crash when node-editing a pattern-filled object has already been confirmed for Inkscape 0.47 r22583 on all platforms (linux, osx, win32) - the fix was committed in bzr trunk (0.47+devel) with the merge of the new node tool.

If interested you can test current development builds: win32 and osx (Leopard+ Universal) packages are available from <http://inkscape.modevia.com/>) - for linux you can get the current sources from the bzr repository as described in <http://www.inkscape.org/bzr.php?lang=en>. You can find more information about compiling Inkscape on Ubuntu in the wiki: <http://wiki.inkscape.org/wiki/index.php/CompilingUbuntu>.

BTW - for Tiger PPC there's a 'completed' 0.47 DMG package available from the official download page <http://sourceforge.net/projects/inkscape/files/inkscape/0.47/> (Note: this 0.47 package will not run on a Mac with i386 Intel arch, and of course it still contains this bug)

BobSongs (bobspcrepair) wrote :

@~suv: First, good to hear the fix is committed. I thought I'd note that in Windows XP Home SP3 the crash _does_ occur, but not as *instantaneously* as it does in Linux. Moving the nodes will work for a time. Then the same style of crash can happen.

I will indeed give the latest tests a run. I'll uninstall my current version (I kept the files from which it was compiled), and I'll try the latest and submit bug reports.

Inkscape is, in my opinion, an O/S essential. I've got it in Linux, Mac & Windows. Thanks for the efforts: the bug reports are my way of saying "thanks".

If there's any hope of compiling a copy of 0.47 for the Intel architecture under Mac O/S 10.4, it would be appreciated.

Changed in inkscape (Ubuntu):
status: New → Confirmed
Dídac Rios (didac) wrote :

Same problem for Inkscape 0.47 r22583, built Apr 4 2010

on ubuntu 10.04 64 bits

** (inkscape:1815): CRITICAL **: virtual const gchar* Inkscape::XML::SimpleNode::attribute(const gchar*) const: assertion `name != NULL' failed

** (inkscape:1815): CRITICAL **: virtual void Inkscape::XML::SimpleNode::setAttribute(const gchar*, const gchar*, bool): assertion `name && *name' failed

Emergency save activated!
Emergency save completed. Inkscape will close now.

jazzynico (jazzynico) on 2010-08-24
Changed in inkscape:
status: Fix Committed → Fix Released
Alex Valavanis (valavanisalex) wrote :

This bug will be fixed in Ubuntu with the release of inkscape_0.48.0-1ubuntu1, which will appear in Maverick shortly. Please see bug #628048 for details.

Changed in inkscape (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.48.0-1ubuntu1

---------------
inkscape (0.48.0-1ubuntu1) maverick; urgency=low

  * Merge with Debian unstable (LP: #628048, LP: #401567, LP: #456248,
    LP: #463602, LP: #591986)
  * debian/control:
    - Ubuntu maintainers
    - Promote python-lxml, python-numpy, python-uniconvertor to Recommends.
    - Demote pstoedit to Suggests (universe package).
    - Suggests ttf-dejavu instead of ttf-bitstream-vera (LP: #513319)
  * debian/rules:
    - Run intltool-update on build (Ubuntu-specific).
    - Add translation domain to .desktop files (Ubuntu-specific).
  * debian/dirs:
    - Add usr/share/pixmaps. Allow inkscape.xpm installation
  * drop 50-poppler-API.dpatch (now upstream)
  * drop 51-paste-in-unwritable-directory.dpatch (now upstream)

inkscape (0.48.0-1) experimental; urgency=low

  * [cae07a3] New Upstream version 0.48.0
  * [309c498] add patch to fix crash in node tool
  * The highlights of this release are:
      - multipath editing
      - improved text tool: subscript, superscript, numerical input for text kerning, tracking and more
      - new Airbrush tool
      - LaTeX export with PDF/PS/EPS
      - JessyInk extension to create presentations
      - numerous bugfixes
  * [56702cf] don't build-depend on libssl-dev (closes: #573338)
  * [013b235] wrap lines in debian/control. patch by Benjamin Drung,
    many thanks to him (closes: #576357)
  * [747d3d1] add README.source adopted from nagios to make lintian a
    bit happier
  * [4df0df7] Remove all patches since they are applied upstream
 -- Alex Valavanis <email address hidden> Sun, 12 Sep 2010 19:44:58 +0100

Changed in inkscape (Ubuntu):
status: Fix Committed → Fix Released
marmot (caseytb) wrote :

A work - around for those stuck on OS X tiger ( using the dmg from 0.47 ) : just fill the object after editing the path. I found that the bug was reliably produce for Draw object -> add fill -> Edit path with node tool, but not for Draw object -> Edit path with node too -> add fill.

Changed in inkscape (Ubuntu):
importance: Undecided → Medium
Changed in inkscape (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.