when installing the deb in ubuntu 8.04 I get error

Bug #582261 reported by pablokal on 2010-05-18
4
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Writetype
Undecided
Unassigned

Bug Description

Dependency not satisfiable python, although I have installed a lot of python applications.

Have python 2.4 and 2.5 installed
python- support 0.75
python-enchant 1.3.1.1
python-qt 4.40

Very sorry about this because this looks great.
I used for my disabled daughter Clicker 4 and 5 a lot from cricksoftware, only on Windows and Mac.
You might look there to get ideas for further options.

Max Shinn (mwshinn) wrote :

I have updated the deb on http://bernsteinforpresident.com/software/writetype so that it should work on 8.04.
Could you please verify that it works?

Hi Max,
Now I get the error:
Dependency not satisfiable python-support.
Thanks for your work on this.
greets Paul

2010/5/24 Max Shinn <email address hidden>

> I have updated the deb on
> http://bernsteinforpresident.com/software/writetype so that it should work
> on 8.04.
> Could you please verify that it works?
>
> --
> when installing the deb in ubuntu 8.04 I get error
> https://bugs.launchpad.net/bugs/582261
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Writetype: New
>
> Bug description:
> Dependency not satisfiable python, although I have installed a lot of
> python applications.
>
> Have python 2.4 and 2.5 installed
> python- support 0.75
> python-enchant 1.3.1.1
> python-qt 4.40
>
> Very sorry about this because this looks great.
> I used for my disabled daughter Clicker 4 and 5 a lot from cricksoftware,
> only on Windows and Mac.
> You might look there to get ideas for further options.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/writetype/+bug/582261/+subscribe
>

Hi Max,
Now I get the error:
Dependency not satisfiable python-support.
So the python itself seems to be solved.
Thanks for your work on this.
greets Paul

Max Shinn (mwshinn) wrote :

I recently played around with a 8.04 computer, and found there is a different problem. It seems 8.04 does not contain the package python-enchant, which WriteType depends on for spell checking.
If this package is unavailable, I could possibly make it fall back to not use spell check, but I don't know if this would be suitable for most cases, as it would likely just give users the wrong impression.

Max Shinn (mwshinn) wrote :

I recently built packages for Python 2.5 Select the Debian packages (not the Ubuntu ones) at http://bernsteinforpresident.com/software/writetype and see if that works for you.

Download full text (11.3 KiB)

Hi Max,
Did not try this anymore as my old pc on which Ubuntu was installed. This pc
went dead.
Felt kind of embarrassed asking support and then not being able to test it.
Anyway tried to install it again in Archlinux on my new pc (64 bits install)
and that went ok:
But when trying to run run the program I get:
Traceback (most recent call last):
  File "/usr/bin/writetype", line 2, in <module>
    import writetype.main
  File "/usr/lib/python2.7/site-packages/writetype/main.py", line 633, in
<module>
    app = MainApplication()
  File "/usr/lib/python2.7/site-packages/writetype/main.py", line 65, in
__init__
    self.ui.setupUi(self)
  File "/usr/lib/python2.7/site-packages/writetype/mainwindow.py", line 47,
in setupUi
    self.textArea = spellCheckEdit(self.splitter)
  File "/usr/lib/python2.7/site-packages/writetype/spellCheckEdit.py", line
54, in __init__
    self.dictionary = enchant.DictWithPWL("en_US")
  File "/usr/lib/python2.7/site-packages/enchant/__init__.py", line 716, in
__init__
    Dict.__init__(self,tag,broker)
  File "/usr/lib/python2.7/site-packages/enchant/__init__.py", line 489, in
__init__
    self._switch_this(broker._request_dict_data(tag),broker)
  File "/usr/lib/python2.7/site-packages/enchant/__init__.py", line 253, in
_request_dict_data
    self._raise_error(eStr % (tag,),DictNotFoundError)
  File "/usr/lib/python2.7/site-packages/enchant/__init__.py", line 207, in
_raise_error
    raise eclass(default)
enchant.errors.DictNotFoundError: Dictionary for language 'en_US' could not
be found
destructor
Exception AttributeError: "type object 'QMainWindow' has no attribute
'__del__'" in <bound method MainApplication.__del__ of
<writetype.main.MainApplication object at 0x264a0e0>> ignore

In Arch I already have installed python3: could this be the origin of the
trouble? Do you have any suggestions?? Thanks Paul

Install feedback, all seems ok:
sudo python2 setup.py install
Password:
/usr/lib/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution
option: 'windows'
  warnings.warn(msg)
running install
running build
running build_py
creating build
creating build/lib
creating build/lib/writetype
copying writetype/settings.py -> build/lib/writetype
copying writetype/spellCheckEdit.py -> build/lib/writetype
copying writetype/revno.py -> build/lib/writetype
copying writetype/distractionFree.py -> build/lib/writetype
copying writetype/mainwindow.py -> build/lib/writetype
copying writetype/statistics.py -> build/lib/writetype
copying writetype/settingsDialog.py -> build/lib/writetype
copying writetype/ttsInterface.py -> build/lib/writetype
copying writetype/espeakInterface.py -> build/lib/writetype
copying writetype/main.py -> build/lib/writetype
copying writetype/platformSettings.py -> build/lib/writetype
copying writetype/pyttsxInterface.py -> build/lib/writetype
copying writetype/resources_rc.py -> build/lib/writetype
copying writetype/colemak.py -> build/lib/writetype
copying writetype/speaker.py -> build/lib/writetype
copying writetype/festivalInterface.py -> build/lib/writetype
copying writetype/__init__.py -> build/lib/writetype
copying writetype/wordsList.py -> build/lib/writetype
running build_scripts
creating b...

Max Shinn (mwshinn) wrote :

What is your computer's locale? Do you also mind posting the output of the command:
dpkg --get-selections|grep aspell-

Hi Max,
Found some time for testing this on Ubuntu too and did some feature
suggestions.

See your launchpad site.
My computers locale is english.
Aspell is installed.

I will give you the precise terminal output later as I am now typing from
Ubuntu
Greetings Paul

2010/11/24 Max Shinn <email address hidden>

> What is your computer's locale? Do you also mind posting the output of the
> command:
> dpkg --get-selections|grep aspell-
>
> --
> when installing the deb in ubuntu 8.04 I get error
> https://bugs.launchpad.net/bugs/582261
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Writetype: New
>
> Bug description:
> Dependency not satisfiable python, although I have installed a lot of
> python applications.
>
> Have python 2.4 and 2.5 installed
> python- support 0.75
> python-enchant 1.3.1.1
> python-qt 4.40
>
> Very sorry about this because this looks great.
> I used for my disabled daughter Clicker 4 and 5 a lot from cricksoftware,
> only on Windows and Mac.
> You might look there to get ideas for further options.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/writetype/+bug/582261/+subscribe
>

locale
LANG=en_US.utf8
LC_CTYPE="en_US.utf8"
LC_NUMERIC="en_US.utf8"
LC_TIME="en_US.utf8"
LC_COLLATE="en_US.utf8"
LC_MONETARY="en_US.utf8"
LC_MESSAGES="en_US.utf8"
LC_PAPER="en_US.utf8"
LC_NAME="en_US.utf8"
LC_ADDRESS="en_US.utf8"
LC_TELEPHONE="en_US.utf8"
LC_MEASUREMENT="en_US.utf8"
LC_IDENTIFICATION="en_US.utf8"
LC_ALL=

The dpkg --get-selections|grep aspell- gives no output in Arch as it is a
different installer pacman.
pacman -Ss packagename gives the available packages and I discovered that I
might not have the English dictionary installed; indeed it wasn't strange as
the Dutch was and I have open office installed; after installing the
dictionary writetype works ok; so your hunch was right; so in the
dependencies should be mentioned aspell and aspell-en.

A short addition to the read aloud as you type option I asked for.
In Clicker 5 you have three options for read aloud as you type:
text is read after each letter is typed
after each word ( marked by space key)
or when a sentence is completed, marked by typing the dot.

Thanks again for your help and work on this great program.
Greetings Paul

2010/11/24 Max Shinn <email address hidden>

> What is your computer's locale? Do you also mind posting the output of the
> command:
> dpkg --get-selections|grep aspell-
>
> --
> when installing the deb in ubuntu 8.04 I get error
> https://bugs.launchpad.net/bugs/582261
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Writetype: New
>
> Bug description:
> Dependency not satisfiable python, although I have installed a lot of
> python applications.
>
> Have python 2.4 and 2.5 installed
> python- support 0.75
> python-enchant 1.3.1.1
> python-qt 4.40
>
> Very sorry about this because this looks great.
> I used for my disabled daughter Clicker 4 and 5 a lot from cricksoftware,
> only on Windows and Mac.
> You might look there to get ideas for further options.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/writetype/+bug/582261/+subscribe
>

Max Shinn (mwshinn) wrote :

You sort-of mentioned on the blogpost that installing aspell-en worked for you. Can you confirm this so that I can update my documentation and package? Thanks. And also thanks for the feature requests!

Yes, I sent you and email about this, didn't you receive that?

Here is part of what I wrote:
The dpkg --get-selections|grep aspell- gives no output in Arch as it is a
different installer pacman.
pacman -Ss packagename gives the available packages and I discovered that I
might not have the English dictionary installed; indeed it wasn't strange as
the Dutch was and I have open office installed; after installing the
dictionary writetype works ok; so your hunch was right; so in the
dependencies should be mentioned aspell and aspell-en.

A short addition to the read aloud as you type option I asked for.
In Clicker 5 you have three options for read aloud as you type:
text is read after each letter is typed
after each word ( marked by space key)
or when a sentence is completed, marked by typing the dot.

On the select suggested word by keystroke you could work like the free word
prediction program in windows *letmetype*;http://www.clasohm.com/lmt/en/ ;
there you select by typing a digit from 1 to number of suggested words
(there maximum is 9, I believe). The nice thing in that program is that it
can used in all kind of other programs and will give a popup kind of window,
when doing a suggestion, where the caret is; letter colour and size.
background colour are configurable.* It doesn't give sound feedback on
typing as does Clicker5*.
I think you could be greatly inspired by Clicker5; you will need a windows
pc to test it .
I have a legitimate copy of that program and can upload an iso with key, if
you would want to explore that further.

Thanks again for your help and work on this great program.
Greetings Paul

2010/11/25 Max Shinn <email address hidden>

> You sort-of mentioned on the blogpost that installing aspell-en worked
> for you. Can you confirm this so that I can update my documentation and
> package? Thanks. And also thanks for the feature requests!
>
> --
> when installing the deb in ubuntu 8.04 I get error
> https://bugs.launchpad.net/bugs/582261
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Writetype: New
>
> Bug description:
> Dependency not satisfiable python, although I have installed a lot of
> python applications.
>
> Have python 2.4 and 2.5 installed
> python- support 0.75
> python-enchant 1.3.1.1
> python-qt 4.40
>
> Very sorry about this because this looks great.
> I used for my disabled daughter Clicker 4 and 5 a lot from cricksoftware,
> only on Windows and Mac.
> You might look there to get ideas for further options.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/writetype/+bug/582261/+subscribe
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers