Hard to tell the difference between actual flags and possible flags for the yellow player

Bug #787464 reported by Hans Joachim Desserud on 2011-05-24
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
widelands
Low
Chuck Wilder

Bug Description

(I'm not really sure what can be done with this, and I know there are already some reports regarding colors.)

I just noticed when playing as the yellow player, that it was a bit hard to tell the difference between where I had placed flags and where it was possible. While I do use shift-click to place roads so that they are filled automatically, it was a bit confusing in the beginning.

To clearify, I don't really have any suggestions for how this could be changed, or even if it *should* be changed, but I thought I'd report it.

-----------------------------------------------------------------

The vote as of 17 Jan.:

......1st Choice=3pts 2nd Choice=2pts 3rd Choice=1pt....Total Pts
Axe ..... 2 votes ....... 4 ............. 0 ...............14
Slash ... 1 ............. 0 ............. 1 ............... 4
Rough \ . 3 ............. 2 ............. 0 ...............13
"X" ..... 0 ............. 0 ............. 1 ............... 1
Wolf .... 0 ............. 0 ............. 1 ............... 1

Hans Joachim Desserud (hjd) wrote :
Hans Joachim Desserud (hjd) wrote :

The point with the screenshot is that one of the flags on the road is not placed.

Changed in widelands:
importance: Undecided → Low
summary: - Hard to tell the difference between actual maps and possible maps for
+ Hard to tell the difference between actual flags and possible flags for
the yellow player
Hans Joachim Desserud (hjd) wrote :

Now with less misleading title. Sorry about that...

tags: added: ui
Nasenbaer (nasenbaer) wrote :

of course this is something about graphics and therefore there will be different opinions :)

My opinion is: I have no problem to dsee, which flag is placed - especially in game (not screenshot, but running game), as the real flags are waving and the buildhelp flag does not.

I vote for "won't fix"

Further there was already a bug report on that topic, but it was about the older flag buildhelp symbol, which looked even more like the real flag. I am not sure, what the decission was, but I think it was won't fix as well. Anyone brave enough to search for the bug report? :)

SirVer (sirver) wrote :

I have no problem with this, vote for Won't fix as well (and will set it to this for now. Please comment if you feel this should be reopened). I promise to play with yellow in my next game as to test this.

Changed in widelands:
status: New → Won't Fix
_aD (ad-simplypeachy) wrote :

Both myself and Mark noticed this last night. I hadn't played yellow before and was surprised how similar the flags are, and how dilute the chequered texture on the yellow flags is. Maybe a subtle change to make the chequering a little more obvious would help. It's not a big deal though :-)

Gabriel Margiani (gamag) wrote :

I tried to paint something, but I don't like the result, so +1 for won't fix.

Mark Scott (mxsscott) wrote :

The flags had a chequered texture? I didn't notice. (Laptop LCD screen running at native resolution, set to 'millions' of colours).

_aD (ad-simplypeachy) wrote :
_aD (ad-simplypeachy) wrote :
SirVer (sirver) wrote :

reopened because this is clearly an issue - also assigned the media guys. Chuck, are you back around after our long hiatus?

Changed in widelands:
status: Won't Fix → Confirmed
assignee: nobody → Widelands Media Developers (widelands-media-dev)
Chuck Wilder (chuckw20) wrote :

Yes, I've been lurking around. ;)

I'll take a stab at this and post something here soon for discussion.

Changed in widelands:
assignee: Widelands Media Developers (widelands-media-dev) → Chuck Wilder (chuckw20)
Mark Scott (mxsscott) wrote :

Is a graphics update necessary? A small tweak to the RGB triplet value in player.cc for player 3 may make the yellow player flag different enough from the build help flag.

The alternative solution is to change the colour of the build help flag to a colour that isn't used by a player - light blue? That may need less graphics update but may be inconsistent with the 'look' of widelands.

By the way, I was the unlucky yellow player playing with _aD.

SirVer (sirver) wrote :

how about posting a screenshot of the rgb tweak and letting the elder of graphics decide?

Chuck Wilder (chuckw20) wrote :

I've considered changing the design of the barbarian tribe flag for some time now, long before the "yellow issue" was raised. However, I will entertain any suggestions including altering the hue and/or pattern of the barbarian flag(s).

To clue you in on my thoughts, I'm considering more of an elongated penant perhaps with chevrons.

Color is the easiest change of course, but some additional distinctive element of design might be nice.

Shevonar (shevonar) wrote :

I think changing the shape of the barbarian flag is a very nice alternative to changing colors. Maybe a simple triangular flag fits the barbarian primitive style. The other tribe's flag can be clearly distiguished from the build help because of their different shape IMHO.

Mark Scott (mxsscott) wrote :

An element of black bordering may help against desert - see the attached screenshot for the current state.

I tried the RGB tweak, it wasn't particularly useful.

Mark Scott (mxsscott) wrote :

IANAA (I am not an artist) - same screenshot as previous comment, but with flags burnt a bit in GIMP.

Chuck Wilder (chuckw20) wrote :

Brainstorming results:

I sketched a few ideas for a revised barbarian road flag (see Barb_flags_sm.jpg). The atlantean and empire designs are included in the lower left corner for comparison.

My personal favorite is #7.

Even though the atlantean and empire flags both hang from a horizontal bar, I'm favoring doing the same for the barbarian flag.

Crafting a distinctive standard (pole) and additonally using some unique pattern on the flag material could further its identification as barbarian.

What do you think?

Changed in widelands:
milestone: none → build18-rc1
_aD (ad-simplypeachy) wrote :

I'm definitely with you for #7, it looks suitably barbarian and will definitely make it contrasting to the build help flags.

Mark Scott (mxsscott) wrote :

My opinion:
#4 #5 #8 - too similar to build flags in shape, won't help yellow player.

#7 is good.

Given the barbarians love of meat, would an animal hide shaped flag be appropriate?

Chuck Wilder (chuckw20) wrote :

@Mark #21 - The use of animal hides had crossed my mind. I'll play around with it. Perhaps a natural skin (with or without fur) and some symbol in player color emblazened on it.

Hans Joachim Desserud (hjd) wrote :

I like #7 as well.

#2 could be a nice alternative though. It's rather crude, but these are barbarians after all. I also like the idea that they would simply tear off a fitting piece of cloth or something when planting the flag and use that.

Chuck Wilder (chuckw20) wrote :

Here is an image in game scale of a variation on #7. The flag is wider, the crossbar is unique to the other tribes plus I've added a nice barbaric wolf skull. :)

Comments?

Chuck Wilder (chuckw20) wrote :

Same image with opaque background and red player color.

This should be a little easier to make out.

Chuck Wilder (chuckw20) wrote :

Here is my shot at an animal skin road flag for our barbarian friends.

I've tried it in the game and it works pretty well with all colors.

Comments please.

Chuck Wilder (chuckw20) wrote :
Gabriel Margiani (gamag) wrote :

Cool! thank you
The only thing I don't like is the sign in player color, maybe something little more complicated, round or thin like the border marks would be better

Since the animal skin is quite heavy, the flag will need a slow animation.

wl-zocker (wl-zocker) wrote :

I like the idea and the color of the animal skin very much! Unfortunally, the skull is not easy to recognize (but I think it is a good idea though). I do not like the sign of the player color neither. It seems the shape symbolizes something (because of its strange form), but I cannot recognize it. What about a vertical stroke?

SirVer (sirver) wrote :

Chuck is at it again :-). I find the skull a bit morbid - though I have to agree that it kinda fits the picture of the barbarians. I also do not like the skull like embleme on the skin flags - maybe an axe is better if you want to go with the martialistic style, a "scratch" might also look like.

The idea with the animal skin flag is very nice though and i like the raw feel it gives in the screenshot. It's really good to see widelands back in full swing again.

Hans Joachim Desserud (hjd) wrote :

I very much like the animal skin, though I agree with the others that the skull at the top is not easy to recognize. And I agree a slow animation to give the impression of weight would be a nice touch here.

I think the player color shape tries to form the skull from the barbarian "logo" (http://wl.widelands.org/wiki/BarbariansPage/). It's not really all that clear though. Maybe we should go for some easier shape or symbol, or reuse some of the runes from the obelisks?

(Wasn't there a bug report on improving/replacing the barbarian logo/symbol, btw?)

Mark Scott (mxsscott) wrote :

Nice! Could you post a screenshot of the same multiplayer color comparison but against mountains and desert terrain just to make sure? (Yellow flags in the desert was a nightmare!)

I agree I don't recognise the skull symbol so yes, some kind of slash of colour might work better? (see mockup attachment)

Chuck Wilder (chuckw20) wrote :

Thank you all for your comments.

I agree the skull atop the standard is difficult to discern. It is modeled after a real wolf skull, but it loses a great deal of detail at that scale. I don't wish to make it any larger, though lest it become a distraction. I'll tack on some horns/antlers and get your feedback. I'm not "married to" the idea. Just thought I'd try it out.

The color pattern on the skin started as an arbitrary spot, but then my imagination conjured a stylized version of the wolf skull.

       hjd wrote: "Maybe we should go for some easier shape or symbol, or reuse some of the runes from the obelisks?"

I LIKE the idea of referencing runes a great deal. I'll cobble together some player color design options and post them soon for discussion. I'll try some runes (maybe a Germanic "WL" or "B" for barbarians), an axe (or two), a "slash", an "X"and a wolf head in profile.

The animation will be suitably slow to convey the sense of mass of the skin.

Thanks again, all. Stay tuned.

Chuck Wilder (chuckw20) wrote :

The image I've attached compares the following designs:
1&2 an axe (on dark & light skins)
3&4 a rune "B" (on dark & light skins)
5&6 a rune "W" (on dark & light skins)
7&8 a rune "WL" (on dark & light skins)
9 a "slash" (on dark skin)
10&11 a wolf head (on dark & light skins)
12 an "X" (on dark skin)

Some of the designs are better recognized when animated.

The skull is still optional. (The antlers don't really show up all that well.) Any ideas for a different treatment of the top of the standard? "Nothing" would be the easiest on the graphician. ;D

Where I felt it was needed (especially on the light skins) I added bordering to the image to improve its discernability.

Let me hear your thoughts/votes. The favored candidate(s) will then be presented against the various ground testures. There are just too many combinations to do that right now.

wl-zocker (wl-zocker) wrote :

That are a lot of ideas. It was not easy to choose my favorites:

- I prefer the dark skin. I think it is more "wild", reminding me of bear skin. The disadvantage is that black and blue are not easy to distinguish from the background. (On a light skin, brown, yellow, and grey are bad to recognize, and the black bordering looks a bit strange.)
- I do not like the runes. While the B seems as if you had had no idea (the rune looks like the normal letter), probably nobody will know what that strange F stands for. (Did you use the Futhark runes? If yes, the F rune stands for F and the letter W looks like a P, which would complicate things even more.)
- The wolf is not easy to recognize. I doubt the flag is simply too small for such a complicated design.
- The X remainds me of a "here is the treasure"-cross. Nevertheless, it would be a second alternative.
- The slash is a simple, primitive slash - fitting to the Barbarians.
- My favorite is the axe. It is the typical Barbarian weapon and easy to recognize.
- I am still not happy with the skull. I think the best thing was to leave it away and let the axe speak for itself ;-)

Chuck Wilder (chuckw20) wrote :

@wl-zocker - I used "dotted" Germanic runes as found at http://www.sunnyway.com/runes/runic_scripts.gif

I guess I didn't execute them well enough, and of course at the scale they are seen in the game most detail is lost. We want to avoid confusion at any rate. It was worth a try, though, and I enjoyed looking at the runes. :)

Speaking of avoiding confusion, the skull will be removed from future candidates.

I could execute the wolf design better and I'll do so if folks wish.

I share your impression of the "X" marks the spot.

I confess the slash and the axe are my favorites.

Let's hear what others think.

Chuck Wilder (chuckw20) on 2013-01-14
tags: added: graphic
_aD (ad-simplypeachy) wrote :

I like the axe graphic, and the idea of the slash but the slash image you linked doesn't look very ragged - could you rough it up a bit?

@_aD - I'll see what I can do about "roughing up" that slash.

On Mon, Jan 14, 2013 at 3:19 PM, _aD <email address hidden> wrote:

> I like the axe graphic, and the idea of the slash but the slash image
> you linked doesn't look very ragged - could you rough it up a bit?
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/787464
>
> Title:
> Hard to tell the difference between actual flags and possible flags
> for the yellow player
>
> Status in Widelands:
> Confirmed
>
> Bug description:
> (I'm not really sure what can be done with this, and I know there are
> already some reports regarding colors.)
>
> I just noticed when playing as the yellow player, that it was a bit
> hard to tell the difference between where I had placed flags and where
> it was possible. While I do use shift-click to place roads so that
> they are filled automatically, it was a bit confusing in the
> beginning.
>
> To clearify, I don't really have any suggestions for how this could be
> changed, or even if it *should* be changed, but I thought I'd report
> it.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/widelands/+bug/787464/+subscriptions
>

Mark Scott (mxsscott) wrote :

'axe' and 'slash' get my vote, with honorable mentions to 'x'.

I agree with the roughing of the slash (should it be a clawing?), and I'm trying to determine if I think the slash should be like / not \.

Chuck Wilder (chuckw20) wrote :

Roughened slash image is attached. I chose to use a \ image because I imagined a crude brush stroke by a "left-handed" barbarian sign-maker (with a rather large brush). ;)

_aD (ad-simplypeachy) wrote :

That makes all the difference! Looking good :-)

Chuck Wilder (chuckw20) wrote :

Try them out for yourself! :)

Here is a ZIP file of the flag-slash files ready for use in the game.
the png files go into the ~\barbarians\pics folder and the conf file goes into the ~\barbarians folder.

Chuck Wilder (chuckw20) wrote :

And here is a ZIP file of the flag-axe files ready for use in the game.
the png files go into the ~\barbarians\pics folder and the conf file goes into the ~\barbarians folder.

Comments please. :)

SirVer (sirver) wrote :

I like the non roughed slash best, followed by the axe. I also prefer the dark skin.

Chuck Wilder (chuckw20) wrote :

Attached, for your consideration, are game-ready files for the non-roughed slash.

I will use the dark skin because I believe it presents all of the playercolors far better than the "raw hide". Though it was good to have the comparison.

The vote thusfar as I tally it -

AXE: 4 (SirVer, _aD, MarkS, Chuck)
SMOOTH SLASH: 2 (SirVer, MarkS)
ROUGH SLASH: 2 (_aD, Chuck)
"X": 1 (MarkS)

These votes are considered on an individual basis. I haven't tried to interpret your favorite, just giving equal weight to those you mention, so if you wish to change, prioritize (First choice, second choice, ...), or otherwise clarify your vote, please do so.

Thanks for your input.

wl-zocker (wl-zocker) wrote :

I like the axe best, followed by the rough slash.

Mark Scott (mxsscott) wrote :

Axe, then rough slash. I definitely prefer the axe because its angle fits more with the direction of the pennants on the headquarters.

Gabriel Margiani (gamag) wrote :

Rough slash, then axe and with low priority maybe wolf.

Chuck Wilder (chuckw20) wrote :

The vote at present:

                       First Choice=3pts Second Choice=2pts Third Choice=1pt Total Pts
Axe 2 votes 4 0 14
Slash 1 0 1 4
Rough Slash 3 2 0 13
"X" 0 0 1 1
Wolf 0 0 1 1

Chuck Wilder (chuckw20) wrote :

My attempt a table obviously failed. :)

With 3 points for each first choice, 2 ppoimts for each second choice and 1 point for each 3 choice,
the voting presently stands as

Axe- 14pts, Slash- 4pts, Rough Slash- 13pts, "X"- 1pt, Wolf- 1pt

Chuck Wilder (chuckw20) wrote :

Gee I wish there was a way to edit these comments. ;D

Hans Joachim Desserud (hjd) wrote :

Chuck: It is possible to edit the description, so you could place your table at the bottom there and update it when necessary. :)

Chuck Wilder (chuckw20) wrote :

@hjd#52 - Thanks for the suggestion! Your VOTE will be valued just as highly. :)

Chuck Wilder (chuckw20) on 2013-01-17
description: updated
description: updated
Chuck Wilder (chuckw20) wrote :

Since no additional votes have been cast since 17 Jan, I proclaim the AXE as the "chosen one"! :)

I'll push the change to trunk very soon. Thank you all for your comments and votes.

Mark Scott (mxsscott) on 2013-01-21
Changed in widelands:
status: Confirmed → In Progress
Chuck Wilder (chuckw20) wrote :

Fix has been pushed to the trunk in bzr#6493.

Changed in widelands:
status: In Progress → Fix Committed
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.