double clicks should be disabled on bfb/Place launcher icon/double key press

Bug #766776 reported by billytalent on 2011-04-20
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Low
John Lea
Unity
Fix Released
Medium
Didier Roche
unity-2d
Medium
Alberto Mardegan
unity (Ubuntu)
Medium
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

Double clicking on the BFB should perform the same action as single clicking on the BFB.

Related branches

Bilal Akhtar (bilalakhtar) wrote :

Needs design discussion.

Changed in unity:
status: New → Incomplete
tags: added: needs-design
Changed in unity (Ubuntu):
status: New → Incomplete

I'll confirm this, double click should do the same as click.

Mark

John Lea (johnlea) on 2011-04-20
description: updated
tags: added: udo
removed: needs-design
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Low
status: New → Fix Committed

Probably triple click too!

Didier Roche (didrocks) wrote :

Same with place icons in the launcher and multiple "request" (like double/triple super press).

Let's see how I can handle that generically.

Changed in unity:
status: Incomplete → Triaged
Changed in unity (Ubuntu):
status: Incomplete → Triaged
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
assignee: nobody → Didier Roche (didrocks)
milestone: none → 3.8.12
Didier Roche (didrocks) wrote :

From the attached merge request:

Don't ack double/triple click or super press on bfb and places icons.
(LP: #766776)
This is workarounded in different files right now, the correct fix will be to
handle that in the ubus level (too risky at this stage), added FIXME to remember
that for oneiric.

There is one glitch though, which cannot been tackled without the ubus rewrite:
- if you open a place, then, double click on a placeicon in the launcher to
  close it, it will be closed by will be reactivated (this is because we send
  the UBUS_PLACE_ENTRY_ACTIVATE_REQUEST again on click).
- so, the next super press will not show the home dash, but the active place
  (closing/opening it again will reset to the home dash)

I still think it's an improvment (see Charline's report in maverick for double
clicking on bfb and people being puzzled) and the last described glitch only
impact people double clicking on a place LauncherIcon for closing it…

summary: - double clicks should be disabled on bfb
+ double clicks should be disabled on bfb/Place launcher icon/double key
+ press
Didier Roche (didrocks) on 2011-04-20
Changed in unity:
status: Triaged → Fix Committed
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.10-0ubuntu2

---------------
unity (3.8.10-0ubuntu2) natty; urgency=low

  * Cherry-pick some fixes before freeze:
    - Fix tooltip stays stuck next to the launcher (LP: #751077)
    - Trash/ws switcher icon in unity resets to default icon theme on the event
      of a deletion or emptying the trash or after an upgrade (LP: #761289)
    - double clicks should be disabled on bfb/Place launcher icon/double key
      press (LP: #766776)
    - Intellihide can be puzzled by dash / and post reveal broken (LP: #767250)
 -- Didier Roche <email address hidden> Wed, 20 Apr 2011 20:10:19 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-04-22
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-2d:
status: New → Confirmed
importance: Undecided → Medium
tags: added: delta-with-3d
Alberto Mardegan (mardy) wrote :

Proposed fixes for unity-2d:
https://code.launchpad.net/~mardy/unity-2d/treat-double-clicks-as-single
(last 2 commits)

I tried to submit this with "bzr lp-propose-merge", but it crashed (I reported it as bug 788219, in case someone can guide me out of it).

Changed in unity-2d:
status: Confirmed → In Progress
assignee: nobody → Alberto Mardegan (mardy)
Anders Kaseorg (andersk) wrote :

I disagree with this “feature”, or at very least with its implementation. It means that when I accidentally click on the corner of the screen and realize that I didn’t want to open/close the menu, I have to wait half a second doing nothing before trying again. Even if I repeatedly click on the menu waiting for it to close/open again, it *never will*, as long as each click was within half a second of the previous one! That just makes the desktop feel unresponsive. (See bug 777492.)

This applies not just to clicks, but also to the keyboard shortcuts (Super and Alt+F2), which makes even less sense.

Frankly, is it really too much to ask the user to realize that when they try double-clicking on the menu button and see the menu briefly open and immediately close, they should try single-clicking instead?

The double-click suppression makes sense for launchers, but not for the main menu which is supposed to act as a toggle.

Changed in unity-2d:
status: In Progress → Fix Committed
milestone: none → 3.10
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Fix Committed
John Lea (johnlea) on 2011-06-03
Changed in ayatana-design:
status: Fix Committed → Fix Released
Changed in unity-2d:
milestone: 3.10 → 3.8.8
Didier Roche (didrocks) on 2011-06-14
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 3.8.8-0ubuntu1

---------------
unity-2d (3.8.8-0ubuntu1) oneiric; urgency=low

  [ Didier Roche ]
  * new upstream release:
    - [spread] Corruption when switching workspaces after windows have been
      moved to other workspaces (LP: #760787)
    - [launcher] launcher won't fully paint, corrupted view (LP: #764690)
    - [launcher] icons no longer active after an incomplete drag (LP: #768812)
    - drag from dash to launcher (LP: #662616)
    - Don't create windows over the launcher (LP: #688816)
    - [launcher] Does not reveal when hovering over the left edge of the
      screen (LP: #760537)
    - UIFe: Launcher - update launcher reveal interaction to make it more
      accessible to first time users (LP: #754583)
    - [launcher] Trash icon should indicate when it has deleted elements
      (LP: #715611)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - double clicks should be disabled on bfb/Place launcher icon/double key
      press (LP: #766776)
    - [dash][launcher] Should use real transparency when a compositing manager
      is running (LP: #794042)
    - [dash] Thunderbird icon is pixelated (LP: #767115)
    - [panel] Hovering the mouse cursor over the BFB reveals the current
      window’s menu (LP: #793403)
    - [panel] Hovering the mouse cursor away from the appmenu applet doesn’t
      hide the menu (LP: #793406)
    - unity-2d: does not parse QT_GRAPHICSSYSTEM env var (LP: #791852)
    - Cannot drag applications from dash to desktop (LP: #756614)
  * debian/control:
    - unity-2d-panel recommends the indicator, not unity-2d
    - appmenu-gtk and appmenu-qt are already provided by indicator-appmenu
    - remove other meaningless recommends
  * debian/libunity-2d-private0.install:
    - install everything in Unity2d private directory

  [ Florian Boucault ]
  * debian/unity-2d-launcher.install:
    - do not install usr/lib/qt4/imports/UnityApplications/ anylonger as all of
      UnityApplications features have been moved to the Unity2d QML plugin
      installed by libunity-2d-private0
  * debian/control:
    - unity-2d-places and unity-2d-spread do not depend on unity-2d-launcher.
      All they need is now in libunity-2d-private0.
 -- Didier Roche <email address hidden> Tue, 14 Jun 2011 16:14:18 +0200

Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in ayatana-design:
status: Fix Released → Fix Committed
Didier Roche (didrocks) wrote :

There is no more bfb in Oneiric. This was done in Natty and acked by design then.

Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignn
removed: udo udp
tags: added: reviewedbydesign
removed: reviewedbydesignn
John Lea (johnlea) on 2011-10-19
tags: added: reviewedbydesigno
removed: reviewedbydesign
Didier Roche (didrocks) on 2011-10-19
tags: added: reviewedbydesign
removed: reviewedbydesigno
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers