dash translations are incomplete (likely a code bug, regression from new scopes version)

Bug #1158779 reported by Sebastien Bacher on 2013-03-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Christopher Townsend
Unity Home Scope
Medium
Christopher Townsend
libunity
Fix Released
Medium
Christopher Townsend
libunity (Ubuntu)
Medium
Christopher Townsend
Raring
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned
unity-scope-home (Ubuntu)
Undecided
Unassigned

Bug Description

Using the 100 scopes version (from the ppa), the dash search entry hint-text is not translated (e.g "Search Files & Folders"), the string didn't change, as far as I can tell, and is showing translated with the raring version, so that seems a regression in unity

Related branches

Sebastien Bacher (seb128) wrote :

the filters UI is also not correctly translated

affects: ubuntu → unity (Ubuntu)
Didier Roche (didrocks) on 2013-03-22
Changed in unity:
importance: Undecided → High
summary: - dash translations are incomplete
+ dash translations are incomplete (likely a code bug, regression from new
+ scopes version)
Didier Roche (didrocks) wrote :

list of projects that are to check for i18n (see the description):
https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1154229

Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
assignee: nobody → Christopher Townsend (townsend)
status: Confirmed → In Progress
Christopher Townsend (townsend) wrote :

I noticed that the hint text for the Dash home is not translated in other languages using Unity from the Raring archive. It still says "Search your computer and online sources". The other lenses hint text is translated.

I do see that none of the hint text is translated when using the"100 scopes" version of Unity though.

Christopher Townsend (townsend) wrote :

I was using Spanish in the last comment. I also noticed that when using Spanish, the "Search videos" hint text is also not translated in Unity from the Raring archive.

Seems translations are not very good to begin with let alone with the "100 scopes" test version.

Christopher Townsend (townsend) wrote :

I'm wondering if the branches/packages of unity-lens-* for the "100 scopes" PPA is set to use the Launchpad translations that the Raring archive packages use????

Christopher Townsend (townsend) wrote :

After chatting w/ seb128, I better understand how the Launchpad translations work and that is not the issue here.

But what I did find is that the lens search hints have switched places and is probably bungling up the translations. Previously, the hints were in /usr/share/unity/blah/blah.lens where blah is the type of lens. Now, they are in /usr/share/unity/scopes/blah.scope.

I will have to figure how this plays into the translations, but this is big clue where the problem lies.

Sebastien Bacher (seb128) wrote :

The string location shouldn't make any difference, as long as the gettext domain didn't change, just test with "gettext -d <domain> "string"" to see if the translation is available. (the "index" is only domain/string, there is no check on source/location)

Christopher Townsend (townsend) wrote :

Thanks Sebastien!

Looking at the new code, the place where the SearchHint was originally obtained (and translated) is no longer in the unity code. It has been moved to libunity-7.0, but looking at that code, it doesn't look like it does any locale translations.

I will dig deeper into that code and figure where to put the locale translating code.

Christopher Townsend (townsend) wrote :

I found another issue here. As I mentioned in comment #6, the new unity-lens-* packages have modified their configuration files. Looking at the new configuration files, all but the unity-lens-applications package has a new X-Ubuntu-Gettext-Domain now and they equal unity-scope-home. This domain does not exist (yet), so of course the translations will not occur.

As it stands now, this looks like a combination of libunity needing to handle getting the translated text along with the unity-lens-* packages setting the correct Gettext-Domain.

Changed in libunity:
status: New → In Progress
assignee: nobody → Christopher Townsend (townsend)
milestone: none → 7.0.0

To expand further on my last comment, the way this is now architected, it is the new unity-scopes-home package that is supposed to handle the translations for the unity-lens-* packages (except unity-lens-applications). Looking at the lp:unity-scopes-home project, it is not been set up for translations nor do I see any work being doing in Launchpad translations for this package either.

I will need to ask around to see if/when this is going to be done, so that it can be included in the language packs.

Err, that's supposed to be lp:unity-scope-home.

So, I think I have this narrowed down to why the translations aren't occurring.

1. The unity-scope-home defines the Gettext-Domain of unity-scope-home, but this domain does not exist yet, so nothing is going to be translated at all until this exists.
2. unity-scope-home also fails to to translate the search-hint. I will have a branch soon to fix that.
3. libunity-7.0 also fails to translate the search-hint. This search-hint is slightly different than the unity-scope-home search-hint in that this is the search-hint first shown when opening a scope, ie, the default. I will also have a branch soon to fix this as well.

Also, when the unity-scope-home domain is created, the filters will be translated as well.

As an experiment, I made a Spanish(es) version of the unity-scope-home domain and made test versions of libunity-7 and unity-scope-home and the Dash is much more translated now. I was still missing some translations in the unity-scope-home.mo file I created.

I'm marking the Unity bugs Invalid since the fix is other packages.

Changed in unity-scope-home:
status: New → In Progress
assignee: nobody → Christopher Townsend (townsend)
Changed in unity:
status: In Progress → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Changed in unity-scope-home:
importance: Undecided → Medium
Changed in libunity:
importance: Undecided → Medium

Even though I have MP's here to address this issue, it is important to note that until the unity-scope-home.mo files for all of the various languages are included, this still won't work.

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity-scope-home at revision 86, scheduled for release in unity-scope-home, milestone Unknown

Changed in unity-scope-home:
status: In Progress → Fix Committed
Michal Hruby (mhr3) on 2013-04-24
Changed in unity:
status: Invalid → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:~unity-team/libunity/libunity-7.0 at revision 368, scheduled for release in libunity, milestone Unknown

Changed in libunity:
status: In Progress → Fix Committed
Michal Hruby (mhr3) on 2013-05-01
Changed in unity:
status: In Progress → Fix Committed
no longer affects: libunity (Ubuntu)
no longer affects: unity (Ubuntu)
no longer affects: libunity (Ubuntu Raring)
Sebastien Bacher (seb128) wrote :

that seems to still be an issue in saucy in the version that landed in the archive?

Hey Sebastien,

I don't think anything has been done about comment #14. That part is really out of my domain. Should we add Ubuntu Translations to this?

Sebastien Bacher (seb128) wrote :

@Christopher: is the home scope including translations for other scopes?

Opening the files lens I see an hint in the entry "Search Files & Folders" ... the translation for this string is available in the langpack ("gettext -d unity-lens-music "Search Files & Folders" returns a translated string). Should that translation be used or did it move to another domain?

I believe they changed the domain to be in the Home scope for all scopes. I didn't architect that, so I have no idea if that is supposed to be correct. All I did for fix up libunity and the home-scope to accept translated strings.

Stephen M. Webb (bregma) on 2013-08-16
Changed in unity:
milestone: none → 7.1.0
status: Fix Committed → Fix Released
Michal Hruby (mhr3) on 2013-09-02
Changed in libunity:
status: Fix Committed → Fix Released
Changed in unity-scope-home:
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

raring has seen the end of its life and is no longer receiving any updates. Marking the raring task for this ticket as "Won't Fix".

Changed in libunity (Ubuntu Raring):
status: New → Won't Fix
Changed in unity (Ubuntu):
status: New → Fix Released
Changed in unity-scope-home (Ubuntu):
status: New → Fix Released
Changed in libunity (Ubuntu):
status: New → Fix Released
assignee: nobody → Christopher Townsend (townsend)
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers