[regression] HUD - No results from Indicator Menus

Bug #1072052 reported by Amr Ibrahim on 2012-10-27
178
This bug affects 64 people
Affects Status Importance Assigned to Milestone
Unity
Triaged
Low
Unassigned
hud (Ubuntu)
Low
Unassigned
Xenial
Low
Unassigned
indicator-appmenu (Ubuntu)
Low
Unassigned
Xenial
Low
Unassigned
unity (Ubuntu)
Low
Unassigned
Xenial
Low
Unassigned

Bug Description

HUD doesn't show results from the messaging menu. See screencast.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity 6.8.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
Date: Sat Oct 27 13:47:09 2012
InstallationDate: Installed on 2012-10-22 (5 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Amr Ibrahim (amribrahim1987) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Sami Jaktholm (sjakthol) on 2012-10-28
Changed in unity:
status: New → Confirmed
Changed in indicator-messages:
status: New → Confirmed
Sami Jaktholm (sjakthol) on 2012-10-28
Changed in indicator-messages (Ubuntu):
status: New → Confirmed
Lars Karlitski (larsu) on 2012-10-28
affects: indicator-messages → indicator-appmenu
affects: indicator-messages (Ubuntu) → indicator-appmenu (Ubuntu)
no longer affects: unity
no longer affects: unity (Ubuntu)
Changed in indicator-appmenu:
importance: Undecided → Medium
assignee: nobody → Lars Uebernickel (larsu)
status: Confirmed → Invalid
status: Invalid → Triaged
Lars Karlitski (larsu) wrote :

`killall hud-service` makes it work for me for some time. I haven't yet figured out what triggers it to not be working anymore.

Amr Ibrahim (amribrahim1987) wrote :

Confirming that 'killall hud-service' makes it work. BTW, HUD shows results normally from the messaging menu right after login.

Lars Karlitski (larsu) wrote :

The problem seems to be that libindicator owns the well-known bus name before indicator-messages exports its menus on the bus. hud-service tries to get the menus as soon as the name appears, but they aren't available at that time. Other indicators are also affected by this.

Lars Karlitski (larsu) wrote :

This wouldn't happen if unity wouldn't start hud-service on login. That's probably a small change that can be SRU'ed.

Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
milestone: none → 6.12.0
Changed in unity:
milestone: 6.12.0 → 7.0.0

If I run 'killall hud-service' it sttarts work, but if I receive a message on Empathy I cannot open the message by typing the name of the sender (it used to work on 12.04). If I kill hud-service after receive the message I can open the incomming message by typing the user name.

Amr Ibrahim (amribrahim1987) wrote :

No results from Onboard either, but 'killall hud-service' fixes it.

Is there any update on this?

I'm using Ubuntu 13.04 beta and it's still not fixed.

Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
milestone: 7.0.0 → 7.0.1
tags: added: raring
Amr Ibrahim (amribrahim1987) wrote :

What is the status of this bug?

In Ubuntu 13.10, HUD doesn't show any results from all indicators. Has this functionality been removed?

tags: added: saucy
Changed in indicator-appmenu (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in unity (Ubuntu):
importance: Undecided → Medium
Lars Karlitski (larsu) on 2014-03-12
Changed in indicator-appmenu:
assignee: Lars Uebernickel (larsu) → nobody
Changed in unity:
milestone: 7.0.1 → 7.3.1
Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
milestone: 7.3.1 → 7.3.2
TomasHnyk (sup) wrote :
summary: - [regression] HUD - No results from Messaging Menu
+ [regression] HUD - No results from Indicator Menus
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in hud (Ubuntu):
status: New → Confirmed
TomasHnyk (sup) wrote :

I do not think bug 1165420 is really a duplicate. It started only in 13.04, not in 12.10 like this one, this one seems to be about a race condition, that one is , to quote sabdfl:

"Feedback from engineers is that this is a regression caused by changes in Gtk, not a desired or planned outcome. It's on the list now, patches welcome if someone here wants to dig in."

Franko Burolo (fburolo) wrote :

I agree, the 2 are not related. In 12.10 the indicator menus were generally working, with occasional hiccups caused by race conditions, mostly (if not only) related to the messaging menu. Since 13.04, it just doesn't work at all. So basically, bug 1165420 is making this one invalid, as we first have to figure out that one, so we can fix this one, if it will still be a bug.
Unduplicate, please!

Amr Ibrahim (amribrahim1987) wrote :

Mmmm, but both have the same symptoms! And also all the indicators stopped working starting from 12.10 but not so many people were affected.

Maybe separate them for now until a developer looks into them.

Franko Burolo (fburolo) wrote :

Hm... Indeed, the bug description is pretty much what happens in this bug's descrioption. But the discussion going on was all about indicator not working in general, which is basically why I am subscribed to that bug. There is even an intervetion from Mark Shuttleworth. :-D

So, in the end, I don't know... Maybe as you said is the best, keep them separate for now, and let the devs decide.

Stephen M. Webb (bregma) on 2015-03-19
Changed in unity:
milestone: 7.3.2 → 7.3.3
tags: added: trusty wily
Changed in hud (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
tags: added: vivid
Will Cooke (willcooke) on 2015-08-26
tags: added: rls-w-incoming
Changed in unity:
importance: Undecided → Low
Changed in hud (Ubuntu):
importance: Medium → Low
no longer affects: indicator-appmenu
Changed in indicator-appmenu (Ubuntu):
importance: Medium → Low
Changed in unity (Ubuntu):
importance: Medium → Low
Changed in unity:
milestone: 7.3.3 → 7.4.0
tags: added: rls-x-incoming
removed: rls-w-incoming
Will Cooke (willcooke) on 2015-11-23
tags: removed: rls-x-incoming
tags: added: unity-backlog
tags: added: xenial
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers