Unable to access indicators from HUD

Bug #1165420 reported by Aleksi-ajp on 2013-04-06
408
This bug affects 86 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity HUD
Confirmed
High
Unassigned
hud (Ubuntu)
High
pierre

Bug Description

In Ubuntu 12.10 I was able to use HUD to access Messaging menu and Gwibber's "Update Status" option there, making status updates to Twitter easy and fast.
I could also use HUD to change my status in Empathy from Available to Busy and vice-versa.

In Ubuntu 13.04 Beta HUD no longer finds the "Update Status" option when typing "Update Status" or "Update"
Also writing "Available" "Away" or "Busy" no longer gives any results.

Other indicators however are accessible and I can use HUD to Suspend my computer or to view Skype status or Ubuntu one indicator options.

Repeating:
1. Press alt key to start HUD
2. Write "Update status" or "Available"

What was expected:
HUD should have shown options ether from Gwibber to Update Status or Empathy to change status to Available both available from the messaging indicator.

What happened:
HUD didn't find any results.

Notes:
I have Ubuntu 13.04 Beta 64bit upgraded from Ubuntu 12.10 64bits and I'm using proprietary fglrx drivers.

Aleksi-ajp (aleksi-ajp) wrote :
description: updated

This is very frustrating. In 12.04, changing my status via HUD probably accounts for 50% of what I use HUD for.

Ted Gould (ted) on 2013-05-28
Changed in hud:
status: New → Confirmed
importance: Undecided → Low
Daniel Woodworth (hdastwb) wrote :

I'm running 13.04 64-bit as well, and recently the HUD has been unable to pick up items from any of the indicators. I'm not sure wheter this is the same bug as it affects all of the indicators and not just the messaging one, but it seems like it might be related.

Should I open a new bug report?

summary: - Unable to access the messaging menu from HUD
+ Unable to access indicators from HUD
Changed in hud:
importance: Low → High
assignee: nobody → Ted Gould (ted)
Changed in hud (Ubuntu):
importance: Undecided → High
status: New → Triaged
Divan (divan-santana) wrote :

Ok with the latest saucy builds 13.10 the hud is not searching the indicators yet. Hopefully it will be fixed in time for 13.10 because it's very useful to search diodon and other indicators. HUD can still search the application menus though.
Not yet working in this build 13.10.1daily13.08.16.1-101.

Edwin Pujols (edwinpm5) wrote :

In saucy, no change yet. 2013-09-11.

It worked for my in Ubuntu 13.04, but not in 13.10, updated up to 2013-09-29. It can't also search in the configuration menu, so I can't suspend, log off, restart, shutdown... etc from the HUD as I used to do in 13.04.

Greg A (etulfetulf) wrote :

I've reported Bug #1233712 for the new Saucy part of the bug - shut down, etc

Ted Gould (ted) wrote :

While I think this feature was useful as well it was a design decision to only work on the focused app for now. There are a bunch of ideas on how to return this functionality, but they're not complete yet, so I'm closing this bug as it's not an engineering bug. When a design is complete, we'll add a work item in a blueprint to add the feature.

Changed in hud:
status: Confirmed → Opinion
Changed in hud (Ubuntu):
status: Triaged → Opinion

Please bring back this functionality.
Intergrating options across several applications was *the* benefit of the HUD. If I want to choose from the options of the currently focused applications, I can simply select the preferences menu. What made the HUD unique was that it showed options from several applications at the same time.
If you chose to change this and show only options from the current application, there is nothing left that the HUD can do over what the application already can.

Why do you kill one of the most innovative inventions ubuntu created since long? Now the HUD is no more than an application menu. This definitely was not what it was intended to be...?

Michael Weimann (m982) wrote :

I totally agree with Rüdiger.

diabloneo (diabloneo) wrote :

+1 on Rudiger

alex (xealits) wrote :

In saucy 13.10 when no application is active HUD still does not list "Suspend, Shut down, turn on/off wifi", which were so useful in 13.04.
Instead it shows commands to Nautilus (like "Connect to server", "New window", "Bookmarks" etc).

In fact at the moment no matter which application I open (LibreOffice Writer, gedit, Chromium and Firefox ...) HUD lists the same 5 commands to Nautilus.

David Roth (davrot) wrote :

Totally aggree with Rüdiger here. This is a huge step backward and I am really frustrated!
I cannot see any good reason for this change ... the old behavior was so productive and a really unique feature compared to other operating systems.

This is a bad decision! As David mentioned this massively reduces efficiency of our time tracking tool which was created specifically for Ubuntu and Unity!

David Roth (davrot) wrote :

Please also have a look at our example of how the old ubuntu HUD allowed us to massively increase time-tracking productivity in our business!

 - http://www.fusonic.net/en/blog/2013/02/08/ubuntu-awesomeness/

All gone in 13.10 ... this is why I am so disappointed.

I fully agree with David Roth.

Aaron Gerber (agerber85) wrote :

I agree with both Rudiger and David. This is a huge loss of functionality and a step backwards. I had grown quite accustomed to frequently controlling my app indicators for Pithos, Caffeine, and Transmission from HUD.

ricsdeol (ricardo.s.o.leite) wrote :

Ok guys, the best feature of the HUD is disabled! :(

Bruno Nova (brunonova) wrote :

I understand that focusing on the current application reduces the "mess" of results when I just want to find something in the application's menu, but being able to search the indicators was very useful.

Why not allow the user to press TAB (or another key) to switch between searching the app's menus and the indicators? (without forgetting to mention this in the HUD)

Michael Weimann (m982) wrote :

Maybe an alternative is to provide a system setting entry for choosing if the HUD displays indicator actions or not.

Alexander Troy (atroy) wrote :

Another solution is to add a priority to the current application, so if menu matches found it selects from the current application and then from others and if no menu match found in current app, then search like in 13.04..

Charles Kerr (charlesk) wrote :

I'm not sure that it makes sense to close this ticket as Opinion. There's no HUD spec discussing this issue, so let's let Design weigh in on this.

Marking as Incomplete for HUD + adding Ayatana as affected.

Changed in hud:
status: Opinion → Incomplete
Changed in hud (Ubuntu):
status: Opinion → Incomplete
Vincent (vinnl) wrote :

This is clearly a bug and not a design decision (at least, if this is the same issue as #1102493, which I think it is, and which has been marked as a duplicate). Note that the problem is not that you cannot access a non-focused application with the HUD - the problem is that *only* the messaging indicator is inaccessible through the HUD. Since other indicators _are_ accessible, this clearly is not a design decision.

(Note for example that it is also impossible to bring up a chat window though the HUD with someone who started an Empathy conversation with you and thus is listed in the messaging menu.)

Changed in hud:
status: Incomplete → Confirmed
Changed in hud (Ubuntu):
status: Incomplete → Confirmed
Changed in indicator-messages:
status: New → Confirmed
Changed in ayatana-design:
status: New → Confirmed
Lars Karlitski (larsu) wrote :

Yes, this is a bug, but not one in the messaging menu. The messaging service exports a menu which is shown by the panel. The HUD can access the same model on the bus, but doesn't.

no longer affects: indicator-messages
Aaron Gerber (agerber85) wrote :

Looks like HUD received an update on Saucy recently. Sadly, this problem was not resolved...

Hamish Downer (mishd) wrote :

@ted: I'm interested in the rationale behind this decision. Could you link to the documents about the design change? A wiki page, an email on a list? I've done a quick google and not found anything.

For those looking for workarounds, there are a couple on http://ubuntuforums.org/showthread.php?t=2181447 - the most reasonable being Alt-F10, left arrow, to get to the indicator menus. Nowhere near as good as the HUD, but do-able. Gnome-do would be another option.

David Roth (davrot) wrote :

@mishd: Alt+F10 is only an option if the menu-items you are looking for are in the first level of the menu and if there are only a few items.
If you have lots of menu items (probably nested in sub-menus), ALT+F10 + keyboard nav does not help.

Yes, a statement from @ted would be really appreciated.

Franko Burolo (fburolo) wrote :

It really would be appreciated. My experience with HUD-related bug reports till now has been quite negative... It's like whatever they are doing with the HUD, they don't want to communicate it to the community, which is quite frustrating. For example, the bug where the HUD didn't work with LibreOffice remained unassigned forever... Then in Saucy it just started to work again. But now we lost the Indicators... But at least now somebody told us it was really a (bad) design decision.

I would really like to see more communication about the HUD, as I think it is the best and most distinctive feature of Unity.

Aaron Gerber (agerber85) wrote :

Indeed, HUD management and communication has been quite poor for some time.

"When a design is complete, we'll add a work item in a blueprint to add the feature." Sounds a lot like "We're not ignoring you, we're just not going to pay attention to you right now." Perhaps that's why this bug was assigned to someone who, according to their own web page, prefers Yellow Dog Linux and Gnome.

(Don't misunderstand, this is not intended as an attack on Mr. Gould, about which I know very little. I'm simply voicing the general feeling that the community and their opinions and preferences are being neglected in favor of Canonical's grandiose designs for creating an OS experience more like those of Ubuntu's commercial competitors.)

Digby (k-ubuntu1) wrote :

Yes I totally agree with Rüdiger Kupper (#9)

I love the new way of working that Unity provides - easy keyboard shortcuts and minimal reliance on a 'mouse' pointing device.

Integrating options across several applications was *the* benefit of the HUD. If I want to choose from the options of the currently focused applications, I can simply select the preferences menu. What made the HUD unique was that it showed options from several applications at the same time...I suspect that some new users could have found that a tad confusing at first but ultimately for everyone the ability to access the indicators is a massive help.

- If this is a design decision we should not 'dumb-down' the HUD but re-implement HUD indicator searching.
- If this is a bug then I appreciate all the work that developers are doing and it would be really nice to get this fixed some time...

Thanks

AliNâ (alinajafi) wrote :

The bug exists in 14.04 trusty development branch too.

Theodore Dokos (t-dokos) wrote :

This was the only thing I ever used the HUD for, and it was the reason I thought the HUD was fantastic. Removing this was an incredibly poor decision.

This is surprising to me too, I'll ask around for the rationale.

Mark

I confirm this experience: I have not used the HUD for months now. Which indicates that it does not add to Ubuntu's usability any more.
Neither does it provide unique functionality (it merely is another way of accessing the application menu -- and that's against Ubuntu's design philosophy of providing only one way to accomplish things). Nor is it especially convenient, otherwise people would use it.

Sergei (markovs-i-mail) wrote :

We really need this fix.

Franko Burolo (fburolo) wrote :

@Rüdiger: I am actually using the HUD quite often as a fast and easy means to access menus, especially in apps where I do a lot of typing, like LibreOfffice, Firefox, Gedit etc... But I used to use it a lot also as a fast and easy means to access the indicators, and I do miss that feat. :-/

Mark Shuttleworth (sabdfl) wrote :

Feedback from engineers is that this is a regression caused by changes in Gtk, not a desired or planned outcome. It's on the list now, patches welcome if someone here wants to dig in.

Mark, that's good news! Looking forward to having the HUD back :-).

David Roth (davrot) wrote :

Thanks for the info @Mark.
I really hope this will be fixed soon and will get into the LTS!

kcpr (kcpr) wrote :

Bug still exists in Ubuntu 14.04. A year passed and still no changed?
This bug makes HUD just useless in most situations.
If there's not going to be any fix soon I would really need to consider switching to Gnome Shell...

Anyway I tried installing older package, with no luck really. HUD launched, but searching for anything just didn't work. Tried this one https://launchpad.net/~ubuntu-unity/+archive/daily-build/+build/4461354/+files/hud_13.04.0daily13.04.03-0ubuntu1_amd64.deb . Needed to remove libbamf3-1 from require dependences.

Franko Burolo (fburolo) wrote :

The bug was reported a year ago, but they have hopefully just started fixing it. First they told us this was a DESIGN DECISION, take a look at commect #8. but days before the Trusty release Mark intervened, and then he told us he was told it was a REGRESSION caused by some changes in gtk... So go and figure out... :-/ Anyhow, I doubt they were doing anything about it before Mark's intervention. But I do hope they really are working on this now. Some more feedback from the people doing it would also be nice. Since the HUD teams seems to be kind of autistic towards bug reporters -- they don't communicate much about them, which is pretty frustrating.

Aaron Gerber (agerber85) wrote :

I echo the sentiments in #36 by @fburolo. As part of my job, i have to work with specialized software that only runs on Windows. It's very feature-rich, but most of the features are buried two tiers deep in the menu structure with no easier way to get to them. If only Windows had HUD...

Scratch that. If only the software were still cross-platform...

Arto Jalkanen (ajalkane) wrote :

I just upgraded from 12.04 to 14.04, and want to add my frustration about this regression here.

I hope this will be fixed. The most used feature for hud for me was to change my IM status to "Available" or "Offline", or to do "Shutdown" or "Suspend" or whatever. HUD was really great there, with the current state it's not at all as usable as before.

1proton (1proton) wrote :

Hopefully, we will see the patches before the next LTS is rolled out.

This was the only thing I used HUD for .... accessing the network manage.

Franko Burolo (fburolo) wrote :

I really don't expect to see this patched anymore, until Unity 8 at least. It is a regression that no dev seemed to care about, in fact, it was stated it was a design decision, until Mr. Shuttleworth gave voice... And then it got seemingly ignored again, while most effort went into the mobile interface, which is now actively being ported and co-designed for desktop usage as Unity 8. The next LTS should be shipped with Unity 8 as default, so I guess we'll get whatever solution they have or have not, or hopefully will found for this in Unity 8. And let's cross our fingers there will be one, as the HUD team seems to be the most hermetic of all Ubuntu teams regarding community feedback, so you never know what really to expect with them, until it is done.

Amr Ibrahim (amribrahim1987) wrote :

Also see Bug #1072052

Franko Burolo (fburolo) wrote :

In 12.10 the indicator menus were generally working, with occasional hiccups caused by race conditions, mostly (if not only) related to the messaging menu. And that's what bug #1072052 is about. Since 13.04, however, the HUD just doesn't work at all with any indicators anymore. So basically, this bug is making #1072052 invalid, as we first have to figure out this one, so we can fix that one, if it will still be a bug.

[I am repeating myself, but it is for this bug's audience sake. :-)]

tags: added: regression-release trusty wily
TomasHnyk (sup) wrote :
tags: added: rls-x-incoming
Will Cooke (willcooke) on 2016-02-15
tags: added: rls-x-notfixing
removed: rls-x-incoming
Will Cooke (willcooke) wrote :

Sorry, wrong bug

Changed in hud:
assignee: Ted Gould (ted) → Marco Trevisan (Treviño) (3v1n0)
Changed in hud (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Confirmed → In Progress
assignee: Marco Trevisan (Treviño) (3v1n0) → nobody
Changed in hud:
assignee: Marco Trevisan (Treviño) (3v1n0) → nobody
Changed in hud (Ubuntu):
status: In Progress → Confirmed
pierre (pierrefischer) on 2018-10-29
Changed in hud (Ubuntu):
assignee: nobody → pierre (pierrefischer)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers