[fglrx] everything is black and blinks when using unity

Bug #819144 reported by Rafał Cieślak on 2011-08-01
178
This bug affects 33 people
Affects Status Importance Assigned to Milestone
Nux
Invalid
Undecided
Jay Taoko
Unity
Fix Released
Undecided
Unassigned
nux (Ubuntu)
Undecided
Jay Taoko
Oneiric
Undecided
Unassigned
unity (Ubuntu)
High
Canonical Desktop Experience Team
Oneiric
High
Canonical Desktop Experience Team

Bug Description

I am using Ubuntu Oneric. Recent updates (where recent means the last two weeks, I can't say when exactly it happened) broke my desktop completely.

Every part of the screen, I mean every button, label, checkboxes and other interface widgets, the panel, launcher, desktop itselt, window title panels, and probably even more elements turned into black rectangles. In some cases it's a flashing rectangle (launcher is simply black, but the wallpaper behind it flashes when I touch it with my mouse). In case of window titles this is just a black rectangle instead of window decoration. In case of buttons labels etc. they display OK, until I move the mouse over them, then they turn into this black rectangle, and get back to normal when I move the window (sometimes some parts of the window randomly switch back to normal, just as if the window was partially redrawn). In firefox, behavior is similar, but everything gets black when I scroll the page, and returns to normal when I switch the tab. In terminal, all characters I type are black rectangles and are not seen at all, but it gets redrawn properly when I move the window. The unity panel is not displayed at all (black).
I cannot see the desktop itself, it's whole black, unless I open an indicator's menu, when I can see both the full walpaper and the icons.

I tried both fglrx from the repos and from ati driver download site, the result is same.

Unity2D works okay, and that's what I use temporarily, but I never had problems with unity3D. Note this apport-bug report I collected when using the broken unity3D, hope that will be more useful.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.4.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-7.9-generic 3.0.0
Uname: Linux 3.0.0-7-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unitydialog,unityshell]
CompositorRunning: compiz
Date: Mon Aug 1 08:25:07 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 5.100.82.38+bdcom, 3.0.0-4-generic, x86_64: installed
 bcmwl, 5.100.82.38+bdcom, 3.0.0-5-generic, x86_64: installed
 bcmwl, 5.100.82.38+bdcom, 3.0-3-generic, x86_64: installed
 fglrx, 8.872, 3.0.0-7-generic, x86_64: installed
DpkgLog:

GraphicsCard:
 ATI Technologies Inc Mobility Radeon HD 3650 [1002:9591] (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:02a0]
JockeyStatus:
 kmod:wl - Sterownik urządzeń bezprzewodowych Broadcom STA (Własnościowy, Wyłączony, Nieużywany) [auto-install]
 xorg:fglrx - Własnościowy sterownik grafiki ATI/AMD FGLRX (Własnościowy, Wyłączony, Nieużywany)
MachineType: Dell Inc. Studio 1737
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-7-generic root=UUID=5475739e-9d60-42fb-87a7-b3b60dce11c0 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/11/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A05
dmi.board.name: 0P786H
dmi.board.vendor: Dell Inc.
dmi.board.version: A05
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A05
dmi.modalias: dmi:bvnDellInc.:bvrA05:bd02/11/2009:svnDellInc.:pnStudio1737:pvrA05:rvnDellInc.:rn0P786H:rvrA05:cvnDellInc.:ct8:cvrA05:
dmi.product.name: Studio 1737
dmi.product.version: A05
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.5.0-0ubuntu1
version.fglrx-installer: fglrx-installer N/A
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11~1-0ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11~1-0ubuntu4
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.2-1ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.0-3ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Changed in unity (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
importance: Undecided → High
status: New → Confirmed
summary: - everything is black and blinks when using unity
+ [fglrx] everything is black and blinks when using unity
Jean-Baptiste Lallement (jibel) wrote :

Rafal, do you see similar corruption to what is shown on the screenshot in bug 818630 ?
Could you attach a few screenshots please ?

Changed in unity (Ubuntu Oneiric):
status: Confirmed → Incomplete
tags: added: fglrx

I cannot. When I press PrintScreen everything gets redrawn and the screenshot looks as if nothing was wrong, expect for the panel and launcher, which are simply not visible at all (wallpaper is displayed instead).

I have, however, made some photos with my camera - hope this will be useful.

I have also noticed, that the screen is ALL black (except for the mouse pointer), if I have no applications opened. When I open one, I can see it and whole desktop, also, when I open a menu, for example by clicking where indicator should be seen, I can also see the whole wallpaper & icons, but they disappear when I close it.

One more photo.

The update to 4.6.0 did not change anything.

I have also noticed, that when I disable the Unity plugin with CompizConfig, all these artifacts disappear and everything is displayed properly. When I turn it back on, the problem returns.

Jean-Baptiste Lallement (jibel) wrote :

Thanks for the pictures. Setting to confirmed

Changed in unity (Ubuntu Oneiric):
status: Incomplete → Confirmed
Changed in nux (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-08-02
Changed in unity:
status: New → Confirmed
Didier Roche (didrocks) on 2011-08-02
Changed in nux:
status: New → Confirmed
Daniel Llewellyn (diddledan) wrote :

this appears to be a dupe of #818630

This may be related to #818630, as symptoms are similar, but on these screenshots the black areas look more randomly placed, while almost have control over them. I am not sure if that's exactly the same.

Jason Smith (jassmith) wrote :

If I had to guess. This looks like somehow the scissor clip state is not getting properly restored by the radeon driver at random. This *might* be fixed in trunk.

Bobby Graese (bobby-graese) wrote :

Following the guide at http://askubuntu.com/questions/28470/how-do-i-build-unity-from-source/28472#28472 I built the new nux and unity and ran unity. However, I'm still getting this bug. Is there any way I can check to make sure it's actually running the version of unity built from trunk? Is there some other debugging I could do to help out with this?

Omer Akram (om26er) wrote :

Does Unity work fine with the free driver? the one that comes with ubuntu pre installed.

I cannot tell at the moment, for I am affected by an another bug, which makes me unable to use the free driver.

Bobby Graese (bobby-graese) wrote :

@om26er -- I've had no troubles using the free driver with Unity.

Omer Akram (om26er) on 2011-08-05
Changed in nux:
assignee: nobody → Jay Taoko (jaytaoko)

I have the same issue with the fglrx driver and an ATI Radeon Mobility HD 4650 graphic card.

When I log in from LightDM to Unity 3D, I have a black screen with some small rectangles of the wallpaper. I can click on the session menu and log out, but windows appear with black areas, just like on the screenshot of #3.

Unity 2D session is working good.

tista (tista) wrote :

Same issues +1.

on Thinkpad X120e (Zacate, Radeon HD6310) with fglrx-8.872/catalyst-11.7.

Redmar (redmar) wrote :

I have this same issue (https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/816290) but in addition, the PC hangs if I try to shutdown/restart with the driver enabled. Should I file a separate bug-report for that?

I have the same problem in Oneiric
I have a Sony VAIO YB25 (Zacate, Radeon HD 6310)
However, I need to use nomodeset to activate 3D acceleration, the only problem is that I see some black rectangles everywhere.
Using the open driver is not an option, it works but it's so slow...

Note the bug is still present after installing recent unity, compiz and fglrx updates.

tista (tista) wrote :

@jfoc

Radeon is so slow?! no...no...
did you see my PPA?:
https://launchpad.net/~tista/+archive/x120e
it has latest mesa/Gallium3D for radeon. so which version did you use?
mine works with unity, gnome-shell, wayland, mutter, compiz, and almost everything... on the other hand, fglrx is?
Yeah absolutely damned!! X(

I think "work" is completely better than "not work" even if it didn't run so fast, isn't it?

I have this problem as well with Radeon HD 6480g. Open source drivers are not an option because they don't work at all (they cause a black screen on boot).

sorry, i don't need "nomodeset" with fglrx, it was a kernel updating problem with oneiric (dependency problems) but i've fixed it already, but i still see some black rectangles. I'm using Unity 2D now with fglrx, but it's not the same experience as using Unity 3D u.u, but at least i can see some HD videos and play games like Penumbra.

I'm using only the drivers and other packages provided by Oneiric. I've installed it using "Additional Drivers".

@tista, how do i use your PPA? or, do I have to install the packages manually?

@tista, lol, sorry, i did not read the steps in your PPA. you don't need to answer now ;)
I'll give it a try in a few hours.

@tista, I updated my system using your PPA in oneiric, but I can't update the fglrx driver... I tested the open source driver, but I don't get any improvements. When i try to install the fglrx driver it says:
------------------------------------------------------------------------------------------------------------------------
Se instalarán los siguientes paquetes extras:
  fglrx-amdcccle
Se instalarán los siguientes paquetes NUEVOS:
  fglrx fglrx-amdcccle
0 actualizados, 2 se instalarán, 0 para eliminar y 0 no actualizados.
Se necesita descargar 0 B/28,9 MB de archivos.
Se utilizarán 83,5 MB de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]? s
Seleccionando el paquete fglrx previamente no seleccionado.
(Leyendo la base de datos ... 177285 ficheros o directorios instalados actualmente.)
Desempaquetando fglrx (de .../fglrx_2%3a8.880~oneiric1_i386.deb) ...
Seleccionando el paquete fglrx-amdcccle previamente no seleccionado.
Desempaquetando fglrx-amdcccle (de .../fglrx-amdcccle_2%3a8.880~oneiric1_i386.deb) ...
Procesando disparadores para ureadahead ...
Configurando fglrx (2:8.880~oneiric1) ...
update-alternatives: error: la alternativa xorg_extra_modules no puede ser esclava de i386-linux-gnu_gl_conf: es un esclavo de gl_conf
dpkg: error al procesar fglrx (--configure):
 el subproceso instalado el script post-installation devolvió el código de salida de error 2
dpkg: problemas de dependencias impiden la configuración de fglrx-amdcccle:
 fglrx-amdcccle depende de fglrx; sin embargo:
 El paquete `fglrx' no está configurado todavía.
dpkg: error al procesar fglrx-amdcccle (--configure):
 problemas de dependencias - se deja sin configurar
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Se encontraron errores al procesar:
 fglrx
 fglrx-amdcccle
E: Sub-process /usr/bin/dpkg returned an error code (1)
jaime@Sion:~$
------------------------------------------------------------------------------------------------------------------------
it says that fglrx isn't configured yet... dependency problems i believe... :(

update-alternatives: error: la alternativa xorg_extra_modules no puede ser esclava de i386-linux-gnu_gl_conf: es un esclavo de gl_conf
-->update-alternatives: error: the alternative xorg_extra_modules can't be a slave of i386-linux-gnu_gl_conf: is a slave of gl_conf

tista (tista) wrote :

@jfoc

OK... see this thread:
http://ubuntuforums.org/showthread.php?t=1699238&page=41
and see the post around #409...

this installation issue caused fglrx's scripts. today we must use the alternatives as "arch-specified" instead of gl_conf. so the first you should run command:
sudo update-alternatives --remove-all gl_conf
and then you re-install fglrx, right?

finally today fglrx-8.881/catalyst-11.8 released on official site. so you could give it a try. this current release seems to solve the installation scripts issues:
http://ubuntuforums.org/showthread.php?t=1773851&page=10

Vanillalite (vanillasky26) wrote :

I can confirm I have the same issue. Someone from the Ubuntu+1 irc channel directed me to here. I can post some pics later if we want more of what the issue looks like. If you need any other info from me let me know.

2d Unity works ok for now until the regular Unity Ati card issue gets straightened out. Oh and for the record I have an Ati 4830 512meg card.

Gyula Pataki (mrfox) wrote :

Got it working with the latest upgrades, https://launchpad.net/~unity-team/+archive/compiz-testing ppa, and the latest fglrx from amd.com (not installed from the script, used ---buildpkg then dpkg install)

(Asus K50AB with a Radeon 4570)

This seems to be fixed with the latest update from Oneiric. I've reinstalled Oneiric because the fglrx driver messed up my system, now jockey-gtk doesn't work, so i needed to install the fglrx driver using apt-get, but I don't know why I need to use nomodeset in grub just to get 3D acceleration work, but the performance is really bad. If i don't use nomodeset then i can't use the console by pressing "alt+ctrl+Fx" because i see some garbage when I press a button and then, when i try to shutdown my machine, it simply shows a black or a gray screen and it doesn't really shutdown. I'll try again now that i've reinstalled my system just to see if fglrx work fine. The open source driver works a little more fa ster with the latest updates of compiz, but if the screen goes off, then when i move the mouse or when I press some button just to turn it on the screen starts flickering. That doesn't happen with the fglrx driver.

I can confirm that, as Gyula Pataki wrote, recent upgrades plus Catalyst 11.8 fixes this. Note that the compiz-testing PPA is not needed, at least in my case I got it working without this PPA (which was empty at the moment). Moreover, the fglrx from ubuntu repository still does not work with unity, so I guess we just need to wait until it's pushed to repos (or alternatively download 11.8 from ADM driver website).

@Rafal, if you're using the packages provided by Oneiric, then I guess that you've used apt-get or another thing different from "Additional Drivers" because it's not working. Remember that you still need to use "amdconfig --initial" if you're not using "Additional Drivers". If that doesn't work then try adding "nomodeset" at the end of the linux line in grub. You can edit that line in grub by pressing "e", then you can press "ctrl+x" just to boot linux if you've modified the line. I told you this because, in the case of my graphics card, I don't need to do all of this after using "Additional Drivers". Your card is in the list of the Supported Hardware. I had a similar problem, if this doesn't.

By the way, I had a lot of problems with fglrx, the uninstaller never does the job as it supposed to do it, because I've installed fglrx from http://wiki.cchtml.com and it worked, however, i decided to give fglrx (oneiric repository) a try, and then it didn't work, after hours I've decided to reinstall oneiric and it worked after that. I really don't understand how fglrx installer configures xorg, because deleting xorg.conf doesn't solve the problem :P.

@Jamie: I do have tried both this tricks, and still no luck! Luckily the 11.8 from website works. But I guess this may be card-specific, so this is rather unrelated to this bug, which seemed to originate from Unity.

Tim Cuthbertson (ratcheer) wrote :

After this afternoon's package updates (94 updates, many of them unity*), Unity 3d is now working with the latest fglrx (2:8.881-0ubuntu1) on my Oneiric system.

I hope it lasts a while.

I am happy to report that, like Tim, Unity 3D now works perfectly well with fglrx with the latest updates.

Vanillalite (vanillasky26) wrote :

Count me in as another person who's issue is fixed for now with the current state of updates! :)

Gyula Pataki (mrfox) wrote :

Just to report: I also installed the latest updates, and the fglrx from the official repositories, Unity works fine.

David Barth (dbarth) wrote :

Yes sorry, that was an fglrx specific workaround that got dropped in a branch reshuffle. We've verified the branches again and this fix should now be firmly merged into the release trunk.

Changed in nux:
status: Confirmed → Fix Released
Changed in unity:
status: Confirmed → Fix Released
Changed in nux (Ubuntu Oneiric):
status: Confirmed → Fix Released
Changed in unity (Ubuntu Oneiric):
status: Confirmed → Fix Released
Changed in nux:
status: Fix Released → Invalid
David Barth (dbarth) wrote :

For reference, that was a /compiz/ patch.

Barry Drake (b-drake) wrote :

'Additional Drivers' seems to be broken. I've just used apt-get install fglrx and it seemed to install. No problems, except now it won't do a clean shutdown. It gets to a strangely coloured screen and hangs. I have to turn off. At the moment, the daily build won't boot for me for the last few days. I am using an updated alpha 3.

Brad Figg (brad-figg) on 2011-09-02
tags: added: rls-mgr-o-tracking

I don't know what's happening, my session works perfectly... but the problem is that this happens when I use the Guest Account :S, the problem is the same, should i create another report?

This is loosely related, and since this bug has been already fixed,
please report a new one.

2011/10/15, Jaime Fernando Ortega Culaciati <email address hidden>:
> I don't know what's happening, my session works perfectly... but the
> problem is that this happens when I use the Guest Account :S, the
> problem is the same, should i create another report?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/819144
>
> Title:
> [fglrx] everything is black and blinks when using unity
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/nux/+bug/819144/+subscriptions
>

On 15/10/11 05:10, Jaime Fernando Ortega Culaciati wrote:
> I don't know what's happening, my session works perfectly... but the
> problem is that this happens when I use the Guest Account :S, the
> problem is the same, should i create another report?
>
Pleasecopy me in to the new report - I have the same bug. Also, after
installing fglrx, the session freezes on shutdown any number of times
until I restart with grub in restore mode - then it shuts down properly
and afterwards it works normally. This took place on two separate
installations. Also for me, there are two versions of fglrx - the first
(release edition) will not install.

Regards, Barry.

-- Barry Drake is a member of the the Ubuntu Advertising team.
http://ubuntuadverts.org/

mikhail-777 (wpr-oxym) wrote :

I don't have fglrx, but have the similar problem:
https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1071482
What I am doing wrong?

Changed in nux (Ubuntu):
status: Fix Released → Invalid
assignee: nobody → Jay Taoko (jaytaoko)
To post a comment you must log in.