X never sees brightness key release events on Dell laptops

Bug #261721 reported by William Grant on 2008-08-27
496
This bug affects 63 people
Affects Status Importance Assigned to Milestone
acpid (Ubuntu)
Undecided
Unassigned
Intrepid
Undecided
Unassigned
Jaunty
Undecided
Unassigned
linux (Ubuntu)
Medium
Tim Gardner
Intrepid
High
Stefan Bader
Jaunty
Medium
Tim Gardner
xorg-server (Ubuntu)
Undecided
Unassigned
Intrepid
Undecided
Unassigned
Jaunty
Undecided
Unassigned

Bug Description

Binary package hint: gnome-power-manager

Pressing either of the brightness keys brings up the g-p-m brightness OSD. This has changed recently such that it now steals keyboard focus. It eventually disappears, leaving corruption on the screen, giving my caret back. However, I can't type again until I switch to another VT and back.

It also sometimes doesn't appear at all, or just appears with some uninitialized texture (but still steals focus).
--

This is caused by X invoking autorepeat on the brightness keys, as it never appears to see a release event.

--

This is caused by a bug in the kernel that requires a Dell specific quirk. It has been fixed in -proposed.

Andrew Bennetts (spiv) wrote :

Something similar is happening to me. I've filed bug 282963 about it. It's probably related, maybe even a duplicate?

William Grant (wgrant) wrote :

The keypress events are actually repeating; X appears to never receive a release event, so invokes autorepeat.

We believe it's a kernel bug, but I've no idea where to look.

Changed in gnome-power-manager:
importance: Undecided → High
milestone: none → ubuntu-8.10
status: New → Triaged
William Grant (wgrant) on 2008-10-14
description: updated

i cannot confirm this. latest intrepid, intel 945gm graphics, 2.24.0-0ubuntu4 g-p-m, 2.6.27-7-generic kernel

Joakim Andersson (jocke) wrote :

I can confirm it on my Dell XPS M1330. The keys worked fine out of the box in Hardy but in Intrepid all my Fn+* keys are repeating.

The keyboard lockup problem only occurs for me when gnome-power-manager is running, and the problem can be removed by reverting the patch from bug 280646 (I.E. by changing "AnyModifier" to "0" on line 118 in gnome-power-manager's src/gpm-button.c).

Mario Limonciello (superm1) wrote :

The root of the problem though is that the kernel is not showing keyreleases for these keys. g-p-m might stack onto it with additional problems, but this root problem needs to be fixed first.

Joakim Andersson (jocke) wrote :

showkeys(1) run in console doesn't see Fn+* key releases either (not even when run with -s, as far as I can see).

kreggz (jasonkregting) wrote :

I can confirm this bug on a Dell M90

My bug report is a duplicate #285795

1. I installed Ubuntu Intrepid (8.10) on a Dell Precision M90
2. When Gnome starts up, off power, it will automatically change the brightness. When you move the mouse the brightness increases
3. If you manually change the brightness without moving the mouse, Gnome will stop being responsive and you can no longer use any menus or type anything.
4. I can reproduce this problem at any time by following the same steps
5. I am using the Nvidia 177 restricted driver

Ben Trusty (ben-trusty) wrote :

same problem on dell inspiron 1150
i have full range of brightness control
but the pop-up dialog only shows either no brightness or full brightness and does not update with brightness change

afterword the keyboard does not for any application (or gui), as well as clicking on 'applications / places / system' and most other items on the panels does not do anything.

Joakim Andersson (jocke) wrote :

I think I've found the solution for this problem (I've successfully fixed it on my laptop anyway).
Because of bug 207473 (or another one of the similar ones), I added "blacklist video" to a file in my /etc/modprobe.d/. I accidentally(?) removed it the other day and suddenly both showkey and X was getting Fn+* key release events (too many though, see bug 207473, but the same amount as the press events anyway).

When I add the blacklisting back, the problem reappears. I tried switching back and forth a few times, only changing the blacklisting between reboots, so this bug was (for me) _definitely_ caused by "blacklist video".

(I think kreggz problem is a totally different one, because my laptop doesn't care at all about the mouse regarding this problem. Also, he installed intrepid directly, while I upgraded from hardy, where the "blacklist video" fix was working just fine.)

Joakim Andersson (jocke) wrote :

An update to my last comment:

My brightness keys still work fine, and don't break X. However, my other Fn-keys (Suspend and battery state) are still broken (only triggers press events). Strange thing is, the battery state button definitely worked at least once when I wrote my last comment... I can't think of any reasonable cause for this re-breakage...

I'd like to confirm of this bug with gnome-power-manager 2.24.0-0ubuntu8 on kernel 2.6.27-7 on a Dell XPS M1330. I've tested this in a guest account and both with and without "visual effects" (compiz). Killing gnome-power-manager makes the brightness controls work correctly but is not optimal.

Like Joakim Andersson above I had previously added "blacklist video" to /etc/modprobe.d/blacklist and removing this solves the immediate problem of losing keyboard focus (but removes a workaround for bug 207473).

Graham Whelan (gawhelan) wrote :

Same issue with a Zepto Znote 6625wd except it affects the volume up/down media keys. showkey is recognizing press and release events for the other media keys, but only press events for the volume keys. All keys worked fine with Hardy.

Justin J Stark (justinjstark) wrote :

I have a Dell 1535 and have this problem. Pressing FN+up or FN+down causes the screen to change brightness but just pressing once seems to cause the key to "stick" and the brightness continues to change after I let go. When I finally get the brightness dialog to go away, X is unresponsive. The menus highlight but will not open and I cannot type anything.

insertnewsn (insertnewsn) wrote :

Same issue with Dell E1705.

Fn+Up or Fn+Down increases/decreases brightness as necessary, but then makes X unresponsive. Currently the only problem I have with Intrepid Ibex!

AaronMT (aaron-train) wrote :

Confirming same issue with Inspiron 1501

Fn+UP or Fn+Down increase and decrease brightness but lock up X afterwards, well at the same time my volume also changes not sure why.

Confirming as well for Dell Latitude D610

Fn+Up/fn+Down will trigger the BIOS to change the brightness, but it locks up X to all keyboard input and some mouse events.

Troy R. (dsm-iv-tr) wrote :

Confirming on Dell Vostro 1000: Fn+up/down 'steals' keyboard input.

The "fix" for me was to use the magic SysRq key to reset the keyboard from a virtual terminal - alt+prtscr+r - I don't know if it's the VT switching or the magic keycombo that fixes it, but this is clearly an input layer bug.

$ apt-cache policy gnome-power-manager
gnome-power-manager:
  Installed: 2.24.0-0ubuntu8
  Candidate: 2.24.0-0ubuntu8
  Version table:
 *** 2.24.0-0ubuntu8 0
        500 http://ca.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

$ apt-cache policy linux-image
linux-image:
  Installed: (none)
  Candidate: 2.6.27.7.11
  Version table:
     2.6.27.7.11 0
        500 http://ca.archive.ubuntu.com intrepid/main Packages

Renaud Muller (imagine2) wrote :

I also have the same problem on a dell inspiron 640m. Do I have to download a file using apt get? (I was not sure to understand the message following yours). Happy anyway to see that the bug has been noticed and discussed.

Troy R. (dsm-iv-tr) wrote :

@Renaud Muller:
I apologize for the confusing comment. The apt-cache lines I pasted indicate the versions of the packages I was referring to.

michote (michote) wrote :

same problem as gawhelan on Zepto 6615WD
see also bug 291612

Following up on my comment: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/261721/comments/16

After upgrading my image to 2.6.27-7-generic I am no longer experiencing the lock-up issues. As I type at this moment I have gone through the whole brightness range (FnUp/Down) and am still able to type and use menus. I had to manually change my menu.lst to use 2.6.27-7 as the installer for 8.10 by default keeps the current GRUB configuration and I had not realized until I ran a uname -r and saw 2.6.24. Here's my output from apt-cache and uname -r.

apt-cache policy gnome-power-manager
gnome-power-manager:
Installed: 2.24.0-0ubuntu8
Candidate: 2.24.0-0ubuntu8
Version table:
 *** 2.24.0-0ubuntu8 0
500 http://us.archive.ubuntu.com intrepid/main Packages
100 /var/lib/dpkg/status

apt-cache policy linux-image
linux-image:
Installed: (none)
Candidate: 2.6.27.7.11
Version table:
2.6.27.7.11 0
500 http://us.archive.ubuntu.com intrepid/main Packages

uname -r
2.6.27-7-generic

I'm assuming that most people commenting to this bug have checked which image they are running, however, it's something that can be overlooked when freaking out about a finger-memory keystroke that render X useless.

Stephen Gibson wrote:
> I'm assuming that most people commenting to this bug have checked which
> image they are running, however, it's something that can be overlooked
> when freaking out about a finger-memory keystroke that render X useless.

It is worth checking. :)

Just to confirm, I still see the problem, and my system is as up to date as
yours:

$ apt-cache policy linux-image
linux-image:
  Installed: (none)
  Candidate: 2.6.27.7.11
  Version table:
     2.6.27.7.11 0
        500 http://au.archive.ubuntu.com intrepid/main Packages

$ uname -r
2.6.27-7-generic

My system is a Dell Inspiron 630m.

Confirming- same problem on my Dell Inspiron 600m. Just updated to Intrepid from Hardy.

Toco (toco8804) wrote :

Pretty sure i fixed the problem with my laptop. (i have a 2 year old e1505)

To make a long and relatively painful story short on how I fixed it for my laptop i'll just say i uninstalled laptop-power-tools and everything associated with it in synaptic and i havn't lost keyboard functionality yet.

Should probably include that i uninstalled gnome-power-manager first and that didn't work so i uninstalled laptop-power-tools and that fixed it. I reinstalled gnome-power-manager and it still works.

I really don't know if this will help me or if you guys want to try it because i basically just went in blind and just started uninstalling things without knowing what they do.

For me it doesn't happens with the brightness key but when I change the volume, Im using a Toshiba U305, as already reported switching to a virtual terminal, pressing alt+prtscr+r and returning to X make the keyboard and right click work again. Its really anoying.

I think that you need to look a little closer at what's actually
happening for these "Release" events possibly. Try starting a Failsafe
Terminal at your login screen. If you run xev over there, you'll see
that a KeyRelease event is somehow generated, however it is *followed*
by the KeyPress event. The two being out of order may be confusing
gnome's keyboard handler and gnome power manager.

Edmundo Valle Neto wrote:
> For me it doesn't happens with the brightness key but when I change the
> volume, Im using a Toshiba U305, as already reported switching to a
> virtual terminal, pressing alt+prtscr+r and returning to X make the
> keyboard and right click work again. Its really anoying.
>
>

--
Mario Limonciello
*Dell | Linux Engineering*
<email address hidden>

Mario Limonciello wrote:
> I think that you need to look a little closer at what's actually
> happening for these "Release" events possibly. Try starting a Failsafe
> Terminal at your login screen. If you run xev over there, you'll see
> that a KeyRelease event is somehow generated, however it is *followed*
> by the KeyPress event. The two being out of order may be confusing
> gnome's keyboard handler and gnome power manager.

I can confirm this. Running xev from a failsafe terminal shows a KeyRelease event being generated before the KeyPress. Both are generated when the key is pressed down and no event is generated when the key is physically released.

$ xev

...

MotionNotify event, serial 23, synthetic NO, window 0x400001,
    root 0x13b, subw 0x0, time 1128533, (120,116), root:(122,118),
    state 0x0, is_hint 0, same_screen YES

KeyRelease event, serial 23, synthetic NO, window 0x400001,
    root 0x13b, subw 0x0, time 1129930, (120,116), root:(122,118),
    state 0x0, keycode 123 (keysym 0x1008ff13, XF86AudioRaiseVolume), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyPress event, serial 23, synthetic NO, window 0x400001,
    root 0x13b, subw 0x0, time 1129930, (120,116), root:(122,118),
    state 0x0, keycode 123 (keysym 0x1008ff13, XF86AudioRaiseVolume), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

MotionNotify event, serial 26, synthetic NO, window 0x400001,
    root 0x13b, subw 0x0, time 1132703, (136,128), root:(138,130),
    state 0x0, is_hint 0, same_screen YES

...

I have the same problem on my Dell Inspiron 6000 as stated in bug description but I don't lose only a keyboard focus but also a part of the mouse functionality. For example I can't move windows, maximize or minimize it. Also I can't use my menu bar - clicking on Places or Applications do not unroll a menu. Everything back to work after switching to other VT and back.

Tim Gardner (timg-tpi) wrote :

I think this bug is related to #284066. Once that kernel version is in -proposed, please mark this report as a duplicate (if it is indeed the correct fix).

Changed in xorg-server:
status: New → Invalid
Brenden Bain (brendenbain) wrote :

Works for me after the upgrade to 2.6.27-8 in -proposed.

While the backlight setting seems to work, the dialog that used to come up in 8.04 showing the adjustment is no longer showing at all in 8.10.

Exactly the same on my system. Backlight setting works after upgrade to 2.6.27-8, but the dialogue doesn't show since 8.10.

Dimitrios Symeonidis (azimout) wrote :

can everyone who reported this problem please upgrade to 2.6.27-8 (from the -proposed repository) and confirm that the issue is fixed for them?

thank you

kreggz (jasonkregting) wrote :

I can confirm this has fixed the problem.

This is great!!! Thanks everyone!

Essence (bryanmcconkey) wrote :

This bug seems similar (identical?) to this one
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/294791

stryderjzw (stryderjzw-gmail) wrote :

Upgrading to 2.6.27-8 (in proposed) has fixed the problem for me! thanks.

Ben Trusty (ben-trusty) wrote :

"can everyone who reported this problem please upgrade to 2.6.27-8 (from the -proposed repository)"

it does NOT work for me
there is no change in the results from using fn+up/down for brightness up/down

the pop-up shows, though the horizontal meter does not move the brightness does adjust
this STILL does cause the keyboard and responsive failure.
no menus, no moving windows with mouse.

suggestions?

mbeach (mbeaches) wrote :

upgrading to 2.6.27-8 today has fixed this issue for me on a Dell Studio 1735. Fn+Up/Down works as expected.

Cory (cory-northwinddesign) wrote :

I can confirm that upgrading to 2.6.27-8 fixed the brightness issue.

Essence (bryanmcconkey) wrote :

I have upgraded to 2.6.27-8 and the steps I used to take to reproduce this problem no longer work, so far it seems fixed from that change. (Dell Inspiron 6400)

For me it didn't worked, but my problem is a little different (the same problem with the function key that controls the volume), any suggestion?

Changed in linux:
status: Triaged → Fix Released
Changed in linux:
status: Fix Released → Fix Committed
description: updated
Changed in linux:
assignee: nobody → timg-tpi
milestone: ubuntu-8.10 → intrepid-updates
Changed in acpid:
status: New → Invalid
Changed in linux:
assignee: timg-tpi → nobody
importance: High → Undecided
milestone: intrepid-updates → none
status: Fix Committed → Invalid
assignee: nobody → timg-tpi
importance: Undecided → High
milestone: none → intrepid-updates
status: New → Fix Committed
Changed in acpid:
status: New → Invalid
Changed in xorg-server:
status: New → Invalid
39 comments hidden view all 119 comments
Mario Limonciello (superm1) wrote :

No, this fix is a dmidecode fix that matches on Dell strings. Something different will be needed for that bug, probably similar to this:

http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-intrepid.git;a=blobdiff;f=drivers/input/keyboard/atkbd.c;h=1aa2eaf59458ed1d4fc619f2ea575e1e170b3ac7;hp=c694eaae79869e364055c732dbdef44476c9a912;hb=aa085ec46c542ebcb952c41409a23ceb72d92664;hpb=0feccfbc02792f9555bd77aa611b863f82974214

It will have to match on the particular brands and models found in different bugs, which is why these should be treated as separate bugs.

On Mon, Jan 19, 2009 at 05:32:01PM -0000, klerfayt wrote:
> However the fix used to get around "most Fn keys on Dell laptops do not generate release event" would be similar if not exactly same for other brands of laptops:
> "generate release events ourselves"

Generally quirk based fixes such as these are very specific to the machine
that they apply to, they change specific keys with specific numbers.
We therefore try and maintain that single machine focus for each bug.
If the bug is not focused very tightly then the general bug would never
get completed and that would make it hard for any one laptop owner to
know if their laptop was supposed to be fixed or not.

Kashi Gorton (flash87) wrote :

So what's the status of this bug? I understand that a previous kernel release fixed the bug for the vendor id = "Dell Inc." case, but the vendor id = "Dell Computer Cooperation" case has not (yet?) made it into proposed: verified on my Inspiron 1100, the latest proposed does not fix the bug.

Kashi Gorton (flash87) wrote :

this guy https://bugs.launchpad.net/ubuntu/+source/linux/+bug/285323/comments/88 states it clearly,

my output for sudo dmidecode | grep Vendor:
Vendor: Dell Computer Corporation
(sorry... misspelling in last comment)

So extending the fix has been suggested a few times:
http://marc.info/?l=linux-kernel&m=122650907006352&w=2
http://marc.info/?l=linux-kernel&m=123055061901679&w=2
http://marc.info/?l=linux-kernel&m=123056100215208&w=2

so it's queued for .29, when is this going to appear in -proposed?

Rafac24 (cabanas86) wrote :

Dell Inspiron B130

I upgraded to kernel 27-11 using the -proposed (all 'generic') and it did fix the issue with the Fn/Brightness.
But, it created another issue in that all networking capabilities were lost. It would not register my Wireless card and I tried plugging into eth0 and it wouldnt register that either.

I had to revert back to kernel 27-9 on startup.

I've only had Ubuntu for a month now. Should i have updated other files besides 'generic' ones?

Thanks.

Robert (robrwo) wrote :

I'm having a similar problem with a Lenovo ThinkPad R61i.

Mario Limonciello (superm1) wrote :

This bug has been fixed by intrepid-updates. If you continue to have problems with a non Dell laptop, please open a NEW bug.

Changed in linux:
status: Fix Committed → Fix Released
Kashi Gorton (flash87) wrote :

The problem has only been partially fixed by released updates, as I said in my previous post the bug has been fixed for the vendor string "Dell Inc." but not for "Dell Computer Corporation". This is exactly the same bug, it's just older Dells with the same bug have a different vendor ID for some reason. The latest kernell (2.6.27-11.27) does not fix the issue on my Inspiron 1100.

Changed in linux:
status: Fix Released → Fix Committed
Alexander Lampret (alamp4kf) wrote :

I have this bug too, on my "FUJITSU SIEMENS PA1510" !!! Not a Dell Laptop

Kashi Gorton (flash87) wrote :

If it isn't a Dell laptop, it isn't the same bug, file a new bug report. If it's exactly the same cause, i.e. brightness function keys reporting a down but not an up, then the solution will be similar but laptop vendor, possibly even laptop model, specific. This bug is treating Dell laptops with this issue. If yours is not a Dell laptop, then file a separate bug report.

https://help.ubuntu.com/community/ReportingBugs

Connor Imes (ckimes) wrote :

Agreed, this is not fixed for Vendor string "Dell Computer Corporation" in Intrepid kernel 2.6.27-11.27-generic, or in Jaunty on the latest kernel 2.6.28-6.16-generic. My laptop is a Dell 600m, I have a duplicate bug filed.

Setting back to Triaged, but if more information is still needed, please ask and we shall provide. Thank you.

Changed in linux:
status: Fix Committed → Triaged

The fix for this is to update 'drivers/input/keyboard/atkbd.c' to widen the Dell DMI signatures:

The fix for this is commit 2a3ec3265741c3b2a7ebbd1b33f538e5a5583c48 in Linus' tree:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=2a3ec3265741c3b2a7ebbd1b33f538e5a5583c48

Tim Gardner (timg-tpi) wrote :
Changed in linux:
assignee: nobody → timg-tpi
importance: Undecided → Medium
milestone: none → jaunty-alpha-5
status: Invalid → Fix Committed
assignee: timg-tpi → stefan-bader-canonical

most recent ubuntu 8.10 proposed update (last night)
2.6.27-11-generic

still broken

On Sat, Jan 31, 2009 at 2:37 PM, Tim Gardner <email address hidden>wrote:

> http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-
> jaunty.git;a=commit;h=bf9b51b29cab40295dfc5d79289bd389f24b7b06
>
> ** Changed in: linux (Ubuntu Jaunty)
> Importance: Undecided => Medium
> Assignee: (unassigned) => Tim Gardner (timg-tpi)
> Status: Invalid => Fix Committed
> Target: None => jaunty-alpha-5
>
> ** Changed in: linux (Ubuntu Intrepid)
> Assignee: Tim Gardner (timg-tpi) => Stefan Bader
> (stefan-bader-canonical)
>
> --
> X never sees brightness key release events on Dell laptops
> https://bugs.launchpad.net/bugs/261721
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "acpid" source package in Ubuntu: Invalid
> Status in "linux" source package in Ubuntu: Fix Committed
> Status in "xorg-server" source package in Ubuntu: Invalid
> Status in acpid in Ubuntu Intrepid: Invalid
> Status in linux in Ubuntu Intrepid: Triaged
> Status in xorg-server in Ubuntu Intrepid: Invalid
> Status in acpid in Ubuntu Jaunty: Invalid
> Status in linux in Ubuntu Jaunty: Fix Committed
> Status in xorg-server in Ubuntu Jaunty: Invalid
>
> Bug description:
> Binary package hint: gnome-power-manager
>
> Pressing either of the brightness keys brings up the g-p-m brightness OSD.
> This has changed recently such that it now steals keyboard focus. It
> eventually disappears, leaving corruption on the screen, giving my caret
> back. However, I can't type again until I switch to another VT and back.
>
> It also sometimes doesn't appear at all, or just appears with some
> uninitialized texture (but still steals focus).
> --
>
> This is caused by X invoking autorepeat on the brightness keys, as it never
> appears to see a release event.
>
> --
>
> This is caused by a bug in the kernel that requires a Dell specific quirk.
> It has been fixed in -proposed.
>

On my Dell Inspiron 5100 laptop(bought 5 years ago), brightness keys and any other function kets works fine.

DOH, Forgot to tell you that I am rinning Ubuntu 8.10 2.6.27-9-generic i686

nanotube (nanotube) wrote :

Problem still persists with the latest intrepid kernel update (2.6.27-11-generic) here on Dell Inspiron 5150.

dmidecode says manufacturer is "Dell Computer Corporation"

On Sun, Feb 01, 2009 at 02:41:13PM -0000, nanotube wrote:
> Problem still persists with the latest intrepid kernel update
> (2.6.27-11-generic) here on Dell Inspiron 5150.
>
> dmidecode says manufacturer is "Dell Computer Corporation"

The fix as committed will be in the next Jaunty kernel, it is not yet
released so that is probabally expected.

I actually never had any problem with brightness and sound keys on Ubuntu, other distributions I have had problems oddly enough including Debian.

Launchpad Janitor (janitor) wrote :
Download full text (7.3 KiB)

This bug was fixed in the package linux - 2.6.28-7.18

---------------
linux (2.6.28-7.18) jaunty; urgency=low

  [ Alok Kataria ]

  * SAUCE: (drop after 2.6.29) x86: add a synthetic TSC_RELIABLE feature
    bit
    - LP: #319945
  * SAUCE: (drop after 2.6.29) x86: add X86_FEATURE_HYPERVISOR feature bit
    - LP: #319945
  * SAUCE: (drop after 2.6.29) x86: Hypervisor detection and get tsc_freq
    from hypervisor
    - LP: #319945
  * SAUCE: (drop after 2.6.29) x86: Add a synthetic TSC_RELIABLE feature
    bit.
    - LP: #319945
  * SAUCE: (drop after 2.6.29) x86: Skip verification by the watchdog for
    TSC clocksource.
    - LP: #319945
  * SAUCE: (drop after 2.6.29) x86: VMware: Fix vmware_get_tsc code
    - LP: #319945
  * SAUCE: (drop after 2.6.29) x86: vmware: look for DMI string in the
    product serial key
    - LP: #319945

  [ Andy Whitcroft ]

  * SAUCE: toshiba_acpi -- pull in current -dev version of driver
    - LP: #269831
  * SAUCE: toshiba_acpi -- add acpi hotkey kernel thread
    - LP: #269831
  * move toshiba laptops back from tlsup to toshiba_acpi
    - LP: #269831

  [ Aneesh Kumar K.V ]

  * SAUCE: (revert before 2.6.28.y update) ext4: Fix the delalloc
    writepages to allocate blocks at the right offset.
  * SAUCE: (revert before 2.6.28.y update) ext4: avoid ext4_error when
    mounting a fs with a single bg
  * SAUCE: (revert before 2.6.28.y update) ext4: Don't overwrite
    allocation_context ac_status
  * SAUCE: (revert before 2.6.28.y update) ext4: Add blocks added during
    resize to bitmap
  * SAUCE: (revert before 2.6.28.y update) ext4: Use
    EXT4_GROUP_INFO_NEED_INIT_BIT during resize
  * SAUCE: (revert before 2.6.28.y update) ext4: cleanup mballoc header
    files
  * SAUCE: (revert before 2.6.28.y update) ext4: don't use blocks freed but
    not yet committed in buddy cache init
  * SAUCE: (revert before 2.6.28.y update) ext4: Fix race between
    read_block_bitmap() and mark_diskspace_used()
  * SAUCE: (revert before 2.6.28.y update) ext4: Fix the race between
    read_inode_bitmap() and ext4_new_inode()
  * SAUCE: (revert before 2.6.28.y update) ext4: Use new buffer_head flag
    to check uninit group bitmaps initialization
  * SAUCE: (revert before 2.6.28.y update) ext4: mark the blocks/inode
    bitmap beyond end of group as used
  * SAUCE: (revert before 2.6.28.y update) ext4: Don't allow new groups to
    be added during block allocation
  * SAUCE: (revert before 2.6.28.y update) ext4: Init the complete page
    while building buddy cache
  * SAUCE: (revert before 2.6.28.y update) ext4: Fix s_dirty_blocks_counter
    if block allocation failed with nodelalloc

  [ Hannes Eder ]

  * SAUCE: (drop after 2.6.29) x86: vmware - fix sparse warnings
    - LP: #319945

  [ Luke Yelavich ]

  * hid modules have hyphens instead of underscores in their names

  [ Mark Fasheh ]

  * SAUCE: (revert before 2.6.28.y update) jbd2: Add BH_JBDPrivateStart

  [ Theodore Ts'o ]

  * SAUCE: (revert before 2.6.28.y update) ext4: Add support for non-native
    signed/unsigned htree hash algorithms
  * SAUCE: (revert before 2.6.28.y update) ext4: tone down
    ext4_da_writepages warnings
  * SAUCE: (revert before 2.6.28.y...

Read more...

Changed in linux:
status: Fix Committed → Fix Released
nanotube (nanotube) wrote :

will this latest kernel be released for intrepid? or is it jaunty-only?

Andy Whitcroft (apw) wrote :

On Thu, Feb 05, 2009 at 05:18:43PM -0000, nanotube wrote:
> will this latest kernel be released for intrepid? or is it jaunty-only?

This is a Jaunty kernel only. Intrepid is carrying the 2.6.27 series of
kernels.

Tim Abell (tim-abell) wrote :

I'm a bit confused, having read all the comments.
I have an inspiron 8500, which reports "Dell Computer Corporation" in dmidecode. So I don't appear to benefit from the fix in 2.6.27-11.

Does the above comment
> This is a Jaunty kernel only.
 mean that I won't get this fix until I upgrade to Jaunty in April? ( https://wiki.ubuntu.com/JauntyReleaseSchedule ).

If so, should I use the blacklist workaround mentioned, and what are the side effects? (Seeing as I have no idea doing that actually means.)

wolfie2x (wolfie2x) wrote :

2.6.27-11 fixed about 90% of the problem for me on Intrepid. (Dell Inspiron 9400; Vendor Str="Dell Inc.". g-p-m 2.24.0-0ubuntu8.2; system fully up-to-date)

The problem now is:
The OSD is displayed but progress bar increment/decrement is in small steps (min brightness at 50% mark). If the progress bar is brought down to 0% mark, brightness doesn't change there after at all (At this point progress bar will move in larger steps though). Brightness works again after killing g-p-m and starting again.

Looks like the kernel bug is fixed but there's still a g-p-m bug. Should I update https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/304187, report a new bug or just continue here?

Stefan Bader (smb) wrote :

The patch "Input: atkbd - broaden the Dell DMI signatures" has been applied to Intrepid by the update to 2.6.27.15 (see LP bug #328652)

Changed in linux:
status: Triaged → Fix Committed

2.6.27-12-generic (latest proposed update)
still broken on dell inspiron 1150

On Fri, Feb 20, 2009 at 11:15 AM, Stefan Bader
<email address hidden>wrote:

> The patch "Input: atkbd - broaden the Dell DMI signatures" has been
> applied to Intrepid by the update to 2.6.27.15 (see LP bug #328652)
>
> ** Changed in: linux (Ubuntu Intrepid)
> Status: Triaged => Fix Committed
>
> --
> X never sees brightness key release events on Dell laptops
> https://bugs.launchpad.net/bugs/261721
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "acpid" source package in Ubuntu: Invalid
> Status in "linux" source package in Ubuntu: Fix Released
> Status in "xorg-server" source package in Ubuntu: Invalid
> Status in acpid in Ubuntu Intrepid: Invalid
> Status in linux in Ubuntu Intrepid: Fix Committed
> Status in xorg-server in Ubuntu Intrepid: Invalid
> Status in acpid in Ubuntu Jaunty: Invalid
> Status in linux in Ubuntu Jaunty: Fix Released
> Status in xorg-server in Ubuntu Jaunty: Invalid
>
> Bug description:
> Binary package hint: gnome-power-manager
>
> Pressing either of the brightness keys brings up the g-p-m brightness OSD.
> This has changed recently such that it now steals keyboard focus. It
> eventually disappears, leaving corruption on the screen, giving my caret
> back. However, I can't type again until I switch to another VT and back.
>
> It also sometimes doesn't appear at all, or just appears with some
> uninitialized texture (but still steals focus).
> --
>
> This is caused by X invoking autorepeat on the brightness keys, as it never
> appears to see a release event.
>
> --
>
> This is caused by a bug in the kernel that requires a Dell specific quirk.
> It has been fixed in -proposed.
>

Martin Pitt (pitti) wrote :

Accepted linux into intrepid-proposed; please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

maraja (ugo-grandolini) wrote :

Problem still persists with the latest intrepid kernel update (2.6.27-11-generic) here on Dell XPS 1330, Bios A15.
Ubuntu 8.10
Attached my dmidecode.

Also (maybe there is another report?) using the OSD buttons to increase/decrease volume show on the screen the indicator that the volume is changed but, actually, the volume on Volume Applet/Alsa mixer does not change.
Used to work on Ubuntu 8.04.

Bryan Quigley (bryanquigley) wrote :

My dmidecode | grep Vendor is Vendor: Dell Computer Corporation

I'm using the latest proposed - 2.6.27-13-generic.

It's fixed for me! Thank you.

Kashi Gorton (flash87) wrote :

Bryan: the linux that appeared in proposed for me was 2.6.27-12. What's going on?

The bug still persists for me, by the way...

Kashi Gorton (flash87) wrote :

/proc/version:
Linux version 2.6.27-12-generic (buildd@palmer) (gcc version 4.3.2 (Ubuntu 4.3.2-1ubuntu12) ) #1 SMP Thu Feb 5 09:26:35 UTC 2009

sudo dmidecode | grep Vendor:
Vendor: Dell Computer Corporation

It won't auto update you to it yet, it's waiting for external drivers to
build perhaps?
I manually installed it, cause my laptop doesn't require any.

If you do a search for 2.6.27-13 it should come up and you could give it a
try (but it might break prop. drivers until they get built). Alternatively
you could just wait for them to finish building.

The reason 2.6.27-13 isn't automatically installed is that, for some strange reason, linux-image-generic wasn't updated, and still points to -12...

To see this for yourself, run "aptitude why linux-image-2.6.27-12-generic", and it will tell you that it's automatically installed because you have installed linux-image-generic. Then do "aptitude show linux-image-generic, and it will tell you it depends on 2.6.27-12

Kashi Gorton (flash87) wrote :

/proc/version:
Linux version 2.6.27-13-generic (buildd@palmer) (gcc version 4.3.2 (Ubuntu 4.3.2-1ubuntu12) ) #1 SMP Thu Feb 26 07:26:43 UTC 2009

... and it's fixed and working like a dream :) thanks guys! Mucho appreciatoed. Proposed now points at the right files, and my brightness is adjustable again, all is right in the world.

Dimitrios Symeonidis [2009-03-01 21:00 -0000]:
> The reason 2.6.27-13 isn't automatically installed is that, for some
> strange reason, linux-image-generic wasn't updated, and still points to
> -12...

It is updated now.

Martin
--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

latest kernel update fixed mine
dell inspiron 1150
2.6.27-13-generic

On Tue, Mar 3, 2009 at 3:30 AM, Martin Pitt <email address hidden> wrote:

> Dimitrios Symeonidis [2009-03-01 21:00 -0000]:
> > The reason 2.6.27-13 isn't automatically installed is that, for some
> > strange reason, linux-image-generic wasn't updated, and still points to
> > -12...
>
> It is updated now.
>
> Martin
> --
> Martin Pitt | http://www.piware.de
> Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)
>
> --
> X never sees brightness key release events on Dell laptops
> https://bugs.launchpad.net/bugs/261721
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “acpid” source package in Ubuntu: Invalid
> Status in “linux” source package in Ubuntu: Fix Released
> Status in “xorg-server” source package in Ubuntu: Invalid
> Status in acpid in Ubuntu Intrepid: Invalid
> Status in linux in Ubuntu Intrepid: Fix Committed
> Status in xorg-server in Ubuntu Intrepid: Invalid
> Status in acpid in Ubuntu Jaunty: Invalid
> Status in linux in Ubuntu Jaunty: Fix Released
> Status in xorg-server in Ubuntu Jaunty: Invalid
>
> Bug description:
> Binary package hint: gnome-power-manager
>
> Pressing either of the brightness keys brings up the g-p-m brightness OSD.
> This has changed recently such that it now steals keyboard focus. It
> eventually disappears, leaving corruption on the screen, giving my caret
> back. However, I can't type again until I switch to another VT and back.
>
> It also sometimes doesn't appear at all, or just appears with some
> uninitialized texture (but still steals focus).
> --
>
> This is caused by X invoking autorepeat on the brightness keys, as it never
> appears to see a release event.
>
> --
>
> This is caused by a bug in the kernel that requires a Dell specific quirk.
> It has been fixed in -proposed.
>

Launchpad Janitor (janitor) wrote :
Download full text (27.1 KiB)

This bug was fixed in the package linux - 2.6.27-14.33

---------------
linux (2.6.27-14.33) intrepid-proposed; urgency=low

  [Stefan Bader]

  * Fix FTBS due to a mysteriously missing ABI directory.

linux (2.6.27-14.32) intrepid-proposed; urgency=low

  [Stefan Bader]

  * Rebuild of 2.6.27-14.30 with 2.6.27-11.31 security patches applied

linux (2.6.27-14.30) intrepid-proposed; urgency=low

  [ Alexey Starikovskiy ]

  * SAUCE: ACPI: EC: Limit workaround for ASUS notebooks even more
    - LP: #288385

  [ Huaxu Wan ]

  * SAUCE: report rfkill changes event if interface is down
    - LP: #193970

  [ Scott James Remnant ]

  * SAUCE: floppy: Provide a PnP device table in the module.
    - LP: #255651

  [ Steve Beattie ]

  * fix apparmor memory leak on deleted file ops
    - LP: #329489

  [ Stefan Bader ]

  * Revert "ACPI: Fix compiler warnings introduced by 32 to 64 bit acpi
    conversions"
    - LP: #337019
  * Revert "ACPI: Change acpi_evaluate_integer to support 64-bit on 32-bit
    kernels"
    - LP: #337019

  [ Upstream Kernel Changes ]

  * KVM: MMU: Add locking around kvm_mmu_slot_remove_write_access()
    - LP: #335097, #333409
  * ricoh_mmc: Handle newer models of Ricoh controllers
    - LP: #311932

linux (2.6.27-13.29) intrepid-proposed; urgency=low

  [ Colin Ian King ]

  * SAUCE: Bluetooth USB: fix kernel panic during suspend while streaming
    audio to bluetooth headset
    - LP: #331106, #322082

  [ Stefan Bader ]

  * Revert "SAUCE: Work around ACPI corruption upon suspend on some Dell
    machines." (replaced by stable update)
    - LP: #330200
  * Revert "SAUCE: Add back in lost commit for Apple BT Wireless Keyboard"
    (replaced by stable update)
    - LP: #330902

  [ Upstream Kernel Changes ]

  * Revert "vt: fix background color on line feed"
    - LP: #330200
  * ti_usb_3410_5052: support alternate firmware
    - LP: #231276
  * fuse: destroy bdi on umount
    - LP: #324921
  * fuse: fix missing fput on error
    - LP: #324921
  * fuse: fix NULL deref in fuse_file_alloc()
    - LP: #324921
  * inotify: clean up inotify_read and fix locking problems
    - LP: #324921
  * mac80211: decrement ref count to netdev after launching mesh discovery
    - LP: #324921
  * sysfs: fix problems with binary files
    - LP: #324921
  * x86, mm: fix pte_free()
    - LP: #324921
  * alpha: nautilus - fix compile failure with gcc-4.3
    - LP: #324921
  * it821x: Add ultra_mask quirk for Vortex86SX
    - LP: #324921
  * libata: pata_via: support VX855, future chips whose IDE controller use
    0x0571
    - LP: #324921
  * rtl8187: Add termination packet to prevent stall
    - LP: #324921
  * serial_8250: support for Sealevel Systems Model 7803 COMM+8
    - LP: #324921
  * SUNRPC: Fix a memory leak in rpcb_getport_async
    - LP: #324921
  * SUNRPC: Fix autobind on cloned rpc clients
    - LP: #324921
  * USB: fix char-device disconnect handling
    - LP: #324921
  * USB: storage: add unusual devs entry
    - LP: #324921
  * USB: usbmon: Implement compat_ioctl
    - LP: #324921
  * ALSA: hda - add another MacBook Pro 4, 1 subsystem ID
    - LP: #324921
  * ALSA: hda - Add quirk for HP DV6700 laptop
    - LP: #324921
  * ALSA: ...

Changed in linux (Ubuntu Intrepid):
status: Fix Committed → Fix Released
cenoura (maggico89) wrote :

I'm experiencing the same problem on a Samsung r60+ laptop, on both Jaunty and Karmic alpha2.
The problem is the same as described in this duplicate: <a href="https://bugs.launchpad.net/bugs/282963">bug 282963</a>. The keyboard becomes unresponsive as well as most of the applets in the gnome-panel. Only way to get back to normal is to ctrl-alt-backspace (which I have activated back).

1 comments hidden view all 119 comments
Saivann Carignan (oxmosys) wrote :

cenoura : This bug is fixed, therefore the problem you get is a different bug (even the symptoms might look very similar), can you copy and launch this line in a terminal to report a brand new detailed bug report for linux? :

ubuntu-bug -p linux

tags: added: iso-testing
Displaying first 40 and last 40 comments. View all 119 comments or add a comment.