keyboard stops working in intrepid

Bug #294791 reported by Cory on 2008-11-06
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

Lately I've had some odd things going on with my laptop... I installed Intrepid a couple of days ago, and I've noticed that if I leave the computer running for a while and come back to it, my keyboard does not work, I can't click on any menus, and the right-click doesn't open any menus. I can click on icons, and my power button works. I haven't noticed it happening with any regularity, and I haven't noticed any particular trigger. Could somebody please help me run the right tests and stuff so I can find out what is wrong? I am happy to provide more information, I just don't know how to go about finding the problem.

Thanks,

Cory

Note: I posted on ubuntu forums, and several other people mentioned similar problems.

pw- (name-here) wrote :

Having the same problem on a VGN-NR330e. The problem did not show itself until today, and I have left this laptop on for says at a time running 8.10 before.

guy (arieguy) wrote :

Having a similar problem. Keyboard stops working at some point. Using a laptop with a USB keyboard and both keyboards stop. Similar behavior with the mouse happened in parallel once but not all times that this problem happened.
Note - I had a problem with the X system and tried using recovery to correct the Xconf but at the end had to revert to an old xorg.conf file (that worked fine in 8.04).
I attach the lspci output.

guy (arieguy) wrote :

So turns out this is an xorg issue, at least for me.
First, pressing Alt-Ctrl-F1 worked.
Second, seems that some of the xorg use of the mouse and keyboard changed. Im no expert but if I get it right, your xorg.conf should not define mouse and keyboard any more. The nvidia-xconfigure isn't updated for this and so if you run it, you get into the kind of trouble we're getting. Im not 100% sure but I think the X-server recovery program (when booting into recovery mode) also generates a file that is at odds with the change.
I removed all reference to mouse and keyboard from xorg.conf (including in the layout) - system is working but I can't say it won't freeze.

Cory (cory-northwinddesign) wrote :

Ok, it just happened to me again, and Ctrl-Alt-F2 made everything work again. What does that mean? I assume something with Xorg, but what can I do to fix it so it doesn't happen anymore?

Amanda (daigle123) wrote :

Something similiar is happening to me, except I can't get into Ubuntu at all because my keyboard doesn't work to sign in. This started just after I upgraded to Intrepid. There were some issues updating so I had to boot through recovery mode to finish upgrading. Could this have been the issue?

guy (arieguy) wrote :

So it seems that my issue was resolved by fixing the xorg.conf file.
Amanda, Cory - If you want to upload your xorg.conf file (in /etc/X11 , it has no personal information) we can see if its the same issue that I had. You can also search the file for the words "mouse" and "keyboard" - if you find them in an un-commented line, it's probably the same issue.
Ubuntu guys, to summarize :
nvidia-xconfigure, "dpkg-reconfigure xserver-xorg" and (possibly the recover-X11 boot option) corrupts xorg.conf (w.r.t. the mouse / keyboard)

Thanks,
Guy

Cory (cory-northwinddesign) wrote :

I'd checked before, and I didn't see anything about the mouse or keyboard.. but I'll upload anyways.

Amanda (daigle123) wrote :

I think I fixed my problem. It seems to be working anyways, and I've restarted and left it running a few times to see if it would stop. I ended up editing xorg.conf to include the keyboard section on the end, it didn't have one before (I just got the standard words off wikipedia). I'll attach my working file.

Anthony Noto (angusthefuzz) wrote :

Thank you all for reporting this bug. I am marking the bug confirmed. Can all of you please post your latest /etc/X11/xorg.conf as well as /var/log/Xorg.0.log. It would also be helpful to have the output of the command "dmesg > dmesg.log" Thank you in advance.

guy (arieguy) wrote :

the tar has my xorg.conf , xorg.conf generated by nvidia settings , xorg.0.log and dmesg output.
Thank you and please feel free to ask if any more info is needed.

Nate (icarus4586) wrote :

I've been having the same problem since upgrading to Intrepid. Sometimes after the machine has been up for a while, the keyboard stops working. If I click on something in the menubar (Applications, Places, System...) it turns to the selected color, but the menu doesn't drop down. It may be the same issue. I'm attaching a tarball with all 3 of the requested files.

Cory (cory-northwinddesign) wrote :

Nate, that's exactly what happens with me (the menu problem).

I've attached all three requested files.

Ioannis (ioannisnousias) wrote :

I have a similar problem and I know how to trigger it.

The keyboard stops working, but it still accepts ctrl+alt+Fx, so I can switch to VT and restart metacity (or compiz, it happens in both). However, unlike Cory, I can still interact with menus and the GUI in general with the mouse.

What triggers the keyboard freeze in my case, is adjusting the brightness with the function key Fn+up/down arrows.

I've seen one mention that this is caused if you blacklist the 'video' module, but it's not blacklisted in my case.

my kernel and Xorg logs have nothing noteworthy.

Jim Spangler (jspangler) wrote :

Hi,

I have similar problems. I can't interact with menus, many things slow down, video isn't blacklisted. The problem also seems to be triggered by adjusting brightness. I have attached three requested files.

Essence (bryanmcconkey) wrote :

Everything has been said, but I too have been having this problem. Can't seem to see what causes it at all, for me both the keyboard and menus will stop working. Anyway, thought I'd attached the requested files and hope they help.

I've attached my xorg.conf, my dmesg.log and Xorg.0.log in the attached archive.

Essence (bryanmcconkey) wrote :

To be more descriptive when this happens i can still click, for example i can select the menus (Applications, Places, System) and it will highlight when I do so but the menu will not drop down. I can also use the mouse to select different windows, but no where will typing on the keyboard work (search bars, text documents etc). I've had this happen to me probably about 4 or 5 times since installing 8.10 a day ago.

Essence (bryanmcconkey) wrote :

After playing around with it for a while, the only way I seem to be able to reproduce this is by adjusting the brightness using the Fn+(Up/Down) keys. This happens both when I am plugged in and not. Also the note of switching using Ctrl+Alt+F1 and then back does seem to restore functionality on my machine.

Cory (cory-northwinddesign) wrote :

I can confirm that the bug can be reproduced by using Fn+(Up/Down) to adjust brightness.

Blake (blake-grover) wrote :

Same here with a Inspiron 9300 laptop. Switching out of X Windows Ctr + Alt + F1 and then back into it fixes it. But this needs to get fixed permanently.

gurrett86 (gurrett86) wrote :

Happens to me as well using an Inspiron 6000 laptop when I change the brightness.

catullus (vergil+launchpad) wrote :

I also have this bug on Inspiron 6000 laptop when I change the brightness!!!

Essence (bryanmcconkey) wrote :

I'd like to point you all to this https://bugs.launchpad.net/ubuntu/+source/linux/+bug/261721 as well, which looks to be similar.

Cory (cory-northwinddesign) wrote :

I posted this bug as a duplicate of the one Essence posted. Also, please note the problem was fixed for me (at least when switching brightness) by upgrading to the latest kernel update in the proposed repository (see duplicate bug).

Kashi Gorton (flash87) wrote :

Is this a duplicate of bug 285323? The symptoms sound very similar, though you would need to be on some sort of Dell laptop and the trigger would be using the brightness hotkeys... not sure if 285323 is a dupe of the one currently flagged, but 285323 seems more specific.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers