Mono WinForms apps don't show text on menus and button

Bug #462349 reported by Eberhard Beilharz
114
This bug affects 19 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Jacques-D. Piguet
Nominated for Lucid by Jacques-D. Piguet

Bug Description

Binary package hint: xserver-xorg-video-intel

With the latest version of xserver-xorg-video-intel (2:2.9.0-1ubuntu2~xup~3) any Mono WinForms doesn't draw the text on menus and buttons. The menus and buttons are there, but the text doesn't show. This happens with my installed mono and a mono version built from latest svn.

With the previous version of xserver-xorg-video-intel (2:2.7.1-0ubuntu1~xup~1) this worked.

I'm running 64-bit Jaunty; problem also happens in a 32-bit chroot.

Revision history for this message
In , Calberto-cortez (calberto-cortez) wrote :

Andrew: just for the sake of testing purposes, could you provide a screenshot? We got a similar issue on irc in the latest days, and it was due to the colors selected to draw the strings.

Revision history for this message
In , Ajorgensen (ajorgensen) wrote :

Created an attachment (id=324113)
screenshot of NClass

This doesn't seem to be the same bug. I switched to the Clearlooks theme before taking this screenshot and it has the same bug (I had been using the new Darkroom theme).

Another possible culprit would be cairo, etc. which we normally embed in gdiplus (with a specific version) but debian / ubuntu likes to link to the system version.

Revision history for this message
In , CiaranG (ciarang) wrote :

Just for info, I have the same problem. Was fine on Intrepid, (almost) no text rendered when upgraded to Karmic. Could well be a colour issue, since the text that *is* rendered is all black on a grey background, while all the missing text is (or isn't) on a white background.

Anything I can do to workaround or help diagnose further?

Revision history for this message
In , CiaranG (ciarang) wrote :

Just to clarify the above, these are all standard WinForms controls, with no explicit colour settings. So, for example, a read-only TextBox does render text. An editable TextBox does not. However, a Label doesn't render text either, even though it would be the same font and colour as the read-only TextBox.

Revision history for this message
In , CiaranG (ciarang) wrote :
Revision history for this message
Eberhard Beilharz (c-e-beilharz) wrote :

Binary package hint: xserver-xorg-video-intel

With the latest version of xserver-xorg-video-intel (2:2.9.0-1ubuntu2~xup~3) any Mono WinForms doesn't draw the text on menus and buttons. The menus and buttons are there, but the text doesn't show. This happens with my installed mono and a mono version built from latest svn.

With the previous version of xserver-xorg-video-intel (2:2.7.1-0ubuntu1~xup~1) this worked.

I'm running 64-bit Jaunty; problem also happens in a 32-bit chroot.

Revision history for this message
Bryce Harrington (bryce) wrote :

Hi c-e-beilharz,

Please attach the output of `lspci -vvnn` and `dmesg`, and attach your /var/log/Xorg.0.log (and maybe Xorg.0.log.old) file from after reproducing this issue. If you're using a custom /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
Revision history for this message
In , Michel Lafon-Puyo (michel-lafonpuyo) wrote :

I have 2 boxes with similar configuration (Archlinux Mono 2.4.2). The first one is in fact a virtual machine (Vmware) and there is no text rendering problem with it.

The second one is a netbook with i945 graphic chipset (xf86-video-intel 2.9.0 driver) and I have the same issue as Andrew (cf. screenshot) and Ciaran with all the Mono applications I tried.

According to https://bugs.launchpad.net/ubuntu/+source/mono/+bug/456279 it seems to be a problem with this particular version of the driver...

Could you confirm that you are using this driver too?

Revision history for this message
In , CiaranG (ciarang) wrote :

The machine I'm seeing this on has the i915 chipset. (using /lib/modules/2.6.31-14-generic/kernel/drivers/gpu/drm/i915/i915.ko)

I don't see any mention of the video driver on that launchpad bug - is that the wrong link, or am I looking in the wrong place?

Revision history for this message
In , Michel Lafon-Puyo (michel-lafonpuyo) wrote :

In my understanding, it is a 2-part driver: the first part is in the kernel (i915.ko) and the second part is a Xorg module named xf86-video-intel (or xserver-xorg-video-intel in the Ubuntu package list).

The links above mentions the Xorg module.

Please could you try to find the package version on your system to confirm it is a 2.9.0 version problem?
For example, you can try the following command line:
dpkg -l | grep xserver-xorg-video-intel

Thank you.

Revision history for this message
In , CiaranG (ciarang) wrote :

Yes, you're right, that machine has version 2:2.9.0-1ubuntu2 of xserver-xorg-video-intel.

I'm still not seeing any mention of this stuff at https://bugs.launchpad.net/ubuntu/+source/mono/+bug/456279 though, what I am doing wrong? Three comments, and the original report - no mention of video drivers or Xorg.

Revision history for this message
In , Michel Lafon-Puyo (michel-lafonpuyo) wrote :

Uh... I'm sorry, copy/paste error.

I was referring to the following bug report: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/462349

Revision history for this message
CiaranG (ciarang) wrote :

This would seem to be a duplicate #456279, or vice versa.

Revision history for this message
ErikShreve (eshreve) wrote :

This is also impacting me. I'm running the same version:
xserver-xorg-video-intel (2:2.9.0-1ubuntu2)

Related bugs:
https://bugs.launchpad.net/ubuntu/+source/mono/+bug/456279
https://bugzilla.novell.com/show_bug.cgi?id=549882
http://sourceforge.net/projects/keepass/forums/forum/329221/topic/3435511

I'll attach my lspci -vvnn, dmesg, and Xorg log.

Revision history for this message
ErikShreve (eshreve) wrote :
Revision history for this message
ErikShreve (eshreve) wrote :
Revision history for this message
ErikShreve (eshreve) wrote :
Revision history for this message
ErikShreve (eshreve) wrote :

I also just discovered that I'm not seeing text in Eclipse 3.5.1's "Install New Software" window when one selects a "Work With" site. The site shows fine, but the software available does not show. However, you can still select it and install it (just can't tell what you are installing until you go the next screen :) )

I've attached a screen shot. Note that the Details portion of the widow fills in to reflect whichever item is "highlited"

Don't know if this is the same bug or not, but the top level symptom is similar.

Revision history for this message
In , Michel Lafon-Puyo (michel-lafonpuyo) wrote :

I installed xf86-video-intel 2.9.1 (a.k.a xserver-xorg-video-intel) from sources and the text is back.

It seems definitively it is a driver problem and has nothing to do with mono.

Revision history for this message
Michel Lafon-Puyo (michel-lafonpuyo) wrote :

I resolved the problem on my Archlinux box by upgrading the xorg Intel video driver to version 2.9.1

More information here:

https://bugzilla.novell.com/show_bug.cgi?id=549882

Revision history for this message
ErikShreve (eshreve) wrote :

I was also able to resolve the issue for Mono applications on Ubuntu 9.10 by upgrading to 2.9.1. No change for Eclipse, but that could be another issue altogether.

Revision history for this message
ErikShreve (eshreve) wrote :

I've confirmed that the eclipse issue I'm seeing is not related to this bug.

Revision history for this message
In , weaver4 (weaver-nc) wrote :

I am having the same problem and I wanted to install xserver-xorg-video-intel 2:2.9.1.

But, I am having some difficulties. It appears that the instructions do not work that I found at:

http://intellinuxgraphics.org/install.html

"If these packages are available, building should be as simple as:
    $ ./autogen
    $ make
    $ sudo -c "make install"
"

In the first step there is no file "autogen" in the package.

Can someone help me figure out how to install this package?

The README found in the package is no help.

I am not an expert at Linux or Driver Install, so it is probably something obvious.

Revision history for this message
In , Dan-keeping (dan-keeping) wrote :

Hi All,

I am having the same trouble I downloaded the latest drivers ran
./configure
make
make install (as root)

all appeared to work ok but I do not know if and how to use the new driver as the program still appears not to render any text.

Any help would be appreciated

p.s. Trey I also downloaded the file you have with the autogen which I got from a link on the driver release announcement but this errored for me so downloaded it from the following link.

http://xorg.freedesktop.org/archive/individual/driver/

Revision history for this message
In , Heikki-salokanto (heikki-salokanto) wrote :

(In reply to comment #13)
> I am having the same trouble I downloaded the latest drivers ran
> ./configure
> make
> make install (as root)
>
> all appeared to work ok but I do not know if and how to use the new driver as
> the program still appears not to render any text.

"make install" places the new drivers in an incorrect directory.

Switch to a text console (ctrl-alt-f1) and execute:
# sudo service gdm stop
# sudo cp /usr/local/lib/xorg/modules/drivers/* /usr/lib/xorg/modules/drivers
# sudo service gdm start

Check /var/log/Xorg.0.log for the driver version currently in use. It should say something like:

  (II) Module intel: vendor="X.Org Foundation"
        compiled for 1.6.4, module version = 2.9.1
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 5.0

Switching to the new drivers solved the problem for me.

CiaranG (ciarang)
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
CiaranG (ciarang) wrote :

I also resolved this issue on three different machines by upgrading the xserver-xorg-video-intel driver (via the xorg-edgers PPA). For others affected, simplest solution (at your own risk!):

 add-apt-repository ppa:xorg-edgers/ppa
 apt-get update
 apt-get upgrade

Then log out and back in. Problem solved.

Probably a good idea to drop that repository from your /etc/apt/sources.list.d directory if and when a working xserver-xorg-video-intel is pushed to the main repos.

Revision history for this message
In , Dan-keeping (dan-keeping) wrote :

(In reply to comment #14)
> (In reply to comment #13)
> > I am having the same trouble I downloaded the latest drivers ran
> > ./configure
> > make
> > make install (as root)
> >
> > all appeared to work ok but I do not know if and how to use the new driver as
> > the program still appears not to render any text.
>
> "make install" places the new drivers in an incorrect directory.
>
> Switch to a text console (ctrl-alt-f1) and execute:
> # sudo service gdm stop
> # sudo cp /usr/local/lib/xorg/modules/drivers/* /usr/lib/xorg/modules/drivers
> # sudo service gdm start
>
> Check /var/log/Xorg.0.log for the driver version currently in use. It should
> say something like:
>
> (II) Module intel: vendor="X.Org Foundation"
> compiled for 1.6.4, module version = 2.9.1
> Module class: X.Org Video Driver
> ABI class: X.Org Video Driver, version 5.0
>
> Switching to the new drivers solved the problem for me.

Thanks so much for this info I have not compiled much and this was exactly the step that I was missing.

For everyone's info this driver update solved the problem for me so it would look like the Intel driver is definitely the source of the problem.

Thanks again

Revision history for this message
volkris (volkris) wrote :

The xorg-edgers solution worked for me to resolve bug #456279

Revision history for this message
fernandos (fsantini) wrote :

Hi there, this bug is bugging me big times. Here the output after reproducing the misbehaving condition (you don't have to open a keepass-database file).

Hope this helps!

Revision history for this message
fernandos (fsantini) wrote :
Revision history for this message
fernandos (fsantini) wrote :
Revision history for this message
fernandos (fsantini) wrote :
Revision history for this message
fernandos (fsantini) wrote :

Oh, I forgot. It's Ubuntu 9.10, the stable release. No beta, no alpha, just plain stable release!

Revision history for this message
Hubert FONGARNAND (hfongarnand) wrote :

I've the same problem!!!

Revision history for this message
Hubert FONGARNAND (hfongarnand) wrote :

Version 2.9.1 compiled and installed from source... and all is ok now!

Revision history for this message
In , Ivan-ivanz (ivan-ivanz) wrote :

*** Bug 561854 has been marked as a duplicate of this bug. ***

Revision history for this message
garyo (garyo) wrote :

Just FYI, I installed the xorg-edgers driver to fix this problem and it worked, but that driver crashes the X server pretty often (more than once a day) on my IBM Thinkpad laptop. So caveat emptor.

Revision history for this message
William Woolrich (wwoolrich) wrote :

You know what garyo. I've experienced the same thing. It crashes like once an hour. How do we go back to the previous version?

Revision history for this message
Hubert FONGARNAND (hfongarnand) wrote :

No, problems with 2.9.1 compiled from sources... no crashes

Revision history for this message
Aram Agajanian (agajania) wrote :

If someone would make a package available for 2.9.1 built on Karmic i386, it would be appreciated.

Revision history for this message
garyo (garyo) wrote :

I removed the launchpad ppa from /etc/apt/sources.list.d, and then did:
 sudo apt-get install xserver-xorg-video-intel=2:2.9.0-1ubuntu2

to reinstall the latest standard karmic driver. There's probably a better way to revert all of them (ati, nv, etc.) but intel's the only one my laptop needs :-).

Revision history for this message
kotkis (kotkis1) wrote :

Adding xorg-edgers PPA resolved this for me too but went me in constant crash :
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/494372?comments=all
I'm knockouted ;)
Hope to see resolution at least for one of these.

Revision history for this message
kotkis (kotkis1) wrote :

"Hubert FONGARNAND wrote on 2009-12-11: #39
No, problems with 2.9.1 compiled from sources... no crashes"

This helped me a lot - 2.9.1 doesent seems to carsh X.

Revision history for this message
Olivier Bilodeau (plaxx) wrote :

I just created a xserver-xorg-video-intel 2.9.1 package compiled against the current karmic xorg and pushed it into my PPA.

It's easy to install, no need to compile anything or upgrade other packages aside from the driver itself.

You can grab the .deb and install it from the PPA or add the PPA to your software sources.

To add the PPA to your software sources:
# sudo add-apt-repository ppa:plaxx/random-fixes
then use whatever mean you prefer to upgrade (apt-get upgrade or synaptics)

I've used the new driver for a few hours without a crash.

PPA URL: https://launchpad.net/~plaxx/+archive/random-fixes

Revision history for this message
Maarten Kossen (mpkossen) wrote :

Just wanted to let you know that I've just installed xserver-xorg-video-intel=2:2.9.0-1ubuntu2.1 and I see text in KeePass!

Revision history for this message
Manuel (mbestler) wrote :

Installing the new xorg-video-intel 2:2.9.0-1ubuntu2.1 from Karmic updates fixed it for me too. KeePass is working fine now.

Revision history for this message
Olivier Bilodeau (plaxx) wrote :

fix released in karmic-proposed and karmic-updates see bug #458545 for details

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.